access to ashx for not authenticated users

hadi tag asked on May 6, 2015 18:23


i use from handler in my webpart. this work very good as long as enter authorized user to site but if enter not authorized user to page, my ajax not work and get an error.

how to set accessibility to ~/CMSModules/MessageBoards/Controls/ExtendMessageBoards/MessageHandler.ashx for not authenticated users(without web.config)?

Recent Answers

Virgil Carroll answered on May 8, 2015 15:57

Did you check that in the physical directory of the IIS your 'IUSR' user (anonymous account) has at least read access to this directory? If not, I really would not add it but instead look at moving it into another newly created folder and setting the permissions on that (just not a good practice to start changing the permissions on the Kentico core folders and objects)

If that does not help, then I would look at the Kentico classes you are instantiating in your code, some may require authentication to access. If you are not sure, shoot an email to Kentico support and they should be able to help you. You may be able to impersonate a elevated user in your code to accomplish this.

Overall you are putting a lot of effort that could be more quickly solved with a web.config change...but even with a web.config change if Kentico classes are causing the issue you will have to take additional steps.

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.