"Please enter transformation name in identifier format."

Kurt Schindler asked on July 2, 2014 16:15

I'm trying to add a new Item Transformation to a Repeater web part, and I cannot get it to save. I always get the following error:

Transformation name: Please enter transformation name in identifier format.

What exactly classifies as valid identifier format? I have used all of these values unsuccessfully:

  • testtransformation
  • testTransformation
  • test.Transformation
  • .test.Transformation
  • _test.Transformation
  • _testTransformation
  • custom.testTransformation
  • a

Basically, nothing works, including transformation names I've used in previous Kentico 7 (eg. "_foo_bar"). I've tried doing this on IE and Chrome on a Mac - not a browser issue. I've also selected different class and document types that the transformation is associated with. Running Kentico 8 hotfix 13.


Recent Answers

Kurt Schindler answered on July 2, 2014 18:31

Follow up with more info:

I can reproduce this issue with a newly installed project with only the "Forms" and "Media Library" components installed. If I create a new installation with every component checked, creating new transformations with a valid name works.

So it would appear there is some component I have opted not to install that is required to create transformations...?! Any help on what it could be?

0 votesVote for this answer Mark as a Correct answer

Brenden Kehren answered on July 2, 2014 21:25

Why do you only install those components? The best way to do your install, is all modules. I don't install any of the templates except the Blank Site template. If you have all the components installed, all you need to do is add a new license key to unlock the other features.

0 votesVote for this answer Mark as a Correct answer

Stefan Lorenz answered on July 3, 2014 06:11

Just yesterday I got the same error, after importing objects from another site. The solution was to resign all macros, see link text

3 votesVote for this answer Mark as a Correct answer

Kurt Schindler answered on July 3, 2014 10:41

Resigning all macros seems to have fixed it! Thanks for that tip!

Brenden - I prefer not to install optional components I know I will never use. In my case, they add about 2500 extra files which slows down Visual Studio, compilation, etc. and adds about 25MB more on disk.

Given that the macro resigning was the solution, my previous post suggesting it had something to do with which components were installed was likely inaccurate. I did install several Kentico 8 instances while troubleshooting, and for some of them I ended up sharing the same database, which would result in a conflict with the CMSHashStringSalt value. As this would cause macro failures, and apparently that's why I couldn't save a transformation (even though it had no macros in it), perhaps that is why I was sometimes it worked for me and sometimes it didn't.

The more you know.

2 votesVote for this answer Mark as a Correct answer

Andrey Lurye answered on July 11, 2014 14:42

For anyone else having this problem, the current solution is to upgrade to hotfix 8.0.15

1 votesVote for this answer Mark as a Correct answer

Christopher Schoeder answered on February 5, 2016 15:20 (last edited on February 5, 2016 15:30)

Re-Assigning all Macros basically worked for me. If you're running Kentico 8.2

Go to Configuration -> System -> Macros -> Signatures

Open up your global web.config file in your project and search for the keyword CMSHashStringSalt Copy the value associated with that. Go back to the Kentico UI and paste it into your Old Salt text field. then click Update macro signatures

BTW Brenden Kehren Telling someone to install all components in CMS system that doesn't require you to shouldn't be a response or answer. If someone has to install all of the components for the entire site to work, then you shouldn't give them the option not to, OR there should do better testing

0 votesVote for this answer Mark as a Correct answer

   Please, sign in to be able to submit a new answer.