
 

 
 

 

 

 

 

 

 

 

 

 

 

 

FLEXIBLE CONTENT MANAGEMENT SYSTEM FOR ALL YOUR NEEDS 

Kentico CMS for .NET User Groups 

We have developed a website template for .NET User Groups, Windows User 

Groups and similar groups focused on Microsoft technologies. It uses Kentico CMS 

for ASP.NET, the flexible content management system for .NET developers. 

The website template allows you to: 

 Share information with your group members  

 Inform about user group meetings  

 Publish articles and presentations from the meetings  

 Communicate in discussion forums  

 Send e-mail newsletters  

 Write blogs 

 Share files and photos  

 Create member-only areas  

 Get feedback through polls, on-line forms and surveys  

 Share experience in a knowledge base 

 and others...  

The website template can be easily customized with your design and logo, you 

can change its structure and layout – all through a friendly browser-based 

interface. 

If you wish to add your own web parts, you can easily develop them as user 

controls in Visual Studio 2005/2008 (C# and VB.NET are both supported). 

In this guide, you will learn: 

 How to install and configure the website 

 How to edit content 

 How to customize the design 

You can find a full Kentico CMS documentation at 

http://www.kentico.com/DevNet/Documentation.aspx and you can get a free 

support for .NET User Groups at http://www.kentico.com/Support.aspx.  

www.kentico.com                              +1 888 225 2767 

http://www.kentico.com/DevNet/Documentation.aspx
http://www.kentico.com/Support.aspx
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Get a Free License and Hosting 

 

Kentico Software offers a free Kentico CMS Ultimate license with upgrades and support (worth $4,499) 

to all .NET User Groups. This free license can be used only for .NET User Group web site. It cannot be 

provided to any third party. The website must use the Powered by Kentico CMS logos in their original 

sizes on the top of the home page and in the footer of all pages as well as the text link. The logos and 

the text links must link back to URL: 

http://www.kentico.com/?utm_source=dngsite&utm_medium=link&utm_campaign=dngsite   

The text link should be as follows:  

This website is powered by Kentico CMS for ASP.NET. 

 

 

Applied Innovations offers a free Kentico CMS hosting (worth $24.95 per month) to all .NET User 

Groups. In return for the free hosting, you have to put the Applied Innovations logo on the home page 

linking back to http://www.appliedi.net if you host your user group site with Applied Innovations. 

 

 

Free Registration 

In order to get your free license and hosting, register for free at http://www.kentico.com/dng.aspx.  

 

 

http://www.kentico.com/?utm_source=dngsite&utm_medium=link&utm_campaign=dngsite
http://www.kentico.com/?utm_source=dngsite&utm_medium=link&utm_campaign=dngsite
http://www.appliedi.net/
http://www.appliedi.net/
http://www.appliedi.net/
http://www.kentico.com/dng.aspx
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1. Introduction 

The website template for .NET User Groups addresses the challenges every group faces: 

Challenge Kentico CMS 

Easy management of up-to-date content Kentico CMS provides easy-to-use WYSIWYG user 

interface that simplifies daily content 

management tasks. 

The content can be managed by multiple users 

with different permission level. 

Meeting management You can easily inform about meetings and allow 

members to register for the meeting. You can also 

send an e-mail to all registered users when the 

meeting date or location changes. 

Keeping the community informed You can publish e-mail newsletters for your 

community using the Newsletter module. 

Involving the community With flexible permission model available in Kentico 

CMS, you can easily delegate management of 

particular site sections to chosen group members. 

The members can also write their own blogs, 

upload files or discuss technical questions in 

forums. 

Getting feedback You can easily create polls, on-line forms and 

surveys without programming and get feedback 

from your members. 

High flexibility and extensibility You can easily modify the design, layout, site 

structure and content types (articles, news, etc.). 

It can also be extended with custom code and 

custom modules developed in Visual Studio. 

Detailed documentation is available at 

www.kentico.com.  

Getting an affordable web hosting You can get a FREE, high-quality ASP.NET hosting 

provided by Applied Innovations 

(www.appliedi.net) for your user group that will 

allow you to run Kentico CMS. 

http://www.kentico.com/
http://www.appliedi.net/
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Installation 

First, please register at http://www.kentico.com/dng.aspx. You will receive the license key and 

instructions for getting the free hosting account (if you choose to use the free hosting offer by Applied 

Innovations). 

Installation on Applied Innovations Hosting 

If you choose the free Applied Innovations hosting offer during the registration, Kentico and Applied 

Innovations will set up a ready-to-use website and you will receive its URL. The default user name is 

administrator with password dngsite1. 

Installation on Your Own Machine 

If you decide to install Kentico on your local machine for testing or on your own server, please download 

Kentico CMS trial version at http://www.kentico.com/Download.aspx (you will be able to insert your 

free full license key later which will turn the application into the full version). 

You will need Microsoft IIS (Internet Information Services) 6 or 7 and MSSQL 2000 or 2005 installed on 

your machine.  

Run the setup and install Kentico CMS into chosen folder.  

 

 

 

 

http://www.kentico.com/dng.aspx
http://www.kentico.com/Download.aspx
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Then, run Kentico CMS Web Installer and create a new site (you can find more details and 

troubleshooting in Kentico CMS Tutorial (portal engine) - 

http://www.kentico.com/downloads/kenticocms_tutorial.pdf). 

 

After Kentico CMS Web Installer creates the new project on your disk, you will see this dialog: 

 

 

Before you click the link, please download the file 

http://www.kentico.com/downloads/dng/DotNetGroupSite.zip and copy it to folder <website project 

folder>\CMSSiteUtils\Import – typically C:\inetpub\wwwroot\kenticocms\CMSSiteUtils\Import. Please 

do NOT unzip the file, the CMS will unzip it automatically. 

http://www.kentico.com/downloads/kenticocms_tutorial.pdf
http://www.kentico.com/downloads/dng/DotNetGroupSite.zip
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Now click the link to open the new website in your web browser. The Database Setup Wizard starts and 

you can connect to your MSSQL server and create the database. Enter the server name, user name and 

password and click Next. 

 

Choose the database name and click Next. 
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You may be asked for a license key at this point. If you do not have a license key for the current domain, 

please contact our support department at http://www.kentico.com/Support.aspx. Now choose to 

import an existing Kentico CMS website and click Next: 

 

The Import Site Wizard starts. Choose to import the DotNetGroupSite.zip file (if this file is not listed, 

please make sure you copied the file to ~\CMSSiteUtils\Import and click Refresh). Click Next. 

 

 

http://www.kentico.com/Support.aspx
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Leave the default values in the next step and click Next. 

 

In Step 3, leave default values here as well and click Next. 
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Once the website is imported, click the Sign Out button in the upper right corner and you will see your 

new website: 

 

If you receive an error saying the domain is not configured, you need to follow the on-screen 

instructions. 

Default User Name and Password 

If you're using Kentico CMS locally, the default account is: 

- user name: administrator 

- password: the default password is blank 

You can login to the website using these URLs: 

- <website>/CMSDesk – the interface for editors 

- <website>/CMSSiteManager – the interface for administrators and website developers 

Important: Please be sure to change the password as soon as you install the website! You can do that 

by signing in to CMS Site Manager and going to Administration -> Users. 
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SMTP Server and E-mail Addresses 

If you use Kentico CMS on your own server and your SMTP server address is different from "localhost", 

please sign in to Kentico CMS Site Manager (<website URL>/cmssitemanager) and click the Settings tab. 

Now choose the DotNetGroup website in the drop-down list, click the E-mails section and configure the 

values as you need. 

 

Documentation and Support 

This document provides only basic information for the .NET User Group website template. If you wish to 

learn more about Kentico CMS, you can download the following documents at 

http://www.kentico.com/devnet/documentation.aspx: 

 Kentico CMS Quick Start Guide – a short guide describing the major features 

 Kentico CMS Tutorial (portal engine) – a step-by-step guide explaining how to use Kentico CMS 

and how to build a website from scratch 

 Kentico CMS Developer's Guide – a complete documentation of all features and modules 

 Kentico CMS Web Parts and Controls, API Reference, Database Reference – reference books 

If you need any help with website template for .NET User Groups, please feel free to contact our support 

at http://www.kentico.com/Support.aspx or visit forums at 

http://www.kentico.com/devnet/forums.aspx and mention in your e-mail, that you're using the .NET 

User Group website template.  

http://www.kentico.com/devnet/documentation.aspx
http://www.kentico.com/Support.aspx
http://www.kentico.com/devnet/forums.aspx
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Website Overview 

The figure below shows the default website: 

 

The website structure and design are fully customizable (you can see hundreds of websites that use 

Kentico CMS at http://www.kentico.com/Showcase.aspx). Customization is briefly described at the end 

of this guide. 

Signing in to the administration interface 

If you wish to sign in, navigate to URL http://<your website>/cmsdesk. The default credentials for 

Applied Innovations hosted solutions are administrator with password dngsite1. The default credentials 

for local installation are administrator with blank password. 

You can also go to http://<your website>/cmssitemanager – this is the administration interface for site 

admins and developers. 

 

http://www.kentico.com/Showcase.aspx
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Editing Content 

Sign in to CMS Desk (http://<website>/CMSDesk) with your user name and password and you can start 

editing your website. 

 

 

 

 

 

 

 

Create/delete/ copy/ 

move/sort pages 

Edit/Preview/Live site view Change font, create link, 

insert image, etc. 

Browse web site 

structure 

This is where you edit the text. The box 

is called "editable region". 

This is the content of the 

currently selected page. 
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Browsing Website Structure 

You can browse the website structure using the content tree on the left. The content is organized in the 

same way as your website which makes it easy to find pages you want to edit. As you can see on the 

figure below, the Community section in the content tree contains sub-pages Forums, Knowledge base, 

Polls and some others. The website on the right contains section Community in the main menu and links 

to Forums, Knowledge base and Polls in the sub-menu. 

 

WYSIWYG Editor 

You can easily edit the content using WYSIWYG editor. WYSIWYG stands for What You See Is What You 

Get, which means you can see what your page will look like as you edit the text: 

 

The live website changes as soon as you save the page. If you create a new page, it's displayed in the 

menu automatically. 

Editor Features 

 Bold, Underline, Strikethrough, 
Italics 

 Choose font face, size, color and 
background 

 Choose from predefined font styles 

 Align paragraph 

 Bulleted and numbered lists 

 Create a link to another page or 
another web site 

 Upload and insert image 

 Create tables 

 Paste from Microsoft Word 

 Edit HTML source if necessary 

 Integrated spell-checker 
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Changing a Page Name and URL 

You can change the page name on the Form tab. If you wish to change the page URL, choose the 

Properties tab and change the Document alias field or change the whole Document URL path. 

 

Content Scheduling 

For every page, you can choose the time when it goes live and when it expires. It means you can 

schedule e. g. news to be displayed on your website on Monday morning, at 8:00 a.m. All you need to 

do is to set the Publish from/Publish to values on the Form tab. 

Inserting Images 

Images can be inserted directly from your local disk into the text: Click the Insert image button in the 

WYSIWYG editor toolbar and click Browse server. Now choose the Files folder or some of its subfolders 

and click Upload file in the upper-right corner. Upload the file and then click Paste image. Click OK in 

the Image Properties dialog and click Save to save changes.                          

Important: If you cannot upload some type of file, you may need to allow it in CMS Site Manager -> 

Settings -> <choose DotNetGroup site> -> Files -> Upload extensions. 
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Changing the Logo 

You can easily put your own logo in the website header. Sign in to Kentico CMS Desk (<your 

website>/CMSDesk) and click the root document in the Content section. 

 

Click the Select... button on the logo. Choose the Files/Logos folder on the Content tab in the pop-up 

dialog (1.). Browse to your logo image on your local disk, select it and click Open (2.). This action 

uploaded the file into your content tree. With the file selected, click Select to use the image as your new 

header logo. 

 

Click the Save button on the Page tab to save the changes: 
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Home Page 

You can edit the home page by selecting the Home document in the content tree. On the right, the 

home page with editable region opens. You can edit the text in the region and save the changes using 

the Save button. 

 

If you wish to organize the home page content differently, click the Design tab and you can drag and 

drop web parts into different areas or add new web parts: 

 

If you do not like the 3-column layout, you can change the HTML layout of the page by choosing Edit 

layout in the page template context menu: 

 

Please note: you can learn more about website customization at the end of this guide. 
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Managing Meetings and Booking System 

The Meetings page contains previous and upcoming meetings. Meetings are separate documents placed 

under the Meetings page: 

 

When the visitor chooses some meeting from the calendar or from the list, they can see the meeting 

name, date, location and attachments and register for the meeting.  

 

When they click the Add event to Outlook link, they can also add the event to their Outlook calendar. 
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Creating a new meeting 

Click the Meetings document in the content tree and click New. Choose to create a new User group 

meeting. Fill in the following fields: 

- Event name – the name of the meeting 

- Event summary – the summary of the meeting content 

- Event details – details on meeting content 

- Event location – where you meet 

- Event date – date and time when the meeting starts 

- Capacity – meeting room capacity 

- Allow registration over capacity – if you know there may be more attendees than chairs, you can 

choose if you allow extra registrations 

- Open from – date and time when the registration starts 

- Open to – date and time when the registration closes 

Then click Save or press CTRL + S to save the new meeting.  

Tip: if you're preparing the meeting content and you do not want to publish the meeting yet, simply set 

the Publish from value to some future date. 

Attachments 

If you wish to add an attachment to the meeting information, click the newly created meeting in the 

content tree and click New. Choose to create a new File and upload the attachment. All files placed 

under the meeting document are automatically displayed as a meeting attachment. 

 

Managing Meeting Attendees – the Booking System 

When the group members register for the meeting, they receive an e-mail invitation. You can modify the 

e-mail template in Site Manager -> Development -> E-mail templates -> Booking event invitation. The 

subject and e-mail address used for sending the invitation can be configured in Site Manager -> Settings 

-> Booking system. 
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You can manage the registered attendees in CMS Desk -> Tools -> Events.  

 

Click the View icon next to the given meeting and you will see the list of attendees: 

 

You can resend a single invitation using the e-mail icon or you can send a mass e-mail to all registered 

attendees using the Send e-mail dialog in case the meeting date changes: 

 

How to remove the booking system from the website 

If you do not wish to use the booking system and you prefer to only publish the 

meeting information, you can easily remove the registration form. Go to CMS 

Desk -> Content, choose the Meetings document in the content tree, click the 

Design tab, find the EventRegistration web part and remove it using the 

Remove command in the context menu. 
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Member Registration and User Management 

Members can register on the Join us page. When they register, they can access the Members section of 

the website.  

 

You may want to review member registrations before you give them access to the Members section. In 

such case, you need to modify the registration form configuration. Sign in to CMS Desk -> Content, 

choose the Join us page in the main menu and click Design.  
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Click the Configure icon of the registrationform web part and locate the Extended settings section: 

 

Configure the following values: 

- Enable user after registration – uncheck the box; the administrator will need to review user 
registration and enable the user 

- Notify administrator about new registrations – check the box so that the administrator receives 
an e-mail notification 

- From e-mail address – e-mail address the notification will be sent from 
- To e-mail address – e-mail address of the administrator 
- Display message after registration – put some explanation here so that the user is informed 

that their registration needs to be reviewed. 
 

Click OK to save the changes. 
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Now, whenever a new member registers, the administrator receives an e-mail and they need to sign in 

to Kentico CMS Site Manager -> Administration -> Users, edit user properties and enable the account: 
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Editor Permissions 

You can delegate the administration of the website or its sections to particular group members. All you 

need to do is to create a new user in Site Manager -> Administration -> Users and check both Enabled 

and Is editor boxes. The Is editor attribute enables site members to access the CMS Desk interface.  

 

Then, you can choose from these options (or you can mix them): 

- Add user to the CMS Desk Administrators role on the Roles tab – this gives the user editing 
access to all content in CMS Desk. 
or 

- Add user to the CMS Editors role which gives them full editing permissions and you can keep the 
control over the website by configuring an approval process (please read chapter Workflow and 
versioning in Kentico CMS Developer's Guide for more details). 
or 

- Grant user with permissions for particular site section (see details in the following paragraphs). 
 

Permissions for Particular Document Type and Site Section 

 
It's recommended that you create roles and assign document permissions to roles rather than particular 
users. If you wish to allow the user to edit only the Articles section, follow these steps: 

1. Go to Site Manager -> Administration -> Roles and create a new role called DNG Article Editors. 
2. Add the user to the newly created role. 
3. Go to Site Manager -> Administration -> Permissions and choose the Document type: Article 

matrix in the drop-down list.  Allow DNG Article Editors perform all actions with articles. It will 
ensure that they can create only articles and no other document types. 
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4. Go back to the Content tab, click the root of the website in the content tree and choose 
Properties -> Security. Add the DNG Article Editors role to the list and grant them with Read 
and Browse tree permissions: 
 

 
 

5. Now choose the Articles document in the content tree and grant the role DNG Article Editors 
also with Modify, Create and Delete permissions. 

6. The user can now sign in and create, modify and delete articles. 

Permissions for Particular Modules 

You can configure the permissions for particular modules in CMS Desk -> Administration -> Permissions. 

You need to organize your users into roles first since the module permissions can be assigned only to 

roles. You can find more details on permissions for particular modules in Kentico CMS Developer's 

Guide. 
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Articles 

The Articles section allows you to publish articles and organize them in categories. 

 

If you want to add a new article, sign in to CMS Desk -> Content, click Articles or some subpage 

(category) in the content tree and click New. Choose to create a new Article document, enter the 

content and click Save. 

Adding a new category 

The categories in the Articles section are actually pages. All you need to do is to create a new Page 

(menu item) document, enter the page name and choose Inherit from parent page. It ensures that the 

category uses the same page template as the Articles section. You can create nested categories as you 

need. 
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Library 

You can easily create a library of downloadable documents, such as e-books, tutorials, sample code or 

meeting presentations. The documents are of type File and the categories are of type Folder: 

 

Jobs and Community Contributed Content 

Jobs can be created either by site editors through Kentico CMS Desk or they can be created directly on 

the live site by site members that do not have access to CMS Desk. The second option is an example of 

how you can configure Kentico CMS for user contributed content. When the site member signs in and 

goes to Members -> My contributions, they can create a new document of a configured type, in the 

configured section of the website (e.g. Job opening in the Community/Jobs section): 

 

If you wish to enable user contributions or Wiki on your website, please read Kentico CMS Developer's 

Guide -> Modules -> User Contributions (Wiki). 
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Newsletter 

Your user group members can easily sign up for the e-mail newsletter on the home page and you can 

send them a newsletter with information on upcoming meetings, group activities, etc. 

Sign up for the newsletter on the home page using your e-mail address. Then sign in to CMS Desk and go 

to Tools -> Newsletter. You can manage multiple newsletters (i.e. multiple lists of subscribers) with 

different focus. The default website contains the ready-to-use User Group Newsletter: 

 

Configuring the newsletter 

Before you send your first newsletter issue, please check the configuration of the newsletter. Edit the 

User Group Newsletter, switch to the Configuration tab and update the Sender name and Sender e-

mail values. 

Creating a new issue 

When you want to send a new e-mail to your subscribers (i.e. a new newsletter issue), edit the User 

Group Newsletter and click the Create new issue button. 

 

The newsletter issue wizard starts.  
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Enter the Subject and then enter the text into the predefined e-mail template (the templates can be 

managed in Templates section of the Newsletter module). You can insert fields or macros that are 

resolved when the e-mail is sent – e.g. "Dear {%FirstName%}" will be displayed as "Dear Mark". Macros 

and fields can be inserted using the drop-down lists at the bottom, highlighted in the screenshot below. 

You can also add attachments to the e-mail. 
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Click Next and preview the content for all subscribers in Step 2: 

 

Click Next. Now you can choose if you wish to send the newsletter now, schedule it for later or send the 

newsletter later manually. Choose Send now and click Next. 

 

Now the e-mails are being sent. This may take a while. You can see the number of sent e-mails in the list 

of newsletter issues or you can check if there are any failed or waiting e-mails in the Newsletter queue. 

You can learn more about the Newsletter module in Kentico CMS Developer's Guide -> Modules -> 

Newsletter. 
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Forums 

The forums allow you to communicate on technical topics or on internal user group issues. Forums are 

organized into Forum groups. Forum groups contain forums and forums contain threads. Users can 

subscribe to receive e-mail notifications when a new post is added. 

 

Managing Forum Groups and Forums 

Go to CMS Desk -> Tools -> Forums, here you can manage the forum groups: 

 

When you edit the forum group, you can manage particular forums: 
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Posts 

Here you can edit, delete, reply and moderate posts. 

General 

Here you can configure the Forum settings.  

Important: Please configure the Forum base URL according to your website URL – e.g.  

http://mydomain.com/community/forums.aspx - this must be the complete URL of the page that 

contains the forums. 

Subscriptions 

Here you can manage all subscriptions of users who want to be notified when a new post is added. 

Moderators 

You can choose to moderate the forum and specify the users who are authorized to moderate the given 

forum. 

Security 

Here you can choose who can post to the forums – all users (including anonymous users), authenticated 

users or only authorized users. 

Adding a new Forum Group 

When you're adding a new forum group in the Forums module, you also need to update the website so 

that the forum group is displayed. Create the new forum group and go to CMS Desk -> Content, select 

the /Community/Forums page in the content tree, switch to the Design mode and add a new 

Forums/Forum group web part to the page and set its Group name value to the name of the newly 

created forum group. 

 

Please note: You can configure the e-mail address of forum notifications in Site Manager -> Settings -> 

Forums. The forum may use WYSIWYG editor for posts, signatures and avatars depending on particular 

configuration of forums and its web parts. The nickname can be edited by user in the Members -> My 

profile section. You can learn more about forums in Developer's Guide -> Modules -> Forums. 

http://mydomain.com/community/forums.aspx
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Blogs 

You can create a blog on your website for chosen members. The blog posts can be edited in the CMS 

Desk as any other document type. 

 

Blog Organization and Authoring a New Post  

 

The blogs section contains a list of all blogs. Each blog contains 

months and months contain posts. When you want to add a new 

post, you need to click the blog in the content tree and choose to 

create a new Blog post. The system automatically organizes the 

posts into months. Every blog has its main author (although there 

may be multiple people contributing to a single blog) that is 

specified as the document owner of the Blog document. You can change the document owner in the 

Properties -> General dialog.  

The blog owner can also create blog posts in the CMS Desk -> My Desk -> My Blogs section where they 

can also moderate blog comments (if moderation is required). 

Comments Configuration 

The comments can be configured on a blog level. Click the blog document in the content tree and click 

Form. You can find comment settings at the bottom of the editing form. 

Please note: You can configure the e-mail address of blog notifications in Site Manager -> Settings -> 

Blogs. 

You can learn more about blogs in Developer's Guide -> Modules -> Blogs. 
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Photo Galleries 

Photo galleries are also created within standard content tree.  

 

The galleries are grouped under the Photo Galleries page that uses the page template List of galleries 

with left menu. If you wish to create a new gallery under this section (or anywhere else in the site 

structure), you need to create a new Page document using the page template Lightbox gallery with left 

menu. The pictures are placed under the gallery page. You can upload them either manually one-by-one 

by creating a new document of type File or you can use the bulk import described below. 

The galleries may have a thumbnail that is used in the list of galleries and can be edited in the Teaser 

image field when you choose the gallery page and click the Form tab. 

File Import 

Go to CMS Desk -> Tools -> File Import. This module allows you to import files from disk to the content 

tree as new File documents. You need to copy your files on the server disk (e.g. through FTP) to the 

folder mentioned in the File import dialog (generally ~\CMSImportFiles\). Then you choose where you 

wish to import the files (e.g. under the new gallery page) and click Start import. 
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Polls 

The Polls module allows you to create and publish polls on your website and get feedback from your 

group members.  

 

Go to CMS Desk -> Tools -> Polls. Here you can create a new poll and specify available answers. You can 

also choose who can vote – anybody, only authenticated users or only chosen roles. 

 

Once you create your new poll, you can publish it by adding the Polls/Poll web part to the page or in the 

editing mode, by clicking the Insert Poll button in the WYSIWYG editor toolbar: 
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Forms and Surveys 

The BizForms module allows you to create forms and surveys without programming – you can simply 

design the database columns, fields and their types, form layout and e-mail notifications through the 

friendly user interface and publish them on the website. 

 

Creating a new form 

Go to CMS Desk -> Tools -> BizForms. Click New form. Enter the display name, code name and table 

name – this is the name of the database table where the records will be stored. The system will create 

the table automatically. Then, switch to the Fields tab and create your own attributes (fields) – the 

system will automatically create a column in the database table. You can choose from a variety of field 

types and  many configuration options – if you need help, please see Kentico CMS Developer's Guide -> 

Modules -> BizForms.  

 

Again, you can publish the form on the website using a BizForms/BizForms web part or using the Insert 

BizForm button in the editor toolbar. 



Kentico CMS for .NET User Groups 

www.kentico.com   P a g e  | 37 

News 

News are just another document type in Kentico CMS database. You can create the news items in the 

/News section in CMS Desk -> Content. The Release date field is only for informative purposes, if you 

wish to publish the news later, please use the Publish from field. 

 

Member-only Areas 

By default, there is one member-only area on the .NET User Group website – the Members section. The 

visitors need to log on before they can see its content. The member area may contain member-only 

information as well as user-related content – user profile, user contributions, "Change password" dialog, 

etc. If you wish to create another member-only area, you need to select the appropriate page in CMS 

Desk -> Content, choose the Properties -> Security dialog and change the value Requires authentication 

to Yes. Also, you need to grant the role DNG Members with Read permission for this section since all 

content in secured areas is displayed only to users with Read permission. 
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Web Analytics 

If you wish to track the visits on your website and see which pages are most favorite, you can use the 

built-in Web Analytics module. However, you need to configure the module first. Go to CMS Site 

Manager -> Settings -> Web analytics, check the box Enable Web Analytics and click Save. 

Close the browser and visit the website or try to visit the website from another computer. When you go 

to CMS Desk -> Tools -> Web Analytics after a few minutes (the results are not displayed immediately), 

you will see the visit in the Visits and Page views statistics: 

 

Customizing Website Design and Code 

Important: This section contains only basic information on customization and development of Kentico 

CMS. If you wish to modify the site design or structure, it's highly recommended that you go through 

Kentico CMS Tutorial (portal engine) that is available at 

http://www.kentico.com/DevNet/Documentation.aspx.   

Design and CSS styles 

The web design is fully customizable. Most of the design can be changed in the CSS stylesheet. Go to 

CMS Site Manager -> Development -> CSS Stylesheets and edit the DNG Stylesheet. Here you can edit 

the CSS styles. 

If you need to use some images for background or design elements, it's recommended that you save 

them on the server disk (over FTP), into folder <website>\App_Themes\dotnetgroup\images. Here you 

can also replace the standard design images used in the .NET User Group website. 

 

http://www.kentico.com/DevNet/Documentation.aspx
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Master page 

Kentico CMS uses the concept of master page (similar to ASP.NET master pages) that contains site 

header and footer. Go to CMS Desk -> Content and click the root document. This document specifies the 

master page. Click the Design tab and you can configure the web parts contained in the header, such as 

main menu or search box: 

 

Please note that the master page must always contain a page placeholder web part that loads subpages 

into the master page. 

If you wish to change the layout of the master page, click Edit layout in the page template context 

menu: 

 

Now you can edit the HTML code of the page. The HTML contains special controls called web part zones 

(e.g. <cc1:CMSWebPartZone ID="zoneMenu" runat="server" />). These controls specify the places 

where you can put web parts in the Design mode. As you can see, you have full control over HTML 

layout code. 
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Changing Website Title 

You can change website title in CMS Site Manager -> Settings -> Website. Choose DotNetGroup site in 

the drop-down list and now you can change the Page title prefix and Page title format values. By 

default, the page title for particular pages is taken from the document Properties -> Metadata dialog or 

the document name is used if no page title is specified. 

Creating Your Own Pages 

You can create your own page from scratch instead of using an existing page template. Go to CMS Desk 

-> Content, click New and choose to create a new page. Enter the some page name and choose to 

create a blank page. Select the page layout Two columns – 20/80 and click Save.  

 

You have just created a new page without any content. Switch to the Design mode. Add the 

Navigation/Tree menu web part to the zoneLeft zone and set the Path value to /% (you could use 

/{0}/% to display the sub-pages). Add the News/ScrollingNews web part under it and add the 

Text/Editable text web part to the right zone: 
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When you switch to the Page tab now, you will see your new page in the editing mode: 

 

You can enter some text into the editable region and save changes. 

Page Templates 

The page templates allow you to re-use the same page design on multiple pages. If you wish to convert 

your new page into a re-usable page template, go to Properties -> Template and click Save as new 

template. Enter the display name, code name, category and click OK. You have just created a new page 

template. Now click the Save button on the Template dialog so that the page is associated with your 

new template. 

 

When you try to create a new page now, you will be offered with this new page template and you can 

create another page with the same design, but different text content. 
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Important note: Moving Pages 

Please note: if you move some page to a different section of the website, you may need to configure the 

Path property of the web parts used on this page or on other pages since some web parts take content 

from specific site sections. The path value in format /News/% means that all documents under the 

/News section should be displayed. 

Adding custom code, development of custom web parts 

So far, you were using the built-in functionality of Kentico CMS. You can however easily modify the CMS 

behavior and add custom functionality using C# or VB.NET. There are several ways how to do that: 

 Adding your own user control (ASCX) to the page - see Developer's Guide -> Development -> 

Development with Portal Engine -> Adding custom code to the portal page template. 

 Developing custom web parts – see Developer's Guide -> Development -> Web parts -> 

Developing web parts. 

 Developing custom modules – see Developer's Guide -> Modules -> Developing custom 

modules. 

 Using Kentico CMS API and event handlers – see Developer's Guide -> API programming and 

Kentico CMS internals. 

 Creating custom document types and writing your own transformations – Developer's Guide -> 

Development -> Document types and transformations. 

Kentico CMS is delivered with source code of the administration interface and all web parts. You can 

learn how to open the project in Developer's Guide -> Installation and deployment -> Visual Studio 

Integration. 

 

Support, Documentation and Feedback 

If you haven't found some information in this brief document, don't give up. You can still: 

- see the full documentation at http://www.kentico.com/DevNet/Documentation.aspx.  

- use Kentico CMS forums at http://www.kentico.com/DevNet/Forums.aspx.  

- contact Kentico support at http://www.kentico.com/Support.aspx 

Please note: you get a free, unlimited support for your .NET User Group website, so please feel free to 

contact us if you need any help. 

If you'd like to suggest a new feature or report a bug, please contact our support at 

http://www.kentico.com/Support.aspx.  

http://www.kentico.com/DevNet/Documentation.aspx
http://www.kentico.com/DevNet/Forums.aspx
http://www.kentico.com/Support.aspx
http://www.kentico.com/Support.aspx
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Appendix A - Kentico CMS Features  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

What is a Web Content Management System? 

A Web Content Management System (CMS) is a software that allows you to manage content of your web site. 

Unlike static web sites, CMS-driven web sites (also called "dynamic web sites") allow you to edit text and 

images using a graphical user interface, without technical knowledge. Once your web site design is prepared 

by developer, you can manage it by yourself. An important feature of a CMS is that it stores content in a 

structured format separated from design, so you can reuse it when you decide to change your site look. 

Content Management 

 Browser-based WYSIWYG editor similar to Word 

 The web site changes dynamically as you save the 
changes 

 Customizable workflow, versioning and unlimited 
rollback 

 Schedule content for publishing in future 

 Content/design separation 

 Customizable document fields and metadata 

 Multiple languages, UNICODE and RTL support 

 Multiple sites sharing content and settings 

 File management 

Security and Membership 

 Forms, Windows (Active Directory) and mixed mode 
authentication 

 Membership management 

 Customizable roles 

 Document-level permissions 

 Secured areas with personalized content for members 

 SSL support 

 Windows LiveID support 

 Registration approval and double opt-in 

 Mass e –mails to site members 

 UI personalization 

Web Site 

 Fully customizable design 

 Flexible, dynamically generated navigation 

 Full-text search 

 Web standards: XHTML, table or CSS layout, WAI 

 Search Engine Optimization  

 WEB 2.0 features for building on-line communities 

Development 

 Portal engine based on web parts 

 Browser-based development 

 Easy integration of custom code written in C# or 
VB.NET, modules and web parts developed with 
Visual Studio 2005/2008 

 Custom ASPX pages 

 Page templates and master pages 

 Open and well-documented API 

 Detailed documentation and tutorials 

 

 

Built-in Modules 

 Blogs 

 Booking system 

 Content rating 

 Content staging 

 E-commerce (shopping cart) 

 Event calendar 

 Forums 

 Friends 

 GeoMapping (Google Maps) 

 Groups 

 Image gallery 

 Media library 

 Message boards 

 Messaging 

 Newsletter 

 On-line forms 

 Polls 

 Reporting 

 Taxonomy 

 Wiki (user contributed content) 

 Web farm support 

 Web analytics Robust Platform 

 Runs on Microsoft ASP.NET 2.0, 3.0 and 3.5 

 Uses Microsoft SQL Server 2000/2005/2008 database 
(including Express Editions) 

 You do not need to have your own server, you can 
install Kentico CMS on shared hosting 

 Tested by 2000+ web sites in 74+ countries 


