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1 Introduction

1.1 Aboutthis guide

Kentico CMS Intranet Administrator's Guide is a guide intended for administrators of Kentico Intranet
Solution, i.e. the Intranet Portal sample website based on Kentico CMS. It provides information on
how the solution can be managed from within the system's administration interface.

Pre-requisites

Before you start using this guide, it is recommended that you get familiar with the contents of Kentico

CMS Intranet User's Guide. Kentico CMS Intranet User's Guide is a guide intended for end users of the
solution and provides information on how it can be used by an ordinary company employee accessing

only the front-end website, not the administration interface. By going through the guide, you will get an

ovenview of the structure of the portal, its main features and functionality.

The next thing that is expected from you before referring to this guide is to go through Kentico CMS
Tutorial. Kentico CMS Tutorial is intended for first-time users of Kentico CMS, describing the system's
installation and the basics of its administration interface. The lewvel of knowledge covered by the tutorial is
necessary to understand most of the topics in this guide.

Where to go next

If you meet all the pre-requisites listed above, but you are new to Kentico Intranet Solution, we
recommend proceeding to the Getting started chapter. The Installation topic in the chapter will guide
you step-by-step through the installation of the Intranet Portal sample website. Once the website is
installed and running, you may proceed to the Accessing the administration interface topic, where the
solution is described from the administrator's point of view. Finally, you may refer to the Configuration for
WebDAV editing topic, which describes additional configuration of the system necessary for WebDAV
editing to be functional.

Further information sources

This guide is not the only source of information related to the solution or Kentico CMS in general.
Complete documentation of Kentico CMS can be found at http://dewnet.kentico.com/
documentation.aspx. At this address, you can find various documentation guides, each of them
describing the system from a different perspective or aimed at a different target audience.

The most important of the guides listed on the above mentioned page is Kentico CMS Developer's
Guide. It is the most comprehensive guide for developers and administrators of the system, providing a
full reference on its installation, configuration and functionality of all its features and built-in modules.
You will find many links referring to the Developer's Guide throughout this guide, as most of the
information necessary for administration of the solution is already contained in it.
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2 Getting started

2.1 Installation

To get started, you need to have Kentico CMS and the Intranet Portal sample website installed. This
topic provides information on how this can be achieved. The topic is divided into two parts, depending on
if you already have Kentico CMS installed or not.

New Kentico CMS installation

Installation of Kentico CMS is fully described in Developer's Guide -> Installation and deployment. The
following points sum up which steps need to be taken in order to perform the installation and provide
links to the relevant topics in that chapter of the Deweloper's Guide:

1. Launch KenticoCMS_<version>.exe and follow the instruction in Installation procedure -> Setup
(KenticoCMS.exe).

2. Once the setup finishes, launch Kentico CMS Web Installer and follow the instructions in Installation
procedure -> Web installer.

3. When the Web Installer is finished, access the URL of the new website. The first step of the
Database Setup will be displayed. Follow the instructions in Installation procedure -> Database setup,
until you reach the Starter Site step (the number of the step may vary). In this step, select the Choose
starter site option and choose the Intranet Portal sample site. Click Next to continue.

Step 5 - Starter Site

2-3-E0-o

SOL Setings Database Starter Site Finish

@ Choose starter site

i Intranet Porta

= 5 ﬁ This is a ready-to-use website template for a sample intranet
LS F portal site. The site showcases many features useful for a

i company intranet, such as sub-sections dedicated to

e departments or workgroups and document or project

management. You may use it as a base for your own company

intranet by replacing the sample data with your own. It uses the

portal engine and may be used by developers who are new to

Kentico CMS.

&

Blank Site

This template iz intended for developers who want to create a
new weh site from scratch. It uses the portal engine.

(") Continue to the New site wizard
1 Import existing Kentico CMS website

2

Do you need help with installation? Please contact our support Version: 6.0 Build: 6.0.4246
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4. Wait until the Database Setup finishes importing the site. Once finished, the Finished step will be
displayed. Click the Continue to the new website link highlighted in the screenshot below.

Step 7 - Finished

L-3-@-

SQL Settings Database Starter Site

The site has been created successfully.

Continue to the new website

Do you need help with installation? Please contact our support Version: 6.0 Build: 6.0.4246

5. You will be redirected to the Logon page of the portal.

= @5 kenico
» 7% Intranet Solution

Logon

Please Log On

Welcome to the Kentico Intranet Solution. In order to see the content, you need to log on. You can use the default user name administrafor and leave the password blank.

LOG OH Not a member yet? Sign up now!
User name: First name:
Password: Last name:
[CIRemember me E-mail:
Log on Passwaord:
Fargotten password Confirm passwaord:
__ Register |

Existing Kentico CMS installation
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If you already have Kentico CMS installed, but without the Intranet Portal website, you can easily add it
using the New site wizard.

1. Log on to Site Manager and on the Sites tab, click the % New site wizard link.

S'Z Kentico

1% Site Manac Administration Settings Development  Tools Dashboard Licenses Support

&) Sites

(gl New site wizard | [E. Import site or objects [3 Export objects

2. In the first step of the wizard, choose the Use web site template option and click Next.

Choose default website

Step 1 If you choose to create a blank site, the wizard will guide you through the process of creating a new site. If you
choose to use a template, you will be able to choose one of the predefined website templates.

() Create a new site using a wizard
Use website template

Next >

3. In Step 2, choose the Intranet Portal website from the list of available website templates and click
Next.

© 2014 Kentico Software


http://devnet.kentico.com/docs/7_0/devguide/new_site_wizard.htm

10

Kentico CMS 7.0 Intranet Administrator's Guide

Choose website template

Step 2 Choose the predefined website template that will be used for your new website. The website template may
contain site structure, design, basic content, new document types and other settings.

BT commny S

= . This is a web site template for a sample community site. Social networking features of Kentico CMS are used on the site to
give you an idea of how they can be used on your web site. You can also modify this web site and use it as a base for the

development of your own site. It uses the portal engine and is recommended for developers who are new to Kentico CMS.

Intranet Portal

This is a ready-to-use website template for a sample intranet portal site. The site showcases many features useful for a

2 E company intranet, such as sub-sections dedicated to depariments or workgroups and document or project management.
[ You may use it as a base for your own company intranet by replacing the sample data with your own. It uses the portal

engine and may be used by developers who are new to Kentico CMS. F

Blank Site

This template is intended for developers who want to create a new web site from scratch. It uses the portal engine.

m

Blank Site ASPX

This template is intended for developers who want to create a new web site from scratch. It uses the ASPX page templates
that require a higher level of NET knowledge than the portal engine.

4. Go through the rest of the wizard as described in Developer's Guide -> ... -> New site wizard ->
Website template. It is recommended to leave the default settings unless you really need to change
them according to your specific requirements. Once the wizard finishes, you should see the website

present in the list of websites in Site Manager -> Sites.

Kentico

Site Manager Administration ~ Settings  Development  Tools  Dashboard  Licenses  Support

&) Sites

@ Mew site wizard [E. Import site or objects [3 Export objects

- Actions Site name =

(fx Yiel PN @ Intranet Portal)

5. Sign out of the administration interface (use the Sign out button at the top right corner of the Ul). You
will be redirected to the Logon page of the portal.
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o2,

= ¥ Kentico

» 7% Intranet Solution

[

Leger [ P~
Please Log On

Welcome to the Kentico Intranet Solution. In order to see the content, you need to log on. You can use the default user name administrafor and leave the password blank.

LOG ON Hot a member yet? Sign up now!
User name: First name:
Password: Last name:
[CIRemember me E-mail:
Log on Passwaord:
Fargotten password Confirm passwaord:
__ Register |

2.2 Accessing the administration interface

Once you have the Intranet Portal website installed and running (please refer to the Installation topic for
information on how this can be achieved), you can start getting familiar with its administration interface.

In Intranet User's Guide -> Getting started -> Intranet Portal ovenview, you can find an oveniew of the
portal's structure, main sections and features. The rest of the Intranet User's Guide focuses on how

particular sections of the portal can be used by ordinary live site users without access to the
administration interface, so please refer to the appropriate sections of the guide if you are looking for this
type of information.

As this guide describes administration of the solution from within its administration interface, we will
start by logging on to this interface. Open your web browser and type in the URL of your intranet
website, followed by the /cmsdesk postfix (e.g. //intra/cmsdesk).

’/-
|'\\. :) @| @ //intrafcmsdesk

Once you access the URL, you will be redirected to the administration interface's logon screen. The
default administrator username is administrator with blank password. It is highly recommended that you
change this password if you haven't done so yet. Enter your user name and password and click Log on.
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2.3

’s;(“ Kenti
[ ] [
S entico

Please log on

Username:  administrator]
Password:
[ Remember me

You will be redirected to the Content tab of CMS Desk (as depicted in the screenshot below), which is
the part of the administration interface where particular pages of the website can be edited. For a
complete ovenview of Kentico CMS administration interface and the basics of content management in it,
please refer to the whole Content management chapter of Kentico CMS Developer's Guide.

Live Site  Site Manager [IntranetPortalEd L Global Administrator ¥ Vv6.04237 @ Sign Out

Ale Kentico
e

! Enterprise Marketing Solution

1N CMS Desk Mydesk Tools  Administration ~ E-commerce  On-line marketing
> > Coj U r —
2 G o 2w [q] =l
Mew  Delete o Move b Down Preview  Live site List Search
Content management View mode Other —]
;t_;'l Intranet Portal Page | Design Form  Properties  Analytics IE‘
D Home
D Company E Save Spell check
] Departments =
| workgroups E] Source | FERE I I A M @ | B I U2 X x2 =B E w4 | E = == =
|1 Documents = = -
5N BAF | HMEDE0 | HOw BB
ews
[ Events Styles ~ Format  ~ Font - size ~ | A A- | @) =
|1 Media L
[ Blogs _* kentico ign ¥ Dashbos ‘Edi this psge
[31 Forums #1 Intranet Solution Sian Out My Deshboerd | HowTo | Editthis oege
] Employees
[3) search ‘You have: D unresd messagels) 3 sciive taskis)
B e ——
|] rss
B Logon Company Departments Workgroups Documents News Events Media Blogs Forums Employees
) Files

& Special pages

E i Welcome to Your New
U QUICK LINKS 1
i Intranet
I, Employees H
i This is a ready-to-use intranet that you can use out of the box Or |
. Documents * you can customize it as you need. For mere information on how to |

= Departments i configure your infranet, please see the Intranet Guide.

2 Workgroups

Configuration for WebDAYV editing

WebDAV editing is a feature of the solution which enables direct editing of files stored on the portal,
without the need to create a local copy and re-upload the modified file back to the sener. This greatly
simplifies the process of editing uploaded files and can be extremely useful, especially on intranet
websites. For detailed information about WebDAV integration in Kentico CMS, please refer to

Deeloper's Guide -> Modules -> WebDAV integration.
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Client-side requirements
For WebDAV integration to be functional, the following client-side requirements must be met:

e \WebDAYV can be used only in Internet Explorer 6 or higher. No other web browsers are currently
supported.

e Client applications with WebDAV support for particular file types need to be installed on the
client machine. E.g. Microsoft Office 2003 or higher or Paint and Notepad in Windows 7 support
editing of associated file types using WebDAV.

e Matching (x86) or (x64) versions of both Internet Explorer and Microsoft Office must be installed.
In other words, to be able to open documents using WebDAYV in Internet Explorer (x86), Microsoft
Office (x86) must be installed on the client computer. For Internet Explorer (x64), you need to have
Microsoft Office (x64) installed.

Editable file size limit

By default, WebDAYV editing is only functional with files smaller than 50 MB.

In case that a user needed to edit larger files using WebDAV, they would need to go to
HKEY_LOCAL_MACHINE\SY STEM\CurrentControlSet\Services\WebClient\Parameters
in their Windows registry and adjust the FileSizeLimitinBytes key to the required value.

Server-side requirements
For WebDAYV integration to be functional, the following server-side requirements must be met:

e Windows authentication must be enabled in IS and the CMS must be configured to use this type
of authentication.

e [f you are using an older version of IS than 7.0, the Kentico CMS website must be installed in the
root of the sener. This is necessary because Microsoft Office submits configuration requests to the
site root and requires the server to respond properly. If the website is not installed to the root,
Microsoft Office will open its associated documents as read-only.

e [fyou are using IIS 7.0 or higher, the website needn't be installed in the root - it can also be installed
in a virtual directory.

The following paragraph guides you step-by-step through the process of enabling Windows
Authentication, which is the most important pre-requisite. The Configuration for WebDAV topic in
Developer's Guide -> Modules -> WebDAYV integration explains the rest of the required configuration
procedure.

Enabling Windows Authentication

1. Before you configure your project for Windows authentication, you need to create a user account that
will be the same as your current domain name and assign administrator permissions to this user
account. This will allow you to access all features as an administrator once you sign in using Windows
authentication.
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2. Sign in as an administrator to Site Manager and go to Administration -> Users. Create a new user
with the following values:

e User name: your domain user name in format domain-username, example: office-johns
e Full name: your full name

Click OK.

3. On the General tab, set the following values:
e |s global administrator: yes
e |s external user: yes
e [sdomain user: yes

Click OK.

4. Now you can switch the application to Windows authentication mode. Edit the web.config file of the
web project and change the following line:

<aut henti cati on node="For ns" >

to:

<aut henti cati on node="W ndows" >

5. Now you have Windows authentication enabled for the administration interface. To enable it for the live
site as well, the following piece of code also needs to be present in your web.config. By default, the
code is already there, but commented. So the only thing you need to do is locate it (just search for the
first line) and uncomment it.

<l ocation path="">
<syst em web>
<aut hori zati on>
<deny users="?"/>
</ aut hori zati on>
</ syst em web>
</l ocat i on>

Verifying the configuration

Once you hawe all the necessary configuration performed, you can verify that WebDAV editing is
enabled. The easiest way is to verify it in any Document library on the portal. The screenshot below
shows the 2 Edit action, which is only present in the drop-down menu if WebDAV editing is enabled
and if WebDAYV editing of the particular file type is supported. In the screenshot, you can see how a
DOCX document is opened for direct editing in Microsoft Word. Saving the changes in Microsoft Word
(just by clicking the Save button or pressing Ctrl+S) replaces the original version of the file with the new
one automatically.
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@"‘. Ellq WD = Understanding-Our-Values - Microsoft Word @Elg
&

Document name -

v E) A Complete Guide for Ne|

| Home | Insert Page Layout References Mailings Review View
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Styles =
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Value
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& Delete
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3.1

Departments

Departments overview

The Departments section of the portal provides a separate website section for each company
department. This section contains its own Home page, Project management, News, Document library,
Forums, Blogs, etc. When viewing a department's section, the main menu serves for navigation within
the department, not within the global section of the portal. It is recognizable by the Back to main portal
button at the left edge of the menu, as well as by the breadcrumbs below it beginning with Portal >
Departments > Department name. You can navigate back to the global section of the portal using these
two controls.

|T 0 SUMMErS : Sign Out My Dashbosrd | How To | Edit this page

department

“fou hawve: D unread messsge(s) 2 active task(s)

News Calendar Documents Media Elogs Forums Wiki Projects Members

L Portal > Depariments > [T > Home }

P

A comprehensive oveniew of the section's functionality and features can be found in Intranet User's
Guide -> Departments, so please refer to it if you are looking for further information on how the section
can be used on the live site.

Departments structure in the content tree

Let's take a look at how the section is created within the system's administration interface. Log on to
CMS Desk and navigate to the Content tab. If you expand the Departments node of the content tree,
you should see the sub-nodes as in the screenshot below. As you can see, there is a number of pre-
defined departments recognizable by the &8 icon.

Below the pre-defined department, there is the Template document, which is a template used when
adding new departments. If you expand the Template node, you should see its sub-pages as in the
screenshot below. If you expand any of the pre-defined departments, you can see that they contain the
same sub-pages as the Template document. These sub-pages represent particular sub-sections of
each department's section. When a new department is created, the sub-pages from under the Template
document are copied under the new department's parent document, as demonstrated in step 6 of the
Adding new departments topic.

Location of the departments template may be customized. Howewer, a correct location of the template
must always be set in Site Manager -> Settings -> Intranet & Collaboration -> Department
template path in order for the creation of new departments to be possible.
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a Departments
&R Finance®
&8 HR*
&
&% Management®
S8 Marketing®
SA production®

T L,
| ] Home

[ News

|1 calendar
[ ] Documents
[ Media

a Blogs

[ Forums

[ wiki

[ Projects
[] Members

] RSS
L || Search

|| Template® ©
|| Home" .
[ News

[ calendar
a Documents
[0 Media

[ Blogs

a Forums

[ wiki

[ projects
[] mMembers
|1 rRsS

[ ] Search

Intranet department document type

Particular departments consist of the sub-pages mentioned above and their parent document. The parent
document is of the Intranet department (IntranetPortal. Department) document type. By default, each
newly created document of this type uses the Intranet Portal - Department master page page
template. This is ensured by the configuration of the Template document, which also has this page
template set.

As obvious from the name of the page template, this document works as a master page for the
department's section. The master page provides the common graphic elements in the header of each
department's section and the dedicated navigation in the main menu (area 1 in the screenshot below).
Particular sub-pages are displayed by the Page placeholder web part in the zoneContent web part
zone on the master page (area 2 in the screenshot below).
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Page Design Form Master page Properties  Analytics

E Save == Spell check

[ Source | Pl - A # ek @ | B I U = X, x2 = = Z W | E = = =
@ap | iEEEOC|l BOow 8

Styles ~ Format ~  Font v Size v | Ho A | )

Y -
1. IT | A = Sign Out My Dashboard | HowTo | Edit this page
department

You have: D unread message(s) 3 aclive task(s)

e —

Home News Calendar Documenis Media Blogs Forums Wiki Projecis Members

Portal > Depariments = T

2,

Settings on the Form tab

Essential settings of the department can be performed on the parent document's Form tab. The
following fields can be configured:

e Department name - name of the department used in the administration interface and on the live
site.

e Department description - text describing the department. It is used as the department's description
in the departments listing.

e Department avatar - image used in departments listing and in the header of the department's
website section. You can click the 4 Upload file link and select an image from your local disk. You
may also leave the field blank, which assigns the default avatar to the department.

e Used stylesheet - theme used for the department's section. You may use one of the three pre-
defined stylesheets, or even edit the selected one directly using the Edit button.

e Used department sections - using these check-boxes, you can choose which sub-sections will be
included in the department's website section.

e Department roles - roles of department members. Members of the roles selected in this field will
have access to the department's website section (see the Departments security topic for more
details).

e Publish from - date and time from when the department will be published on the live site. If you
leave the field blank, it will be published immediately after its creation.

e Publish to - date and time until when the department will be published on the live site. If you leave
the field blank, it will be published until it is deleted.

For sample values that can be entered in the fields, please see the pre-defined sample departments or
refer to the Adding new departments topic.
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3.2

¢ Kentico
1™

[y

Live Site  Site Manager

CMS Desk My desk  Tools  Administration  E-commerce  On-line marketing

=) Col U e r— —
2 [ Bow T 4| [ L
Mew  Delete | Move JL Down Edit Preview  Live site List Search
Content management View mode Other
!;‘_’! Intranet Portal o Page Design | Form | Master page  Properties  Analytics
D Home
[0} Company E Save Spell check
|| Departments
&8 Finance®
epartment name:
o8 HR? Department T
This department contains sample i
»
m EI' data.
|| Home
D News Department description:
[0 calendar
D Documents i
[ Media
e Actions Update Name Size
|| Blogs Department avatar: =
|| Forums FR 2 &= Tipg 14.9 kB
[ wiki .
) Projects | Used stylesheet: Intranet Portal - Red Em
[] Members ; Home News calendar [¥] Documents
D RSS | Used department sections: ¥ Media Blogs Forums Wiki
|| Search Projects [¥] Members [/ RSS Search

S8 Management®
&8 Marketing®
&8 production®

A sales* Department roles:
[] Template®

D Workgroups

D Documents Publish from:

5 News Publish to:
Events

Adding new departments

[Tl Role name

b | cio

B o

[ Remove sefected | Addrole [
& Now
& Now

The following topic provides a step-by-step example of how a new department can be added to the

portal.

1. The first step in creation of a department is creation of roles that the members of the department will
belong to. This is necessary in order to control access to the department's section, as described in the
Departments security topic. Go to CMS Desk -> Administration -> Roles and click the & New role

link abowe the list.
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Me Kentico
FAY

CMS Desk Content My desk Tools [QELIUNEIEGGUM  E-commerce  On-line marketing

Event log Users | Roles | Membership Permissions Ul personalization  Banned IPs E-mail templates
System Membership Security

&4 Roles

i& New role !

Role name: LIKE |Z|

2. In the New role dialog, enter the following details:

¢ Role display name: Support Engineer; name of the role displayed in the system's administration
interface and on the live site.

¢ Role code name: SupportEngineer; name of the role used in website code.

* Role description: enter some text describing the role.

e |[sdomain role: disabled; indicates if the role is a domain role from Active Directory.

Click OK. Repeat the procedure and create another role using the following details:
¢ Role display name: Customer Care Manager
* Role code name: CustomerCareManager
¢ Role description: enter some text describing the role.
e |[sdomain role: disabled

Click OK.

M¢ Kentico
1N

CMS Desk Content My desk RIS E-commerce  On-line

Event log Users Roles Membership Permissions Ul personalization Banned IPs
System Membership Security

ﬁ New role

» Roles » New role

Role display name: Customer Care Manager

Role code name:  CustomerCareManager

Role description.  Head of the Customer Care -
department.
Is domain role: =

3. With the roles defined, you may proceed with creating the actual department section in the content
tree. Go to CMS Desk -> Content and select the Departments node in the content tree. Click the New
button abowe the tree.
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l_(e_nti.co
CMS Desk My desk  Tools  Administration  E-commerce  On-line marketing
.'.l- —%, CB U S— B —n
Sl & Fow T L4 [d] A
Mew § Delete & Move J} Down Edit Preview  Live site List Search
Content management View mode COther
!;_’! Intranet Portal Page | Design Form  Properties  Analytics
D Home
[ Company
D Departments
— g
9 Workgroups . P> entico -
L] Documents » 7% Intranet Solution
] News -

4. In the New document dialog which gets displayed, select the & Intranet department document
type.

:!:. Kentico

#1%  CMS Desk Mydesk Tools  Administraion  E-commerce  On-line marketing
2 g BPow Tw L4 | [d ~
Mew  Delete o Move {} Down Edit Preview  Live site List Search

Content management View mode Other

{‘._,’ Intranet Portal = New document

[1] Home —

9 Company Please select new document type:

| Departments

[0 workgroups [ Page (menu item)

|| Documents

[ News '] Blog

[l Events |4 Event (booking system]

9 Media S Eile

|| Blogs -

[ Forums Loider

[] Employees A Intranet department

[ search = News

9 RSS “| Simple article

|| Logon -

5. On the department creation form, you need to specify the following details. For detailed descriptions
of particular fields, please refer to the Departments oveniew topic.

e Department name: Customer Care

e Department description: enter some text describing the department.

e Department avatar: for the purpose of this example, you may leave the field blank, which assigns
the default avatar image to the department. If you wish, you may click the % Upload file link and
select an image from your local disk.

e Used stylesheet: Intranet Portal - Blue

e Used department sections - enable all available check-boxes

e Department roles: add the Customer Care Manager and Support Engineers roles created in step 2.

e Publish from: leave the field blank.

e Publish to: leawve the field blank.

Finally, click & Save to create the department with the entered details.
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Intranet Portal B

Live Site  Site Manager

ale Kentico
#1v  CMS Desk My desk  Tools  Administraion  E-commerce  On-line marketing
T T CB U — — o
S @ Bow tw 4 [ A
New  Delete | Move J} Down Edit Preview  Live site List Search
Content management View mode Other
& ) Intranet Portal E Save F‘ Save and create another Spell check

D Home

|1 company

D Departments
SR Finance®
LA HR*
8

LA Management®
LA Marketing®
S8 Production®
LA sales*

[] Template®
Workgroups
Documents
News

Events

Media

Blogs

Forums
Employees
Search

B

Logon
Files
Special pages

Qp Qp D R D e D

Department name:

Department description:

Department avatar:

Used stylesheet:

Used department sections:

Department roles:

Fublish from:
Fublish to:

Customer Care

This department provide our
customers with help in sloving
issues with our products.

- Upload file
Intranet portal
Home News
¥ Media Blogs
Projects Members
]
O
[} Support Engineers
.
& Now
& Now

Calendar Documents
Forums Wiki

Role name

Customer Care Manager

6. Now, the department should be created. You should see it in the content tree, under the
Departments node. If you expand the Customer Care node, you should see that all pages from under
the Template document were copied under it, as depicted in the screenshot below.

D Departments

&R customer Care®
[} Home
D News
[ calendar
[ Documents
[ Media
[ Blogs
D Forums
[ wiki
[ projects
[ Members
& Rss
[ search

&8 Finance®

7. The last thing you need to do is configure permissions for access to the new department. With the
Customer Care document selected, switch to the Properties -> Security tab. By default, both the
Customer Care Manager and the Support Engineer roles have only the Read permission assigned.
This only enables them to view the content of the department.

As we want the Customer Care Manager role members to manage the content in all possible ways,
let's give them the Full control permission. Enable the Full control check-box in the Allow column, all
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check-boxes below it will be enabled too. Finally, click OK to save the configuration.

!‘u_‘_’] Intranet Portal il Page Design Form  Master page | Properties | Analytics
|| Home
[[1 company

|1 Departments

SR customer Care®

[] Home
] News
;J Calendar
;J Documents
[0 Media
[l Blogs
|| Forums
[ wiki
[ Projects
|| Members
[] rsS
|| search
SR Finance*
SR HR*
SAm*
SR Management®
A Marketing®
SR Production®
S sales*
[} Template®

8. Let's see what we hawe created

mn

General
URLs
Template
Metadata
Categories
Menu
Workflow
Versions
Related docs

Linked decs

; Security

| Attachments

Permissions

This document does NOT inherit permissions from the parent document.

Change permission inheritance...

Users and Roles:

Customer Care Manager

Support Engineers

Access rights:

Full control
Read
Modify
Create
Delete
Destroy
Browse tree

Modify
permissions

=
5
=

GEEEEEEE

:

ODDEnEmm

|

. If you go to the live site and browse to the title page of the

Departments section, you should see the department present in the All departments list.

Home Company

Workgroups

Events

Forums

Employees

Departments

Departments

You aren't currently member of any department.

ALL DEPARTMENTS

Customer Care
a This department provides our
customers with helpin ___

Management
This department belongs
directly to CEQ.

-l

o Marketing

Finance department

" ! Marketing and PR department.

Production department

HR
m Human resources department

=

IT

This department contains
sample data.

Sales

"J # Sales department
‘

9. Click the department's name or avatar. You will be redirected to the Home page of the department's
dedicated website section. As you can see in the following screenshot, the page already contains all
web parts that are present on other departments' Home pages, but they have no content yet.

In a real-world scenario, the next logical step would be to assign ordinary members of the department to
the Support Engineer role and the department's management to the Customer Care Manager role.
The rest of the department's section is pre-configured and ready to be used. Once the department starts
being used by its members, web parts on this page will get populated with content from the respective
sub-section of the department automatically.
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“ Customer Care . . Global Administrator : Sign Out My Dsshbosrd | How Te | Edit this pege

department

“You have: 0 unread messages) 0 active tack(s]

Calendar Documents Media ogs Forums

Ports| > Departments > Customer Care > Home

© auckumcs [ tnresrmens R s o

—

‘?.“ Portal home There are currently no news. How do you like our new portal?
View all news
4?-% Members ) Very satisfied
. Documents
LATEST BLOG POSTS N ) satisfied
—
There are currently no blog posts. @ Neutral
View all posts —
© Dissatisfied
LATEST FORUM POSTS N © Very dissatisfied
[5] uPCOMING EVENTS BN
There are currently no posts.
There are currently no upcoming events. M

View all events

Automatically created objects

When a new department is created, a number of objects is automatically created within the system's
administration interface. These objects are necessary to provide object-based functionality of the
department's section. The following text describes which objects are created and what display hame and
code name they are created with. In the code names, the globally unique identifier (GUID) of the
particular department's parent document is always used. This identifier can be found in the Node GUID
field on the Properties -> General tab of the parent document's editing interface.
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»

\:-h"'! Intranet Portal d

Page  Design Form Master page Properties | Analytics

D Home
[] company E Save
|| Departments el N
S8 customer Care® »r The changes were saved.
|1 Home Design
[ News Template
= Intranet Portal - Blue m
L] Calendar Metadata csSsiyleshest [=] (R—
] Documents R Inherit
[ Media
= Other properties
[ Blogs Menu prop
D Forums Workflow Document name: Customer Care
O wile Type: Intranet department
Wilki ;
g Profect Version= Created by: Global Administrator
) Projects Related Created: 8/9/2011 1:17-58 PM
9 Members . | gy Lastmodified by Global Administrator
5] RSS g Uinked cocs Last modified: 2/9/2011 1:22:52 FM
|| Search | Security _
SR Finance® ! Raing: —
P N r| Attachments NIA
HR ags
Pl L
S8 Management® B
5 Marketing™ Alias path: /Departments/Customer-Care
Fe.) Production® Culture: English - United States
O sales* Name path: /Departments/Customer Care
— - Live URL: [KenticoCM:54237 20467/Depariments/Customer-
|| Template : Care.aspx
[ workgroups Praview URL: Show preview @
D Documents Published: Yes
D News
Media library

If you choose that the new department should contain the Media sub-section (in step 5 of the example
abowe), a media library is created for the department in CMS Desk -> Tools -> Media libraries. The

media library is created with the following nhames:

e Display name: <display hame of the department> media libary
e Code name: Department_<guid of the department's parent document>

Site Manager |Intranet Portal B3

Kentico

CMS5 Desk Content My desk Administration ~ E-commerce  On-line marketing

@ Polls  [J Custom tables & Forums Message boards E =3 [&] Reporting

Forms | Media | § Staging [ File import Blogs fa Groups | Abuse report Projects  Events Newsletters 5] Web analytics
Content Community Collaboration Marketing & Reports

Media
gl Mew media library

~ Actions Name - Folder Description
(f x - Customer Care media library Customer-Care  Media library for Customer Care departmenl.)

f x - Finance media library Finance Media library for the Finance depariment.

SR~ HR media library HR Media library for the HR department.

R~ IT media library IT Media library for the IT department.

f x - Management media library Management Media library for the Management department.

f x - Media Media Global media library accessible to all employees.

f x - PR & Marketing media library ~ PR-—-Marketing  Media library for the PR & Marketing department.

f x - Production meadia library Production Media library for the Production department.

f x - Sales media library Sales Media library for the Sales department.
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Forum group

If you choose that the new department should contain the Forums section (in step 5 of the example
abowe), a forum group is created for the department in CMS Desk -> Tools -> Forums. The forum group
contains a single forum, which is also created automatically. The forum group is created with the
following names:

¢ Display name: <display name of the department> forum group
e Code name: Department_<guid of the department's parent document>

The forum in the forum group is created with the following names:

e Display name: <display nhame of the department> forum
e Code name: Default_department_<guid of the department's parent document>

Please note that if you wanted to add another forum into the forum group, it would be necessary for its
code name to end with the _department_<guid of the department's parent document> suffix. Otherwise,
content of the forum would not be indexed by the department's forum smart search index (see below for
more details).

T wonsimn | Live Site  Site Manager |Intranet Portal B2

M2 Kentico
0

1™ CMS5 Desk Content My desk Administration ~ E-commerce  On-line marketing

— @ Polls  [fjl Custom tables &4 Forums Message boards s 1 [&@) Reporting
o 8 S
Forms  Media g Staging [[3 File import Blogs fla Groups |e| Abuse report Projects  Events Newsletters 5] Web analytics
Content Community Collaboration Marketing & Reports

&l Forum groups

&4 New forum grou

~ Actions Group name

rf i &~ Customer Care forum group)
f x i & - Finance forum group
FRE &~ Production forum group
f x i & - Management forum group
FRE L~ PR & Marketing forum group
FRT G~ Sales forum group
FRT L~ IT forum group
FRT G~ HR forum group
F R4 § = | Intranet Discussion

Search indexes

Each newly created department gets a search index for its content created in Site Manager ->
Administration -> Smart Search. In addition, if you choose that the new department should contain
the Forums section (in step 5 of the example abowe), another search index gets created for the
department's forums. The index for general content of the department is created with the following
names:

e Display name: <display name of the department> - Default
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e Code name: default_department_<guid of the department's parent document>
The index for department forums is created with the following names:

e Display name: <display nhame of the department> - Forums
e Code name: forums_department_<guid of the department's parent document>

w CMS Desk
% Kentico =

#IN  Site Manager Si ing Development  Tools Dashboard  Licenses  Support
Administration ) Smart search indexes
Avatars
(7 Bad words ¥ New index
& Badges
24 Banned IPs - Actions Display name - Last rebuild time Index type  Index status
& Categories Cust C Default BHT2011 1:422TPM D nts  Read
ustomer Care - u 42 ocume ea

& E-mail queue fxs - Y
%) E-mail templates e 4 -9 Customer Care - Forums Forums New
[] Event log f x % + | Finance - Default 81712011 1:2819 PV Documents  Ready
% Integration bus F®B~  Finance - Forums 8/17/2011 12820 PM  Forums Ready
&y, Membership
% permissions FR® -~  HR-Defaut 8/17/20111:28:27 PM  Documents  Ready
4/ Recycle bin FRD ~ HR - Forums 8/17/2011 1:28:2T PM  Forums Ready
&4 Roles f x S - Intranet Portal - General content 8M7/2011 1:28:30 PM Documents  Ready
C—" Scheduled tasks

f x S - Intranet Portal - General forums 8M7/2011 1:2839 PM  Forums Ready
13 Smart search
E‘i SMTP servers f x S - IT - Default 8M7/2011 1:28:48 PM  Documents  Ready

Tag group

In Site Manager -> Development -> Tag groups, a tag group is created automatically for each newly
created department. This tag group is intended for tagging of blog posts in the department's Blogs sub-
section, but it is created even if you choose not to include the Blogs sub-section in the department (in
step 5 of the example abowe). The tag group is created with the following names:

e Display name: <display name of the department>
e Code name: <guid of the department's parent document>
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CMS Desk

i)
#INV  Site Manager Sites  Administration i DR  Tools  Dashboard  Licenses  Support
Development Q Tag groups

@ Countries

Q’ CSS stylesheets Site: Infranet Portal |Z|

& cultures

%4l New tag group
4 Custom settings

fill Custom tables

[ Document types ~ Actions  Name -

< Form controls R~ Elogs

Inline controls - Content

‘H Modules

i) Notifications 4 - Customer Care ]
[H Page layouts TR~ Finance

@ Page templates AR~ Global

E_E Relat|onsh||.: names f“ - .

[@ search engines

fHl System tables TR~ m

<7 Tag groups SR~ Management

@ Time zones SR~ Marketing Strategy

3 UI cultures
_____ \ f x - Microsoft Office Upgrade

% web parts | SR~ PR & Marketing
[@] web templates 1 2R~ Emilrarey

[&] widgets IR~ Sales

« Workflows

f x - Tradeshow in Las Vegas

3.3 Customizing departments

It is possible to customize of each department’'s website section, i.e. modify particular pages on the
Design tab, add additional sub-sections or remove the existing ones. This can be done at three lewels:

e Page templates customization - useful to customize pages on the Design tab.

¢ Individual department customization - useful if you want to add or remove sub-sections of a single,
already existing department.

e Customization of the department template - useful if you want all newly created departments to
reflect certain customization.

In a real-world scenario where you already have some departments created, it is expected that you will
have to combine these approaches to achieve the expected result. The following examples will guide you
through the process of performing these types of customization. These examples are intentionally
simple, but the principles shown in them are applicable for all customizations you would possibly want
to perform.

Reordering and renaming default department sub-pages

Configuration of most of the web parts and widgets used within the department
sections, as well as other configuration, is dependent on alias paths of particular
department sub-pages. Therefore, it is not recommended to change the default alias
paths.
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In case that you needed to perform this, please refer to the Customizing the portal ->
Modifying structure of the website topic for more details on how this can be achieved.

Page templates customization

Documents of particular department sub-sections share common page templates. For example, the
Home pages of all pre-defined departments, as well as the one under the Template node, share the
Intranet Portal - Department home page page template. This fact implies that if you customize one
Home page on the Design tab (e.g. if you add a web part), the customization will be reflected on all
Home pages that share the page template.

To prevent this behavior, i.e. to customize only one single document using the template without affecting
the other ones, you can use the ' Clone template as ad-hoc action on the Properties -> Template
tab of the document's editing interface.

The following example demonstrates both of these approaches:

1. At first, we will try modifying one page so that all pages that share the same page template will reflect
this customization as well. Log on to CMS Desk and in the content tree, choose the Departments/IT/
Home document and switch to the Design tab of its editing interface.

2. We will customize the page by adding one extra web part to the zoneCenterTop web part zone.
Click the Add web part (%) icon in the top right corner of the web part zone.

0 Live Site  Site Manager  [INUGNGEPOEIES & Clobal Administrator ¥ V604237 @ sign
Kentico

CMS Desk My desk  Tools Administration E-commerce On-line marketing ! Enterprise Marketing So|

[ Ccopy T Up @ @

New Delete [ Move b Down Edit Preview  Live site List

e

Search

Content management View mode Other

{-_';3 Intranet Portal /1" Page | Design | Form Properties  Analytics
:] Home
[J] company
;] Departments
8 Customer Care™ department
SR Finance* - You have: 0 unread message(s) 3 aciive taskis)
— e
58 HR®
M
D Home - ___________________________________________________________ |
O News Porisl > Degariments » [T > Home : ol
| calendar
a Documents
[ Media 2
[ Blogs ¥ zoneTop a4k
LI Forums |v WidgetActions @;‘
[ wild -
| projects | v"ﬁ]zc"eLeﬁ |* -‘zoneCenlerTop ﬁ v"ﬁ]zunenghl ‘*
B | =] 5] Department_Quicklinks ||| ||+ | Contentrext |G| [ #] ] IntranetPortal_Poll 53|

] Members
] rsS
[ search 1 Portal home v‘@zone{:emer |+

S Management® 3 Members |v L] Department_LatestNews @_
o -

& Marketing™

SA production®

IT listrator : Sign Out My Dashboard | HowTo | Edit this page

News Calendar Documents Media Blogs Forums Wiki Projects Members

= [Departments/IT/Home - page template: Intranet Portal - Department home page

m

! Documents NEW INTERNAL RULES OF THE IT DEPARTMENT | 11/9/2010

" m | have just finished a new document whose aim is to
@ Sales 4 sum up the current internal rules of the IT department.
[] Template® a The document has been uploaded to the department's

3. Inthe Select web part dialog which pops-up, choose the General -> Powered by Kentico web
part. In its web part properties, only add <br/><br/> into the Content after property, which will ensure
some free space between the web part and the ones under it. Leave all other properties at their defaults
and click OK. The web part will be added to the page template, as can be seen in the following
screenshot.
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~ [Departments/IT/Home - template: Intranet Portal - Department home ;
v zoneTop o
| v | WidgetActions |@|
- | ] zoneLeft |+ - |zoneCenterTop |+ - |§] zoneRight |*
v 0] Department QuickLinks @3/ |+ ContentText ¢ |»| €] IntranetPortal_Poll | G|

<; Portal home ‘; PoweredByKentico | {&3

l—v--«--——u

52 Members

. Documents ~ '] zoneCenter |+

‘l v| T] Department_LatestNews |@_

4. Now if you view the Home page of any other department, e.g. Finance, you will see that the web part
is present there as well. The same applies to the Home page under the Template node.

inistrator : Sign Out My Dashbosrd | How To | Edit this page

Finance

deparitment
“ou have: D unread message(s) 2 active task(s)

News Calendar Documents Media Elogs Forums WWiki Projects Members

Portal > Depariments > Finance > Home \:\ p

, e o
&) Quick LiNks =meow Kentico

e~
“?? Portal home

52 Members o

. Documents There are currently no news.
View all news

5. Let's try the other approach. Now that all Home pages contain the added web part, we can try
removing it from just one of these pages, while keeping it in the rest of them. With the Finance
department's Home page selected, switch to its Properties -> Template tab and click the = Clone
template as ad-hoc action.

{‘,_,’ Intranet Portal o Page Design Form | Properties | Analytics
[2] Home
[] company Hsave
[l Departments
S8 customer Care® i Template
LA Finance* URLs = Inherit from parent
[1] Home e plat N .. All culture versioqs use mg same page template
[0 News @ Each culture version uses its own page template
[ Metadata
9 Calendar Intranet Portal - Department home page m
g Documents Categories
L] Media N =,/ Save as new template. .
I_] Blogs Mavigation
£ -/ Clone template as ad-hoc
g Forums Related docs J Clone template as ad-hoc
Wiki
H Projects Linked docs E Edit template properties
roje
|—] Members Security

6. The page template will be cloned as an ad-hoc one, which will be recognizable by its hame changing
to Ad-hoc: Home. Now you can modify the page without affecting the other Home pages. For example,
if you remowve the Powered by Kentico web part added in step 3, it will only be removed from this
Home page, not from all the other ones.
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Individual department customization

In case that you want to customize the dedicated website section of a single department, you only need
to perform the required customization on documents under the department's parent document in the
content tree. This customization will then be reflected only in this particular department's website
section.

In the following example, you will learn how to add a sample FAQ page to the IT department's section:

1. Log on to CMS Desk and on the Content tab, select the Departments/IT document in the content
tree. Click the New button abowe the tree. When the New document dialog appears, select the Page
(menu item) document type.

Me Kentico
FY

1™ CMS Desk My desk  Tools Administration E-commerce On-line marketing
a "F_x EJ copy i Up w @ ‘ ,O ‘
Delete | Move  J{} Down Edit Preview  Live site List Search
Content management View mode Other
&) Intranet Portal “1 [ New document
D Home —
j‘—] Company Please select new document type:
|| Departments
SR customer Care® (D PAQQ{MI] ,_
5 Finance®
S8 HR®
& m
Q Home gg Link an existing document
] News

2. In the following dialog, enter FAQ into the Page name field and choose the Create a blank page
option (in a real-world scenario, you may also use one of the pre-defined page templates according to
your needs). Finally, click Save to save the changes.

E Save E‘ Save and create another " Spell check
Page name:
(T} Use existing page template () Use parent page template () Create a blank page with layout @ Create a blank page

The new page will use new ad-hoc page template with an empty layout.

3. The new page is added as the first page under the department's main document (before the Home
page). The position of the page in the content tree determines the position of the page in department
navigation. As you will probably want the page to be located a bit more to the right in the navigation, drag
and drop the page to the desired position in the content tree.
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A
D Home
[ Mews
[0 calendar
D Documents
[ Media
D Elogs
D Forums
[ wiki
[} projects
[ Members
L] FAQ
[ mrss
| search

4. Once the page is created, switch to the Design tab of its editing interface and add the required web
parts. For the purposes of this example, we will only add a single Editable text web part with all its
properties left at the defaults.

Page | Design | Form  Properties  Analytics Display web part content

IT al [ = Sign Out My Dashboard | HowTo | Edit this page

department
- You have: D unread message(s) 3 active task(s)

Home News Calendar Documents Media Blogs Forums Wik Projects Members

Fortal > Depariments = [T » FAQ \:I el
v [Departments/IT/FAQ - page template: Intranet Portal - D: nt FAQ E
v zoneleft o

| editabletext (3|

5. Now go to the Page tab of the page's editing interface and add the actual content of the page. For the
purposes of this example, you can just add some sample text as in the screenshot below. Click Save
to sawve the changes.
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Page | Design Form Properties  Anahytics [¥] Display web part content
E Save * Spell check

The changes were saved.

E] Source | 0 M O A A | e @ | B I U = X x2 = = =N E = = =

& P EREEE O BOw# E

Styles » Format v Font v Size v | B AT | L

ISIrator : Sign Out My Dashboard | HowTo | Edit this page

IT

department

You have: D unread messape(s) 3 active task(s)

e —

Home News Calendar Documents Media Blogs Forums Wiki Projects Members

Fortal > Deparimenis > [T > FAQ I:I yel

———————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————

Frequently Asked Questions

E Some sample text come here .

6. Once you are finished, go to the live site to see what you have created. Browse to the IT department's
website section. You should see the FAQ menu item present in the main navigation, at the position
where you dragged it in step 3. If you click the document, you should see the page with the content
defined in the previous step.

IT Brad - Sign Out My Dashbosrd | How To | Edit this page

department
“fou have: [ unread message(s) 2 aclive task(s)

e
News

Home Calendar Documents Media Elogs Forums Wiki Projects Members

Portsl > Depariments > |T = FAQ I:I Je)

Frequently Asked Questions

Some sample text come here ..

Customization of the department template

As explained in the Departments oveniew and Adding new departments topics, the Departments/
Template node contains sub-pages with pre-configured web parts. These pages are copied under each
newly created department's parent document. By performing customization of the documents under the
Template document, you ensure that each newly created department will reflect this
customization too. However, this will not be the case for already existing departments. To ensure
uniformity in this case, you will need to copy the new page under the existing departments manually.
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In the following example, you will learn how to add the FAQ page to to the department template:

1. Log on to CMS Desk and on the Content tab, select the Departments/Template document in the
content tree. Go through steps 1. to 5. in the example above to create the FAQ page under the
Template document.

{u_j Intranet Portal
D Home
] Company
D Departments

&R customer Care®

A Finance®
SR HR*
S
SR Management®
LA Marketing®
&R production®
SR sales*
(] Template*
D Home
D News
[ calendar
D Documents
[ Media
D Blogs
[ Forums

[ wiki

RS
[ search
D ‘Workgroups

“|| | Page | Design Form Properties Analytics

[ s Spell check

El Saurce | FER I HE 2| B I U =xx | EE Ew | E=E EE
aapP EERE0|l By BE
Styles ~  Format -  Font -~ Sze v | A A- | )

department —
dministrator : sign Out My Dashbosrd | HowTo | Edit this page

‘You have: 0 unresd messsge(s) 3 active tesk(s)

Portal > Depariments > Template > FAQ : Pel

m

i Frequently Asked Questions

Some sample text come here ...

2. At this point, the page is created with an ad-hoc page template. To ensure uniformity with all other
department sub-pages, i.e. that modification of a single FAQ page will be reflected in all other FAQ
pages (see Page templates customization above for more details), we need to save the ad-hoc template
as a new regular page template. To do this, go to the Properties -> Template tab of the FAQ page's
editing interface and click the “# Save as new page template action.

Page  Design Form Properties | Analytics

General

URLs

Template >

Metadata
Categories
Navigation
Related docs

Linked docs

E Save

Template

) Inherit from parent
@ All culture versions use the same page template
() Each culture version uses its own page template

;"_-_'Ti Save as new template.

E Edit template properties

Inherit content

3. In the Save as new page template dialog which pops-up, enter the following details:

Template display name: Intranet Portal - Department FAQ
Template code name: IntranetPortal. DepartmentFAQ

Template category: Intranet Portal

Template description: enter some text describing the page template.
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Click OK.
el 3 ™
{23 Save as new page template - Windows Internet Explorer E@g
£ Save as new page template
Template display name: Intranet Portal - Department FAQ
Template code name: IntranetPortal DepartmentFAQ
Template category: Intranet Fortal El
This is & template cof a page -
where department FAQ will be
rublished.
Template description:
Ok |" Cancel |
A oy

4. Now try creating a new department, just as described in the Adding new departments topic.

5. Once the new department is created, you can see that it contains the FAQ page as well. The same
would apply to any other newly created department.

[ Copy 4t Up [ @ =

New  Delete [ Move b Down Edit Preview | Live site List

pe

Search

Content management View mode Other

) Intranet Portal S| view | validate
3 Home

|1 Company

3.4

[ Departments u Customer Care

&4 customer Care®

[] Home
D News
[} calendar
a Documents
] Media
D Blogs
a Forums
B wiki

a Projects
| Members
B raQ

|1 Rss

[} search

i

department
You have: 0 unresd message(s) 3 sctive task(s)

Home News Calendar Documents Media Blogs Forums Wiki Projects Members

Portsl > Depariments > Customer Care > FAQ

Frequently Asked Questions

Some sample text come here .

Departments security

Access to department sections is limited based on document permissions configured on the three-level
permissions hierarchy. However, the permissions configurable on the two higher lewels, i.e. permissions
for all content and permissions for particular document types, are typically only used in special cases.
Therefore, you will typically configure department permissions on document-level.

As explained in the Departments oveniew topic, you can choose department member roles in the
Department roles field on the Form tab of the department's parent document. By adding a role to this
field, the role is added to the Users and Roles list on the Properties -> Security tab of the parent
document and the Read document-level permission is granted to it. All documents stored under the
parent document inherit document-level permissions from their parent by default, which results in the fact
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that members of the roles can view all documents in the department's section. On top of it, these
permissions ensure that the department is displayed to them in the My departments list on the
Departments section's title page.

Apart from the basic Read permission, it is possible to set up additional permissions to enable
management of document-based features of the section:

e News
Calendar
e Documents
e Wiki

A typical example of this configuration can be seen in the configuration of each pre-defined department
shipped with the portal. Let's take the IT department for demonstration:

The IT role is intended for ordinary employees without document management permissions. Therefore,
only the Read permission is granted to the role on document-level. Contrary to that, the CIO role is
intended for the head of the department who should be able to manage all content within the
department's section. Therefore, full permissions are granted to the role (as can be seen in the
screenshot below) to provide full permissions for all possible content management actions.

Live Site  Site Manager Intranet Portal B3 A Global Administrator

Kentico
CMS Desk Mydesk Tools Administration  E-commerce  On-line marketing
C 1]
) o 0w tw (NN Q@) L
New  Delete o Move J} Down Edit Preview  Live site List Search
Content management View mode Other
;t_’i Intranet Portal il Page Design Form  Master page | Properties | Analytics
D Home
&1 company
[0l Departments o
&8 customer Care® Permissions
LR Finance® -
This document inherits permissions from the parent document.
m HR* Template
Change permission inheritance...
el ind Metadata
|1 Home Categories Users and Roles: Access rights:
B news Authenticated users
B calendar e co-———— ] Mow | Dem
[l Documents Workflow IT Full control &
g Media Versions Read =]
[l Blogs
- Related d Modi v
] Forums L o - Ty g
[ wiki " ||| Linked docs Create =]
|1 Projects | security 5 Delete ]
S Members r| Attachments Destroy ]
FAQ
D RSS Browse tree [
[] search Modify
= . permissions E
5% Management
ing™
&8 production®
S8 sales®

3.5 Managing department features

The most of the functionality provided by the Departments section is based on standard Kentico CMS
modules and features. The following topic provides brief descriptions of the particular sub-sections and
the modules and features that they are based on. With each module or feature, you can find a link
leading to its full documentation in Kentico CMS Developer's Guide.
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*

Home
News
Calendar
Documents
Media
Blogs
Forums
Wiki
Projects
Members
RSS
Search
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News

The News section is based on standard Kentico CMS documents. Each published news item is a
document of the News (CMS.News) document type stored under the News document in the
department's section. For more information on document types, please refer to Developer's Guide ->

Development -> Document types and transformations.

To enable adding of news on the live site, the User contributions (Wiki) module is leveraged. Detailed

information about the module is located in Developer's Guide -> Modules -> User contributions (Wiki).

Calendar

The calendar used for events scheduling and attendees registration is based on the Events module. To
find more information about the module, please refer to Developer's Guide -> Modules -> Events.

Documents

Documents storage on the live site is provided by the Document library module. More information
about the use of this module on the portal can be found in the Document libraries chapter of this guide.
Complete documentation of the module is located in Developer's Guide -> Modules -> Document library.

Media

The Media section is based on the Media libraries module. Each department has its own media library
created in CMS Desk -> Tools -> Media libraries. The library is recognizable by the name in the
<Department name> media library format. Detailed documentation of the module can be found in

Deeloper's Guide -> Modules -> Media libraries.
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7 Live Site  Site Manager Intranet Portal B
3le Kentico
#1%  CMS Desk Content My desk Administration  E-commerce  On-line marketing
@ Polls  [ifl Custom tables 84 Forums Message boards la T ‘} [&) Reporting
Forms | Media | #g Staging [fg File import Blogs fa Groups |g Abuse report Projects  Evenis Newsletters 5J| Web analytics
Content Community Collaboration Marketing & Reports

Byl Media

New media library

~ Actions Name - Folder Description

f x - Customer Care media library Customer-Care  Media library for Customer Care department.

f x - Finance media library Finance Media library for the Finance depariment.
f x - HR media library HR Media library for the HR department.
f x - IT media library IT Media library for the IT department.

f x - Management media library Management Media library for the Management depariment.
f x v Media Media Global media library accessible to all employees.
f x - PR & Marketing media library ~ PR---Marketing Media library for the PR & Marketing depariment.

f x - Production media library Production Media library for the Production department.
f x - Sales media library Sales Media library for the Sales depariment.
Blogs

Functionality of the Blogs section is provided by the Blogs module. Blogs are standard documents in
Kentico CMS content tree, but the module also has its dedicated user interface in CMS Desk -> Blogs.
Detailed documentation of the module can be found in Developer's Guide -> Modules -> Blogs.

Forums

The discussion forums are based on the Forums module. Each department has its own forum group
created in CMS Desk -> Tools -> Forums. The forum group is recognizable by the name in the
<Department name> forum group format. Detailed documentation of the module can be found in
Deweloper's Guide -> Modules -> Forums.

Wiki

Similarly as the News section, the Wiki section is also based on standard Kentico CMS documents.
Each published wiki article is of the Simple article (CMS.SimpleArticle) document type, stored under
the Wiki document within the department’s section in the content tree.

To enable adding of articles on the live site, the User contributions (Wiki) module is leveraged. Detailed
information about the module is located in Developer's Guide -> Modules -> User contributions (Wiki).

Projects

Functionality of the Projects section is provided by the Project management module. The module's
user interface is located in CMS Desk -> Tools -> Project management. Its functionality and
management is briefly described in the Project management chapter of this guide. Full documentation of
the module can be found in Developer's Guide -> Modules -> Project management.

© 2014 Kentico Software


http://devnet.kentico.com/docs/7_0/devguide/module_blogs_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/forum_module_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/user_contributions_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/project_management_overview.htm

40

Kentico CMS 7.0 Intranet Administrator's Guide

Live Site  Site Manager Intranet Portal B3
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CMS5 Desk Content My desk Administration E-commerce On-line marketing
= Folls Custom tahles 4 Forums| [] Message boards f fﬁ Reporting
W S & 5 % ]
Forms  Media g Staging [ File import Blogs fla Groups |@| Abuse report Projects  Events Newsletters ] Web analytics
Content Community Collaboration Marketing & Reports

&d Forum groups

&4 New forum grou

+ Actions Group name

FRTE ~ Customer Care forum group
fx T &~ Finance forum group
fx i ¢ - Production forum group
fx i & - Management forum group
FREE ~ PR & Marketing forum group
FRTE ~ Sales forum group
FRT G~ IT forum group

FRT G~ HR forum group

AR 4§ ~ | Intranst Discussion

Members

The Members page only contains a combination of the following three interconnected web parts: Basic
repeater + Department members data source + Filter. These web parts are configured so that the
Basic repeater displays users provided by the Department members data source. The data source is
configured so that it displays only members of the current department (i.e. members of the roles added
in the Department roles field on the Form tab of the department's parent document's editing interface).
The filter enables further filtering of displayed users based on their names.

Detailed information about data source web parts can be found in Dewveloper's Guide -> Development ->
Web parts -> Data source web parts. A detailed reference concerning management of users and roles in
Kentico CMS can be found in Developer's Guide -> Dewvelopment -> Membership.

RSS

The RSS page is not accessible via the department's navigation. It contains special sub-pages which
provide RSS feeds of the department's content. The feeds are created using web parts of the
Syndication module. A full reference on the module can be found in Developer's Guide -> Modules ->

Syndication.

Search

Search of the department's content is provided by the Smart search module. Each department has two
indexes created in Site Manager -> Administration -> Smart search: one for its discussion forums
(with name in the <Department name> - Forums format) and one for the actual content of the department
pages (with name in the <Department name> - General format). For a full reference on the module,
please refer to Developer's Guide -> Modules -> Smart search.
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4.1

Workgroups

Workgroups overview

Workgroups are separate sub-sections within the Intranet Portal website that are dedicated to a certain
activity. A workgroup's content and tools are only available within the context of the given workgroup. A
full description of all the features offered by workgroups from the live site point of view can be found in

Intranet User's Guide -> Workgroups.

Workgroups utilize the standard groups module. For general information about groups, please refer to
Deeloper's Guide -> Modules -> Groups. There are two main elements that each workgroup is
composed of: a section of documents in the content tree and a corresponding object in the
administration interface. An ovenview of workgroup documents may be found below and information about
managing workgroups via the CMS Desk -> Tools -> Groups interface is given in the Managing

workgroups topic.

Workgroups in the content tree

If you log on to CMS Desk, navigate to the Content tab and expand the Workgroups node in the
content tree, you will see all documents related to workgroups as depicted in the screenshot below.

pq] Intranet Portal
,_1 Home
[ ] company
,_1 Departments
,_1 Workaroups
[} Template®
,_1 Create
|1 Marketing_Strategy®
[ Microsoft_office_Upgrade®
|} Tradeshow_in_Las_Vegas®™
,_1 Documents

The Template node and its child documents define the structure that Intranet Portal workgroups are all
based on and the Create document allows users to add new workgroups directly from the live site. The
workgroup creation process is described in the Creating new workgroups topic. Below are the document
sections of several pre-defined sample workgroups, e.g. Marketing_Strategy. Each section is stored
under a document with the same name as the workgroup that it represents.

Workgroup document structure

Expand the Template node to view the default document structure of Intranet portal workgroups. If you
expand one of the sample workgroups, you will see that it contains the same child documents. To learn
how the structure of workgroups may be modified, please see the Customizing workgroups topic.
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Individual workgroups consist of a parent document and child documents that reflect the various
workgroup sections available on the live site. The parent document serves as a master page for the

Search
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remaining pages of the workgroup. This means that all workgroup pages inherit the header, navigation
menu and all other content defined in the parent document (area 1 in the screenshot below). Particular

sub-pages are displayed by the Page placeholder web part in the zoneContent web part zone on the
master page (area 2 in the screenshot below).
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4.2

Page Design Form Master page Properties  Analytics

Display web part content

E Save Spell check

@aP | EEEEOC| BOw 86

Styles ~ Format ~ Font v Size v | fuv A | i8]
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Portal = Workgroups > Marketing Strategy

[ Source | B S o e e W& @ | B I U a x x2
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Board

LI

istrator - Sign Out My Dachbosrd | HowTo | Edit this page

Wiki

Wou have: D unread message(s) 2 active task(s)

Projects

Members

2.

Managing workgroups

All workgroups on the Intranet Portal website can be managed through the interface located at CMS
Desk -> Tools -> Groups. The workgroups displayed on this page may be filtered according to their

display name and approval status.

New workgroups that require an administrator's approval before they are published can be approved here
by clicking the Approve (#) action icon. Using the Reject (&) icon returns the given workgroup to the
state it was in before approval. Rejected workgroups are not displayed on the live site.
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Live Site
Content My desk Administration E-commerce On-line marketing
= Polls Custom tables 4 Forums [] Message boards 15
S - : S
Forms  Media % Staging [y File import Blogs [#] Abuse report Projects  Events
Content Community Collaboration

& Groups

& New group
Groupname: LIKE  [~]
Status: (all) [~]
+ Actions Display name = Approved

F RS D - Marketing Strategy Yes

F R D ~ | Microsoft Office Upgrade  Yes

FRITD ~ Tradeshow in Las Vegas  Yes

The listed workgroups may also be Edited (#) or Deleted (#). When deleting a workgroup, it is
possible to choose whether all its documents should be deleted as well. The edit action opens the
Group properties dialog, where the settings and content of the given workgroup can be defined and
managed. For more detailed information about the available options, please refer to Developer's Guide ->

Modules -> Groups -> Editing a group.

& Group properties

» Groups » Microsoft Office Upgrade

General | Security  Members  Roles  Forums  Media libraries  Message boards  Polls  Projects

Display name: Microsoft Office Upgrade
Code name: Microsoft_Office_Upgrade
This workgroup contains sample -

data. Its mission is to upgrade
Microgsoft Office on all our
Description: network machines.

Group pages location: IWorkgroups/Microseft_Office_Up

Theme: {default)
3 I I e’
Avatar: ’) @
Upload: Browse

Select pre-defined avatar

Users designated as administrators of a workgroup may also edit it in a similar fashion through the live
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4.3

site workgroup management interface, as documented in Intranet User's Guide -> Workgroups ->
Managing workgroups. Certain settings, such as code names, are not available when editing on the live
site.

Additional settings that are applied to all workgroups may also be specified at Site Manager ->
Settings -> Community as described in Developer's Guide -> Modules -> Groups -> Settings.

Managing document-based workgroup features

Most of the functionality provided by the various sub-sections of a workgroup is based on standard
Kentico CMS modules and features. The following topic provides brief descriptions of individual
workgroup sections and the modules and features that they are based on, including links to the
appropriate documentation in Kentico CMS Developer's Guide. Sections linked with the features that
are manageable through the CMS Desk -> Tools -> Groups workgroup editing interface, as described

in Developer's Guide -> Modules -> Groups -> Editing a group, are not listed in this topic.

[] Marketing_Strategy®
| Home

News
Calendar
Documents
Media

Blogs
Forums
Board

Wiki

Projects
Members
Access
Management
RSS

Search

DD o oo m D mm m o m

News

The News section is based on standard Kentico CMS documents. Each published news item is a
document of the News (CMS.News) document type stored under the News document within the
workgroup' s section of the content tree. For more information on document types, please refer to
Deweloper's Guide -> Dewvelopment -> Document types and transformations.

To enable the adding of news on the live site, the User contributions (Wiki) module is leveraged.
Detailed information about the module is located in Developer's Guide -> Modules -> User contributions

(Wiki).

Calendar

The calendar used for event scheduling is based on the Events module. To find more information about
the module, please refer to Developer's Guide -> Modules -> Events.

Documents

Document storage on the live site is provided by the Document library module. More information about
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the use of this module on the portal can be found in the Document libraries chapter of this guide.
Complete documentation of the module is located in Developer's Guide -> Modules -> Document library.
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Blogs

The functionality of the Blogs section is provided by the Blogs module. Blogs are standard documents
in the Kentico CMS content tree, but the module also has its dedicated user interface in CMS Desk ->
Blogs. Detailed documentation of the module can be found in Dewveloper's Guide -> Modules -> Blogs.

Wiki

Similar to the News section, the Wiki section is also based on standard Kentico CMS documents.
Each published wiki article is of the Simple article (CMS.SimpleArticle) document type, stored under
the Wiki document within the workgroup' s section of the content tree.

To enable the adding of articles on the live site, the User contributions (Wiki) module is leveraged.
Detailed information about the module is located in Developer's Guide -> Modules -> User contributions

(Wiki).

Members

The Members document contains a combination of the following four interconnected web parts: Basic
repeater + Group members data source + Filter + Universal pager. These web parts are configured
so that the Basic repeater displays users provided by the Group members data source. The data
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source displays only users who are members of the current workgroup. The filter allows further filtering of
the displayed users based on their names and the pager ensures that the list of users is divided into
multiple pages in case there is a large amount of workgroup members.

Page | Design | Form  Properties  Analytics Display web part content

[ 1% i . . - o
*2t5 Microsoft Office Upgrade ' —— =5

| 'J_ workgroup
o “fou have: D unread message(s) 3 aclive taskis)

e —
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News Calendar Documents Media Blogs Forums Board Wikd Projects

Portal >\ » Microscf Office Uparsde > I:I yel

v [Workgroups/Microsoft_Office_Upgrade/Members - page template: Intranet Portal - Workgroup members | 3
v zoneTop o
v zoneCenter o
v HeaderText {3
| - | i WorkgroupSecurityAccess |@|
|v J» MembersFilter @| M
|v| | 2| MembersDataSource |@|
|v MembersRepeater @ Position Phone  E-mail Skype ™
I? Brad Summers Clo 161 brads@localhostlocal company_brads WLM: Brad_Summers
? Colin Douglas CFO 152 colind@localhost local company_colind WLM: Colin_Douglas
B
‘I Ruth Baker System Administrator 167 ruthb@localhost local company_ruthb WLM: Ruth_Baker
* | MembersPager | {2
v |znneBonom |*

Detailed information about data source web parts can be found in Developer's Guide -> Dewvelopment ->
Web parts -> Data source web parts. A detailed reference concerning the management of users and

roles in Kentico CMS is located in Developer's Guide -> Dewvelopment -> Membership.

Access

This document is not visible in a workgroup's navigation menu. Instead, users are redirected to it when
they attempt to view the pages of a workgroup to which they do not have access permissions, typically
when they are not members. Relevant information is displayed by the Group security message web
part. The path to this document is specified in the Site Manager -> Settings -> Community -> Group
security access denied path setting.

This functionality is ensured by Group security access web parts, which are placed on all workgroup
documents apart from this one.

Management

This document is also not reachable through a workgroup's navigation menu. It allows workgroup
administrators to manage the workgroup directly on the live site as described in Intranet User's Guide ->
Workgroups -> Managing workgroups. It must contain the Group profile web part, which provides all
necessary functionality. The path to this document is specified in the Site Manager -> Settings ->
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Community -> Group management path setting.

RSS

The RSS document is not accessible via a workgroup's navigation menu. It contains special child
documents which allow users to access RSS feeds of the workgroup's content. This is achieved by web
parts of the Syndication module. A full reference can be found in Developer's Guide -> Modules ->

Syndication.

Search

This document ensures the functionality of the search box available under the menu in all workgroup
sections and displays the search results. The necessary functionality is provided by the Smart search
dialog with results web part. Each workgroup uses two search indexes created in Site Manager ->
Administration -> Smart search: one for the content of its documents (with a name in format
<Workgroup display name> - Default) and another for its forums (with a name in format <Work group
display name> - Forums). Information about the creation of these indexes for a sample workgroup is
described in steps 10 and 11 of the Creating new workgroups topic. For a full reference on the smart

search module, please refer to Developer's Guide -> Modules -> Smart search.

4.4  Creating new workgroups

All authenticated users of the Intranet Portal website may create workgroups directly on the live site.
This approach is how most workgroups are normally created, since it is easy to use and automatically
performs many tasks that are necessary for the correct functioning of the new workgroup. The details of

this process may be found in Intranet User's Guide -> Workgroups -> Creating a hew workgroup.

This feature is facilitated by the Group registration web part. It is possible to modify how workgroups
are created by changing the properties of this web part. To do so, access CMS Desk -> Content, select
the Workgroups -> Create document from the content tree, switch to the Design tab and Configure (
&) the web part (named WorkgroupRegistration by default).
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Additional settings related to workgroups and their creation may be specified at Site Manager ->
Settings -> Community as described in Developer's Guide -> Modules -> Groups -> Settings.

A new workgroup may also be defined manually in the administration interface, as is demonstrated in

the following example:

Please note

This example is not a recommended way of creating workgroups. The following steps
are all performed automatically when a workgroup is created via the Group
registration web part, they only sernve to help understand the process.

1. Log on to CMS Desk as a global administrator (username administrator with a blank password by
default) and the Content tab will automatically be displayed. The first thing that needs to be done is
create the documents that will form the section of the portal dedicated to the new workgroup. Expand
the Workgroups node in the content tree, select the Template child node and create a copy of it under
the same parent. This can be done either using the Copy button from the menu abowve the content tree
or by holding down the Control key and dragging the given node to its target location in the tree. When

copying, ensure that the Copy also all child documents box is checked.
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[ [ ] Template® "

|| Documents
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workgroup

2. Select the new copy of the Template document and switch to the Form tab. Now change the
Document name to the name that you wish to give to the new workgroup. This example uses

New_Product_Line.

3¢ Kentico

#1%  CMS Desk

E =y [ Copy f Up
New Delete |2 Move J} Down

Content management

My desk

Live Site

Tools Administration E-commerce

On-line marketing

4 [d AL
Edit Preview Live site List Search
View mode Other

;‘_J! Intranet Portal

D Home

[ company

D Departments

D Workaroups
[] Template®
D Create
|1 Marketing_Strategy®
[J] Microsoft_Office_Upgrade®
[] Tradeshow_in_Las_Vegas®
[ Template®

D Documents

Click & Save.

Page Design Form Master page Properties Analytics

E Save Spell check

(Dccumenl name: New_Product_Line l
Teaserimage: | 4 Upload file I
Vienu group: (none) El
Publish from: & Now
Publish to: = Now

3. Switch to the Properties -> URLs tab and change the value of the Document alias property to
New_Product_Line as well. The value of this property will be used in the URL of the workgroup's
documents, so it cannot contain spaces or other forbidden characters. When a workgroup is created
automatically, the name specified for the workgroup is used as the value of this property and any
forbidden characters are converted to underscores.
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Click & Save. With default Intranet Portal website settings, a document alias will automatically be
created for the previous value of the Document alias property. Delete (¥) this alias, so that the
documents of the workgroup cannot be accessed under the old URL.

Page  Design Form Master page Properties | Analytics

[ Sawe

_.'q'. Add new alias

- Actions

(7%

URL path URL extensions

I MWorkgroups/Template-(1) ]
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Alias
URLs >
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4. Now that the workgroup's documents are prepared, the workgroup object itself must be added to the
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system. Go to Tools -> Groups and click the £ New group link at the top of the page.

3 Live Site  Site Manager Intranet Portal B3
Kentico

CMS5 Desk Content My desk Administration ~ E-commerce  On-line marketing

[&8) Reporting
Newsletters  [5f] Web analytics
Marketing & Reports

[ig

@ Polls [} Custom tables ‘I 84 Forums Message boards
Forms Media g Staging [fy File import Blogs l@ Abuse report

Content Community
& Groups

i&n New group '

Group name: LIKE |Z|
Status: (all) [~]

~ Actions Display name - Approved
F R D ~ | Warketing Strateay Yes
F WD ~ | Microsoft Office Upgrade  Yes

f x ‘[ @ - Tradeshow in Las Vegas  Yes

5

of
Projects  Events

Collaboration

The New group form will be displayed. Fill in the following fields:

e Display name - the name of the workgroup that will be displayed on the website and in the
administration interface. This example uses New Product Line.

e Code name - a unique name used to identify the workgroup. The value of this field must be the
same as that of the Document alias property set in step 3 to ensure that links to the workgroup
function correctly. For the purposes of this example, the value must be New_Product_Line.

e Description - text describing the new workgroup.

e Group pages location - contains the alias path of the node that contains the workgroup's
documents. Select the /Workgroups/New_Product_Line node for the purposes of this example.

e Avatar - allows the selection of the workgroup avatar image used for graphical representation.

e Approve members - this selection determines if users can join the workgroup with or without a
workgroup administrator's approval. The Only approved members can join option requires all new
members to be approved, while Only approved members can join except for invited members allows
users who accept an invitation from a workgroup member to join without approval.

e Content access - this selection determines what type of users can view the content of the
workgroup. Please keep in mind that if the Only group members can view the content option is
selected, users cannot apply to join the workgroup and must be invited to become members.

e Notify group admins when a user joins/leaves - if checked, workgroup administrators will
receive a notification e-mail when a user joins/leaves the workgroup.

e Notify group admins on pending members - if checked, workgroup administrators will receive a
notification e-mail when a user requests to join the workgroup and approval is required.
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& New group

» Groups » New group

Display name: New Product Line
Code name: NewProductLine
The purpose of this workgroup is -

to prepare our new product line.

Description:

Group pages location: IM\Workgroups/New_Product_Line

Avatar:
Upload: Browse. ..
Select pre-defined avatar
@ Any site member can join

Approve members: () Only approved members can join

() Only approved members can join except for invited members

@ Anybody can view the content

. ™ Site members can view the content
Content access: o=

(© Only group members can view the content
Notify group admins when a user joinsfleaves: [
Motify group admins on pending members: ]

(R—
Click OK.

5. Now return to the Content tab, select the Workgroups/New_Product_Line document from the
content tree and switch to its Properties -> General tab. Click the Change button next to the Owned
by group property, choose the New Product Line workgroup in the displayed dialog and check the
Inherit by child documents box.
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This assigns the given document and all documents under it to the workgroup object that was created in
step 4, which ensures that the tools provided by these documents operate correctly within the context of
the new workgroup.

6. When a default Intranet Portal workgroup is created automatically, several other associated objects
are also added to the system. These include a forum group, forum and media library under the given
workgroup, a tag group and a pair of search indexes for the content of the workgroup. The next steps
describe how these objects can be defined manually.

7. To add forums to a workgroup through the administration interface, go to Tools -> Groups, edit (£)
the New Product Line workgroup, open its Forums tab and click the & New forum group link.
Forums are described in Developer's Guide -> Modules -> Forums, so please refer to this chapter if you
are unfamiliar with the use of the forum management interface.
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Ia @ Polls [l Custom tables &4 Forums Message boards
Forms  Media #§ Staging ([ File import Blogs |8 Abuse report

Content Community
& Group properties

» Groups » New Product Line

Collaboration

General  Security Members Roles | Forums | Media libraries  Message boards  Polls  Projects

&4 New forum group

No data found.

Fill in the displayed form according to the following information:

e Group display name - the name of the forum group that will be displayed on the website and in the
administration interface. When a workgroup's initial forum group is created automatically, this name
is in format <Display name of the edited work group> forums, for example New Product Line forums.

e Group code name - a uniqgue name used to identify the forum group.

e Description - a text description for the forum group that will be displayed on the website.

e Forum group base URL - the URL of the document where the workgroup's forums are displayed.
Default workgroups use the Forums child document, so enter ~/Work groups/New_Product_Line/
Forums.aspx for the purposes of this example.

e Forum group unsubscription URL - the URL of a page where users can unsubscribe from the
forums under the given group. On the default Intranet Portal, this page may be found at ~/Special-
Pages/Forum-Unsubscribe.aspx and the URL can be loaded from the value of the Site Manager ->

Forums -> Forum unsubscription URL setting automatically by checking the Inherit from settings
box.

& Group properties

» Groups * MNew Preduct Line

General  Security  Members  Roles | Forums | Media libraries  Message boards  Polls  Projects

» Groups » New forum group

Group display name: MNew Product Line forums

Group code name: NewProductLineForums

Description: -

Forum group base URL: ~MWorkgroups/New_Product_Line/Forums.aspx [l Inhsrit from settings

Forum group unsubscription URL: |~/Special-Pages/Forum-Unsubscribe. aspx Inherit from settings
oK |

Click OK. The Forums tab of the new forum group will now be displayed. Click the & Add forum link
and enter the following details:

e Forum display name - the name of the forum that will be displayed on the website and in the
administration interface. When a workgroup's initial forum is created automatically, it is named
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General discussion.

e Forum code name - a unique name used to identify the forum. It must end with the following string:
_group_<GUID of the edited work group>. This is necessary to ensure that the forum will be fully
functional. A workgroup's GUID is a string of 32 characters generated when the workgroup is created
and serves as a globally unique identifier. If necessary, the GUID of a workgroup may be found in the
database, specifically the GroupGUID column of the Community_Group table.

e Description - a text description for the forum that will be displayed on the website.

e Forum base URL, Forum unsubscription URL - leave the Inherit from forum group boxes checked
to use the same values as the parent forum group.

The remaining fields may be left unchanged for the purposes of this example.

& Group properties

¥ Groups » New Product Line

General  Security Members  Roles | Forums | Media libraries  Message boards  Polls  Projects

» Groups » New Product Line forums

Forums | General  View

» Forums » New forum

Forum display name: General discussion
Forum code name: General_discussion_group_1be5eb8c-6445-4228
Description:

Forum base URL: s/Mew Product Line/Forums.aspx [¥] Inherit from forum group

Forum unsubscription URL: ~/Special-Pages/Forum-Unsubscribe. aspx Inherit from forum group
Require e-mail addresses: [T inherit from forum group
Display e-mail addresses: [ Inherit from forum group
Enable WYSIWYG editor:

Use security code {CAPTCHA):

[Z] inherit from forum group
[ inherit from forum group
Forum is open:

Forum is locked:

Forum is moderated:

Click OK to create the new forum.

8. Media libraries can be created on the Media libraries tab of the same group editing interface.

Information about managing media libraries may be found in Developer's Guide -> Modules -> Media
libraries. There are no special requirements for defining media libraries under workgroups.
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No data found.

9. Now create the workgroup's tag group, which is intended for the tagging of blog posts under the
workgroup's Blogs section. For more information about tags, please refer to Developer's Guide ->
Modules -> Tags. Go to Site Manager -> Development -> Tag groups and click the “¢ New tag
group link.

'. Kentico

1% Site Manager Si Administration Setting Development [RETCH Dashboard Licenses Support Buy
Development Q Tag groups

@ countries

§ CSS stylesheets Site: Intranet Portal [~]
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fidl Custom tables
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-
B. Search engines
FH System tables SR~ Management
<¥ Tag groups # % ~  Marketing Strategy
g Time zones FR~ Microsoft Office Upgrade
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0 Web part containers . 7R~ PR & Marketing
«# web parts 1 AR~ Production
[@] web templates AR~ sales
Widgets
@ ¢ #  ~  Tradeshow in Las Vegas
« Workflows

Fill in the New tag group form. By default, the display and code names of the tag group are the same
as those of the new workgroup, so enter these values.

The tag group also needs to be assigned to the appropriate workgroup documents. Return to CMS Desk
-> Content, select the Workgroups/New_Product_Line document from the content tree and switch to
its Properties -> Metadata tab. Here, uncheck the Inherit box under the Page tag group drop-down
list and select the New Product Line tag group.
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D Members [ Inherit
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[] Documents [T inherit
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Click & Save. All child documents will inherit this tag group.

10. Next, to ensure that searching within the new workgroup is possible, appropriate smart search
indexes must be defined. To learn more about the smart search module, please see Deweloper's Guide -
> Modules -> Smart search. Go to Site Manager -> Administration -> Smart search and click the %
New index link.
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<@ Categories
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F# ®® ~ | Production - Forums 8/20/2011 121236 PM  Forums Ready
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First, create the index for regular workgroup documents by entering the following values into the New
search index form:

e Display name - the name of the index used in the administration interface. The standard format for
this name is <Display hame of the indexed work group> - Default, for example New Product Line -
Default. This format is used when a workgroup search index is created automatically, but it is not
strictly necessary.

e Code name - a unique name used to identify the index. It must be in format default_group_<GUID of

the indexed work group> in order for the index to be applied to the given workgroup.

Analyzer type - leave the default value.

Stop words - leave the default value.

Index type - select Documents.

Assign index to website Intranet Portal - leave this box checked.
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g New search index

» Search indexes » MNew index

E Save

Display name: New Product Line - Default @
Code name:  default_group_1be5ebB8c-6445-4228-badd-f1 c65diE)
Indextype:  Documents [~]
Analyzer type: Standard |Z|

Stop words: (Default) |Z|

[¥] Assign index to website Intranet Portal

Click k1 Save. Now switch to the Index tab of the newly created index, click the & Add allowed
content button and fill in the displayed form according to the following information:

e Path - the path to the documents that should be indexed. For this example, either manually enter /
Work groups/New_Product_Line/% or click the Select button and choose the /Work groups/
New_Product_Line node with the Only sub-items box checked.

e Document types - the document types that should be indexed. It is recommended to leawe this field
empty to allow all types of workgroup content to be indexed.

e Include ad-hoc forums, Include blog comments, Include message boards, Include categories
- these fields determine what types of additional content should be indexed. When a workgroup index
is created automatically, these fields are disabled, but you may set them as required. Please note,
the forums contained by default Intranet Portal workgroups are not ad-hoc forums, they are
pre-defined and thus require their own search index as shown in the next step.

) Smart search indexes

» Smart search indexes » Mew Product Line - Default

General | Index | Sites  Cultures  Search preview

» Item list » New allowed item

E Save
Path: MWorkgroups/MNew_Product_Line/? ﬁ

Leave the field empty if you wish to choose all document fypes.
Include ad-hoc forums: [

Include blog comments: [
Include message boards: [

Include categories: 0=

Click & Save. Switch to the Cultures tab and add the culture(s) used by your website. Finally, return to
the General tab and ® Rebuild the index.

11. In a similar fashion, a second search index must be added to allow searching of the workgroup's
forums. To do this, go back to the Smart search indexes list, click the & New index link again and
enter the following values into the form:

e Display name - the name of the index used in the administration interface. The standard format for
this name is <Display name of the indexed work group> - Forums, for example New Product Line -
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Forums. This format is used when a workgroup search index is created automatically, but it is not
strictly necessary.

e Code name - a unigue name used to identify the index. It must be in format forums_group_<GUID

of the indexed work group> in order for the index to be applied to the given workgroup.

Analyzer type - leave the default value.

Stop words - leave the default value.

Index type - select Forums.

Assign index to website Intranet Portal - leave this box checked.

g New search index

» Search indexes » New index

E Save

Display name: New Product Line - Forums @
Code name:  forums_group_1be5eb8c-6445-4228-badd-f1c65¢ (2]
Index type: Forums |Z|
Analyzer type: Standard |Z|

Stopwords:  (Default) [~]

[7] Assign index to wehsite Intranet Portal

Click W Save. Switch to the Index tab of the new index and click the & Add allowed forums link.
Use the Site name drop-down list to select your Intranet Portal website. Now enter a string in the
following format into the Forums field: *_group_<GUID of the indexed work group>. The asterisk
character (*) serves as a wildcard, ensuring that all forums under the specified workgroup using the
correct code name format (as specified in step 7) are indexed. The Select button cannot be used to
assign the index to workgroup forums.

%y Smart search indexes

» Smart search indexes » New Product Line - Forums

General | Index | Sites  Search preview

¥ ltem list » Mew allowed item

E Save

Site name: | Intranet Portal |Z|

Forums: "_gmup_1beEebBc-6445—4228—baﬁ

Leave the field empty if you wish to choose all forums on the selected site.

Click kdl Save. Now return to the General tab and ® Rebuild the index.

Please keep in mind

When a workgroup is deleted, its search indexes will remain in the system and must
be removed manually.

12. The workgroup and its associated objects are now created. If you go to the live site, you should see
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it listed under the Workgroups section of the portal, as depicted below. If you open the workgroup, all
sections should be fully functional (but without any content).

i " o
7% 9 entico Global Administrator : Sign Out My Dashboard | How To

~ 1% Intranet Solution

e —

Home Company Departments Documents Nei Events Media Blogs Forums Employees

Workgroups
Workgroups
Create a new workgrou
You are not currently in any workgroup.
Sort by: Workgroup name Created Search
New Product Line %‘ Tradeshow in Las Vegas 4% Microsoft Office Upgrade Marketing Strateqy
The purpose of this workgroup Las o Workgroup to prepare our ) This workgroup contains - Workgroup to review and
is to prepare our new ... h‘ “f presentation for the upcomi... - sample data. Its mission is ... update our current marketing...

4.5 Customizing workgroups

It is possible to customize the website sections dedicated to workgroups by adding new documents,
deleting unwanted documents or modifying existing ones. This can be done at two levels:

e Customizing all workgroups
e Customizing one specific workgrou

Relocating and renaming default workgroup sub-pages

The configuration of many web parts and widgets used within the sections dedicated to
workgroups and certain other settings are dependent on the alias paths of particular
workgroup sub-pages. Therefore, it is not recommended to change the default alias
paths.

In case that this is absolutely necessary, please refer to the Customizing the portal ->
Modifying structure of the website topic for more details on how this can be achieved.

Customizing all workgroups

If you wish to customize a document for all workgroups, you can perform the required change by adding,
removing or configuring the web parts of the given document on the Content -> Edit -> Design tab of
CMS Desk. The default documents of all workgroups share common page templates, so changes made
to a document under any existing workgroup or to the documents under the Workgroups/Template
node will immediately affect every workgroup.

When altering the workgroup document structure by adding or deleting a document, the change needs to
be carried out under the Template node. This will ensure that all new workgroups are created with the
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updated document structure. Customization of this type does not affect existing workgroups and must
be performed for each one individually to ensure uniformity across all workgroups.

The following example will demonstrate how to add a simple FAQ page to the workgroup Template:

1. Log on to CMS Desk and on the Content tab, select the Workgroups/Template document in the
content tree. Click the New button abowe the tree. When the New document dialog appears, select
the Page (menu item) document type.

I_(e_nti.co
CMS Desk My desk  Tools  Administration  E-commerce  On-line marketing
> Co u - r =
5 o T (4 [d A
Delete o Move  J{} Down Edit Preview Live site List Search
Content management View mode Other
&) Intranet Portal *11 [ New document
[] Home
9 Company Please select new document type:
|| Departments - -
[ workgroups ﬁ P_aqe_{ma
[] Template®
[] Home ] Blog
D News '.EQEvent booking system
9 Calendar File
|| Documents
e =
B Media i) Folder
[] Blogs A Intranet department
[1] Forums (37 News
9 B{?a.rd | Simple article
L] wiki —
[} Projects = || Smartphone
] Members |
D Access 4
L-J Management I Sﬁ Link an existing document
[ RsS '
[0l search

2. In the following dialog, enter FAQ into the Page name field and choose the Create a blank page
option (in a real-world scenario, you may also use one of the pre-defined page templates according to
your needs). Finally, click Save to save the changes.

.| Spell check

E Save F‘ Save and create another
Page name:

(©) Use existing page template  (©) Use parent page template  (©) Create a blank page with layout @ Create a blank page

The new page will use new ad-hoc page template with an empty layout.

3. The document will be added as the first item under the Template node. Because the document order
in the content tree determines the position of the given page in the workgroup navigation menu, you will
probably want to mowve the FAQ document further down. Drag and drop it to the desired position in the
content tree.
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[] Template®
D Home
D News
[ calendar
| Documents
[ Media
[} Blogs
[ Forums
[ Board
[ wiki

[ Projects

[ Management

[0 rss

[ search

4. Now switch to the Design tab of the editing interface and add () a Text & Images -> Editable text
web part to the only zone on the page. Leave the properties of the new web part in their default state.

Page | Design | Form  Properies  Analytics

workgroup al Ad * SignOut My Dashbosrd | HowTo | Edit this page

ou have: D unread message(s) 2 aclive task{s)

Home News Calendar Documents Media Blogs Forums Board WWiki Projects Members

Portal > Workarouss > Temolste > FAQ I:I yel
v rol emplate/FAQ - te: ad-hoc B
= zoneleft o

| »| editabletext 33|

5. Go to the Page tab and add the actual text content to the page. For the purposes of this example,
you can just add some sample text as shown below. Click Save when you are done.
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Page Design Form Properties  Analytics

The changes were saved.

El Source | P W T & @ | B I U x x2 | 1= E M ow | = = = =
& Pl EEEEOC| BO w83
Styles ~ Format ~ Font v Size v | B A~ | 21

workgroup
= Sign Out My Dashboard | How To | Edit this page

“You have: D unread message(s) 3 active task(s)

e —

Home News Calendar Documents Media Blogs Forums Board Wiki Projects Members

Portal > Workgroups > Templste = FAQ I:I yeol

Frequently Asked Questions

Some sample text come here _..

6. At this point, the document uses an ad-hoc page template. To ensure that modifications made to a
single FAQ page will be reflected on the FAQ pages of other workgroups, the ad-hoc template needs to
be saved as a new regular page template. To do this, go to the Properties -> Template tab and click
the < Save as new page template action.

Page  Design Form Properties | Analytics
E Save
General Template
URLs = Inherit from parent
@ All culture versions use the same page template
Template > . .
) Each culture version uses its own page template
Metadata
Adhoe FAQ [ Soect
Categories
/= Save as new template. .
Navigation =
Related docs E Edit template properties
Linked docs
Inherit content

In the Save as new page template dialog which pops-up, enter the following details:

e Template display name: Intranet Portal - Work group FAQ

e Template code name: IntranetPortal. Work groupFAQ

e Template category: Intranet Portal

e Template description: enter some text describing the page template.

Click OK. This ensures that future workgroups all use the same template for the FAQ page.
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7. Now the document is complete. All new workgroups will now be created with a FAQ page. If you want
this page to be present in all workgroups, the document will have to be added to all existing workgroups
individually. However, the process is now easier since the page template created in the previous step
can be selected directly when creating the document.

Setting the default widget layout on the Home page

A special type of customization may be performed on the Home document of every workgroup. If you
select this document under one of the sample workgroups and switch to the Design tab, you will see
that it contains two widget zones: zonelLeftBottom and zoneRightWidgets.

Page | Design | Form  Properties  Analytics Display web part content

ey i . o r— . e
25 Microsoft Office Upgrade LSS

| L‘_ workgroup
T “fou have: D unread message(s) 3 aclive taskis)
2 SRR S —

News Calendar Documents Media Blogs Forums Board Wikd Projects Members

Portal > \ > Microsoft Offiee Uparade > Homa I:I yel

4

IWorkgroups/Microsoft_Office_Upgrade/Home - page template: Intranet Portal - Workgroup home page

v zonelop

|

v zoneleft |+ - ‘ zoneRight

| WorkgroupSecurityAccess @| v | Shortcuts | {3

My profile

Edit my profile

My messages

My invitations

My tasks

Create a new workgroup
Join the workgroup

KICK-OFF MEETING ON MONDAY | 11/5/2010

# | There will be a workgroup meeting on Monday at 10-00 AM_ We will discuss what needs to be done to —9—9—9:\"13_"3 e med:rork rou
&; carry out the project successfully. Inwite to workgroup

WELCOME TO THE MICROSOFT OFFICE UPGRADE WORKGROUP! | 11/3/2010

[ nmongvims 4
)

Welcome to the Microsoft Office Upgrade workgroup. This workgroup has been established in order to
' =~ ensure upgrade of Microsoft Office on all our network machines from version 2007 to the brand new
version 2010.

#, Portal home
View all news -

. Documents

These zones are customizable directly on the live site by workgroup administrators, as described in
Intranet User's Guide -> Workgroups -> Modifying a workgroup home page. On the Design tab, the
widgets in these two zones may be handled in the same way as web parts. Howewer, any changes
made in the widget zones will only affect the default layout of the widgets. Modifications made for a
specific workgroup by a workgroup administrator will not be overridden and will still be displayed on the
live site.

A full widgets reference may be found in Developer's Guide -> Development -> Widgets.

Customizing a specific workgroup

When modifying only one specific workgroup, documents may be added or deleted without influencing
other workgroups. Howeer, if you need to alter one of the existing default documents, certain additional
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steps need to be taken due to the fact that workgroups share page templates. This is demonstrated in
the following example:

1. Log on to CMS Desk and on the Content tab, select the Workgroups/Microsoft_Office_Upgrade/
Forums document in the content tree. Switch to the Properties -> Template tab and click &' Clone
template as ad-hoc. This creates a separate copy of the page template used by the Forums page and

any modifications will now only affect the document under the given workgroup.

Page  Design Form Properties | Analytics

General

URLs

Template

Matadata
Categories
Navigation
Related docs
Linked docs
Security

Attachments

E Save

Template

) Inherit from parent
) All culture versions use the same page template
@ Each culture version uses its own page template

Intranet Portal - Workgroup forums

.'___ rl
/=g Save as new template...
=

5/ Clone template as ad-hoc
_\;ﬁ-)’

E Edit template properties

Inherit content

@ Use page template settings
@ Do not inherit any content
() Inherit only master page
) Select inherited levels

2. Now switch to the Design tab and add () a Text & Images -> Editable text web part. In the Web
part properties dialog, select the Intranet content box option for the Web part container property and
enter Forum Guidelines as the Container title.
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-
(= Web part properties (Editable text) - Windows Internet Explarer

21 Web part properties (Editable text)

[E=NEERS=)

General | Layout
El Source | O A A |
=E==s= | @apP| EmE 0|
Styles ~ Format - Font - | Size - |
Web part container
Default
Visibility Web part container:
Content ) )
Container fitle:
Design
Behavicy Container CSS class:
Security

Web part container
Container custom content:

HTML Envelope
AJAX

i Hide container on subpages:
Time zones

Partial caching

HTML Envelope

Reifresh content

m Documentation
Bk @ | B I U = x x| I E o s |
0@ v &
- A | @
=]
> Inanetcofent box =] T T
v FORUM GUIDELINES
»
> (=
v O [ |
— Sk

Click OK and mowe the new web part above the existing WorkgroupForumList web part.

3. Go to the Page tab and add some text content into the region above the displayed forums. For the
purposes of this example, you can just add some sample text as shown below. Click Save when you

are done.
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Page Design Form Properties Analytics
E Save Spell check

The changes were saved.

El Source | FEl W S BE @ | B I U *=x x| EE E e 4w | = = = =
& Pl EEEEO| BoOx#E
Styles - Format - Font v Size v | B A- | 2
Wy i ) ) .
"%t Microsoft Office Upgrade dministiator : SgnOu wyDssmbomr | HowTo | St s page

1 "; l:‘_ workgroup

“rou have: D unread message(s) 3 active task(s)

e ——

Home News

Calendar Documents Media Blogs Board Wik Projects Members

Portsl * Warkaroups * Microsoft Office Uparsde = Forums I:I Je)

(L) LATESTPOSTS N

RE:How is the uparade
noing? | 11/8/2010

Just FY1: half of the computers
i 1 have already been upgraded. If
Sample forum guidelines... : everything goes well, we
' should be....

RE:How is the upgrade
going? | 11/8/2010

Well, not that | think that this
would have any positive effect
on the staff's on-line
behaviar,...

RE:How is the upgrade
going? | 11/8/2010

Oh my goodness, that's typical
of Hector, he will never
understand what on-ling
security is all...

4. Once you are finished, go to the live site, open the Microsoft Office Upgrade workgroup's website
section and view the Forums page. You should see the text that you entered displayed abowe the
forums, enclosed in the specified container.
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-‘3 Mlcrosoﬂ Oﬁ:lce Upgrade : al Administrator : Sign Out My Dashbosrd | HowTo | Editthis page

workgroup

“fiou have: 0 unread message(s) 2 aclive task(s)

Home News Calendar Documents i 3log Board Wikd Projects Members

Portal > Warkgroups > Microsoft Office Uparade > Forums I:I ye)
Forums (L) LATEST POSTS N

RE:How is the upgrade
Just FYI: half of the computers
have already been upgraded. If
Sample forum guidelines... everything goes well, we
should be...

RE:How is the upgrade

noing? | 11/8/2010
Loat post el not st | ik rat s
would have any positive effect

Microsoft Office Upgrade forums on the staffs on-line

behavior, ...

General discussion RE:How is the upgrade

BradS going? [ 11/8/2010

e s (11/8/2010 7:18:12 PM) Oh my goodness, that's typical

— of Hector, he will never
undersiand what on-line
security is all...

Al
@)
[¥5}
-
[¥%)

If you check the Forums page of any other workgroup, you will see that it is not modified.

5. In case you wish to re-use this modified page template for other workgroups, go back to CMS Desk ->
Content, select the Workgroups/Microsoft_Office_Upgrade/Forums document again and return to
the Properties -> Template tab. This time, click “# Save as new template, which will allow you to
create a new permanent page template identical to the one used by this document that can be assigned
to any other document.
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5.1

Project management

Project management overview

Project management is a tool that helps organize work and keep track of its progress on the Intranet
Portal website. This is achieved by using objects called projects that represent a planned activity with a
specific goal. Projects contain objects called tasks that are individually assigned to specific users.
Tasks do not necessarily have to be a part of any project and may also created and assigned
individually. These types of tasks are referred to as personal tasks. Every project and task has a set of
properties that are used to define its goal, time frame, priority, current status and other characteristics.

An oveniew of project management and examples of use on the Intranet Portal from the live site
perspective can be found in Intranet User's Guide -> Project Management. A full reference for the module
is located in Deweloper's Guide -> Modules -> Project Management.

Projects can be created, viewed and managed either on pages (documents) containing the Project list
web part or through the administration interface. When a project is created on a certain document, it is
bound to that specific document. Projects may only be accessed on the document that they are bound
to. There are seweral types of projects available on the Intranet Portal:

e Department projects
e Workaroup projects
e Ad-hoc projects

The website also uses other types of web parts and widgets that allow users to interact with projects
and tasks. These web parts may be configured (“#) as necessary. Information about all project
management web parts and their properties can be found in Developer's Guide -> Modules -> Project

Management -> Project management web parts and widgets.

The master page of the website and individual master pages of departments and workgroups contain the
Task info panel web part. This web part displays the amount of active tasks that are assigned to the
current user and senes as a direct link to a page showing task details (this document is described
below). Due to being placed on the master pages, the web part is available in the header of all pages.
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Live Site  Site Manager Intranet Portal B 2 Global Administrator v v6.0.4237 E ] Sign On

Mydesk Tools Adminisiration  E-commerce  Online marketing ! Enterprise Marketing Solu
= [ [#copy i Up Y —
New na%fe & Move I Down - Pr@ew Lls Search ‘
Content View mode Other -
) Intranet Portal * Page |Design | Form Masterpage  Properties  Analytics ¥ Dispiay web part content
[] Home® =]
] Company*®
|| Departments® zonelogo
[ workgroups® v Logolmage {3
[l Documents* yvlﬁf‘ra_r‘\et Solution

D News © L e

e e
D Media®

|] Blogs® : LanguageSelector

] Forums®

. —
| Emelovess EditDocumentLink | Edit this page
] Search®
My Dashbosrd | HowTo

|] Rss*®
8 Logon® SignOutButton Sign Qut
e Global Admi 3

CurrentU Global Administrator :
i Special pages® urrentUser

1 Czonelexeoton o 4
~ | TaskinfoPanel 3 cobve tasids]
n MessagingInfoPanel You have: D unread message(s)

H:umpany Depariments ‘Workgroups Documents News Events Media Blogs Forums Employees

- |znneBmad(:mmlxi |+
| v ‘ MainBreadcrumbs ‘ s ‘

Further project management web parts can be found on the Employees/Management/My projects
and tasks document, which implements a part of the employee profile. Here, projects and tasks relevant
to the current user can be seen. The web parts on this document also allow users to create new
personal tasks.
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2 Intranet Portal
e Kentico .
#1%  CMS Desk My desk s Administration  E-commerce  On-line marketing Enterprise Marketing Sol
E [q r
New  Delete |5 Move & Down Preview  Live site List Search
Content management View mode Other
) Intranet Portal Page | Design | Form Properties Analytics [¥] Display web part content
D Home
[ company o >
2% 7 Kentico al Administrator : Sion Out My Dashbosrd | HowTo | Editthis pege

D Departments
D Workgroups
|1 Documents

~# 70  Intranet Solution

You have: D unread message{s) 3 sefive task(s)

D News -
D Events Home Company Departments ‘Workgroups Documents News Events Media Blogs Forums
[ Media
[ Blogs Employees > Management > My projects and tasks \:I )
D Forums
D Employees - — _
[ My dashboard é.’Em ees/Managemen ts and tasks - page template: Intranet Portal - Profile - My tasks 2| ) Shortcuts
|1 profile = |zoneTop o My profile
B Tanagament Sl & IEAT my profile
|] Invitations My invitat
- = ly invitations
[ Messages - sdiavietet B2t and tasks My it
] My projects and tasks Create a new workgroup
|1 search > MyProjects @I
[] rRss
D Logon : Progress. Name Deadline Owner Status
) Files H || 52%  Microsoft Office Upgrade 11/30/2010 7:41:33 PM Brad Summers (BradS) {3
5 Special pages
|| 38% Network Upgrade Brad Summers (BradS) Q _
&) My blogs

You currently do not have

v TasksAssignedToMe iaal any blogs

[} New personal task

Actions Title Deadline Owner Project Priority Status
R L testlk Normal ()
i & testand Personal task 1 Global Administrator (administrator) Normal (@
# testjand Personal task 2 Global Administrator (administrator) Normal (D

@ My workgroups

You are currently not

¥ TasksOwnedByMe &3
member of any

[} New personal task workgroup

Alternatively, users with access to CMS Desk may also view their tasks and projects under the various
tabs at My Desk -> Projects.

y Live Site Intranet Portal B3
e Kentico
1% OMS Desk Content [EEVENESS  Tools  Administration  E-commerce  On-line marketing
My dashboard My profile Blogs Friends Messages
Dashboards My Data
[§] Projects

My tasks | My projects  Tasks owned by me

| New personal task

~ Actions Title Progress Estimate (hours) Owner Deadline Project Priority Status
Z® 4 & RFPpreparation 50% 0 Brad Summers (BradS) Network Upgrade  Normal b3
f x T & Vendor Selection  JJ 10% 0 Brad Summers (BradS) MNetwork Upgrade  MNormal oy

Project management general configuration

There are sewveral possible configuration options that affect all types of projects and tasks. The statuses
and priorities that can be set for projects or tasks may be defined on the Configuration tab of the CMS
Desk -> Tools -> Project management interface.
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AR Live Site Intranet Portal [
CMS Desk Content My desk Administration ~ E-commerce  On-line marketing
@ Pols [l Custom tables &1 Forums [F] Message boards 'P& [&] Reporting
Forms  Media ™ Staging [f3 File import Blogs  fa Groups |e| Abusereport Projects | Events Newsletters (5] Web analytics
Content Community Collaboration Marketing & Reports
|§] Projects
Projects  Tasks | Configuration
@ Project statuses
Project statuses » @ New project status
Task statuses
Task priorities = Actions Name Color Icon Is not started status Is finish status Enabled
F W & Notstared @ Yes No Yes
FRa4§ | Ontrack B No No Yes
R4 § | Atrsk o Mo No Yes
Ve & Critical FoN No No Yes
re 'S Canceled b4 No No Yes
re 4 Finished « No Yes Yes
Additional settings may also be specified at Site Manager -> Settings -> Intranet & Collaboration ->
Projects as described in Deweloper's Guide -> Modules -> Project management -> Settings.
To ensure that users are aware of task assignments or any events related to tasks they are involved
with, project management uses a system of notification e-mails that are automatically sent when
required. The format of these e-mails is based on specific e-mail templates, which may be customized
at Site Manager -> Administration -> E-mail templates. The following project management templates
are available:
e Project Management - New task - sent when a new task is assigned to the user.
e Project Management - Changed task - sent when an assigned or owned task is in some way
modified.
e Project Management - Overdue task - sent when an assigned task reaches its deadline before it
is finished.
* Project Management - Task reminder - sent when the Send reminder () button is used for an
assigned task.
5.2 Department projects

Each Intranet Portal department has a dedicated sub-section, where its projects can be managed from
the live site by users with access to the department. For departments using the default structure, this
functionality is provided by the Project list web part on the Projects document.

© 2014 Kentico Software


http://devnet.kentico.com/docs/7_0/devguide/project_management_settings.htm
http://devnet.kentico.com/docs/7_0/devguide/managing_e_mail_templates.htm

Project management 77

o Site Manager  [Intranet PortallBa Global Administrator ¥ V6 ® sign
Kentico
CMS Desk My desk T Administration ~ E-commerce  On-line marketing Enterprise Marketing So|
[= [= Co Uy -y —
=) Qoo & e (] L
New  Delele |= Move J} Down Preview  Live site List Search
Content management View mode Other
f‘vi Intranet Portal o Page | Design | Form  Properties  Analytics Dlsplay web part content
C] Home
|1 Company -
D Departments IT . dministrator : Sign Out My Dashboard | How To | Edit this page
&8 Customer Care® department
58 Finance® - “You have: 0 unresd message(s) 3 sciive task(s)
o8 HR* -
V- Bind Home News Calendar Documents Media Blogs Forums Wikd Members
D Home
[ News Portsl > Degariments > [T > Projects
D Calendar
D Documents —
D Media ;.'De rtments/IT/IProjects - e template: Intranet Portal - Department projects 2
| Blogs = zoneTop o
9 Forums = zoneCenter o
[0 wiki
2 Projects = = | HeaderText | {3
[ Members il
B Rrss o H ProjectList
D Search Actions Name Deadline Owner Status Progress
-
: Manageme‘ﬂt # % Network Upgrade Brad Summers (BradS) Gz W 38%
Marketing
58 production® "20"950“-0"1 ‘*
A sales*
] Template®

Projects from all departments and their tasks can be administered at CMS Desk -> Tools -> Project

Management.
7 Live Site Intranet Portal B3
|_(e_ﬂtl.C0
CM5 Desk Content My desk Administration ~ E-commerce  On-line marketing
I @ Polls  [Hjl Custom tables "I 84 Forums [5] Message boards Iﬂ = [&] Reporting
Forms  Media Bg Staging Lﬁ File import Blogs & Groups E Abuse report Proiéc{s Events Newsletters r_.f.j Web analytics
Content Community Collaboration Marketing & Reports
E‘ Projects
Projects | Tasks  Configuration
[Z—g MNew project
~ Actions Name - Deadline  Owner Status  Progress
7R Network Upgrade Brad Summers (Brads) B ] 38%

In order for department projects to be available on the live site, their Project page property must contain
the path to the document where they should be displayed, for example /Departments/IT/Projects. The
value of this property can be set during the creation of a new project or when editing (#) an existing
project on its General tab.
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5.3

E] Projects

Projects | Tasks  Configuration

» Projects » MWetwork Upgrade

Tasks | General | Security

Display name: MNetwork Upgrade
Code name: Metwork_Upgrade_general_5936a4fa-9963-428f
Plan for a major upgrade of our -

network infrastructure.

Project goal:

Start date: @ Now

Deadline: @ Moy

Progress: [ ] 38%

Owner: Brad Summers (BradS)
Status: On track |T|

(E'FOiECT page: /Departments/IT/Projects

Allow task ordering:

e

If you customize the website and create a document containing the Project list web part outside of a
department somewhere on the global part of the portal, the projects created there will also be available at
this location.

A full reference for the project management module can be found in Developer's Guide -> Modules ->
Project Management.

Workgroup projects

Project management is also integrated into workgroups. Workgroup projects only operate within the
scope of the workgroup that they belong under, which means that tasks can only be assigned to
workgroup members, project security settings can be configured for workgroup roles instead of global
site roles etc.

Similar to departments, each workgroup has a dedicated sub-section, where its projects can be
managed from the live site by users with access to the workgroup. For workgroups using the default
structure, this functionality is provided by the Project list web part on the Projects document.
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Intranet Portal B3

Mydesk Tools Administration  E-commerce  Online marketing ! Enterprise Marketing So

3 [ Oow tw o 2
New Dslste [ Move { Down Preview  Live site List Search
Content nt View mode Other
) Intranet Portal || Page |Design | Form  Properties  Anahtics [¥] Disptay web part content
D Home
[] Company ey . -
= pame R 1 al Administrator : Sion Out My Dsshbosrd | HowTo | Editthis pege
[ Departments “t'5 Microsoft Office Upgrade .
L] workaroups 1\ Ul workgroup
[0 Template® *‘ “You have: 0 unresd messsge(s) 3 sctive tasi(s)
| Create -
i + lome ews Calendar ocuments edia 3logs orums 3oart ki Members
1 Marketing_stratsgy H N Calend D 1 Medi B F Board | Wiki Memb
D Microsoft_Office_Upgrade |
[ Home Portal > Werkgroups > Miorosof Offe Upgrade > Frojects .,
D News
D Calendar —
[} Documents é rou| icrosoft_Office_Upgrade/Projects - page template: Intranet Portal - Workgrou jects 2
[ Media v zoneTop ds
9 Blogs = | zoneCenter )
] Forums E =
11 Board | WorkGroupSecurityAccess |@|
[0 wiki 4 ~ | editabletext | 3|
D Projects M
1 e st
D Access " "
= ctions Name ine er atus Progress
[} Management Acti Ni Deadii ‘Own Status Pri
[] RSS ##®  Microsoft Office Upgrade 11/30/2010 7:41:33 PM  Brad Summers (BradS) {3 1l 52%
- |51 search V|znneBoltum |+
|| Tradeshow_in_Las_Vegas
[ New_Product_Line*

All projects associated with a workgroup can be accessed by editing the given workgroup via the CMS
Desk -> Tools -> Groups interface and switching to the Projects tab.

3 Live Site Intranet Portal B
3i¢ Kentico

1% CMS Desk Content My desk Administration ~ E-commerce  On-line marketing

H @ Polls [ Custom tables "I 84 Forums Message boards = [E] Reporting
Forms  Media ®§ Staging [f3 File import Blogs la] Abuse report Projecls Evenis | Newsletters (5] Web analytics
Content Community Collaboration Marketing & Reports

& Group properties

» Groups » Microsoft Office Upgrade

General  Security  Members Roles  Forums  Media libraries  Message boards  Polls | Projects

[@ Mew project
~ Actions Name - Deadline Owner Status Progress
7R Microsoft Office Upgrade  11/30/2010 7:41:33 PM  Brad Summers (BradS) B I 52%

In order for workgroup projects to be available on the live site, their Project page property must contain
the path to the document where they should be displayed, for example /Work groups/
Microsoft_Office_Upgrade/Projects. The value of this property can be set during the creation of a new
project or when editing (#) an existing project on its General tab.
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5.4

& Group properties

» Groups * Microsoft Office Upgrade

General  Security  Members  Roles  Forums — Media libraries  Message boards  Polls | Projects

» Projects » Microsoft Office Upgrade

Tasks | General | Security

Display name: Microsoft Office Upgrade
Code name: Microsoft_Office_Upgrade_group_fc6918d8-9913
Upgrade Microsoft Office on all -
OuUr netwWwork computers to wersion
2010.
Project goal:
Start date: 11/3/2010 7:41:24 PM @M
Deadline: 11/30/2010 7:41:33 PM @M
Progress: ] 52%
Owner: Brad Summers (BradS)
Status: On track -]
( Project pags: Workgroups/Microsoft_Office_Up Select I Clear '

Allow task ordering:

——

A full reference for the project management module can be found in Developer's Guide -> Modules ->
Project Management.

Ad-hoc projects

Site administrators or developers may create projects for their own purposes directly in CMS Desk ->
Tools -> Project Management, without specifying any document to which the projects should be
bound. Projects of this type may only be managed through the administration interface and are not
visible on the live site.

Live Site  Site Manager Intranet Portal B3

Kentico
CMS Desk Content My desk Administration ~ E-commerce  On-line marketing
= = Polls Custom tables & Forums [7] Message boards =4 Reportin
E g O @ W 3 oo @ vesoronss| TR 18 | (g W neors
Forms  Media Bg Staging [ File import Blogs &; Groups i Abuse report Projects | Events Newsletters ﬁ.j Web analytics
Content Community Collaboration Marketing & Reports
E] Projects
Projects | Tasks  Configuration
[5__3 MNew project
~ Actions Name - Deadline Owner Status Progress
7R Network Upgrade Brad Summers (BradS) B B 38%
f x Sample ad-hoc project Global Administrator (administrator) @ 0%

The difference between these ad-hoc projects and standard projects is that the value of their Project
page property is empty.
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IE_] Projects
Projects | Tasks  Configuration

» Projects » Sample ad-hoc project

Tasks | General | Security

Display name: Sample ad-hoc project
Code name: Sample_ad-hoc_project
This is an example of an ad-hoc -
project.
Froject goal:
Start date: 81772011 11:32:01 AM | & Now
Deadline: @ Now
Progress: 0%
Owner: Global Administrator (administrato

Status: Mot started

Allow task ordering:

——

Tasks under ad-hoc projects are shown normally by the appropriate web parts and widgets and in CMS
Desk -> My desk -> Projects.

Ad-hoc projects may be converted to projects visible on the website simply by entering the path to a
document containing the Project list web part into their Project page property, which can be set when
editing (#) a project on its General tab.

A full reference for the project management module can be found in Deweloper's Guide -> Modules ->
Project Management.
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6.1

Document libraries

Document libraries overview

Document libraries provide live site users with a convenient way of files storage on the intranet, without
the need to access the user interface of the system. These libraries are located at three places on the
portal:

e In the global section.
¢ In each department's dedicated website section.
¢ In each workgroup's dedicated website section.

In Intranet User's Guide -> Document libraries, you can find a detailed oveniew of the document libraries
on the portal and instructions on how they can be used by live site users.

A full reference on the Document library module is located in Developer's Guide -> Modules ->
Document library. The chapter contains examples based on the Intranet Portal website, including a
step-by-step guide on creating a new document library, so please refer to it in case that you are looking
for this type of information.

:q. New document ﬁ Library permissions

Document name - Modified Workflow step
v W] Dress Code 10/15/2010 2:50:48 PM  Published
v ] Equal Opportunities 10/15/2010 2:50:52 PM  Published
v ] |ntellectual Property Policy 10/15/2010 2:50:56 PM  Published
v ] Network and Software Use 10/15/2010 2:51:01 PM  Published
v I Our Core Values 10/15/2010 2:51:05 PM  Published
v 2 Travel Expense Report 10/15/2010 2:51:09 PM  Published
v 8 Travel Expense Reporting 10/15/2010 2:51:12 PM  Published
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7 Other features

7.1 RSS feeds

The portal contains numerous RSS feeds of blog posts, events, forum posts and news published in
the portal's global section and in each department's and workgroup's dedicated website section. The
feeds are created using web parts of the Syndication module. A full reference on the module can be
found in Developer's Guide -> Modules -> Syndication. In Intranet User's Guide -> Other features -> RSS
feeds, you can find a detailed summary of the available feeds and an explanation of how the feeds can
be used by live site users.

RSS feeds in the content tree

The RSS feeds are provided by a set of dedicated special pages. These special pages can be found at
three locations:

1) RSS feed pages for the content of the portal's global section are located under the RSS document in
the root of the content tree, as depicted below.

q-_’J Intranet Portal
,_1 Home
| Company
|1 Departments
,_1 Workgroups
Documents

|

[ News

,_1 Events

[ Media

[ Blogs

,_1 Forums

,_1 Employees

|| Search

|4 Rss
,_1 Blog posts
[] Events
[71 Forum posts
,_1 News

] Logon®

i Files

& Special pages

2) RSS feed pages for content of particular department sections are located under the RSS document in
each department's dedicated website section.
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,_1 Departments
SR Finance®
[] Home
I_] News
[ calendar
I_] Documents
[] Media
I_] Blogs
[ Forums
[ wiki
I_] Projects
[ Members
|1 RSS"
I_] Blog posts
I_] Events
[ Forum posts
[] News
] Search®

3) RSS feed pages for content of particular workgroup section are located under the RSS document in
each workgroup's dedicated website section.

I_] Workgroups

[] Template*

I_] Create

[] Marketing_Strategy®
I_] Home
[ Mews
[ calendar
I_] Documents
[ Media
[} Blogs
I_] Forums
[ Board
[ wiki
I_] Projects
[] Members
[ Access

|| RsS

|1 Blog posts
[] Events
,_1 Forum posts
[ News

= Search™

RSS feed web part configuration

RSS pages of news, event and blog post feeds contain two interconnected web parts: a Documents
data source and an RSS repeater.

The Documents data source is used to retrieve data records for the feed from the system's database
and provide them to the RSS repeater. From all its properties, the following are configured to ensure the
required functionality (the sample values are taken from the Departments/IT/RSS/Blog posts page):

e Web part control ID: DocumentsDataSource; code name of the data source (used for connection to
the RSS repeater).
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e Path: {%cmscontext.currentdepartment.nodealiaspath%}/Blogs/%; documents under this path will
be provided by the datasource. The macro is used to retrieve the alias path of the current
department's parent document.

e Class names: CMS.BlogPost; only documents of this type located in the specified path will be
provided by the datasource.

e ORDER BY Expression: BlogPostDate DESC; ordering of provided documents.

e Select top N documents: 15; only the 15 top documents will be provided (based on the ORDER BY
expression sorting).

The RSS repeater ensures that the page becomes the actual RSS feed, i.e. that the URL of the page
will be the actual URL of the feed. From its properties, the following are configured to ensure the required
behavior:

e Feed name: blogposts; name of the feed used for its identification (typically used if you have more
than one feed on a single page).

e Feed title: Latest {%cmscontext.currentdepartment.documentname%} department blog posts; title
of the feed. The macro is used to retrieve the name of the current department.

e Feed description: Latest {%cmscontext.currentdepartment.documentname%} department blog
posts RSS feed.; text describing the feed. The macro is used to retrieve the name of the current
department.

e Data source name: DocumentsDataSource; code name of the datasource that provides documents
for the feed.

e Transformation name: IntranetPortal. Transformations.SecuredBlogPostRSSItem; transformation
used to transform provided documents to the feed format.

Page | Design | Form  Properties  Analytics Display web part content

»
= %7 Kentico

» 7% Intranet Solution

“fou have: O unread message(s) 2 active task(s)
R

Home Company Workgroups Documents News Events Media Blogs Forums Employees

Departments * Finance > RSS > Blog posts I:I yel

4

{Departments/Finance/RS $/Blog posts - page template: | Portal - Dep RSS blog posts | 2
zoneCenter L]
v | | 2 DocumentsDataSource | {3

4

v | i RSSRepeater {u

Forum post RSS feed pages are created in a similar manner. They also contain an RSS repeater, but
the data is provided to it by a Forum posts data source instead of the Documents data source
described above. However, configuration of the web parts is very similar.

The Forum posts data source has its properties configured the following way (the sample values are
taken from the Departments/IT/RSS/Forum posts page):

e Web part control ID: ForumPostsDataSource; code hame of the data source (used for connection
to the RSS repeater).

e Forum name: all; ensures that posts from all forums on the site should be provided, the posts are
then filtered using the WHERE condition below.

e Select only approved: enabled; ensures that only approved posts will be provided (in case that
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forum moderation is enabled).

ORDERY BY expression: PostLastModified DESC;

Select Top N posts: 15;

WHERE condition: GroupName = 'Department_{%cmscontext.currentdepartment.nodeguid%]}’
Select columns: PostGUID,PostSubject,PostIDPath,PostForumID,ForumSitelD;

The RSS repeater has the following properties configuration:

Feed name: forumposts; name of the feed used for its identification (typically used if you have more
than one feed on a single page).

Feed title: Latest {%cmscontext.currentdepartment.documentname%?} department forum posts; title
of the feed. The macro is used to retrieve the name of the current department.

Feed description: Latest {%cmscontext.currentdepartment.documentname%} department forum
posts RSS feed.; text describing the feed. The macro is used to retrieve the name of the current
department.

Data source name: ForumPostsDataSource; code name of the datasource that provides
documents for the feed.

Transformation name: IntranetPortal. Transformations.SecuredForumPostsRSSitem;
transformation used to transform provided documents to the feed format.

Home Company De ents Workgroups Documents Mews Events Media Elogs Forums Employees
Departments > Finance > RSS > Forum posts /O
- | IDepartments/Finance/RSS/Forum posts - page template: Intranet Portal - Department RSS forums | 2
v zoneCenter o

= | | g ForumPostsDataSource {3

|v i RSSRepeater @|

Links to RSS feeds

Links to particular RSS feeds can be found throughout the whole portal. The first location where you may
come across them are the Home pages, both the global one and the ones of departments and
workgroups. The feeds are accessible under the &\ icons in widgets displaying latest news, blog posts
and forum posts (only on department and workgroup Home pages). Displaying of these links is ensured
by the code of the Intranet content box RSS and Intranet column box RSS web part containers,
which are used to encapsulate the web parts.
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(& auick Links Welcome to Your New |ntranet Employee of the month

-
«» Employees This is a ready-to-use intranet that you can use out of the box. Or you can customize it as

Documents you need. For more information on how to configure your intranet, please see the Intranet
. Guide.

i/ Departments
42 Workgroups [ oestens N |
SCHEDULED NETWORK MAINTENANCE | 1011212010

Due to the scheduled upgrade of our network infrastructure, the local network
Ib ‘ as well as our VPN will not be available during this Saturday, between 6am
b

- and Bam.

[ upcomma EvenTs N RECORD SALES IN Q3 | 1011212010
01/04/2011 Company Plans 2011 (Feemm  The third quarter was the best quarter in our historyl We grew the sales i POLL
06/04/2011 Family Weekend .4 Dby 70% yearto-year. Thanks to everybody to their hard work.
1001272011 Strateqy Meeting "! How do you like our new portal?
12/16/2011 Christmas Pal

NEVI SALES OFFICE I NEW YORK | 101212010 = Very satisfied

We have just opened a new sales office in New York. It will be managed by - satefied
- Jennifer Wilson. The office is located on the §th avenue. ® Neutral
) Dissatisfied

View all events

NEW CFO JOINS OUR COMPANY | 10/12/2010 (@] Very dissatisfied

Colin Douglas joins our company as a new CFO. He will oversee the Finance
v (?
CANTEEN MENU ‘s=¢,  department. Colin previously worked in Nebraska Finance Group. He M

Canteen menu for this week: f graduated from Harvard and has three daughters.

MON:  Grilled pork chop gamni -
TUE: Bacon zwche P Viewialinews
WED: Ruoast of the day
THU:  Cottage pie

FRI: Fish pie

LATEST BLOG POSTS &

The other location where links to RSS feeds can be found are the particular News, Events, Forums and
Blogs pages, both in the portal's global section and in particular department and workgroup sections. On
the Forums page, the feed is accessible under the M icon in the web part container of the Latest posts
repeater, similarly as described above.

Home Company Departments Workgroups Documents Events Media Blogs

Y

Forums © watest rosTs
RE:How can we improve our

= = Have you seen the latest
Intranet Discussion version? We have already
Intranet discussion forum group. simplified it as much as

possible. If you stil...

On the other pages, the respective feeds are accessible under the EX icon next to the page's title (as
highlighted abowe). This time, the link is added to the page using the Feed link web part, whose Feed
URL property is configured to the path of the respective feed's page (e.g. ~/RSS/News.aspx in case of
the global section's news).
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Home Company Departments Workgroups Documents BWS Events Media Blogs Forums Employees
News]
Add news
Colin Douglas joins our company as a new CFO. He will oversee the Finance department. Colin previously worked in MNebraska Finance
'|=§} Group. He graduated from Harvard and has three daughters.
Security of department and workgroup feeds
RSS feeds of department or workgroup content contain only titles of the new content. These titles work
as links to the page where the new content is published. This happens for security reasons, as RSS
feeds cannot be secured and anybody who knows the feed URL can subscribe to it. To prevent users
without appropriate permissions from viewing secured content, only links are included in the feeds. This
way, users hawe to log on to the secured portal to see the actual content.
& Lstest IT department news - Windows Internet Explorer E@g
& () = [&] http://tocalhost/KenticoCMs 1130/ Depertments/IT/RSS/News.aspx ~[4+] x|l 8ing 2 |
5l Favorites ‘ 5% @& Suggested Sites ¥ & Get More Add-ons
I@Latestl'rdepartmentnews | & - * [ @ > Page~ Safety v Tools~ @' ”
Latest IT department news Displaying 272
You are viewing a feed that ins freq ly updated When you subscribe to a feed, it is added to the
Comman Feed List. Updated information from the feed is automatically downloaded to your computer and can be viewed in
Internet Explorer and other programs. Learn maore about feeds. @ Al 2
& Subscribe to this feed Sortibiy 77777777777777777777 i
= Date 1
Title
MNew internal rules of the IT department
>
New intranet launched B
EY
Done Protected Mode: Off 3 v ®100% -
7.2 Search

The portal comes with built-in index-based search functionality. Using it, it is possible to search for text
in website content and in the website's discussion forums. The whole functionality is provided by the
Smart search module. Full documentation of the module can be found in Developer's Guide -> Modules
-> Smart search.

Smart search indexes

The Smart search module provides indexed-based search using the Lucene search engine. For your
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website's content to be searchable, the content must be indexed by some of the smart search indexes
defined in Site Manger -> Administration -> Smart search. As you can see in the screenshot below,
the portal comes with an extensive number of default smart search indexes, so that all its default
content is already pre-indexed and fully searchable.

There are two basic types of indexes: Documents indexes for content of documents and Forums
indexes for content of discussion forums. Primarily, there are two indexes for content of the portal's
global section: Intranet Portal - General content and Intranet Portal - General forums. The first one
is for content of the global section's documents, while the second one is intended for indexing of the
global section's forums. The two indexes are highlighted in the screenshot below.

Apart from the global section's indexes, two indexes are also created automatically when a new
department or workgroup is created. These indexes are only used for search of the particular
department's or workgroup's website section, as described further below. You can identify them by the
display name of the department or workgroup present in the name of the index (e.g. Finance - Default
and Finance - Forums are indexes of the Finance department).

CMS Desk  User: A Global Administrator v v6.0.4258 @  Sign Out

.
#1% Site Manager JEIUEISSON  cetfings  Development  Tools  Dashboard  Licenses  Support  Buy
Administration 5y Smart search indexes ?
Avatars
@ Bad words 3 Hew index
‘Q Badges
28 Banned IPs + Actions Display name - Last rebuild time Index type  Index status.
¥ Categories
& Email quene A ®@B ~  Finance - Default 8/29/2011 12:11:33 PM  Documenls  Ready
) E-mail templates ##®®B ~  Finance - Foums 8/29/2011 12:11:33PM  Forums Ready
[ Event log FH®B~  HR-Default 8/28/2011 121140 PM  Documents  Ready
9 Integration bus
é m gh n - HR - Forums 8/20/2011 12:11:40 PM__ Forums Ready
embership — —
4 permissions # B ~  Intranet Portal - General content 8/29/2011 12:11:52 FM  Documents  Ready
R ecycle bin hd ntran ortal - General forums orums eady
3] Recycle bi Intranet Portal - General f 812972011 12:1153PM  Fu Read
g Roles 8B~ IT-Default 8/29/2011 121201 PM  Documents  Ready
) Scheduled tasks
- IT - Forums 8/29/2011 12112202 PM  Forums Read:
3] Smart search 7R® v
I, SMTP servers @B~  Management- Default 8/20/2011 121209 PM  Documents  Ready
& system Z¥®® ~  Management - Forums 8/29/2011 121210 PM  Forums Ready
S El personalization A RB ~  Wareing Strategy - Default 8/29/2011 121216 PM  Documenls  Ready
@ Users ) -
& Web farm 4 RSB~ Marketing Strategy - Forums 8/29/2011 121216 PM  Forums Ready
N ARS8~ Microsoft Office Upgrade - Default  8/28/2011 121223 PM  Documents  Ready
Z WP~ Microsoft Office Upgrade - Forums  8/20/2011 12:1224 PM Forums Ready
A ®B ~  PRE&Marketing - Default 8/29/2011 12:1230 FM  Documents  Ready
A RB ~  PREMarketing - Forums 8/29/2011 121230 PM  Forums Ready
##®@B ~  Production - Default 8/29/2011 121236 PM  Documents  Ready
# ¥ @~  Production - Forums 8/28/2011 12:12:36 PM Forums Ready
BB~ Salkes - Default 8/20/2011 12:1243PM  Documents  Ready
A RB ~  Sakes-Foums 8/29/2011 12:1243PM  Forums Ready

# W@ ~  Tradeshow in Las Vegas - Defaull  8/28/2011 121250 PM  Documenls  Ready
# ¥ ~  Tradeshow inLas Vegas - Forums  8/28/2011 121251 PM Forums Ready

Items per page: 25 El

Searching on the live site

On the live site, the search functionality is provided by the Smart search box web part. The web part is
placed below the main menu on master pages, both the global one and the ones used for department
and workgroup sections.

Company Depariments ‘Workgroups Documents News Evenis Media Elogs Forums Employees

o m

Among the web part's properties, the following configuration is the most important:
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e Search button CSS class: CSS class used for the search button next to the textbox. In this case,
the SearchButton CSS class ensures that the # icon is used for the purpose.

e Search textbox CSS class: CSS class used for the textbox where searched text is entered. The
SearchTextBox class is used by default.

e Search results page URL: URL of the page where search results should be displayed. The target
page must contain either the Search results or the Smart search dialog with results web part with
proper configuration in order for search results to be displayed.

e Search mode: type of search matching. Determines if a match (search result) should be returned if
any word/all words/exact phrase is found in the searched content.

As you can see, the actual indexes to be searched are not set in the properties of this web part.
Contrary to that, the indexes are selected in properties of the Smart search dialog with results web
parts placed on the search results pages where users get redirected after submitting the search
request.

' ™
(= Web part properties (Smart search box) - Windows Internet Explorer @M
21 Web part properties (Smart search box) mm

General | Layout 57
Search box settings
Default
Search button text: o
Visibility
Search box settings Search button C35 class: » SearchButton
Button settings F
Web part ontunel Search label text: 4
HTML Envelope =
Search label CSS class: 3
AIAX
Time zones Search textbox CSS class: + SearchTextBox o
Partial caching
Search results page URL: » ~/Search.aspx
Show search label: r [
Search mode*: »  Any word |Z|
Button settings
Show image button: r [
Refresh content [ Ok~ Cancel | Apply
A A

Search results pages

The search result pages are special pages where search results are displayed to users. There are three
locations of search result pages:

e ~/Search.aspx - this page displays search results when searching content of the global section.

e ~/Departments/<department name>/Search.aspx - each department has its own search results
page where search results are displayed when searching the department's section.

e ~/Workgroups/<workgroup name>/Search.aspx - each workgroup has its own search results
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page where search results are displayed when searching the workgroup's section.

- [} Template*
b_;]_lntranet Portal & ) Intranet Portal [ create
1| Home [[] Home [ Marketing_Strategy*
| Company [} company [l Home
|] Departments [] Departments [0 News
9 Workgroups SR Finance® [ calendar
g Documents [ Home || Documents
| News [ News 0] Media
g Everlwts g Calendar [ Blogs
9 Media || Documents || Forums
L] Blogs [] Media [] Board
|1 Forums [] Blogs [ wiki
- mplovees [ Forums [ Projects
i m ] wiki || Members
RSS [] projects [ Access
[] Logen [[] Members [[] Management
5 Files [ RSS | 1 RS5

Global search results

The global section's search results are displayed on the ~/Search.aspx page. On this page, the
Search dialog with results web part is placed, with its Indexes property configured to
IntranetPortal. GeneralContent;IntranetPortal. GeneralForums. This ensures that when a user enters the
searched text into the search box anywhere in the global section, they are redirected to the ~/
Search.aspx page, where the web part displays search results found in the two indexes.

Department and workgroup search results

Particular departments and workgroups have their own search results pages. In master pages of the
department and workgroup sections, the following values are entered in the Search results page URL
property of the Smart search box web part:

e Departments: ~{%cmscontext.currentdepartment.nodealiaspath%}/Search.aspx
e Workgroups: ~/Workgroups/{%communitycontext.currentgroup.groupname%?}/Search.aspx

This ensures that users are redirected to the correct search results page when searching a department
or workgroup. These search results pages also contain the Search dialog with results web parts. The
web parts are configured so that in the Indexes property, the following macros are used:

e Departments: default_department_{%cmscontext.currentdepartment.nodeguid%};
forums_department_{%cmscontext.currentdepartment.nodeguid%}

e Workgroups: default_group_{%communitycontext.currentgroup.groupguid%};forums_group_{%
communitycontext.currentgroup.groupguid%}

These macros ensure that correct smart search indexes are selected, depending on the department or
workgroup where the search is currently being performed.
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Home Comp

Emplo:

Search

Search

Search for: intranet
Search mode: | Any word |z|

Search

Home

Welcome to Your New Intranet This is a ready-to-use intranet that you can use out of the box. Or you
can customize it as you need. For more information on how to configure your intranet, please see the
Intranet Guide.

e hitp://localhost/KenticoCMS_r2/Homepage.aspx 7/19/2010 10:16

Logon

Please Log On Welcome to the Kentico Intranet Solution. In order to see the content, you need to log
on. You can use the default user name administrator and leave the password blank.

]

e http://localhost/KenticoCMS_r2/Logon.aspx 7
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8.1

Customizing the portal

Changing the themes

The portal comes with three default themes - Blue, Green and Red, as described in Intranet User's
Guide -> Other features -> Available themes. These themes can be applied separately to the global
section of the portal and to particular departments and workgroups. While the global section themes and
departments documents themes can only be changed by the system administrators via the system
administration interface, the themes of workgroups documents can be changed by both the system
administrators and workgroup administrators. As the global administrator, you can thus not only add
your custom color themes, but also change the themes on all the three different lewels:

Global section

1. Globally for the whole site

If you need to change the theme for the whole site, log on to Site Manager -> Sites and choose to Edit
(#) your intranet site. On the General tab of the Site properties page, choose the required theme from
the Site CSS stylesheet drop-down list and click OK. If you now go back to CMS Desk or live site, all
portal pages inheriting their theme from the portal global settings will have the color you have just
chosen. Please note that if you choose (none) from the Site CSS stylesheet drop-down list, your portal
pages will lack a theme unless you choose one as described below.

e’ entico

#1N Site Manager Administration Settings Development

GJ Site properties

» Sites » Intranet Portal

{ General l Domain aliases  Cultures  Off-line mode

Site display name: Intranet Portal
Site code name: IntranetPaortal
Site domain name: localhost

Default content culture: English - United States

Default visitor culture: Automatic) E
Site CSS stylesheet:  Infranet Portal - Blue [~] [ New |

Editor CSS styleshest: | (site stylesheet) Edit ﬁ
Site description: Intranet portal site -
ok

2. Globally for the root in the content tree

Another way to globally change the theme of the Intranet Portal is to choose one for its root. Log on to
CMS Desk and choose the root from the content tree. Now select the theme that you would like to use
on the Properties tab in General -> CSS stylesheet . Please note that selecting (default) from the
CSS stylesheet drop-down list will result in applying the theme set in step 1. To save the theme for the
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portal root, click & Save. From now on, this theme will be used for all portal pages inheriting from the
root or from a parent inheriting directly or indirectly from the root.

Live Site  Site Manager |Intranet Portalbd & Global

e Kentico
L)

CMS Desk My desk  Tools Administraion  E-commerce  On-line marketing
Col 4] T | —
B & oy 4 up 4| [d
New  Delete o Move J} Down Edit Preview Live site List Search
Content management View mode Other
q* Ei Intranet Portal l Page Design Form  Master page [Praperties ﬂ Analytics
Home
[J] company E Save
g Departments Pl 5
|1 Workgroups Design
— URLs
- Documents : T
CSS stylesheet: Intranet Portal - Blue
B News — ty L [ New |

3. Separately for different pages

On the Intranet Portal, you can also set a theme for a particular page. Log on to CMS Desk, choose the
page from the content tree and select the theme that you would like to use on the Properties tab in
General -> CSS stylesheet. Please note that selecting (default) from the CSS stylesheet drop-down
list will result in applying the theme set in step 1. To save the theme for the given page, click k Save.

Live Site  Site Manager Intranet Portal B8 2 Global

Kentico
CMS5 Desk My desk Tools Administration E-commerce On-line marketing
Co U, ! 1 =
B ) Copy Up 4| @ AL
New  Delete |5 Move b Down Edit Preview Live site List Search
Content management View mode Other
;t‘_"') Intranet Portal Page Design Form | Properties | Analytics
D Home
[ company E Save
g Departments Pl N
|| Workgroups Design
— URLs
3 pocuments et P[] I
[ News Template CS8S stylesheet: [ inherit
- nheri
|| Events Metadata

Please note that if you set the Inherit option value to true, the CSS stylesheet drop-down list will
become inactive and the page will be inheriting its theme from the parent.

Page Design Form Properties Analytics

E Save
General >

Design
URLs 9

Intranet Portal - Blue m New
Template CSS styleshest: L
Metadata
Departments

If you need to change the theme of a department, log on to CMS Desk and from the content tree,
choose the department root document whose theme you want to change. You can perform the task
either the same way as described abowe, i.e. on the Properties tab in General -> CSS stylesheet, with
the possibility to inherit the theme from the parent by checking the Inherit check box.
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Live Site  Site Mansger Intranet Portal B3

Jle Kentico
1

-
% CMS Desk My desk Tools  Administraion  E-commerce  On-line marketing
Coj 4] B & | —]
S & 0w tw (PO o e
New  Delete & Move b Down Edit Preview  Live site List Search
Content management \iew mode Other
l.:‘_’! Intranet Portal Page Design Form  Master page | Properties | Analytics
D Home
[ | Compan: E Save
D Departments General 5
A Finance® " The changes were saved.
&8 Customer Care® Desi
ign
A HR* Template
Intranet Portal - Red [ Edit | New |
o Metadata CSS stylesheet Hintor =]
&8 Management® Inherit
Categories
S8 Marketing® n
) Other properties
B8 production® Mer prop
A Sales? Workflow Document name: IT
= Type: Intranet department
Template® -
- ﬁ - - Versions Created by: Global Administrator
L] vorkgroups Related docs Created 10/8/2010 12:06:30 PM
9 Documents - Last modified by Global Administrator
[ News e Last modified: 81012011 12:32:10 PM

Or you can change the department root document theme using the Used stylesheet drop-down list on
the Form tab. However, it is not possible to set inheritance from here.

Live Site  Site Manager

¢ Kentico
7N

1™ CMS Desk My desk  Tools  Administraion  E-commerce  On-line marketing
Col U gl | =
S g 2w fw (4| @ L
Mew  Delete | Move J} Down Edit Preview  Live site List Search
Content management View mode Other
!;_’! Intranet Portal Page Designl Form . Master page  Properties  Analytics
D Home
[0 Company ==| Spell check
] Departments
S8 Finance® Depariment i
epartment name:
SR Customer Care® P
a HR. ilalt:.d&partm&nt contains sample -
fam
5% Management® Department description:
SR Marketing®
&8 production® o=
&8 sales® Acti Update N Si
o ctions pda ame ize
[] Template®* Department avatar: :
| Workgroups P g | =] ITipg 14.9 kB
] Documents f
o= Used styleshest: Intranet Portal - Red Em
Bl News o [ New |

In either case, clicking & Save will result in changing the theme of the given department root document
including all department pages inheriting directly or indirectly from this department root document.
Please note that choosing the department document theme on both the Form tab and Properties tab
has the same effect and the value chosen on the one tab is automatically set on the other.

Workgroups

If you need to change the theme of a workgroup, log on to CMS Desk and from the content tree, choose
the workgroup root document whose theme you want to change. You can perform the task either the
same way as described abowe, i.e. on the Properties tab in General -> CSS stylesheet, with the
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possibility to inherit the theme from the parent by checking the Inherit check box.

Live Site  Site Manager Intranet Portal [E3

¢ Kentico
IS

[ CMS Desk My desk  Tools  Administraion  E-commerce  On-line marketing
Col 4] i 9 —]
2 [ Copy & Up 4 @ A~
Mew  Delete o Move J{} Down Edit Preview  Live site List Search
Content management View mode Other
!:‘_’! Intranet Portal Page Design Form  Master page | Properties | Analytics
D Home
|1 company E Save
General »
D Workgroups Design
—. URLs
»
|| Create Template CSS stylesheet: &
— Inherit
|| Marketing_Strategy® Metadata
— >
9 Mlcrosoft_Of’ﬁce_Upgrade Caiog Other properties
B Tradeshow_in_Las_Vegas™ ®
= . Document name: Microsoft_Cffice_Upgrade
| ] New_Product_Line® Meny ) e
- - Woin Type: Fage (menu item)
& Documents | Created by: Erad Summers

Or you can change the workgroup root document theme in Tools -> Groups -> Edit (#) <group> ->
General using the Theme drop-down list. However, you will not be able to set inheritance from here.
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Live Site

¢ Kentico

'l‘ CMS Desk Content My desk Administration ~ E-commerce  On-line marketing

@& Polls  [jl Custom tables 8. Forums [5] Message boards E] “P}
Forms Media Ba Staging [ﬁ File import Blogs I' .\ Abuse report Projects Events

Content o unity Collaboration

& Group properties

» Groups » Microsoft Office Upgrade

‘ General I Security  Members  Roles  Forums — Media libraries  Message boards  Polls  Projects

Display name: Microsoft Office Upgrade
Code name: Microsoft_Office_Upgrade
This workgroup contains sample -

data. Its mission is to upgrade
Microsoft Office on all our
Description: network machines.

Group pages location: /Workgroups/Microsoft Office Up:
l Theme: Intranet Portal - Green E[

I anc
) @
Avatar: ’) @

Upload: Browse. ..

Select pre-defined avatar

(@ Any site member can join
Approve members: @ Only approved members can join
) Only approved members can join except for invited members

) Anybody can view the content

. ) Site members can view the content
Content access: -

i@ Only group members can view the content

Motify group admins when a user joinsfleaves:
Motify group adming on pending members:

When you have the value entered, click kd Save on the Properties tab or click OK on the General tab.
This will result in changing the theme of the given workgroup root document including all workgroup
pages inheriting directly or indirectly from this workgroup root document. Please note that choosing the
workgroup document theme on both the General tab and Properties tab has the same effect and the
value chosen on the one tab is automatically set on the other. What is more, workgroup administrators
can change the workgroup document theme also on the live site, as described in Intranet User's Guide -

> Workgroups.

Please note

If you choose any value other than (none) or (default) from the Site CSS stylesheet,
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CSS stylesheet and Used stylesheet drop-down lists, the stylesheet Edit button will

be active enabling you to edit the code of the particular CSS style.

Creating your custom color theme

1. If you need to create your own color theme, log on to Site Manager, go to Development -> CSS
stylesheets and choose to Edit (#) either the Intranet Portal - Green or Intranet Portal - Red theme.
On the <CSS stylesheet> -> General tab, copy the content of the Stylesheet text field to clipboard.

Please note that the Intranet Portal - Blue theme is the portal default theme, which is used as the
basis of the Intranet Portal - Green and Intranet Portal - Red themes, defining only color differences.
The steps described in this section thus concern only the creation of a new theme color variant.
However, if you would like to create a new theme from scratch, you can use also the Intranet Portal -
Blue theme as the basis or you can start with a blank one, writing all the CSS stylesheet code yourself.

co

e en
P18 Site Manager

Development
@ Countries
& €SS stylesheets
@ cultures
f Custom settings
{Fl Custom tables
m Document types
<& Form controls
Inline controls
(% Modules
4:| Notifications
[H page layouts
Page templates
=5 Relationship names
Ea Search engines
{H System tables
<7 Tag groups
@ Time zones
@ UT cultures
{3 Web part containers
¢ web parts
[@] web templates
Widgets
# Workflows

CMS Desk  User: A& Global Administrator ¥ V6.0.4246 @  Sign Out
Stes  Administration  Settings [ESCICRLLINUN Tools  Dashboard  Licenses  Support
f CSS stylesheet properties [z]
» C38 stvlesheets » Intranet Portal - Green
General | Theme  Sites
=

E Save @l Check out

Check out the

to the

Stylesheet display name:

Stylesheet code name:

Intranet Portal - Green

IntranetPortalGreen

enticoCM54246.165722\CMSC § S StylesheetsiintranetPortalGreen.css file to edit it externally.

\
| |{ Stylesheet fext:

/* Default Intranet Portal stylesheet */
@import url('~/CMSPages/GetCSS.aspx?stylesheetname=IntranetPortal’):

h2
{
color:

1

#466517;

/*#Header block#+/
.HeaderBlock
1
background: url('~/App_Themes/IntranetPortalGreen/Images/Backgroundieader.]
1

.Wrap
{

background: #££f url('~/App Themes/IntranetPortalGreen/Images/BackgroundBo
1

.CurrentUser a

< il = »

[ »

= H oA R B EOE 1 / 338

Blogs page
Boxes
Column box
Content box
Document library
Uploaders
Events
Forums
Header block
Poll
Listings
Box
File list
Table
Other styles
Search
Tooltip
Top menu block
workgroup board

2. In Site Manager -> Development -> CSS stylesheets, click the % New CSS stylesheet link.
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ﬂ KGI\I:CO

#IN  Site Manager

Sites

Administration

Development [ Dashboard Licenses Support

Development
@ Countries

¢ €SS stylesheets

& cultures

f Custom settings
[if Custom tables
ﬁ]] Document types
< Form controls
[=3] Inline centrols

‘& Modules

"_L Notifications

§ CSS stylesheets

‘ @ New CS5 stylesheet !

+ Actions Display name = Code name
SR~ Intranet Portal - Blue IntranetPortal
FR~ Intranet Portal - Green  IniranetPortalGreen
FR~ Intranet Portal - Red IntranetPortalRed

3. This displays the dialog used for the creation of a new CSS stylesheet.

'. l(enl:co

CMS Desk 4 Global Administrator v v7.0 | @ | SignOut

1% Site Manager Sites

Administration

Settings

Development [JRETHS

Dashboard  Licenses  Support ! Enterprise Marketing Solution

Development

0 Countries

& Css stylesheets
© cultures

f Custom settings
fdl Custom tables
G Device profiles
&) Document types
<& Form controls
Inline controls
EI avascript files
[E| macro rules

(® Modules

iz Notifications

[H page layouts

[@ Page templates
=R Relationship names
ﬂ Search engines
@ System tables
& Tag groups

@ Time zones
Translation services
1 cultures

eb part containers
o web parts

[@] Web templates

[@] widgets

« Workflows

& New CSS stylesheet

» CSS stylesheets » New CSS stylesheet

Hsave

Stylesheet display name:

Stylesheet code name

(automatic)

[l

Stylesheet text:

Hloca | &&= |F

assign to website Intranet Porial

The following fields are available when defining a CSS stylesheet:

e Stylesheet display name - name of the stylesheet displayed in the user interface; a required field.

e Stylesheet code name - name of the stylesheet that serves as a unique identifier, e.g. in the API or
URLs. Unless you wish to set a specific code nhame, you can leave the default (automatic) option
and the system will generate an appropriate one based on the display name.

e Stylesheet text - standard CSS stylesheet code; a required field.

e assign to web site Intranet Portal - indicates if the CSS stylesheet will be assigned to the Intranet
Portal web site; an optional field.

Now copy the content of the clipboard to the Stylesheet text field. Modify the style code as needed, fill
in the remaining two required fields and make sure that the assign to web site Intranet Portal option is
set to true. If you have all values entered, click &l Save to create the new CSS stylesheet. Please note
that you can also make the CSS stylesheet available for any other website on the <CSS stylesheet> ->
Sites tab using the Add sites button.

4. You may also want to modify some of the auxiliary image files related to the CSS style defining your
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custom color theme. You can either upload new image files with the same names or you can modify the
existing files using the built-in Image editor as described in more details in the Handling images
chapter in the Content management -> File management section of the Deweloper's Guide. Please
note that image files on the Intranet Portal are placed in the Files folder.

p_ﬁ! Intranet Portal
[l Home
[} company
;_1 Departments
;_1 Workgroups
[] Documents
[ Mews
;_1 Events
[ Media
[ Blogs
;_'] Forums
;_1 Employees
|] Search
& Rrss
;J | ogon

- & Files

) Icons

IconDepartments
IconDocuments
IconEmployees
IconHome
IconMembers

|®i IconProjects

¥ ¥ ¥ ¥

B IconWorkgroups
¥ DefaultDepartmentsAvatar
|=| jenniferw_photo
¥ KenticoFooterLogo
|=| KenticoLogo
|®&| KenticoLogoBig
|| DefaultTeaserImage

¥ KenticoLogoSmall
Ty Gpecal pages®

For a detailed description of how to deal with CSS styles on the Intranet Portal, please refer to the CSS
stylesheets and design chapter in the Development section of the Developer's Guide.

8.2 Modifying the Home page

In this topic you will learn how to modify some important elements of the Intranet Portal Home page,
such as the Quick links, Employee of the month and the Canteen menu widgets. You will also learn how
to add other widgets to the portal main page. Widgets introduce support for the personalization of pages.
They allow users and editors to edit the structure of page templates. The personalized settings are
saved within the system and can be invoked from the live site by authorized users or through the CMS
Desk interface in the case of website editors. If you need to modify the portal Home page, log on to CMS
Desk, choose Home from the content tree and navigate to the Content -> Edit -> Page tab. You should
see a page similar to the one depicted in the following screenshot.
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Kentico

CMS Desk

Live Site  Site Manager  [intlanctPortalEd L Global Administrator v v6.0.4237 @  Sign

Administration ~ E-commerce  On-line marketing ! Enterprise Marketing So

B3 Cony
New  Dslste [ Move Preview  Live site List Search
Content nt View mode Other
I Page 'Dgn Form  Properties  Analytics
P
E Save pell check

:l Departments
[] workaroups [E] source | B G G Ar A | M@ | B I U == x x| IZi En W | EE =EE
[ Documents — = = =
Ellw AR | EEEE0| BCx 8B

ews
] Events Styles ~ Format ~ Font v Size v | Br A- | R
] Media
= i
[ Blogs _» & Kentico P e . o
1] Forums ~70  Intranet Solution el e e
:l Employees .
[ search You have: D unresd messages) 2 sctive taskis)
- —
[ Rss
2 Company Departments Workgroups Documents News Events Media Blogs Forums Employees
|.] Logon
) Files

&) Special pages

\ﬂﬂd widget | ‘ $€ Reset to default |

Welcome to Your New
“Intranet

& auick Links

I Employees

| Thisis a ready-to-use intranet that you can use out of the box Or |
. Documents { you can customize it as you need. For more information on how to |
. configure your intranet, please see the Intranet Guide.

@ Departments
52 Workgroups

Widgets management

As a content editor, you can add, modify or delete any widget placed in a widget zone. This can be used
to quickly customize pages beyond simply entering content into static page templates.

To add a new widget to your portal Home page, just click the Add widget (&) button in the top left
corner of an editor widget zone.

SCHEDULED NETWORK MAINTENANCE | 10/12/2010

Due to the scheduled upgrade of our network
!Ih ‘ infrastructure, the local network as well as our VPN will
" ' not be available during this Saturday, between Gam
— and 8am.

RECORD SALES IN Q3 | 101272010

== The third quarter was the best quarter in our history!
= We grew the sales by 70% year-to-year. Thanks to
* 1 everybody to their hard work.

NEW SALES OFFICE IN NEW YORK | 10/12/2010

We have just opened a new sales office in New York. It
i will be managed by Jennifer Wilson. The office is

located on the 8th avenue.

You can modify any widget placed in an editor widget zone by clicking the Configure widget (&)
button. You can also delete widgets using the Delete widget (E) button. Widgets can be moved
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between different widget zones by clicking the Drag widget () button and dragging the widget to the
desired place.

If you would like to learn more about using widgets in Kentico CMS, please refer to the Development ->
Using widgets chapter in the Development section of the Developer's Guide.

Changing the Quick links

The Quick links box contains links to pages that you need to be accessible directly from the Intranet
Portal Home page. If you need to modify or delete some of these links or if you need to add new ones,
move the mouse over the box so that the widgets management buttons become \isible.

| ) QUICK LINKS n

£, Employees

. Documents

|4/ Departments
$2, Workgroups

By clicking the Configure widget () button, you will open the Widget properties (Intranet quick
links) dialog window. In the Content -> Text field you can perform all editing actions concerning your
quick links using the built-in WYSIWYG editor. For more information on how to use the editor, please
refer to the WYSIWYG editor chapter in the Development section of the Developer's Guide.
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'l ™
{28 Widget properties (Intranet quick links) - Windows Internet Explorer E@g
gdget prope B [ra ¥ 4] Doct 0
E| Source | P R Mk @ | B I U = X x|
= E E M ds | E E E E | P EEEO| BOX § 6
Styles - Format - Font 7839v| 'A'|Q
Content WYSIWYG Editor
@Emglﬁ\-‘ees
ocumen‘rs
epartmen‘rs
\Vorkgrougs
Text:
Widget container
Widget container: Infranet column box |Z| Edit m
Widget container title: QUICK LINKS
V] Refresh page Ok | Cancel [~ Apply |
L

The following fields are available to define the Intranet quick links widget:

e Text - the text to be displayed in the Quick links box. All editing actions related to the actual links
can be performed using the built-in WYSIWYG editor.

e Widget container - the container containing the particular widget.

e Widget container title - the title of the widget container. It is displayed only if the {%ContainerTitle
%} macro is used in the container code.

When you have the values entered, click OK to save the widget new settings and close the dialog
window. Or click Apply to confirm the entered value(s) and leave the dialog window open. Or click
Cancel to close the dialog window. Please note that if you click the Cancel button after confirming
some previously made changes, these changes will not be lost. If you set the Refresh page option
value to false, the edited content will not be updated after closing the dialog window unless you either
refresh the Edit mode or switch to the Preview or Live site modes.

Changing the Employee of the month

The Employee of the month box contains an image of a selected company employee together with its
caption. The image is presented on the Intranet Portal Home page for the duration of one month and can
be partially customized. You can select a different image from the Intranet Portal file system by clicking
the | Select link, or you can click the # Clear link, which removes the selected image and replaces it
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with the default one. Another option to modify some basic properties of the image is to move the mouse
over the box so that the widgets management buttons become visible.

Employee of the

Employee of the month
| select... $§Clear

If you click the ' Select link, the Select image dialog window will pop up. Choose an image file from
the Intranet Portal content tree and optionally adjust its width and height. You can Lock/Unlock () the
image aspect ratio and you can also Reset (&) its size. By clicking Refresh () you can refresh the
image URL according to the current image file settings. When you have the values entered, click Select
to confirm selection and adjustment of the new image or click Cancel to discard the changes.

The following fields are available if you are selecting a new Employee of the month widget image using
the Select image dialog window:

e URL - URL of the image file in your Intranet Portal file system.
e Width - the width of the image in pixels. The image will be resized to this width.
e Height - the height of the image in pixels. The image will be resized to this height.
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' A’
a Select image -- Webpage Dialeg M

E71 select image
Attachments | Content | Medialibraries  Web .
(g Newfolder | Ju Newie =] ust Tiles [£2] Thumbnails (2]

Site: Intranet Portal - Jm‘

= . ICMS/getfile/a72aa3d2-6a8a-430f-b111-109d4c802ddE/jenniferw_phot
| Media -

[ Blogs ®

B Forums width: 199 am
— =

|| Employees Height: 199

|| Search

|| RSS

a Logon Pl

i Files 5

&) Icons

B DefaultDepartmentsA’

= jenniferw_photo

R KenticoFooterLogo

=/ KenticoLogo

B KenticoLogoBig

B DefaultTeaserimage

B KenticoLogoSmall

4 Special pages -

4| 1} | [

L 7

If you click the Configure widget (#l) button, you will open the Widget properties (Employee of the
month) dialog window. This dialog window enables you to modify some basic properties of the image
file. When you have the values entered, click OK to save the new widget settings and close the dialog
window. Or click Apply to confirm the entered value(s) and leave the dialog window open. Or click
Cancel to close the dialog window. Please note that if you click the Cancel button after confirming
some previously made changes, these changes will not be lost. If you set the Refresh page option
value to false, the edited content will not be updated after closing the dialog window unless you either
refresh the Edit mode or switch to the Preview or Live site modes.

The following fields are available to define the Employee of the month widget:

Image width - the width of the image in pixels. The image will be resized to this width.

Image height - the height of the image in pixels. The image will be resized to this height.

Image title - the title of the image region displayed on the Intranet Portal Home page.

Alternate text - the alternate text of the image displayed on the live website. It is the value of the alt
attribute of the image tag.

Widget container - the container containing the particular widget.

e Widget container title - the title of the widget container. It is displayed only if the {%ContainerTitle
%} macro is used in the container code.
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Content

Image width:
Image height:

Image title:

Default image:

Alternate text:

Widget container
Widget container:

Container fitle:

Refresh page

r ™
{22 Widget properties (Employee of the menth) - Windows Internet Explorer E@g

@' Widget properties (Employee of the month) E Documentation

197
197

Employee of the month

/KenticoCMS4253.14802

-
4

Jennifer Wilson

Infranet simple container

Employee of the month

[ Cear

m

Bl Edit | Rew

Please note

If you need to modify the image file using the standard image editing operations, please
refer to the Handling images chapter in the Content management -> File
management section of the Deweloper's Guide.

Changing the Canteen menu

The Canteen menu box contains the company canteen menu for the period of one week, optionally
together with a description. The Intranet Portal comes shipped with a canteen menu in the form of table.
Howevwer, you can fully customize the menu according to your needs. If you would like to modify the
canteen menu, move the mouse over the box so that the widgets management buttons become \visible.
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Canteen menu for this week:

© MON: Grilled pork chop gami
: TUE: Bacon quiche

© WED: Roast of the day

: THU: Cottage pie

© FRI:  Fish pie

By clicking the Configure widget () button, you will open the Widget properties (Intranet canteen
menu) dialog window. In the Content -> Text field you can perform all editing actions concerning your
canteen menu using the built-in WYSIWYG editor. For more information on how to use the editor, please
refer to the WYSIWYG editor chapter in the Development section of the Developer's Guide.

i ™
= Widget properties (Intranet canteen menu) - Windows Internet Explorer Elﬂlg
@' Widget properties (Intranet canteen menu)
N
| 5] source | FEl R A HE& | B I U =x x|
= = EY W | EE EE | & P EEE 0| B ol E
Styles v Format - Font v Size v | S A- | 5}
\ [-]
Content WYSIWYG Editor
Canteen menu for this week:
MON: Grilled pork chop garni
TUE: Bacon quiche
WED: Roast of the day
Text THU: Cottage pie
FRI: Fishpie
Web part container
Widget container: Intranet column box B Eait | New |
Widget container title: CANTEEN MENU
Refresh page s
L vy

The following fields are available to define the Intranet canteen menu widget:

e Text - the text to be displayed in the Intranet canteen menu box. All the editing actions related to the
text can be performed using the built-in WYSIWYG editor.
e Widget container - the container containing the particular widget.
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e Widget container title - the title of the widget container. It is displayed only if the {%ContainerTitle
%} macro is used in the container code.

When you have the values entered, click OK to save the widget new settings and close the dialog
window. Or click Apply to confirm the entered value(s) and leave the dialog window open. Or click
Cancel to close the dialog window. Please note that if you click the Cancel button after confirming
some previously made changes, these changes will not be lost. If you set the Refresh page option
value to false, the edited content will not be updated after closing the dialog window unless you either
refresh the Edit mode or switch to the Preview or Live site modes.

Please note

If you switch to the Edit -> Design tab, you can modify the layout of the page.
Howevwer, special permissions are needed to perform this task. Please refer to the
Portal engine development model chapter in the Development section of the Developer's
Guide for more details.

8.3  Modifying structure of the website

In case that you are planning to customize the portal so that alias paths of documents change, you
need to take into account that some intranet portal widgets may not work correctly. These widgets are
based on standard Kentico CMS web parts, but have most of their properties pre-configured. Howeer,
some of them have their configuration dependent on the default structure of the portal. Therefore, it is
either necessary for the documents listed below to be accessible under their original URLS, or to change
the pre-configuration of particular widget properties in Site Manager -> Development -> Widgets -> ...
select a widget from the tree ... -> Properties to reflect your new custom location.

For more information on URLs in Kentico CMS, please refer to Developer's Guide -> Development ->
Page processing and URLsS. A detailed reference on path expressions is located in Developer's Guide ->
Appendix A - Path expression.

Global section

The following alias paths of documents from the global section of the portal are pre-configured into the
default properties of at least one Intranet portal widget:

e /Home - the Department quick links and Workgroup quick links widgets contain a link to this
alias path in their default text.

e /Departments - the Intranet departments widget is by default configured to display departments
under this alias path. Also, the Intranet quick links widget contains a link to this alias path in its
default text.

e /Workgroups - the Intranet quick links widget contains a link to this alias path in its default text.

e /Documents - the Intranet quick links widget contains a link to this alias path in its default text.

e /News - the Intranet latest news widget is by default configured to display News documents under
this alias path and also provides a link to it. To modify this link, the default value of the widget's
ContentAfter property must be changed.

e /Events - the Intranet upcoming events widget is by default configured to display Event documents
under this alias path.
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/Events/Events-list - the Intranet upcoming events widget by default provides a link to this alias
path. To modify this link, the default value of the widget's ContentAfter property must be changed.
/Blogs - the Intranet latest blog posts widget is by default configured to display Blog documents
under this alias path.

/Blogs/Blog-posts - the Intranet latest blog posts widget by default provides a link to this alias
path. To modify this link, the default value of the widget's ContentAfter property must be changed.
/Employees - the Intranet quick links widget contains a link to this alias path in its default text.
/Employees/Management/My-projects-and-tasks - the My projects - Intranet Portal, Tasks
assigned to me - Intranet portal and Tasks owned by me - Intranet portal widgets by default
provide a link to this alias path. To modify these links, the default value of the ContentAfter property
of the appropriate widget must be changed.

/RSS/<BlogPosts, Events, ForumPosts, News> - the RSS feed buttons in the container headers of
the Intranet latest blog posts, Intranet upcoming events, Intranet latest forum posts and
Intranet latest news widgets link to the respective alias path (if a container that supports an RSS
link is used). To modify these RSS feed links, the default value of the ContainerCustomContent
property of the appropriate widget must be changed.

Workgroup sections

The following alias paths of documents from the sections dedicated to individual workgroups are
pre-configured into the default properties of at least one Intranet portal widget:

/Work groups/<work group code name> - the Workgroup recent pages widget is by default
configured to display Simple article documents under this alias path.

/Work groups/<work group code name>/News - the Workgroup latest news widget is by default
configured to display News documents under this alias path and also provides a link to it. To modify
this link, the default value of the widget's ContentAfter property must be changed.

/Work groups/<work group code name>/Calendar - the Workgroup upcoming events widget is by
default configured to display Event documents under this alias path.

/Work groups/<work group code name>/Calendar/Events-list - the Workgroup upcoming events
widget by default provides a link to this alias path. To modify this link, the default value of the
widget's ContentAfter property must be changed.

/Work groups/<work group code name>/Documents - the Workgroup quick links widget contains a
link to this alias path in its default text.

/Work groups/<work group code name>/Blogs - the Workgroup latest blog posts widget is by
default configured to display Blog documents under this alias path.

/Work groups/<work group code name>/Blogs/Blog-posts - the Workgroup latest blog posts widget
by default provides a link to this alias path. To modify this link, the default value of the widget's
ContentAfter property must be changed.

/Work groups/<work group code name>/Wiki - the Workgroup recent pages widget by default
provides a link to this alias path. To modify this link, the default value of the widget's ContentAfter
property must be changed.

/Work groups/<work group code name>/Projects - the Workgroup quick links widget contains a link
to this alias path in its default text.

/Work groups/<work group code name>/Members - the Workgroup quick links widget contains a
link to this alias path in its default text.

/Work groups/<work group code name>/RSS/<BlogPosts, Events, ForumPosts, News> - the RSS
feed buttons in the container headers of the Workgroup latest blog posts, Workgroup upcoming
events, Workgroup latest forum posts and Workgroup latest news widgets link to the respective
alias path (if a container that supports an RSS link is used). To modify these RSS feed links, the
default value of the ContainerCustomContent property of the appropriate widget must be changed.
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Department sections

The following alias paths of documents from the sections dedicated to individual departments are
pre-configured into the default properties of at least one Intranet portal widget:

/Departments/<department code name>/News - the Department latest news widget is by default
configured to display News documents under this alias path and also provides a link to it. To modify
this link, the default value of the widget's ContentAfter property must be changed..
/Departments/<department code name>/Calendar - the Department upcoming events widget is by
default configured to display Event documents under this alias path.

/Departments/<department code name>/Calendar/Events-list - the Department upcoming events
widget by default provides a link to this alias path. To modify this link, the default value of the
widget's ContentAfter property must be changed.

/Departments/<department code name>/Documents - the Department quick links widget contains
a link to this alias path in its default text.

/Departments/<department code name>/Blogs - the Department latest blog posts widget is by
default configured to display Blog documents under this alias path.

/Departments/<department code name>/Blogs/Blog-posts - the Department latest blog posts
widget by default provides a link to this alias path. To modify this link, the default value of the
widget's ContentAfter property must be changed.

/Departments/<department code name>/Members - the Department quick links widget contains a
link to this alias path in its default text.

/Departments/<department code name>/RSS/<BlogPosts, Events, ForumPosts, News> - the RSS
feed buttons in the container headers of the Department latest blog posts, Department
upcoming events, Department latest forum posts and Department latest news widgets link to
the respective alias path (if a container that supports an RSS link is used). To modify these RSS
feed links, the default value of the ContainerCustomContent property of the appropriate widget
must be changed.

Remembering original URLs when moving documents

The Site Manager -> Settings -> URLs and SEO -> Remember original URLs when moving
documents setting may come in handy in this situation.
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w CMS Desk  User: A& Global Admi
& Kentico

1V Sie Manager Sites Administration Settings Development Tools Dashboard Licenses Support Buy
Site:
taio0a) 5 =2 URLs and SEO
Save Reset these settings to default
Settings E _ f

@ Content

=5 URLs and SEO These settings are global, they can be overridden by individual website settings. Please select a site to see or change the site settings.

a Security & Membership

B system URL format

& On-line marketing Forbidden URL characters (2]

m E-commerce

&4 community Forbidden characters replacement (2]

o Intranet & Collaboration

\é, Versioning & synchronization Allowed URL characters e

@ Integration

<3 Cloud services Friendly URL extensions @ aspx
Files friendly URL extension @ .aspx
Excluded URLs @

!

Document URLs
Default URL path prefix (2]
Use name path for URL path e O
Use permanent URLs 9 O
Remember original URLs when moving
documents 9 ]l
Automatically update document alias @ |}

This setting is enabled by default and it ensures that when a document is mowved or its alias path is
modified, the original alias path is added among its additional Document aliases. This way, the
document is still accessible under the original URL (2. in the screenshot below), as well as under the
new one (1. in the screenshot below). If you perform your alias-path-related modifications with this
setting enabled, the functionality of the structure-dependent widgets listed above will be preserved.
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Page Design Form Properties
=
Save

The changes were saved.

General

U > Alias
Template t Document alias: Homepage l 1_
Metadata
Document URL path
Categories
Use custom URL path:
—— Path type: @ Standard URL or wildcard () Route &) MVC
Workflow Path or pattern:
Versions -
Extended properties
Related docs URL extensions:
Linked docs [l Use custom URL extensions
Secunty Document aliases
Attachments + Add new alias
- Actions URL path URL extensions = Track campaign Language
e 4 Home 2_

Items per page: 25 |Z|

8.4  Configuration for multiple languages

The intranet portal can be multilingual, i.e. both the content of the front-end website and the resource
strings in the administration interface can be displayed in various languages, based on the current user's
preferences. This topic will give you a basic oveniew of how this configuration can be achieved. For a full
reference on the multilingual possibilities of Kentico CMS, please refer to the Content management ->

Multilingual content and Development -> Ul cultures and localization chapters in the Developer's Guide.

Multiple content cultures

If you want to make the portal's content multilingual, the first thing to do is to add the required cultures

in Site Manager -> Sites -> edit (#) the site -> Cultures. By default, the portal only uses the English -
United States culture. You can add additional cultures using the Add cultures button, which opens a
culture selection dialog where all cultures defined in Site Manager -> Development -> Cultures will be
offered. Unwanted cultures can be removed from the list by checking their check-boxes and clicking the
Remove selected button.
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x Kentico

1™ Site Manager Administration ~ Settings  Development  Tools

(u_) Site properties

> Sites » Intranet Porial

General  Domain aliases | Cultures | Offline mode

The website uses the following cultures:

] Culture name
0 English - United States
(=] German - Germany

Remove selected Add cultures -

Once you have more than one culture in the list, the Language toolbar is displayed in CMS Desk ->
Content. Using this toolbar, you can switch between particular language versions of the document
currently selected in the content tree.

TV Live Site  Site Manager Intranet Portal [E3
3l Kentico
1% CMS Desk

My desk  Tools Administration E-commerce On-line marketing

Col U " =] — B=
B C) Copy & Up 4| @ = =
MNew Delete = Move G Down Edit Preview Live site List English German Compare Search
Content management View mode Other

On the live site, you can switch between particular language versions of the website using the
Lanugage selection or Language selection with flags web part. On the Intranet Portal website, the
second mentioned web part is located in the top right corner of the master page header.

= English ' [German

»
= ”(" 4 I|<emim Sol Global Administrator : Sign Out My Dashboard | How To | Edit this psge
> "
» 7% Intranet 50 ution
“You have: 0 unresd messspe(s) 0 sctive tasi(s

e ——

Home Company Depariments Workgroups Documenis MNews Evenis Media Blogs Forums Employees

Multiple user interface cultures

User interface cultures can be managed in Site Manger -> Development -> Ul cultures. In this part of
the administration interface, you can see a list of all user interface cultures currently available in the
system. The default installation of Kentico CMS only contains the English, Czech and Slovak cultures.
Localization packs containing other cultures can be downloaded for free at http://www.kentico.com/

Download/Localization-Packs.aspx.

It is also possible to create a completely new user interface culture using the & New Ul culture link on
this page. If you click the Edit (#) button next to a culture, you open its editing interface where you can
define custom resource strings. It is also possible to remowe listed cultures using the Delete () button.
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CMS Desk
'. I(entco

1S site Manager Sites  Administration Setting Development RG] Dashboard Licenses Support Buy
Development Ul cultures

@ Countries

G C55 stylesheets Default culture | All cultures

€ cultures 3 Mew UI culture

f Custom settings

£ Custom tables You can download additional localization packs from http://www.kentico.com/Download,/Localization-Packs. aspx

[l Document types

4’} Form controls = Actions Ul culture name Ul culture code

[Z3 Inline controls A8~ | b Czech sz

Modul
( Modules SR~ B3 English (default)  en-us

3_L Naotifications
[H Page layouts SR~ & Slovak sk-sk
@ Page templates

=5 Relationship names
[@ Search engines

[ System tables

<« Tag groups

@ Time zones

E?_' UI cultures

i Web part containers

Culture settings for users

Each user has the following two properties on the General tab of their editing interface in Site Manager
-> Administration -> Users:

e Preferred content culture - preferred culture of website content displayed to the user. If set to
(default) or if the selected culture is not available, content is displayed in the default website culture.

e Preferred user interface culture - preferred culture of the system's administration interface
displayed to the user. If set to (default) or if the selected culture is not available, user interface is
displayed in the default user interface culture.
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CMS Desk  User: L Global Administrator ¥

0
#IN Site Manager Si ENNTEL G Settings  Development  Tools  Dashboard  Licenses  Support  Buy
Administration & Users
Avatars
9 Bad words Users | Waiting for approval ~ Mass e-mail ~ On-line users
& Badges » Users » BradS
28 Banned 1Ps
<4l Categories General | Password  Seftings  Sites  Roles  Departments  Motifications  Categories  Friends  Subscriptions  Languages  Membership
& E-mail queue W Loq in as this user
2 E-mail templates
] Event lox
g g User name:* BradS
@ Integration bus
. Full name: * Brad Summers
& Membership
A permissions First name
 Recydle bin Middle name:
84 Roles Last name:
@ Scheduled tasks E-mail: brads{@localhost. local
3] Smart search
I SMTP servers Enabled:
'_' System Is editor:
UI personalization
S UIn 15 global administrator: /|
@ Users Ll
& web farm Is external user: =
- Is domain user =
15 hidden: /|
Preferred content culture: (default) E
Preferred user interface culture: {defaulf) E
\

Users with access to CMS Desk can adjust these settings for their own accounts in My desk ->
Account -> Details.

;:!:. Kentico

CMS Desk Content QUNMEES Tools  Administraion  E-commerce  On-line marketing

W & 5

My dashboard My profile | Blogs  Friends Prﬁiéﬁs

Dashboards My Data
ﬁ My profile

Details | Change password  Subscriptions  Categories

User name: Brads

Full name: Brad Summers

First name:

Last name:

Nick name:

E-mail: brads@Iocalhost.local

Preferred content culture: English - United States |Z|
Preferred user interface culture: | (defaulf) E

IMessaging notification e-mail:

Default culture settings

When setting up a multilingual intranet, it is necessary to choose default cultures. These cultures are
used when the two preferred culture settings described above are set to (default), or when the user's
preferred culture is not available. These settings need to be adjusted separately for the website content
and for the administration interface.
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Default content culture

Default content culture can be configured in Site Manager -> Sites -> edit # the site -> General. The
following two settings on this tab are related to default cultures:

e Default content culture - content culture displayed to registered users whose Preferred content
culture is set to (default).

e Visitor culture - content culture displayed to anonymous site visitors. If set to (Automatic), the
culture will be used based on client browser preferences.

Site Manager Administration Settings Development  Tools

ft_) Site properties

» Sites » Intranet portal

General | Domain aliases  Cultures  Offdine mode  Site objects

Site display name: Intranet portal @
Site code name: IntranetPaortal
Site domain name: localhost

Default content culture: English - United States

Visitor culture: {Automatic)

Site C58S stylesheet: Intranet Portal - Blue -

Editor CSS stylesheet  (site stylesheet) - [ Hew |

Site description: Intranet portal site - @
ok |

The Default content culture option abowe is linked with the Default content culture setting in Site
Manager -> Settings -> Content. If you change the value here with the correct website selected, it gets
changed in the dialog described abowe too, and vice versa.
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8.5

w CMS Desk  User:
= Kentico
71N Site Manager Sites Administration Settings Development Tools Dashboard Licenses Support Buy
Site: @ c
ontent
Intranet Portal |Z|
. E Save f Reset these settings o default
Settings
@ Content

=5 URLs and SEO
a Security & Membership

& system Default alias path @ MHome m

i On-line marketing

Web site content

TR E-commerce

&4 Community Page not found

#% Intranet & Collaboration

\g’ Versioning & synchronization Fage not found for non-published documents @

9 Integration

- Page not found URL

< Cloud services g @
Log page not found exception @
Multilingual

I (Defaurt content culture ) English - United States |Z| ]|

Combine with default culture (2]
Combine files with default culture e

Default user interface culture

The default Ul culture can be set by adding the following key to the <appSettings> section of your site's
web.config file:

<add key="CvBDefaul tU Cul ture" val ue="en-nz" />

If you use this key, you also need to rename the ~\CMSResources\CMS.resx file to CMS.en-us.resx
and the CMS.en-nz.resx file to CMS.resx. This is needed because the CMS.resx file is used when the
(default) option in selected in users' Preferred user interface culture. When this key is used and the
CMS.resx file contains the en-nz dictionary, for the user who has their Preferred user interface
culture set to (default), the Ul culture will be en-nz.

Changing the company logo

Here you will learn how to change and modify your company logo. You can change the logo in the
Intranet Portal root or you can update it in the Intranet Portal content tree.

Changing the company logo

1. If you need to change your company logo, log on to CMS Desk and choose the Intranet Portal root
from the content tree. You should see a page similar to the one depicted in the following screenshot.
You can select a different logo image from the Intranet Portal file system by clicking the | Select link
or you can restore the default logo image by clicking the # Clear link.
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[] Copy r Up

New Delete [ Move L Down

Content management

My desk  Tools Administration E-commerce On-line marketing

/O

Search

4| d [ E

Edit Preview  Live site List

View mode Other

o~
Fp_"i Intranet Portal ]

= Home®

[ company
|| Departments
a Workgroups
[} Documents
[ nNews

a Events

[ Media

[ Blogs

a Forums

a Employees
[0 search

[ mrss

a Logon

&) Files

i) Special pages

Fage Design Form Master page Properties  Analytics

% Spell check
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QAP EEEOEO|BDBOYBE

Styles v Format v Font v Size - | e v
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Solution

_______________________________________

Company Depariments Workgroups
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2. If you click the |’ Select link, the Select image dialog window will pop up. Choose an image file
from the Intranet Portal content tree and optionally adjust its width and height. You can Lock/Unlock (&
) the image aspect ratio and you can also Reset (&) its size. By clicking Refresh () you can refresh
the image URL according to the current image file settings. When you have the values entered, click
Select to confirm selection and adjustment of the new image or click Cancel to discard the changes.

The following fields are available if you are selecting a new logo image using the Select image dialog

window:

e URL - URL of the image file in your Intranet Portal file system.

e Width - the width of the image in pixels. The image will be resized to this width.
e Height - the height of the image in pixels. The image will be resized to this height.
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-
{2 Select image - Windows Internet Explorer

B7 select image

Attachments | Content | Media libraries  Web

ESREERT)

=

(g Newrolder [ g, New il

List Tiles

Thumbnails

2]

=

D Events
[ Media
[} Blogs
D Forums
D Employeas
[} search T
[ rss
D Logon
i Files
i Icons
|W| DefaultDepartmentsiv
|=| jenniferw_photo =
|M| KenticoFooterLogo

|i=| KenticoLogo
|® KenticoLogoBig
M| DefaultTeaserlmage
¥ KenticoLogoSmall
& Special pages i
< i | 3

Site: Intranet Portal |Z| W

URL: /CMS/getiile/f538a085-60c5-4360-9840-3d67626503e/KenticoLogoBig.aspx?width=54 S

Width: 64 p
Height: 64 @ = -‘!’-
e

™ Select™|™" Cancel

3. Finally, go to CMS Desk -> Content -> Edit, choose any Intranet Portal page displaying the company
logo, e.g. the Home page, from the content tree and switch to the Page tab. The new company logo will
be displayed. Please note that you can check your company logo also on the live site.

© 2014 Kentico Software



Customizing the portal 123

Fage Design Form Properties  Analytics

E Save |§; Spell check

&l Source | FEl W R A #Het@| BIU
& Pl EgBEE 0| BHOw 8 G

Styles ~ Format ~ Font v Size v | A A~ | @1

el

Company Depariments ‘Workgroups Documents New

Home

| o Add widget | | 3¢ Reset to default

B

[ Quick LINks

e

~ Welcome to Your
. ! Intranet

Updating the company logo

1. Another option to change your company logo is to update the existing one. The company logo image
file can be found in the Intranet Portal Files folder. Navigate to this folder from CMS Desk -> Content
and choose the appropriate image file from the content tree.

i Files

i Icons

W IconDepartments

IconDocuments
IconEmployees
IconHome
IconMembers
IconProjects

P EEEEE

IconWorkgroups
B DefaultDepartmentsAvatar
=/ jenniferw_photo
B I centicoEonto 0go
™| KenticoLogoBig
|®| DefaultTeaserImage

| KenticoLogoSmall

Please note

The Files folder in CMS Desk -> Content does not only contain the company logo
image file and image files related to the Intranet Portal themes. All other image files
placed on the portal can be found in this folder, too.
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2. Now go to CMS Desk -> Content -> Edit, switch to the Form tab and click Update (#').

Page Form Properties  Analytics

E Save @ Spell check

File name:  KenticoLogo

Description:
Actions Update Name
File: -
7R Ll li=| KenticoLogo.jpg
Publish from: & Now
Publish to: B Now

1B

Size

19.6 kB

3. This will open the Choose file to Upload webpage dialog of the operating system enabling you to
choose the new logo image file from your local or network file system. Navigate to the appropriate file,

select it and click the Open button to confirm the update of your company logo.

-
€ Choose File to Upload

@Qvl ;€ 0SDisk (C:) » Company » Imagefiles

Organize * MNew folder

i Favorites
4 Libraries
1M Computer

G‘F Metwork

File name: Kenticolego_2

Irtranet Sohution

Kenticolego_1

e

Kenticelogo_2

[ AllFiles ()

7]

[ Open

I |

Cancel

]

L

o

4. Finally, go back to CMS Desk -> Content -> Edit, choose any Intranet Portal page displaying the
company logo, e.g. the Home page, from the content tree and switch to the Page tab. The new
company logo will be displayed. Please note that you can check your company logo update also on the

live site.
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Fage Design Form Properties  Analytics

E Save %—E—a Spell check

&l Source | FEl W R A #Het@| BIU
& Pl EEEE | B O 8 E

Styles ~ Format ~ Font v Size v | A A~ | @1

—

Company Depariments ‘Workgroups Documents New

Home

| o Add widget | | 3¢ Reset to default |

_______________________________________

H . Welcome to Your
QUICK LINKS P
v . Intranet

Please note

If you don't need to change your company logo and only wish to modify it, navigate as
described in step 2. and click Edit (#). This will open the Edit image webpage dialog
enabling you to perform standard image editing operations such as Resize, Rotation,
Convert, Crop and Color adjustment, same as display the Properties of the image.
For more details on how to performs these operations, please refer to the Handling
images chapter in the Content management -> File management section of the
Deeloper's Guide.
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9 Special pages

The portal contains a number of special pages. These pages are standard Page (menu item)
documents in the content tree, but they are not visible in the navigation menu. Their function is to provide
functionality such as handling unsubscription requests, etc.

The special pages described in this topic are located in the Special pages folder in the content tree.
The following pages can be found there:

e Access denied

Blog unsubscribe

e Board unsubscribe

e Forum unsubscribe
Invitation acceptation
e Reqistration approval

There are also other special pages in addition to the ones described in this topic - special pages for
search and RSS feeds. These pages are described separately in the RSS feeds and Search topics in
the Other features chapter of this guide.

!n_’J Intranet Portal
[J] Home
[ company
,_1 Departments
,_1 Workgroups
| Documents
News
Events
Media
Blogs
Forums
Employees
Search
RSS
Logon
Files

G oo D DD Dk

Special pages”
|1 Access denied

,_1 Blog unsubscribe

| ] eoard unsubscribe
[] Forum unsubscribe
,_1 Invitation acceptation
=l

‘| Registration approval )

Access denied

Users who attempt to access a page for which they do not have permissions are by default redirected to
a system page that displays a security message. A custom page may however be set as an alternative
for the default system page. The Access denied special page is prepared for this purpose, it only
requires the simple configuration process described below to be performed to ensure that users without
permissions are redirected correctly.

Go to Site Manager -> Settings -> Security & Membership, select the Intranet Portal site from the
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drop-down list on the top left, uncheck the Inherit from global settings box on the right of the Access
denied page URL setting and enter the appropriate value into the field. By default, the URL is ~/
Special-pages/Access-denied.aspx.

CMS Desk  User: & Global Administrator ¥ v6.0.4234 Sign Out

X
#1% Site Manager Sites Administration Settings Development Tools Dashboard Licenses Support Buy
Site:
Intranet Portal |z|
General
Settings

Administrator's e-mail V|

@ Content e Inherit from global settings

=5 URLs and SEO Send membership reminder (days) 2] Inherit from global settings

a Security & Membership

, System

= On-line marketing Registrations

ti! E-commerce

&4 Community Reserved user names (2] Inherit from global settings

* Intranet & Collaboration

{5 Versioning & synchronization Registration requires e-mail confirmation @ Inherit from global settings

Q_ Integrat\on. Registration requires administrator's approval @ I inherit from aglobal settings

< Cloud services
Delete non-activated user after (days) @ Inherit from global settings
Require unigue user e-mails @ Inherit from global settings

q
'|  On-line users
Update online users (minutes) @ Inherit from global settings
Content
Check page permissions & | Secured areas [T inherit from global settings
Website logon page URL @ |~/Logon.aspx [Tl inherit from global settings
(Access denied page URL &) ~/Special-pages/Access-denied.aspx. [Z] inherit from global semngs]

Click & Save to complete the process.

The content of the page is fully customizable. By default, the following message is displayed: You are
not allowed to access the required page. Please contact the administrator if you think you should be
allowed to access it.

Home Company Departments Workgroups Documents News Events Media Blogs Forums Employees

P

Access denied

You're not allowed to access the required page. Please contact the administrator if you think you should be allowed to
access it.

The pages of workgroups do not redirect to this page when accessed without the appropriate
permissions, since every workgroup has its own Access page dedicated to this purpose.

Blog unsubscribe

This page is used for the handling of blog post unsubscription requests. When a user subscribes to
receive notifications about new blog posts in some blog, a notification e-mail is sent to their e-mail
address when a new blog post is published. The notification e-mails contain unsubscription links leading
to this page.

When the page is accessed, the Blog post unsubscription web part on the page recognizes the
subscription based on a value passed in the query string, performs unsubscription and displays a
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message confirming it to the user. From now on, notifications about blog posts in the respective blog will
no longer be sent to the user.

The URL of the page must be entered in Site Manager -> Settings -> Content -> Blogs -> Blog
unsubscription URL in order for the links to be functional. The portal is already pre-configured for the
default location of this page, so you only need to modify it in case you wish to change the page's alias

path.

More information on blog subscriptions can be found in Developer's Guide -> ... -> Blog comments
notifications -> User subscriptions.

+ [Special pages/Blog unsubscribe - page template: Intranet Portal - Blog unsubscribe

v | zoneTop

o 8

v zoneCenter

v Heagerren G bscribtion

|v BlogPostUnsubscription @|

hd | zoneBottom |+

Board unsubscribe

This page is used for the handling of message board unsubscription requests. When a user subscribes
to receive notifications about new messages on a message board, a notification e-mail is sent to their e-
mail address when a new message is added. The notification e-mails contain unsubscription links
leading to this page.

When the page is accessed, the Message board unsubscription web part on the page recognizes the
subscription based on a value passed in the query string, performs unsubscription and displays a
message confirming it to the user. From now on, notifications about new messages on the board will no

longer be sent to the user.

The URL of the page must be entered in Site Manager -> Settings -> Community -> Message
boards -> Board unsubscription URL in order for the links to be functional. The portal is already pre-
configured for the default location of this page, so you only need to modify it in case you wish to change
the page's alias path.

More information on board subscriptions can be found in Developer's Guide -> ... -> Message board
notifications -> User subscriptions.

v | [Special pages/Board unsubscribe - page template: Intranet Portal - Board unsubscribe

- zoneTop

oo

v |zoneCenter
~ neaderText sUbscribtion

| ¥ | MessageBoardUnsubscription @
- | zoneBottom |+

Forum unsubscribe

This page is used for the handling of forum unsubscription requests. When a user subscribes to receive
notifications about new posts in a forum, a notification e-mail is sent to their e-mail address when a new
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forum post is added. The notification e-mails contain unsubscription links leading to this page.

When the page is accessed, the Forum unsubscription web part on the page recognizes the
subscription based on a value passed in the query string, performs unsubscription and displays a
message confirming it to the user. From now on, notifications about new posts in the forum will no longer
be sent to the user.

The URL of the page must be entered in Site Manager -> Settings -> Community -> Forums ->
Forum unsubscription URL in order for the links to be functional. The portal is already pre-configured
for the default location of this page, so you only need to modify it in case you wish to change the page's
alias path.

More information on forum subscriptions can be found in Developer's Guide -> Modules -> Forums ->
Subscriptions.

~ [Special pages/Forum unsubscribe - page template: Intranet Portal - Forum unsubscribe

v | zoneTop

o 8

v zoneCenter

v HeaderText ZisUbscribtion

| +  ForumUnsubscription @ |
- | zoneBottom |*

Invitation acceptation

This page is used to handle workgroup invitations. A new user can be invited to a workgroup via e-mail or
the internal messaging message. Both types of messages contain links that can be used to accept the
invitation. The links lead to this page.

When the page is accessed, the Group invitation web part on the page recognizes the invtation based
on a value passed in the query string and makes the user a member of the workgroup.

The alias path of the page must be entered in Site Manager -> Settings -> Community -> Invitation
acceptation path in order for the links to be functional. The portal is already pre-configured for the
default location of this page, so you only need to modify it in case you wish to change the page's alias
path.

v | [Special pages/Invitation acceptation - page template: Intranet Portal - Invitation acceptation

- zoneTop

oo

v |zoneCenter
v | HeaderText {33/

| ~ | Grouplnvitation | |
- | zoneBoftom |+

Registration approval

This page is used to handle registration confirmations. When a new user registers on the Logon page,
an e-mail is sent to them, asking them to confirm their registration by clicking a link in the e-mail. The
link leads to this page.
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When the page is accessed, the Registration confirmation web part on the page recognizes the
registration based on a value passed in the query string and confirms the user's registration. From now
on, the new user account will be enabled and the new user can log on to the portal using the account.

The URL of this page needs to be entered in the E-mail confirmation page property of the
Registration form web part on the Logon page. The web part is already pre-configured for the default
location of the page, so you only need to modify it in case you wish to change the page's alias path.

Detailed information on user registration can be found in Developer's Guide -> ... -> User registration ->
Registration approval and double opt-in.

~ [Special pages/Registration approval - page template: Intranet Portal - Registration approval

e
v zoneTop L'
s

v zoneCenter

v HeaderText S JONS

|v RegistrationConfirmation @|

hd | zoneBottom |+
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10 Intranet widgets and web parts

The portal comes with a number of widgets designed specifically for intranet scenarios. These widgets
are derived from standard Kentico CMS web parts, but have most of their properties pre-configured so
that the required configuration is limited to the minimum. In any case, you can always modify the
configuration of the widgets in Site Manager -> Development -> Widgets. Some of the widgets have
their properties configured depending on the default alias paths of certain documents in the content tree.

For more information on this topic, please refer to Customizing the portal -> Modifying structure of the

website.

All intranet widgets are stored in the Intranet Portal widget category. Other widget categories are also
available, but the widgets in them are meant for general use and it may be necessary to pre-configure
the properties of these widgets according to the document structure of the portal website. Each of the
widgets can be used in one of the following scenarios:

e User widgets - can be used by live site users on their personalizable pages, typically on the My
Dashboard page.

e Editor widgets - can be used by website editors on the Page tab in CMS Desk, typically on the
Home page of the global portal or of individual departments.

e Workgroup widgets - can be used by workgroup administrators, typically on each workgroup's Home

page.

The following paragraphs describe widgets in each of these three categories.
User widgets

General widgets
The following widgets are available in the root of the Intranet Portal category:

e My blogs - based on the Repeater web part, displays all blogs belonging to the current user.

e My blogs comments - based on the Blog comments viewer web part, displays blog comments
from all blogs belonging to the current user.

e My workgroups - based on the Groups viewer web part, displays all workgroups to which the
current user belongs.

Project management widgets
The following widgets are available in the Intranet Portal/Project management sub-category:

e My projects - Intranet Portal - based on the My projects web part, displays all projects for which
the current user has access permissions.

e Tasks assigned to me - Intranet Portal - based on the Tasks assignhed to me web part, displays
all tasks assigned to the current user.

e Tasks owned by me - Intranet Portal - based on the Tasks owned by me web part, displays all
tasks owned by the current user.
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{2 Select widget - Windows Internet Explorer

@5? Recently used widgets

Select widget

Widget name:

=5 [ |

[¥]Search in description

& All widgets
Categories -
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Community [ | - Y § | | | |
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General =

Intranet Portal My bl ts
& Project management v blogs commen

Maps
Media & services

85eH5HL

My projects -
Intranet portal

My workaroups Tasks assigned to

me - Intranet portal
Project managemeant

Syndication
Text

Tasks owned by me -
Intranet portal

6e66E

Intranet Portal

Editor widgets

The following widgets are available in the Intranet Portal widget category when adding widgets to pages
on the Page tab in CMS Desk.

General widgets

The following widgets are available in the root of the Intranet Portal category:

Employee of the month - based on the Editable image web part, displays an image selected by a
website editor.

Intranet canteen menu - based on the Static HTML web part, displays a pre-defined text, typically
a weekly canteen menu.

Intranet departments - based on the Repeater web part, displays a list of all existing
departments.

Intranet employees - based on the Users viewer web part, displays a list of all users of the
system (i.e. company employees).

Intranet latest blog posts - based on the Repeater web part, displays latest blog posts published
in the portal's global section.

Intranet latest forum posts - based on the Forum posts viewer web part, displays latest posts
from the global section's forums.

Intranet latest news - based on the Repeater web part, displays latest news published in the

© 2014 Kentico Software



Intranet widgets and web parts

135

portal's global section.

e Intranet poll - based on the Poll web part, displays a poll where users can vote to express their

opinion.

e Intranet quick links - based on the Static HTML web part, contains customizable links leading to
the most frequently used sub-sections of the portal.
e [ntranet upcoming events - based on the Repeater web part, displays the latest events scheduled
on the Events page of the global section.

r
2 Select widget - Windows Internet Explorer

4l Recently used widgets
) Al widgets
Categories
Community
Content
Corporate Site
Dashboard
Document library
Forms & Surveys
Forums
General
Intranet Portal
& Departments
Layouts
Maps
Media & services
MNavigation
Newsletters
Reporting
Syndication
Text

loyofof oyl ol cigy oy oy ol ol oy of o ol oy sy
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Department latest
blog posts
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month
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Intranet latest forum
posts

Intranet Portal

&

Department latest
forum posts

Intranet canteen
menu

)

Intranet latest news

big

Department latest
news

Intranet
departments

Intranet poll

=[5 [ |

Select widget

[¥]Search in description

E -

Department quick Department
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G
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\ﬁ.
=3 &
Er]

2

Intranet guick links

Intranet latest blog
posts

_ I3
¥

Intranet upcoming
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Department widgets

The following widgets are available in the Intranet Portal/Departments sub-category:

e Department latest blog posts - based on the Repeater web part, displays latest blog posts
published in the current department's section.

e Department latest forum posts - based on the Forum posts viewer web part, displays latest
posts from the current department's forums.

e Department latest news - based on the Repeater web part, displays latest news published in the
current department's section.

e Department quick links - based on the Static HTML web part, contains customizable links leading
to the Home page of the portal and sub-sections of the current department.

e Department upcoming events - based on the Repeater web part, displays the latest events
scheduled in the current department's calendar.
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r@ Select widget - Windows Internet Explorer E@g‘

48 Recently used widgets Widget name: [¥]Search in description
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i) Dashboard -
. . Department latest Department latest Department latest Department quick Department
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Workgroup widgets

The following widgets can be found in the Intranet Portal widget category when adding widgets to
workgroup pages:

e Workgroup administrators - based on the Group members viewer web part, displays all
administrators of the current workgroup.

e Workgroup latest blog posts - based on the Repeater web part, displays latest blog posts
published in the current workgroup's section.

e Workgroup latest forum posts - based on the Group forum posts viewer web part, displays
latest forum posts published in the current workgroup's section.

e Workgroup latest news - based on the Repeater web part, displays latest news published in the
current workgroup's section.

e Workgroup members - based on the Group members viewer web part, displays all members of
the current workgroup.

e Workgroup messages - based on the Group message board viewer web part, displays latest
messages from the current workgroup's message board.

e Workgroup quick links - based on the Static HTML web part, contains customizable links leading
to the Home page of the portal and sub-sections of the current workgroup.

e Workgroup recent pages - based on the Repeater web part, displays the latest wiki pages in the
current workgroup's section.
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e Workgroup upcoming events - based on the Repeater web part, displays latest events scheduled
in the current workgroup's calendar.
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11 Microsoft SharePoint integration

Using Microsoft SharePoint, you can collaborate and share files with your colleagues more effectively
and publish your website content more efficiently. Kentico CMS provides integration with SharePoint and
allows you to access data stored on a SharePoint (Windows SharePoint Senices 3.0 (WSS) or MOSS -
Microsoft Office SharePoint Server) server and display it on your site. This can be done using the web
parts of the SharePoint module. Please note that the module enables you to get list and list item data
from SharePoint and provide it to Kentico CMS. You can also download documents or images using the
SharePoint module. However, it is not possible to modify SharePoint data or display Kentico CMS data
in SharePoint.

How it works

SharePoint web parts use pre-generated proxy classes of selected SharePoint web senices to get data
from the senver. The following senices are used:

e http://server/_wvti_bin/Lists.asmx - methods for working with lists
e http://server/_vti_bin/Imaging.asmx - methods for working with picture libraries
e http://server/_vti_bin/Copy.asmx - methods for retrieving file content

The returned data is in CAML (XML) format, which needs to be further processed to display the data in a
meaningful way. XSLT or ASCX transformations may be used for this purpose. For ASCX, the CAML
response must be transformed to an ASP Dataset.

The whole integration functionality is provided by the following web parts from the Microsoft SharePoint
category:

e SharePoint data source - this data source web part enables you to retrieve some of the data from
the SharePoint sener. It uses web senices (Lists.asmx, Imaging.asmx).

e SharePoint datagrid - this web part displays a grid with data retrieved from the SharePoint senver. It
uses web senices (Lists.asmx, Imaging.asmx).

e SharePoint datalist - this web part enables you to retrieve and display some of the data from the
SharePoint server. It uses web senices (Lists.asmx, Imaging.asmx). The inner datalist control
displays can display the data in multiple rows/columns.

e SharePoint repeater - this web part enables you to retrieve and display some of the data from the
SharePoint server. It uses web senices (Lists.asmx, Imaging.asmx).
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Please note

Detailed information and examples of the use of these web parts can be found in the
SharePoint integration chapter in the Modules section of the Deweloper's Guide.

© 2014 Kentico Software


http://devnet.kentico.com/docs/7_0/devguide/sharepoint_Web_parts.htm

Index

Index
A -

accessing the administration interface 11
authentication 11

_C-

customization
color schemes 96
company logo 120
graphical themes 96
Home page modification 103
multilingual configuration 115
website structure modifications 111

D -

departments 17

creating new departments 20
customizing departments 29
features 37

security 36

document libraries 83

installation 7
Intranet Portal website 5
introduction 5

“K -

Kentico CMS Intranet Solution 5

Microsoft SharePoint 139

_P-

project management 73

"R -

RSS feeds 85

_S -

search 90

SharePoint integration 139
special pages 127
syndication 85

W -

WebDAV editing configuration 12

widgets 133

workgroups 42
creating new workgroups 49
customizing workgroups 63
document features 46
managing workgroups 44

141

© 2014 Kentico Software




	Introduction
	About this guide

	Getting started
	Installation
	Accessing the administration interface
	Configuration for WebDAV editing

	Departments
	Departments overview
	Adding new departments
	Customizing departments
	Departments security
	Managing department features

	Workgroups
	Workgroups overview
	Managing workgroups
	Managing document-based workgroup features
	Creating new workgroups
	Customizing workgroups

	Project management
	Project management overview
	Department projects
	Workgroup projects
	Ad-hoc projects

	Document libraries
	Document libraries overview

	Other features
	RSS feeds
	Search

	Customizing the portal
	Changing the themes
	Modifying the Home page
	Modifying structure of the website
	Configuration for multiple languages
	Changing the company logo

	Special pages
	Intranet widgets and web parts
	Microsoft SharePoint integration

