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1 Introduction

1.1 About this guide

This guide contains information about the E-commerce solution features of Kentico CMS, offering you a
full-featured E-commerce platform based on this CMS system. It will guide you through the basics of all
the E-commerce features and explain how your website can benefit from using them. It will also navigate
you through the related sections of the user interface and provide step-by-step examples that can be
tried out in order to get hands-on experience and see how they behave in real-world scenarios.

To be able to understand the content of this guide, it is highly recommended to be already familiar with
the basics of Kentico CMS. If you are completely new to Kentico CMS and have no previous experience
with it, we recommend you to go through Kentico CMS Tutorial before proceeding further in this guide.

In the E-commerce features topic, individual features are listed with links leading to their dedicated
chapters. Before going through the related step-by-step examples and trying out their functionality on
your Kentico CMS instance, it is recommended to install the sample E-commerce Site and configure
your on-line store settings to enable these features. It is also recommended to see the E-commerce
user interface topic in order to get familiar with the sections of the user interface where the E-commerce
features are located.

Please note

Built-in Context Help

Basic documentation of particular sections of the system's user interface can be found
in Kentico CMS Context Help. It is useful in case that you need a quick explanation of
the currently used functionality.

If you click the  icon in the top right corner of each UI screen, you get redirected to
the appropriate Context Help page which describes the current UI screen. The Context
Help is embedded in the web project, so you don't even need to have Internet
connection to view it.

1.2 E-commerce features

The E-commerce solution allows your on-line store customers purchasing via the integrated shopping
cart, checking the status of their orders, subscribing to newsletters, etc.

Site owners are given tools for managing orders, shipping and payment options, product or manufacturer
lists and much more.

Among the features offered by the E-commerce solution you can find:

http://devnet.kentico.com/docs/7_0/tutorial/index.html
http://devnet.kentico.com/docs/7_0/contexthelp/index.html
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Departments - allows to manage departments to organize the products and services that you offer in
your on-line store.
Products - allows to manage products and services offered in your on-line store.
Product options - allows to manage options added to the offered products and services.
Product image galleries - allows to create galleries of the offered articles. For example, you can
present your customers with featured images of a given article.
Product categories - allows to sort products based on topic-related groups.
Multilingual products - allows to offer products in multiple language versions.
Product workflow - allows to set up a reviewing and approval process to ensure quality of content and
design.
Multiple currencies and exchange rates - allows your on-line store customers to make orders in
currencies different from the main currency.
Configurable tax calculation based on country and state
Discounts - in Kentico CMS you can grant your on-line store customers the following types of
discount:

Discount coupons
Discount levels
Volume discounts

Customers - allows to manage customers who purchase the products offered in your on-line store.
Orders - allows to manage orders of the offered products.
Site-specific and global data - the concept allows you to use both site-specific objects available on
the respective sites only and global objects shared across all your sites.
Reports and statistics - the feature allows to view reports and statistics related to your on-line store.
Custom providers for alternative shipping and tax calculations.
Custom checkout process - allows to customize the checkout process.
Built-in payment gateways such as PayPal and Authorize.NET are supported.
Custom payment gateways support allows to integrate your own payment gateways.
Mobile device support

From this topic you can also navigate to an introductory chapter focused on gaining your first experience
with the E-commerce solution and to general chapters dedicated to your on-line store:

Configuration - learn how to set up your on-line store and perform all necessary configurations to
start your e-business.
Management - learn how to manage E-commerce solution objects.
Security - the section describes the security features of the E-commerce solution.
Customization - outlines the possibilities of E-commerce solution features customization.
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2 Getting started

2.1 Overview

This chapter will help you install your sample E-commerce site, containing all E-commerce solution
features described further in this guide. Besides, the chapter describes in which parts of the Kentico
CMS user interface these features can be found and you will also learn about the CMS system's mobile
device support.

2.2 Installing the sample E-commerce site

Examples in this guide are based on the sample E-commerce Site. It is therefore recommended to
have this website installed in order to try out the examples in practice. This topic provides information on
how to install the website and is divided into two parts, depending on if you already have Kentico CMS
installed (but without the E-commerce Site), or if you are performing a completely new installation.

New Kentico CMS installation

Installation of Kentico CMS is fully described in Developer's Guide -> Installation and deployment. The
following points sum up which steps need to be taken in order to perform the installation and provide
links to the relevant topics in that chapter of the Developer's Guide:

1. Launch KenticoCMS_<version>.exe and follow the instruction in Installation procedure -> Setup
(KenticoCMS.exe).

2. Once the setup finishes, launch Kentico CMS Web Installer and follow the instructions in Installation
procedure -> Web installer.

3. When the Web Installer is finished, access the URL of the new website. The first step of the
Database Setup will be displayed. Follow the instructions in Installation procedure -> Database setup,
until you reach the Starter Site step (the number of the step may vary). In this step, select the Choose
starter site option and choose the E-commerce Site sample site. Click Next to continue.

http://devnet.kentico.com/docs/7_0/devguide/installation_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/setup_kenticocms_exe.htm
http://devnet.kentico.com/docs/7_0/devguide/setup_kenticocms_exe.htm
http://devnet.kentico.com/docs/7_0/devguide/web_installer.htm
http://devnet.kentico.com/docs/7_0/devguide/web_installer.htm
http://devnet.kentico.com/docs/7_0/devguide/database_setup.htm


Kentico CMS 7.0 E-commerce Guide12

© 2014 Kentico Software

4. Wait until the Database Setup finishes importing the site. Once finished, the Finished step will be
displayed. Click the Continue to the new website link highlighted in the screenshot below.
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5. You will be redirected to the Home page of the website.

Existing Kentico CMS installation

If you already have Kentico CMS installed, but without the sample E-commerce Site, you can add it
using the New site wizard.

1. Log on to Site Manager and on the Sites tab click  New site wizard.

2. In the first step of the wizard, choose the Use website template option and click Next.

http://devnet.kentico.com/docs/7_0/devguide/new_site_wizard.htm
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3. In Step 2, choose E-commerce Site from the list of available website templates and click Next.
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4. Go through the rest of the wizard as described in Developer's Guide -> ... -> New site wizard ->
Website template. It is recommended to leave the default settings unless you really need to change
them according to your specific requirements. Once the wizard finishes, you should see the website
present in the list of websites in Site Manager -> Sites.

5. Log out of the administration interface (use the Log out button at the top right corner of the UI). You
will be redirected to the Home page of the website.

http://devnet.kentico.com/docs/7_0/devguide/website_template.htm
http://devnet.kentico.com/docs/7_0/devguide/website_template.htm
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2.3 E-commerce user interface

Once you have Kentico CMS and the sample E-commerce Site installed, it is a good idea to get familiar
with the parts of Kentico CMS user interface where the E-commerce solution features are located.

Getting familiar with the UI

1. To get started, log on to CMS Desk. This can be done either by clicking the CMS Desk link in the
header of the sample E-commerce Site ...

... or by directly entering an address in the following format into your browser's address bar: http://
<website domain>/cmsdesk

2. Once in CMS Desk, navigate to the E-commerce tab, which is the main E-commerce solution user
interface encapsulating all its main features. You can access the features, i.e. Orders, Customers,
Products, etc., using the ribbon at the top of the screen.

3. The above mentioned interface is site-specific, which means that it provides functionality related only
to the website currently edited in CMS Desk. However, in Site Manager -> Tools -> E-commerce
configuration you can perform global configuration of the whole E-commerce solution. Please refer to
the Multisite store chapter for more details.
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4. Besides, there are a number of settings that can modify behavior of the E-commerce solution
features. These settings can be adjusted in Site Manager -> Settings and are located under the E-
commerce settings category highlighted in the screenshot below.

5. Now go to CMS Desk, switch to the E-commerce tab and click the Products button. This is where
all products defined in your on-line store are listed. If you need to manage any of them, click the Edit (
) icon on the corresponding line.



Kentico CMS 7.0 E-commerce Guide18

© 2014 Kentico Software

6. Finally, navigate to CMS Desk -> Content -> Edit and expand the content tree. As you can see, the
Products section's structure corresponds to the structure depicted in the previous screenshot. This
means that you can edit the products offered in your on-line store also in this part of the administration
interface.

2.4 Mobile device support

The number of visitors who access websites using their mobile devices has risen dramatically over the
last few years. With Kentico CMS, you are well prepared for this challenge as your on-line store website
supports all commonly used mobile platforms, such as Android, Symbian, Blackberry, etc.
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You can find further details in the Going mobile section of the Kentico CMS 7: New E-commerce
Starter Site blog post.

http://devnet.kentico.com/Blogs/Petr-Vozak/August-2012/Kentico-CMS-7-New-E-commerce-Starter-Site.aspx
http://devnet.kentico.com/Blogs/Petr-Vozak/August-2012/Kentico-CMS-7-New-E-commerce-Starter-Site.aspx
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3 Configuring your store

3.1 Overview

When you start using the E-commerce solution, it is recommended that you configure it in the
following order:

1. Configure the use of site-specific and global objects and site-specific and global settings that
will be used in your multisite store (in case you plan to work in a multisite environment).
More details can be found in the Multisite store chapter.

2. Configure other E-commerce solution settings.
More details can be found in the Settings chapter.

3. Perform additional configuration tasks such as checkout process, payment gateways, invoices/
receipts and multilingual store configuration.

4. Create and set up the E-commerce solution features (unless you have done so already).
More details can be found in the Managing your store chapter.

3.2 Multilingual store

Kentico CMS allows you to have your website content translated into multiple languages. In a
multilingual store this typically applies to products, which may have separate language versions.
Individual cultural versions of your on-line store content may be displayed to the customers automatically
based on various settings, and the users of your website can also switch between individual languages
manually using dedicated web parts.

If multilingual support is enabled in your on-line store, you can see a dedicated section with language
selection options above the product sections tree. Using the options, you can switch between particular
language versions of the currently selected section or product. Besides, the Languages column in the
list of products indicates which cultural versions are currently available on the website.

You can also click the Compare ( ) button to switch to the language version comparison mode and
edit language versions side-by-side. However, currently only product fields in General tab -> Custom

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/language_versions_comparison.htm
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properties (except for those added to the Ecommerce - SKU table), along with the following product
fields in General tab -> General can be localized (and also the Section name field when editing a
product section):

Product name 
Short description
Description

Please note that only a product created the recommended way (i.e. created as SKU + associated
product type document) can be localized. This means that a separate product object (i.e. stand-alone
SKU) cannot have different language versions.

For further details concerning the use of multilingual content in Kentico CMS, please refer to the 
Multilingual content chapter in the Content management section of the Developer's Guide.

3.3 Multisite store

3.3.1 Overview

Kentico CMS allows you to use in your on-line store both site-specific objects available for the respective
sites only and global objects shared across all your sites. This approach not only gives you more
flexibility but is also highly effective in multi-site environment, e.g. when hosting several e-commerce
sites for different customers.

To learn how to allow global data on the given site, please refer to the Enabling the use of global objects
topic.
Security matters related to your E-commerce package site separation are described in the Security
topic.

In the E-commerce solution, there are three groups of objects available for a particular site from the point
of view of site separation:

http://devnet.kentico.com/docs/7_0/devguide/multilingual_content_overview.htm
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Objects with both site and global option include objects which can be used either as site-specific
or site-specific together with global. Further details can be found in the Site and global data topic.
Objects with only site or global option include objects which can be used only separately, either
as site-specific or global. Further details can be found in the Site and global configuration topic.
Objects with special cases include objects which cannot be put into either of the above groups.
Further details can be found in the Special cases topic.

Before you start configuring and using global data in your on-line store, you should learn what basic E-
commerce solution configuration scenarios are available with regard to site separation.

3.3.2 Basic configuration scenarios

This topic describes basic E-commerce solution configuration scenarios with regard to site separation.
There are three such scenarios:

Single site (on-line store)

Typically, if you have only one on-line store, you should always use site data only. It helps you build
other on-line stores in the future without any problem.

Multiple sites (on-line stores)

This scenario concerns multiple sites (on-line stores) which are owned and managed by a single
organization. Typically, there is a need for global data which should be shared across all sites. The set
of settings for objects with both site and global option and objects with only site or global option covers
all typical scenarios for the usage of global data.

Multiple sites (on-line stores)

This scenario concerns multiple sites (on-line stores) which are owned and managed by different
organizations. Typically, global data cannot be used because of the different owners of the on-line
stores. Therefore, each site should be configured to use site data only.

3.3.3 Enabling the use of global objects

Here you will learn how certain authorized users can enable the use of global objects for the E-
commerce solution. There are three options to perform this task:

Site Manager -> Settings

You can navigate to Site Manager -> Settings. Using the Site drop-down list select (global) to perform
the configuration globally or choose one of the available sites to perform configuration for this particular
site only. Then choose E-commerce -> Global objects from the settings tree and mark the
checkboxes next to objects which should be used as global objects. Click  Save. For general
information on how to configure settings in Kentico CMS, please refer to Developer's Guide -> Website
settings.

http://devnet.kentico.com/docs/7_0/devguide/settings_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/settings_overview.htm
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Site Manager -> Tools

You can perform this configuration also in Site Manager -> Tools -> E-commerce configuration ->
Store settings on the Global objects tab. You need to mark the checkboxes next to objects which
should be used as global objects and click  Save.

Please note that only global configuration can be performed from this part of the administration interface;
i.e. you cannot select a site here. The system thus behaves as if you selected (global) from the Site
drop-down list in Site Manager -> Settings.

CMS Desk -> E-commerce
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The third option is to navigate to CMS Desk -> E-commerce -> Configuration -> Store settings. Here,
you need to switch to the Global objects tab and mark the checkboxes next to objects which should
be used as global objects.

As you are now performing configuration for a particular site, you can optionally enable inheriting of the
settings for the given objects from the global settings. This can be done using the Inherit from global
settings checkboxes; more details can be found in the Website settings chapter of the Developer's
Guide. Click  Save to save the configuration.

Marking the checkboxes in the Allow global objects for category allows global objects which can be
used together with the site-specific objects.

Marking the checkboxes in the Use global settings for category results in allowing global objects
which need to be used separately from their site-specific counterparts.

Please note

Global objects can use data from other global objects only. When editing a global
object, only global data is thus available in its editing interface, regardless of the global
objects settings for the given site.
For example, a global product can be in a global department only and it can have only a
global manufacturer, a global supplier, etc. assigned. Also the price of a global product
is set in the global currency.

3.3.4 Site and global data

Included are objects which can be used on a particular site either as site-specific objects or as a
combination of site-specific and global objects. The following objects belong to this group:

Products
Product options
Manufacturers
Suppliers
Discount coupons
Discount levels
Departments

http://devnet.kentico.com/docs/7_0/devguide/settings_overview.htm
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Shipping options
Payment methods

1. If global objects belonging to this group are allowed for the current site, the Site drop-down list with
the following options is available on the object page:

(global and this site) - both global and current site data is listed; global objects are marked Yes in
the Is global column. The option does not allow to create a new object and the button to create one
is disabled.
(global) - only global data is listed. The option allows authorized users to create a new global object.
current site - only current site data is listed. The option allows users to create a new site-specific
object; the default option.

2. If global objects belonging to this group are not allowed for the current site, the Site drop-down list is
hidden and only current site-specific objects are listed.
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Products

If global products are allowed for the current site, the Products drop-down list allows you to filter and
view global products, current site products or a mix of global and current site products. However, if global
products are not allowed for the current site, only products created on the current site can be viewed.

If you decide to add a new product (by clicking the  New button and choosing the appropriate product
type from the Product types list), you can choose from the following SKU (product object) binding
options:

Create a new SKU (recommended) - creates a new site-specific SKU; the recommended option.
Create a new global SKU - creates a new global SKU.
Use an existing SKU - if you choose this option, the Select button is displayed allowing you to use
an existing SKU. Click the button and then select the required SKU (site-specific or global) from the 
Select product dialog.

Discount levels

If global discount levels are allowed for the current site, you can assign a registered customer both a
discount level defined for the current site only and a global discount level (if defined) using the Global
discount level and Discount level on this site drop-down lists. This can be done while editing the
given customer on the General tab in the Registered user info -> Discounts section.

Please note that if both the selected levels apply to a given product (i.e. if they apply to a department
responsible for this product), the site-specific level will be used for the price of the product to be reduced.



Kentico CMS 7.0 E-commerce Guide28

© 2014 Kentico Software

3.3.5 Site and global configuration

Included are objects which can be used on a particular site only separately, either as site-specific
objects or as global objects. The following objects belong to this group:

Tax classes
Currencies
Exchange rates
Customers credit
Order statuses
Public statuses
Internal statuses
Invoice

1. If global settings for objects belonging to this group are used on the current site, only global objects
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are listed.

2. If global settings for objects belonging to this group are not used on the current site, only site-specific
objects are listed. Besides, the  Copy from global button is visible, enabling you to copy global
settings for the given object.

On condition that a site-specific object with the same code name like a corresponding global object
exists, the site-specific object is updated with global data if you are copying from global settings. If a
site-specific object has no such counterpart among global objects, it is lost. However, providing there is
no dependency on other objects in the system. If this is the case the object is only disabled but remains
in the system.

Exchange rates

Only the following combinations of currency and exchange rate settings should be applied when
configuring your online store:

Site settings for currencies + site settings for exchange rates
Global settings for currencies + global settings for exchange rates
Global settings for currencies + site settings for exchange rates

Kentico CMS allows you to view prices in different currencies both in the user interface and on the
live site. For this to be possible, one or two currency conversions are performed by the CMS
system, based on your store configuration.
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One currency conversion

One currency conversion from the main currency to other currencies, i.e. from the site main currency
to other site currencies or from the global main currency to other global currencies, is performed. Only
one table is displayed in the user interface.

This regards the following configurations:

No price-related global objects (i.e. global products, global product options, global discount coupons
or global taxes) are allowed on the current site.
At least one type of such global objects is allowed and global settings for currencies are used on the
current site.
At least one type of such global objects is allowed and site settings for currencies are used on the
current site. The global main currency and the site main currency are the same (i.e. both the
currencies have the same code names). Please note that this does not apply if the price is converted
from global currency XY to site currency XY and site currency XY is not the site main currency
(regardless of the currencies' code names).

Two currency conversions

Two currency conversions are performed, the first from the global main currency to the site main
currency and the latter from the site main currency to other site currencies. Two tables are
displayed in the user interface.

This regards the following configuration:

At least one type of price-related global objects is allowed and the site settings for currencies are
used on the current site. The global main currency and the site main currency are not the same (i.e.
the currencies do not have the same code names).
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3.3.6 Special cases

This group includes special objects from the point of view of site separation, which cannot be regarded
as objects with both site and global option or objects with only site or global option. The following
objects belong to this group:

Orders - are bound to a particular site.
Customers - an anonymous customer is bound to a particular site, same as a registered one who is
bound through their user's account. This dependency enables registered customers to have preferred 
currency, payment methods and shipping options on different sites. As concerns the customers'
credit, users can use both their global credit and credit bound to a given site. However, these cannot
be mixed together, i.e. the customer can pay on the given site either with global credit or with site-
specific credit.

3.3.7 Security

Enabling the use of global objects

Only global administrators can enable the use of global objects.

Managing global objects

Only global administrators and users with the Modify global data and Modify global configuration
permissions (see Developer's Guide -> Development -> Membership, permissions and security ->
Permissions) can create, modify and delete global objects.

For more detailed information about these permissions, same as for a comprehensive description of how
security is supplied in the E-commerce solution, please refer to the Security chapter.

3.4 Settings

3.4.1 Overview

In this sub-chapter, you will learn about settings which influence and modify the behavior of your on-line
store. These settings can be adjusted in the Site Manager -> Settings section of the system's user
interface. Here, they are located in the E-commerce settings category and its sub-categories. Please
note that E-commerce solution settings can be configured also from alternative locations. You can find a
detailed description of how and where this configuration can be done in the Site settings topic.

You will also learn how to further modify functionality of the module by adding and setting keys in the 
appSettings section of your project's web.config file, as descibed in detail in the Web.config settings
topic.

3.4.2 Site settings

To adjust your on-line store settings, navigate to Site Manager -> Settings and from the settings tree
select the E-commerce category. Depending on your selection in the Site drop-down list, you can
either adjust the settings for a particular website, or globally if the (global) option is selected. Global
settings can be inherited by individual sites if the Inherit from global settings check-box next to a

http://devnet.kentico.com/docs/7_0/devguide/User_management.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/Configuring_settings.htm
http://devnet.kentico.com/docs/7_0/devguide/Configuring_settings.htm
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site-specific setting is enabled.

Alternatively, you can set these settings also in CMS Desk or in Site Manager -> Tools with the
exception of Payment gateways settings, which cannot be set from those alternative locations.

E-commerce

Here you can set the following E-commerce solution settings:

Products UI

Display tree of product sections - indicates whether the tree of product sections is displayed in the
products administration UI. If the sections tree is hidden, only stand-alone SKUs can be created from
the products administration UI. Otherwise, a complete product (i.e. an SKU with its document
representation in the sections tree) can be created.
Products starting path - a path within the content tree where the subtree of product sections starts,
e.g.: /Products. This subtree is then displayed in the products administration UI. However, the setting
has no effect if the sections tree is hidden. Please refer to the Display tree of product sections setting
for more details.
Display products in sections tree - indicates if products should be displayed in the product
sections tree. This setting has no effect if the sections tree is hidden. Please refer to the Display tree
of product sections setting for more details.
Allow stand-alone SKUs - indicates whether it is possible to create stand-alone SKUs (i.e. SKUs
without their document representations in the sections tree). If so, the stand-alone SKUs node is
displayed in the product sections tree in the products administration UI. This setting has no effect if
the sections tree is hidden. Please refer to the Display tree of product sections setting for more
details.

Products properties

Related products relationship name - the name of the relationship which is used for defining
related products. If you leave the default option, i.e. (all), the user can choose from all relationships
defined on the given site when adding related products. This gives them the possibility to use more



Configuring your store 33

© 2014 Kentico Software

than one type of relationship among products.
Products are 'new' for - the number of days for which created products are marked as New
products in the store. The days are counted based on the product's In store from property.
Public status for 'new products' - a product public status indicating that the respective product has
been evaluated as new. Any product may be marked with this status automatically based on the 
Products are new for setting and In store from product property, regardless of the product-specific
public status settings. Properties of the status are then used when displaying the product status
indicator on the live site.
Default product image URL - the default product image URL (virtual path). This image is used if no
image is specified for a given product.

Taxes

Default country - allows to set the default country, choose your country or country where you sell
the most. All taxes are applied based on their values in the default country unless the customer
specifies their country or state during the checkout process.
Apply taxes based on - indicates whether the taxes are applied based on a shipping or billing
address. Taxes related to orders without a shipping address will be calculated based on a billing
address, regardless of this setting.

Live site pricing

Display price including discounts - indicates if product prices on the live site are displayed
including discounts. This takes effect only for prices that are displayed using the 
GetSKUFormattedPrice() or GetSKUPriceSaving() methods.
Display price including taxes - indicates if product prices on the live site are displayed including
taxes. This takes effect only for prices that are displayed using the GetSKUFormattedPrice() or
GetSKUPriceSaving() methods.

Accounts

Allow anonymous customers - indicates if customers need to register on your site so that they can
make the purchase.
Use an extra company address - indicates if the option of providing a company address is available
in the check out process.
Require company account information - indicates if it is compulsory to provide company account
information during the check out process.
Show Tax registration ID field - if checked, customer details will contain the tax registration ID
field (e.g. VAT registration ID). The field will be displayed also in My account on the live site and
during the check out process.
Show organization ID field - if checked, customer details will contain the organization ID field. The
field will be displayed also in My account on the live site and during the check out process.
Invoice number pattern - a pattern used for invoice number generating. The default pattern {%
Order.OrderID%} is used when left empty. In that case, the invoice number is equal to the ID of the
order.

Shipping

Weight formatting string - the format used to display product weight. Use the {0} expression to
insert the weight into the formatting string.
Minimal amount for free shipping - the minimum order value in the store main currency when the
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shipping is not charged.

Pages

My account URL - the URL of the My account page (virtual path).
Wishlist URL - the URL of the Wishlist page (virtual path).
Shopping cart URL - the URL of the Shopping cart page (virtual path).
Redirect to shopping cart - if checked, the user is redirected to the shopping cart content page
when the Add to shopping cart button is clicked. Otherwise, the user stays on the same page and
the product is added to the shopping cart at the background.

E-mails

Send e-commerce e-mails from - an e-mail address from which the E-commerce notification e-
mails are sent.
Send e-commerce e-mails to - an e-mail address (e.g. merchant's e-mail address) to which the E-
commerce notification e-mails are sent.
Send order notification - indicates if e-mail notifications are sent after an order has been finished
and saved. The E-commerce order notification to customer e-mail template is used when sending a
notification to a customer. The E-commerce order notification to administrator e-mail template is
used when sending a notification to the administrator.
Send payment notification - indicates if e-mail notifications are sent after the payment has been
completed. This is done automatically by the system on condition that the user paid using a payment
gateway or if the order changed its status to one with the Mark order as paid property enabled
(available in E-commerce -> Configuration -> Order status -> Edit ( ) order status). Besides, a store
administrator can manually complete the payment by enabling the Order is paid property (available in
CMS Desk -> E-commerce -> Orders -> Edit ( ) order on the Billing tab). Please note that the E-
commerce - Order payment notification to customer e-mail template is used when sending a
notification to a customer, whereas the E-commerce - Order payment notification to administrator e-
mail template is used when sending a notification to an administrator.
Send e-products reminder (days) - the number of days prior to e-product expiration when a
notification is sent to the user.
Use customer's culture for e-mails - indicates if e-mails to customers should be sent in the
shopping cart culture.

 

Conversion tracking

Registration conversion name - the name of the conversion that will be logged when a user
successfully registers on the website through the checkout process.
Registration conversion value - sets a number that will be recorded as the value of the registration
conversion whenever it is logged. The values are cumulative, i.e. when a conversion hit is logged, the
specified value is added to the total sum previously recorded for the conversion. You may insert a
macro expression into this field to dynamically retrieve a value from the current website context.
Order conversion name - the name of the conversion that will be logged when a user completes an
order.
Order conversion value - sets a number that will be recorded as the value of the order conversion
whenever it is logged. The values are cumulative, i.e. when a conversion hit is logged, the specified
value is added to the total sum previously recorded for this conversion. You may insert a macro
expression into this field to dynamically retrieve a value from the current website context, e.g. {%
EcommerceContext.CurrentShoppingCart.TotalPrice %}.
Add to shopping cart conversion name - the name of the conversion that will be logged when a
user adds a product to the shopping cart.
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Add to shopping cart conversion value - sets a number that will be recorded as the value of the
add to cart conversion whenever it is logged. The values are cumulative, i.e. when a conversion hit is
logged, the specified value is added to the total sum previously recorded for this conversion. You may
insert a macro expression into this field to dynamically retrieve a value from the current website
context, e.g. {% ShoppingCartItem.UnitTotalPrice %}.

E-commerce -> Global objects

To learn how to enable and configure E-commerce solution global objects, please refer to the Enabling
the use of global objects topic.

E-commerce -> Payment Gateways -> Authorize.NET

Here you can set the following payment gateway settings:

API Login - allows to set the API login ID for the payment gateway account.
Transaction key - the transaction key obtained from the merchant interface.
Use test mode - gateway behavior depends on test mode settings both in the CMS administration
interface (Site Manager -> Settings) and in the Authorize.NET Merchant Interface. Test mode
configuration in the CMS administration interface and in the Authorize.NET Merchant Interface
resulting in the transaction being processed as a test transaction: ON/ON, OFF/ON, ON/OFF. Test
mode configuration resulting in the transaction being processed as a live transaction: OFF/OFF.

For more information please see the Authorize.NET topic.

E-commerce -> Payment gateways -> PayPal

Here you can set the following payment gateway settings:

Business - the e-mail address used for merchant's PayPal account.
Cancel return URL - the URL to which the buyer's browser is redirected if the payment is cancelled,
e.g.: a URL on your website that displays your custom Payment cancelled page. By default, i.e. if no
such URL is defined, the browser is redirected to a corresponding PayPal webpage.
Notify URL - the URL to which PayPal posts information about the transaction. If set, overrides the
settings in PayPal merchant's interface.
Return URL - the URL to which the buyer's browser is redirected after completing the payment, e.g.:
a URL on your website that displays your custom Thank your for your payment page. By default, i.e.
if no such URL is defined, the browser is redirected to a corresponding PayPal webpage.

For more information please see the PayPal topic.

CMS Desk

Settings which influence and modify the behavior of the E-commerce solution on the current site can be
configured also in CMS Desk -> E-commerce -> Configuration -> Store settings. This part of the
administration interface is divided into tabs. Most of the settings can be configured on the General tab
and the ones related to e-mails, global objects and on-line marketing (i.e. conversion tracking) have their
own tabs.

General tab
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Please note that on the General tab in the Currencies section you can configure the main currency of
your on-line store.

Main currency - the default currency used as base for calculation of exchange rates. After clicking
the Change button a new dialog appears enabling you to select items which should be converted to
the new main currency based on the current exchange rate.

Checkout process tab

This tab allows you to set up and manage steps of your on-line store checkout process. Please refer to
the Checkout process chapter for further information.

Site Manager -> Tools

E-commerce solution settings in Site Manager -> Tools -> E-commerce configuration -> Store
settings are organized the same as in CMS Desk -> E-commerce -> Configuration -> Store settings.
However, only global configuration can be done from this location, i.e. you cannot adjust the settings for
a particular site from here.

3.4.3 Web.config settings

In the web.config file, you can set appropriate keys in the following location to modify functionality of
your on-line store:



Configuring your store 37

© 2014 Kentico Software

<configuration>
  <appSettings>
    <add key="CMSEnableOrderItemEditing" value="true" />
    .
    .
    .
  </appSettings>
</configuration>

The following keys can be set: 

CMSUseCurrentSKUData If set to false (default value), the name and price of an existing order
item are used while editing order items.

If set to true, the current name and price of a product are used while
editing order items.

CMSEnableOrderItemEdit
ing

If set to true and an order is not marked as paid, it is possible to Edit (
) order item price, name and quantity. Please note that you can make

these changes only if the CMSUseCurrentSKUData key is set to false
at the same time.

Set to false by default.

CMSUseMetaFileForProd
uctImage

If set to true (default value), the user is asked to choose a product
image from the file system on their computer. The product image is
uploaded to a server and saved as a metafile of the given product (a
product image document of the cms.file type is not created). The path
to the given metafile is saved as a product image path (SKUImagePath).

If set to false, the user is asked to choose a document of the cms.file
type to become a product image. The path to the selected document is
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saved as a product image path (SKUImagePath).

CMSShoppingCartExpirat
ionPeriod

Specifies the number of days after which a shopping cart is considered
to be old and is removed by the Deleting old shopping carts task.

Custom web.config settings

You can add your own settings (key and its value) into the web.config file.To work with these settings,
use methods of the CMS.SettingsProvider.SettingsKeyProvider class.

The following example shows how to get the value (type of double) of the key named MyCustomKey.

[C#]

double value = CMS.SettingsProvider.SettingsKeyProvider.GetDoubleValue
("MyCustomKey");

3.5 Checkout process

3.5.1 Overview

The checkout process in Kentico CMS provides a mechanism that the customers must go through to
purchase products or services offered in your on-line store. Although the process is fully automatic and
no direct involvement by your staff is needed, you have full control over the process. This is because you
can define and customize the actual checkout process steps.

The checkout process in Kentico CMS is more intuitive and enjoyable for your customers because it
offers, among other features:

The option to checkout as an anonymous customer or as a registered customer.
A clear indication of the steps/progress throughout the entire checkout process.
Retention of information that the customer entered in the previous steps.
The option to create custom checkout process steps.

3.5.2 Checkout process

In this topic you will learn how to configure the checkout process that the users go through when
purchasing in your on-line store.

Configuring the checkout process

The checkout process can be configured in CMS Desk -> E-commerce -> Configuration -> Store
settings -> Checkout process (or in Site Manager -> Tools -> E-commerce configuration -> Store
settings -> Checkout process; global checkout process only). In this section of the administration
interface, you can see a list of all currently defined checkout process steps. You can create a new step
by clicking the  New step button and you can also Edit ( ) or Delete ( ) the existing steps or
change their succession ( ), ( ). Besides, you can generate a default process using the  Generate
default process button or you can generate the process from global settings using the  Generate
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from global process button (CMS Desk only). However, in both these cases, your current process will
be lost. Please note that the purchase process can be enhanced with your custom steps.

In the four right columns of the list you can see if the particular step is displayed (Yes) or not (No) in the
given section of the CMS.

When creating a new step or editing an existing one, you can specify the following properties:

Caption - the name of the step displayed to users on the live site and in the administration interface.
Code name - the name of the step used by developers in the code.
Image file name - here you can set the name of the image file used for the current step.
Control path - allows you to specify the path to the control file.
Show on the live site - indicates if the step should be displayed on the live site.
Show in CMSDesk customer section - indicates if the step should be displayed in the customer
section.
Show in CMSDesk order section - indicates if the step should be displayed in the order section.
Show in CMSDesk order items section - indicates if the step should be displayed in the order
items section.
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Checkout process types

Checkout process can be performed at four different locations:

Creating a new order on the live site.
Creating a new order in CMS Desk -> E-commerce -> Orders.
Editing an existing order in CMS Desk -> E-commerce -> Orders -> Edit ( ) order -> Items.
Creating a new order or editing an existing one in CMS Desk -> E-commerce -> Customers -> Edit
( ) customer -> Orders.

3.5.3 Creating a custom checkout process step

Here you will learn how to create a custom checkout process step to enhance the purchase process to
best fit your needs.

1. Create a new web user control (*.ascx) and place your own form controls into it.
2. Go to its code behind and set the control class to inherit from 

CMS.EcommerceProvider.ShoppingCartStep.
3. There are several methods you can override to reach the required functionality:

IsValid() - validates the current step custom data and returns a validation result. True - all step data
is correct and can be processed, False - some step data is not correct or missing and cannot be
processed. In this case an appropriate error message should be displayed. By default, True is
returned.
ProcessStep() - processes the current step information (updates the shopping cart data) and
returns a result of this action. True - the shopping cart data was updated successfully and the
customer can be moved to the next checkout process step, False – the shopping cart update failed
and the customer cannot be moved to the next step. In this case an appropriate error message
should be displayed. By default, True is returned.
ButtonBackClickAction() - defines an action which is run after the Back  button is clicked. By
default, the parent shopping cart control method ButtonBackClickAction() is called, which moves
the customer one step backward in the checkout process.
ButtonNextClickAction() - defines an action which is run after the Next button is clicked. By
default, the parent shopping cart control method ButtonNextClickAction() is called, which moves the
customer one step forward in the checkout process when the current step data is valid and
processed successfully.

4. There are several properties you should use to get or set the required information:

ShoppingCartControl - the parent shopping cart control to which the step belongs.
ShoppingCartInfoObj - the shopping cart object which stores all data during the checkout
process.
CheckoutProcessStep - the checkout process step information.

5. The step control is created and can be registered as your custom checkout process step.

If a control represents checkout process steps in different checkout process types and these steps differ
from each other only slightly, you can create one control and specify different behavior depending on the
checkout process type as follows:

[C#]
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using System;
using CMS.EcommerceProvider;
using CMS.GlobalHelper;

switch (this.ShoppingCartControl.CheckoutProcessType)
{
    case CheckoutProcessEnum.LiveSite:
        // Here comes the code which will be run only 
        // when it is a checkout process on the live site
        break;

    case CheckoutProcessEnum.CMSDeskOrder:
        // Here comes the code which will be run only 
        // when it is a checkout process in the section CMSDesk/Tools/E-commerce/
Orders
        break;

    default:
        // Here comes the code which will be run in all other cases
        break;
} 

Example - My step

The following example shows a simple checkout process step definition. The step displays the total
price and an editable field to insert a customer comment. After the Next button is clicked, the editable
field is checked for emptiness. If it is not empty, the customer comment is saved and the shopping cart
data is updated. Otherwise, an appropriate error message is displayed. If the customer is a member of
the VipCustomers role, an extra step with an additional form for VIP customers is loaded
(MyVipStep.ascx). The Back button action is not overridden.

MyStep.ascx

Please note

If you installed the Kentico CMS project as a web application, you need to rename the 
CodeFile property on the first line to Codebehind for the code example to be functional.

<%@ Control Language="C#" AutoEventWireup="true" CodeFile="MyStep.ascx.cs"
Inherits="MyStep" %>
<asp:Label ID="lblError" runat="server" EnableViewState="false" Visible="false"></
asp:Label>
<table>
    <tr>
        <td><asp:Label ID="lblTotalPrice" runat="server" /></td>
        <td><asp:Label ID="lblTotalPriceValue" runat="server" /></td>        
    </tr>
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    <tr>
        <td><asp:Label ID="lblComment" runat="server" /></td>
        <td><asp:TextBox ID="txtComment" runat="server" TextMode="MultiLine"
Rows="3" /></td>
    </tr>
</table>

MyStep.ascx.cs

[C#]

using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;

using CMS.GlobalHelper;
using CMS.Ecommerce;
using CMS.EcommerceProvider;

public partial class MyStep : ShoppingCartStep
{
    protected void Page_Load(object sender, EventArgs e)
    {
        // Initialize labels
        lblTotalPrice.Text = ResHelper.GetString("MyStep.TotalPrice");
        lblComment.Text = ResHelper.GetString("MyStep.Comment");

        // Display rounded and formatted total price
        lblTotalPriceValue.Text = CurrencyInfoProvider.GetFormattedPrice
(ShoppingCart.RoundedTotalPrice, ShoppingCart.Currency);
        
        if (!ShoppingCartControl.IsCurrentStepPostBack)
        {
            // Load customer comment
            txtComment.Text = ValidationHelper.GetString
(ShoppingCart.ShoppingCartCustomData["CustomerComment"], String.Empty);
        }
    }

    /// <summary>
    /// Validates current step data.
    /// </summary>
    /// <returns></returns>
    public override bool IsValid()



Configuring your store 43

© 2014 Kentico Software

    {
        // Check customer comment for emptiness
        if (txtComment.Text.Trim() == "")
        {
            // Display error message
            lblError.Text = ResHelper.GetString("MyStep.Error.CommentMissing");
            lblError.Visible = true;
            
            // Data are not correct - customer comment missing
            return false;
        }
        else
        {
            // Data are correct
            return true;
        }
    }

    /// <summary>
    /// Process current step data
    /// </summary>
    /// <returns></returns>
    public override bool ProcessStep()
    {
        // Update shopping cart with customer comment
        ShoppingCart.ShoppingCartCustomData["CustomerComment"] =
txtComment.Text.Trim();

        try
        {
            // Update shopping cart in database
            ShoppingCartInfoProvider.SetShoppingCartInfo(ShoppingCart);

            // Current step data were processed and saved succesfully
            return true;
        }
        catch
        {
            // Display error message
            lblError.Text = ResHelper.GetString
("MyStep.Error.ShoppingCartUpdate");
            lblError.Visible = true;

            // Current step data update failed
            return false;
        }
    }

    /// <summary>
    /// Action after the "Next button" is clicked
    /// </summary>
    public override void ButtonNextClickAction()
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    {
        // If customer is registered and is a member of role "VipCustomers"
        if ((ShoppingCart.User != null) && (ShoppingCart.User.IsInRole
("VipCustomers", ShoppingCart.SiteName)))
        {
            if (IsValid() && ProcessStep())
            {
                try
                {
                    // Load extra step for VIP customers which is not included
                    // in standard checkout process definition
                    ShoppingCartStep ctrl = (ShoppingCartStep)Page.LoadControl("~/
CMSEcommerce/ShoppingCart/MyVipStep.ascx");
                    ShoppingCartControl.LoadStep(ctrl);

                    // Note: Current step index is not increased                 
            
                }
                catch
                {
                    // Error while loading extra step control -> Do standard
action                  
                    base.ButtonNextClickAction();
                }
            }
        }
        else
        {
            // Do standard action (validate step data, process step data, load
next step)
            base.ButtonNextClickAction();
        }
    }
}

Example - My VIP step

This is an external checkout process step, which is not included in a standard checkout process
definition. It is loaded only when the current customer is a member of the VipCustomers role. However,
you will need to use your own condition to load your external steps. There is no data validation (i.e. the
Vip customer comment can be empty). Neither the Back button action nor the Next button one is
overridden, which means that the standard methods are called after the Back button or the Next button
is clicked.

MyVipStep.ascx

Please note

If you installed the Kentico CMS project as a web application, you need to rename the 
CodeFile property on the first line to Codebehind for the code example to be functional.
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<%@ Control Language="C#" AutoEventWireup="true" CodeFile="MyVipStep.ascx.cs"
Inherits="MyVipStep" %>
<asp:Label ID="lblError" runat="server" EnableViewState="false" Visible="false"></
asp:Label>
<asp:Label ID="lblComment" runat="server" />
<asp:TextBox ID="txtComment" runat="server" TextMode="MultiLine" Rows="3" />

MyVipStep.ascx.cs

[C#]

using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;

using CMS.GlobalHelper;
using CMS.Ecommerce;
using CMS.EcommerceProvider;

public partial class MyVipStep : ShoppingCartStep
{
    protected void Page_Load(object sender, EventArgs e)
    {
        // Initialize label
        lblComment.Text = ResHelper.GetString("MyVipStep.Comment");

        if (!ShoppingCartControl.IsCurrentStepPostBack)
        {
            // Load VIP customer extra comment
            txtComment.Text = ValidationHelper.GetString
(ShoppingCart.ShoppingCartCustomData["VipComment"], String.Empty);
        }
    }

    /// <summary>
    /// Process current step data
    /// </summary>
    /// <returns></returns>
    public override bool ProcessStep()
    {
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        // Update shopping cart with VIP customer extra comment
        ShoppingCart.ShoppingCartCustomData["VipComment"] = txtComment.Text.Trim
();

        try
        {
            // Update shopping cart in database
            ShoppingCartInfoProvider.SetShoppingCartInfo(ShoppingCart);

            // Current step data were processed and saved succesfully
            return true;
        }
        catch
        {
            // Display error message
            lblError.Text = ResHelper.GetString
("MyStep.Error.ShoppingCartUpdate");
            lblError.Visible = true;

            // Current step data update failed
            return false;
        }
    }
}

Step order

Notice that data of all steps (including Kentico CMS standard shopping cart steps) is always processed
by itself, not by the parent shopping cart control. It means that if you reorder the standard checkout
process steps, you can experience strange behavior because of missing information or omitting some
important action.

For example, if you move the Order preview step in the standard checkout process definition for the
live site before the Select billing and shipping address and the Select payment and shipping
methods steps, some order preview data will be missing (billing and shipping addresses, payment
method and shipping option) because it has not been entered yet. What is more, the data entered during
the following two steps (i.e. the Select billing and shipping address step and the Select payment
and shipping methods step) will not be saved.

This occurs because the order is saved after the Next button of the Order preview step is clicked,
while the two above mentioned steps include completely different actions after their Next buttons are
clicked.

3.6 Payment gateways

3.6.1 Overview

This chapter describes the use of payment gateways, i.e. E-commerce application services authorizing
payments that the customers make when purchasing products and services offered in your on-line store.
A payment gateway facilitates the transfer of information between your website and the transaction
processor or acquiring bank. Currently, the following payment gateways are directly supported in Kentico
CMS:
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Authorize.NET - the customer pays using their card.
PayPal - the customer pays using their card or PayPal account.

Please note that you are not limited to the use of those two gateways as the CMS system allows you to
integrate your custom payment gateways using your code.

The customer can also pay using their customer credit. The credit must be entered in the customer
details by the store owner. This option is useful e.g. for customer loyalty programs.

The way how payment results are stored in the system and how they can be customized is tackled in
the chapter, too.

3.6.2 Authorize.NET

Authorize.NET is one of the most popular gateway providers. It uses plain HTTPS POST operations
against its gateway server.

What do I need?

1. Kentico CMS with built-in Authorize.NET support.
2. Internet Merchant Account - a type of bank account that allows a business to accept internet credit

card payments (the card is not physically presented to the merchant).
3. Payment Gateway Account - a secure internet bridge between your website and the credit card

processing networks.

Please refer to Authorize.NET's E-Commerce Getting Started Guide for more details.

How does it work?

Authorize.NET settings in Kentico CMS

Before your customers can start using the Authorize.NET payment gateway, you need to perform the
following configuration:

1. Go to Site Manager -> Settings -> E-commerce -> Payment Gateways -> Authorize.NET.
2. Enter API Login (API Login ID for the payment gateway account) and Transaction key (a

transaction key obtained from the Merchant Interface) to identify your payments.
3. Turn off the Authorize.NET payment gateway Test Mode by unchecking the Use test mode box.

Gateway behavior depends on both test mode settings: in Site Manager and in Authorize.NET
Merchant Interface. See the table below for more details about test mode settings:

http://www.authorize.net/files/ecommerceguide.pdf
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Kentico CMS Merchant Interface Transaction processed as

ON ON test transaction

OFF ON test transaction

ON OFF test transaction

OFF OFF live transaction

4. Ensure that the Authorize.NET payment method is registered and enabled. 
5. Check the Authorize.NET payment method payment gateway settings:

Payment gateway url: https://secure.authorize.net/gateway/transact.dll
Payment gateway assembly name: CMS.EcommerceProvider
Payment gateway class name: CMS.EcommerceProvider.CMSAuthorizeNetProvider

Please note

If you want your transaction to be processed as a test transaction, turn on the Test
Mode and use https://test.authorize.net/gateway/transact.dll as your payment gateway
url.

While using the Authorize.NET payment method, a customer is required to fill their credit card
information in the respective step of the checkout process to finish payment. After the payment is
finished the order payment result is updated.
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3.6.3 PayPal

PayPal is one of the most popular on-line payment systems. It allows for money transfers between bank
accounts, which are identified by e-mail addresses. Each account is linked to one or more credit cards,
e.g. a VISA card, with on-line payment enabled.

Please note

While using Kentico PayPal payment gateway, your on-line store customers can make
payment in the following currencies:

United States Dollar (USD)
Euro (EUR)
Pound Sterling (GBP)
Canadian Dollar (CAD)
Japanese Yen (JPY)

What do I need?

1. Kentico CMS with built-in PayPal support.
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2. PayPal account, please refer to PayPal website for more details.

How does it work?

PayPal settings in Kentico CMS

Before your customers can start using the PayPal payment gateway, you need to perform the following
configuration:

1. Go to Site Manager -> Settings -> E-commerce -> Payment Gateways -> PayPal.
2. Enter Business (e-mail address for the merchant's PayPal account) to identify your payments. Other

settings are optional:

Cancel return URL - the URL to which the buyer’s browser is redirected if the payment is
cancelled; e.g. a URL on your website that displays a Payment canceled page. The browser is
redirected to a PayPal page by default.
Notify URL - the URL to which PayPal posts information about the transaction; see PayPal IPN for
more details. If set, overrides settings in the PayPal merchant's interface.
Return URL - the URL to which the buyer’s browser is redirected after completing the payment;
e.g. a URL on your website that displays a Thank you for your payment page. The purchaser is
redirected to a PayPal page by default.

3. Ensure that the PayPal payment method is registered and enabled.
4. Check the PayPal payment method payment gateway settings:

Payment gateway url: https://www.paypal.com/cgi-bin/webscr

https://www.paypal.com/us/cgi-bin/webscr?cmd=_registration-run
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Payment gateway assembly name: CMS.EcommerceProvider
Payment gateway class name: CMS.EcommerceProvider.CMSPayPalProvider

Please note

If you want your transaction to be processed as a test transaction, use https://
www.sandbox.paypal.com/cgi-bin/webscr as your payment gateway URL and sign up
for the PayPal SandBox testing environment. Please refer to the PayPal website for
more details.

The price is always rounded to two decimal places, otherwise the PayPal payment
gateway would not allow the payment.

IPN - Instant Payment Notification

It’s easy to spoof the Return URL you sent to PayPal since it is visible in the query string. Therefore, a
user could type in the Confirmation URL directly and you should not confirm the order at this point. You
can then manually check the order on the PayPal website or wait for PayPal’s confirmation e-mails,
etc., all of which let you know that the order was processed manually.

To automate the process, PayPal can optionally ping you back at another URL with order completion
information. It uses a mechanism called Instant Payment Notification (IPN), which is essentially a web-
based callback mechanism that calls a pre-configured URL on your site. IPN must be enabled on the
PayPal side and when allowed it sends a confirmation to this URL after the order was processed.
PayPal then expects a return from you within a certain timeframe (a few minutes) and returns a
response to confirm that the customer has paid. To enable this, you have to POST the data back to
PayPal by echoing back all the form data that PayPal sends to you. IPN is optional, but it is a
requirement if you need to immediately confirm the orders to your customers.

While using the PayPal payment method, a customer is not required to fill any additional information in
the last step of the checkout process. After the Finish payment button is clicked, the user is redirected
to the PayPal payment gateway to finish payment:

https://cms.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=developer/howto_testing_sandbox
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3.6.4 Customer credit

Customers may receive a credit on their account. They can then purchase products using this credit.
This feature is useful for customer loyalty competitions where customers receive bonus points/credit for
their previous purchases and can order some products once they achieve an appropriate amount of
credit.

Please note that a purchase can be made using one payment method only, which means it is not
possible to combine credit payment with another form of payment and the whole order must be paid
using the credit.

The customer receives credit when the store owner adds some credit event to the customer history. This
can be done in the Customer properties dialog, on the Credit tab.

The credit is added to/deducted from the customers' site-specific or global credit balance. This depends
on the site separation settings of a given site. Specifically, it depends on whether the customers use
site-specific or global credit on the site. More details can be found in the Multisite store chapter.

Before you can offer registered customers to use the customer credit you will need to do some
necessary settings:

1. Ensure that the Customer credit payment method is registered and enabled. 
2. Check the Customer credit payment method settings:

Payment gateway URL: leave blank
Payment gateway assembly name: CMS.EcommerceProvider
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Payment gateway class name: CMS.EcommerceProvider.CMSCreditPaymentProvider

While using the customer credit, a customer is not required to fill any additional information in the last
step of the checkout process. After the Finish payment button is clicked, their credit is reduced by a
specified amount which is equal to the order total price in the default currency and the order payment
result is updated.

3.6.5 Payment results

Payment results are stored in xml format, which is represented by the 
CMS.Ecommerce.PaymentResultInfo object. Each payment result xml node is equal to a single
payment result item, which is represented by the CMS.Ecommerce.PaymentResultItemInfo object.

Base payment result items are:

Payment date - the date and time when the payment result was last updated.
Payment method - indicates the payment method which was used for payment.
Payment is completed - indicates whether payment is already completed.
Payment status - indicates the status of the payment, e.g. Completed, Failed, etc. (your custom
status).
Payment transaction ID - a unique identifier for a completed payment generated by the payment
gateway.
Payment description - describes the payment result in more details.

Payment result item properties are:
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Name - a unique identifier of the item.
Header - a friendly name of the item visible to the user (simple text or localizable string).
Text - an outer representation of the item value visible to the user (simple text or localizable string).
Value - an inner representation of the item value used by developers.

The following example shows an xml definition of an order payment result extended by the item
“authorizationcode” used by the Authorize.NET:

<result>

<item name="date" header="{$PaymentGateway.Result.Date$}" value="1/27/2008
5:01:41 PM" />

<item name="method" header="{$PaymentGateway.Result.PaymentMethod$}"
text="Credit card" value="230" />

<item name="completed" header="{$PaymentGateway.Result.IsCompleted$}"
value="1" text="{$PaymentGateway.Result.PaymentCompleted$}" />

<item name="status" header="{$PaymentGateway.Result.Status$}"
text="{$PaymentGateway.Result.Status.Completed$}" value="completed" />

<item name="transactionid" header="{$PaymentGateway.Result.TransactionID$}"
 value="0" />

<item name="description" header="{$PaymentGateway.Result.Description$}" />

<item name="authorizationcode" header="{$AuthorizeNet.AuthorizationCode$}"
value="000000" />
</result>

The following example shows an order payment result which is visible to the user in CMS Desk:

Date: 1/27/2008 5:01:41 PM
Method: Credit card
Is completed: YES
Status: Completed
Transaction ID: 0
Authorization code: 000000

Please note

The order payment result remains empty until it is updated by the payment gateway
processor.

You do not need to specify both item value and item text if they are identical because
the payment result rendering method can manage this and renders payment result as
follows: try to render item text, if not found, try to render item value.

How to customize payment results

You can use PaymentResultInfo properties to get or set a specified item text or value:

PaymentDate 
PaymentMethodID
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PaymentMethodName
PaymentIsCompleted
PaymentStatusName
PaymentStatusCode
PaymentTransactionID

You will need to use the GetPaymentResultItemInfo(string itemName) and SetPaymentResultItemInfo
(PaymentResultItemInfo itemObj) public methods to get and set your custom payment result items.

The following example shows how to get and set a custom payment result item while payment
processing by your custom payment gateway provider:

[C#]

using CMS.Ecommerce;

// Set authorization code
PaymentResultItemInfo item = new PaymentResultItemInfo();
item.Header = "{$AuthorizeNet.AuthorizationCode$}";
item.Name = "authorizationcode";
item.Value = "00000";
this.PaymentResult.SetPaymentResultItemInfo(item);

[C#]

using CMS.Ecommerce;

// Get authorization code
PaymentResultItemInfo item = this.PaymentResult.GetPaymentResultItemInfo
("authorizationcode");

3.6.6 Custom payment gateways

Kentico CMS allows you to implement custom payment gateways. While purchasing, your on-line store 
customers can use the gateways like any other payment methods available.

In this section you can find the following examples of integrating custom payment gateways into the
system:

Integrating a custom payment gateway as a library - offers an approach suitable for users who want
to implement their custom payment gateway as a dynamic-link library; requires library compilation.
Directly integrating a custom payment gateway - offers an approach suitable for users who want to
integrate their custom payment gateway with minimum development effort.

3.6.6.1 Example - Integrating a custom payment gateway as a new library

Here's a general overview of the process of integrating a custom payment gateway as a dynamic-link
library:
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1. Create a payment gateway form with your custom controls to enable customers to enter their
payment data such as credit card number; see the Creating a custom payment gateway form
section.

2. Create your custom payment gateway class and override required methods for payment processing,
see the Creating a custom payment gateway class section.

3. Go to CMS Desk -> E-commerce -> Configuration -> Payment methods.
4. Create a new payment method and register your custom payment gateway.

Creating a custom payment gateway form

1. Create a new web user control (*.ascx) and place it into your site folder which is located in the root of
your web project. Since the control is located in the site folder, it is included in the export package of
your site.

2. Set the control class to inherit from the abstract 
CMS.EcommerceProvider.CMSPaymentGatewayForm class.

3. There are several methods you need to override to reach your required functionality:

LoadData() - initializes form controls with customer payment data.
ValidateData() - validates customer payment data.
ProcessData() - processes customer payment data and saves it to the ShoppingCartInfo object.

4. There are several properties to get or set the required information:

ShoppingCartControl - the parent shopping cart control to which the current shopping cart step
belongs.
ShoppingCartInfoObj - the shopping cart object which stores all data during the checkout
process.

Please note

Payment data, such as credit card numbers, credit card codes and others are not
saved into the database due to security reasons. 

Creating a custom payment gateway class

1. Create a new library (assembly) as part of your solution and a new class in this library.
2. Add a reference to the System.Web assembly in the project with the payment gateway (right-click

the References folder, choose Add reference, select .NET -> System.Web).
3. Set your class to inherit from the CMS.EcommerceProvider.CMSPaymentGatewayProvider abstract

class.
4. There are several methods you can override to reach the required functionality:

AddCustomData() - adds payment gateway custom controls to the current shopping cart step. By
default the CMSPaymentGatewayForm control is added to the payment data container and its data
is loaded.
RemoveCustomData() - removes payment gateway custom controls from the current shopping cart
step. By default all controls from the payment data container are removed.
ValidateCustomData() - validates payment gateway custom data of the current shopping cart step.
By default the CMSPaymentGatewayForm control data is validated.
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ProcessCustomData() - processes payment gateway custom data of the current shopping cart
step. By default the CMSPaymentGatewayForm data is processed.
ProcessPayment() - processes payment; you need to override this method to process payment by
your payment processor.
GetPaymentDataForm() - loads the payment gateway form with custom controls; you need to
override this method to get your own payment gateway form.

5. There are several properties to get or set the required information:

ShoppingCartControl - a parent shopping cart control to which the current shopping cart step
belongs.
ShoppingCartInfoObj - a shopping cart object which stores all data during the checkout process.
If OrderId is set, it is created from the existing order, otherwise it is returned from the current
shopping cart control.
OrderId - a unique identifier (ID) of the currently processed order.
PaymentDataContainer - the payment gateway custom controls container of the current shopping
cart step control.
PaymentResult - the result of the currently processed payment.
IsPaymentCompleted - indicates whether order payment is already completed. It is determined by
the order payment result.
InfoMessage - the payment result message displayed to the user when payment succeeds.
ErrorMessage - the payment result message displayed to the user when payment fails.

6. Compile the library.
7. Ensure the library file (*.dll) is included in the <your web project folder>/Bin directory.

Example

The following example shows a custom payment processor implementation. It allows customers to pay
for their orders using an external payment gateway similar to PayPal; we can call it e.g. Custom
Gateway. The customer is asked for their credit card number in the last step of the checkout process.
The credit card number is validated for emptiness and processed after the Finish payment button is
clicked. If successful, the payment process is performed – required payment data is attached to the
payment URL and the customer is redirected to the Custom Gateway. If the payment process fails
(payment gateway URL is not defined), the order payment result is updated and an appropriate error
message is displayed. Notice that the order is saved before the customer is asked to pay for it.
Specifically, this happens immediately after the Order now button is clicked.

Please note

It is not secure to send credit card information as a part of payment gateway URL.
Customers are usually asked for their credit card number after they have been
redirected to the payment gateway itself. Otherwise, another way of sending credit card
information should be used instead.

For more details about how payment gateways can inform merchants about the results of payments
finished outside their websites, please see the IPN (Instant Payment Notification) section in the PayPal
topic.
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On the following screenshot you can see an example of a custom payment gateway definition.

Custom payment gateway form

It is a simple form with one input field to enter customer credit card number, see image bellow.
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CustomGatewayForm.ascx

If you installed the Kentico CMS project as a web application, you need to rename the CodeFile property
on the first line to Codebehind for the code example to be functional.

<%@ Control Language="C#" AutoEventWireup="true"
CodeFile="CustomGatewayForm.ascx.cs"
Inherits="CMSEcommerce_Example_CustomGatewayForm" %>
<asp:Label ID="lblTitle" runat="server" EnableViewState="false"
CssClass="BlockTitle" />
<asp:Label ID="lblError" runat="server" EnableViewState="false"
CssClass="ErrorLabel" Visible="false" />
<asp:Label ID="lblCardNumber" EnableViewState="false" runat="server" />
<asp:TextBox ID="txtCardNumber" runat="server" />

CustomGatewayForm.ascx.cs

[C#]

using System;

using System.Data;

using System.Configuration;

using System.Collections;

using System.Web;
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using System.Web.Security;

using System.Web.UI;

using System.Web.UI.WebControls;

using System.Web.UI.WebControls.WebParts;

using System.Web.UI.HtmlControls;

using CMS.EcommerceProvider;

using CMS.GlobalHelper;

public partial class CMSEcommerce_Example_CustomGatewayForm :

CMSPaymentGatewayForm

{

    protected void Page_Load(object sender, EventArgs e) 

    {

        // Initialize label      

        lblTitle.Text = "Your credit card details";

        lblCardNumber.Text = "Credit card number:";

    }

    /// <summary>

    /// Initializes form controls with customer payment data.

    /// </summary>

    public override void LoadData()

    {

        // Display customer credit card number

        txtCardNumber.Text = ValidationHelper.GetString

(this.ShoppingCartInfoObj.PaymentGatewayCustomData["CustomGatewayCardNumber"],

"");

    }

    /// <summary>

    /// Validates customer payment data. 

    /// </summary>

    /// <returns></returns>

    public override string ValidateData()

    {

        if (txtCardNumber.Text.Trim() == "")

        {            

            lblError.Visible = true;

            lblError.Text = "Please enter your credit card number";

            return lblError.Text;

        }

        return "";

    }

    /// <summary>

    /// Process customer payment data.

    /// </summary>

    /// <returns></returns>

    public override string ProcessData()

    {

        // Save credit card number

        this.ShoppingCartInfoObj.PaymentGatewayCustomData
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["CustomGatewayCardNumber"] = txtCardNumber.Text.Trim();

        return "";

    }

}

Custom payment gateway class

The following example uses the CMS.CustomProvider assembly name and the
CMS.CustomProvider.CustomGateway class, however, you will need to use your own names.

CustomGateway.cs

[C#]

using System;

using System.Collections.Generic;

using System.Text;

using System.Web;

using System.Collections;

using CMS.EcommerceProvider;

using CMS.GlobalHelper;

using CMS.UIControls;

using CMS.ExtendedControls;

namespace CMS.CustomProvider

{

    /// <summary>

    /// Class representing Custom Gateway processor.

    /// </summary>

    public class CustomGateway : CMSPaymentGatewayProvider

    {

        /// <summary>

        /// Returns payment gateway form with custom controls.

        /// </summary>

        /// <returns></returns>

        public override CMSPaymentGatewayForm GetPaymentDataForm()

        {

            try

            {

                return (CMSPaymentGatewayForm)this.ShoppingCartControl.LoadControl

("~/CMSEcommerce/Example/CustomGatewayForm.ascx");

            }

            catch

            {

                return null;

            }

        }

        /// <summary>

        /// Process payment.

        /// </summary>

        public override void ProcessPayment()
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        {           

            // Get payment gateway url

            string url = this.GetPaymentGatewayUrl();

            if (url != "")

            {

                // Initialize payment parameters

                Hashtable parameters = InitializePaymentParameters();

                // Add required payment data to the url

                url = GetFullPaymentGatewayUrl(url, parameters);

                // Redirect to payment gateway to finish payment

                this.ShoppingCartControl.Page.Response.Redirect(url);

            }

            else

            {                

                // Show error message - payment gateway url not found

                this.ErrorMessage = "Unable to finish payment: Payment gateway url

not found.";

                // Update payment result

                this.PaymentResult.PaymentDescription = this.ErrorMessage;

                this.PaymentResult.PaymentIsCompleted = false;

                // Update order payment result in database

                this.UpdateOrderPaymentResult();

            }

        }

        /// <summary>

        /// Returns table with initialized payment parameters.

        /// </summary>

        /// <returns></returns>

        private Hashtable InitializePaymentParameters()

        {

            Hashtable parameters = new Hashtable();

            parameters["orderid"] = this.ShoppingCartInfoObj.OrderId;

            parameters["price"] = this.ShoppingCartInfoObj.TotalPrice;

            parameters["currency"] =

this.ShoppingCartInfoObj.CurrencyInfoObj.CurrencyCode;

            parameters["cardnumber"] = Convert.ToString

(this.ShoppingCartInfoObj.PaymentGatewayCustomData["CustomGatewayCardNumber"]);

            return parameters;

        }

        /// <summary>

        /// Returns payment gateway url with payment data in query string.

        /// </summary>

/// <param name="url">Payment gateway url.</param>

        /// <param name="parameters">Initialized payment paremeters.</param>

        /// <returns></returns>

        private string GetFullPaymentGatewayUrl(string url, Hashtable parameters)
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        {

            foreach (DictionaryEntry parameter in parameters)

            {

                // Add payment data to the url

                url = URLHelper.AddParameterToUrl(url, Convert.ToString

(parameter.Key), HttpUtility.UrlEncode(Convert.ToString(parameter.Value)));

            }

            return url;

        }

    }

}

For further details on how to create your custom payment gateway, please see the Developing Custom
Payment Gateway webinar.

3.6.6.2 Example - Directly integrating a custom payment gateway

Here you will learn how to directly integrate a custom payment gateway. You will also learn what steps
you need to take to enable the use of the gateway during the checkout process. Unlike the approach
demonstrated in Example - Integrating a custom payment gateway as a library, this approach is simpler
and does not require library compilation.

In this topic

The process of directly integrating a custom payment gateway can be divided into three logical parts.

1. Defining the required classes
2. Registering the payment gateway in the system
3. Registering the payment gateway in shipping options

Besides, the Using the payment gateway during the checkout process section shows how your
customers can use a custom payment gateway during the checkout process.

1. Defining the required classes

This section demonstrates how to write classes providing functionality for your custom payment
gateway.

1. Open your web project in Visual Studio and add two new classes into the App_Code folder (or
Old_App_Code folder if the project is installed as a web application). Name the classes
CustomGatewayLoader.cs and CustomGateway.cs.

http://devnet.kentico.com/Videos/E-commerce/Developing-Custom-Payment-Gateway.aspx
http://devnet.kentico.com/Videos/E-commerce/Developing-Custom-Payment-Gateway.aspx
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2. Edit the classes and change their code to the following:

CustomGatewayLoader.cs

[C#]

using System;

using CMS.GlobalHelper;

using CMS.SettingsProvider;

using CMS.Ecommerce;

    /// <summary>

    /// CustomGatewayLoader e-commerce loader class. Partial class ensures correct

registration.

    /// </summary>

    /// 

[CustomGatewayLoader]

public partial class CMSModuleLoader

{

    #region "Macro methods loader attribute"

    /// <summary>

    /// Module registration

    /// </summary>

    private class CustomGatewayLoaderAttribute : CMSLoaderAttribute

    {

        /// <summary>

        /// Constructor

        /// </summary>

        public CustomGatewayLoaderAttribute()

        {

            // Require E-commerce module to load properly.

            RequiredModules = new string[] { ModuleEntry.ECOMMERCE };

        }

        /// <summary>

        /// Initializes the module.

        /// </summary>
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        public override void Init()

        {

            // This line provides the ability to register the classes via

web.config cms.extensibility section from App_Code.

            ClassHelper.OnGetCustomClass += GetCustomClass;

        }

        /// <summary>

        /// Gets the custom class object based on the given class name. This

handler is called when the assembly name is App_Code.

        /// </summary>

        private static void GetCustomClass(object sender, ClassEventArgs e)

        {

            if (e.Object == null)

            {

                // Provide your custom classes.

                switch (e.ClassName.ToLower())

                {

                    // Create a custom getaway object inheriting from

CMSPaymentGatewayProvider.

                    case "customgateway":

                        e.Object = new CustomGateway();

                        break;

                }

            }

        }

    }

    #endregion

}

CustomGateway.cs

[C#]

using System;

using System.Collections.Generic;

using System.Text;

using System.Web;

using System.Collections;

using CMS.EcommerceProvider;

using CMS.GlobalHelper;

using CMS.UIControls;

using CMS.ExtendedControls;

    /// <summary>

    /// Class representing the Custom Gateway processor.

    /// </summary>

public class CustomGateway : CMSPaymentGatewayProvider

{

    /// <summary>

    /// Returns a payment gateway form with custom controls.

    /// </summary>
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    /// <returns></returns>

    public override CMSPaymentGatewayForm GetPaymentDataForm()

    {

        try

        {

            return (CMSPaymentGatewayForm)this.ShoppingCartControl.LoadControl("~/

CustomGatewayForm.ascx");

        }

        catch

        {

            return null;

        }

    }

    /// <summary>

    /// Process payment.

    /// </summary>

    public override void ProcessPayment()

    {

        // Get payment gateway url.

        string url = this.GetPaymentGatewayUrl();

        if (url != "")

        {

            // Initialize payment parameters.

            Hashtable parameters = InitializePaymentParameters();

            // Add required payment data to the url.

            url = GetFullPaymentGatewayUrl(url, parameters);

            // Redirect to payment gateway to finish payment.

            this.ShoppingCartControl.Page.Response.Redirect(url);

        }

        else

        {

            // Show error message - payment gateway url not found.

            this.ErrorMessage = "Unable to finish payment: Payment gateway url not

found.";

            // Update payment result.

            this.PaymentResult.PaymentDescription = this.ErrorMessage;

            this.PaymentResult.PaymentIsCompleted = false;

            // Update order payment result in the database.

            this.UpdateOrderPaymentResult();

        }

    }

    /// <summary>

    /// Returns table with initialized payment parameters.

    /// </summary>

    /// <returns></returns>

    private Hashtable InitializePaymentParameters()

    {

        Hashtable parameters = new Hashtable();
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        parameters["orderid"] = this.ShoppingCartInfoObj.OrderId;

        parameters["price"] = this.ShoppingCartInfoObj.TotalPrice;

        parameters["currency"] = this.ShoppingCartInfoObj.Currency.CurrencyCode;

        parameters["cardnumber"] = Convert.ToString

(this.ShoppingCartInfoObj.PaymentGatewayCustomData["CustomGatewayCardNumber"]);

        return parameters;

    }

    /// <summary>

    /// Returns payment gateway url with payment data in query string.

    /// </summary>

    /// <param name="url">Payment gateway url.</param>

    /// <param name="parameters">Initialized payment paremeters.</param>

    /// <returns></returns>

    private string GetFullPaymentGatewayUrl(string url, Hashtable parameters)

    {

        foreach (DictionaryEntry parameter in parameters)

        {

            // Add payment data to the url.

            url = URLHelper.AddParameterToUrl(url, Convert.ToString

(parameter.Key), HttpUtility.UrlEncode(Convert.ToString(parameter.Value)));

        }

        return url;

    }

}

2. Registering the payment gateway in the system

Once you have implemented the classes, you need to register your custom payment gateway as an
object in Kentico CMS.

1. Navigate to CMS Desk -> E-commerce -> Configuration -> Payment methods and click  New
payment method.
2. Enter the following values into the payment method's properties:

Display name: Custom gateway
Code name: Leave the (automatic) option. The system will generate the code name as
CustomGateway (based on the display name).
Description: Enter payment gateway description (optional).
Teaser image: Upload payment gateway teaser image (optional).
Allow if no shipping is supplied: yes
Enabled: yes
Payment gateway URL: ~/Special-Pages/Temporary-Payment-Page.aspx
Payment gateway assembly name: App_Code
Payment gateway class name: customgateway
Order status if payment succeeds: In progress
Order status if payment fails: Payment failed
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3. Click  Save.

Your new payment gateway is now fully functional and ready for use in the system.

If you registered your custom payment gateway as a global payment method, you need
to enable it for use on the current site.
You can do this in CMS Desk -> E-commerce -> Configuration -> Store settings ->
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Global objects.

3. Registering the payment gateway in shipping options

To enable the use of your custom payment gateway during the checkout process, the last step you
need to take is to register it in selected shipping options.

1. Navigate to CMS Desk -> E-commerce -> Configuration -> Shipping options.
2. Edit ( ) a shipping option where you want to add your custom payment gateway on the Payment
methods tab.
3. Click Add payments and in the Select payment dialog that opens select Custom gateway. Click
OK.

As you can see, your custom gateway is now listed among other payment methods available for the
current shipping option.
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4. (Optional) Repeat this procedure to register your custom gateway in other shipping options.

Using the payment gateway during the checkout process

If your customers select during the checkout process a shipping option to which you added your custom
payment gateway, they can use the gateway as any other payment method available.
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3.7 Invoices

3.7.1 Overview

Kentico CMS allows you to customize the invoice (or receipt) design and use a whole range of pre-
defined and data macro expressions. Invoices (and receipts) are commercial documents that you issue
to the customer to indicate the products, quantities, prices and optionally other purchase-related details.

3.7.2 Invoice

When editing an order (on the Invoice tab), you can generate and print the invoice using the respective
buttons.

Configuring invoices

Invoices (and receipts) can be configured in CMS Desk -> E-commerce -> Configuration -> Invoice
(or in Site Manager -> Tools -> E-commerce configuration -> Invoice; global invoices only). In this
section of the administration interface, you can see your invoice design, which can be further edited
using the built-in WYSIWYG editor (you can edit the HTML code representing your invoice) and by
adding special expressions, i.e. macros, to insert dynamic parts of the invoice. For example, you can
use the {%Order.OrderInvoiceNumber#%} expression to insert the invoice number.

http://devnet.kentico.com/docs/7_0/devguide/wysiwyg_editor_overview.htm
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Macro examples

If you click the Click here for invoice macro examples link at the bottom of the page, you can find a
complete list of available dynamic expressions:

Macro expression Description

{%
ShoppingCart.ShoppingCartCurre

Displays the value of a specified shopping cart data column
(COM_ShoppingCart).
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ncyID%}

{%Order.OrderID%} Displays the value of a specified order data column (COM_Order).

{%Order.OrderInvoiceNumber%} Displays the invoice number.

{%Order.OrderNote|(encode)%} Displays the encoded order note.

{%OrderStatus.StatusID%} Displays the value of a specified order status data column
(COM_OrderStatus).

{%BillingAddress.AddressID%} Displays the value of a specified billing address data column
(COM_Address).

{%
BillingAddress.Country.CountryI
D%}

Displays the value of a specified billing address country data
column (CMS_Country).

{%BillingAddress.State.StateID
%}

Displays the value of a specified billing address state data column
(CMS_State).

{%ShippingAddress.AddressID
%}

Displays the value of a specified shipping address data column
(COM_Address).

{%
ShippingAddress.ApplyTransform
ation()%}

Displays the formatted shipping address (COM_Address) using a
specified transformation. You can use the default transformation for
formatting addresses
(Ecommerce.Transformations.Order_Address).

{%
ShippingAddress.Country.Countr
yID%}

Displays the value of a specified shipping address country data
column (CMS_Country).

{%
ShippingAddress.State.StateID
%}

Displays the value of a specified shipping address state data
column (CMS_State).

{%CompanyAddress.AddressID
%}

Displays the value of a specified company address data column
(COM_Address).

{%
CompanyAddress.Country.Count
ryID%}

Displays the value of a specified company address country data
column (CMS_Country).

{%
CompanyAddress.State.StateID
%}

Displays the value of a specified company address state data
column (CMS_State).

{%
ShippingOption.ShippingOptionID
%}

Displays the value of a specified shipping option data column
(COM_ShippingOption).

{%
PaymentOption.PaymentOptionI
D%}

Displays the value of a specified payment option data column
(COM_PaymentOption).

{%Currency.CurrencyID%} Displays the value of a specified currency data column
(COM_Currency).
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{%Customer.CustomerID%} Displays the value a of specified customer data column
(COM_Customer).

{%
Customer.CustomerOrganizationI
D%}

Displays the customer organization ID.

{%
Customer.CustomerTaxRegistrati
onID%}

Displays the customer tax registration ID.

{%
DiscountCoupon.DiscountCoupo
nID%}

Displays the value of a specified discount coupon data column
(COM_DiscountCoupon).

{%
ContentTable.ApplyTransformatio
n()%}

Displays a list of ordered products (shopping cart items) using
specified transformations. You can use the default transformation
for header
(Ecommerce.Transformations.Order_ContentTableHeader), for
body (Ecommerce.Transformations.Order_ContentTable) and for
footer (Ecommerce.Transformations.Order_ContentTableFooter).

{%
ContentTaxesTable.ApplyTransfo
rmation()%}

Displays a list of taxes applied to ordered products (shopping cart
items) using specified transformations. You can use the default
transformation for header
(Ecommerce.Transformations.Order_TaxesTableHeader), for body
(Ecommerce.Transformations.Order_TaxesTable) and for footer
(Ecommerce.Transformations.Order_TaxesTableFooter).

{%
ShippingTaxesTable.ApplyTransf
ormation()%}

Displays a list of taxes applied to the employed shipping option
using specified transformations. You can use the default
transformation for header
(Ecommerce.Transformations.Order_TaxesTableHeader), for body
(Ecommerce.Transformations.Order_TaxesTable) and for footer
(Ecommerce.Transformations.Order_TaxesTableFooter).

{%TotalPrice.Format
(Currency.CurrencyFormatString)
%}

Displays the formatted total price.

{%Format(Order.OrderDate, "{0:
d}")%}

Displays the formatted order date.

{%TotalShipping.Format
(Currency.CurrencyFormatString)
%}

Displays the formatted total shipping for the order.

Attachments

This section allows you to attach files to the invoice; for example, you can upload an image and insert it
into the invoice. When a file is uploaded, the following actions are available:

Edit ( ) - if the file is an image, clicking the icon opens it in the built-in image editor. If the file is not
an image, the metadata editor is opened after clicking the icon. 
Delete ( ) - can be used to remove an item from the list.

http://devnet.kentico.com/docs/7_0/devguide/image_editor_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Metadata_editor.htm
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Update ( ) - use this action to update the attached file.

Please note

The Attachments section is available only if you are using site-specific settings for
your invoice. 

Kentico CMS offers you the capability of splitting an invoice into several pages for printing. In case you
experienced difficulties with your invoice printed design in Internet Explorer, try to print it using the
Firefox browser instead.
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4 Managing your store

4.1 Overview

This chapter explains how to manage features that make up your on-line store. Please use the following
links to learn about management of the respective E-commerce solution features:

Departments
Products
Product options
Currencies
Tax classes
Discounts
Customers
Orders
Reports

Besides, the Dashboard topic describes a customizable section of the E-commerce administration
interface containing frequently used tools and sources of information, which you can personalize directly
through the browser.

4.2 Dashboard

Dashboard is a page within Kentico CMS administration interface which can be personalized by
individual users. For this purpose there are many different widgets, which can be configured and placed
on the given page. For example, you can use widgets to view various e-commerce reports (e.g. monthly
sales, sales by order status, etc.), to display a list of products, orders, etc. that match a specified filter,
or to check whether all required e-commerce settings are configured correctly.

You can view and manage the E-commerce solution dashboard in CMS Desk -> E-commerce -> My
dashboard.

http://devnet.kentico.com/docs/7_0/devguide/Widgets_overview.htm
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For a detailed description of the E-commerce solution dashboard, please refer to the Kentico CMS 7: E-
commerce Dashboard blog post.

You can find more details about the use of dashboards in Kentico CMS in the Dashboards chapter in the
Modules section of the Developer's Guide.

4.3 Departments

4.3.1 Overview

The Departments feature is used for organizing your product management efforts as it enables you to
specify users responsible for the management of products in a particular department of your on-line
store. This means you can have a different product manager e.g. for the books and for the electronics
departments.

http://devnet.kentico.com/Blogs/Petr-Vozak/August-2012/Kentico-CMS-7-E-commerce-Dashboard.aspx
http://devnet.kentico.com/Blogs/Petr-Vozak/August-2012/Kentico-CMS-7-E-commerce-Dashboard.aspx
http://devnet.kentico.com/docs/7_0/devguide/dashboards_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/User_management.htm
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You create a single department and place all products in it. However, if you have more product managers
in your on-line store, you can thus create multiple departments and have them managed separately by
several product managers.

Please note that the departments are not the same as product categories displayed to the site visitors.

4.3.2 Departments

When creating a new product or editing an existing one (on the General tab), you can choose a
department under which it should be placed. This can be done by using the Department drop-down list
as highlighted in the screenshot below.

Managing departments

Departments can be managed in CMS Desk -> E-commerce -> Configuration on the Departments
tab. In this section of the administration interface, you can see a list of all defined departments. New
ones can be added to the list by clicking the  New department button above the list. Properties of
already defined departments can be edited by clicking the Edit ( ) icon in the Actions column. You can
also delete a department by clicking the Delete ( ) icon.
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When editing a department, the following tabs are available to specify its properties:

General tab
Users tab
Default tax classes tab

General tab

On this tab you can edit general properties of the selected department. You need to click the
confirmation button to save any changes.

Display name - the name of the department displayed to users on the live site and in the
administration interface.
Code name - the name of the department used by developers in the code.

Users tab

On this tab you can specify which users will be able to manage products in the current department. To
add a user, click the Add users button and check the boxes next to the appropriate users in the
displayed selection dialog. Users can be removed from the list at any time using the corresponding
checkboxes together with the Remove selected button. You can also remove all listed items at once
by clicking the  icon and performing the  Remove all action.

http://devnet.kentico.com/docs/7_0/devguide/User_management.htm
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Default tax classes tab

On this tab you can specify which taxes will automatically apply to all new products from the current
department. To add tax classes, click the Add tax classes button and check the boxes next to the
appropriate tax classes in the displayed selection dialog. Tax classes can be removed from the list at
any time using the corresponding checkboxes together with the Remove selected button. You can also
remove all listed items at once by clicking the  icon and performing the  Remove all action.

4.4 Products

4.4.1 Overview

Products are the most important entities in your on-line store. They feature the actual products and
services that are offered and sold in multiple product types to the customers of your on-line store.

Products may be purchased separately or with options, which may include various accessories,
additions, etc. Internal and public statuses may be assigned to inform the user about the current state of
the product, and you can also specify product's manufacturer and supplier. Besides, images and other
types of files can be attached to enhance the customer's live site experience.

In Kentico CMS, products  are  defined  as  product  objects,  i.e.  SKUs,  associated  with  product  type
documents. When you want to display a product on your website,  you thus need to display  a product
type document with a product object assigned to this document.
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4.4.2 Product types

4.4.2.1 Overview

Product types

Product types in Kentico CMS are fully customizable document types used to create products of
multiple representations. Specifically, they define the structure of documents that are associated with
SKU objects, thus allowing to present the actual product articles and services to your on-line store
customers on the live website. Same as any other document type, each product type may have its own:

fields (data structure)
editing form layout
transformations (design)
queries

and other settings.

You can use the built-in product types, e.g. Product - Computer, Product -TV, Product - T-shirt, etc.,
and you can also set up your custom ones.

Section types

Similarly, you can add custom Section types, which allow you to define the structure of your on-line
store.

4.4.2.2 Product type configuration

In Kentico CMS, you can use either sample product types that come with the CMS system installation
or you can define your custom ones. Product types can be managed in Site Manager -> Development
-> Document types after clicking the Edit ( ) icon on the respective line in the Document types list.
To add a new product type, you need to:

Required

1. Click the  New document type button. This will redirect you to the New document type wizard,
which will guide you through the steps you will need to take to create a new document type.

http://devnet.kentico.com/docs/7_0/devguide/Document_types_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Defining_a_new_document_type.htm
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2. As you need to create a product type (not a standard document type), switch to the newly created
document type's E-commerce tab and choose the Document type represents a product type option
in the Document's relation to product section.
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Optional

3. In the Fields mapping section, you can optionally select fields that will be automatically populated
with values from the specified SKU fields.

4. Using the Default department property in the New product creation section you can optionally
specify a department that will by default be responsible for a product created based on the given product
type.

Besides, the This document type represents property in this section allows you to choose a default
representation for the product (Standard product is selected by default).

You can also specify whether a product object (SKU) should be created automatically when a new
document of the given type is created using the respective checkbox.
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4.4.2.3 Product section configuration

The Page (menu item) section type comes with the CMS system installation and is thus offered by
default while defining the structure of your on-line store. Besides, you can set up your custom section
types. They can be managed in Site Manager -> Development -> Document types after clicking the
Edit ( ) icon on the respective line in the Document types list. To add a new section type, you need
to:

1. Click the  New document type button. This will redirect you to the New document type wizard,
which will guide you through the steps you will need to take to create a new document type.

2. As you need to create a section type (not a standard document type), switch to the newly created
document type's E-commerce tab and choose the Document type represents a product section
option in the Document's relation to product section.

Please note

http://devnet.kentico.com/docs/7_0/devguide/Defining_a_new_document_type.htm
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Only document types designated as product sections (together with products they
contain) may be displayed in the product sections tree in CMS Desk -> E-commerce -
> Products.

4.4.2.4 Product representations

4.4.2.4.1      Overview

Your on-line store supports five different product representations:

Standard product - the standard sort of product typically representing a single article or service.
Membership - membership is a grouping of roles, e.g. allowing customers to access a paid section of
the website or perform certain actions on the website.
E-product - file(s) that can be downloaded after being purchased by a customer.
Donation - product that a customer pays for in order to donate money.
Bundle - multiple products grouped into a single product.

Click the links above to learn more about the particular product representation and its specifics.

4.4.2.4.2      Standard product

The Standard product representation is used for standard sorts of product, which typically include
articles and services. All other product representations, i.e. Membership, E-product, Donation and
Bundle, are derived from this one. It means that they have the Standard product properties but contain
also other properties specific for the respective representation.

Any product has properties described in the Managing products -> General tab topic.

4.4.2.4.3      Membership

The Membership product representation is designed to allow website users to buy a membership. You
will typically use it to let users access paid premium content or other restricted website sections, or let
them perform actions that are normally not allowed.

Memberships can be defined in CMS Desk / Site Manager -> Administration -> Membership. They
are defined as a set of roles, while users who have the membership have the same privileges as if they
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were direct members of all the roles. Detailed information can be found in Developer's Guide ->
Development -> Membership, permissions and security -> Memberships.

Defining a membership product

When creating a new product or editing an existing one (on the General tab), you need to choose
Membership in the Representing drop-down list. After doing so, the Membership section appears
below, allowing you to enter the following properties specific for this product representation:

Membership group - membership defined in CMS Desk / Site Manager -> Administration ->
Membership that a customer will get for purchasing the product.
Membership validity - indicates how long the membership will be valid after being purchased. Can
be set either for a limited period of time (Days, Weeks, Months, Years, Until a given date) or for an
unlimited period. To set membership validity for an unlimited period of time, choose Until and leave
the text box below empty.

Granting a membership

From the customer's point of view, there is no difference in the way memberships and any other
representations of product are bought. However, the membership is granted to the customer only if the 
order is marked as paid. This can be done either automatically when the order changes its status to one
with the Mark order as paid property enabled (available in CMS Desk -> E-commerce ->
Configuration -> Order status -> Edit ( ) order status) ...

http://devnet.kentico.com/docs/7_0/devguide/membership_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/membership_overview.htm
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... or manually by a store administrator by enabling the Order is paid property in CMS Desk -> E-
commerce -> Orders -> Edit ( ) order on the Billing tab of the order's editing interface.

Marking a memberships order as paid, both automatically and manually, results either in renewing the
existing memberships or assigning new ones (depending on if a new membership or a renewal was
ordered). In both cases, users are notified by means of a notification e-mail based on the E-commerce -
Order payment notification to customer e-mail template.

Please note

If an order for memberships with validity in time units already marked as paid is
unmarked, the validity is reduced by these unpaid units.

If an order for memberships with unlimited validity or validity until a particular date
already marked as paid is unmarked, the memberships are removed completely.
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Notifying about membership expiration

The system can be configured to send customers an automatic e-mail notification when their
membership is close to expiration. This can be configured by means of the Send membership
reminder (days) setting in Site Manager -> Settings -> Security & Membership. For more details,
please refer to the Memberships -> Managing memberships topic in the Developer's Guide, specifically
to its Membership expiration reminders section.

Renewing membership

To have an expired membership renewed, the customer can either ask the administrator to perform the
renewal or they can buy a new membership using the My account web part on the live site. On the
Memberships tab, the customer can view a list of their memberships. By clicking the Buy
membership button, they are redirected to a page allowing them to buy new memberships or renew
their existing ones.

4.4.2.4.4      E-product

The E-product product representation is designed for products in form of electronic files that can be
downloaded. You will typically use it for software installation files, audio files, videos, e-books, etc.

http://devnet.kentico.com/docs/7_0/devguide/membership_management.htm
http://devnet.kentico.com/docs/7_0/webparts/MyAccount_overview.htm
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Defining an e-product

When creating a new product or editing an existing one (on the General tab), you need to choose E-
product in the Representing drop-down list. After doing so, the E-product section appears below,
allowing you to enter the following properties specific for this product representation:

Files validity - sets the period of time during which the file(s) can be downloaded after being
purchased. Can be set either for a limited period (Days, Weeks, Months, Years, Until a given date) or
for an unlimited period. To set your files validity for an unlimited period of time, choose Until and leave
the text box below empty.
Files - allows to upload the actual file(s). Only files with allowed extensions can be uploaded. The
extensions can be defined using the Upload extensions setting in Site Manager -> Settings ->
System -> Files.

Enabling e-product download links

From the customer's point of view, there is no difference in the way e-products and any other types of
product are bought. However, the customer is able to download the files only if the order is marked as
paid. This can be done either automatically when the order changes its status to one with the Mark
order as paid property enabled (available in CMS Desk -> E-commerce -> Configuration -> Order
status -> Edit ( ) order status) ...
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... or manually by a store administrator by enabling the Order is paid property in CMS Desk -> E-
commerce -> Orders -> Edit ( ) order on the Billing tab of the order's editing interface.

Marking an e-product order as paid, both automatically and manually, results in creating new download
links for the respective e-product files, with validity set as of the time of marking.

Please note

If an order for e-products already marked as paid is unmarked, the download links
related to these e-products are deleted so the customer is not able to download the
files.

Downloading e-product files

Once the download links are created when the order is marked as paid, customers can get to the links
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two ways.

First, they can see the links via the My account web part on the live site. On the Orders tab, they can
view a list of all their orders, where each order containing at least one e-product has a View link in the
Downloads column. By clicking the link, the user can view a list of e-products bought in the given order,
together with the respective download links.

If e-mail notifications about paid orders are enabled, the user receives an e-mail notification based on
the E-commerce - Order payment notification to customer e-mail template when an order is paid. This
template contains a macro which ensures that respective download links are included in the e-mails.

http://devnet.kentico.com/docs/7_0/webparts/MyAccount_overview.htm


Kentico CMS 7.0 E-commerce Guide94

© 2014 Kentico Software

Notifying about e-product expiration

If an e-product download link is close to its expiration, the system can send the customer an automatic
e-mail notification. By setting the Send e-product reminder (days) value in Site Manager -> Settings
-> E-commerce, you can specify how many days prior to expiration a notification will be sent.

Checking for upcoming expirations is performed by the E-product reminder scheduled task
(manageable in Site Manager -> Administration -> Scheduled tasks). This task is defined as global
by default, which means that it checks for upcoming expirations of e-products purchased on all websites
running in the system. Alternatively, you can define the scheduled task separately for individual websites
in order to check only for expirations of e-products purchased on a particular website.

The content of the e-mails is based on the E-commerce - E-product expiration notification e-mail
template, which can be edited in Site Manager -> Administration -> E-mail templates. This template
is also defined as global by default, but you can create a site-specific template with the same code
name. This one would be used for all notifications for orders made on the respective website.

Detailed information on scheduled tasks in Kentico CMS can be found in Developer's Guide ->
Development -> Scheduler.

4.4.2.4.5      Donation

The Donation product representation is designed to allow a user to donate a sum of money. It behaves
as a standard product and can be offered stand-alone or with various product options. However, you
cannot put a donation into a bundle or select it as a product option.

Defining a donation

When creating a new product or editing an existing one (on the General tab), you need to choose
Donation in the Representing drop-down list. After doing so, the Donation section appears below,
allowing you to enter the following properties specific for this product representation:

Minimum donation - the minimum sum of money that a user can donate.
Maximum donation - the maximum sum of money that a user can donate.

http://devnet.kentico.com/docs/7_0/devguide/scheduler_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/scheduler_overview.htm
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Allow private donation - indicates whether the user is allowed to donate privately so that they will
not be present in public donation lists, reports, etc. If enabled, an option letting to choose a private
donation is displayed during the purchase process when adding the product into the shopping cart.

Reporting donations

Kentico CMS allows you to view donation reports. If you decide to view these reports, navigate to CMS
Desk -> E-commerce -> Reports and from the Reports tree choose the Donations section. If you
choose e.g. the List of donations report, you can see what users (donors) made what donations, how
much they donated, and also some other donation-related details.
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4.4.2.4.6      Bundle

The Bundle product representation is designed to allow users to buy several different products as a
single product. This can be highly effective if selling related products or products which would not sell
well enough separately.

Defining a bundle

When creating a new product or editing an existing one (on the General tab), you need to choose
Bundle in the Representing drop-down list. After doing so, the Bundle section appears below, allowing
you to enter the following properties specific for this product representation:

Remove from inventory - defines the behavior of the product inventory when a bundle is purchased.
Remove bundle only - the bundle is removed from the inventory as a whole, but individual
products are kept in the inventory.
Remove each product separately - individual products contained in the bundle are removed from
the respective inventories, but the bundle is not removed.
Remove both bundle and products - both the bundle and products contained in it are removed
from the inventory.

Products - allows to add products to be sold within the bundle. You can add any representation of
product except for a donation and another bundle.

Bundle price calculation

During its price calculation, a bundle behaves as a separate product. Neither taxes nor discounts related
to individual products contained in the bundle are reflected in the calculation.
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4.4.3 Managing products

4.4.3.1 Adding a new product

In this topic, you will learn how new products can be added to your on-line store. The same approach
that is demonstrated here can be used to add any products into any website featuring the E-commerce
solution.

1. In order to add a product to your on-line store, navigate to CMS Desk -> E-commerce -> Products
(alternatively to CMS Desk -> Content) and above the product sections tree (where you can choose a

section under which the product will be put) click the  New button.

2. This redirects you to the New product or section user interface, where you need to specify what
product type to use for the new product.
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Please note that if you were creating a new product section, you would need to choose one of the
available section types in this step.

3. At this point, you enter the more frequently accessed properties of the product (you can later modify
them while editing the product on the General tab).
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4. When you have entered the required values, click  Save. As you can see, the new product is listed
among other products. It can be further managed as described in detail in the Managing products
chapter.

4.4.3.2 Managing products

Products can be managed in CMS Desk -> E-commerce -> Products (alternatively in CMS Desk ->
Content). In this part of the administration interface, you can see a product sections tree, which
represents a selected part of your website structure, and a list of all defined products under the currently
selected section. Please note that the actual content of the page is determined by your store settings
and configuration of the filter.
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Product sections tree

The sections tree allows you (if displayed) to view a specified part of your website structure, either with
or without the contained products. If you select a section, all products contained in the section are
listed. If you select a product, its editing interface is displayed allowing you to modify the product's
properties. The following actions are available to manage items displayed in the tree:

 New - allows to create a new section or product under the currently selected node.

 Delete - deletes the currently selected section (including the contained products) or product.
 Copy - creates a copy of the currently selected section or product in a location specified in a pop-

up dialog. If a section is selected, the contained products, same as respective permissions may also
be copied.

 Move - moves the currently selected section or product to a location specified in a pop-up dialog.
If a section is selected, the contained products are also moved, while the respective permissions
may be preserved.

 Up - moves the currently selected section or product above the one which is above it at the same
level.

 Down - moves the currently selected section or product below the one which is below it at the
same level.

Deleting a section or product

If you decide to delete a section or product, the Delete document dialog will pop up, prompting you to

enter the  Delete action parameters. The Assigned SKU section of this dialog allows you to choose
what should happen with the SKU (product object) upon deletion of the associated product type
document:

Delete SKU if possible otherwise disable it (recommended) - the product type document same
as the assigned SKU will be deleted if no preclusive dependency exists (e.g. the product is not
contained in any order). Otherwise, only the document will be deleted and the SKU will be disabled
and remain in the system, the recommended option.
Delete SKU if possible - the product type document same as the assigned SKU will be deleted if no
preclusive dependency exists (e.g. the product is not contained in any order). Otherwise, only the
document will be deleted and the SKU will remain in the system.
Disable SKU - the product type document will be deleted and the assigned SKU will be disabled and
remain in the system.
Do not delete SKU - only the product type document will be deleted.

Multilingual store

If your store is multilingual you can switch between multiple language versions of the currently selected
section or product. You can also switch to the language version comparison mode and edit language
versions side-by-side.

Stand-alone SKUs

If stand-alone SKUs are allowed on the current site, the  Stand-alone SKUs node is displayed above
the sections tree, allowing you to view a list of all stand-alone SKUs defined on the current site.

Products list
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Under a selected section, you may need to display only products matching certain search criteria (e.g.
name or number, department, manufacturer, etc.). To do so, choose either the simplified or advanced
filter, enter the required values and click Show.

The following actions are available if a section is selected from the sections tree:

 Parent section - can be used to navigate to the parent section of the currently selected section.
Please note that this button is hidden if no such parent section exists.

 Section properties - allows to edit properties of the currently selected section.

Besides, the listed products under the selected section can be Edited ( ) or Deleted ( ).

Using the pair of drop-down lists below the listed product items, you can perform certain management
tasks with multiple products at once (Move, Copy, Link, Delete, Translate, Publish, Archive). To do
so, choose either Selected documents or All documents from the first drop-down list, the required
action from the second one and click OK.

When editing a product, the following tabs are available to specify its properties:

General tab
Attachments tab
Metadata tab
Categories tab
Tax classes tab
Advanced tab

Options
Volume discounts
Related products
Workflow
Versions
Documents

Preview tab
Live site tab
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CMS Desk -> Content

Although it is recommended to manage products in CMS Desk -> E-commerce -> Products, they can
be managed also in CMS Desk -> Content -> Edit. As this part of the administration interface is
designed primarily to manage pages (or documents) that build up your website, more product document
type properties can be edited here as compared with the corresponding UI in the E-commerce solution.
The more frequently modified properties of the respective product objects (SKUs) can be edited on the 
Form tab, and other product object-specific properties can be configured using the SKU tab (tax
classes, volume discounts, options and documents).

Form tab

Please note

If you are editing a product (i.e. an SKU and the associated product type document),
the  Remove SKU from this document action in the SKU binding section allows
you to remove the bound SKU from the document. Please note that the system does
not support the action (and hides the section) for products using a workflow.

If you are editing a product type document only (i.e. no SKU is currently assigned), the 
 Create new or assign existing SKU action allows you to assign an SKU (new or

existing) to the document.
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4.4.3.3 General tab

On the General tab you can edit the more frequently accessed properties of the product. Currently, the
system supports five product representations: standard product, membership, e-product, donation and
bundle.

The following properties (standard product) are shared by all product representations:

General

Product name - here you can enter the name of the product that will be displayed to users on the
live site and in the administration interface.
Product number - allows you to specify the product number (serial number or SKU number) for your
records.
Price - allows you to specify the product price in the main currency.
List price - here you can specify the list price, i.e. the recommended retail price (RRP) or
manufacturer's suggested retail price (MSRP), of the product. The list price typically is determined
by factors such as supply, demand and manufacturing costs.
Department - here you can specify the department responsible for the product.
Manufacturer - here you can specify the product manufacturer.
Supplier - can be used to enter the product supplier.
Image - URL of the product image. When a file is uploaded into the field, two icons are displayed
next to it:
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Edit ( ) - if the file is an image, clicking the icon opens it in the built-in image editor; see
Developer's Guide -> Content management -> File management -> Image editor. If the file is not an
image (which would not make sense as no product image could be displayed), the metadata editor
is opened after clicking the icon; see Metadata editor in the same section of the Developer's
Guide.
Delete ( ) - removes the file from the field.

Short description - a short product description used for special product listings.
Description - a product description used for special product listings.
Representing - defines a product representation. You can choose from five different representations.
Specifically, a standard representation (i.e. standard product) and four specialized types derived from
this general type (i.e. membership, e-product, donation and bundle) can be offered in your on-line
store.

Custom properties

In the top part of the section you can edit custom fields that you added in Site Manager -> Development
-> System tables -> Edit ( ) the Ecommerce - SKU table. Besides, product type-specific properties
can be edited in this section (if available). For example, a cell phone has a resolution and an e-book has
a publisher. Please note that if no custom properties are defined for the current product, this section is
hidden.

Status

In store from - indicates since when the product is available in your on-line store. The default value
is the current date (i.e. the date of product creation). You can type in the value and you can also
change it automatically by using the  icon or the Now link.
Public status - here you can select a product status displayed to the visitors of your website - e.g.
Featured.
Internal status - can be used to select a product status used for your internal business purposes,
e.g. New model.
Allow for sale - indicates if the product can be added to the shopping cart and purchased.

Shipping

Needs shipping - indicates if the product needs shipping.
Package weight - can be used to specify package weight in your chosen units.
Package height - can be used to specify package height in your chosen units.
Package width - can be used to specify package width in your chosen units.
Package depth - can be used to specify package depth in your chosen units.

Inventory

Sell only if items available - indicates if customers can purchase only quantity that is in stock
(checked box).
Available items - indicates the number of items available in stock.
Reorder at - indicates at which quantity the product should be reordered.
Availability (days) - indicates the number of days required for processing an order (e.g. an order
may take 3 days to get the product from its distributor).
Min items in one order - defines the minimum number of items in one order.
Max items in one order - defines the maximum number of items in one order.

Analytics

http://devnet.kentico.com/docs/7_0/devguide/image_editor_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Metadata_editor.htm
http://devnet.kentico.com/docs/7_0/onlinemarketingguide/Conversions_overview.htm
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Please note that this section is not available when editing a global product.

Conversion name - can be used to select a conversion that will be logged when this product is
purchased (ordered) by a customer. The Select button allows you to choose from a list of existing
conversion objects available for the website. Edit and New may be used to directly manage
conversions.
Conversion value - sets a numerical value that will be recorded for the specified conversion when
the product is purchased. The values are cumulative, i.e. when a conversion hit is logged, the
specified value is added to the total sum previously recorded for the given conversion. You may insert
a macro expression into this field to dynamically retrieve a value from the current site context. For
example: {%ShoppingCartItem.UnitTotalPrice%}. This sample macro allows the conversion to log
the price of the given product as its value. The advantage of a macro is that it retrieves the price
dynamically, including tax and any potential discounts applied by the given customer.

4.4.3.4 Attachments tab

On the Attachments tab you can see a list of the currently selected product's attachments. In Kentico
CMS, attachments are a concept of attaching multiple files to your products and documents. You can
easily add images, same as any other registered types of files where required, and thus enhance your
on-line store users' experience.

For example, you may wish to present your customers with featured images of a given article, i.e. you
may wish to create an image gallery, or simply want to provide them with various supplementary
materials such as leaflets, e-guides, etc.

When attached to a product, images can be displayed on the live site through an appropriate 
transformation or web part, e.g. the Attachment image gallery web part. Therefore, it is essential that
you had placed it into your product type template.

http://devnet.kentico.com/docs/7_0/devguide/macro_expressions_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/attachments_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/files_related_settings.htm
http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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You can upload a New attachment ( ). You can also perform the following actions with the
attachments in the list:

Edit ( ) - if the attachment is an image, clicking the icon opens it in the built-in image editor. If the
attachment is not an image, the metadata editor is opened after clicking the icon. 
Delete ( ) - removes the attachment from the product. 
Move up ( ) and Move down ( ) - re-orders the attachments. The order is stored in the
AttachmentOrder property of each attachment. You can enter AttachmentOrder into the ORDER
BY expression property of a displaying web part to have the attachments ordered accordingly.

Please note

The order of attachments is not versioned with products' workflow. This means that if
you change the order of attachments in one version of a product, the order is changed
in all other versions, too.

Clone ( ) - allows you to quickly create a copy of the selected item, including its configuration. You
can then modify it as required.
Update ( ) - enables you to replace the original attachment with a new one.
After clicking an attachment's name, the attachment is opened.

http://devnet.kentico.com/docs/7_0/devguide/image_editor_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Metadata_editor.htm
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4.4.3.5 Metadata tab

On the Metadata tab you can edit the currently selected product's metadata. This type of data can be
used e.g. for Search engine optimization (SEO) or to mark your products with key words called tags,
depending on their content.

http://devnet.kentico.com/docs/7_0/devguide/document_properties_Metadata.htm
http://devnet.kentico.com/docs/7_0/devguide/search_engine_optimization.htm
http://devnet.kentico.com/docs/7_0/devguide/tags_module_overview.htm
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4.4.3.6 Categories tab

On the Categories tab you can assign categories defined for the current site to the currently selected
product. The Categories concept allows to sort products offered in your on-line store based on topic-
related groups. In addition to tags, it is thus another approach to sorting your on-line store content.

If any categories are already assigned to the product, a list of these categories is displayed, together
with a category status and the Remove selected and Add categories buttons. If no categories are
assigned, only the latter button is displayed. Please note that you can remove all listed items at once by
clicking the  icon and performing the  Remove all action.

4.4.3.7 Tax classes tab

On the Tax classes tab you can specify which taxes will apply to the currently edited product. To add
tax classes, click the Add tax classes button and check the boxes next to the appropriate tax classes
in the displayed selection dialog. Tax classes can be removed from the product at any time using the
checkboxes next to the listed items, together with the Remove selected button. You can also remove
all listed items at once by clicking the  icon and performing the  Remove all action.

4.4.3.8 Advanced tab

On the Advanced tab you can edit the following advanced properties of the product:

Options
Volume discounts
Related products
Workflow
Versions
Documents

http://devnet.kentico.com/docs/7_0/devguide/Categories_module_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/tags_module_overview.htm
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Options

In the Options section you can specify which option categories will apply to the current product. To add
option categories, click the Add categories button and check the boxes next to the appropriate
categories in the displayed selection dialog. Option categories can be removed from the product at any
time using the checkboxes next to the listed items, together with the Remove selected button. You
can also remove all listed items at once by clicking the  icon and performing the  Remove all
action.

Volume discounts

In the Volume discounts section you can see a list of volume discounts which are applied when a
customer purchases a specified amount of the product. The discounts are automatically calculated and
applied during the checkout process when the user adds a given amount of product items to their
shopping cart. Multiple volume discount levels can be defined, allowing you to apply different discounts
for different amounts of purchased items.

You can add a new volume discount by clicking the  New volume discount button above the list.
Properties of already defined volume discounts can be edited by clicking the Edit ( ) icon in the
Actions column. You can also delete a volume discount by clicking the Delete ( ) icon.

The following properties are available when creating or editing a volume discount object:
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Minimum amount - sets the minimum amount of ordered items to which the current volume
discount applies.
Discount value - here you can specify a discount for the given volume (as set in the Minimum
amount property). You can choose to apply either a relative or absolute discount using the respective
radio buttons.

Related products

In the Related products section you can build relationships between products. The relationship names
need to be defined in Site Manager -> Development -> Relationship names. Please note that only
relationship names enabled for the current website can be used when building relationships between
products offered in your on-line store.

New relationships can be created after clicking the  Add related document button. Listed
relationships can be deleted by clicking the Delete ( ) icon in the respective row.

Workflow

The Workflow section is available only if a workflow is defined for the product. Workflow is a sequence
of steps that define the life cycle of the product. This allows to set up a reviewing and approval process
to ensure quality of content and design. In such process, you can specify roles that different users play
and places in the flow where the users have influence on the product.

In the initial section of the page, you can see which workflow is currently applied to the product, perform
workflow actions (  Publish,  Archive, etc.) and enable sending notification e-mails. Please note

http://devnet.kentico.com/docs/7_0/devguide/Workflow_overview.htm
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that workflow notification e-mails are not sent among users who have the same e-mail address. So for
example, when user1 and user2 have the same address and user1 sends a document for user2's
approval, no notification e-mail is sent.

Workflow steps

This table displays all workflow steps of the current product's workflow, while the current step is
highlighted.

Workflow history

This list displays the current product's workflow step history, i.e. a list of all workflow status changes
made throughout the product's life cycle. With each status change, you can see its exact date and time,
final workflow step, the user who performed the action and the actual type of action that was performed.

Please note

Only basic product properties that can be accessed on the General tab are subject to
workflow, with the following exceptions:

e-product files (i.e. the Files property of the E-product representation)
products contained in a bundle (i.e. the Products property of the Bundle
representation)
product image (i.e. the Image property shared by all product representations)

Besides, Attachments and Page settings (i.e. the Page title, Page description and
Page keywords properties accessible on the Metadata tab) are also versioned. Other
product properties are not subject to workflow, which means their changes are reflected
immediately.

Versions
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The Versions section is available only if a workflow is defined for the product. You can see here all
workflow versions of the currently edited product. The history is also displayed when a particular version
has been published and when it was replaced with a new one.

You can perform the following actions with the versions:

 View - displays an overview of the product's content with the possibility of side-by-side
comparison of versions.

 Rollback - rolls back any changes made since the particular version of the product.
 Delete - deletes the old product's version.

If you click the Clear history button, all product versions except the latest one will be deleted. Please
note that the length of the version history can be configured in Site Manager -> Settings -> Content ->
Content management -> Version history length.

Automatic version numbering

Kentico CMS supports automatic version numbering: 

If you use workflow without content locking, automatic version numbering is used by default.
If  you  use  content  locking,  this  option  is  optional  and  can  be  configured  in  Site  Manager  ->
Settings -> Content -> Content management -> Use automatic version numbering.

The automatic version numbering works as shown in the following example:

0.1 - the first version of the product when it is created.
0.2 - the second modification of the product.
1.0 - the first published version of the product.
1.1 - the first modification of the published product.
2.0 - the second published version of the product.

Documents

In the Documents section you can see a list of documents to which the currently edited product object
(SKU) is assigned. Click Edit document ( ) to edit the given document or click Navigate to
document ( ) to view the document on the live site.

http://devnet.kentico.com/docs/7_0/devguide/document_properties_overview.htm
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4.4.3.9 Preview tab

On the Preview tab you can see the current version of the product before it is published (if you are
using workflow). You can also view the content without using caching, which allows you to preview it
even if the live website displays the cached version.

If the product does not use workflow and its Publish from property (if available) is set to a future date
and time, the Preview tab displays the content that will be published after the specified date and
time.
If the product uses workflow and did not get to the Published step yet, the content created in the
current workflow step is displayed.
If the product uses workflow, it already got to the Published workflow step and its workflow cycle
has been restarted (i.e. it was switched from the Published/Archived workflow step back to the
Edit step and is going through the workflow cycle again), the content from the current workflow step
is displayed.

Please note

The Live site and Preview tabs display the same content when the product is
published and no further changes have been made to it since it was published.

http://devnet.kentico.com/docs/7_0/devguide/Workflow_overview.htm
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4.4.3.10 Live site tab

On the Live site tab you can see the product as it is currently displayed on the live site to website
visitors.

If the product does not use workflow and its Publish from property (if available) is set to a future date
and time, the Live site tab does not display any content.
If the product uses workflow and did not get to the Published step yet, no content is displayed.
If the product uses workflow, it already got to the Published workflow step and its workflow cycle
has been restarted (i.e. it was switched from the Published/Archived workflow step back to the
Edit step and is going through the workflow cycle again), the last published version is displayed.

Please note

The Live site and Preview tabs display the same content when the product is
published and no further changes have been made to it since it was published.

http://devnet.kentico.com/docs/7_0/devguide/Workflow_overview.htm
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4.4.4 Product statuses

4.4.4.1 Overview

When creating a new product or editing an existing one (on the General tab), you can assign it with two
different statuses:

Public status - status of the product typically used to be displayed to website visitors. For example
Featured product, Sale, Bestseller, etc.
Internal status - status of the product typically used for internal purposes, i.e. displayed only in the
user interface and not visible to website visitors. For example New model, Old model, Discounted,
etc.
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4.4.4.2 Public statuses

Public statuses are typically displayed to your on-line store customers while viewing the product offer on
the live site. For example Featured product, Sale, Bestseller, etc.

Public statuses can be defined in CMS Desk -> E- commerce -> Configuration -> Public status (or
in Site Manager -> Tools -> E-commerce configuration -> Public status; global public statuses
only). In this section of the administration interface, you can see a list of all defined public statuses. You
can add new public statuses by clicking the  New public status button above the list. Properties of
already defined public statuses can be edited by clicking the Edit ( ) icon in the Actions column. You
can also delete a public status by clicking the Delete ( ) icon.
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When creating a new public status or editing an existing one, you can specify the following properties:

Display name - the name of the public status displayed to users on the live site and in the
administration interface.
Code name - the name of the public status used by developers in the code.
Enabled - indicates if the public status object can be used in your on-line store. For example, if
checked, the respective public status can be selected from the Public status drop-down list when
editing a product on the General tab.

4.4.4.3 Internal statuses

Internal statuses are typically displayed only to your on-line store administrators in the user interface,
not to the customers on the live site. For example New model, Old model, Discounted, etc.

Internal statuses can be defined in CMS Desk -> E- commerce -> Configuration -> Internal status (or
in Site Manager -> Tools -> E-commerce configuration -> Internal status; global internal statuses
only). In this section of the administration interface, you can see a list of all defined internal statuses.
You can add new internal statuses by clicking the  New internal status button above the list.
Properties of already defined internal statuses can be edited by clicking the Edit ( ) icon in the Actions
column. You can also delete an internal status by clicking the Delete ( ) icon.
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When creating a new internal status or editing an existing one, you can specify the following properties:

Display name - the name of the internal status displayed to the users of your website.
Code name - the name of the internal status used by developers in the code.
Enabled - indicates if the internal status object can be used in your on-line store. For example, if
checked, the respective internal status can be selected from the Internal status drop-down list when
editing a product on the General tab.



Managing your store 119

© 2014 Kentico Software

4.4.5 Stand-alone SKUs

4.4.5.1 Overview

Although it is recommended to manage products the standard way as described in detail in the 
Managing products chapter (i.e. to manage product objects or SKUs together with associated product
type documents), the current version of the CMS system allows you to manage product objects with
unassigned product type documents (stand-alone SKUs).

Please note that as stand-alone SKUs are disabled by default, you need to modify your on-line store
settings to be able to access product objects with unassigned product type documents.

4.4.5.2 Stand-alone SKUs

Stand-alone SKUs can be managed in CMS Desk -> E-commerce -> Configuration -> Products. If
they are allowed on the current site, the  Stand-alone SKUs node is displayed above the sections
tree, allowing you to view a list of all product objects with unassigned product type documents defined
on the current site.

You can add a new stand-alone SKU by clicking the  New button above the tree (if the  Stand-
alone SKUs node is selected). Properties of already defined stand-alone SKUs can be modified in the
Stand-alone SKUs user interface by clicking the Edit ( ) icon in the Actions column. You can also
delete a stand-alone SKU by clicking the Delete ( ) icon.

However, if the sections tree is hidden (see the Site settings topic), both stand-alone SKUs and SKUs
with associated product type documents are listed in the Products user interface and a new product
object (SKU) can be added by clicking the  New SKU button.
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When editing an SKU, the following tabs are available to specify its properties:

General tab
Tax classes tab
Options tab
Volume discount tab
Documents tab - site-specific stand-alone SKUs cannot have any documents assigned. Therefore,
the tab is available for global stand-alone SKUs only.

Please note that the same tabs offering the same properties are available when editing a product (i.e.
SKU + associated product type document).

4.4.6 Manufacturers

For each product, it is possible to specify its manufacturer. You can use this information for your internal
purposes or you can display it on your website. You can for example display a link to the manufacturer's
website on a product detail page in order to let your customers find more details about the product. This
information is optional and you don't need to enter it.

When creating a new product or editing an existing one (on the General tab), you can choose its
manufacturer in the Manufacturer drop-down list as highlighted in the screenshot below.
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Managing manufacturers

Manufacturers can be managed in CMS Desk -> E-commerce -> Manufacturers. In this section of the
administration interface, you can see a list of all defined manufacturers. New ones can be added to the
list by clicking the  New manufacturer button above the list. Properties of already defined
manufacturers can be edited by clicking the Edit ( ) icon in the Actions column. You can also delete a
manufacturer by clicking the Delete ( ) icon.
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When creating a new manufacturer or editing an existing one, you can specify the following properties:

Display name - the name of the manufacturer displayed to users on the live site and in the
administration interface.
Code name - the name of the manufacturer used by developers in the code.
Description - can be used to enter a text description for the manufacturer in order to give information
about its orientation, background, etc.
Homepage - allows to specify the URL of the manufacturer's website.
Logo - can be used to add a teaser, usually an image, to the manufacturer. However, other types of
files such as documents and audio and video files can also be uploaded.
Is important - allows to mark the manufacturer as important. The flag can be used e.g. for filtering
purposes when displaying data on the live site.
Enabled - indicates if the manufacturer object can be used in your on-line store. For example, if
checked, the respective manufacturer can be selected from the Manufacturer drop-down list when
editing a product on its General tab.
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4.4.7 Suppliers

For each product, it is possible to specify its supplier, i.e. a company that supplies you with the product.
You will typically use this information only for your internal purposes and will not display it on your
website.

When creating a new product or editing an existing one (on the General tab), you can choose its
supplier in the Supplier drop-down list as highlighted in the screenshot below.



Kentico CMS 7.0 E-commerce Guide124

© 2014 Kentico Software

Managing suppliers

Suppliers can be managed in CMS Desk -> E-commerce -> Suppliers. In this section of the
administration interface, you can see a list of all defined suppliers. New ones can be added to the list by
clicking the  New supplier button above the list. Properties of already defined suppliers can be edited
by clicking the Edit ( ) icon in the Actions column. You can also delete a supplier by clicking the
Delete ( ) icon.

When creating a new supplier or editing an existing one, you can specify the following properties:
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Display name - the name of the supplier displayed to the users of your website.
Code name - the name of the supplier used by developers in the code.
Supplier e-mail - can be used to specify the supplier's e-mail address.
Supplier phone - allows to enter the supplier's phone number.
Supplier fax - can be used to specify the supplier's fax number.
Enabled - indicates if the supplier object can be used in your on-line store. For example, if checked,
the respective supplier can be selected from the Supplier drop-down list when editing a product on
its General tab.

4.5 Product options

4.5.1 Overview

Product options offer your customers greater variability in choosing the right product and thus boost your
sales.

They are divided into categories, e.g. T-shirt size or T-shirt color. An actual product option, e.g. the
Medium size of a T-shirt or its Green color, may then be offered and sold along with the given product
article.

Besides, any suitable product can be assigned a category with a single text option, which allows to put
writing or inscription on the product, e.g. to put writing on a T-shirt.

4.5.2 Product option categories

When editing a product (on the Options tab), you can choose categories containing product options
which will be offered together with the product. This can be done by clicking the Add categories button
and checking the boxes next to the appropriate categories in the displayed selection dialog.
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Managing product option categories

Product option categories can be managed in CMS Desk -> E-commerce -> Product options. In this
section of the administration interface, you can see a list of all defined option categories. New ones can
be added to the list by clicking the  New category button above the list. When creating a new
category, choose either Category with selectable options to create a category containing selectable
options or choose Category with one text option only to create a category containing just one text
option. Properties of already defined categories can be edited by clicking the Edit ( ) icon in the
Actions column. You can also delete a category by clicking the Delete ( ) icon.

When editing a product option category, the following tabs are available to specify its properties:

General tab
Options tab

General tab

On this tab you can edit general properties of the selected category. Every category with selectable
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options has the following properties:

Display name - the name of the option category displayed to users on the live site and in the
administration interface.
Code name - the name of the option category used by developers in the code.
Selection type - the type of input selection which allows the user to choose a category option.
Please note that the checkbox selection type allows them to select more than one option.
Display price - if enabled, product option prices are displayed together with product options.
Default option(s) - the category option(s) which is(are) set by default. If the user doesn't select any
option, the default one is used.
Description - can be used to enter a text description of the option category in order to give further
information.
Default record text - can be used to enter a default record text for the current option category, e.g.
(none). For example, if you use this text in the Default option(s) property, it will be displayed to the
user as the category default option.
Enabled - indicates if the option category object can be used in your on-line store. For example, if
checked, the category will be offered in the selection dialog when editing a product on the Options
tab.

Every category with one text option only has the following properties:

Display name - the name of the option category displayed to users on the live site and in the
administration interface.
Code name - the name of the option category used by developers in the code.
Text type - here you can define the type of text; either a text box or text area can be selected.
Display price - if enabled, the product option price is displayed together with the product option.
Default text -  can be used to set the default text of the product option under this category.
Text max length - specifies the maximum length of the option text.
Description - can be used to enter a text description of the option category in order to give further
information.
Enabled - indicates if the option category object can be used in your on-line store. For example, if
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checked, the category will be offered in the selection dialog when editing a product on the Options
tab.

You need to click the confirmation button below the fields to save any changes.

Options tab

On this tab you can manage product options under the currently edited category as described in detail in
the Product options topic.

Categories with one text option only

Categories with one text option only contain just one text option. They can be used e.g. to give your
customers the choice of having some writing put on a T-shirt or an inscription added on the cover of a
cell phone. However, from the point of view of the user, the option is defined for and assigned to a
selected product as any other product option.

4.5.3 Product options

Product options can be managed in CMS Desk -> E-commerce -> Product options if the respective
product option category is Edited ( ) on its Options tab.

On this tab you can see a list of all options under the currently edited category. You can add a new
option by clicking the  New product option button, alphabetically sort the listed items using the 
 Sort A-Z button and Edit ( ) or Delete ( ) an existing item in the list. You can also change the items'
succession within the current option category ( ), ( ).
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Please note that if you are editing a category with one text option only, just this option is listed and the
 New product option and  Sort A-Z buttons, same as the Delete ( ), Move up ( ) and Move

down ( ) actions are missing.

If you choose to Edit ( ) a product option, the following tabs are available to specify its properties:

General tab
Tax classes tab

General tab

On this tab you can edit general properties (further divided into categories) of the currently edited product
option. You can choose from three product representations, which can be used as product options:
standard product, membership and e-product. Every option has its Standard product properties and,
based on the product representation from which it is derived, may also have other representation-specific
properties:

Product representation: Standard product

General

Product name - here you can enter the name of the product that will be displayed to users on the
live site and in the administration interface.
Product number - allows you to specify the product number (serial number or SKU number) for your
records.
Price - allows you to specify the product price in the main currency.
List price - can be used to enter the list price, i.e. the recommended price, of the product.
Department - here you can specify the department responsible for the product.
Manufacturer - here you can specify the product manufacturer.
Supplier - can be used to enter the product supplier.
Image - URL of the product image. When a file is uploaded into the field, two icons are displayed
next to it:

Edit ( ) - if the file is an image, clicking the icon opens it in the built-in image editor; see
Developer's Guide -> Content management -> File management -> Image editor. If the file is not
an image (which would not make sense as no product image could be displayed), the metadata
editor is opened after clicking the icon; see Metadata editor in the same section of the Developer's
Guide. 
Delete ( ) - removes the file from the field.

http://devnet.kentico.com/docs/7_0/devguide/image_editor_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Metadata_editor.htm
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Short description - a short product description used for special product listings.
Description - a product description used for special product listings.
Representing - defines a product representation; you can choose from three different
representations. Specifically, a standard representation (i.e. standard product) and two specialized
types derived from this general type (i.e. membership and e-product) may be offered in your on-line
store as product options. Please note that if you are editing a text product option, only Text is
available.

Custom properties

In this section you can edit custom fields that you added in Site Manager -> Development -> System
tables -> Edit ( ) the Ecommerce - SKU table. Please note that if no such custom properties are
defined, this section is hidden.

Status

In store from - indicates since when the product is available in your on-line store. The default value
is the current date (i.e. the date of product creation). You can type in the value and you can also
change it automatically by using the  icon or the Now link.
Public status - here you can select a product status displayed to the visitors of your website - e.g.
Featured.
Internal status - can be used to select a product status used for your internal business purposes,
e.g. New model.
Allow for sale - indicates if the product can be added to the shopping cart and purchased.

Shipping

Needs shipping - indicates if the product needs shipping.
Package weight - can be used to specify package weight in your chosen units.
Package height - can be used to specify package height in your chosen units.
Package width - can be used to specify package width in your chosen units.
Package depth - can be used to specify package depth in your chosen units.

Inventory

Sell only if items available - indicates if customers can purchase only quantity that is in stock
(checked box).
Available items - indicates the number of items available in stock.
Reorder at - indicates at which quantity the product should be reordered.
Availability (days) - indicates the number of days required for processing an order (e.g. an order
may take 3 days to get the product from its distributor).
Min items in one order - defines the minimum number of items in one order.
Max items in one order - defines the maximum number of items in one order.

Analytics

Please note that this section is not available when editing a global product option.

Conversion name - can be used to select a conversion that will be logged when this product is
purchased (ordered) by a customer. The Select button allows you to choose from a list of existing
conversion objects available for the website. Edit and New may be used to directly manage
conversions.

http://devnet.kentico.com/docs/7_0/onlinemarketingguide/Conversions_overview.htm
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Conversion value - sets a numerical value that will be recorded for the specified conversion when
the product is purchased. The values are cumulative, i.e. when a conversion hit is logged, the
specified value is added to the total sum previously recorded for the given conversion. You may insert
a macro expression into this field to dynamically retrieve a value from the current site context. For
example: {%ShoppingCartItem.UnitTotalPrice%}. This sample macro allows the conversion to log
the price of the given product as its value. The advantage of a macro is that it retrieves the price
dynamically, including tax and any potential discounts applied by the given customer.

Product representation: Membership

Membership group - membership defined in CMS Desk / Site Manager -> Administration ->
Membership that a customer will get for purchasing the product.
Membership validity - indicates how long the membership will be valid after being purchased. Can
be set either for a limited period of time (Days, Weeks, Months, Years, Until a given date) or for an
unlimited period. To set membership validity for an unlimited period of time, choose Until and leave
the text box below empty.

Product representation: E-product

Files validity - sets the period of time during which the file(s) can be downloaded after being
purchased. Can be set either for a limited period (Days, Weeks, Months, Years, Until a given date) or
for an unlimited period. To set your files validity for an unlimited period of time, choose Until and leave
the text box below empty.
Files - allows to upload the actual file(s). Only files with allowed extensions can be uploaded. The
extensions can be defined using the Upload extensions setting in Site Manager -> Settings ->
System -> Files.

http://devnet.kentico.com/docs/7_0/devguide/macro_expressions_overview.htm
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Tax classes tab

On this tab you can specify which taxes will apply to the currently edited product option. To add tax
classes, click the Add tax classes button and check the boxes next to the appropriate tax classes in
the displayed selection dialog. Tax classes can be removed from the product option at any time using
the checkboxes next to the listed items, together with the Remove selected button. You can also
remove all listed items at once by clicking the  icon and performing the  Remove all action.

Please note

Unlike product price, product option price can have a negative value. This is because
this price is an amount that is either added to or subtracted from the given product
price.

Please note that volume discounts (and discount coupons) cannot be assigned to a product option.

4.6 Currencies

4.6.1 Overview

Although each on-line store can have precisely one main currency defined (in which your store
administrators enter the prices of all store items, i.e. product prices, shipping charges, discounts, etc.),
the E-commerce solution provides support for multiple currencies.

This means that a customer can make an order in a currency different from the main currency. The order
price is then converted based on the current exchange rates table.

To properly configure currencies in your on-line store, please follow these steps:

1. Enter all currencies you will use and delete or disable those you do not want to use. More details can
be found in the Currencies topic.

2. If applicable, set one of the newly added currencies as the main currency (Configuration -> Store
settings -> General).

3. If you are using multiple currencies, specify the exchange rates (Configuration -> Exchange rates).
More details can be found in the Exchange rates topic.
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4.6.2 Currencies

When configuring the general settings of your on-line store (in Configuration -> Store settings on the
General tab), you can set which currency should be used as the store main currency. This can be done
by clicking the Change button in the Currencies section and choosing the main currency in the
displayed selection dialog.

Managing currencies

Currencies can be managed in CMS Desk -> E-commerce -> Configuration -> Currencies (or in Site
Manager -> Tools -> E-commerce configuration -> Currencies; global currencies only). In this
section of the administration interface, you can see a list of all defined currencies. You can add new
currencies by clicking the  New currency button above the list. Properties of already defined
currencies can be edited by clicking the Edit ( ) icon in the Actions column. You can also delete a
currency by clicking the Delete ( ) icon.

When creating a new currency or editing an existing one, you can specify the following properties:

Display name - the name of the currency displayed to users on the live site and in the
administration interface
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Code name - the name of the currency used by developers in the code.
Currency code - a three-letter code of the currency used globally in banking and business, i.e. the
official code of the currency used in exchange rates.
Currency formatting string - the format used to display amounts in the given currency. Use the {0}
expression to insert the value into the formatting text.
Significant digits - The number of digits in the price that will be used in the total amount. The value
will be rounded if the actual number of decimal digits is higher.
Enabled - Indicates if the currency object can be used in your on-line store. For example, if
checked, the respective currency can be selected from the Currency drop-down list when editing an
order on the Billing tab.

4.6.3 Exchange rates

In this topic you will learn how to manage exchange rates. Kentico CMS allows the user to view prices in
different currencies both in the user interface and on the live site. For this to be possible, one or two
currency conversions are performed, based on the defined exchange rates.

Managing exchange rates

Exchange rates in Kentico CMS are organized into Exchange tables, which specify the complete
exchange rate table for a given period of time. You can thus define a new exchange table e.g. for every
day.

Exchange rates can be managed in CMS Desk -> E-commerce -> Configuration -> Exchange rates
(or in Site Manager -> Tools -> E-commerce configuration -> Exchange rates; global exchange
rates only). In this section of the administration interface, you can see a list of all defined exchange
tables. You can add new exchange tables by clickingby clicking the  New exchange table button
above the list. Properties of already defined exchange tables can be edited by clicking the Edit ( ) icon
in the Actions column. You can also delete a table by clicking the Delete ( ) icon. Please note that
the currently valid exchange table is highlighted in green color.
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When creating a new exchange table or editing an existing one, you can specify the following properties:

Display name - the name of the exchange table displayed to the users of your website.
Valid from - indicates since when the exchange table is valid. You can click the Now link to insert
the current date and time or you can click the  icon to choose the date and time from the calendar.
Please leave the field empty for unlimited validity.
Valid to - indicates till when the exchange table is valid. You can click the Now link to insert the
current date and time or you can click the  icon to choose the date and time from the calendar.
Please leave the field empty for unlimited validity.

Exchange rates:

An exchange rates table is displayed, allowing you to enter the actual exchange rates.

Please note that if global data is allowed on the current site, two tables may be displayed in the 
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Exchange rates section. For further details, please refer to the Site and global configuration chapter in
the Configuring your store section of this guide.

4.7 Tax classes

4.7.1 Overview

Tax classes allow you to configure taxes the customers pay when purchasing in your on-line store. You
can specify different tax classes with different rates for each country or state and then apply the taxes to
particular products and shipping options.

4.7.2 Tax classes

When editing a product (on the Tax classes tab), you can choose tax classes which will apply to this
product when purchased in your on-line store. This can be done by clicking the Add tax classes button
and checking the boxes next to the appropriate tax classes in the displayed selection dialog. Please
note that you can, in like manner, assign tax classes also to shipping options.

Managing tax classes

Tax classes can be managed in CMS Desk -> E-commerce -> Configuration -> Tax classes (or in
Site Manager -> Tools -> E-commerce configuration -> Tax classes; global tax classes only). In
this section of the administration interface, you can see a list of all defined tax classes. You can add
new tax classes by clicking the  New tax class button above the list. Properties of already defined tax
classes can be edited by clicking the Edit ( ) icon in the Actions column. You can also delete a tax
class by clicking the Delete ( ) icon.
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When editing a tax class, the following tabs are available to specify its properties:

General tab
Countries tab
States tab

General tab

On this tab you can edit general properties of the selected tax class.

Display name - the name of the tax class displayed to users on the live site and in the
administration interface.
Code name - the name of the tax class used by developers in the code.
Zero tax if Tax ID is supplied - indicates if the tax should be calculated as zero (0) if the customer
enters a Tax ID.

Countries tab

On this tab you can set the value of the currently edited tax for a particular country; please note that the
country recognition is based on the Apply taxes based on setting. The value can be either a
percentage of the product price (by default) or a flat amount. If the tax is specified for both a country and
a state, only the tax specified for a state is applied.
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States tab

On this tab you can set the value of the currently edited tax for a particular state; please note that the
country recognition is also based on the Apply taxes based on setting. The value can be either a
percentage of the product price (by default) or a flat amount. If the tax is specified for both a country and
a state, only the tax specified for a state is applied.

4.8 Discounts

4.8.1 Overview

With the E-commerce solution you can offer your on-line store customers various discounts and thus
more effectively boost your sales. There are many purposes for discounting, including e.g. to increase
short-term sales, to move out-of-date stock or to reward valuable clients, etc.

Discount coupons represent virtual vouchers that can be exchanged for a financial discount or rebate
when purchasing a particular product offered in your on-line store.

Discount levels allow you to benefit any registered customer making a purchase in your store. For
example, you can assign all Gold Partners a 30% discount on any product they purchase on your
website.
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Volume discounts are applied when your customers purchase specified amounts of selected products.
The discounts are automatically calculated and applied during the checkout process when the user adds
the specified amount of the product items to their shopping cart. Multiple volume discount levels can be
specified, allowing you to apply different discounts for different amounts of purchased items.

4.8.2 Discount coupons

Discount coupons are virtual vouchers that your on-line store customers can exchange for financial
discounts or rebates when purchasing selected products.

When creating a new order or editing an existing one (on the Items tab), you can enter a discount
coupon code and try to apply the given discount.

Managing discount coupons

Discount coupons can be managed in CMS Desk -> E-commerce -> Discount coupons. In this
section of the administration interface, you can see a list of all defined discount coupons. You can add
new discount coupons by clicking the  New discount coupon button above the list. Properties of
already defined discount coupons can be edited by clicking the Edit ( ) icon in the Actions column.
You can also delete a discount coupon by clicking the Delete ( ) icon.
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When editing a discount coupon, the following tabs are available to specify its properties:

General tab
Products tab

General tab

On this tab you can edit general properties of the selected discount coupon.

Display name - the name of the discount coupon displayed to the users of your website
Coupon code - the code of the coupon that will be used by the user during the purchase.
Absolute discount / Relative discount - you can choose between an absolute and relative discount
and you can enter the discount value in the box below.
Discount value - you can choose between an absolute and relative discount and you can enter the
discount value in the box below. 
Valid from - indicates since when the discount coupon is valid. You can click the Now link to insert
the current date and time or you can click the  icon to choose the date and time from the calendar.
Please leave the field empty for unlimited validity.
Valid to - indicates till when the discount coupon is valid. You can click the Now link to insert the
current date and time or you can click the  icon to choose the date and time from the calendar.
Please leave the field empty for unlimited validity.
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Products tab

On this tab you can specify which products the discount coupon should be applied to or not applied to
by using the Only the following products and All products expect for these radio buttons. To add
products to the list, click the Add products button and check the boxes next to the appropriate items in
the displayed selection dialog. Product items can be removed from the list at any time using the
corresponding checkboxes together with the Remove selected button. You can also remove all listed
items at once by clicking the  icon and performing the  Remove all action.

4.8.3 Discount levels

Discount levels represent a type of discount that you can offer to your registered customers. For
example, you can assign all Gold Partners a 30% discount on any product they purchase in your on-line
store.

When editing a registered customer (on the General tab in the Registered user info -> Discounts
section), you can assign them a discount level for the current site (if defined). Please note that if global
discount levels are allowed for the current site, two drop-down lists are available in the section, allowing
you to assign the customer both a global and site-specific discount level (if defined).
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Managing discount levels

Discount levels can be managed in CMS Desk -> E-commerce -> Discount levels. In this section of
the administration interface, you can see a list of all defined discount levels. You can add new discount
levels by clicking  New discount level button above the list. Properties of already defined discount
levels can be edited by clicking the Edit ( ) icon in the Actions column. You can also delete a discount
level by clicking the Delete ( ) icon.
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When editing a discount level, the following tabs are available to specify its properties:

General tab
Departments tab

General tab

On this tab you can edit general properties of the selected discount level.

Display name - the name of the discount level displayed to users on the live site and in the
administration interface.
Code name - the name of the discount level used by developers in the code.
Value - allows you to enter the percentage value of the discount.
Valid from - indicates since when the discount level is valid. You can click the Now link to insert the
current date and time or you can click the  icon to choose the date and time from the calendar.
Please leave the field empty for unlimited validity.
Valid to - indicates till when the discount level is valid. You can click the Now link to insert the
current date and time or you can click the  icon to choose the date and time from the calendar.
Please leave the field empty for unlimited validity.
Enabled - indicates if the discount level object can be used in your on-line store. For example, if
checked, the respective discount level can be selected from the Discount level on this site drop-down
list when editing a registered customer on the General tab.
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Departments tab

On this tab you can specify departments which the discount level should cover. This results in the
discount being applied to the products from these departments. To add departments to the list, click the 
Add departments button and check the boxes next to the appropriate items in the displayed selection
dialog. Department items can be removed from the list at any time using the corresponding checkboxes
together with the Remove selected button. You can also remove all listed items at once by clicking
the  icon and performing the  Remove all action.

4.8.4 Volume discounts

Volume discounts are applied when your customers purchase specified amounts of selected products.

When creating a new order or editing an existing one (on the Items tab), the order price is automatically
reduced by the discount amount if a sufficient number of applicable product items (the volume) has been
entered.
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Managing volume discounts

Volume discounts can be managed when editing a selected product on the Volume discounts tab. In
this section of the administration interface, you can see a list of all defined volume discounts for the
current product. You can add a new volume discount by clicking the  New volume discount button
above the list. Properties of already defined volume discounts can be edited by clicking the Edit ( ) icon
in the Actions column. You can also delete a volume discount by clicking the Delete ( ) icon.

When creating a new volume discount or editing an existing one, you can specify the following
properties:

Minimum amount - sets the minimum amount of ordered items to which the current volume
discount applies.
Discount value - here you can specify a discount for the given volume (as set in the Minimum
amount property). You can choose to apply either a relative or absolute discount using the respective
radio buttons.
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4.9 Customers

4.9.1 Overview

In Kentico CMS, the products offered in your on-line store can be purchased by both anonymous and
registered users, in the E-commerce solution commonly referred to as customers. The anonymous
customers make a lump-sum purchase whereas the registered ones can purchase in your store
repeatedly using the same login details.

Please note that a customer profile can be created either manually using the CMS Desk -> E-
commerce -> Customers administration interface or automatically during the purchase process.

4.9.2 Customers

When making a new order you can either select an existing customer or create a new one. Please note
that if you decide for the latter option, the form contains the same customer properties as if opened
directly from the Customers section.

http://devnet.kentico.com/docs/7_0/devguide/User_management.htm
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Managing customers

Customers can be managed in CMS Desk -> E-commerce -> Customers. In this section of the
administration interface, you can see a list of all defined customers. New ones can be added to the list
by clicking the  New customer button above the list. Properties of already defined customers can be
edited by clicking the Edit ( ) icon in the Actions column. You can also delete a customer by clicking
the Delete ( ) icon.

When editing a customer, the following tabs are available to specify its properties:

General tab
Custom fields tab
Addresses tab
Orders tab
Credit tab
Newsletters tab

General tab

On this tab you can edit general properties of the selected customer.

General info:

First name - sets the customer's first name.
Last name - sets the customer's last name.
Company - can be used to enter the name of the customer's company.
Organization ID - allows you to enter a registration ID of the customer's company.
Tax registration ID - allows you to enter a tax registration ID of the customer's company.
Country/state - here you can select the customer's country. If the country has any states, another
drop-down list is displayed allowing you to select a state.

Contacts:

E-mail - can be used to enter the customer's e-mail address.
Phone - here you can enter the customer's phone number.
Fax - here you can enter the customer's fax number.

Registered user info:
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Create a login for this site - allows you to register the customer on the current website. Unless
checked, other fields in this section are hidden.
User name - sets the user name that they will use to log in to the current website.
Password - sets the password that the customer will use to log in to the current website. The
Password strength indicator below the field informs you about the strength of the entered password.
Confirm password - allows you to confirm the entered password.

The following properties can be set in the Registered user info section of already registered customers:

Login:
User name - the customer's user name that the customer uses to log in to the current website. Click
the Edit button to edit properties of the registered user.
Enabled - if checked, the customer is enabled for shopping, i.e. they are allowed to purchase on the
current website.

Preferred settings on this site:
Preferred currency - can be used to enter the currency in which the prices are displayed when the
customer signs in to the current website (it is set automatically based on the customer's last
purchase).
Preferred payment method - here you can enter a payment method to be used when the customer
makes a purchase on the current website (it is set automatically based on the customer's last
purchase). A default value which may be changed as needed during the purchase process.
Preferred shipping option - here you can enter a shipping option to be used when the customer
makes a purchase on the current website (it is set automatically based on the customer's last
purchase). A default value which may be changed as needed during the purchase process.

Discounts:
Global discount level - specifies a global discount level applied to the customer's orders on the
current website (if available). Please note that unless global discount levels are allowed on the site,
the drop-down list is hidden.
Discount level on this site - specifies a site-specific discount level applied to the customer's orders
on the current website (if available).
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Custom fields tab

On this tab you can edit custom fields that you added in Site Manager -> Development -> System
tables -> Edit ( ) the Ecommerce - Customer table. If no such fields were added, the tab is hidden.

Addresses tab

Each customer can have multiple addresses for billing and shipping stored in their profile. On this tab
you can see a list of all available addresses of the current customer. You can add a new address by
clicking the  New address button, Edit ( ) or Delete ( ) an existing item in the list and you can
also  Clone an address if you click the  Other actions icon on the selected address line.
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The following properties are available when creating or editing a customer address object:

Personal or company name - here you can enter a name to be used in the customer's current
address. The name can be either a personal name or a company name.
Address lines - here you can enter lines of the address, e.g. a house number and street name.
City - allows you to enter the city name.
ZIP code - here you can enter the ZIP code of the city.
Country - allows you to select a country to be used in the customer's current address. If the country
has any states, another drop-down list is displayed.
Phone number - can be used to enter a phone number.
Enabled - indicates if the address should be offered in the CMS system. If you disable the address
(i.e. uncheck this checkbox), it will no longer be displayed, but it will be kept in the database for your
records and to keep the customer's purchase history.
Use as shipping address - indicates if the address should be offered to the customer as a shipping
address.
Use as billing address - indicates if the address should be offered to the customer as a billing
address.
Use as company address - indicates if the address should be offered to the customer as a
company address.
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Orders tab

On this tab you can see a list of orders made by the current customer in your on-line store. You can add
a new order by clicking the  New order button and Edit ( ) or Delete ( ) an existing item in the list.
You can also move the orders to the Next ( ) or Previous status ( ).

Please note that the listed orders can be filtered using the text boxes above the list.

Credit tab

On this tab you can see the total credit of a registered customer, along with a list of credit events during
which this credit has been accumulated. Credit can be both added to and deducted from the total credit.
However, only positive value credit can be used to pay for the purchased products.

You can add a new credit event by clicking the  New credit event button and Edit ( ) or Delete ( )
an existing item in the list.
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The following properties are available when creating or editing a customer credit object:

Event name - here you can enter the name of the credit event.
Event credit change - specifies a credit amount (in the main currency) by which the total credit
amount should be changed. Please note that you can add a negative value if you want to decrease
the customer's credit.
Event date - specifies the date when the credit event occurs.
Event description - can be used to enter a text description for the credit event in order to give further
information.

Please note that for anonymous customers the tab is hidden.

Newsletters tab

On this tab you can specify which newsletters the current customer is subscribed to receive. To add
newsletters, click the Add newsletters button and check the boxes next to the appropriate newsletters
in the displayed selection dialog. Newsletters can be removed from the list at any time using the
checkboxes together with the Remove selected button. You can also remove all listed items at once
by clicking the  icon and performing the  Remove all action.

http://devnet.kentico.com/docs/7_0/devguide/newsletter_module_overview.htm
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4.10 Orders

4.10.1 Overview

Orders of the products that you offer in your on-line store can be made by both registered and
anonymous customers. Various discounts such as discount coupons, volume discount and discount
levels may be applied to further motivate the purchasers and thus boost your sales. The purchase
process is fully customizable, allowing you to define your own checkout steps. Besides, the life cycle of
the order can be tracked by means of customizable order statuses.

You can also define multiple shipping options and payment methods to make the purchase process
smoother and easier.

4.10.2 Orders

Orders made in your on-line store can be managed in CMS Desk -> E-commerce -> Orders. In this
section of the administration interface, you can see a list of all orders made in your on-line store. You
can add a new order by clicking the  New order button and Edit ( ) or Delete ( ) an existing item
in the list. You can also move the orders to the Next ( ) or Previous status ( ).

The listed orders can be filtered using the text boxes above the list.

When editing an order, the following tabs are available to specify its properties:

General tab
Custom fields tab
Shipping tab
Billing tab
Items tab
Invoice tab
History tab

General tab
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On this tab you can edit general properties of the selected order.

Order ID - displays the ID of the current order.
Date - indicates the date of the order. You can enter the value manually, use the Calendar ( ) or use
the Now link.
Invoice number - specifies the invoice number. The number is generated automatically and can be
changed on the Invoice tab.
Status - allows you to specify order status.
Customer - allows you to enter the name of the customer. You can edit customer properties by
clicking the Edit button (the Customer properties dialog will be displayed).
Company address - allows you to enter the address of the company. You can select an address
from the drop-down list (if available), edit the selected one or add a new address.
Order note - can be used to add some notes about the order.

Custom fields tab

On this tab you can edit custom fields that you added in Site Manager -> Development -> System
tables -> Edit ( ) the Ecommerce - Order table. If no such fields were added, the tab is hidden.

Shipping tab

On this tab you can edit the shipping-related properties of the currently edited order.

Shipping option - allows you to change the shipping option of this order. If no item in the shopping
cart needs shipping, the field contains the (none) value by default.
Shipping address - allows you to change the shipping address of this order. You can also edit an
existing address or add a new one. If no item in the shopping cart needs shipping, the field contains
the (none) value by default.
Tracking number - can be used to enter a number or any combination of signs according to which
the order will be tracked, e.g. a packaging code.
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Billing tab

On this tab you can edit the billing-related properties of the currently edited order.

Payment method - here you can change the payment method used for the current order. If the
shopping cart does not contain any items that need shipping, only payment methods with the Allow if
no shipping is supplied setting enabled are offered.
Currency - can be used to change the currency in which the order is calculated.
Billing address - allows you to change the billing address of this order. You can also edit an
existing billing address or add a new one.
Payment result - indicates the result of the payment performed via a payment gateway.
Order is paid - can be used to manually mark the order as paid, e.g. if an issue occurs while
completing the payment. By default, the system automatically marks the order as paid when it
receives the given order status.

Items tab

On this tab you can see a list of all ordered items, the total price and other order details. New items can
be added by clicking  Add item. This opens a new dialog allowing you to choose an order item, its
quantity and, if defined, item options. The tab also allows to enter a discount coupon code if available.

By clicking the Empty button the listed items can be removed from the shopping cart all at once.
Besides, you can remove only selected items if you check the boxes next to the respective items and
click the Update button. By clicking the  icon you can view the product price details.

You can Edit ( ) product properties and you can also Edit ( ) order item properties but only if the
current order is not marked as paid. However, this editing is enabled only if the web.config file
contained in your web project folder is properly configured (i.e. the CMSEnableOrderItemEditing key is
set to TRUE and the CMSUseCurrentSKUData key is set to FALSE) as described in detail in the
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Web.config settings topic in the Configuring your store -> Settings section of the E-commerce Guide.

Please note that if you mark the Send order changes by e-mail checkbox, a notification about the
changes in the order will be sent to specified e-mail addresses (typically to the customer and to the
merchant).

Invoice tab

On this tab you can see a preview of the invoice. You can change the invoice number and you can also
generate or print the invoice.
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History tab

On this tab you can see a list of order changes (i.e. basically order status changes).

4.10.3 Order statuses

An order status gives you the stage of your customer's order; i.e. it represents what has been happening
with the order since the customer placed it. For example, the In progress status would mean that some
steps of the purchase process have not yet been completed.
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When editing an existing order (on the General tab), you can change its status using the Status drop-
down list as highlighted in the screenshot below.

Managing order statuses

Order statuses can be defined in CMS Desk -> E- commerce -> Configuration -> Order status (or in
Site Manager -> Tools -> E-commerce configuration -> Order status; global order statuses only). In
this section of the administration interface, you can see a list of all defined order statuses. You can add
new order statuses by clicking the  New order status button above the list. Properties of already
defined order statuses can be edited by clicking the Edit ( ) icon in the Actions column. You can also
delete an order status by clicking the Delete ( ) icon.
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When creating a new order status or editing an existing one, you can specify the following properties:

Display name - the name of the order status displayed to users on the live site and in the
administration interface.
Code name - the name of the order status used by developers in the code.
Order status color - here you can set the color which will be used to highlight orders having the
given status, e.g. when viewing orders in CMS Desk -> E-commerce -> Orders. Alternatively, you can
set the color using the color picker by clicking the  icon.
Send notification - indicates if an e-mail notification should be sent to the customer and to an e-
mail address specified in the Send e-commerce emails to setting in CMS Desk -> E-commerce ->
Store settings on the E-mails tab (or in Site Manager in the respective sections) if an order receives
the current status. Typically, this e-mail address is the merchant's. Please note that the E-
commerce order status notification to customer e-mail template is used when sending notifications to
customers and the E-commerce order status notification to administrator e-mail template is used
when sending notifications to merchants (administrators).
Enabled - indicates if the order status object can be used in your on-line store. For example, if
checked, the respective order status can be selected from the Status drop-down list when editing an
order on the General tab.
Mark order as paid - indicates if the system should automatically mark the order as paid when it
receives the given status.

Please note

Editing orders marked as paid is limited. Specifically, you cannot change any value
which could influence order price calculation.
However, orders not marked as paid can be edited without limitation.

4.10.4 Shipping options

For each product, it is possible to specify whether shipping is required. For example, media files or e-
books that the customer downloads from your site after purchase do not require any shipping. On the
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other hand, other products such as clothing, footwear, food, electronics, etc. need to be supplied to the
customer using a delivery service. Shipping options thus represent the actual services used to deliver the
product to the customer.

When creating a new product or editing an existing one (on the General tab), you can specify whether
shipping is needed using the Needs shipping check box, as highlighted in the following screenshot.

When creating a new order or editing an existing one, you can select which shipping option will be used
for delivery provided that at least one product with the Needs shipping property enabled can be found in
the shopping cart.

Managing shipping options
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Shipping options can be managed in CMS Desk -> E-commerce -> Configuration on the Shipping
options tab. In this section of the administration interface, you can see a list of all defined shipping
options. New ones can be added to the list by clicking the  New shipping option button above the
list. Properties of already defined shipping options can be edited by clicking the Edit ( ) icon in the
Actions column. You can also delete a shipping option by clicking the Delete ( ) icon.

When editing a shipping option, the following tabs are available to specify its properties:

General tab
Payment methods tab
Shipping costs tab
Tax classes tab

General tab

On this tab you can edit general properties of the selected shipping option. Click OK to save the
changes.

Display name - the name of the shipping option displayed to users on the live site and in the
administration interface.
Code name - the name of the shipping option used by developers in the code.
Charge - sets the cost charged for the shipping option (in the main currency). If flat rate shipping is
used, the cost is charged for all shipping. If shipping based on weight is used, the cost is charged for
the lowest weight range.
Description - can be used to enter a text description for the shipping option in order to give further
information.
Teaser image - can be used to add a teaser image to the shipping option. However, other types of
files such as documents and audio and video files can also be uploaded.
Enabled - indicates if the shipping option object can be used in your on-line store. For example, if
checked, the respective shipping option can be selected from the Shipping option drop-down list
when editing an order on its Shipping tab.
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Payment methods tab

On this tab you can specify which payment methods will be available for the given shipping option. To
add payment methods, click the Add payments button and check the boxes next to the appropriate
payment methods in the displayed selection dialog. Payment methods can be removed from the
shipping option at any time using the checkboxes in the list together with the Remove selected button.

Shipping costs tab

On the Shipping costs tab, you can define shipping costs for the given shipping option. Two types of
shipping are available. If Shipping based on weight is used, multiple shipping costs are charged for
the shipping based on the specified weight ranges. If Flat rate shipping is applied, the same cost is
charged for all shipping.

Shipping based on weight

Multiple shipping costs are defined and the cost is charged for a particular weight range. Please note
that the cost of the lowest weight range is specified in the Charge property on the General tab.

Using this approach, you can see a list of all defined shipping costs for the selected shipping option.
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These can be edited by clicking the Edit ( ) icon in the Actions column and you can also delete a
shipping cost by clicking the Delete ( ) icon.

New shipping costs can be added by clicking the  New shipping cost button above the list and
entering the following properties: 

Minimal weight - specifies the lower limit of the weight range for which the current shipping cost is
charged. The upper limit of the weight range is made up by minimal weight of the next weight range (if
defined).
Shipping cost - sets the shipping cost charged for the current weight range.

Flat rate shipping

The same cost is charged for all shipping regardless of the shipping weight, as specified in the Charge
property on the General tab. No shipping costs are listed.

Tax classes tab
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On this tab you can specify which taxes will be applied to the given shipping option. To add tax classes,
click the Add tax class button and check the boxes next to the appropriate tax classes in the displayed
selection dialog. Tax classes can be removed from the shipping option at any time using the
checkboxes in the list together with the Remove selected button.

4.10.5 Payment methods

For each shipping option, it is possible to specify multiple payment methods. You can thus let your on-
line store customers pay cash on delivery or choose one of the available payment systems to pay for the
purchased products. These systems may include traditional mail orders and card payments, currently
widespread online payments using payment gateways or more alternative approaches such as secure
order forms, etc.

When creating a new order or editing an existing one on the Billing tab, you can choose a payment
method based on the shipping option (selected on the Shipping tab), as highlighted in the screenshot
below.

Managing payment methods

Payment methods can be managed in CMS Desk -> E-commerce -> Configuration on the Payment
methods tab. In this section of the administration interface, you can see a list of all defined payment
methods. New ones can be added to the list by clicking the  New payment method button above the
list. Properties of already defined payment methods can be edited by clicking the Edit ( ) icon in the
Actions column. You can also delete a payment method by clicking the Delete ( ) icon.
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When creating a new payment method or editing an existing one, you can specify the following
properties:

Display name - the name of the payment method displayed to users on the live site and in the
administration interface.
Code name - the name of the payment method used by developers in the code. 
Description - can be used to enter a text description for the payment method in order to give further
information.
Teaser image - allows to add a teaser image, which will be displayed to users on the live site.
However, other types of files such as documents and audio and video files can also be uploaded.
Allow if no shipping is supplied - indicates whether the payment method should be allowed if no
shipping is supplied. If checked, the payment method is offered while no shipping is available during
the purchase process (e.g. if no product with the Needs shipping flag is found in the shopping cart).
Enabled - indicates if the payment method object can be used in your on-line store. For example, if
checked, the respective payment method can be selected from the Payment method drop-down list
when editing an order on its Billing tab.

Payment gateway settings

The following properties need to be entered only if the given payment method represents a payment
gateway.

Payment gateway URL - the URL of the payment gateway. It can be parametrized by macros,
e.g.: http://mycustompaymentgateway.com?currency={%Currency.CurrencyCode%}&total={%
RoundedTotalPrice%}.
Payment gateway assembly name - the name of the assembly (dll) where the payment provider is
stored.
Payment gateway class name - the name of the corresponding class that represents the payment
provider.
Order status if payment succeeds - can be used to assign order status after a successful payment
has been made. Please use the drop-down list to select an appropriate order status.
Order status if payment fails - can be used to assign order status after the payment has failed.
Please use the drop-down list to select an appropriate order status.
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4.11 Reports

4.11.1 Overview

Kentico CMS offers multiple interactive reports related to the E-commerce solution. All the major store
sections, i.e. sales, orders, products, customers and donations, are covered. The information is
gathered during your on-line store life cycle as individual events occur (e.g. the customer makes an order
or adds a product to a wishlist) and is stored in the database. If you select a report from the reports tree,
you can view its details. Depending on the selected report, a graph, table or a combination of these may
be displayed, sometimes along with additional report information (e.g. various report values).

The reports may be filtered based on their type and any report can be  Saved or  Printed. You can
also subscribe to a report by clicking the  Subscribe button.

The dashboard page allows you to personalize and view various e-commerce reports on a single page.
Besides, you can use the sample data generator and generate e-commerce sample data to try out e-
commerce reports without the need to enter your real data. 

Please note that you can configure your on-line store reports in CMS Desk -> Tools -> Reporting if you
have the corresponding permissions. More details can be found in the Membership, permissions and
security -> Permissions chapter in the Development section of the Developer's Guide.

http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
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4.11.2 Dashboard

The Reports dashboard allows you to use dedicated widgets to view various e-commerce reports. You
can configure and place these widgets on your dashboard page.

4.11.3 Sales

The Sales section allows you to view reports related to sales made in your on-line store.

http://devnet.kentico.com/docs/7_0/devguide/Widgets_overview.htm
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4.11.4 Orders

The Orders section allows you to view reports related to orders made in your on-line store.
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4.11.5 Products

The Products section allows you to view reports related to products offered in your on-line store.
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4.11.6 Customers

The Customers section allows you to view reports related to customers of your on-line store.

4.11.7 Donations

The Donations section allows you to view reports related to donations made in your on-line store.
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4.11.8 Sample data generator

The E-commerce solution sample data generator allows you to generate sample customers and orders.
You can use this data to become familiar with e-commerce reports.

Click Generate to generate your sample data or click Delete to remove your sample data (if any) from
the CMS system.

Other e-commerce data, e.g. products, is not generated by the sample data generator, but is used from
the current site (if available). Please note that such data is not affected by the generator.
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5 Security

5.1 Overview

This chapter describes security of the E-commerce solution:

To learn what security settings are available in your on-line store to define access and configuration
rights for users of your website, please refer to the Permissions topic.
To learn what needs to be set for a user to be able to manage products from a specific department,
please refer to the Department administrators topic.
To learn how to personalize your user interface of the E-commerce solution, please refer to the UI
personalization topic.
To see UI personalization and permissions sample settings for the E-commerce solution, please refer
to the E-commerce sample roles topic.

5.2 Permissions

To prevent users from accessing and modifying certain on-line store data and from configuring the on-line
store,  you will  need to assign E-commerce solution permissions.  This  procedure  is  described  in  more
detail in the Membership, permissions and security  -> Permissions chapter in the Development  section
of the Developer's Guide.

The E-commerce solution has the following permissions:

Read  data  -  allows  to  access  Orders,  Reports,  Customers,  Products,  Product  options,  Discount
coupons, Discount levels, Manufacturers and Suppliers.

http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
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Modify data - allows to create, modify and delete data; see Read data.
Modify global data - allows to create,  modify  and delete global Customers,  global Products,  global
Product  options,  global Discount  coupons,  global  Discount  levels,  global  Manufacturers  and  global
Suppliers.
Read configuration - allows to access E-commerce solution configuration (Store settings,
Departments, Shipping options, Payment methods, Tax classes, Currencies, Exchange rates, Order
status, Public status, Internal status, Invoice).
Modify configuration - allows to modify E-commerce solution configuration; see Read configuration.
Modify global configuration - allows to modify E-commerce solution global configuration.
Read orders - allows to access Orders.
Modify orders - allows to create, modify and delete Orders.
Read reports - allows to access Reports.
Read customers - allows to access Customers.
Modify customers - allows to create, modify and delete Customers.
Access all departments - allows to access Products from all departments.
Read products - allows to access Products and Product options.
Modify products - allows to create, modify and delete Products and Product options.
Read discounts - allows to access Discount coupons.
Modify discounts - allows to create, modify and delete Discount coupons.
Read manufacturers - allows to access Manufacturers.
Modify manufacturers - allows to create, modify and delete Manufacturers.
Read suppliers - allows to access Suppliers.
Modify suppliers - allows to create, modify and delete Suppliers.
Destroy - allows to destroy E-commerce solution object version history.

Example

To allow members of a particular role to edit e.g. a site-bound Manufacturer, you will need to assign this
role permissions in one of the following combinations:

Read data + Modify data
Read data + Modify manufacturers
Read manufacturers + Modify data
Read manufacturers + Modify manufacturers

Similarly, to edit e.g. a global Customer, you will need to assign permissions in one of the following
combinations:

Read data + Modify global data
Read customers + Modify global data

This can be configured in the E-commerce permissions matrix in Site Manager -> Administration ->
Permissions, as described in detail in the Permissions chapter in the Development -> Membership,
permissions and security section of the Developer's Guide.

Product permissions

Permissions described in this topic relate to E-commerce objects only. If you need to restrict access to
modifications of a product, you thus need to distinguish between:

Product as Stand-alone SKU

http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
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The respective above-described permissions apply fully, i.e. you do not need any other permissions.

Product as SKU + document

In such case, you will need both respective E-commerce solution permissions and document-related
ones. These are described in detail in the Permissions -> Document permissions chapter in the
Development -> Membership, permissions and security section of the Developer's Guide.

5.3 UI personalization

UI personalization enables you to provide certain users with customized user interface. You can hide
any E-commerce solution UI item represented by the corresponding UI element and you can also create
your custom UI elements. To learn how to do this, please refer to the Membership, permissions and
security -> UI personalization chapter in the Development section of the Developer's Guide.

Here follows a survey of E-commerce UI elements and the real UI which these elements represent.

E-commerce toolbar

The E-commerce solution offers ample possibilities for UI personalization. As you can see in the
screenshot below, it is divided into six categories: Dashboard, Orders, Products, Discounts, Reports
and Configuration.

These categories together with items they contain are represented by the first- and second-level E-
commerce solution UI elements as highlighted below.

http://devnet.kentico.com/docs/7_0/devguide/Document_permissions.htm
http://devnet.kentico.com/docs/7_0/devguide/UI_personalization_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/UI_personalization_overview.htm
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Please note

It is recommended not to move any UI elements that come with the installation. The
reason is to ensure the possibility of a correct security check in the real UI.

You can adjust the size of the icon in the ribbon. This can be done in Site Manager -> Development -
> Modules -> Edit ( ) E-commerce on the User interface -> General tab of the corresponding UI
element. More details can be found in the UI personalization -> UI elements management chapter in the
same section of the Developer's Guide.

Dashboard

The Dashboard category provides access to your E-commerce dashboard.

http://devnet.kentico.com/docs/7_0/devguide/ui_elements_management.htm
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Orders

The Orders category provides information about orders and customers.

Orders

These tabs contain information about your order. Please note that the Custom fields tab is visible only if
you added your custom fields via Site Manager -> Development -> System tables.

Customers

These tabs contain information about your customer. Please note that the Custom fields tab is visible
only if you added your custom fields via Site Manager -> Development -> System tables.

Products

The Products category provides information about products, product options, manufacturers and
suppliers.
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Products

These tabs contain information about your product.

Please note that if you are editing a site-specific stand-alone SKU, all document-related tabs are hidden
by default.

Product options

These tabs contain information about your product option.
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These tabs contain your product option details.

Discounts

The Discounts category provides information about discount coupons and discount levels.

Discount coupons

These tabs contain information about your discount coupon.

Discount levels

These tabs contain information about your discount level.
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Reports

The Reports category provides E-commerce reports.

The reports tree items provide categorized reporting related to your on-line store.

Configuration

The Configuration category provides access to configuration-related features of your on-line store.
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The Configuration menu items enable you to configure your E-commerce solution features.



Kentico CMS 7.0 E-commerce Guide182

© 2014 Kentico Software

Store settings

These tabs contain information about your on-line store settings.

Departments

These tabs contain information about your department.

Shipping options
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These tabs contain information about your shipping option.

Tax classes

These tabs contain information about your tax class.

5.4 E-commerce sample roles

After installing the sample E-commerce site, you can see UI personalization and Permissions sample
settings for your E-commerce solution. For this purpose, the following sample roles are pre-configured
on the site: CMS E-commerce Account Managers, CMS E-commerce Administrators and CMS E-
commerce Editors. Please note that these roles are not available on other Kentico CMS sample sites.

These roles can be edited in Site Manager -> Administration -> Roles. More details can be found in
the Membership, permissions and security -> Role management topic in the Development section of the
Developer's Guide.

Please note

These roles serve only as inspiration for security settings of your on-line store
administration. You can create and configure your own roles for your on-line store. 

http://devnet.kentico.com/docs/7_0/devguide/role_management.htm
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CMS E-commerce Account Managers

Members of this role can access the following features, based on the role UI profile settings as
described in detail in the UI personalization topic:

Based on the role permissions settings, members of this role have full access to Orders, Customers,
Manufacturers and Suppliers and they can also view Reports. However, Products and Product options
they can only read:

Please note
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To try this role out, please log in as the role default user, i.e. E-commerce Account
Manager, with ECAccountManager user name and blank password.

CMS E-commerce Administrators

Members of this role can access the following features, based on the role UI profile settings as
described in detail in the UI personalization topic:

Based on the role permissions settings, members of this role have full access within the E-commerce
solution. However, they cannot modify global data or global configuration:
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Please note

To try this role out, please log in as the role default user, i.e. E-commerce Admin, with
ECAdmin user name and blank password.

CMS E-commerce Editors

Members of this role can access the following features in CMS Desk -> E-commerce, based on the role
UI profile settings as described in detail in the UI personalization topic:

Based on the role permissions settings, members of the CMS E-commerce Editors role have full access
to Products, Product options, Discount coupons and Discount levels. However, Manufacturers and
Suppliers they can only read:
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Please note

To try this role out, please log in as the role default user, i.e. E-commerce Editor, with
ECEditor user name and blank password.

5.5 Department administrators

Here you will learn how to assign certain users, i.e. your department administrators, to departments
containing products for which they are responsible. This will prevent them from accidentally modifying
other products.

To allow a user to manage products in given departments, you need to:

1. Assign the role whose member the user is appropriate E-commerce solution permissions.
Specifically, you need to assign the Read and Modify permissions for products or data. The user will
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thus be able to access and manage products. If you have not assigned these permissions yet and
need further advice, please refer to the Permissions topic for more details.

2. Assign the user to departments the products of which they should manage OR assign the role whose
member the given user is the Access all departments permission; see note below.

Please note

If you need to allow certain department administrators to access products from all
departments regardless of the departments to which they are assigned, please set the 
Access all departments permission for role(s) whose members these administrators
are.



Part

VI

Building your on-line store
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6 Building your on-line store

6.1 Overview

This chapter will help you build your on-line store. Before you launch the store, we recommend that you
go through the following steps:

Getting familiar with the CMS system
Personalizing your store
Configuring your store
Adding your product types (optional)
Further personalizing your store (optional)
Modifying the design of your website (optional)
Performing advanced configuration (optional)

6.2 Getting started

Here you will learn how to install your E-commerce starter site, and what the user interface of the E-
commerce solution looks like.

Installing E-commerce starter site

For detailed, step-by-step instructions on how to install your E-commerce starter site, please refer to
the Installing the sample E-commerce site topic. Once the installation is finished, navigate to Site
Manager -> Sites and make sure the site is running in your CMS system (this can be done by clicking
the Start site ( ) icon on the respective line).

E-commerce user interface

You can access the E-commerce user interface in CMS Desk -> E-commerce. The more frequently
used E-commerce features (e.g. Products, Customers, etc.) are available from the ribbon and others can
be accessed after clicking the  Configuration button in the Configuration section of the ribbon. You
can find a more detailed description of the E-commerce user interface in the E-commerce user interface
topic.
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6.3 Personalizing your store

6.3.1 Overview

This chapter will help you customize your on-line store to best suit your needs.

In the initial section you will learn how website content is organized in Kentico CMS, how you can
manage pages that build up your store and how to deal with web parts, i.e. web page components that
provide a combination of content and functionality. Then you will continue with required and optional
personalization of your store, such as changing the store logo or managing text, various lists, etc.,
which you need to present to your customers.

A separate section is dedicated to personalizing products, i.e. the most important entities in your on-line
store.

Further personalization and customization of your on-line store is described in the Further personalizing
your store chapter.
To learn how to modify design of your on-line store, please refer to the Modifying design chapter.

6.3.2 Content management basics

6.3.2.1 Organizing content

All content in Kentico CMS is stored in a tree hierarchy, which has many advantages. For example, the
pages are organized in a logical structure that represents a (dynamic) site map ensuring easy-to-
navigate information architecture, permissions (and other types of settings) can be defined for a
particular site section, etc.

You can see the content tree in CMS Desk -> Content.

http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
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Besides, you can see the product sections tree in CMS Desk -> E-commerce -> Products, which
allows you to view the structure (and content) of the Products section.

The following picture shows how the content tree (and product sections tree) defines the structure and
navigation on the live website.
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Pages and documents

All items in the content tree are, in fact, documents. However, there is a special type of documents
called pages. Pages (such as /Home, /Products, /Help, etc.) display the content and they are displayed
as menu items by default (you can customize this behavior).

Unlike pages, structured documents (e.g. news items under the /News section or products under the /
Products section) contain structured data that can be displayed on the pages.

While pages usually contain unstructured content in the form of editable regions that can be edited on
the Page tab, structured documents contain structured data stored in document type-specific database
tables and can be edited on the Form tab.

Files

There are two types of files you need to manage on the website:

Website design files - images and flash files that are part of the website's design, such as logo,
background or menu images, etc. These should be stored in the file system as part of the application
theme.
Media files and document files - images, flash movies, word documents, PDFs, etc. that are
published on the live website and are part of the content editable by editors. These should be
uploaded to the content tree as documents so that content editors can manage them and so that
you can apply all content-related features (permissions, workflow and versioning, multilingual support)
to the files as well.

To learn more about how content is organized in Kentico CMS, please refer to the Content management
section of the Developer's Guide.

http://devnet.kentico.com/docs/7_0/devguide/workflow_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/multilingual_content_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/content_management_overview.htm
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6.3.2.2 Managing documents

Your website's pages can be managed through a browser-based, WYSIWYG user interface. Please note
that content editors need to have the appropriate permissions assigned and must first authenticate
themselves by signing in with a user name and password. Specifically, you can manage the content in 
CMS Desk -> Content, where the actions can be executed either from the ribbon above the content
tree or from a context menu displayed by right-clicking a document.

The ribbon offers the following actions:

 New - creates a new document under the currently selected one.
 Delete - deletes the currently selected document.
 Copy - creates a copy of the currently selected document in a location specified in a pop-up

dialog.
 Move - moves the currently selected document to a location specified in a pop-up dialog.
 Up - moves the currently selected document above the one which is above it at the same level.
 Down - moves the currently selected document below the one which is below it at the same level.
 Refresh content tree - displayed only on mouse-over of the content tree's top right corner;

refreshes the content tree so that it shows the current content.

If you right-click a document in the content tree, a context menu appears. The menu offers the same
actions as listed above, while the following extra options are available below the ones from the ribbon:

 Sort subsection - sorts documents under the selected one, while both ascending and descending
order by date or alphabet is available.

 Refresh subsection - refreshes the content tree subsection under the selected document.
 Properties - opens the currently selected document's Properties -> General tab.

If you right-click some of the items in the context menu or hold the mouse pointer above it, a sub-menu
with additional options appears, as further described in the Basic content tree actions topic in the
Editing content (CMS Desk) -> Content management section of the Developer's Guide.

http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/basic_content_tree_actions.htm
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Editing documents

Each document in Kentico CMS is based on some document type. Document types are fully
customizable and can be edited in Site Manager -> Development -> Document types, as described
in detail in the Document types and transformations chapter in the Development section of the
Developer's Guide (please note that products are based on special document types called product
types, which can be edited in the same location).

If you need to edit a document's content, design or properties, select it from the content tree and make
sure Edit mode is selected from the View mode selection. The following tabs are available for all
documents:

Page tab
Design tab
Form tab
Properties tab
Analytics tab

Page tab

On this tab you can edit the content of editable regions placed into the document using the WYSIWYG
editor. Additionally, if there are any editor widget zones defined on the page, this tab is where they can
be managed.

http://devnet.kentico.com/docs/7_0/devguide/Document_types_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/wysiwyg_editor_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/wysiwyg_editor_overview.htm
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Design tab

On this tab, you can edit the current document's page template, which means you can add ( ), relocate
( ), duplicate ( ), configure ( ) or remove ( ) web parts and widgets. Besides, entire web part/widget
zones may be managed through their drop-down menus ( ).

Depending on the preferences of the current user, the tab may also include a toolbar that provides a
convenient way to add new web parts. The toolbar's Settings ( ) button allows you to disable the
toolbar or change its position. Please note that you can remove existing web part instances from the
page template by dragging them into the trash bin area ( ) of the toolbar.

Please keep in mind that any changes made on this tab will be applied also to all documents using the
same page template as the currently edited document.

Form tab

http://devnet.kentico.com/docs/7_0/devguide/What_is_a_page_template.htm
http://devnet.kentico.com/docs/7_0/devguide/Widgets_overview.htm
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On this tab you can edit data related to the document (the Document name, Publish from/to, etc.
properties) or its structured content. The document fields are fully customizable for every document type.

Properties tab

On this tab you can manage the document's properties, i.e. its general attributes such as design, owner,
etc., same as other properties such as URLs, metadata, related documents, etc. You can switch
between the sections of the menu to view the respective properties.

Analytics tab

On this tab you can view the web analytics data measured for the selected document and manage its
tracking (campaigns and conversions) and optimization (A/B or Multivariate testing) options. More
resources concerning web analytics can be found in the Web analytics chapter in the Modules section
of the Developer's Guide.

http://devnet.kentico.com/docs/7_0/devguide/Web_Analytics_Overview.htm
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Please note

Kentico CMS allows you to work with the content of your on-line store also through a
convenient on-site editing interface. Store editors can thus make changes to page
content and manage documents directly while viewing the website from the live site
perspective.

Editing the Master page

Master pages represent a powerful concept of sharing the same header and footer on all pages of your
website. It allows you to manage repeated items such as website logo, main menu and header/footer
content in a single place.

Master pages are either the root of the content tree or pages whose page template has the Master
template option enabled (Site Manager -> Development -> Page templates -> Edit ( ) page
template -> General tab). They can be edited just like any other pages, i.e. you can use the Design
tab to edit the web parts and layout of any master page.

In addition, there's a special Master page tab available in CMS Desk -> Content -> Edit only for master
pages, where you can define the sections of the HTML code of the master page. This code is used for all
pages that inherit content from the master page.

More information about master pages can be found in the Portal engine development model -> Editing
the master page topic in the Development section of the Developer's Guide.

Viewing documents

http://devnet.kentico.com/docs/7_0/devguide/onsite_editing_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Editing_the_master_page.htm
http://devnet.kentico.com/docs/7_0/devguide/Editing_the_master_page.htm
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The View mode selection in CMS Desk -> Content allows you not only to edit the currently selected
document (this mode is selected by default) but also choose how the content shall be displayed.

Live site - this mode shows the page as it currently appears to visitors on the live site.
Preview - this mode also displays the current version of the page, but it may be used even for
documents that are not yet published on the live site while using workflow and versioning.
List - this mode shows a list of all documents under the currently selected document. This can be
useful if there is a large number of documents under a single parent, or if you wish to perform an
action on multiple documents simultaneously.

For more information on how documents can be viewed in Kentico CMS, see the Editing content (CMS
Desk) -> Previewing documents topic in the Content management section of the Developer's Guide.

6.3.2.3 Using web parts

6.3.2.3.1      Overview

The E-commerce solution provides a number of specialized web parts that can be integrated into your
on-line store. Among them you can find:

Shopping cart - allows you to add products to a virtual shopping cart (during the checkout-process)
and displays the shopping cart content.
Shopping cart preview - displays the links to the shopping cart, to My account and to My wishlist,
and the total value of the shopping cart content.
My account - displays the details of the current user, such as personal settings, addresses, orders
and invoices, and allows the user to change the password.
Wishlist - displays the wishlist of the currently logged-on user.
Similar products by sale - displays products that were purchased together with the current product
by previous customers.
Random products - displays N random products that correspond to the criteria specified in the
content filter.
Product datalist - displays products on the basis of their e-commerce product (SKU) properties,
instead of displaying the standard CMS documents.
Top N newest products - displays N newest products.
Top N products by sales - displays N best-selling products.

The web parts can be used on both portal page templates and ASPX templates. However, with ASPX
page templates the web parts are used as independent user controls, which means you need to add and
configure them in Visual Studio just like standard user controls. You thus lose the friendly
browser-based interface.

Further in this section, you will learn how to manage web parts and how to set properties common to
web parts used in your on-line store.

http://devnet.kentico.com/docs/7_0/devguide/Workflow_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Previewing_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/Previewing_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/portal_templates_vs_aspx_templates.htm
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6.3.2.3.2      Managing w eb parts

This topic describes how you can work with instances of web parts when editing page templates through
the portal engine.

Navigate to CMS Desk -> Content and make sure Edit mode is selected from the View mode
selection. Select any page document from the content tree (for example Home) and switch to the
Design tab. This tab allows you to view the structure of the page's template in design mode and modify
its web part content as required.

Using the Web part toolbar

The most direct way to add a new web part to the template is provided by the web part toolbar, which is
displayed on the right side of the tab by default. Because there is a large number of web parts available,
you can choose which ones should be listed in the toolbar by selecting an appropriate category from the
drop-down list at the top. It is also possible to look up specific web parts by entering their name or its
part into the search textbox ( ).

Once you find the web part that you wish to add, simply drag it from the toolbar and drop it into the
desired location in one of the template's web part zones. You can also remove existing web part
instances from the page template by dragging them into the trash bin area ( ) of the toolbar.

You can configure the toolbar according to your preferences. The settings can be accessed directly on
the toolbar by clicking the Settings ( ) button next to the category selector and you can also find the

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/portal_templates_vs_aspx_templates.htm
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same options by going to CMS Desk -> My Desk -> My profile -> Details.

Managing web parts

If you do not wish to use the toolbar, you can instead click the Add web part ( ) icon in the top-right
corner of the zone where you want to insert the web part. This opens the Select web part dialog, which
contains a catalog of all available web parts. You can locate a specific web part by browsing through the
category tree and then confirm your selection by clicking OK.

When a new web part instance is added into a zone, using either the toolbar or the zone action buttons,
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the Web part properties dialog opens (unless the given web part is configured to skip the action). Here
you can set up and finetune the behavior of the web part by entering appropriate values for its properties.

The same configuration dialog can be opened for existing web part instances at any time by clicking the 
Configure ( ) button in their header on the Design tab. You can also use the drag-and-drop
functionality to relocate web parts to different positions or other zones.

Additionally, every web part has a context menu that can be opened by right-clicking its header or using
the arrow icon ( ). The actions in this menu provide an alternative way to perform common tasks, i.e.
Configure ( ), Move to... ( ), Duplicate web part ( ) and Remove ( ).

A similar menu is available also for entire web part zones. This allows you to configure the zone's
properties or carry out actions for all contained web parts.

All web part modifications are applied immediately and reflected on the live site. Page templates are not
connected to workflow, but it is possible to use object versioning to keep track of the changes made to a
template, including its web part content (and roll back to previous versions if necessary). More details
can be found in the Object versioning chapter in the Development section of the Developer's Guide.

Configuring web parts via on-site editing

Although on-site editing is primarily intended for modifying basic page content

http://devnet.kentico.com/docs/7_0/devguide/object_versioning_overview.htm
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and managing documents, users with design permissions may use it also to directly
configure the properties of web parts while browsing the website. Please refer to the 
On-site editing chapter in the Content management section of the Developer's Guide for
more details.

Editable text / Editable image web part

These two web parts provide an editable text / image region that you can use to enter page content.
Content editors can thus edit the region in CMS Desk -> Content -> Edit on the Page tab or while
viewing the page in the On-site editing mode.

6.3.2.3.3      Common w eb part properties

All web parts that display lists, for example the Wishlist, Random products, Product datalist, etc. web
parts, have a similar set of properties to define the displayed content (i.e. product lists, store lists, news
lists, etc.). Specifically, these properties determine:

Where to display the content from (content location).
What content to display (type of content, further content specifications).
How to display the content (transformations, layout, paging).

http://devnet.kentico.com/docs/7_0/devguide/permissions_for_modules_and_documents.htm
http://devnet.kentico.com/docs/7_0/devguide/onsite_editing_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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Where...

These properties define the content's location, i.e. where to load the documents from:

Path - defines the path of the document(s) to be loaded. In addition to basic paths, the property also
supports special characters that may be used to specify entire sections of the content or relative
paths. More details can be found in the Development -> Macro expressions chapter of the
Developer's Guide.
etc.

What...

These properties specify which documents to display from the given location:

Document types - determines which types of documents are to be selected.
ORDER BY expression - sets the value of the ORDER BY clause in the SELECT statement used to
retrieve the content.
Select top N documents - specifies the maximum amount of documents to be loaded. If empty, all
possible documents are selected.
WHERE condition - sets the value of the WHERE clause in the SELECT statement used to retrieve
the content.
Columns - lists the database columns to be loaded along with the given objects, separated by
commas (,). If empty, all columns are loaded.
etc.

http://devnet.kentico.com/docs/7_0/devguide/Types_of_macros.htm
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How...

These properties define how to display the given content:

Transformation - sets the transformation used for the displayed content.
Enable paging - indicates whether to page the displayed data.
Page size - determines the maximum number of records displayed per page.
HTML before - contains HTML code placed on the page before the pager.
HTML after - contains HTML code placed on the page after the pager.
etc.

http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
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Data source web parts

Some web parts use another web part to define the page content, i.e. they use a data source web part,
and only display the content through transformations. If this is the case, then the source of data (its
location, type, database columns, etc.) is not defined directly in the displaying web part but externally in
the data source web part.

For example, the Product Detail web part on product details pages uses the Product Data Source
web part for its content definition.

http://devnet.kentico.com/docs/7_0/devguide/Using_DataSource_web_parts.htm
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Similarly, the Headline Banners Images web part on the Home page uses the Headline Banners
Data Source web part for its content definition.

More information about properties shared by most web parts can be found in the Common web part
properties chapter in the Portal engine development model -> Development section of the Developer's
Guide.

6.3.3 Required personalization

6.3.3.1 Overview

This section describes general tasks that you need to perform when personalizing your on-line store.
Specifically, you will learn how to:

Hide the administrator actions toolbar
Change the store logo
Set up your Facebook profile
Manage lists
Manage text content
Set up store headquarters

6.3.3.2 Hiding the toolbar

If you need to hide the toolbar displaying links to CMS Desk and Site Manager...

http://devnet.kentico.com/docs/7_0/devguide/Common_web_part_properties.htm
http://devnet.kentico.com/docs/7_0/devguide/Common_web_part_properties.htm
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...navigate to CMS Desk -> Content, select the master page (Ecommerce site) from the content tree,
switch to Edit -> Design and remove the Admin Actions web part from the page template.

If you now go back to the live site, you can see that the toolbar is hidden.

6.3.3.3 Changing the logo

If you need to change the store logo...

...navigate to CMS Desk -> Content and select the master page (Ecommerce site) from the content
tree. Then switch to Edit -> Page, locate the respective editable region and click  Select.
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This opens the Select image dialog where you can choose your new logo. Confirm the changes.

If you now go back to the live site, you can see that the logo is different.
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6.3.3.4 Setting up your Facebook profile

If you need to set up your Facebook profile, navigate to CMS Desk -> Content and select the Home
page from the content tree. Then switch to Edit -> Design and locate the Facebook Like Box web
part.

Finally, edit the web part to change its Facebook page URL property as required.

6.3.3.5 Managing lists

If you need to manage any list of documents, you need to:

Locate the respective document items in the content tree.
Add (delete, relocate) the document items.
Alternatively, change the design of the list.
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Example - Adding a new store item

Although the following example shows how to modify the list of stores, you can use this procedure to
modify various other lists, e.g. the list of news, FAQs, products, banners, etc.

1. Navigate to CMS Desk -> Content and in the content tree locate the page that displays the list of
stores.

2. Add a new document of the respective type under the Stores page by clicking  New and selecting
 Office from the list of available document types.

http://devnet.kentico.com/docs/7_0/devguide/Document_types_overview.htm
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3. Fill in the properties of the new document as required and click  Save.

If you now go to the live website, you can see the new store is listed among other stores.
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Displaying banners on the Home page

The web part displaying banners on the Home page (the Headline Banners Images web part) uses a
data source web part (Headline Banners Data Source) for its content definition.

This means that you need to modify the content- and design-related properties of this particular list in
two different web parts.

Common properties of web parts, which allow you to change the lists' content and design, are described
in detail in the Using web parts -> Common web part properties topic.

6.3.3.6 Managing text content

Kentico CMS offers two ways of managing text (or image, HTML, etc.) content:

Editable text - the Editable text web part is used, allowing to enter page content via the Page tab.
Static text - the Static text web part is used, allowing to enter page content by configuring its Text
property.

Modifying editable text content

If you need to modify editable text content, navigate to CMS Desk -> Content, choose a given page from
the content tree, e.g. the Shipping Options page, and switch to Edit -> Page. Make content changes
as required by editing the respective editable region and click  Save.
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As you can see, the live website displays content as defined in the respective editable region.

Modifying static text content

If you need to modify static text content, navigate to CMS Desk -> Content, choose a given page from
the content tree, e.g. the Detail page under Brands, switch to Edit -> Design and locate the Static text
web part on the page template (the Brand Info web part in this example). Make content changes as
required by editing the web part's Text property.
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As you can see, the live website displays content corresponding to the current configuration of the 
Static Text web part.
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Please note that the brand details page implements the Static text web part as an example of the use
of macro expressions. You can use these expressions to display content dynamically, i.e. to display it
on the basis of the given context.

6.3.3.7 Setting up the headquarters

If you need to change your store headquarters...

http://devnet.kentico.com/docs/7_0/devguide/macro_expressions_overview.htm
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...navigate to CMS Desk -> Content, select the respective store document from the content tree and
switch to Edit -> Form. Here you need to set the Is headquarters property of the given document.

Please note that for your new headquarters settings to take effect, you must uncheck the Is
headquarters box for the store that was set as your on-line store headquarters previously (if any).

If you now go to the live website, you can see the store has new headquarters.
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6.3.4 Optional personalization

6.3.4.1 Overview

This section describes other tasks that you may wish to perform when personalizing your on-line store.
Specifically, you will learn how to:

Hide the See our newsletter link
Hide the Donate with us link
Disable the support chat

6.3.4.2 Hiding the See our latest newsletter link

If you need to hide the See our latest newsletter link...

...navigate to CMS Desk -> Content, select the respective pages (Home, Contact, etc.) from the
content tree, switch to Edit -> Design and remove the Newsletter Archive Link web part from the page
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templates.

If you now go back to the live site, you can see that the link is hidden.

6.3.4.3 Hiding the Donate with Us link

If you need to hide the Donate with Us link, allowing website users to make donations, ...

...navigate to CMS Desk -> Content, select the respective page (Home) from the content tree, switch
to Edit -> Design and remove the Donate with Us Link web part from the page template.
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Then delete the Donate with Us page, which is no longer needed.

If you now go back to the live site, you can see that the link is hidden.
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6.3.4.4 Disabling the support chat

To disable support chat, which allows the marketers to communicate with your on-line store customers
in real time by means of text messages, you need to:

1. Navigate to CMS Desk -> Content.
2. Select the respective pages (Contact, product details pages, etc.) from the content tree.
3. Switch to Edit -> Design and remove the Chat Support Request web part from the given page
templates.

6.3.5 Personalizing products

6.3.5.1 Overview

This section describes product-related tasks that you need to perform when personalizing your on-line
store. Specifically, you will learn how to:

Add brands
Delete sample products
Delete sample product types
Add product sections and products
Set up public statuses

6.3.5.2 Adding brands

To add a new brand, i.e. a manufacturer whose products you sell, you basically need to create a new
manufacturer in your CMS system.

However, if a manufacturer is to be displayed as a brand on the Home page of your on-line store, the
following conditions must be fulfilled by default.

A logo is assigned for the manufacturer.
The manufacturer is set as important.

http://devnet.kentico.com/docs/7_0/devguide/chat_overview_basics.htm
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You can change this by modifying the WHERE condition property of the Brands web part, which
displays the list of brands.
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6.3.5.3 Deleting sample products

You may wish to delete Kentico CMS sample products (and sample product sections in which these
products are contained). To do so, navigate to CMS Desk -> Content -> E-commerce -> Products and
choose the sample products (sample product sections) you wish to remove.

You can do this either by selecting a whole product section from the sections tree or by selecting
individual products from the list. Please note that to remove a product section, you need to perform the 

 Delete action above the tree, i.e. you cannot remove a product section by only deleting the products
it contains.

You can remove all listed sample products at once by selecting All documents / Delete from the drop-
down lists on the bottom of the page.
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For a detailed description of product management in Kentico CMS, please refer to the Products chapter
in the Managing your store section.

6.3.5.4 Deleting sample product types

You may wish to delete Kentico CMS sample product types, i.e. document types defining the properties
of products that you offer in your on-line store.

To do so, navigate to Site Manager -> Development -> Document types and from the list of all
available document types choose the sample product types you wish to remove. To perform the actual
deletion of a product type, click the Delete ( ) icon on the respective line.

We recommend that you use the filter to display product types only.

We also recommend that you keep the general Product (CMS.Product) type in your
CMS system so that you can add products for which you do not need to define any
custom properties.

http://devnet.kentico.com/docs/7_0/devguide/Document_types_overview.htm
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To learn how to add your custom product types, please refer to the Adding your product types chapter.
For a detailed description of product types management in Kentico CMS, please refer to the Products ->
Product types chapter in the Managing your store section.

6.3.5.5 Adding product sections and products

If you deleted Kentico CMS sample products (and sample product sections), you must first create a new
structure of your on-line store by adding custom product sections. Then you need to add new products
under these new sections.

Please note

If you deleted all sample product types, you need to create your custom ones to be
able to add new products to your on-line store.

6.3.5.6 Setting up public statuses

Public statuses , i.e. atributes that inform your customers about the current state of products you offer in
your on-line store, can be configured in CMS Desk -> E- commerce -> Configuration -> Public
status.

To set a public status for a particular product, you need to choose the given status from the list of
available public statuses while editing the product on the General tab.
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By default, you can find public statuses (e.g. Featured, New, Sale, etc.) in product lists and product
details.
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To change this behavior, you need to edit web parts that display the given status by changing their
Transformation properties.

As the web parts basically display a box whose content is defined by a dedicated class, you need to 
edit this class to modify the design of the status representation on a web page.

Product lists

The Product List web part displays public status in product lists. To change this behavior, you need to
edit its Transformation properties.

http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
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Product details

The Product Main Image web part displays public status in product details. To change this behavior,
you need to edit its Transformation properties.
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6.4 Configuring your store

6.4.1 Overview

This chapter describes what you need to do when configuring your on-line store. Specifically, you will
learn:

What we recommend before you launch your on-line store.
What configuration is required before launching your on-line store. 
What configuration is optional before launching your on-line store.

6.4.2 Removing sample data

The E-commerce starter site has various sample data (e.g. sample products, product options, shipping
options, payment methods, etc.) set up by default.

That's why we recommend that you delete this data and replace it with your custom data before
launching your on-line store. Alternatively, you can only overwrite Kentico CMS sample data with values
corresponding to your on-line store profile.

If you decide to not use some kind of data (e.g. shipping options if you plan to offer e-products only),
you need to consider:

Removing the corresponding web parts from page templates so that the pages display relevant
content.
Removing the corresponding documents from the content tree so that menus display relevant items.



Kentico CMS 7.0 E-commerce Guide230

© 2014 Kentico Software

6.4.3 Required configuration

6.4.3.1 Overview

You need to configure the following E-commerce solution features before launching your on-line store:

Main currency
Countries
Default country
E-mails
Anonymous/registered users
Checkout process
Invoice
Other settings

6.4.3.2 Main currency

You can set a currency as your on-line store main currency in CMS Desk -> E-commerce ->
Configuration -> Store settings on the General tab.

The main currency is your store default currency, in which you enter the values of all prices, taxes and
other charges and which is used as base for calculation of exchange rates.

Please note

You need to have at least one currency defined on your website to be able to set the
store main currency.

For further details on how to perform these tasks, please refer to Managing your store -> Currencies.

6.4.3.3 Countries

We recommend that you set up what countries (and states) are to be defined in the CMS system before
you launch your on-line store. This configuration determines from which locations your on-line store will
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accept your customers' orders. Besides, you can specify different tax classes with different rates for
each country (or state) and then apply the taxes to particular products and shipping options.

You can perform the task in Site Manager -> Development -> Countries by Deleting ( ) from the
list of countries (or states) the items you are not going to use.

6.4.3.4 Default country

You can set the default country in CMS Desk -> E-commerce -> Configuration -> Store settings on
the General tab.

Your default country is a country used as base for application of taxes unless the customer specifies
their country (or state) during the checkout process.
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6.4.3.5 E-mails

If you wish to inform your customers (and other users) about orders made in your on-line store by
sending notification e-mails, navigate to CMS Desk -> E-commerce -> Configuration -> Store
settings and adjust the settings on the E-mails tab as required.

For further details on how to perform this task, please refer to the Site settings topic in the Configuring
your store -> Settings section.

6.4.3.6 Anonymous/registered users

Kentico CMS allows you to determine whether the customers can purchase in your on-line store
anonymously or whether they have to register before being allowed to make a purchase.

This is defined by the Allow anonymous customers setting in CMS Desk -> E-commerce ->
Configuration -> Store settings on the General tab.
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6.4.3.7 Checkout process

We recommend that you keep the default checkout process in your CMS system. However, you can
personalize this process in CMS Desk -> E-commerce -> Configuration -> Store settings on the
General tab by adding or removing process steps.

Besides, you can define your custom steps to enhance the purchase process to best fit your needs.

For further details on how to perform these tasks, please refer to Configuring your store -> Checkout
process.

6.4.3.8 Invoice

You can configure the invoice, i.e. a commercial document that you issue to the customer while making
a purchase in your on-line store, in CMS Desk -> E-commerce -> Configuration -> Invoice.
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For further details on how to perform this task, please refer to Configuring your store -> Invoices.

6.4.3.9 Other settings

You can configure other on-line store settings in Site Manager -> Settings -> E-commerce.

For further details, please refer to the Site settings topic in the Configuring your store -> Settings
section.

6.4.4 Optional configuration

6.4.4.1 Overview

You may wish to configure the following E-commerce solution features before launching your on-line
store:
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Multiple currencies and exchange rates
Tax classes
Shipping options
Payment methods
Departments
Product categories
Product options
Product statuses
Manufacturers
Suppliers
Discounts

6.4.4.2 Multiple currencies and exchange rates

Multiple currencies

Although you can define precisely one main currency for each on-line store, Kentico CMS allows you to
use multiple currencies while running your store. As a result, a customer can make orders in a currency
that best fits their needs.

You can configure multiple currencies in CMS Desk -> E-commerce -> Configuration -> Currencies
as described in detail in the Currencies topic in the Managing your store -> Currencies chapter.

Exchange rates

If multiple currencies are defined in your on-line store, exchange rates need to be defined in your CMS
system, too for the customers to be able to view relevant prices.

You can configure exchange rates in CMS Desk -> E-commerce -> Configuration -> Exchange
rates as described in detail in the Exchange rates topic in the Managing your store -> Currencies
chapter.
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6.4.4.3 Tax classes

You can configure tax classes in CMS Desk -> E-commerce -> Configuration -> Tax classes. Tax
classes allow you to configure taxes that the customers pay when making purchases in your on-line
store.

For further details on how to perform this task, please refer to Managing your store -> Tax classes.

6.4.4.4 Shipping options

You can configure shipping options, i.e. services used to deliver products to your customers, in CMS
Desk -> E-commerce -> Configuration -> Shipping options. For further details on how to perform this
task, please refer to Managing your store -> Orders -> Shipping options.
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If you add a shipping option, it is displayed in the list of shipping options on the Shipping Options page
(linked by the Help page).

Removing shipping options

If you remove all shipping options from the system, you thus need to update the Help page by editing
the Links web part...
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...and remove the Shipping Options page from the content tree.

6.4.4.5 Payment methods

You can configure payment methods, i.e. instruments your customers use to pay for the purchased
products, in CMS Desk -> E-commerce -> Configuration -> Payment methods. For further details on
how to perform this task, please refer to Managing your store -> Orders -> Managing payment methods.
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If you add a payment method, it is displayed in the list of payment methods on the Payment Methods
page (linked by the Help page).

Removing payment methods

If you remove all payment methods from the system, you thus need to update the Help page by editing
the Links web part...
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...and remove the Payment Methods page from the content tree.

6.4.4.6 Departments

You can configure departments in CMS Desk -> E-commerce -> Configuration -> Departments.

The Departments feature is used for organizing your product management efforts as it enables you to
specify users responsible for the management of products in a particular department of your on-line
store.
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For further details on how to perform this task, please refer to Managing your store -> Departments.

6.4.4.7 Product categories

You can categorize the products you offer in your on-line store by putting them under categories, which
allow for sorting on the basis of topic-related groups. You can do this while editing a given product in 
CMS Desk -> E-commerce -> Products on the Categories tab.

Please note that you can assign categories also in CMS Desk -> Content after selecting the respective
product from the content tree.

6.4.4.8 Product options

You can configure product options in CMS Desk -> E-commerce -> Product options.

Product options offer your customers greater variability while purchasing in your on-line store by allowing
them, for example, to choose color of a given product or add an inscription on it, etc.
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For further details on how to perform this task, please refer to Managing your store -> Product options.

6.4.4.9 Product statuses

With Kentico CMS, you can assign the products that you offer to the customers of your on-line store two
types of status. These include:

Public statuses
Internal statuses

You can configure product statuses in CMS Desk -> E-commerce -> Configuration.
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To learn how to set up public status for a particular product, please refer to the Products -> Setting up
public statuses topic.
For further details on how to configure product statuses, please refer to the Product statuses chapter in
the Managing your store -> Products section.

6.4.4.10 Manufacturers

You can configure manufacturers of the products that you offer to your on-line store customers in CMS
Desk -> E-commerce -> Manufacturers.

Please note that Kentico CMS allows you to display manufacturers as brands on your live website.

For further details on how to configure manufacturers, please refer to the Manufacturers topic in the
Managing your store -> Products section.

6.4.4.11 Suppliers

You can configure suppliers of the products that you offer to your on-line store customers in CMS Desk -
> E-commerce -> Suppliers.
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For further details on how to perform this task, please refer to the Suppliers topic in the Managing your
store -> Products section.

6.4.4.12 Discounts

With Kentico CMS, you can offer your on-line store customers various discounts. These include:

Discount coupons
Discount levels
Volume discounts

For further details, please refer to the Discounts chapter in the Managing your store section.

6.5 Adding your product types

6.5.1 Adding your product types

Product types in Kentico CMS are fully customizable document types, allowing you to create products
and thus present product articles and services to your on-line store customers.

Creating a new product type

http://devnet.kentico.com/docs/7_0/devguide/Document_types_overview.htm
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If you added a new product type to your CMS system, i.e. if you defined a new document type and
configured it as a product type as described in detail in the Product types -> Product type configuration
topic in the Managing your store -> Products section, you now need to create transformations to
determine how products based on this product type are to be displayed on the live website.

Setting up transformations

As products use some transformations by default, e.g. the Product Detail web part uses the
ProductDetail transformation, you only need to add transformations for displaying product parameters
and printing product details.

You can do this in Site Manager -> Development -> Document types while Editing ( ) your new
product type on the Transformations tab. Please note that you can create more custom
transformations if required.

Parameters

To be able to display product parameters (if any) on the Parameters tab of the product details page,
the Document Parameters web part must have the respective Parameters transformation set up.

http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
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Print

To be able to print product details (if any), the Print web part must have the respective Print
transformation set up.

6.6 Further personalizing your store

6.6.1 Overview

Basic content adjustments of your on-line store website and the accompanying modifications of page
templates are described in detail in the Personalizing your store chapter. Here you will see further
examples of personalization of your on-line store as you will be working with more advanced templates'
modifications. Specifically, you will learn how to further personalize your website's:

Master page
Adding the Brands link to the menu bar
Modifying the Shopping cart preview text

Home page
Adding the Sale tab
Changing the number of displayed Brands
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Product listing pages
Changing transformation
Modifying page size and sorting

Product details pages
Changing transformation text

6.6.2 Master page

6.6.2.1 Adding the Brands link to the menu bar

If you need to add a link to the Brands page into the header menu...

...navigate to CMS Desk -> Content, choose the Brands page from the content tree and switch to Edit -
> Form. Make sure the Top menu is selected from the Menu group drop-down list and click  Save.

You may also wish to change the order of items displayed in the menu. To do so, choose the master
page (Ecommerce site) from the content tree, switch to Edit -> Design and modify the respective
properties of the Stripe Menu web part as required.

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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If you now view the given page on the live website, you can see that the menu contains the Brands link
leading to the Brands page.

6.6.2.2 Modifying the Shopping cart preview text

If you need to modify text in the shopping cart preview...

...navigate to CMS Desk -> Content and choose the master page (Ecommerce site) from the content
tree. Switch to Edit -> Design and edit the Shopping Cart Preview web part.

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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Specifically, you need to modify the Total price title property of this web part. Change the property
values using the Edit value dialog as required and confirm the changes.

{% GetAmountText(ECommerceContext.CurrentShoppingCart.TotalUnits, "item ", "items
") + ", Total price: " + FormatPrice
(ECommerceContext.CurrentShoppingCart.TotalItemsPrice)#%}

If you now view the given page on the live website, you can see that the text in the shopping cart preview
has changed and corresponds to the current values of the Total price title property.

6.6.3 Home page

6.6.3.1 Adding the Sale tab

If you need to add the Sale tab into your website's Home page...
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...navigate to CMS Desk -> Content and choose the Home page from the content tree. Switch to Edit -
> Design and edit the Special Offer Tabs web part.

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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Specifically, you need to modify the Tab headers property of this web part by entering the name of the
new tab.

To allow the customers of your on-line store to view the Sale tab on the live site, you also have to modify
the Number of tabs property of the Special Offer Tabs web part accordingly.

As the web part provides basically a tab layout, each tab defines just a separate web part zone. This
means that you now need to add the required content by clicking on your new tab and adding
appropriate web part(s) into the respective zone.
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If you now view the Home page on the live website, you can see the Sale tab displays products on sale.
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6.6.3.2 Changing the number of displayed Brands

If you need to change the number of brands displayed on the Home page...
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...navigate to CMS Desk -> Content and choose the Home page from the content tree. Switch to Edit -
> Design and modify the Select top N property of the Brands web part, which displays the list of
brands.

Alternatively, you may wish to change the layout of the displayed brand items by modifying properties in
the Layout section of the web part.

If you now view the Home page on the live website, you can see that the number of displayed brands
has changed and that it corresponds to the current value of the Select top N property of the Brands
web part.

6.6.4 Product listing pages

6.6.4.1 Changing transformation

By default, Kentico CMS uses the 
EcommerceSite.Transformations.ProductPreviewForThreeColumnsLayout transformation to list
products on product listing pages.

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
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If you wish to use an alternative transformation, e.g. the 
EcommerceSite.Transformations.ProductPreviewForTwoColumnsLayout transformation, to list
products that you offer in your on-line store, navigate to CMS Desk -> Content and from the content tree
choose some product listing page. Switch to Edit -> Design and locate the Product List web part.

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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Then modify the Transformation property of this web part by choosing your alternative transformation.

Please note that you may also need to change values of some other properties of the web part based on
the choice of your alternative transformation, e.g. the Repeat columns property.

If you now view some product listing page on the live website, you can see the listing looks different as it
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corresponds to the current configuration of the Product List web part.

6.6.4.2 Modifying page size and sorting

If you need to modify the size and sorting of listings on product listing pages...
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...navigate to CMS Desk -> Content and from the content tree choose some product listing page.
Switch to Edit -> Design and locate the Product List web part.

Then modify the ORDER BY expression, Page size, etc. properties of this web part as required.

If you now view some product listing page on the live website, you can see the listing of products
corresponds to the current configuration of the Product List web part.

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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6.6.5 Product details pages

6.6.5.1 Changing transformation text

Here you will learn how to change transformation text.

For example, if you need to change transformation text to display on product details pages a specific
number of items available instead of displaying only In stock info (default)...

http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
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...navigate to CMS Desk -> Content and choose some product details page from the content tree.
Switch to Edit -> Design and edit the Product Detail web part.

Specifically, you need to modify the Transformation property of this web part. Change the property
values using the Edit transformation dialog as required and confirm the changes.

<%# If(IsSKUAvailableForSale(), "<span class=\"stock green\">" + EvalInteger
("SKUAvailableItems") + "</span>", "<span class=\"stock red\">Out of stock</
span>") %>

http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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If you now view some product details page on the live website, you can see that the displayed text
corresponds to the current values of the Transformation property.
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Please note

Similarly, you can modify the manner of representation (transformation) in any other
displaying web part, e.g. the Product List, Brands, etc. web part.

6.7 Modifying design

6.7.1 Overview

Basic modifications of your on-line store content are described in the Personalizing your store chapter.
The Further personalizing your store chapter gives various examples of modifications of your website's
content and design. Here you will learn how to:

Modify CSS stylesheets
Modify page layouts
Display and resize images
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6.7.2 Modifying CSS stylesheets

CSS stylesheets allow you to change the appearance and design of your on-line store.

In Kentico CMS, each website has its default stylesheet defined. You can assign the default stylesheet
to a site in Site Manager -> Sites while editing the given site on the General tab. Specifically, you
need to modify the Site CSS stylesheet property.

Individual pages can either use the default website stylesheet or override it with their own stylesheet.
You can assing a stylesheet to an individual page in CMS Desk -> Content -> Edit while editing the
given page on the Properties -> General tab. Specifically, you need to modify the CSS stylesheet
property.

Modifying CSS stylesheets

You can modify CSS stylesheets in Site Manager -> Development -> CSS stylesheets.
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To modify a particular CSS stylesheet, you need to:

1. Open the CSS stylesheet editing interface by clicking Edit ( ) on the respective line in the CSS
stylesheet list.

2. Edit the stylesheet code by changing the definitions of respective classes as required.

Examples

The following examples show basic CSS stylesheet modifications. We will be modifying design of your
on-line store Home page, and you will see examples of changing:

Font family
Font size
Text color
Button color

Changing font family
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Changing font size
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Changing text color
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Changing button color
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You can find more details about CSS stylesheets in the CSS stylesheets and design chapter in the
Development section of the Developer's Guide.

6.7.3 Modifying page layouts

A page layout in Kentico CMS consists of layout code and web part zones that specify regions where
web parts can be placed. You thus use page layouts to define the layout and design of your on-line
store.

If you need to modify layout of a given page, navigate to CMS Desk -> Content and choose the page
from the content tree. Then switch to Edit -> Design and click the Edit layout ( ) button at the top

http://devnet.kentico.com/docs/7_0/devguide/CSS_Overview.htm
http://devnet.kentico.com/docs/7_0/devguide/web_part_development_overview.htm
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right of the green template area. This opens the Page template layout properties dialog, where you
can edit the layout code as required.

You can find description of the management of web parts in Kentico CMS in the Content management
basics -> Using web parts chapter in the Building your on-line store -> Personalizing your store section.
To learn more about page layouts, please refer to the Portal engine development model -> Page layouts
topic in the Development -> Web development overview section of the Developer's Guide.

6.7.4 Displaying and resizing images

6.7.4.1 Overview

If you want to present an image on your website multiple times, each time in different sizes, it is
sufficient to upload the image just once. Kentico CMS is able to resize it for you. However, please
consider that the size of an image can only be decreased, not increased. It is therefore important that
you upload your images in the maximum size you want to use on your website.

The section is divided into the following parts:

Displaying images
Resizing images

6.7.4.2 Displaying images

Here you will learn how to display images and product images in transformations.

Displaying images in transformations

To get an image in the given size, you need to insert one of the following methods into the 

http://devnet.kentico.com/docs/7_0/devguide/Page_layouts.htm
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transformation:

Getting image by its attachment GUID

GetImage(object attachmentGuidColumn, object maxSideSize, object width, object height, object
alt)
GetImage(object attachmentGuidColumn)
GetImage(object attachmentGuidColumn, int maxSideSize)
GetImage(object attachmentGuidColumn, int width, int height)

Getting image by its URL

GetImageByUrl(object imageUrl, object maxSideSize, object width, object height, object alt)
GetImageByUrl(object imageUrl)
GetImageByUrl(object imageUrl, int maxSideSize)
GetImageByUrl(object imageUrl, int width, int height)

These methods use the following parameters:

attachmentGuidColumn - specifies the attachment GUID.
imageUrl - specifies the image URL.
maxSideSize - determines the required image maximum side size.
width - specifies the required image width.
height - specifies the required image height.
alt - specifies alternate text of the image.

All the methods generate HTML code for inserting an image according to given parameters.

Example: Displaying images in transformations using image attachment GUID

You can display images using the field value of a given document type that represents the attachment
GUID.

In the following example, we defined a new document type Employee. This type has two attributes:
Employee name specified in the EmployeeName column and Employee photo specified in the
EmployeePhoto column.

To display the employee photo, you need to insert the GetImage method with the following syntax into
the transformation.

http://devnet.kentico.com/docs/7_0/devguide/document_types_transformations_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/Document_types_overview.htm
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<%#GetImage(Eval("EmployeePhoto")) %>

Examples: Displaying images in transformations using image URL

You can display images:

a) Using the Live URL property while editing the given file in CMS Desk -> Content -> Edit on the
Properties -> General tab.

<%#GetImageByUrl(~/Files/logo.aspx )%>

b) Using the field value of a given document type that represents the image URL, for example 
SKUImagePath.

Displaying product images in transformations

To get a product image in a given size, you need to insert the GetSKUUrl() method into the
transformation or you can insert the GetSKUImageUrl method with the following syntax into the
transformation: 

GetSKUImageUrl(int width, int height)
GetSKUImageUrl(int maxSideSize)

The methods generate HTML code that inserts an image into your page. If no product image is set, the
methods display the default image in the given size.
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Please see the examples in the Resizing images chapter for further details.

Storing images

For the best performance while loading images, please ensure that images are stored
in the file system.

6.7.4.3 Resizing images

This chapter describes how you can resize product images. Please note that you can resize any image
the following way using the respective methods (i.e. GetImage() and GetImageByUrl() ) with appropriate
parameters.

You can set a size of the original image (width: 422px, height: 266px) using the GetSKUImageUrl
method in the following ways:

Setting the Maxsidesize value
Setting the Height value
Setting the Width value
Setting the Width and Height values
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Setting the Maxsidesize value

This sets the longer side to the value specified as Maxsidesize. The other side is calculated
automatically, and so the aspect ratio remains the same as it is in the original image. In the following
image, Maxsidesize is set to 240px.

GetSKUImageUrl(240)

Setting the Height value 

This sets the height of an image. The width is calculated automatically, and so the aspect ratio remains
the same as it is in the original image. In the following image, Height is set to 170px.

GetSKUImageUrl(0,170)
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Setting the Width value

This sets the width of an image. The height is calculated automatically, and so the aspect ratio remains
the same as it is in the original image. In the following image, Width is set to 200px.

GetSKUImageUrl(200,0)

Setting the Width and Height values

The given values are set on condition that they are not greater than the original size of an image. Please
note that the aspect ratio may not be maintained. In the following image, Width is set to 150px and
Height is set to 240px.

GetSKUImageUrl(150,240)
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In the following image, Width is set to 240px and Height is set to 150px.

GetSKUImageUrl(240,150)

If at least one value is greater than the original size, the original image size is set. In the following
image, Width is set to 600px and Height is set to 500px.

GetSKUImageUrl(600,500)
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6.8 Advanced configuration

6.8.1 Overview

This section describes advanced configuration of your on-line store. The following features are covered:

Multilingual products
Versioned products
Multisite store
Store security
API customization

Please note that here the features are explained only briefly. This is because dedicated sections in this
and in other Kentico CMS guides (to which you are linked from the respective topics) provide a detailed
description of the features.

6.8.2 Using multilingual products

Kentico CMS allows you to have your website content translated into multiple languages. In a
multilingual on-line store this typically applies to products, which may thus have separate language
versions.

You can find more details in the Multilingual store topic in the Configuring your store section.

6.8.3 Using versioned products

Kentico CMS supports workflow, which is a sequence of steps that define the life cycle of products (and
documents). This allows you to set up a reviewing and approval process to ensure quality of content and
design. In such process, you can specify roles that different users play and places in the flow where the
users have influence on the products.

If workflow is enabled on your website, the Advanced -> Versions tab available in CMS Desk -> E-
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commerce -> Products while Editing ( ) a product allows you to view all workflow versions of the
given product.

You can find more details about workflow and versioning in Kentico CMS in the Workflow and versioning
chapter in the Content management section of the Developer's Guide.

6.8.4 Multisite store

Kentico CMS allows you to run multiple stores on a single Kentico CMS installation. If you decide for
this option, you can use both site-specific objects available for the respective sites only and global
objects shared across all your on-line store sites.

You can find more details in the Multisite store chapter in the Configuring your store section.

6.8.5 Store security

With Kentico CMS you can easily and effectively ensure high security standards of your on-line store by
defining access, configuration, etc. rights for your store administrators.

You can find more details in the Security section.

6.8.6 API customization

Kentico CMS allows you to script any action accessible via the user interface. You can thus create your
customized features or write procedures for integration with external systems.

You can find more details in the Customization section, and in the API programming and Kentico CMS
internals section of the Developer's Guide.

http://devnet.kentico.com/docs/7_0/devguide/Workflow_overview.htm
http://devnet.kentico.com/docs/7_0/devguide/API_Overview.htm
http://devnet.kentico.com/docs/7_0/devguide/API_Overview.htm
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7 Customization

7.1 Customization

Customization of the behavior of the CMS application or its specific module according to your exact
requirements is described in detail in the Custom providers chapter in the API programming and Kentico
CMS internals section of the Developer's Guide.

As this type of customization is also available for the E-commerce solution, you can override the default
behavior and calculations by using custom providers that ensure various operations.

Examples

The Kentico CMS installation includes examples of E-commerce customization. To access these
samples:

1. Open your installation directory (by default C:\Program Files\KenticoCMS\<version>).
2. Expand the CodeSamples\App_Code Samples\ sub-directory. 
3. Copy the E-commerce samples folder into the App_Code\CMSModules\Ecommerce\ folder of
your web project.

Web application installations

If your Kentico CMS project was installed in the web application format, copy the
examples into the Old_App_Code folder instead. 

You must also manually include the sample class files into the project:

1. Open your CMS application in Visual Studio.
2. Click Show all files at the top of the Solution Explorer.
3. Navigate to Old_App_Code\CMSModules\Ecommerce, right-click the new
E-commerce samples folder and select Include in Project.

Now you can view the code of the sample customized providers and try out their functionality. To apply
the customizations to your application, you must uncomment the appropriate lines in the 
SampleECommerceModule.cs loader class.

http://devnet.kentico.com/docs/7_0/devguide/Custom_Providers_Writing.htm
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