
Kentico CMS 5.5 beta Personal Site Guide



Kentico CMS 5.5 beta Personal Site Guide2

© 2010 Kentico Software

Table of Contents

Personal Site Guide 4

................................................................................................................................................... 4Overview

Getting Started 6

................................................................................................................................................... 6Editing content

................................................................................................................................................... 9Adding a blog post

................................................................................................................................................... 12Adding a photo gallery

................................................................................................................................................... 16Adding a forum

Adjusting Design 20

................................................................................................................................................... 20Changing the theme

................................................................................................................................................... 25Editing CSS stylesheets

Adding web parts 31

................................................................................................................................................... 31Adding text

................................................................................................................................................... 35Adding a poll

Further reading 40



Part

I

Personal Site Guide



Kentico CMS 5.5 beta Personal Site Guide4

© 2010 Kentico Software

1 Personal Site Guide

1.1 Overview

Kentico CMS Personal Site allows you to easily run your own personal web site. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:

Content editing
Blogs
Forums
Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need. 

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx). 

You can contact our technical support at http://www.kentico.com/Support.aspx.

http://www.kentico.com/devnet/documentation.aspx
http://www.kentico.com/Support.aspx
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2 Getting Started

2.1 Editing content

In this chapter, you will learn how to change the About text on your web site.

1. Go to CMS Desk -> Content -> Personal Site -> About me.
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2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This is the new About me text. Then click Save at the top-left.
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3. Now switch to the Preview viewing mode. You can see that the About me text has been updated.
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2.2 Adding a blog post

In this chapter, you will learn how to add a new post to your blog.

1. Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action
toolbar.

2. Choose Blog post as a new document type.
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3. Next, enter information for your new blog post.

Post title: My new blog post
Post Summary: Summary of the blog post.
Post text: The entire text of the blog post.

Then click Save at the top.
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Your new blog post has been added to My Blog. 
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2.3 Adding a photo gallery

In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document
action toolbar. 

2. Choose Image gallery as a new document type.
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3.  Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then
click Save at the top.

4. Now, go to Properties -> Template and click Select to choose template to use. Choose Personal
Site\Personal Site - Photo Gallery. Click Save at the top.
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5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.

6. Click the Upload file ( ) icon and choose a picture to upload. 

Then enter The description of the first picture. into the File description text box and click Save at the
top.
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Congratulations, you've just learned how to create a new gallery and add some pictures into it.

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import. 
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2.4 Adding a forum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group. 

2. In the Forum group properties, click Add forum . 
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3. Add the following information for the new forum:

Forum display name: New forum
Forum code name: newForum 
Description: The description of the new forum.

Then click OK.
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4. The forum has been added as you can see in the following screenshot.
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3 Adjusting Design

3.1 Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will learn
which stylesheets are available and how you can choose the CSS stylesheet you want to use on your
web site.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site
next to the Personal Site.

In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.
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The following CSS stylesheets are available in the sample Personal Site:

Personal Site
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Personal Site - Blue
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Personal Site - Green
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Personal Site - Red
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3.2 Editing CSS stylesheets

In this chapter, you will learn how to change the design of your web site by modifying the CSS
stylesheets.

Changing the header picture 

1. Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site
and choose Main styles -> Master page section in the text box on the left side.

2. In the .zoneTop style, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

   .zoneTop

{

height: 239px;

width: 795px;

background-color: #fff;

padding: 0px 0px 7px;

margin: 0px 0px 0px;

background: #fff url(../App_Themes/PersonalSiteGreen/Images/bg_head.jpg)

       no-repeat top left;

}

Then click Save at the top-left.
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3. Now click Sign out at the top-right. You can see that the header image has been changed.
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Changing the top menu

1. Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master
page section in the text box on the left side.

2. Scroll down to see .zoneTopMenu style.

 

3. Change the background color to #B0C4DE and erase the URL part so that the entire section reads
as follows: 

   .zoneTopMenu

{

height: 43px;

width: 795px;

background: #B0C4DE; 

padding: 0px;

margin: 0px;

}

This will change the background of the navigation at the top to dark blue.
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4. Now, switch to the Top menu section and find .CMSListMenuLI a:hover style. This style modifies
the appearance of menu item when mouse is over it. 

5. Change color to #fff and replace the url part with #87CEFA. The entire style should read as follows:

.CMSListMenuLI a:hover, .CMSListMenuLinkHighlighted, .CMSListMenuLIlast a:hover, 

.CMSListMenuHighlightedLIlast a, .CMSListMenuHighlightedLI a

{

                color: #fff;

                background: #87CEFA;

                text-decoration: none;

}

This will change the background of the menu item to light blue and its font color to white when mouse
hovers above it.
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You've just learnt how modify CSS stylesheets to change design of your web site.
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4 Adding web parts

4.1 Adding text

In this chapter, you will learn how to add the new editable text region into your web site.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web part in
zoneRight.
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2. Select Text/EditableText web part.

3. In the Web part properties dialog, enter the following information for the new web part.

Editable region title: AboutWebPageTitle
Content before: <h1>
Content after: </h1>

Then click Ok.

4. Click Add web part again and select the same Text/EditableText web part.

5. In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click Ok.

6. Now you have the new web parts ready and you can enter some new text. Switch to the Page tab
and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.
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7. Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.
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That is how you add a new editable region into your web site.
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4.2 Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll.

2. Enter the following information for the new poll.

Display name: My poll
Code name: MyPoll
Question: How do you like my pictures?

Then click Ok.

3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers

tab and click New answer . Into the Text text box, enter I love them! and click Ok.
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4. Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.
Then click Ok.

5. Click New answer again and enter Waste of time! into the text box provided. Click Ok. 

6. Now we are ready to add your new poll to web site. Go to CMS Desk -> Content -> Personal Site ->
Photo Gallery and switch to the Design tab. Click Add web part in zoneLeft.
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7. In the Select web part dialog, select Polls\Poll web part. 



Kentico CMS 5.5 beta Personal Site Guide38

© 2010 Kentico Software

8. In the Web part properties dialog, make sure My poll is selected as Poll name and click Ok.

Congratulations, you've just learned how to add a new poll to your web site.
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5 Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

Kentico CMS Tutorial
Kentico CMS Developer's Guide
Kentico DevNet at http://www.kentico.com/DevNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.
com/Support.aspx.

http://www.kentico.com/DevNet.aspx
http://www.kentico.com/Support.aspx
http://www.kentico.com/Support.aspx
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