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1 Introduction

11 Kentico CMS Overview

Kentico CMS for ASP.NET helps you create powerful dynamic websites with minimum effort. This
document will guide you through the most important features of the system step-by-step, so that you
can start creating your own websites.

This document was written for evaluators and new users. It's intended for developers who create the
websites. It's not intended for end-users without programming knowledge.

If you need a more detailed documentation of some features, please see one of the following documents:

e Deweloper's Guide

e Web parts and Controls Reference
e API Reference

e Database Reference

Kentico CMS Support

You get free technical support during your evaluation period. If you need any help,
please wvisit http://www.kentico.com/Support.aspx.
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2 Installation

2.1 Prerequisites

Before you start the installation, please make sure you have the following software installed. Other
configurations may work too, but the system was not tested on them.

Server-side Requirements

e Windows XP, 2003, 2008, 2008 R2, Windows Vista Home Premium/Business/Enterprise/Ultimate or
Windows 7 (both 32bit and 64bit)

e Microsoft .NET Framework 2.0 or higher

e Microsoft Internet Information Senices (IIS) or Visual Studio/Visual Web Deweloper 2005/2008 built-in
web server

® Microsoft SQL Server 2005, 2008 (including free SQL Server Express Edition)

Hosting Requirements

ASP.NET 2.0 (or higher) and Microsoft SQL Server 2005/2008 support

Medium-trust or full-trust permissions for the ASP.NET application

If the server uses medium trust, ASP.NET AJAX 1.0 must be installed on the senr.

It's recommended that your hosting plan comes with 125 MB or more memory and 100+ MB
database.

You can use your favorite hosting provider or choose from our hosting partners.
Development Tools

If you want to create custom web parts or integrate custom code, you need Visual Studio 2005/2008 or
Visual Web Developer 2005/2008 Express Edition.

Supported Client Browsers for Content Editors

e |[E 7.0, IE 8.0 (compatibility mode)
e Firefox 3.5
e Safari 4.0 or Firefox 3.5 on Mac OS

Supported Client Browsers for Site Visitors

IE 6.0, IE 7.0, IE 8.0 (compatibility mode)
Firefox 1.0.5+

Mozilla 1.7.1+

Netscape 7.1+

Opera 7.52+

Safari or Firefox on Mac OS

(the \isitor browser requirements depend on functionality used on the website)
Required experience

Although Kentico CMS allows you to create dynamic websites without programming, you may need to
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2.2

2.3

create custom web parts or to add custom code when dewveloping a more complex website. You should
be able to create a simple application in ASP.NET 2.0 using Visual Studio 2005 and have some
experience with relational databases and SQL, so that you can leverage the flexibility of Kentico CMS.

Setup installation

Troubleshooting installation issues

If you encounter any problems during the installation, please see Kentico CMS
Developer's Guide -> Installation and deployment -> Troubleshooting
installation issues or contact our support at http://www.kentico.com/Support.aspx

Run KenticoCMS.exe and follow the installation wizard:

=32 Setup - Kentico CMS 5.5 R2 = e

Welcome to the Kentico CMS 5.5

22 venti
I.\ mﬁ!}mlco R2 Setup Wizard

This will install Kentico CMS 5.5 R2 on your computer.

It is recommended that you dose all other applications before
continuing.

Click Next to continue, or Cancel to exit Setup.

Mext = |’ Cancel ]

Read and accept the license agreement and click Next. Choose the installation location of the binary
files and documentation on your disk. After the setup completes the installation, choose to Launch
Kentico CMS Web Installer and click Finish.

Web application installation

Now you should see the Kentico CMS Web Installer. If you cannot see it, you can always run it from
Start menu -> All Programs -> Kentico CMS -> Kentico CMS Web Installer.

First, you need to choose the version of .NET Framework and Visual Studio that you wish to use. Click
Next.

© 2011 Kentico Software


http://www.kentico.com/Support.aspx

Installation 9

r-;;z- Kentico CMS Web Installer C=hLE
@ O® Sicp - Select NET Frm_—._

7S

Pleaze choosze the NET Framework verzion you are using:

| am using .MET Framework 4.0 or Visual Studio 2010
| am using .MET Framework 3.5 or Visual Studio 2008

" lamusing .NET Framework 2.0 or Visual Studio 2005

Now choose to use either IIS server or Visual Studio built-in web sener (if you do not hawe IIS installed).
Click Next.

-
1= Kentico CMS Web Installer C=nee

Step 2 - Select target IDE

Choose the location where the web files will be installed:

@ | want to use local 115 server
7 |'want to use buitt-n web server in Visual Studio 2008
| want to install Kertico CM5 on a remote (production or testing) server

| want to modify existing Kentico CM3 installation

< Back Next > | Cancsl |

IIS installation

If you choose the IIS sener, you can choose the website where the virtual directory will be created and
the folder on your local disk where project files will be deployed. The installer will create a new virtual
directory on your server and configure it for ASP.NET. Click Next.

Please note: if you are installing Kentico CMS into the root of your website (such as http://www.
domain.com) and do not wish to create a virtual directory (such as http://www.domain.com/cms), please
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check the Thisis an installation to the root (do not create virtual directory) check-box.

p
3= Kentico CMS Web Installer

-‘ !'- Step 3 - Local IS X
7S

Pleaze choose the 115 location:

Choose web site: IDefault Web Ste VI
Type of application poal: IInteglElted 'I

Choose target folder: Ic:\lneipub\wwmoot\l‘(enticoCMS Browse .. |

[~ Thisis an installation to the root {do nat create vitual directory)

os | o |

"

Visual Studio installation

If you chose to use the built-in senver in Visual Studio, you only need to specify the local disk where the
project files will be deployed. Click Finish.

p
3¢ Kentico CMS Web Installer C=reE

N7 —
Q& Sicp 3 - Visual Studio 2008

7S

Pleaze choose the web site location:

Choose target folder: Ic:\lnetpub\wwwroot\KemicoCMS Browse ... |

os | e |

"

Type of installation

No matter if you chose the IIS or VS installation, the next step after specifying the target folder is the
selection of installation type. The following two types of installation are available:
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e Full installation - this is the recommended option for the purposes of this tutorial; in this type of
installation, all components of the CMS will be installed

e Custom installation - in this type of installation, one extra step will be displayed, letting you choose
which components you want to include in the installation

Click Next to start the installation process.

r-:i:— Kentico CMS Web Installer =] = |
L
s —
-'.\- Step 3 - Select installation type i

Select installation type:

@ Fullinstallation frecommended)

" Custom installation

" J

After the setup copies all files, you will see the link for opening the web application in browser or the web
project in Visual Studio. Click the link.

Opening the website in Visual Studio

If you chose Visual Studio installation, the project is opened in Visual Studio:
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2.4

% WebProject - Microseft Visual Studio (Administrator)

File Edit View Website Build Debug Tools Test Analyze

- E-E @ B9 -85 b Debug

Window Help
~ Mixed Platforms

|= General

There are no usable controls in this group.
Drag an item onto this text to add it to the

toolbox.

—

Ready

B W Y -
- | @ Kentico e Ea-k
Solution Explorer - C\.\KenticoCMSY -3 x

2| FE]a 5w

2l
2l
|
H
H
2}
2l
2l
|
H
H
2}
2l
2l
|
H
H
2}
2l
2l
|
H
H
2}
2l
2l
2l
H
H
2}
2l
2l

[5A Selution 'WebProject' (1 project)
B & C\\KenticoCMS\
- g App_Browsers

- E@ App_Code

- [ App_Data

= App_Themes
3 App_WebReferences

- @ Bin

- [ ClientBin

- [ CMSAdminControls

- [ CMSControlsExamples

4 CMSDesk
[ CMSFermControls

- 3 CMSHelp

- [ CMSImportFiles

- [ CMSInlineControls
- [ CMSInstall

[[d CMSMasterPages
[ CMSMessages

- 3 CMSModules
- [ CMSPages

- [ CMSResources
- [ CMSScripts

[ CMSSiteManager
[ CMSSiteltils

- 3 CMSTemplates
- [ CMSWebParts
- [ CommunitySite
- [ CorporateSite

[ CorporateSiteAspx
[ mycentrols

- 3 PersonalSite
- [ Products

- [E| Default.aspx
- favicon.ico
- 4] Global.asax

parameters.config

web.config
... 2] WebProjectsln

Choose Debug -> Start without debugging from the main menu. The site will be displayed in new
browser window using the built-in web senver.

When you cannot open the website in Visual Studio

If the link for opening the project in Visual Studio doesn't work, you may need to start
Visual Studio manually and choose File -> Open -> Web Site... and locate the project

folder on your disk manually.

Database setup and Corporate Site

Now you should see the Database setup in your web browser.

In the first step, choose the SQL Server name or IP address. If you are using SQL Server 2005 Express
Edition, the default server name is \SQLEXxpress or (local)\SQLEXxpress.

You can use either SQL Server authentication (recommended) or integrated Windows authentication.

e In case you use SQL Server account, you need to enter the user name (such as sa) and password.
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e In case you use Windows authentication, you need to ensure that the ASP.NET account of the
name displayed in the brackets has an appropriate login name in your SQL Sener.

Permissions for creating new databases or for creating database objects in an existing database must
be granted to the account.

Click Next.

(" ——
(& Kentico CMS Database Setup - Windows Intemnet Explorer

{3 ()= [ €] nttp://localhost/Kenticochs 0420/c
¢ Favorites | oy @ Suggested Sites v @] Web Slice Gallery »

& Kentico CMS Database Setup

.

Starter Site

Lo name:
I —

() Use integrated Windows authentication
{ASP.MET account: NT AUTHORITY\INETWORK SERVICE)

2  Nec> [

Version: 5.5 Build: 5.5.3762

€& Local intranet | Protected Mode: Off

In the Database Instance step, choose Create a new database, enter the name of the new database
into the New database name field and click Next.
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i-8-9 -0

SOL Settings Database Starter Site Finish

KenticoCMS

Existing database name:

Create Kentico CMS database objects

The database creation log will be displayed.

i-8-9-0

SQL Settings Database Starter Site Finish

Running query: proc_cms_tree_orderalphadesc.sql

Running query: proc_cms_tree_orderalphaasc.sgl

Running query: proc_cms_class_getclassesonsite.sgl

Running query: proc_analytics_statistics_removedependencies.sql
Running query: proc_com_shippingoption_removedependences.sqgl
Running query: proc_com_paymentoption_removedependences.sql
Running query: proc_reporting_filedownloads.sgl

Running query: proc_reporting_reporicategory_removedependencies.sgl
Running query: proc_reporting_report_removedependencies.sql
Running query: proc_reporting_savedreports_removedependencies.sql
Running query: proc_analytics_statistics_delete.sqgl

Running query: proc_analytics_processlog.sgl

Running query: proc_polls_pollanswer_moveup.sql

Running query: proc_polls_pollanswer_mavedown.sql

Running query: proc_polls_pollanswer_initorders.sql

Running query: proc_polls_poll_removedependences.sqgl

Running query: proc_ecommerce_customer_removedependences.sgl
Running query: proc_ecommerce_exchangetable_removedependences.sql
Running query: proc_cms_webfarmserver_removedependences.sgl
Running query: proc_cms_webfarmtask_removedependences. sqgl
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When the database is created, you will be asked to enter your license key. If you do not have a license
key yet, click Next to continue in the trial mode. The functionality of the trial mode is the same as the
full version.

Step 4 - License Key

w |
- =3,
»

SQL Settings Database Starter Site nish

Your trial license key has expired, please enter avalid license key for domain: localhost

Tip: If you need a temporary license key for this domain, please write to support@kentico.com and
ask for a trial key for the following domain name: localhost

You can also get a license of Kentico CMS Free Edition after registration at http:ffiwww. kentico.com.

Please enter the key:

Skip this dialog

® =3

In the Starter Site step, you can choose from the following options:

e Choose a starter site:
e Corporate Site (portal engine) - this option installs the sample corporate site - it is
recommended for most users, especially for evaluators.
e Corporate Site (ASPX templates) - this option is recommended only for experienced ASP.NET
dewelopers who want to use ASPX page templates instead of portal templates.
e E-commerce site - this sample site can be used as a starting point for creating your own e-shop
and shows the possibilities of Kentico CMS's E-commerce module.
e Personal site - this is a web template suitable for a simple personal site.
e Community site - complex web template suitable for community webs, showing Kentico CMS's
social networking features in practice.
e Intranet Portal - ready-to-use solution for company intranets with support of departments,
workgroups, project management, etc.
e Blank site - this is a blank site without any content; you will use it to create a new site from
scratch.
e Blank site ASPX - the same as abowe, but for ASPX poage templates.

e Continue to the New site wizard - this option is recommended if you are starting a new site from
scratch.

e Import an existing Kentico CMS website - use this option is you already created a website with
Kentico CMS and need to import it into the new installation (e.g. on the production server).
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For the purpose of this guide, please choose to create sample Corporate Site and click Next. You
will see the confirmation and a link to your new website:

Step 5 - Starter Site

=
)
SQL Settings Databasze Starter Site Finish
@ Choose starter site
Company.c2 Corporate Site =

- ;_'] This is a web template for a general corporate site. It's used =
as a showcase of Kentico CMS capabilities and it can be
used as a staring site that you modify as needed. It uses the
portal engine and it's the recommended choice for developers
who are new to Kentico CMS.

Corporate Site ASPX

;_'] This is a web template for a general corporate site. It's used
as a showcase of Kentico CMS capabilities and it can be
used as a starting site that you modify as needed. It uses the
ASPX page templates that require a higher level of MET

% knowledge than the portal engine.

(=) Continue to the New site wizard
() Import existing Kentico CMS web site

© =3

A log displaying creating of the site will be displayed. When it's finished, you will be displayed with the
final step that you can see in the screenshot below. Click the Continue to the new web site link.
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SQL Settings

Starter Site Finish

You will be redirected to the title page of the sample Corporate Site:

17
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’_,é Corporate Site - Home - Windows Internet Explorer

G-

[ &[4[ x ][ sing p -

http://localhost/KenticoCMS_2212/default.aspx

¢ Corporate Site - Home

j:y Favorites 5.3 & Suggested Sites » £ | Web Slice Gallery +
»

Y e v Pagew Safetyv Tools~ @~

fi - B -

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

tp Shopping cart | My account | My wishlist
“Your shopping cart is empty

Companylogo

Search for:

Newsletter subscripl

First Name:
Last Name:

E-mail:

De you like our product?

© ves, 1 do.
[ | 28
© Mo, I dont
[ — 1 | 4
) 1 den't know your product

| 5

[Vore|

This is a sample web site created with Kentico CMS for ASP.NET.
You can use it as a starer kit for your own web site and to leam
Kentico CMS.

Default user name and password

You can sign in to CMS Desk (the administration interface) using the
link at the top of the page or by going to the following address
http/localhost/KenticoCMS/CMSDesk  (f you're using the default

installation path). Use the following credentials:

User name: administrator
Password: Leave the password blank.

Getting Started

Kentico CMS Tutorial will guide you through Kentico CMS. You can also
get help at http-www kentico com/Support aspx.

Your second news
11512008

Here you can enter the summary of the
news item. ¥ou can use WYSMWYG
editor to format the text, insert links and
images. The summary wil be used in
newe tam nreview

Featured product

Price:

$470.00

m

Done

& Local intranet | Protected Mode: Off

3 -

#,100%

-

Sample website

The Corporate Site website is only an example of a website you can create with
Kentico CMS. You hawe full control over the site structure, design, page layout and
functionality as you will see in the following chapters.
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3.1

Managing content

User interface overview

Click the Sign in to CMS Desk link at the top of the website or go to http://<domain>/
<virtualdirectory>/cmsdesk. You will be asked for a user name and password.

Default user name and password

The default user name is administrator, the default password is blank (no password)

It's highly recommended that you change the password before you publish the website
on the live sener.

Once you sign in, you will see a splash screen, giving you some basic information. Click the Continue
button, you will be redirected to the following page:

: Editing mode e Switch to Site Current Current
Main menu selection Site Manager | | selection user version
G / ; .-

rech 16 Ste Manager  Sites Corporate se[=]  Users Global Admin

iz Remtes
J

N
“a

cor W OEWwE B o
e Ty p— 'Emg 'f.u 2 List So)ar.'r\ o Sign Out
Contert management Ceher = button
) &) Comparate sita Pag | Desn  Fom  Propwes 2]

Document Saves
actions

Web Design - ;
Web Developmant E] Soece | (& &
Network Adverwstration i3 )

Products ] snee =] Fomat =T T 1% a3 B
Cell phones
Poas
Laptops

) e Companylogo

& Your first news

WYSIWYG
editor

Global Admeastrater (admancstraton E ;; J
P Shoppieg cart | by account | by wishiist

e snaping oa s wees

Content 2
tree SR

Compary
Blogs
Forums
Evants
Images
Czech Republic

Editable
region

* Wisb Dusign Seacas
* Wisd Devalopment
® Netwerk Admnistration

- Our Seraces
- IMO02628.0PG

Page in i 14002601906 e grovda profevsional seeaces n ihe folowing eas
= [MO02555.0PG
e s - Vieh desiopmass
= MO01775.0PG
editing mode = N

France

Thia i3 @ simple page with ket meny and content on the nght. You can create haks similar 1o those above USng the
insarEcH Link betion in the acior foolbar.

o & Special pages
+ ) Images

h 104 1
—,:\- Kentico

The user interface consists of the following main sections and features:

e Main menu with Content, My Desk, Tools and Administration tabs.

e Content tree that represents the site map of the website and allows you to organize the structure of
documents and choose document that appears on the right side of the screen.

e Document actions toolbar with buttons for creating new documents, deleting, copying, moving and
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sorting documents.

e View mode selection - allows you to choose between editing, preview, live site view and list view.

e Editing mode selection - you can choose to edit page content, design the page template, edit the
document fields, product properties or document properties.

e Go to Live Site - this action redirects you to the title page of the currently edited website, logged
under the same user account that you used to log into the user interface. This is a more convenient
way than using the Sign out button and logging in on the live site afterwards.

e Switch to Site Manager - redirects you to Site Manager, the other part of the system's user
interface. This option is only available to global administrators.

e Site selection - this drop-down list is used to select the currently edited website. Only those
websites that the current user can edit are available in the drop-down list.

e Current user - user name of the current user.

e Current version - version of Kentico CMS.

e Sign Out button - clicking this button log you off the user interface and redirects you to the title
page of the live site. This button is only displayed if Forms authentication is used. When using
Windows authentication, the link is not displayed.

e WYSIWYG editor - allows you to edit text stored in Editable regions, change text formatting or
insert graphics into the text.

e Page in editing mode - this is where you can view and edit the document selected in the content
tree, in the mode selected in the view mode and editing mode toolbar.

CMS Desk and Site Manager

CMS Desk allows content editors to edit content of a single website. Developers and site administrators
who need to manage settings, code and configuration of all websites, can also use the Site Manager
interface.

The Site Manager interface is accessible either through the http://<domain>/<virtualdirectory>/
KenticoCMS/CMSSiteManager URL, by clicking the Switch to Site Manager link at the top of the
CMS Desk user interface or the Sign into Site Manager link at the top of the live site. The following
figure shows how the database, Site Manager, CMS Desk and websites are related:
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CMS Desk for Site 1 CMS Desk for Site 2

Site Manager

gl —
\-————’

Kentico CMS
Database

3.2 Editing home page content

CMS Desk for Site 3

Now we will modify the home page content. Click Home in the content tree. You will see a page like this

on the right side:
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@& CMS Desk - Windows Intemet Explorer

& () = [E] hues/ftocalhost/KenticotMS/CMSDesk/default asp [ &[4 x || sing P~

J Favorites | 35 (@ Suggested Sites = @] Web Slice Gallery = 3¢ k50

& CMS Desk fii v B - ) # v Pagev Safety v Tools~ @~
-‘2'- Kentlco Switch to Site Manager Site: Corporate Site El User: Global Administrator v5.0.3632 Sign out

#4%  CMs Desk Content | Mydesk Took  Administration

[ Copy T up 'A @ E] E )}

New Delete [ Move & Down Edit Preview Live site List Search
Content management View mode Other
5] -‘_{" Corporate Site Page Design Form Properties
ES _, Home
(-] Services E Save Eﬁ Spell check

(#)-1.] Products S 5 B
Source | [&, 2 & [#42|BE SiB £ U s
IBO=9& =0 Elow 8

yle - | Fomat - | Fort - Size

(-] News

(&) ] Partners
()-[] Company

-] Blogs

(- [ Forums
[#)-|] Events

_;; _, Images
(#-[] wiki

#)-.| Examples
+)-5 Special pages
(+-5) Images

T

‘ Newsletter subscription

{ First N NEW/S MEM. ¥ OU CaN USE VWY 2y ¥

| First Name: j )

i i |This is a sample web site created with Kentico CMS for ASP.NET_| | || ‘::QD;:;:;Tsl;r::aix‘\:‘:ﬁ‘:m!l?i:"d
| Last Name: " [You can use it as a starter kit for your own web site and to learn [ ———

| E-mail- | Kentico CMS. Your first news

[“subscribe | . . i 110:2008
. Default user name and password -

o,

Do you like our product?

i
)
g
i

25
3
g
7
5
2
3
g
=l

iy
B

IYou can sign in to CMS Desk (the administration interface) using [

he link at the top of the page or by going to the following address '
ittp://localhost/KenticoCMS/CMSDesk (if you're using the default
stallation path). Use the following credentials:

| © ves. 1 do.

| S 25

H=y § {User name: administrator L m
—— P d: Leave the blank. . 2
| ] - L =

€& Local intranet | Protected Mode: Off & v H100% -

The page is now displayed in the editing mode with editable region. Delete all content from the editable
region and enter the following text:

This is my first text.

You can then use the WYSIWYG editor toolbar at the top of the page to change the formatting of the
text like this:

This is my first text.

Click the Save button at the top of the page or press CTRL+S to save the changes.

Now click the Live site button in the main toolbar. You will see the modified version of the home page
as it's displayed to the site visitors.

Preview mode
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3.3

If you click the Preview mode now, it will display the same content as the Live site
mode. It works as a preview mode only if you set up workflow. Then, you can preview
the latest modifications before they are published.

Creating a new page

Now we will create a new page under the Senices section. Click Edit in main toolbar to switch back to
the editing mode.Click Services in the content tree. Click New in the main toolbar. You will see the
following dialog that allows you to select the type of the document you want to create under the currently

selected document:

New document

Please select new document type:

[ Page (menu item)

= Article

] Blog

5 Cell phone
P Event

Ifg Event (booking system)

@Fa0
HEie

i) Folder

Image gallery
& Job opening

&» Knowledge base article

& Laptop

@, Office
@eoa

(3! Press release
Ej Product

| Simple article

£ Link an existing document

Click the Page (menu item) button. You will be redirected to the new page properties dialog.

Enter System Integration in the Page name field and choose the Templates with editable regions ->

Header and text with left menu template:
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22 Kentico
F4% CMS Desk

Content My desk Tools Administration
) ey e @ @ =
New Delete |= Move & pown Edit Preview Live site List
Content management View mode
26 Corporate Site » Senices

| Home
(@1l [Services
[#]-l-] Products
-] News
[#]-l] Partners
@11 Company
(+]-l-] Blogs
(-] Forums
(#)-l2] Events
-] Images
(-] wiki
(-] Examples
(-Gl Special pages

E3] ﬁ Images

E Save E‘ Save and create another

Page name: System Integration

Switch to Site Manager

e

Search
Other

Spell check

25

Site: Corporate Site ~ User: Global Administrator v5.0.3632

@ Use page template () Inheritfrom parent page () Create a blank page

=5 Al page templates
&) Articles
-4 Blank pages for widgets
= Blogs
&) Corporate Site ASPX
&) E-commerce
) Events
& FAQs
&) Forums
&) General
d Home pages
iﬂ Images
-3 Job openings
= Knowledge base
o] Master templates
= Membership and security
- Message boards
&) News
i) Newsletter
& offices
) Press releases
& Products
o] Templates with editable regio
& wiki

Template name:

Header and text

Simple text

12

Search

Header and text with
left menu

Header, text region Left menu, right text

Simple text with left
menu

Simple text with left
menu (personalised)

Simple text, page
placeholder and left
menu

Header and text with left menu

Displays header and text region with menu on the left.

Sign out

m

Click Save to create the new page. The page is now created in the content tree and you can edit page
content on the right. Enter some text in the editable regions and click Save.

© 2011 Kentico Software




26

Kentico CMS 5.5 R2 Tutorial

& CMS Desk - Windows Internet Explorer =

()= [ hi/tacalhost/KenticoThs/ ChsDesk/defaultasp -[&]4 | x| aing p -
S Favorites | 5l3 @ Suggested Sites v @] Web Slice Gallery v 32 k50

@ CMS Desk B - v [ @ v Pagev Safety~ Took~ @+
.‘!,- Kentico Switch to Site Manager  Site: | Corporate Site [+] user: Global Administrator v5.0.3632 Sign out
#% CMS Desk Content | Mydesk  Tools  Administration

7;‘ [ Copy T up 2 @ [@] = )D @

New Delete hMove & Down | | Edit  Preview Liveste List | Search |

Content management View mode || other

=

12 ) Corporate Site Page | Design Form  Properties @
|1 Home -
5] Services E Save @ Spell check

: J System Integration
.[1] web Design
g _I Web Development
“.[] Network Administration
(-] Products
-] News
(- Partners al .
obal Administrator (administrator) m

1] company com panyLogo & Shopping cart | My account | By wishiist

(-1l Blogs
(+)-.] Forums
-] Events
-] Images
(-1 wiki Home v Products  News Partners Company Blogs Forums Events  Images Wiki Examples
(-] Examples

() %3] Special pages
(-5 Images

Source | [& 1 % B | &Gt o [ 2L El £iB I U sk o
JEO=ZQ &S 08olwld
£ Shle ~ | Fomat ~| Fort | Size ~E Ty dm-E 0 [

Sign in to CMS Desk. Sign in to CMS Site Manager. The default t is admi with blank password. —

Your shopping csrt is empty

Search for:

‘
” # System Integration Senices > System Integration
* Web Design

m

* Web Development

* Network Administration

{We provide system integration senices. =

€ Local intranet | Protected Mode: Off v H10% v

Now you may want to change the order of the items in the left menu. Click the Down button in the main
toolbar three times. The System Integration item is mowved at the bottom of the section:

L

Services

-] web Design

I_] Web Development
I_] MNetwork Administration
.|| System Integration

Click Live site in the main toolbar. You will see your new page as it is displayed to site visitors. Please
note that the System Integration item is placed at the end of the left menu as you specified:
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Companylogo

Home v Products News Partners

Company

* Web Design Senices > System Integration

* Web Development

* MNetwork Administration

# System Integration

We provide system integration senices.

You have learned how to create a new page based on a pre-defined page template.

3.4 Inserting an image

Now we will upload and insert a new image to our new page. Click Services -> System Integration in
the content tree. Switch to the Edit -> Page mode.Place the cursor into the main editable region, just
below the text, and click the Quickly insert image (&) in the WYSIWYG editor toolbar.

The browser's Choose file dialog opens. Locate some suitable image file and click Open.

& Choose File to Upload

@uv|5| » Libraries » Pictures »

Organize = Mew folder
-
- Favorites N
‘ Includes: 2 locations

Bl Desktop
& Downloads

‘ Pictures library

. | Sample Pictures
= Recent Places |m|
4 Libraries
3 Documents
J‘- Music
=/ Pictures
=| My Pictures
J Public Pictures
B2 Videos

1M Computer
£, Local Disk (C)

File name: computer

[t
- | ‘yl | Search Pictures 2|
#~- 0 @
Arrange by:  Folder v
- | AllFiles (=) v
[ Open |V] [ Cancel ]

The image will be pasted to the editable region so that the page looks like this:
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3.5

2Y2 Kentico

#gS  CMS Desk

A copy

= Move

Content

i up
Qv Down

Content management

My desk

x

New Delete

|:'|1_:_"J Corporate Site
i~[] Home
G- services
._I Web Design
._I Web Development
“[1] Network Administration
...| ||System Integration
| Products
] News
| Partners
| Company
| Blogs
| Forums
| Events
| Images
1 wiki
| Examples

I 7 O ) [ ) o) ) [ [

]

ﬂf_;' Special pages

-5 Images

Switch to Site Manager

Tools Administration
(4 [d = ~r
Edit Preview Live site List Search
View mode Other
Page Design Form Properties
E Save @ Spell check
{[E Souce | (& § F=s | ¢4 25| Bl ~2iB 2
BRI Si0I0I0Iw|8
‘ Style = | Format = | Font - | Size

Companylogo

Home

Products

News Partners Company B

* VWeb Design

* VWeb Development

* Metwork Administration

Senices > System Integration

@ System Integration

We provide system integration services.

Click Save to save the changes. Click Live site to see the new version of your page.

You have learned how to upload an image and insert it into the text.

affected by this.

Allowing pop-ups for the website

If you are using a pop-up blocker, you may need to allow pop-up windows in your
browser so that the Web part properties dialog as well as some other dialogs work
correctly. This applies only to the administration interface, so the site visitors are not

Creating a link

Now we will create a link between the Services page and our System Integration page. Click Services
in the content tree and make sure you have the Edit -> Page mode selected.

Add a new item in the bulleted list called System integration:
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Semnices

———————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————

[We provide professional semrvices in the following areas: -

= Web development

= Web design

= Network administration
= System integration

|This is a simple page with leff menu and content on the right. You can create links similar fo those above using the
\Insert/Edit Link button in the editor toolbar.

Select the whole line:

Semnices

———————————————————————————————————————————————————————————————————————————————————————————————————————————————————————————

We provide professional semvices in the following areas: - |
d

+ Web development
+ Web design
= MNetwork administration

Ll System integration

|This is & simple page with left menu and content on the right. You can create links similar to those above using the
\Insert/Edit Link button in the edifor toolbar.

And click the Insert/Edit Link () button in the WYSIWYG editor toolbar.

The Insert link dialog opens.
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2] Insert -- Webpage Dialog

D Insertlink

Attachments Content Media libraries Web Anchor E-mail

[:.ﬂ New folder D. New file =] ust Tiles [£5] Thumbnails

site: | Corporate Site = General Target  Advanced
Protocol:  URL:

5 g Corparate Site (other) El /KenticoCMS/Services/System-Integration_aspx

[ Home
= a Services
: :] Web Design
D Web Development
<[] Network Administration
ll System Integration
| Products
a News
a Partners
a Company
a Blogs
a Forums
a Events
a Images H
a Wiki
a Examples
(+]-C Special pages
(). Images

B -G E-E GG BB BB e e s

http://lecalhost/KenticoCMS/CMSFermControls/Selectors/InsertlmageOrMedia/ Default aspxfoutput=htmi&amp;link=18&amp;documentid=5&amp;pare G Local intranet | Protected Mode: Off

Switch to the Content tab, select the Services -> System Integration page from the content tree and

click Insert.

The text is now marked as a link:

Senices

We provide professional services in the following areas:

+ Web development
» Web design
= MNetwork administration

= System integration

insert/Edit Link button in the editor toolbar.

This is & simple page with left menu and content on the nght. You can create links similar fo those above using the

Click Save and choose the Live site mode. When you click the System integration link now, you are

redirected to the new page.
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You hawe learned how to create a link between pages.

3.6 Creating a news item

Now you will learn how to create a news item. Click Edit in the main toolbar. Click News in the content
tree and click New. Choose to create a new document of type News. You are redirected to the form that

allows you to define news item sections: title, summary, full text and release date. Enter the following
text:

e News title: My first news

e Release date: click Now

e News summary: Some summary text.
e News text: Some news text.

Click Save to sawe the new document.

Switch to Site Manager Site: Corporate Site
232 Kentico ” =
“1%  CMS Desk Content | Mydesk  Tools  Administration
B Fooy e (4  [d
New Delete = Move & Down ‘ Edit Preview Live site List ‘ Search |
Content management | View mode | &'
J € Corporate Site Page  Design | Form | Properties
l_] Home
@ [ services E Save |ZE. Spell check
&[] Products : - o : T
5B News Souce | [& § =H @445 Bl £iB I U ae|x & (iZ T
{37 My first news =0 [T R E=H= =N AR
; Your first news | sl - | Farmat | Fant - Size -l Iy &
“..{Tf Your second news
=J-L] Partners
‘—_‘ ‘—] News Title: My first news
(=)L Company
¢A|_| Blogs Release Date:  |12/11/2009 B Now
= l_] Forums [Some summary text
= l_] Events
= ,_] Images
=1 wiki

=[] Examples
(+)-"4) Special pages
(-5 Images

[y

News Summary:

Some news text

As you can see, the editing mode is now set to Form instead of Page. It means you do not edit the
editable regions on the page, but you edit the structured data related to the document. The Form tab is
used for editing the structured data related to the document. The document fields are fully
customizable for every document type.

When you click Live site, you will see the news item displayed using a pre-defined transformation in
both News and News -> My first news page:

© 2011 Kentico Software



32 Kentico CMS 5.5 R2 Tutorial

Companylogo

Home  Services Products Partners~ Company

News = My first news

1211172009

Some summary text

Some news text

You hawe learned how to add a news item and how to use the editing form for structured documents.

Page versus Form

There are two faces of document: content stored in editable regions on the page and
data stored in form fields. The following table compares both approaches:

Editable regions Form
on the page
Content structure | Simple content structure, Complex content structure,
only text content. typed data, such as text,
date-time, numbers, etc.
Validation Only basic validation rules | Complex validation rules,
for minimum and maximum | including regular expressions
length. and custom form controls

with custom validation code.

Display The content is displayed in | The content is displayed
the context of the page as it |using XSLT or ASCX
is displayed in the editing transformations using

mode. special controls or web
parts.
Storage The content is stored in a The content is stored in a
single XML document in the |separate database table.
document properties. Each field has its own

column. The data can be
easily modified using SQL
queries or API.

Examples of use. | Home page, contact page. |[News, product specification,
event details, job opening,
Generally: pages with etc.
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simply structured or
unstructured text-based
content.

The editable regions are
usually used for documents
of type Page (menu item).

Generally: pages with
structured content where you
need to separate content
from design and keep the
content in its original data

type.

The form-based content is
usually used for documents
of type News, Product,
Article, etc.

© 2011 Kentico Software




Site Develogm ent Overview



Site Development Overview 35

4 Site Development Overview

4.1  Site Development Overview

Kentico CMS provides two development models and you can choose which one suits you better:
e Portal Engine - this model allows you to build websites using a portal engine. It's the recommended

way for most developers since it doesn't require programming and using Visual Studio. You can easily
build websites using web parts in the browser-based user interface.

Page Design Farm Properties

Sign in to CMS Desk. Sign in to CMS Site Manager. The de

Companylogo

Home  Services du News Partners  Company Blogs

= [Products - page template: Proeduct multicolumn view with left menu

v zonelLeft gp||= zoneRight

¥ LeftTreeMenu @ _____________________________ |' ProductBreadcrumbs @|
® PDAs v PrintLink (&

*® Laptops —
|' ProductDatalist "g:!l

a

Q \

e ASPX Templates - this model can be chosen by advanced ASP.NET dewelopers who prefer to create
the website using standard ASP.NET architecture and using standard development tools, such as
Visual Studio. You need to be familiar with ASP.NET development and have at least basic

programming knowledge of C# or VB.NET.

. CMSTemplates/Co...spx/Images.aspx

Root.ma

SeriptManager - manScript
[ CMSPageManager Control - ctl00_CMSPageManager] ]

Sign in to CMS Desk. Sign in to CMS Site Manager The default account is administrator with blank password

[inkHome]
[ Literal "rDivOpen" ] [ Literal "tiHyperlinks" ] [ Literal "lrDivClose” |

[btnSignOut] [btaSignOutLink]

[blLabel] [ Literal "ltrSignLink" ]
[ Literal "HRTLFix" ] 3| |

—

pletain (Custom)jontrol : cmsmenu menuFlem table |
[ CMSBreadCrumbs "bcElem” | L

{~

‘CMSRepeater - ListOfGalleries

Switch to source view to edit the control's templates.

Site map | Disclaimer
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Both approaches are fully supported and they provide the same lewel of flexibility and extensibility. We
recommend that you use the portal engine model, but if you are a hard-core .NET developer and do not
trust portal engines, you may want to use ASPX templates.

Both models can be combined in a single website and you can e.g. enhance the portal engine website
with ASPX templates or even with your own ASPX pages and integrate your own applications.

The following table compares both portal engine and ASPX templates:

Portal Engine

ASPX Template

How you work

You build website using the browser-
based interface.

No programming knowledge is required
for common tasks.

You build ASPX page templates that
are used to display content from
Kentico CMS.

At least basic programming
knowledge of ASP.NET and either C#
or VB.NET is required.

How you assemble
pages

You use built-in or custom web parts
that you place into customizable page
layouts.

You use built-in or custom

ASP.NET sener controls that are
placed on the ASPX pages. These are
standard ASPX pages and they are
part of the website project that you
can open in Visual Studio.

You can also place web parts (which
are actually standard ASCX user
controls) on the page templates if the
functionality is not available as a
senver control.

Master pages and
visual inheritance

Sub-pages inherit the content from the
parent pages by default (so called
"visual inheritance"). The inheritance
can be optionally broken if you want to
create a page without parent content.

All page templates ((ASPX pages)
may use a master page, which is a
standard ASP.NET 2.0 master page (.
master page).

The pages do not inherit content from
their parents, they only inherit content
from the master page (if it's used).

Custom code
integration and
extensibility

You can create your own user controls
and web parts if you need to integrate
a specific functionality.

You can add any custom controls and
code to the web parts or user controls
that you use on your website.

You can also use standard ASPX
pages within your portal engine-based
website.

You build standard ASPX pages with
code-behind which means you can
use any custom controls and code on
the page in Visual Studio.

Advantages

e Easier and faster way of building a
website.
e ASP.NET programming knowledge

e Standard ASP.NET architecture.
e You can use your favorite
development tools, such as Visual
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is not required for common tasks. Studio for all changes.
e You can build the whole website
very quickly, only using the web

browser.
Disadvantages e Proprietary architecture and e Requires ASP.NET programming
development. knowledge.

Is Kentico CMS just another portal engine?

Now you may ask what's the difference between Kentico CMS and DotNetNuke or
SharePoint.

Well, the main difference is the flexibility. Kentico CMS gives you full control over:

e site structure

e site navigation

e page layout

e design

e content structure

Also, it's important to explain that Kentico CMS is a content management system,
not only a portal engine. It provides features of advanced CMS systems, such as:

e content repository with a logical tree hierarchy of documents
e content/design separation

e custom document types with custom fields

e workflow and versioning

e content locking (check-out, check-in)

e multilingual content

e content preview and content staging

e document-level permissions with permission inheritance

e full-text search in all content

e document management features for uploaded files

Moreover, Kentico CMS comes with many professional and flexible built-in
modules out-of-the-box, including Newsletters, On-line forms, Forums, E-commerce,
Content Staging, Image gallery, Event calendar, Booking system, Blogs, Polls and
others

It means you do not need to purchase third-party modules with inconsistent user and
programming interface, but you get everything from a single source, with a complete
documentation.

The rest of this tutorial explains the portal engine approach. If you want to use the portal engine, please
read the Tutorial for portal engine.
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5.1

Creating pages using the portal engine

Page templates

Kentico CMS portal engine provides a highly flexible and extensible framework that allows you to build
complex dynamic websites using built-in and custom web parts. This chapter explains how the portal
engine works.

What is a page template?
Every web page is based on some page template. The page template can be specific for a single page

(so called "ad hoc" page template) or it can be re-used for several pages. The following picture shows an
example of two pages that use the same page template:

obal \l Sion out |
CompanylLogo O et et

“Your shopping cart is empty

Search for

Products News Partners Company Blogs Forums Events Images Wiki Examples

 Web Design Senices > Web Development

* Web Development
* Network Administration

We provide web development senices

You can insert images into the fext using the Insert/Edit
Image button in the editor toalbar. Click Browse server
button and choose the Images folder. You can choose
from uploaded images or upload a new one from your
computer.

Global i 'l Sign out |
Companylogo @ Shongiog con | My sccun | My wihis
You shosping cert is mpty
Search for
Home WSEMICESN Products News Parners Company Blogs Forums —Events ges Wiki Examples
* Web Design Senices > Web Design
* Web Development
I« tvorc Adminisuraion
7 We provide web design services.

s "
7:: Kentico

As you can see, both of them use the same header, main menu, sub-menu, content structure and footer
- they are based on the same page template. In this way, you can create multiple pages using the
same design.

What does a page template consist of?

The page template is a combination of page layout (HTML code) and web parts. The following figure
illustrates the structure of the page template and how it's used to display a page:
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<table>

zoneleft zoneRight
<tr>
<td>
ccl:CMSWebPartZone |ID="zonelLeft" runat="server" />
<ftd> —
<td=> -
<cc1:CMSWebPartZone ID="zoneRight” runat="server” />
<ftd=>
</tr>
<ftable>
Web part 2
Web part 1
Web part 3
zoneleft zoneRight

Web part 1

Web part 2
Web part 3

Customizable HTML
layout specifying the
design and web part
zones where web parts
can be placed

Web parts with their
settings

Page template

layout + web parts

Page-specific content

Page

page template + content

As you can see, the page layout is a simple, fully customizable HTML code that defines the design of
the page and it contains web part zones. The web part zones can contain web parts. The web parts
display page content or provide some functionality, such as input form. The layout and the web parts
together define the page template.
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When you add page specific content to the page template, you get the final page.

5.2

Modifying a page template

Now you will learn how to modify the page template. Click the Home page and switch to the Design
tab. You will see the structure of the home page template.The main logo and main menu are inherited
from the root page. The "active" part marked with a green box contains the orange web part zones and

blue web parts:

Active

page
template

\

Web part
zone

Inherited
content

Global Administrator (administrator) m
COITI [ I'IYLOQO & Shopping cart | My account | My wishlist

Services

Products

News  Partners

Company Blogs Forums Events

Images Wik

‘Your shopping cant is empty

Search for:

Examples

~ [Home - page template: Home page with top image and three columns

=-ZoneTop

= Editablelmage &3

v WidgetActions {3

* statichtml {3

v '] zonel eft qp| | zoneCenter | [* T)zoneRight i
- 'g_u.aws\ettarSubscmptmn Q- " MainContentText ;ﬂ = 'ﬂScmllmgNews Lg)

Web part

ﬁt Name:
Last Name:

E-mail:

IThis is a sample web site created with Kentico CMS for ASP.NET.
[You can use it as a starter kit for your own web site and to leam
Kentico CMS

Default user name and password

Your first news
111012008

Here you can enter the summary of the
news ftem. You can use WYSIWYG
edttor to format the text, insert links and
images. The summary wil be used in
news item nreyvis

The page is based on the page template Home page with top image and three columns. The page
template consists of web parts that are placed inside web part zones. The web part zones are
organized in the page layout (HTML layout) that specifies the placement of the zones within the page.

When you click the Edit layout () button in the green header of the active page template, you can edit

the page layout:
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5.3

Page Design Faorm Properties Display web part content \(:

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is ini with blank p.

G Page layout @

E Save fai' Check out

Check out the layout to file c:\Inetpublwwwroot\KenticoCM S\CM STemplateLayouts\cmsihomepagewithtopimageand3cols.ascx to edit the layout externally.

Use the following expression to add a new web part zone: <cc1:CMSWebPartZone ID="zoneTopRight" runat="semer" /=
(the ID must be unigue within page layout)

<div class="homeTopImage3cols"> -
<!-- Top image --»
<div class="zoneTop">
<ccl:CMSWebPartZone ID="zoneTop" runat="server" />
</div>
<!-- Left column -->
<div class="zoneleft" =tyle="flpat: left;">
<occl:CMSWebPartZone ID="zoneLeft" runat="server" />
</div>
<!-- Center column -->
<div class="zoneCenter" style="float: left;">
<ccl:CMSWebPartZone ID="zoneCenter" runat="server" />
</div>
<!-— Right column -->
<div class="zoneRight" style="float: left;">
<ccl:CMSWebPartZone ID="zoneRight" runat="server" />
</div>
<div style="clear:both;line-height:0px;height:0px;" ></div>
</div>

As you can see, the page layout is a simple HTML (or rather ASPX) code that contains controls called
CMSWebPartZone. Each of them must have a unique ID. You can also see that you can use any
HTML code for page formatting - it's up to you whether you use tables or CSS layout.

Editing the layout using an external editor

You can check out the file to the disk using the Check out to file button, edit it using Visual Studio or
some other editor and then check it in.

Access control

The document can be opened in the Design tab only by user who is marked as a
global administrator or the Desigh website permission for the CMS Content module
is granted to them. It cannot be accessed by content editors.

Modifying the home page structure

Now you will learn how you can modify the home page structure. We will replace the polls on the left
with a static text.

Click Home in the content tree and click the Design tab. We will add another web part to the
zoneCenter web part zone. Click the Add web part (4) icon in the top right corner of the zone.
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d B =

Edit Preview Live site List
iew mode
Page Design Form Properties

¥ WidgetActions

j)

Search

Other

Display web part content

v 0] zonelLeft op

= zoneCenter

= 0] zoneRight

#]

= 0] NewsletterSubscription (&3

|' MainContentText %::y}|

First Mame:
Last Name:

E-mail-

[ stscibe |

Kentico CMS.

Default user name and password

This is a sample web site created with Kentico CMS for ASP.NET.
You can use it as a starter kit for your own web site and to leam

You can sion in tn CMS Desk (the administration interface) usina the

= ¥] ScrollingNews
Your second news
115/2008

Here you can enter the summary of the
news item. You can use WYSMYG
editor to format the text, insert links and
images. The summary wil be used in
news item nreview

The Select web part dialog opens. Choose the General -> Date & time web part and click OK.

#] Select web part -- Webpage Dialog

o selectweb part

Ja Recently used web parts
=% All web parts
) Abuse report
-5 Articles
-5 Attachments

=
-3 BizForms

73 Blogs
-.i5) Booking system
=]

(x5 Community

- ‘.f: Community services

) Content rating

=)

Custom tables
-] Data sources
=Y
E-commerce
.5

= Events

J Forums
Full-text search
General

Google services
Listings and viewers
Media

Media library
Membership
Message board
Messaging
Navigation
News

J Newsletters

Ty TITITY

I Notifications

J Polls

) Reporting

Silverlight

= Tagaging & categories
i Text

User contributions
Web services

-] Widgets

Web part name:

Filter

Date & time

Language selection
with flags

Page placeholder

Date & time

Displays current date and time.

http://localhost/KenticoCMS_2212/CMSModules/PortalEngine/Ul/Webparts/WebPartSelector.aspx

<head>

</head>

Head HTML code

Vs
-

I|:

Powered by Kentico

[ Search |
S

Java script

Language selection

User control

S

€& Local intranet | Protected Mode: Off
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The web part is added to the web part zone and the Web part properties dialog opens. Enter the

following values:

e Web part container: Black box

e \Web part container title: The current time is:

The dialog now looks like this:

-
& | CMS Desk - Web Part properties - Webpage Dialog

25

General Layout
Default

Visibility

General

HTML Envelope
AJAX

Time zones

Partial caching

Refresh content

Q Web part properties (Date & time)

General

Use server time:

Date and time format:

HTML Envelope

Web part container:

Web part container title:

Content before:

Content after:

AJAX

Use update panel:

a

dd.mm.yy HH:MM:ss

Black box

The current time is:

il

LY
@ Documentation

m

1 »

http://lecalhost/KenticoCM5_2212/CMSModules/PortalEngine/UL'Webparts/WebPartPropertic € Local intranet | Protected Mode: Off

Click OK to sawve changes. Click Live site in the main toolbar and see the new design of the home

page:
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First Name: Your second news
Last Mame: This is a sample web site created with Kentico CMS for ASP.NET. 1115/2008
E—. You can use it as a starter kit for your own web site and to leamn T DT e e T
) Kentico CMS. news item. You can use WYSIMYG
editor to format the text, insert links and
Default user name and password images. The summary will be used in
news item nreview
You can sign in to CMS Desk (the administration interface) using the
Do you like our product? link at the top of the page or by going to the following address
_ http:/flocalhost/KenticoCMS/CMSDesk  (if you're using the default
I'-'YES- | de. 2 installation path). Use the following credentials:
/]
© N, 1 don't User name: administrator
- ! Password: Leave the password blank.
'_!'1 don’t know your product.
= l Getting Started
E Price:
Kentico CMS Tutorial will guide you through Kentico CMS. You can also $490.00

get help at http-//www.kentico.com/Support. aspx.

The current time is:
22.12.09 14:00:41

You hawve learned how to modify the structure of an existing page template and how to work with web

parts.

l‘\-"‘.‘

Tip: Testing the changes without switching to the view mode

You can quickly test the changes you make to the web part values by opening/
refreshing the website in a new browser window. However, you will need to use a
different browser (e.g. IE for design and FireFox for testing) since the view mode is
stored in cookies (if you use different browsers, they use different cookies).

It's also useful to use tabbed browsing support in IE 7.0 and Firefox for easy switching
between the CMS Desk and Site Manager interface.

5.4

Creating a new page template

Now you will learn how to create a new page from scratch without using a pre-defined page template.
We will create a new About Us page with two columns that will contain editable regions.

Click the root in the content tree and and click New. Choose to create a new Page (menu item).

Enter the page name About Us and choose to create a blank page using the Two columns layout.
Make sure that the Copy this layout to my page template box is checked - it will ensure that your
page template can use a modified version of the pre-defined layout without modifying other pages.
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Corporate Site

E Save F Save and create another

f%' Spell check

Page name: |About us
() Use page template () Inheritfrom parent page @ Create a blank page

Layout name:

il

|

Grid 2x2 cells Grid 2x2 cells (C5S5) Grid 3x2 cells Grid 3x2 cells (C5S) Simple

Three columns Three columns (CSS) Top row, three columns, Top row, two columns, Two columns
bottom row bottom row

12

Two columns

Two columns with web partzones.

Copy this layout to my page template

Click Save to create the new page. Use the Down (#) button to move the page to the bottom of the
content tree.

The page cannot be edited now since it doesn't contain any editable regions. We will add an editable

image region on the left and two editable regions on the right. Switch to the Design tab and click the
Add web part (%) icon in the zoneLeft web part zone.

Choose the Text -> Editable image web part and click OK.
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] Select web part - Webpage Dialog e

s Select web part

&8 Recently used web parts Web part name: ﬁ

5G] All web parts

) Abuse report

) Articles ; = 2 = e
& : - = ==
) Attachments ﬁ BV = — —
.- BizForms 5 == —— =
Blogs
Editable image Editable text Paged text Static HTML Static text

Booking system
| Community
Community services
Content rating
Custom tables

Data sources
il E-commerce
Events

&
=l

=)

=l

S

o=

G

el

)

=l

=

&

)

=l

=)

=l

=)

&=

G

3 Forums

el

@ Full-text search
& General

i) Google services
& Listings and viewers
& Media

& Media library

3 Membership

& Message board
& Messaging

4 Navigation

’S‘ News

& Newsletters

5 Notifications

o
=
&5
&
&
G
QY
@
)

| Polls
£ Reporting

Silverlight

Tagging & categories
Text

User contributions Editable image
Web services

= Widgets The Editable text web part displays an editable region that contains single image.

=
&
&
=
&

http://localhost/KenticoCMS/CMSModules/PortalEngine/Ul/Webparts/\WebPartSelector.aspx € Local intranet | Protected Mode: Off

Set the following values:

e Web part control ID: Leftimage
¢ Image title: Left image

Add another web part to the zoneRight zone: Choose the Text -> Editable text web part and click OK.
Set the following property values:

Web part control ID: HeaderText
Editable region title: Header
Editable region type: Text box
Content before: <hl>

Content after: </h1>

Click OK. Add another Editable text web part to the right web part zone and set the following
properties:

Web part control ID: MainText
Editable region title: Main text
Editable region type: HTML Editor
Editable region width: (leave empty)
Editable region height: 400
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Switch to the Page tab and you will see a page with editable regions like this:

Page Design Farm Properties

E Save ;:_: Spell check

£ ElSouce | [§ 2 | & [#8 25 B £ iB I U ae|x x iz =[5 4F = &
iReD=0@9 S o|x ¥
‘E Style ~ | Farmat - | Font - | Size vE g dgE &,

with blank p d.

C L Global Administrator (administratar)
om pany ogo &} Shopping cart | My account | My wishlist
Your shopping cart is empty

Search for:

Sign in to CM S Desk. Sign in to CMS Site Manager. The default account is

Forums  Events Images Wiki Examples

Home  Services  Products News Partners Company Blogs

| Main Text ]
~|

Now you can enter some content and choose some image using the Select button. Click Save and
view the page in the Live site mode:

C L Global Administrator (administrator) l;l
om pany ogo ! Shopping cart | My account | My wishlist
“Your shopping cart is empty

Search for:

Events  Images Wiki Examples

Home  Services Prod News  Partners Compa Blogs  Forums

Qur company was founded in...

W rocnoe
-,:: Kentico
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Congratulations, you hawe just created your first page template using web parts.

5.5 Re-using the page template

In the previous chapter, you have learned how to create a new page with its own, page-specific page
template. This type of page template is called an ad-hoc page template.

Now, you will learn how to convert the page-specific page template into a re-usable page template
that can be used for several pages with the same layout, but different content.

Go to CMS Desk -> Content. Click the new About Us page and switch to the Properties tab. Click
Template. Now you can see a dialog like this:

Page Design

General
URLs
Template
Metadata
Cakegoaries
Menu
WarkFlow
Versions
Related docs
Linked daocs
Securiky

Aktachments

Properties

[ 2=

Termplate
Ad-hoc: About us

.'-__ 7
/=g Bave as new template. .
[ Save as new femplate..

-Q{ Inherit terplate

E Edit template properties

Inherit content
@ Use page template settings
@ Do notinherit any content
() Inhetit only master page
(7 Selectinherited levals

Click Save as new template and enter the following values:

Template display name: Left image with text on the right

Template code name: LeftimageWithRightText

Template category: Templates with editable regions

Template description: Two columns with image on the left and text on the right.
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e Page template - Save as new -- Webpage Dialog @

_% Save as new page template

Template display name: |Left image with text on the right
Template code name: LeftimageWithRightText
Template category: Templates with editable regions -

Two columns with image on the e
left and text on the right.

Template description:

http://localk Q Local intranet | Protected Made: Off

Click OK and click Save on the Template dialog. The dialog now looks like this:

Page Design Faorm Properties

General
LRLs E Saie
Template
Metadata Termplate
Categaries Left irmage with text on the right ﬁ
Menu .
ol .ai: Save as new template...
Wersions Q: Inhetit ternplate
Related docs )
L .3:! Clone ternplate as ad-hoc
Security G Edit ternplate properties
attachments
Inherit content
@ Use page ternplate settings
) Do notinherit any content
) Inherit anly master page
(7 Selectinherited levels

You hawe just created a new re-usable page template. If you try to create a new page now, the page
template will be offered and you can create another page with the same structure as the About Us page.

Modifying shared page templates

Please note that when you modify the re-usable page template, the changes will affect
all pages that use this page template!
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Important!

Please keep in mind that when you create a page based on an ad-hoc page template
and later delete the page, the corresponding ad-hoc page template is deleted too and
can not be restored.

5.6 Visual inheritance

The content of sub-pages is displayed using page placeholder web parts. The impact of this approach
is that the sub-page content is "nested" inside the content of upper pages. The following picture shows
the root (master page) without nested content:

22 Kentico
#1% CMS Desk

7 Copy

New Delete |= Move

Content management View mode Other

|zl 7 Corporate Site
+ [ Home
(- [ services
®- || Products
(-1 News
(2-11 Partners
® || Company
&[] Blogs
®- || Forums
@[ Events
(#-[-] 1Images
(-1 iki
(2-1] Examples
[ About us
(i) Special pages
(-5 Images

Switch to Site Manager  Site: Corporate Site ~ User: Global Administrator v5.0.3635 Sign out

Content My desk Tools Administration

Ui Z & & =2 | L ¢

& pown Edit Preview Live site List Search

Page | Design Form  Masterpage  Properties

E Save ;'-% Spell check

Sign in to CMS Desk. Sign in o CMS Site Manager. The default account is administrator with blank password.

Global Administrator (administrator) ;l

e Shopping cart | My account | My wishlist
Your shopping cart is empty

LU LT PR PR ST SR SR : Search for:

Home —Services  Products News Partners Company Blogs Forums  Events Images Wiki Examples  Aboutus

... and here's the home page nested inside the master page:

)

=

©f

i
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_)!'_ Kentico

1% CMS Desk Content | Mydesk  Tools  Administration
e dw i [ =
New Delete |=bMove & Down Edit  Preview Livesite  List
Content management View mode
=% ) Corporate Site Page Design Form Properties

+[H[Home

® __. Services
(#1-|-] Products
@] News
#-[] Partners
(-] Company

Spell check

[=] Source | (&, § | &
SO =0 &35!

Style - | Format

Switch to Site Manager  Site: Corporate Site

):)

Search

Other

[da 2k | E & ¢

[Blels|

~| Font ~| Size o[ T Py

User: Global Administrator v5.0.3635 Sign out

of ©

-] Blogs

® || Forums

-1 Events

®- | Images

[ wiki

| Examples
-] About us

- Special pages
(+-3) Images

Please note how the pages are structured in

(This is a sample web site created with Kentico CMS for ASP.NET_
ou can use it as a starter kit for your own web site and to learn
[Kentico CMS.

|Default user name and password
{You can sign in to CMS Desk (the administration interface) using

he link at the top of the page or by going to the following address
httpciflocalhost/KenticoCMS/CMSDesk (if you're using the default

linstallation path). Use the following credentials:

|User name: administrator
|Password: Leave the password blank

:Gening Started

|Kentico CMS Tutorial will guide you through Kentica CMS. You can

m

|| Your second news
1015i2008

1| Here you can enter the summary of the
| mewes item. You can use WYSIAYG
| editor to format the text, insert links and
| images. The summary will e used in

Featured product

Price:

the content tree: the root (master page) is parent of the

Home page which is loaded inside the master page. You can do the nesting recursively at any level of
the content tree. The important component of page nesting is the Page placeholder web part. This web
part must be placed in the master page and it specifies the place where the underlying page will be
inserted. The Page placeholder in the Corporate Site root loads the sub-pages between the main menu

and footer:

2 JCorporate Site Page | Design | Form  Masterpage  Properties

Display web part content

++.] Home
2 | - page template: Top logo and menu

-] Services
+ zoneTopinfo

o 1

e

|. txtTrialinfo s,:%‘!‘ Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password
| Company ~ zoneTop
-] Blogs ¥ zonelogo | " :
lar

(&)1 Forums

] Images
| wiki

v editableimage & L
| Events y ogo

lectionwithflags ’-:q?|

|| Examples
-] About us

=
(x)- <) Special pages
(#)-73] Images

¥ SignOutButton ’:a}

¥ ShoppingCartMiniPreview &l Shopping cart | My account | My wishlist

¥ SearchBox ‘,:&:!

St

Global Administrator (administrator)|

Your shopping cart is empty

Search for:

q ¥ zoneMenu

3

+ zoneContent

|' [1PagePlaceholder @}‘
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5.7 Configuring visual inheritance

In some cases, you may want to hide some parts of the parent page. There are several ways how to
achiewe that:

Using the "Inherit content” property of the page template

Click the /News page and click Properties -> Template -> Edit template properties. Now you can
set the Inherit content value to Selected inherited levels and check only the Level 1 box. It means
that only the content from first level of content hierarchy will be displayed and the master page (root) is
not inherited. Click Save to save the changes.

£ | Page Templates --YWebpage Dialog @
9

J’ Page template properties

Templates » Mews with summary

General Sites Layout weh parts Header Documents Scopes
=
. # ¥ Long
Thumbnail:
Upload:
Template type: @ Portal page ) ASPX page
Master ternplate: &
Inherit cortent; ©) Inherit all

= Do notinherit any content
) Inherit only master page
@ Selectinherited levels

m

[ Levelz
E""D Leveld
[ Levels
[ Levels
[ Level?
[ Levels -
http:fflocalhostfKenticoChS_0325/ChSModules/PortalEngine Ul € Local intranet | Protected Made: Off

The page will look like this:
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] Switch to Site Manager Site: C te Sit -
-‘.’- Ken ti.CO orporate Site
'l‘ CMS Desk Content My desk Tools Administration
Do Hup g A
New Delete |= Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other |

clb_’l Corporate Site

This page contains a list of news with a header and introductory text. The news can be displayed in multiple ways

-] services

¢|._] Products
-] [News Your second news | 1/15/2008

{&F vour first news

4 Your second news Here you can enter the summary of the news item. You can use WYSIWYG editor to farmat the text, insert lin

¢|._] Partners preview.

-] Company

(#)-|] Blogs

[©-L| Forums

|:l|_] Events Your first news | 1/10/2008
¢|._] Images

'1"—] Wiki Here you can enter the summary of the news item. You can use WYSIWYG editor to format the text, insert lin
(-] Examples preview.

-] About us

[x)-°2 Special pages

-9 Images ﬂ

=
Set the value back to inheritance from LevelO only and click Save.

Similarly, you can set the content inheritance on page level using the Properties -> Template dialog.
The content inheritance settings you configure for the page override the page template settings:

Page Design Form Properties

General
LRLs E Save
Template
Metadata Termplate
Categories MNews with summary
Menu -
wo [/ Bave as newternplate..
Versions Q Inhetit ternplate
Related docs —
Lo :FJ’ Clone termplate as ad-hoc
Security E Edit temnplate properties
Attachments
Inherit content

7 Use page template settings

= Do notinherit any content

=1 Inherit only master page

@ Selectinherited levels

..... Root

Using the "Hide on sub-pages" web part property

Every web part has a property called Hide on sub-pages. When you check the box, the web part is
hidden if some sub-page is displayed.

© 2011 Kentico Software



Creating pages using the portal engine 55

Using the "Show for document types" web part property

The Show for document types property allows you to define a list of document types for which the web
part will be displayed. Click /News, click Design and choose to Configure () the BreadCrumbs web
part. The Show for document types field contains the cms.news value. Do not make any changes and

click Cancel.

& | CMS Desk - Web Part properties -- Webpage Dialog

E=D

@/ Documentation

»

m

Soect | Clar |
Add roles

ﬂ Web part properties (Breadcrumbs)
General Layout
Default
S Default
Visibility
ConteaE Web part control ID: » |BreadCrumbs
Content filter
Web part title: 3
Design
No data behavior i i
Disable view state: r O
System settings
HTML Envelope Disable macros: r @
AJAX
Time zones
Partial caching LT
Visible: 4
Hide on subpages: [ (]
Show for document types: P [CMS.NEWS
Display to roles: 3
Refresh content
http://localhost/KenticoCMS5/CMSModules/PortalEngine/Ul/Webparts/WebPartProperties.asp €L Local intranet | Protected Mode: Off

Go to the live site, to the News page. The breadcrumbs navigation is hidden since the currently selected

document type is a page:

Home  Services Products SNEW Partners Company

This page contains a list of news with a header and introductory text. The r
part.

Your second news | 1/15/2008

Here you can enter the summary of the news item. You can use WYSIV
news item preview.
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5.8

When you go to some particular news item, the currently selected document is a news item (cms.news

document type) and the breadcrumbs navigation is displayed:

Home  Services  Products Partners Company

Mews > Your second news

111572008

Here you can enter the summary of the news item.’
images. The summary will be used in news item pre

This is the news text. It's displayed in combination with news title and s
may be displayed in various formats, with or without teaser image.

You hawe learned how to break inheritance of content and how to display content based on the current

document type.

Web part containers

The web parts can display only its own content or they can be rendered with a "container". The container

consists of HTML code that is rendered before and after the web part.

Switch to CMS Desk and click Live site. The Newsletter subscription web part uses the black

container:

With container:

First Name:
Last Mame:

E-mail:

Hewsletter subscription

Without container:

First Mame:
Last Mame:

E-mail:

The container is useful when you need to organize the page layout into separate boxes. You can choose
the web part container when you configure the web part in the Design tab.
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The containers can be edited in the Site Manager -> Development -> Web part containers section.

232 Kentico
#§% CMS Site Manager

=) Development
::? Categories
@ Countries
(j" CSS stylesheets
@ Cultures
:ﬁ'ﬂ Custom tables
l:]] Document types
Q E-mail templates
\f} Form controls
Inline controls
L’} Modules

Sites Administration Settings Development Licenses Support

Container properties

Web part containers » Black box

General Sites
Display name: Black box
Code name: BlackBox

<div class="blackBox"»
<h2 class="title">{$ContainerTitle%}</h2>
<div class="content"»

Switch to

| Notifications

E Page layouts

E Page templates
=8 Relationship names
@ System tables
\-%# Tag groups

@ Time zones

@ UI cultures —
1 Web part containers | |*
- ¢® Web parts .

Text before web part:

--[@] web templates

Widgets

[« Workflows
<fdiv>
</div>

Here's an example of the Black box container code:

Text before web part:

<di v cl ass="bl ackBox" >
<h2 class="title">{%ontainerTitle%</h2>
<di v class="content">

Text after web part:

</di v>
</ di v>

As you can see the container is a simple HTML code. It can use DIVs or a TABLE element. The {%
ContainerTitle%} expression indicates where the container title should be displayed. It's dynamically

substituted when the web part is displayed.
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5.9

Adding custom code to your web site

The easiest way how to insert custom code into the portal engine-based website is using the standard
ASCX user controls. This chapter will show you how to do that. If you are not familiar with Visual Studio
development, you can skip this chapter.

Current time example

In this example, we will create a simple user control (ASCX) using Visual Studio and integrate it into our

home page.

Open the website project using the WebProject.sIn file that is placed in the folder where you deployed
the website. Right-click the web project root in the Solution Explorer window and click the Add new

item... option. Choose to create a new Web User Control and set its name to GetTime.ascX. You can
set the programming language option to either Visual C# or Visual Basic.

Add New Item - Chinetpublwwwroot\KenticoCMS),

Templates:

E]Web Form

Li4 ADO.NET Data Service
5] AJAX Client Control
2] AJaxX Web Form

#] Class

é] Databet

|#] HTML Page

j Report

2] site Map

Al Style Sheet

5 Web Cenfiguration File
|&] XML Schema

My Templates

Visual Studic installed templates

.j Master Page

< ADQ.NET Entity Data Model
B AJAX Client Library

B3 AAX-enabled WCF Service
2] Class Diagram
"_'EDynamic Data Field
57JSeript File

/j Report Wizard

S Skin File

=] Text File

) Web Service

B XSLT File

Web Uzer Control
5] AJAX Client Behavior
[ ] AJAX Master Page
HJ Browser File

2] Crystal Report

g Generic Handler
|21 LING to SQL Classes
(= Resource File

[J SQL Server Databaze
B3 WCF Service

%3 XML File

»

m

An ASP.MET server control created using the visual designer

Mame: GetTime.ascx

Language:

Visual C#

v] [#] Place code in separate file

Select master page

Add

|| conce |

Click Add. Switch to the Design tab and drag and drop the following controls and set their properties:

Button control:
- ID: Buttonl
- Text: Get time

Label control:
- ID: Labell

- Text: <clear the value>
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Iy -GetTime.ascxl
Get time |[[ abell]

Double-click the Get time button and enter the following code to the Buttonl_Click method:

[CH]

Label 1. Text = DateTi nme. Now. ToStri ng() ;

[VB.NET]

Label 1. Text Dat eTi nme. Now. ToStri ng()

This code ensures that the label displays current date and time when the button is clicked. It's not
necessary to compile the project - the user controls are compiled at run time.

Save both the ASCX and ASCX.CS files.
Adding the user control on the page

Sign in to Kentico CMS Desk, click the Home page and click Design. Add (4F) a web part of type
General -> User control to the zoneCenter web part zone. Enter the following value into the User
control virtual path property:

~/GetTime.ascx
The ~ character represents the root of your web application. Click OK. Click the Live site mode and

now you can see the user control inserted into the page. When you click the Get time button now, the
current date and time is displayed next to the button:

12/15/2009 10-09-25 AM

User controls versus web parts

Another option how to insert custom code into the page is creating your own web part. A web part is
basically also an ASCX user control, but it inherits some standardized properties and methods from the
CMSADstractWebPart class. You will build web parts in case you need to create re-usable,
parameterized user controls. The web parts are described in the next chapter.
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6 Developing web parts

6.1 Web part development overview

Web parts allow you to add your custom .NET code inside the website. They allow you to display
content or add some functionality to your website.

A web part is a user control (ASCX) that inherits from the CMSAbstractWebPart class. You can easily
create your own web parts using Visual Studio or Visual Web Developer Express Edition.

Web parts can be managed in Site Manager -> Development -> Web parts. Each web part has the
following properties on the General tab:

Display name

The name of the web part displayed to the users.

Code name

The name of the web part used in website code.

Category

Here you can choose the category of the web part catalog where the web part is
placed.

Type

Type of the web part. There are the following types of web parts:

Standard - typical web parts displaying some content

Data source - do not display any content, only provide data to be displayed by
a connected web part

Filter - can be connected to a data source and enables users to limit the data
provided by it

File name

Contains a relative path to the user control that implements the web part. The
path starts from the CMSWebParts folder. Example:

Search/cmscompletesearchdialog.ascx

It's recommended that you organize the web parts on the disk in the same way
as in the categories.

Description

Description.

Thumbnail

Image used in the web part catalog.
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232 Kentico

#i% CMS Site Manager

=) Development

@ Categories
e Countries
- 55 stylesheets
@ Cultures
,_DH Custom tables
il Document types
ﬂ E-mail templates
: - Form controls
- 1nline controls
L’} Modules

i Notifications
.-[H page layouts

: -[@ Page templates

EE Relationship names

ﬂ System tables

# Tag groups

@ Time zones

2 Ul cultures H
Web part containers
¢ Web parts

@] web templates

g Widgets

[ workflows

Sites Administration
&8 Web parts
@ x Delete selected

| | j Export selected

Settings

@ Clone web part

[=)-%5) All web parts
3’5:. Abuse report
| Articles

el
(-5 Attachments

/ BizForms

"% BizForm (on-line form)
J Blogs

Booking system

| Community

J Community services

J Content rating

J/ Custom tables

Data sources

m

E-commerce

/| Full-text search
J General
) Google services

Development

Licenses Support

Web parts » BizForm (on-line form)

General Properties Layout Documentation

Display name: BizForm (on-line form)

Switch to CMS Desk

Code name:  BizForm
Category: BizForms
Type: Standard
File name: BizForms/bizform.ascx
The BizForm web part allows you -
to insert your own BizForm on the
Description: page.
) # 3 bizform.pna
Thumbnail:

Upload:

[ OK |

Browse...

On the Properties tab, you can define the web part properties and how they appear in the Web part
properties configuration dialog. Each web part has the following default properties that are not displayed
on this tab. These properties are created automatically when the web part is defined. Howeer, if you
define some of these properties via this tab, you can modify its default behaviour and attributes of the
property (e.g. for it not to be displayed, etc.).

Default

WebPartControllD

ID of the web part on the page.

WebPartTitle

Title of the web part displayed in CMS Desk's Design tab.

DisableViewState

Indicates if ViewState is disabled for the web part.

DisableMacros

Indicates if macro resolving is disabled for the web part.

Visibility
Visible Indicates if the web part should be displayed.
HideOnSubPages Indicates if the web part should be hidden on sub-pages.
The list of document type code names separated with a semicolon (;) for
ShowForDocumentTypes | which the web part should be displayed (if they are selected as the current
document).
DisplayToRoles The list of roles the web part should be displayed to.

HTML Envelope

Container

containers.

Container (box) displayed around the web part. This value contains the
code name of the container defined in Development -> Web part

ContainerTitle

Container title displayed if you specify the container.

© 2011 Kentico Software



Developing web parts 63

HTML content displayed before the web part. You can use it to display

ContentBefore some header or add some encapsulating code, such as <div> or <table>
element for required layout.
HTML content displayed after the web part. You can use it to close the

ContentAfter tags contained in the ContentBefore value, such as </div> or </table>
element for required layout.

AJAX

Use update panel

Indicates if AJAX UpdatePanel container is used for the web part.

Time zones

Time zone

Time zone used for the web part content.

Custom time zone

Optional custom time zone that can be used specifically only for this web
part.

Partial caching

Partial cache minutes

Number of minutes that the content of the web part remains cached for.

Partial cache
dependencies

List of cache keys on which the cached keys depend. When the cache
item changes,the cache of the web part is also deleted. Each line contains
one item.

The structure of the web part, content before/after and container is following:

Container

ContentBefore

Web part (ASCX) content

ContentAfter

Storing files related to a web part

If your web part consists of seweral files (such as ASCX controls, images, js scripts,

etc.), you should place these files in a subfolder under the folder where your main web
part ASCXfile is placed. If the name of the web part is MyWebPart.ascx, the subfolder
name must be MyWebPart_Files. It will ensure that the additional files are exported/
imported correctly when you move your website or when you distribute the web part to
other dewelopers.
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6.2

Creating a simple web part

This chapter will guide you through the process of creating a very simple "Hello world" web part that
displays a label and a button. When the button is clicked, it updates the current time displayed in the
label.

1. Open the web project in Visual Studio (or Visual Web Developer) using the WebProject.sIn file or
using File -> Open -> website in Visual Studio.

2. Right-click the CMSWebParts folder in the Solution Explorer window and choose New Folder.
Rename the folder to MyWebParts.

3. Right-click the MyWebParts folder and choose Add New Item. Choose to create a new Web User
Control and call it HelloWorld.ascx.

Solution Explorer - Selution "WebPr... » I X
a[EANER=lck
[ CMSTemplates -

- [ CMSWebParts
i~ [ AbuseReport
b~ [ Attachments
i [ BizForms
+- [ Blegs
i~ [ Community
b~ [ CommunityServices
+- [ ContentRating
i [ CustomTables
i~ [ DataSources
¢~ [ Ecommerce
e [ Events
t- [ Forums
H- [ General
b~ [ GoogleServices
H- [ Media
t- [ MediaLibrary
i [ Membership
#- [ MessageBoards
H- [ Messaging
= [ MyWebParts
o )
k- [ Mavigation
b [ MNewsletters

i T O OO et OO o OO e IO OO g O ot OO e OO DO eSO s Ot O o OO o OO = IO IO

m

[l

=

4. Display the HelloWorld control on the Design tab. Drag and drop a new Button control and a new
Label control on the form:
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ﬁ WebProject - Micresoft Visual Studio E@g

File Edit View Website Build Debug Format Table Tools Test Analyze Window Help

@'d'ﬁﬂﬁlﬁ —Jfﬁgl_ﬂ.m.v__ﬂ,lb Debug ~ Mixed Platforms vlm cmscennection -‘@ﬁ@%ma.:
_;Kl = £ = |XHTML1‘U Transitioni - |® . ! Style Application: Manual ~ Target Rule: (Mew Inline Style) - = ! (None) - (DefaultFeont) - ;
Toolbox 1 x CMSWebParts/MyW...HelloWorld.ascx ~ » | Solution Explorer - Solution 'WebPr.. » 1 X
i Standard - N2 EREE B e

Dats Button I [ [ CMSTemplates -
Validation 5 5 CMSWebParts

Navigation Label ¢ [ AbuseReport

Login - [ Attachments

WebParts . [ BizForms

AJAX Extensions - 3 Blogs

Reporting [ Community B
HTML - [ CommunityServices =
= CMS - [ ContentRating

k Pointer - [ CustomTables

G CMSSiteMap
58 ColorPicker

m

.
.

.

H

.

.

.

i [ DataSources
i [ Ecommerce
.
.
.
.
H

- Event:

43§ BasicCalendar 3 Events

. - [ Forums
b nghtl:r.oxExtender . £ General
& CMSViewer - [ GoogleServices
43§ BasicDataPager 3 Media
53§ DataPager F hdedialih 2
53§ BasicDatalist Properties i x
58§ QueryDatalist DOCUMENT -

558 CMSTreeMenu

43§ BasicRepeater

58§ QueryRepeater

58§ CMSTextPager

48§ CMSSearchDialog

53§ BasicDatalrid

58§ CMSDataGrid

58§ CMSPageManager

458 MediaSelector

58§ CMSHEmIEditor

48§ CMSSearchResults

58§ CMSDocumentComparison
53§ TemplateDataPager

4§ CMSMenu i - Debug

B o |5 s ] = st | souree | e
Requesting Data... Ln6 Coll Chl

EE

L9 Debug

Language (e

5. Double-click the Button control and add the following code to the Buttonl_Click method:

[CH]

Label 1. Text

Dat eTi me. Now. ToStri ng() ;

[VB.NET]

Label 1. Text = Dat eTi me. Now. ToStri ng()

6. Add the following line to the beginning of the code:

(CH]

usi ng CVB. Portal Control s;
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[VB.NET]

I nports CVS. Portal Control s

7. Change the following line:

[CH]

public partial class CVSB\WebParts M/WbParts Hel | oWorl d : System Wb. U . User Cont r ol
to

public partial class CVEVébParts M/\WebParts Hel | oVWorl d : CVSAbstract WebPar t

[VB.NET]

Partial d ass CvBWbParts_ M/WbParts_ Hel | oVorl d
I nherits System Web. U . User Cont r ol

to

Partial d ass CvBWbParts M/WebParts_Hel | oWorl d
I nherits CMSAbstract WebPar t

It ensures that the user control behaves as a web part.
8. Add the following code to the Page_Load method:

[CH]

Buttonl. Text = (string) Partlnstance. GetVal ue("ButtonText");

[VB.NET]

(Visual Basic.NET doesn't create the Page_Load method automatically, so you need to add the whole
method:)

Prot ected Sub Page_Load(ByVal sender As Object, ByVal e As System Event Args)
Handl es Me. Load

Buttonl. Text = CType(Part| nstance. Get Val ue("ButtonText"), String)
End Sub

It sets the button text to the value configured in Kentico CMS Desk.

9. Sawe all changes.
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10.0Open Site Manager -> Development -> Web parts, click the root and click New category. Enter
My web parts into the Category display name field and click OK.

11.Click the new category and click New web part. Choose to create a new web part and enter the
following values:
- Web part display name: Hello world
- Web part code name: HelloWorld
- Web part file name: MyWebParts/HelloWorld.ascx
Click OK.

12.Switch to the Properties tab and add the following properties using the Add attribute () button:
- Attribute name: ButtonText
- Attribute type: Text
- Attribute size: 100
- Field caption: Button text
- Field type: Text Box

a8 98 Deleteselectsd  © Webpars » Hello world
@ [3 Export selected
General Properties Layout Documentation

' Clone web part
=5 All web parts
- Abuse report rT—
- Articles ElienTrr Database

g
] A St s Aftribute name ButtonText

- BizForms @

-3 Blogs Aftribute type: Text -
d@ Booking system @ Aftribute size: 100

‘ﬂﬁ Cornrnunfty : Allow empty value: [}

[+ Community services

- Content rating ) Aftribute default value:

-
m@ Custom tables \2
[1"3) Data sources
-9 E-commerce
1 9 Events Field
M’\S‘ Forums

d@ Full-text search

Display attribute in the editing form

m

[

+ Field caption: Button text

M’\S‘ General x
ﬂ@ Google services Field type: Text box -
tﬂ@ Listings and viewers
d@ Media -
-5 Media library ok
m@ Membership
d@ Message board
-9 Messaging
%3 My Web Parts

- & [Hello world

13.Switch to CMS Desk.

14.Create a new blank page using the Simple layout (or any other layout) under the root and switch to
the Design tab.

15.Click Add web part in the upper right corner of the web part zone and choose to add the Hello
world web part:

m
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Home Services Products News Partners  Company Blogs Forums  Events  Images Wiki | Examples ﬁt}out
= [blank page - page template: ad-hoc 2
= zoneleft ok
v HelloWorld &3
Label

16.The Web part properties window of the HelloWorld webpart appears, set the value of the Button text
field to Hello world!

& | CMS Desk - Web Part properties -- Webpage Dialog lé'
Q Web part properties (Hello world) é‘Documentation

General

Default o

Visibility Visibility

G |

e visible: v

HTML Envelope

Gl Hide on subpages: y [

Time zones

Partial caching Show for document types: 3 Select

m

Display to roles: 3 Add roles

General 4

Button text: ¥ Hello World)

HTML Envelope

Web part container: » |(none) E

Web part container title: 3

— [ ox [ cancer [ Aw

http://localhost/KenticoCMS/CMSModules/PortalEngine/Ul/Webparts/WebPartProperties.asp €L Local intranet | Protected Mode: Off

17. Now switch to the Live site mode using the button in the main toolbar. You will see the button with
text Hello world! When you click it, the label displays current date and time:

Home  Services Products

Hello world!

12/15/2009 10:45:09 AM

You hawve learned how to create a simple web part.
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Tip: Displaying content on the web part

You can also use Kentico CMS Controls on the web part (on the ASCX control) to
display content from Kentico CMS in a customized form.

6.3 Web part modifications
Web part cloning

If you need to copy or modify the behavior of some web part, you can clone the web part. It ensures that
your changes won't be overwritten with the nearest upgrade.

You can clone a web part in Site Manager -> Development -> Web parts. Choose the original web
part and click Clone web part. Then, you can modify the web part code in Visual Studio.

Web part layout

Custom web part layouts allow you to modify the design of web parts. It's useful if you need to change
the look of some dialog or hide some field.

Go to CMS Desk, choose the Design tab, open web part properties and switch to the Layout tab. Here
you can choose to create a new layout and modify its HTML code. Please note: you always need to
keep all ASP.NET controls in the layout. If you need to hide some of the controls, just add the
Visible="False" attribute to the control.

Web partinheritance

Web part inheritance allows you to create web parts with pre-set values for a particular purpose. You
can, for example, create a specialized web part for displaying news, inherited from the Repeater web
part. You will define default values for the relevant properties so that the Repeater web part displays
news items without additional configuration. It may speed-up your work.

You can create an inherited web part by going to Site Manager -> Development -> Web parts,
clicking New web part and choosing to inherit from an existing web part.
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7 Managing styles and design

7.1 CSSstyles

The design of the website relies on standard CSS styles. Each website has its global CSS stylesheet
that can be chosen in Site Manager -> Sites -> ... edit site ... -> General. Here you can also choose
a different CSS stylesheet used by WYSIWYG editors.

Besides, each page can overwrite the global CSS stylesheet by setting its own stylesheet in CMS Desk
-> Content -> ... edit some document ... -> Properties -> General.

The CSS stylesheets can be managed in Site Manager. When you are in CMS Desk, you can easily
switch to Site Manager by clicking the Switch to Site Manager link in the header:

ger| Site:| Corporate Site
232 Kentico > =
’.‘ CMS Desk Content My desk Tools Administration

Then click Development in the Site Manager main menu and click CSS stylesheets in the left menu:

22 Kentico

’.‘ CMS Site Manager Siteg Administration Settings Development Licenses Support
(=) Development (j CSS stylesheets
.5 Categories
@ Countries @ New CSS stylesheet
Q’ CSS stylesheets
@ Cultures
il Custom tables ekons Display name - Code name
|;]1 Document types # R 3 Corporate Site CorporateSite
Q E-mail templates # 3 |3 Corporate Site - Grayand Blue  CorporateSiteGrayBlue
i< Form controls _
@ Inline controls # R |3  corporate site printer styles CorporateSitePrinter
* % Modules

Edit (#) the Corporate Site stylesheet:
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\’; CSS5 stylesheet properties

C55 stylesheets » Corporate Site

General Sites

[ sae ra} Check out

Check outthe stylesheet to file cilinetpubwwwrootiKenticoCMSICMSC S S Stylesheets\Corporate Site.css to edit the stylesheet externally.

Stylesheet display name: Corporate Site

Stylesheet code name:

Stylesheet text:

Example:

CorporateSite

f*$#Global#*/

.LIR,

{

body

.RTL

background-color: #£fffff;

background-color: #£fffff;

font-size: =small:
font-family: Arial:
margin: Opx:

color: #ffaZle:
font-size: 160%;

font-gize: 130%
m

m s

Abuse report -
Blog
Board
Containers

Black box

Content padding

Gray box

Crange box

Crange box with grey col
Content rating
Ecommerce
Events
Examples

Change password

Drop down menu

Event manager

Media Libraries

My profile

Pager control

Report

Vertical css menu
Forum

Attachments

Extended actions -

m

Change the background color of the .LTR, .RTL style to #fef3b8, click OK to sawe the changes. Switch

back to CMS Desk and see the live site. The site background will be yellow.

Please note: you may need to right-click the page and choose Refresh (in Internet Explorer) in order to
see the latest version of the style.

The body CSS class is applied to BODY element in both website and WYSIWYG
editor.

.LTR, .RTL and body CSS classes

The .LTR and .RTL CSS classes are assigned to the BODY element for the left-to-right
and right-to-left text direction respectively. You can use them to set the styles of the
BODY element used on the live site without setting the BODY element in the
WYSIWYG editor. It's useful if you need to set a dark background to the website, but
use a white background in the WYSIWYG editor text.

Browser-dependant styles

The BODY element CSS class consists of the combination of LTR/RTL style (see the
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box abowe) and the browser version. It looks like this:
<body class="LTR IE7" >

This feature allows you to create styles that depend on the browser version. So if you
define the styles like this:

.IE6 .MyClass
{height: 20px ;
?Opera .MyClass
{height: 18px ;

}

the font size will be different for IE6 and Opera.

The class names are:

¢ |E: IE<major version>
® Opera: Opera

¢ Firefox: Gecko

e Safari: Safari

7.2  App themes

In some cases, you may leverage the built-in support for ASP.NET themes. You can use them for
setting styles of controls that do not have their own CSS class name, such as Datagrid, Calendar or web
parts with complex dialogs (logon form, registration form, ...).

The name of the theme folder under App_Themes must be same as the code name of the site's CSS
stylesheet. So if you use the Green stylesheet on your site, your theme must be stored in the
App_Themes\green sub-folder under your web project.

You need to add your skins to the default.skin file. Here's an example of CMSCalendar / Calendar web
part skin:

<cns: CVBCal endar Ski nl D="Event Cal endar" Runat ="server">
<Next PrevStyl e ForeCol or =" Red" ></ Next PrevStyl e>
<WeekendDaySt yl e BackCol or ="#EOEQEQ" ></ WeekendDay St yl e>
</ cns: CVSCal endar >

The code above defines the look of the Event calendar control. You can see this control on the Events
page in the sample Corporate Site.

Where should | store website design files?
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7.3

It's recommended that you store all images or Flash movies that are part of the website
design template in folder app_themes/<stylesheet code name>. This ensures that the
files are exported together with the website when you are deploying it to some other
server.

Menu design

Now you will learn how to change the design of the main menu. The main menu used in the sample
Corporate Site is displayed using the Drop-down menu web part which is based on the CMSMenu
server control.

The menu design depends primarily on the CSS styles. Here's an example of the CSS styles for the

drop-down menu:

. hori zont al menu{
background: #000 url (../App_Themes/ Cor porateSite/l mges/topMenuBackground.

gif);
}
. hori zont al CMSMenu
{
hei ght: 34px;
col or: #fff;
paddi ng: 3px;
background: #000 url (../App_Themes/ Cor porateSite/l mges/topMenuBackground.
gif);
}

. hori zont al subCMSMenu

{
background: bl ack;

col or: #fff;
}

. horizont al subCMSMenu tr

{
background: bl ack;

}

. hori zont al subCMSMenul t em
{

whi t e- space: no-wr ap;
di spl ay: bl ock;

As you can see these are standard CSS styles. You can modify the styles in the global CSS stylesheet
of the given site.

The default menu looks like this:
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services  Products  News Partners  Company  Blogs

Now we will change the background color of selected menu items to orange. Go to Site Manager ->
Development -> CSS stylesheets and edit the Corporate Site stylesheet. Choose Top menu styles -
> Horizontal in the right navigation panel. Change the highlighted line:

. hori zont al CvBMenul t emVbuseOver, . hori zont al CVBMenuH ghl i ght edMenul t em
. hori zont al CvBMenuH ghl i ght edMenul t emVbuseOver ,
. hori zont al CvBMenuH ghl i ght edMenul t emvbuseDown

{

|backgr ound: orange;

Click OK to save changes. When go to the live site now, you will see a menu like this:

services  Products  News Partners  Company  Blogs

Defining different styles for different menu levels

When you mouse-over the menu you will see that the sub-menus are displayed in different colors:

Home  Services Mews  Partners  Company Blogs

Cell phon

* Cell phones
PDAs

® PDAs
@ | aptops Laptops

The sub-menu styles can be configured using the CSS prefix property of the Drop-down menu web
part or the CSSPrefix property of the CMSMenu control.

In the sample Corporate Site project, the property is set to "horizontal;horizontalsub”. It means that the
CSS styles for the first level of the menu use styles like horizontal CMSMenultem, while the sub-menus
on the second and further levels are displayed using the CSS styles with prefix horizontalSub, such as
horizontalSubCMSMenultem. In this way, you can define different CSS styles for any level of the menu
structure.

Defining the style of a single menu item

Every document may have its own style that is used when the document is displayed in the menu. We
will try to modify the style of the Home menu item. Go to CMS Desk -> Content and click Home.
Click Properties -> Menu. Here you can define:

e Menu caption - the name of the document when it's displayed in the menu.
e Show in navigation - indicates if the document should be displayed in the navigation controls
e Show in site map - indicates if the document should be displayed in the site map
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e Menu item design for standard, mouse-overed and highlighted menu item.

Enter the following value into the Menu item style value (under the Menu item design section):
background-color: red; and click Save. Click Live site. Click Services. The Home menu item is now

displayed in red:

Home

Products

MNews

Partners

Company

Blogs

© 2011 Kentico Software



Creating a new site using the gortal engine



78

Kentico CMS 5.5 R2 Tutorial

8.1

8.2

Creating a new site using the portal engine

Overview

This part of the tutorial will guide you through the creation of a simple website. You will learn how to
define site structure and design and how to create your own pages and page templates.

During this tutorial, we will use a static website template that is similar to what a deweloper gets from a

graphic designer. It looks like this:

Our Business, Inc.

Home Page 1

Welcome to OQur Business, Inc. Web Site

This is a sample web site design that will help you understand how to convert a web
site template into a master page in Kentico CMS.

How to convert a web site template into a master page

The procedure is simple:

* Create a new web site.

+ Go to CMS Desk.

+ Click the root document, which is the master page.

* Switch to the design mode and choose the HTML layout view

+ Enter the HTML code from the static page.

* Put the web part zone tags whereever you want to display dynamic content,
such as editable regions, menu, news, stc.

+ Save the page layout.

+ Switch back to the web part view and add web parts to the web part zones.

+ Remember to place one placeholder web part on the master page template so
that it can Inad sub-pages into this place.

* Copy and paste the CS5 styles into your web site style sheet in Site Manager
-= Development -= CSS Style sheets.

* “You're done. Now you can continue by creating sub-pages.

You can find the static page template in folder C:\Program Files\Kentico

Contact us

Our Business, Inc.
127 One Business Way
Los Angeles, CA

phone: (200} 111 1111
fax (800) 111 1111

CMS\<wersion>\CodeSamples\SampleWebTemplate. The template consists of the home.htm file, styles

folder and app_themes folder with images.

Creating a new web site using a wizard

The following chapters assume that you have previously installed a sample Corporate Site on your
computer. We will leave the existing website and add a new website that will run on http://127.0.0.1.

Multiple sites and Visual Studio's built-in web server

If you are using the built-in web server in Visual Studio instead of IIS, you need to
stop the CorporateSite site in the Site Manager -> Sites dialog first and then you can
continue. Since the built-in web server doesn't support any domain other than localhost,
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you will use the localhost domain again.

Sign in as Administrator to Site Manager -> Sites. Click New site wizard on the home page.

-‘!’- Ken tico Switch to CMS Desk User: Glot

’.\ CMS Site Manager Sites Administration Settings Development Licenses Support
5 .
&) Sites

E_QJ MNew site wizard |_E'. Import site or objects |3 Export obijects

Actions Site name ~ Status Main domain

% T [e] B> @ &3 Corporate Site Running  localhost

In the first step, choose to Create a new site using a wizard. Click Next to proceed.

Choose default web site
Step 1 If you choose to create a blank site, the wizard will guide you through the process of creating a new site. If
you choose to use atemplate, you will be able to choose one of the predefined web site templates.

@ Create a new site using a wizard
(7 Use web site template

In the second step, enter the following details:

Site display name: My website

Site code name: mysite

Domain: 127.0.0.1 - if you are using Visual Studio built-in web server, set the default value to
localhost

Default culture: English - United States (by choosing a different default culture, you can achieve
displaying date, time and numeric values in culture-specific format)

Click Next.
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Enter new site settings

Step 2 Enter the display name and code name of the web site. The Domain field must contain the domain that you
will use to access the web site during development (you may change it when the site goes live). The default
culture is the main language of the web site.

Site display name: My web site
Site code name:  My\WebSite
Domain name: | 127.0.0.1

Site culture: English - United States |Z|

In the third step, you are asked to select objects which should be imported to your new site. Do not
change anything and click Next.
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Step 3

=1 All objects
5@ web

Objects selection

Please select objects which should be imported.

site

[}l Documents
] Administration
f Settings

. [+-55 Development
- Global objects
[-2F Toals
(€] Administration
[+)-=8 Development

@ Import objects @

Please note: The import process may overwrite your existing objects. The existing objects are
marked with * and will be overwritten if checked.

Please select the object type from the tree if you wish to change the default selection.
Click Next to start the import of selected objects.

Global selection
Load default selection  Selectall objects Select only new objects  Deselect all objects

Import settings

Assign all objects to the imported site (recommended)
Run the site after import

[ pelete incomplete site when import fails

Import files (recommended)

[ Do not import objects where parent object is missing
Import tasks (recommended)

In the fourth step, the progress of objects import is displayed.

Step 4

Import progress

Objects are being imported.

Importing ‘Roles’ objects

Importing Web s

ite’ objects

Importing "Settings” objects
Importing "Settings categories’ objects

being imported

81
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In the fifth step, you can choose the master page. You can change or modify it at any time later. For
now, please choose the Blank master page option.

Select master page
Step 5 The master page defines the layout of the main menu, logo and content placeholders. You can change it at
any time later.

»

Blank master page =
Blank master page

Generic default page template.

.= Top logo and left menu
"ﬂ %—-—— Master page template with logo on the top and menu on the left side.

m

e

Top logo and menu

= ﬁ Master page for the Sample web site.
=]

Click Next. In the sixth step, you can design the site map of your new website. Click New and add a
new page called Home and choose page template Templates with editable regions -> Simple text.
Click OK to sawe it.

© 2011 Kentico Software



Creating a new site using the portal engine

Define basic site structure
Step ﬁ Define the site map of your new web site. The pages you create will be displayed in the site menu. Every
page must have some template specified or it can inherit page template from the parent page.

L3t

New Delete & Down |

Content management

Ij{tv! My web site
[ ][Home

C] Page properties

Page name: Home

Page template: |Simple text

83

Inherit template

Next>

Click My website and click New. Add a new page called News and choose page template News ->
News list. Click OK to sawe it.

Define basic site structure

Step 6 Define the site map of your new web site. The pages you create will be displayed in the site menu. Every
page must have some template specified or it can inherit page template from the parent page.

Y

New Delete & Down |

Content management

Ij{t_’! My web site

C] Page properties

Page name: Mews

Page template: News list

Inherit template

Next>

© 2011 Kentico Software




84

Kentico CMS 5.5 R2 Tutorial

Click Next. You will see a confirmation message:

The web site has been created successfully
Step T Mow you can view and edit your new web site.

Edit your new web site

Ifthis is your first web site, the default user account is administrator without password.

Click the Edit your new website link. A new window with Kentico CMS Desk opens at domain
127.0.0.1. You need to sign in again (user name administrator, blank password) since the authentication
is not shared over different domains. After you sign in, you will see your new, empty website:

© 2011 Kentico Software



Creating a new site using the portal engine 85

Switch to Site Manager  Site: | My web site User: Global Administrater v5.0.3636 Sign out
232 Kentico 2 2
#1%  CMS Desk Content | Mydesk  Tooks  Administration
2 Co u
% Howr  Ww [4 | [d =i 2 )
New Delete |= Move & pown Edit Preview Live site List Search
Content management View mode Other
==
5 #My web site Page | Design  Form  Masterpage  Propertes (2]
+|] Home
L[ News [l s2e @ Spell check

=

You have created the base for your new website. In the next chapters, you will learn how to implement
the required design.

8.3 Creating a CSS stylesheet

Before we start editing our new website, we will prepare the CSS styles and images based on our
website template. Go to Site Manager -> Development -> CSS Stylesheets and click New CSS
stylesheet. Enter the following values:

e Stylesheet display name: My site stylesheet

e Stylesheet code name: MySite

e Stylesheet text: copy and paste all text from the SampleWebTemplate\Styles\main.css file (you
will find it in folder C:\Program Files\Kentico CMS\<wersion>\CodeSamples)
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2 Kentico

g% CMS Site Manager

=) Development
i3 Categories
@ Countries
- |Css stylesheets
@ Cultures
L..£43l custom tables
; £ Document types
- [3) E-mail templates
<.;¥5 Form controls
: & 1nline controls
- Modules
L[ Notifications

.-[H Page layouts

@ Page templates
-..=8 Relationship names
- system tables

i-+%# Tag groups

) Time zones

: UI cultures

Web part containers
.- Web parts

i-[@] Web templates
...[@] widgets

L[ Workflows

[

Switch to CMS Desk  User: Global .

Sites Administration Settings Development Licenses Support

(j& New stylesheet

C3S stylesheets » Mew C3S stylesheet

Stylesheet display name: My site stylesheet

Stylesheet code name: MySite
Stylesheet text:
color: #3cTEcc;
font-gize: large;
}
NewsSummary
4
padding-top: 3px;

padding-bottom: 3px;
font-weight: bold:

}

/* —-—- Drop-down menu —-—-— %/

.subCMSMenultem, .subCHMSMenultemMouselver,
subCMSMenuHighlightedMenultem,
MenuItemMouseOver,
1

.subCM3MenultenMouseDown, .subCHMSMenultenMouseUp, .
. subCMSMenuHighlightedMenuItemMouseDown, .subCMSMenuHighlighted
. subCHMSMenuHighlightedMenuIcemMouselUp

background-color: ¥3a75ca;

color: white;

text-decoration: none; .

width: 90px |E|
} -

assign to web site My web site

Click OK. Click the Sites tab and make sure the stylesheet is assigned to My website.

2)2 Kentico

#g% CMS Site Manager

=)~ Development
-5l Categories
.. countries
- 4f|C35 stylesheets
- cultures
g custom tables
.. Document types
23 E-mail templates
<% Form controls
+[E Inline controls
(% Modules

.| Notifications

Sites Administration Settings Development Licenses Support

d CSS stylesheet properties
CS5 stylesheets » My site stylesheet

General Sites

The CSS stylesheet is available for the following web sites:

] Site name
[l My web site

Remove selected Add sites

Go to Site Manager -> Sites and Edit (#) properties of My website. Select My site stylesheet in the
Site CSS stylesheet drop-down list and click OK. It ensures that the stylesheet is used on all pages of

your new website.
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212 Kentico

'.‘ CMS Site Manager Sites Administration Settings Development

6_) Site properties

Sites » My web site

General Domain aliases Cultures
Site display name: My web site
Site code name: MyWebSite
Site domain name: 127.0.0.1
Default content culture: English - United States
Defaultwisitor culture: | (Automatic) IZ|
Site C33 stylesheet: | My site stylesheat Eﬁ
Editor CSS stylesheet: | (site stylesheet) [=] T
Site description: Sample blank web =site ks
——

Now copy the folder SampleWebTemplate\app_themes\MySite to <web project>\app_themes.
The folder contains graphics for this website template. It will ensure that the images are exported as a
part of the website if you decide to mowve the website in future. Please note that the folder under
app_themes must have the same name as the code name of the CSS stylesheet - MySite.

CSS stylesheet URL and relative paths

We hawe adjusted the image paths in the sample CSS stylesheet so that they match
the target folders in your new website. In real life, you will need to adjust the paths
manually. The URLs of images in the CSS stylesheets are always relative to the
CSS stylesheet.

The URL of the CSS stylesheet is
<web project>/CMSPages/GetCSS.aspx?stylesheetname=MySite
which means, you need to link to files in the app_themes folder like this:

..lapp_themes/mysite/images/imagename.gif.

8.4 Master page

The site master page is defined by the root document. Switch to CMS Desk, click the root of the content
tree and switch to the Design tab. You will see the blank page template:
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22 Kentico

#%  CMS Desk Content | My desk
y [ Copy i we
x

New Delete |=Move & pown

Content management
(241 My web site
+ | Home
~-|2] News

Tools Administration

[4 | [d g | A

Edit Preview Live site List Search
View mode Other

Page | Design | Form  Masterpage  Properties

Switch to Site Manager

Site: My web site

[=] user: Global Administrator v5.0.3836 Sign out

Q

=
Display web part content @

= I- page template: Blank master page ;
= zoneTop ok
= zoneContent o

v [ pageplaceholder (&

As you can see, there are no web parts at this moment. Click the Edit layout () icon in the green box
to edit the HTML layout.

Clear the text box content and copy and paste the HTML code inside the <BODY> element from file
home.htm (it's part of the website template located in folder C:\Program Files\Kentico
CMS\<version>\CodeSamples\SampleWebTemplate) into the text box:
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Page Design Form Master page Properties | Display web part content @

= |- page template: Blank master page 2’

[H Page layout E

E Save E?J Chedk out

Check out the layout te file ciilnetpubiwewwrootiKenticoCMS\WCM STemplateLayoutsicms\blankmasterpage.ascx to edit the layout externally.

The changes were saved.

<div class="MainDiv">

<1-- logo —--»

<br />

<div class="Logo™> E
&nbsp:

</div>

<!-- main menu -->

<div class="MainMenu">
<table cellspacing="2" cellpadding="2" border="0">>

<tr>
<td class="MainCMSMenuHighlightedMenultem">Home<,/ td>
<td class="MainCMSMenultem">Page 1</td>
</tr>
</table>
</div>
<!-- main content -->

<table style="width:100%;height:500px;border: Opx">
<tr wvalign="top">

<!-- left column -->
<td style="width:280px" class="HomePageLeftColumn™:>
</td>
<!-- center column -->
<td style="padding: 3px S5px Opx Spx;width:450px;">

<!-- center box —->

<table cellspacing="0" cellpadding="0" border="0" class="ContainerWithCorners" widch="100%">

<tr class="ContainerWithCornersRow"> i
PP RPN * P PR SO D S A S Y

Click Save.

Using CSS-based layout instead of tables

If you prefer using CSS-based layout, you can easily change the HTML code here and
replace the tables with DIV elements. You may also need to modify page layouts in
Site Manager -> Development -> Page layouts so that they use CSS-based layout.
We use table-based layout by default since it's easier to understand, although we are
aware of advantages of the CSS-based layout.

Click the Page tab now and you can see your new website design (it's still static):
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22 Kentico
“1

b CMSDesk | conent | mydesk

Tools. ‘Administration

Switch to Site Manager

Site:|My web site || User: Global Administrator v5.0.3638

Sign out

| B [Peopy T up | @ [E [ » o
| New Delete [SMove & Down | Edit | Preview Live site  List | search

| Content management View mode | Other ]
) My web site | | Pace | Desion  Fom  Mssterpsge  Propertiss (2]

i[] Home
E a News

e,

E Save Spell check

Our Business, Inc.

Welcome to Our Business, Inc. Web Site

This is a sample web ste design that will help you understand how to convert a web
site template into a master page in Kentico CHS.

How to convert a web site template into a master page

The procedure is simple:

+ Create a new web ste
* Goto CMS Desk.

+ Click the root document, which is the master page.

+ Switch to the design mode and choose the HTML layout view

* Enter the HTWL code from the static page.

* Putthe web part Zone tags wheresver you want to display dynamic content,

such as editable regions, menu, news, etc.

+ Save the page layout
+ Switch back to the web part view and add web parts to the web part zones.
* Remember to place one placeholder web part on the master page template so

that it can load sub-pages into this place.

+ Copy and paste the CSS styles into your web site style sheet in Stz Manager

-» Development = CSS Style sheets.

+ You're done. Now you can continug by creating sub-pages.

Contact us

Our Business, inc.
127 One Business Way
Los Angeles, CA

phone: (800) 1111111
fax: (800} 111 1111

e

Adding web part zones

Now we need to replace static text with web part zones, so that we can put dynamic web parts on the
page. Click Design and click Edit layout ().

Locate the <!-- main menu --> section in your page template and replace the following code:

<l-- main nenu -->
<di v cl ass="Mai nMenu" >

<tr>

<[tr>

</t abl e>
</ di v>

<t abl e cel | spaci ng="2" cel | paddi ng="2" border="0">

<td cl ass="Mai nCVsMenuH ghl i ght edMenul t ent' >Home</ t d>
<td cl ass="Mi nCvBMenul t emt >Page 1</t d>

with:

<l-- main nenu -->
<di v cl ass="Mai nMenu" >

</ di v>

<ccl: CvB\WbPart Zone | D="zoneMenu"

runat ="server"

/>
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Now replace the main content section between <!-- main content --> and <!-- /main content --> lines
with:

<ccl: CvBWbPart Zone | D="zoneMai n" runat="server" />

Click Save. After you close the HTML layout, you will see the new layout with web part zones:

%
Page Design Form Master page Properties | Display web part content L5

= |- page template: Blank master page p

I ¥ zoneMenu

| = zoneMain

Tip 1: Editing HTML layout code in an external editor

.
L

If you prefer to edit the HTML layout code in some external editor, such as Visual
Studio or Dreamweavwer, you can Check-out the code to file on your disk using the
Check out to file button in the HTML layout editor:

" ES
Page | Design | Form  Masterpage  Properties /| Display web part contant L 2]

= /- page template: Blank master page é“
[CR Page layout X

E Save @J Chedk out

Check out the layout to file c:linetpublwwwrootiKenticoCMSICM STemplateLayoutsicmsiblankmasterpage.ascx to edi the layout externally.

Use the following expression to add a new web part zone: <cc1:CMSWebPartZone ID="zoneTopRight” runat="server" />
(the ID must be unique within page layout)

<div class="MainDiv">

<l—— logo —->
<br />

Now you can open the file using the path displayed on the screen in your favorite editor.
You can modify the HTML code and preview the changes on the live site. After you
finish the changes, you can check in the code back to the system and make the
changes available to all users.

Please note: If you check-in the file or undo the check-out, the file is deleted on your
disk.

You can use the same concept with transformations and CSS stylesheets as well.

Tip 2: Master page tab

The Master page tab allows you to add custom DOCTYPE directive, custom HEAD
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section elements and custom BODY attributes. It also allows you to edit the master
page HTML layout directly (this is the same code that you edit in the HTML layout
mode of the Design view).

Page  Deson  Form | Masterpage | Properties

[l S22

<!DOCTYPE html PUBLIC "-//W3C//DID XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtmll/DTD/xhtmll- -
transitional.dtd"> -
=html=
<head=
=title=
My Site - <ftitle=
<meta hitp-equiv="pragma" content="no-cache" /=
<link type="texticss" rel="stylesheet” href="/KenticoCMSICMSP; tCSS aspx?stylest ySite” /=
=/head=
<hody class="LTR DesignMode IES ENUS" =

<01V CLass="Malnuiv'>

<!-- logo —--»

<br />

<div class="Logo">
inbsp;

</divy

<!-- main menu -->

m

<div clazs="MainMenu">
<ccl:CMSWebPartZone ID="zoneMenu" runat="server" />

</dive
<!-- main content --%
<ccl:CMSWebPartZone ID="zoneMain" runat="server" />
<!-- /main content —->
<!-- footer -->

<div class="Footer">

=/body=
=ihtml=

Main menu

Now we will add the main menu. Switch to the Design tab of the root. Add (<) the Navigation/Drop-
down menu web part to the zoneMenu zone:
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] Select web part -- Webpage Dialog ‘ ‘ ‘ 5]

‘E http://127.0.01/KenticoCMS/CMSModules/PortalEngine/UL/Webparts/WebPartSelector.aspx
s#" selectweb part
B ﬂ Recently used web parts Web part name: | |

=5 All web parts
;
h I

...%5) Abuse report _
Breadcrumbs CS5 list menu Drop-down menu Site map Tab menu

3 Articles
.15 Attachments |
£ BizForms |

3 Blogs

%) Booking system
() Community

i) Community services

‘- Content rating
) Custom tables

i) Data sources =
&) E-commerce — el
i) Events — o

-4 Forums

&) Full-text search

: &) General

: 4 Google services
i) Listings and viewers
-G Media

E &) Media library

5] Membership

%3] Message board

& Messaging

G [Navigation

-4 News

&) Newsletters

&) Natifications

K 4 Polls

. Reporting

i) silverlight

£ Tagging & categories
@ Text

15 User contributions

£ Web services
& Widgets The Drop-down menu web part displays a menu including sub-menus that open on mouse-over. It uses Javascript, tables and it
can be designed using CSS styles. You can choose between horizontal and vertical layout.

Tree menu Tree view

Drop-down menu I

. T

http://127.0.0.1/KenticoCMS/CMSModules/PortalEngine/Ul/Webparts/WebPartSelector.aspx o Internet | Protected Mode: On F l
—

Click OK. The Web part properties dialog opens. Set the value of CSS prefix to ;sub - it means that
the menu CSS classes for the second menu level will have the sub* prefix. Set the value Design/Layout
to Horizontal. Click OK.

When you switch to the Page tab, you will see the page with a dynamic menu that displays the pages
- Home and News:

Page 1 Design Form Master page Properties 0

H Save Spell check

Qur Business, Inc.

Home News
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8.6

8.7

Page placeholder

Now we need to add a Page placeholder web part that ensures loading of sub-pages (such as Home
or News page) into the master template. There can be only one page placeholder web part in a single
page template.

Switch to the Design tab and add the General/Page placeholder web part into the zoneMain web
part zone. Click OK. You do not need to make any changes to the page placeholder settings.

Page J Design l Form  Master page  Properties [¥] Display web part content 0

‘-;_Wm-mmm Q|

Our Business, Inc.

Home page

Now we will create the home page. Delete the existing /Home page. Click the root and click New to
create a new Page (menu item) document. Enter the page name Home and choose to create a blank
page using the Simple layout:
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-\21- Kentlco Switch to Site Manager ~ Site:|My web site  [+]| User: Global Administrator v5.0.3638

1% CMS Desk Content | Mydesk  Tools  Administration

[lcopy it up E @ = y e

New Delete |=hMove & pown ‘ Edit Preview Live site List | Search [
Content management | View made || Other
(=] qu_‘l My web site My web site
,j News ==
E Save F Save and create another =5, Spell check

Page name: Home

(") Use pagetemplate ) Inheritfrom parent page @ Create a blank page

=

Grid 2x2 cells Grid 2x2 cells (CS5) Grid 3x2 cells Grid 3x2 cells (C55) Simple

Three columns Three columns (CSS) Top row, three columns, Top row, two columns, Two columns
bottom row bottom row

12

Simple

Simple layout with one web partzone

Copy this layout to my page template

Click Save to create the page.

Now we will define a new HTML layout for our home page. Click the Home page. Switch to the Design
tab and click the Edit layout (&) icon. Replace the default code with following code:

<tabl e style="wi dth: 100% hei ght: 500px; border: Opx">
<tr valign="top">
<l-- left colum -->
<td styl e="wi dt h: 280px" cl ass="HonePagelLeft Col utm" >

</td>

<l-- center colum -->

<td styl e="paddi ng: 3px 5px Opx 5px;w dt h: 450px; ">
<ccl: CMSWebPart Zone | D="zoneCenter" runat="server" />

</td>

<l-- right colum -->

<td styl e="paddi ng: 3px Opx Opx 5px;w dth: 270px" >

<ccl: CMSWebPart Zone | D="zoneRi ght" runat="server" />

</td>
</tr>
</tabl e>

Click Save to save the new layout and close the HTML layout editor. Add the Text -> Editable text
web part into the zoneCenter web part zone. Set its properties:
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e Editable region title: Main text
e Editable region height: 450

Click OK. Add another Text -> Editable text web part into the zoneRight web part zone and click OK.
Set its properties:

e Editable region title: Contact text
e Editable region height: 100

Click OK. Click the Page tab. Now you can see that the page contains two editable regions. Enter the
following text:

e Main text: Here comes the welcome text.
e Contact text: Call 800 111 2222

Click Save.

Click Live site and you will see the home page of your new website:

Our Business, Inc.

Home News

Here comes the welcome text. Call 800 111 2222

This is a sample web site for Kentico CM$S

Configuring the website home page

When a site visitor comes to the root of your website (e.g. to http://www.example.com), the system
needs to know which page should be displayed as a home page. Go to Site Manager -> Settings,
select My website in the Site drop-down menu, click website and make sure the value Default alias
path is set to /[Home, which is the alias path of our new home page. If not, please uncheck the Inherit
from global settings box, enter the value and click Save.
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Switch to CMS Desk User: Global Administrator v5.0.2636

22 Kentico
#g%  CMS Site Manager Sites  Admristaton | Settngs | Development  Licemses  Support
it @ Web site
My web site E
= f Reset these settings to default
[=)-Settings
@|web site
'ﬁ Content management
E Files Cache content (minutes)
a Membership
;@ Security Cache images (minutes)
EE URLs and SEO Cache page info (minutes)
y Qutput filter
. . System Combine with default culture
@ E-mails Combine files with default culture
-- Avatars
13 Bad words [Default alias path /Mome Select I
i ' Blogs Default culture of the content English - United States EI
Fﬂ Booking system
&’d Community Page description prefix
- Content st
D? ontent staging Page key words prefix
&4 Forums H

E Media libraries

Message boards
Q Messaging

15l Web analytics
--& Windows LivelD

ﬁ E-commerce
-@ Payment gateway - Authorize .NET
A} payment gateway - PayPal

Exclude documents from SQL search

Control element

Page title format

Page title prefix

Page not found for non-published documents
Page not found URL

Exclude document types from SQL search

@00 Q0COOOO0OOOPOOO®O®

Exportthese seftings

8.8

Container for home page text

My Site

Inherit from global settings
Inherit from global settings
Inherit from global settings
Inherit from global settings
Inherit from global settings
[linnerit from glabal setings
[Z] Inherit from global settings
Inherit from global settings
Inherit from global settings
Inherit from global settings
[T inheritfrom global settings
Inherit from global settings
Inherit from global settings
Inherit from global settings
Inherit from global settings

Inherit from global settings

Sign out

Now we will create the gray and blue containers for our home page text. Such a container can be re-
used for any other web part later. If you do not wish to use a container, you could alternatively insert the

surrounding code into the HTML layout of your page template.

Go to Site Manager -> Development -> Web part containers and click New container. Enter the

following values:

e Display name: My website gray box
e Code name: MyWebSiteGrayBox

e Text before web part:

s

@.

<t abl e cel | spaci ng="0"
wi dt h="100% >
<tr
<td
<td
<td cl ass="Cont ai
</[tr>
<tr>
<td cl ass="Cont ai
<td cl ass="Cont ai

cel | paddi ng="0"

cl ass="Cont ai ner Wt hCor ner sRow" >
cl ass="Cont ai ner Wt hCor ner sTopLeft">&nbsp; </t d>
cl ass="Cont ai ner Wt hCor ner sTop" >&nbsp; </t d>

ner Wt hCor ner sTopRi ght " >&nbsp; </t d>

bor der =" 0"

ner Wt hCor nersLeft">&nbsp; </t d>
ner W t hCor ner sCont ent "

val i gn="t op" >

cl ass="Cont ai ner W t hCor ner s"

® Text after web part:

</td>
<td cl ass="Cont ai

ner Wt hCor ner sRi ght " >&nbsp; </t d>
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</[tr>
<tr class="Contai ner Wt hCor ner sRow" >
<td cl ass="Cont ai ner Wt hCor nersBottonlLeft">&nbsp; </td>
<td cl ass="Cont ai ner WthCornersBottonl></td>
<td cl ass="Cont ai ner Wt hCor ner sBott onRi ght " >&nbsp; </t d>
</[tr>
</t abl e>

Click OK. Switch to the Sites tab and make sure that the container is assigned to My website. Now
create another container:

e Display name: My website blue box
e Code name: MyWebSiteBlueBox
e Text before web part:

<t abl e cel | paddi ng="0" cel | spaci ng="0" style="width: 100% " cl ass="Bl ue">
<tr>
<td class="BoxTitle">{%ContainerTitle% &bsp;
</td>
</[tr>
<tr>
<td cl ass="BoxArea">

® Text after web part:

</td>
</[tr>
</tabl e>

Now go back to CMS Desk -> Content -> select Home page -> Design tab and configure the
editabletext web part in the middle column. Set its Web part container property to My website gray
box and click OK.

Configure the editabletextl web part in the right column and set the Web part container property to
My website blue box. Set the Web part container title property to Contact Us.

When you go to the Live site now, you can see the gray box around the home page text and blue box
around the Contact Us text:
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Qur Business, Inc.

Home News
Here comes the welcome text. ;

Call 800 111 2222

This is a sample web site for Kentico CMS

8.9 News page

Click /News in the content tree. The News page is ready to use since it uses the pre-defined News list
page template. Click New, choose to create a news document and enter the following text:

News title: News 1

Release date: click the date-time picker and click Now and click OK.
News summary: News 1 summary.

News text: News 1 text.

Teaser, Publish from, to: leave the fields blank.

Click Save and create another. Enter the following values:

News title: News 2

Release date: click the date-time picker and click Now and click OK.
News summary: News 2 summary.

News text: News 2 text.

Teaser, Publish from, to: leave the fields blank.

Click Save.

When you click /News and Live site now, you will see the list of news under the New's section:
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Our Business, Inc.

News

News 1
News 1 summary.
News 2

News 2 summary.

As you can see, the main page /News displays the list of the news items that are placed under it. This

is an example of how the content is logically structured in Kentico CMS. When you click /News/News 1
now, you will see the detail view:

Qur Business, Inc.

Home News

MNews = News 1

News 1

12/15/2009
News 1 summary.

News 1 text

The breadcrumbs now show the current path on the website: News > News 1. The position is also
reflected in the URLS:

e The URL of the News page is /news.aspx
e The URL of the News 1 page is /news/news-1.aspx

This makes the website more accessible to both people and search engines, such as Google.

You might wonder how the listings are displayed by Kentico CMS. Let's explain it on this page: Click /
News, click Edit and choose the Design tab. Edit the properties of the NewsRepeater web part. This

web part ensures displaying of the list of documents. It's actually based on the standard ASP.NET
Repeater control that you may already know.
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& | CMS Desk - Web Part properties -- Webpage Dialog M

http://127.0.0.1/KenticoCMS/CMS5Modules/PortalEngine/Ul/Webparts/WebPartP roperties.aspx?aliaspath=%:2fNews&izoneid=zonel eft&webpartid=NewsRepeater&ir
P 9 P P P! P P P

Q Web part properties (Repeater) @/ Documentation
General Layout
Defauit Content filter i
Visibility
Conta Document types: » |CMS Mews Select
Content filter
Transformations O Yes
. & N E
Paging Combine with default culture: » ) Mo

Relationships @ Use site settings B

System settings
Mo data behavior T

Culture code: 3 Select
Editing buttons

HTML Envelope

Maximum nesting level: r -1
AJAX
et DRDER BY expression: » |MNewsReleaseDate DESC
Partial caching
Select only published: »
Selecttop M documents: 3
Site name: 3 Select
WHERE condition: 3 -
VIRefresh content | Ok | Cancel | Appy |

hitp://127.0.0.1/KenticoCMS/CMSMedules/PortalEngine/Ul/Webparts/WebPartProperties.asp: € Intemet | Protected Mode: On

The most important properties are these:

e Path - this property says where the content that should be displayed is located in the content tree. If
you leave the value empty, it searches for documents under the current page.

e Document types = cms.news - this property says what type of documents should be displayed
(news/products/jobs/etc.)

e Transformation = cms.news.preview - this property says which transformation should be used for the
items displayed in the listing. The transformation is actually the ltemTemplate section that you
normally use with Repeater control. The transformations can be managed in Site Manager ->
Development -> Document types -> ... edit document type ... -> Transformations dialog.

e Selected item transformation = cms.news.default - this property says which transformation should
be used for the detailed view of the selected document.

e Paging - if you plan to have too many news items on a single page, you can configure automatic
paging using this property.

How it works

[N

. You go to the /News page.

2. The NewsRepeater web part checks if you have selected some particular news item (based on its
Document types property value).

3. It finds out that you have selected a page document, so it looks for all underlying news documents
and displays them as a list using the cms.news.preview transformation.

4. When you click on some particular news item, such as /News/News 1, the NewsRepeater web part
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uses the cms.news.detail transformation instead and displays the details.
Path expressions
The Path property in web parts supports the following special expressions that allow
you to select the content dynamically:
1% All documents on the website.
/news/% All documents under /News.
/news/news1 News1 document.
1% All items under the current document.
.Jllogo Logo document under the current document.
Jlimages/% All images under the images child document.
..Icontacts/% All documents under the sibling document contacts.
All documents under the current first level document.
1{OM% Example: if the currently selected document is
/news/news1
the expression is evaluated as
/news/%
8.10 Services page

Now we will create a new site section for senvices. This site section will contain a left tree menu and a
single editable region.

Click the root of the content tree and click New. Choose to create a new Page (menu item). Enter
page name Services and choose to create a blank page using the Two columns - 20/80 layout. Leave
the box "Copy this layout to my page template" checked.
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e

7.

New

Kentico
CMS Desk content

- copy i up
Delete |= Move & Down

Content management

My desk

Z& My web site
i [1] Home
@[] News

Tools Administration
[4 [d
Edit Preview Live site
View mode
My web site

E Save E‘ Save and cr

B | A
List Search
Other

Switch to Site Manager

eate another £ Spell check
Eo s

Page name: Serices
() Use page template ()

Layout name
GO ZXZ Cells

Three columns

Two columns - 20/80

12

Two columns - 20/80

Inheritfrom parent page

GO £X2 CENS [L55)

Three columns {CSS)

Two columns - 20180
)

Two columns in ratio 20%/80%

Copy this layoutto my page

template

@ Create a blank page

GINa 3X2 cens

Top row, three columns,
bottom row

Two columns - 3070

Site: | My web site

G0 3XZ CeNs (L53)

Top row, two columns,

bottom row

Two columns - 30/70
(css)

[=] user: Global Administrater

simpie

Two columns

Two columns - T0/30

Click Save. Click Design and add the Navigation -> Tree menu web part into the zoneLeft zone. Set
the following menu properties:
e Content -> Path: /{0}/% (this means that the menu starts from the second lewel)
e Design -> Item image URL: ~/app_themes/mysite/images/bullet.qif
e Design -> Open item image URL: ~/app_themes/mysite/images/bullet.gif

(the ~ character represents the root of the website and it ensures that the image will be displayed
correctly whether you run the websites in the root or in a virtual directory)

Click OK.

Add the Text/Editable text web part into the zoneRight zone and set the following values:

Editable region title: Header
Editable region type: Text box
Editable region width: 600
Content before: <hl>
Content after: </h1>

Click OK. Add another web part of type Text/Editable text below the first one and set the following web

part properties:

e Editable region title: Main text
e Editable region type: HTML editor
e Editable region height: 300
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Click OK. The design tab of the page now looks like this:

Page Design Form Properties

Our Business, Inc.

Home News Services

ad hoc.

pane

v zoneleft qp||= zoneRight
¥ cmstreemenu {53 v editabletext {3
[+ zoneBottom

This is a sample web site for Kentico CMS

Entering text
Click the Page tab and enter some text into editable regions. Click Save.

Page Design Form Properties

Save Spell check

IEsouce [[Ri4 B BB EIGio o [M%IE LIB 1 U s <=
O -0 & SiEE| 0w 8

£ Shle |

111
T
il

|'|Format| |'|Fc-nt| |'|Size|

i TE- dm-i0 [

Qur Business, Inc.

Home News Services

|Our services are the best.

Creating are-usable template

Now we will save this page as a re-usable template so that we can use it for sub-pages. Go to
Properties -> Template and click Save as new page template. Enter the following values:
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e Template display name: Senices page template
e Template code name: SenicesPageTemplate
e Template category: General.

Click OK and click Save on the Template dialog.

Adding sub-pages

Click New in the main toolbar and choose to create a new Page (menu item) under the /Senvices
page. Call the page Service 1 and choose the General/Services page template template. Click
Save. Enter the following text:

¢ Header: Web hosting

e Main text: We provide professional web hosting.

Click Save.

Click Live site. You will see a page like this:

Switch to Site Manager Site:
22 Kentico _ Y =]
4% CMSDesk | [conent | Mydesk  Tooks  Administration
| [Acopy  Wup . @ [ s
| New Delete = Move & Down | Edit Preview Live site List | Search
| Content management | iew mode | Other

EJ-(:_.';\! My web site
‘.| ] Home :
-1 News Our Business, Inc.
EJD Services

“[O[service 1]

Home News Services

P service 1

Web hosting

We provide professional web hosting.

In this chapter, you have learned how to create a new page template with editable regions from scratch
and how to re-use it for multiple pages.

8.11 Products page
8.11.1 Overview

Now we will add a new Products section displaying a list of computers and their technical specification.
You will learn how to create a new document type Computer and how to display a list of computers on
the site. You will also learn how write transformations.

8.11.2 New documenttype

Each document in the Kentico CMS repository is of some type, such as news, product, article, etc.
Each document type has its own fields. Our document type will describe a computer, so it will have a
computer name, processor type, RAM size, disk size and a product image field.
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Go to Site Manager -> Development -> Document types and click New document type. You are
redirected to the New document type wizard. In the first step, enter the following values:

e Document type display name: Computer (this name will be displayed to the users)

e Document type code name: custom.computer (custom is your namespace to distinguish your
document types from system types that use the cms namespace, computer is the document type);
you will use this value in web part properties later.

Switch to CMS Desk  User: Global Administrator v5.0.3636

22 Kentico

#8%  CMS Site Manager Sites Administration Settings Development Licenses Suppart

(= Development i New document type
& Categories
... @ Countries Documenttypes » Mew document type
d CS5S stylesheets
D cultures
:.fiJ Custom tables General
: “ Document types Step 1 Please enter document type display name (for users) and code name (it will be used in your code when necessary).

Q E-mail templates
: eé Form controls
3| Inline controls

Modules Decumenttype display name: Computer
g Notifications Document type cods name: | custom computer
R l] Page layouts namespace document type

i Page templates

EIE Relationship names

7 System tables

& Tag groups

. Time zones

UI cultures

i3} Web part containers H
¥ web parts 1
i-[@] web templates

@ Widgets

8 ! Workflows

Click Next.

In step 2, you need to choose the name of the database table that will be used for storing computer
details. You also need to enter the name of the primary key in this table. Leave the default values:
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Data type
Step 2 Please choose document data type. If you choose a document type with custom attributes you will also need to supply names ofthe
new database table and its primary key.

@ The document type has custom fields
Table name: custom_computer
Primary key name: ComputerlD

() The document type is only a container without custom fields

Click Next.

The wizard has created a new database table for computers. Now you need to define the fields (columns
of the table). Click New attribute to create a new field. Enter the following values:

Attribute name: ComputerName
Attribute type: Text

Attribute size: 200

Field caption: Computer name
Field type: Text box

Click OK. Click New attribute. Enter:

Attribute name: ComputerProcessorType
Attribute type: Text

Attribute size: 200

Field caption: Processor type

Field type: Drop-down list, choose to use Options
Options: enter the following options, one per line:
Athlon;Athlon

Pentium XEON;Pentium XEON

Pentium Core 2 Duo;Pentium Core 2 Duo

Click OK. Click New attribute. Enter:

Attribute name: ComputerRamSize
Attribute type: Integer Number
Field caption: RAM (MB)

Field type: Text box

Click OK. Click New attribute. Enter:
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Attribute name: ComputerHddSize
Attribute type: Integer Number
Field caption: HDD (GB)

Field type: Text box

Click OK. Click New attribute. Enter:

e Attribute name: Computerimage
e Attribute type: File
e Allow empty value: check the box
e Field caption: Image
e Field type: Upload file
Click OK.
Fields
Step 3 Please define custom attributes of the document type and their appearance in the editing form. You can define attributes, such as
praduct number, product weight, press release text, etc.
The changes were saved.
ComputerlD -
ComputerName Database N
ComputerProcessorType Attribute name: Computerimage
ComputerRamSize ﬁ ] -
ComputerHddSize Aftribute type: File |Z|
J | Htrout sizs: 3
Allow empty value:
Attribute default value:
_& Display attribute in the editing form
Field
Field caption: Image
Field type: Upload file [~]
x Automatic image resize on upload
(use site settings) IZ|
Wiicdth fr: a2
[ ok |
He>
Click Next.

Now you need to choose the field that will be used as the document name. Choose the
ComputerName field. It means that when you create a new computer document, its name will be
automatically taken from the ComputerName value and this value will appear in site navigation and in
CMS Desk content tree.

© 2011 Kentico Software



Creating a new site using the portal engine 109

Additional settings
Step 4 Please choose the source field that will be used as a document name. You can choose either one of the custom fields or you can
choose to use document name as a separate field.

Document name source: | ComputerName El

Click Next.

In Step 5, you need to select the document types under which the computers can be added in the
content tree. Click the Add document types button and add the Page (menu item) document type,
which means the editors will be able to create computer documents only under some page, not under an
article or news document in the content tree.

Parent types
Step 5 Please select document types under which this document template can be placed.

[T | Documenttype name
] FPage (menu item) (CMS.Menultem)

Remove selected Add document types

Click Next.

In step 6, you need to choose which websites will use this document type. Click the Add sites button
and choose My website in the following dialog.
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Sites
Step 6 Please select sites where this document type can be used:

[7] | site name

[ Myweb site

Remove selected Add sites

'I'le:-

Click Next. In Step 7, you are asked to specify how documents of this type should be indexed for
searching and displayed in search results. Select the following values in the drop-downs:

Title field: ComputerName
Content field: DocumentContent
Image field: Computerimage

Date field: DocumentCreatedWhen

Leave the default values for the rest of the options and click Next.

Search options
Step 7 Please set search fields for Smart search module.

Title field: Documentiame
Content field: DocumentContent
Image field: | Computerimage

Date field: | DocumentCreatedWhen

EAEE ]

Set automatically
Field name Content | Searchable = Tokenized = Custom search name

ComputerlD 0

]

<
=

ComputerMame

&
o @
&

ComputerProcessorType

i i
E =
i i

ComputerRamSize

ComputerHddSize

The wizard has finished the configuration of the new document type. It has

»

m

HE>

automatically created not
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only the database table, but also the SQL queries for SELECT, INSERT, UPDATE, DELETE operations
and a default transformation.

Step 8 The wizard has finished

The setup has finished the following steps:

The new document type was created.

The new editing form was created.

The document types were added among allowed child types of the new document type.
The sites were selected where this document type can be used.

The default queries were created.

The default ASCX transformations were created.

The default permission names were created.

The defaulticon was created.

Document smart search specification was created.

You have learned how to define a new document type.

How the content is stored

As you already know, the new document type Computer has its own database table.
Each document is stored in three tables: CMS_TREE (tree structure), CMS_Document
(document properties and metadata) and the custom table - in this case
CUSTOM_Computer:

| CMS_Tree CMS_Document | CUSTOM_Computer
_‘i‘l CornputerlD

_I ZormputerHanme

_I ComputerProcessorType
_I CormnpukerRamSize

_I ComputerHddSize

_I CompukerImage

The system automatically ensures all operations on these tables. The advantage of this
storage is that it's very fast and you can easily write standard SQL SELECT
queries to retrieve data from the repository (i.e. from the Microsoft SQL Server
database).

8.11.3 Transformations

Now that we have created a new document type, we need to prepare the transformations that will be
used for displaying product details in a list and in a detail view.
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In the Computer document type properties dialog, click the Transformations tab:

n Document type properties

Document types » Computer

@Newtralsﬁrmalim

Adions | Tansformationneme~

‘/x Default
SR Prevew

As you can see, the wizard has created some default transformations. We will use them for our detail
view. Edit (#) the Default transformation, clear the default code and enter the following code:
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Click Save. As you can see the transformation code is the standard ItemTemplate code that you may
already know from ASP.NET 2.0 Repeater and Datalist controls. It combines HTML code with ASP.NET
commands and data binding expressions. You can use several built-in functions, such as Getimage
that simplify some tasks. You can find the list of the most important functions directly under the
transformation code.

Now we will create transformation for a list of computers. Go back to the transformation list and edit the
Preview transformation. Clear the default code and enter the following code:

<div style="text-align:center;border: 1px solid #CCCCCC'>

<h2>

<a href="<% CetDocurmentUrl () 9%"><%t Eval (" Conput er Name") %</a>
<h2>

<ing src="<% CetFilelrl (" Conputerlmage") %?nexsidesi ze=120" />
</ di v>

Click Save.

Please note how the link to the document is created:

<a href="<%t GetDocunentUrl () %"><%t Eval (" Conput er Nane") %</a>

It consists of standard HTML tags for links and it inserts the URL and link text dynamically.

Similarly, you can create an image tag with parameter that ensures automatic resize of the longest side
to 120 pixels on the server side:

<ing src="<%t CGetFileUrl ("Conputerlmge") %?maxsidesize=120" />

You hawve learned how to write transformations for displaying the content of structured documents.

8.11.4 Page template

Now we get to the final step of this chapter: publishing computer specifications on your website. Go to
CMS Desk -> Content, click New and choose to create a new Page (menu item) document. Enter
page name Products and choose to create a blank page using the Simple layout.
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Switch to Site Manager  Site: My web site User: Global Administrator
232 Kentico v [=]
1% CMS Desk Content My desk Tools Administration
P L 4 & @ 2| A~
New Delste |=Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other
(=& My web site My web site
-] Home .
G0 News E Save E‘ Save and create another Spell check
(3| Services

Page name: Products
(") Use pagetemplate () Inheritfrom parent page @ Create a blank page

Layout name:

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells Grid 3x2 cells {CSS)

[

Three columns Three columns (CSS) Top row, three columns, Top row, two columns,
bottom row bottom row

12
Simple

Simple layout with one web partzone.

Copy this layout to my page template

Click the Down button in the toolbar until you mowve the new page at the end of the list.

Simple

Two columns

Switch to the Design tab and add the Navigation -> Breadcrumbs web part into the zonelLeft zone.

Leave the default values and click OK.

Then, add the Listing and viewers -> Datalist web part. Set the following property values of this web

part:

e Document types: custom.computer

e ORDER BY expression: ComputerName ASC

e Transformation: custom.computer.preview

e Selected item transformation: custom.computer.default
e Show New button: yes

e New button text: Add new computer

e Show edit and delete buttons: yes

Click OK.

Now we need to enter some computer details. Click /Products in the content tree and click New.

Choose to create a new Computer. Enter the following value:

e Computer name: Home PC Dallas
e Processor type: Athlon
e RAM (MB): 512
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¢ HDD (GB): 80

e Image: upload some image (you can find sample images in folder <Kentico CMS
installation>\CodeSamples\SampleWebTemplate\Computer_Images)
e Publish from/to - leave the values blank

Click Save and create another and enter the following values:

e Computer name: Office PC Houston
e Processor type: Pentium Core 2 Duo

¢ RAM (MB): 1024
e HDD (GB): 120

e Image: upload some image (you can find sample images in folder <Kentico CMS
installation>\CodeSamples\SampleWebTemplate\Computer_Images)
e Publish from/to - leave the values blank

Click Save.
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232 Kentico
#g% CMS Desk

Content

Tools Administration

Switch to Site Manager

C u oy Y
) g Bor  ®w 4 [ pe
New Delete |= Move & Down Edit Preview Live site List | Search |
Content management View mode | other |
C-"\"‘_;'J My web site Page Design Form Properties
i[] Home
@2 News E Save Spell check
.ﬂ,_] Services
5[] Products
I_| Home PC Dallas ComputerlD: 2
:...[])[Office PC Houston Computer name: | Office PC Houston
Processortype: | Pentium Core 2 Duo E
RAM (MB): 1024
HDD (GB): 120
| #  Computer2.jpg
mage:
’ Uploac:
Publish from: B Now
Publish to: @ Mow

Now, when you click /Products you will see a page like this:
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Our Business, Inc.

Home News Services Products

Products

Home PC Dallas Office PC Houston

25

When you click on some link, you will see computer details:

Qur Business, Inc.

Home News Services Products

Products = Home PC Dallas

Home PC Dallas

Processor: Athlan
RAM (MB): 512
HDD (GB): 80

Image:

You have learned how to define new document type and how to publish its documents on the website.

8.12 Search page

Kentico CMS allows you to perform index-based search through all documents in Kentico CMS
repository. For this to work, you need to have a search index created. Go to Site Manager ->
Administration -> Smart search and choose to create a New index (&). In the following dialog, enter
the following details:

e Display name: My website
e Code name: MyWebSite
e Analyzer type: Standard
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e Index type: Documents
e Assigh index to website MyWebSite: enabled

Click OK. You will be redirected to the index's editing interface. Switch to the Index tab and click Add
allowed content ('4). In the following dialog, enter /% into the Path field and click OK. Switch to the
Sites tab and make sure that the index is assigned to My website. Click Save. Switch to the Cultures
tab and choose the default culture of your site (typically English - United States). Click Save.

Finally, switch to the General tab and choose to Rebuild (#) the index. Once the index gets rebuilt,
the site is prepared to be searched.

Now we need to create the search page. Click root, click New and choose to create a new Page
(menu item). Enter page name Search and choose the General/Search page template. Click Save.

Click the Down arrow in the main toolbar until you move the Search page at the end of the list.

= = [copy ir up
=l e =
New Delete |= Move & Down

Content management

db‘_’l My web site
[ Home
@[] News
|1||_] Services
|1||_] Products
I_] Search

Switch to the Design tab, choose to Configure (&) the SearchDialogWithResults web part and
choose the previously created index in its Indexes property. Click OK.

Now switch to the live site and view the page. Enter PC in the Search for box and click Search.
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8.13

Qur Business, Inc.

Home News Services Products Search

Search results

Search for: pc

Search mode: n

Home PC Dallas

o5

s hitpo/127.0.0.1/KenticoCMS/Products/Home-PC-Dallas.aspx  12/16/2009 9:15:07 AM

| Office PC Houston

e hitpoi127.0.0.1/KenticoCMS/Products/Office-PC-Houston.aspx. 12/16/2009 9:15:32 AM

When you click some search result, you are redirected to the appropriate document.

i'*} Modifying the search results format

J If you prefer a different design of the search results, you can modify the format in Site
Manager -> Development -> Document types -> Root -> Transformations ->
searchresults transformation.

Secured section for partners

Kentico CMS allows you to create secured site sections that can be accessed only by users who have
a valid user name and password. We will create a simple page for partners that can be accessed only
by registered users.

Go to CMS Desk -> Content, click root and click New. Choose to create a new Page (menu item).
Enter page name Partners and choose to use the page template Templates with editable regions ->

Simple text. Click Save. Click the Down arrow in the main toolbar until you move the Partners page
at the end of the list.

Click the Page tab and enter the following text: This is a secured page for partners.
Click Save.

Click Propeties -> Security. In the Access section of the dialog, click Yes in the Requires
authentication field and click OK. This will ensure that the page can be accessed only by
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authenticated users.

Configuring the logon page

Now we need to create the logon page. We will use a pre-defined page template that you can further
customize if necessary. Click root and click New. Choose to create a new Page (menu item). Enter
page name Logon and choose the page template Membership and security -> Log-on page with
registration form. Click Save.

Click Properties -> Menu and uncheck boxes Show in navigation and Show in sitemap. Click
Save and use the Down button to mowve the Logon page to the end of the document list in the content

tree.

232 Kentico
iy CMS Desk

(1 Copy

= 4 .
New Delete |= Move

Content management

Content

I up
Q’ Down

Toals Administration

Z @ @ 32 | AL

Edit Preview Live site List |

View mode

Search
Other

= f-_"] My web site
] Home
-2 News
.ﬂ,_] Services
(5[] Products
“.[] search
L[] Partners
[ [Logon

e

Page Design
General
URLs
Template
Metadata
Categories
Menu
Workflow
Versions
Related docs
Linked docs
Security
Attachments

Form

Properties
E Save

Basic properties
Menu caption
Show in navigation: [

Show in sitemap:  [7]

Menu actions
@ Standard behavior

(©) Inactive menu item

() Javascript command:

Switch to Site Manager  Site: | My web site El User: Global

Example: alert{hello);return false;

) URL redirection:

Example: hitp:/wwiv.mydomainxy.com of ~jproducts. aspx

We will also need to configure the system so that it uses our new logon page. Go to Site Manager ->
Settings, choose My website in the drop-down list, click Security and set the value Website logon
page URL to ~/logon.aspx, which is the relative URL of our logon page (from the web application root).

Click Save.
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232 Kentico
#4% CMS Site Manager

My web site

=)-Settings

L@ web site

..."[] content management

|l Files

& Membership

- #g|Security

i-=5 URLs and SEO
-3 output filter
’ System

[ E-mails

Avatars

(% Bad words
Blogs

% Booking system
&4 Community
g Content staging
&4 Forums

..ol Media libraries
Message boards
[ Messaging

{sll Web analytics
1} Windows LivelD
PR E-commerce

Sites Administration Settings

[=]

e

@ Payment gateway - Authorize.NET

“..iZ} Payment gateway - PayPal

Development

4@9 Security

Licenses

E Save f Reset these settings to default

The changes were saved.

Send password e-mails from &)
Check page permissions
Website logon page URL

Access denied page URL

Redirect banned IPs to URL
Enable flood protection

Flood interval

2]
@
2]
Enable banned IPs [2]
2]
2]
2]
2]

Enable Ul personalization

Export these seftings

Configuring the Sign out button

Secured areas

~flogon_aspx

Support

Switch to CMS Desk User: Global

[¥ Inherit from global settings
[ Inherit from global settings
[Tlinnerit from global settings
[¥] Inherit from global settings
[ Inherit from global settings
(¥l Inherit from global settings
[ Inherit from global settings
(¥l Inherit from global settings

[ Inherit from global settings

Go to CMS Desk -> Content -> select the root document -> click Design, add the following web parts
to the zoneMain web part zone and set their properties:

Membership -> Current user
e Content before: <div style="text-align:right">

Membership -> Sign out button

e Content after: </div>

Then sort the web parts in the zoneMain zone in the following order (you can drag and drop web parts

using mouse):
e Current user

e Sign out button
e Page placeholder
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22 Kentico

15 CMs

Desk Content

New Delet

[ Copy

(=] BMwe

9 up

aDown

vIRCIOIN=

Edit  Preview Live site

5 €)My web site

[ ] Home

Products
il ] Search
Partners
.| ] Logon

Sign out of CMS Desk. Click Partners in the main menu. You are redirected to the logon page:

Our Business, Inc.

Home News Services Products Search Partners

Log on

User name:

Password:

Remember me

Log on

Forgotten password

This is a sample web site for Kentico CMS

Not a member yet? Sign up now!

First name:
Last name:
E-mail:

Password:

‘Confirm password:

Register

Now you need either to sign in as administrator or register as a new user. After you sign in successfully,
you will see the Partners page content together with Sign out button:

QOur Bu

Home News Services Products Search Partners

siness, Inc.

This is a secured page for pariners.

Current user: Global Admi i J[ Sign out ]

This is a sample web site for Kentico CM S
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You hawe learned how to secure part of the website so that it's only accessible for registered users.

Displaying personalized content based on user's permissions

Kentico CMS also allows you to display a personalized content based on user's read
permissions. You can e.g. grant the Read permission for the Gold partners section to
gold partners and then only the gold partners will see the menu item and page content.

You can find more details on personalized content in Developer's Guide -> Security,
permissions and personalization -> Displaying personalized content.

You hawe just finished the sample website.
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9.1

Further steps

Further steps

This is the end of the Kentico CMS Tutorial. If you need any further details, you will find them in Kentico

CMS Deweloper's Guide. It cowers also other advanced topics, such as:

Multi-lingual content

Multi-site configuration

Workflow and versioning

Security administration

Deployment to the live website
Newsletters, BizForms and other modules
Kentico CMS API and extensibility

and many other features.

If you cannot find some information, please feel free to contact us at http://www.kentico.com/Support.

aspx.
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