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1.1

Personal Site Guide

Overview

Kentico CMS Personal Site allows you to easily run your own personal website. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:
e Content editing

e Blogs

e Forums

e Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.
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Getting Started

Editing content

In this chapter, you will learn how to change the About text on your website.

1. Go to CMS Desk -> Content -> Personal Site -> About me.

Switch to Site Manager  Site:| Personal Site User: Global Administrator v5.0.3688 Sign out
2l Kentico =]
1% CMS Desk Content | Mydesk  Tools  Administration
Eife u
w ¥» | 3 =N o
New Delete = Move & pown Edit Preview Live site List Search
Content management View mode Other
Q

(4 Personal Site Page | Design Form  Properties
2-E] My Blog ‘__
~[1/About Me [ s2e [ soetiches
|| Forums = = = < =
-] Photo Gallery i = souce | [& = |84 2L |EH #im 7 U = &
mEO -0 &SiE 3 olwl B

(1.5 Special pages
#-%5) Images AET

= | Format - | Font - | Gize

S T U S DS, S 1 10 LS SILE FIanager. i

Current user: Global Administrator| My details | Sign out

My Blog Photo Gallery

i Title
| About Me

f Vhat can you find on my web . |
|site? There isn't much stuffon |
it so far, still working on ft.

What you might be interested

iin near future.

2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This is the new About me text. Then click Save at the top-left.
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Page Design Form Properties

Spell check

£ El souee | [& £ |Gt @4 H £2iB 7 U | = <z = =E=i@ 0 F
e =-0Q &SR 0lw 8
[ Stle - | Format - | Font - | Size - Ty~ M- [,
. Left column text . |

What can you find on my web & |
Jsite? There isn't much stuff on |
|it so far, still working on it.

J(What you might be interested |
in is rry blog from a trip |
'faround Europe that we took d

[with my friend PJ this summer.
[Hope to upload more photos
fin near future.

: 5 K:;g'/

My latest blog posts This is the new About me text.

6/15/2008 | Friendly Slovenia

After a while, we're getting
farther away from the coast.
From Trieste, the old ldy gave
us a ride. She realzed soon that
she liked us so much that we
had to meet her famity. And you
can't say NO to an old lady who
gives you a ride. Meeting her ) s
famity was great. We werent T TTTTTTTIITIIITITImI I
apparently the first hitchhikers

invited into this family in its

history. Therefore, everybody

3. Now switch to the Preview viewing mode. You can see that the About me text has been updated.
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Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator | My details | Sign out

. - Oscar W

My Blog About Me Photo Gallery

What can you find on my web About Me
site? There isn't much stuff on it o
so far, stil working on it. What you

might be interested in is my blog

from a trip around Europe that we

took with my friend P this

summer. Hope to upload more

photos in near future.

This is the new About me text.

My latest blog posts

6/4/2008 | Along the coast of
Dragon to Montpellier

France, eventually. For a while,
it seemned like \ i

able to make
than three hours waiting for a
ride at the Spanish — French

Adding a blog post
In this chapter, you will learn how to add a new post to your blog.

1. Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action
toolbar.
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22 Kentico

#1%  CMS Desk Content | Mydesk Tools  Administration
5 co u
R [ =2
New Delete = Move & pown Edit Preview Live site List Search
Content management View mode Other
() Personal Site Page | Design  Form  Properties
-'E)My Blog
[ About Me E Save @ Spell check

-] Forums

Source | [& £ | & ¢4 %5 B #:iB 1 U s x <

(x| Photo Gallery _
RO =0 & SiBla ol #

() %5 Spedial pages
-5 Images

Switch to Site Manager  Site: | Personal Site [v]

tyle | Fomat ~ | Font | Sizs - Ty~ Iy

User: Global Administrator v5.0.3688

&

Sign out

©f ©

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My detsils | Sign out

About Me

Saying goodbye Europe

Tags

airport  Austria bus cuisine
Czech Republic France Germany

Photo Gallery

hitchhiking hostel Paris, our final destination. Because there’s no upcoming hitchhilking

o Sp— trip, the tension between P and me is all gone. T have a friend here,

Slovenia | SPain  sabway 3 so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in

tourism  traffic  train Europe.

2. Choose Blog post as a new document type.

212 Kentico

“1% CMS Desk Content My desk Tools Administration
2 3 Co U
g ooy Wup 4 [d =
New Delete = Move & Down Edit Preview Live site List
Content management View mode
u;l'é_"] Personal Site + My Blog
5-'5][My Blog ™
¢ ﬂ New document
S| About Me
-] Forums

(i1 Photo Gallery Please select new document type:

- H
[+)-0) Special pages -
LRt pad [E) Blog month

| Blog post

-G Images

£ Link an existing document

3. Next, enter information for your new blog post.
e Post title: My new blog post
e Post Summary: Summary of the blog post.
e Post text: The entire text of the blog post.

Then click Save at the top.

)3
Search
Other
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+ My Blog

F- Save and create another Spell check

Elsouce [RT) RBB® S0 (48 HF = &
imMEEO =04 SiH 3 0w B
4 Style ~ | Format ~ | Fant ~| Size Tﬂ' %‘ &
Post title: My new blog post
Post date: 2M16/2010 10:02:43 @Nﬂ

Post summary:

Post text:

Your new blog post has been added to My Blog.

Summary of the blog post.

»

m

The entire text of the blog post.

»

m
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Tags

airport  Austria bus cuisine
Czech Republic France Germany

hitchhiking hostel
Italy luggage sacher torte

Slovenia 5Spain  subway
tourism  traffic  train

] Recent posts

» Saying goodbye Europe

» Wir sind Berliners

* Disappointment in Prague
+ Sweetness of loneliness

b Garher Farke and dnctrian

2.3

Adding a photo gallery

Sign in ko CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

is the first of all pleasures." - Oscar W

My new blog post

-

Summary of the blog post.

Posted: 2/16/2010 10:02:43 AM by Global Administrator | with 0 comments

Saying goodbye Europe

L=

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
i <n tha lact ninht wa cnend in hic nlare drinkina wine and ncinn hic

In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document
action toolbar.

2. Choose Image gallery as a new document type.
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| New document

Please select new document type:

|| Page (menu item)

= Article

) Blog

8 cell phone
1P Event

|4 Event (booking system)
[ 2 J=ite]

HEie

& 1ob opening

& Knowledge base article

¥ Laptop

@, Office
&eoa

(i Press release

9 Product

| Simple article

%] Link an existing document

3. Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then
click Save at the top.
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+ Photo Gallery

E Save F Save and create another

Spell check

£ [ Sowree | [& | &¢ |4 S5 |B £iB I U #|x & [i= = &
imMEED =0 &SiBIE ol 8
A Style - | Format - | Font - | Size < Ti' %' [,
Name: MNew gallery
Description:
Actions Update Name Size
Teaserimage: .
7R & [ testimage png 6 kB
Publish fram: @M
Publish to: & ow

4. Now, go to Properties -> Template and click Select to choose template to use. Choose Personal
Site\Personal Site - Photo Gallery. Click Save at the top.

Page Design Form Properties

General
URLs E Save
Template
Metadata Template
Categaries Personal Site - Photo Gallery Select
Menu -
e =i|': Save as new template...
Versions € Inherit template
Related docs —
linked :}J Clone template as ad-hoc
Security E Edit template properties
Attachments
Inherit content
@ Use page template settings
) Do notinherit any content
() Selectinherited levels

5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.

© 2011 Kentico Software
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New document

Please select new document type:

[ ] Page (menu item)

il

#] Link an existing document

6. Click the Upload file (\#) icon and choose a picture to upload.

» Photo Gallery » Mew gallery

E Save E‘ Save and create anather

Spell check

Upload file: 4 Upload file

File description:

Then enter The description of the first picture. into the File description text box and click Save at the
top.

» Photo Gallery » Mew gallery

E Save E‘ Save and create another

(]

pell check

Actions Update Name Size
Lipload file: -
7R %) [=] Penquins.ipg 760 kB

The description of the first picture

File description:

Congratulations, you've just learned how to create a new gallery and add some pictures into it.
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Current user: Global Administrator| My detsils | Sign out

"Tlusion is the first of all pleasures.” - QOscar V

My Blog About Me Forums Photo Gallery
About my photos List of galleries
Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload

more pictures in near future.
I'm far from being a professional
photographer. Therefore, if you're
looking for mesmerizing pictures, I European Trip
advise you to search somewhere
else. Set of pictures, we've taken on our hitchhiking trip around
Europe with my friend PJ. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
MNothing compares to view of blossoming saguaro.

MNothing compares to Arizona.

New gallery

302 A
-,:: Kentico

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import.

2.4 Adding aforum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.

© 2011 Kentico Software
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=32 Kentico
'.‘ €MS Desk Content My desk Tools Administration

- Tools & Forum groups

| Abuse report

BizForms &4 New forum aroup

Wl Blogs

..’ Booking system

Ba Content staging Actions Group name
-fill custom tables 4 & myForums
T E-commerce

[ File import

--&d[Forums

&3 Groups

- lgal Media libraries

...[] Message boards

fﬁ Newsletters

4@ Polls

..[&] Reporting

“fafl Web analytics

2. In the Forum group pr(;perties, click Add forum (&#).

3. Add the following information for the new forum:
e Forum display name: New forum
e Forum code name: newForum
e Description: The description of the new forum.

Then click OK.

Switch to Site Manager

© 2011 Kentico Software
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&a Forum group properties

Forum groups *» My Forums
Forums General Wiew

Forums » Mew forum

Forum display name:

Forum code name:

Description:

Forum base URL:

Forum unsubscription URL:
Require e-mail addresses:
Display e-mail addresses:
Enable WYSIWYG editor:

Use security code (CAPTCHA):
Forum is open:

Forum is locked:

Forum is moderated:

New forum
newForum

The description of the new forum. -

Inherit from forum group
Inherit from forum group

[Z Einnerit from forum group

[T [l inherit from forum group

[Z Einnerit from forum group

[T [l inherit from forum group

O

]

4. The forum has been added as you can see in the following screenshot.

17
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Current user: Global Administrator| My details | Sign out

ion is the first of all pleasures.”

My Blog About Me Forums Photo Gallery

Forums

Velcome to my forums. You ca use these forums to discuss different topics. If you want to add new post or reply to a post you have to be
signed in. You can use the sign in link in the top right corner.

Search forums:

Forum Threads Posts Last post
My Forums
New forum
The description of the new forum. 0 0 (1/1/0001 12:00:00 AM)
Lock
Goodbye party )
Goodbye pa ) . Abi
Lock (5/28/2008 3:57:25 PM)

Where to go in Europe
Kate
Lock (5/22/2008 8:16:15 PM)
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3.1

Adjusting Design

Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will learn
which stylesheets are available and how you can choose the CSS stylesheet you want to use on your

website.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site

next to the Personal Site.

232 Kentico
#4% CMS5Site Manager Sites Administration Settings

6_} Sites

E:IJ Mew site wizard [E. Import site or objects [3 Export objects

Actions Site name -

@X W@ B M@ &3 Personal site

In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.

& Site properties
Sites » Personal Site

General Domain aliases Cultures

Site display name: Personal Site

Site code name: PersonalSite

Site domain name: localhost

Default content culture: | English - United States
Default visitor culture: | (Automatic) |Z|
Site CSS stylesheet

Editor CSS stylesheet | Personal Site ~ | ETE

Site description: Sample personal web site -

The following CSS stylesheets are available in the sample Personal Site:

Personal Site

© 2011 Kentico Software
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Current user: Global Administrator | My details | Sign out

My Blog About Me Forums Photo Gallery
Tags 8
My new blog post
airport  Austria bus cuisine =
Czech Republic France Germany
hitchh |k|ng hostel Summary of the blog post.
Italy luggage sacher torte
Slovenia Spain  subway
tourism  traffic  train Posted: 2/16/2010 10:02:43 AM by Global Administrator | with 0 comments
D Recent posts Saying goodbye Europe
U

» Saying goodbye Europe

¥ Wir sind Berliners

} Disappointment in Prague Paris, our final destination. Because there's no upcoming hitchhiking
} Sweetness of loneliness trip, the tension between PJ and me is all gone. I have a friend here,
¥ Sacher torte and Austrian <o the last night we spend in his place, drinking wine and using his

capital computer to look at pictures we've taken during our month in
Europe.
Today, PJ went to do some shopping and we've promised each
£ syndication other go out have dinner tonight.

Personal Site - Blue

© 2011 Kentico Software
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| My details

Personal starter site

Tags

b airport * Austria * bus * cuisine
} Czech Republic * France

F Germany Y hitCl'Il'likiI'lg

+hostel » Italy ¥ luggage * sacher
torte F Slovenia ' 5pain * subway
¥ tourism ¥ traffic ¥ train

] Recent posts

} Saying goodbye Europe

» Wir sind Berliners

} Disappointment in Prague
} Sweetness of loneliness

» Sacher torte and Austrian
capital

Syndication

Personal Site - Green

My Blog | About Me | Forums | Photo Gallery

a Saying goodbye Europe

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between P1 and me is all gone. I have a friend here,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we’ve taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2005 1:56:04 P by Abigail Woodwarth | with 3 comments

a Wir sind Berliners

" Berlin, after a long time the city we both wanted to see. And as we're
- A - almost done with our trip, we’re getting much more relazed in
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| My details

&

I:I .7 MyBlog w7 About Me wr Forums w Photo Gallery

Tags

Saying goodbye Europe
F airport * Austria ¥ bus * cuisine
¥ Czech Republic ¥ France
F Germany D hItCh hlkl“g
rhostel » Italy * luggage * sacher
torte * Slovenia * 5pain b subway
F tourism * traffic ¥ train

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between P1 and me is all gone. I have a friend here,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, P1 went to do some shopping and we've promised each
other go out have dinner tonight.

[3 Recent posts Pasted: 7/5{200% 1:56:04 PM by Abigail Woodwarth | with 3 comments

¥ Saying goodbye Europe

» Wir sind Berliners

+ Disappointment in Prague

+ Sweetness of loneliness

» Sacher torte and Austrian

capital U Wir sind Berliners

Eﬂ svndicati Berlin, after a long time the city we both wanted to see. And as we're
yndication & ﬁ - almost done with our trip, we're getting much more relaxed in

Personal Site - Red
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3.2

| My details

Personal starter site

"liusion is the first of all pleasures." - Oscar Wilde,

_ Search ¥ MyBlog ¥  Ahout Me ¥+ Forums < Photo Gallery

Tags .
k_J saying goodbye Europe

b airport * Austria ¥ bus ¥ cuisine
¥ Czech Republic * France

F Germany L hltCl'll'I lkl“g
rhostel » Italy * luggage ¥ sacher

torte P Slovenia ¥ 5pain » subway
F tourism F traffic ¥ train

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

{1 Recent posts Posted: 7/%/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

k Saying goodbye Europe

» Wir sind Berliners

k Disappointment in Prague

F Sweetness of loneliness

» Sacher torte and Austrian =

capital J Wir sind Berliners

- . . Berlin, after a long time the city we both wanted to see. And as we're
o) Syndication & & . almost done with our trip, we're getting much more relaxed in

Editing CSS stylesheets

In this chapter, you will learn how to change the design of your website by modifying the CSS
stylesheets.

Changing the header picture

1. Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site
and choose Main styles -> Master page section in the text box on the left side.

© 2011 Kentico Software
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_\21- Kentico Switch to CMS Desk  User: Global Administrator v5.0.3683
#3§%  CMS Site Manager Sites

Administration Settings Development | Licenses Support

(=) Development

G’ CSS stylesheet properties

L Categories

L o Countries CSS stilesheets » Personal Site
. CsS stylesheets

H Genersl | Sites

B @ Cultures

*.£l custom tables

: E’]‘ Document types
{3 E-mail templates

g qf} Form controls

«[E] Inline controls
B Modules

i) Notifications

*.[H Page layouts

i Page templates
:..=8 Relationship names

E Save @ Check out

Check out the stylesheet to file

The changes were saved.

Stylesheet display name: Personal Site
Stylesheet code name:  PersonalSite

.zoneTopMenu

| Abuse report

Sign out

Blogs
@System tables { Euﬂgﬂns
L& Tag groups height: 43px; Content rating
g eTlme TS width: T795px: r=1| [Forums
: . background: #fff url(../Epp Themes/PersonalSite/Images/bg_topmenu.g: Attachments
I cultures ﬂ padding: Ops: Global
eb part containers margin: Opx; Boxes
8t web parts ; Logon page
H ain styles
:-[@] web templates ) ’ Lgﬁmnu
.DesignMode .zoneTopMenu
:-[@] widgets 1 Master page
+ Workflows Stylesheet text height: 120px; Membership top zone
) Search box
Top menu
Modal popup
.zoneBottom My profile
i Photogallery

neight: 57px: Search page
width: 795px: Tags
padding-top: 15px;

text-align: center;

background: #e2e2e2 url(../App Themes/PersonalSite/Images/bg footte:

ol i ] G

2. Inthe .zoneTop style, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

.zoneTop

hei ght: 239px;

wi dt h: 795px;

background- col or: #fff;

paddi ng: Opx Opx 7pX;

mar gi n: Opx Opx Opx;

background: #fff url(../App_Thenes/ Personal SiteG een/| mages/ bg_head. j pg)
no-repeat top left;

Then click Save at the top-left.

3. Now click Sign out at the top-right. You can see that the header image has been changed.
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| My details

[ ] ' Search | My Blog About Me Forums Photo Gallery

J My new blog post
] Recent posts

» My new blog post

» Saying ik Europe Summary of the blog post.
+ Wir sind Berliners

} Disappointment in Prague

} Sweetness of loneliness Posted: 2f16/2010 10:02:43 AM by Global Administrator | with 0 comments

£J syndication
F RSS J Saying goodbye Europe

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

("7 Post archive

¥ February 2010(1)
» July 2008(3)
¥ June 2008(7)

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.

Changing the top menu

1. Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master
page section in the text box on the left side.

2. Scroll down to see .zoneTopMenu style.
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Switch to CMS Desk  User: Global Adrinistrator 6.0 3656 Sign
22 Kentico
#§% CMS Site Manager Stes  Administration  Settngs | Developmert | Licenses  Support
(5 Development (j CSS stylesheet properties

& Categories

@ Countries CB5 stylesheets » Persanal Site

G CSS stylesheets

General Sikes
- Cultures

- Custom tables E Save ﬂﬁ?' Check out
-l Document types -

- Q E-mail templates
- Form controls
[ Inline contrals
[‘ Modules Stylesheet display name: \Personal Site
i.| Notifications
[B Page layouts

Check outthe styleshestto file 'KenticoCMS_0225'CMSC! Py ite.css to edit the styleshest extarnally

Stylesheet code name: | PersonalSite

page templates /*#Hain styles/Master page#®/ | Abuse report
d wainDiv Blogs
- =3 Relationship names { Butions
- @ System tables width: 796px; = Contentrating
&P Tag groups wargin: 35px auto: Fumr:rtsachmems
@ Time zanes padding: Opx 7px Opx 7px; Slobal
background-color: #Eff;
- @ UI cultures H 3 Boxes
| Logon page
‘
eb part containers [ Main styles
o web parts Left menu
[@] web templates helghe: 23opxs .a 1 .ae
Stylesheet text : : : emuership lop zone
widgets L1 width: 795px; Search box
et Workflows background-color: #Eff; Top menu
background: #£ff urli../ipp Themes/Personal3ite/Images/bg head.jpg) Modal popup
¥ My praofile
Photogallery
.zoneTopMenbership Search page
{ Tags

width: 795px;
height: 15px;
padding: Ipx O 3px 0O:

« . v

3. Change the background color to #B0C4DE and erase the URL part so that the entire section reads
as follows:

.zoneTopMenu

hei ght : 43px;

wi dt h: 795px;

backgr ound: #BOCADE;
paddi ng: Opx;

mar gi n:  0px;

This will change the background of the navigation at the top to dark blue.

4. Now, switch to the Top menu section and find .CMSListMenuLl a:hover style. This style modifies
the appearance of menu item when mouse is ower it.
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d CSS stylesheet properties
CS58 stylesheets » Personal Site

General Sites

E Save f?l Check out

Check out the stylesheetto file ¢!

ootiManuals\CMSCS S Sty

\Personal Site.css to edit the stylesheet externally.

Stylesheet display name: |Personal Site
Stylesheet code name:  |PersonalSite

.CMSListMenulI a:hover,
i

.CMS5ListMenulLinkHighlighted, .CHSListMenuLIlast a:ht .

color: #000;

background: url(../Rpp Themes/PersonalSite/Images/bg_topmenu hover.g
text—-decoration: none:

.UnigridActionButton
1

margin-right: 5px:

Stylesheet text: .RTL .UnigridActionButton

i
margin-right:
margin-left:

auto;
Spx;

/*#Main styles/Left menuf*/
JleftMenu .CMSListMenulLI, .leftMenu
i

.CM5ListMenuHighlightedLI

background:
line-height:

none:;
18px:

4 T

Abuse report
Blogs
Buttons
Content rating
Forums
Aftachments
Global
Boxes
Logon page
Main styles
Left menu
Master page
Membership top zone
Search box
Modal popup
My profile
Photogallery
Search page
Tags

5. Change color to #fff and replace the url part with #87CEFA. The entire style should read as follows:

. OVBLi st MenuLl a: hover, . QVBLi st MenuLi nkHi ghli ght ed,
. CVBLi st MenuH ghl i ght edLI | ast a,

. QvBLi st MenuH ghl i ght edLl
{

a

color: #fff;
backgr ound: #87CEFA;
t ext - decor ati on: none;

. C\VBLI st MenulLl | ast a: hover,

This will change the background of the menu item to light blue and its font color to
hovers abowe it.

You've just learnt how modify CSS stylesheets to change design of your website.

white when mouse
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Adjusting Design

[] Recent posts

* My new blog post

¥ Saying goodbye Europe

» Wir sind Berliners

» Disappointment in Prague
+ Sweetness of loneliness

£ Syndication

* R55

(79 Post archive

» February 2010{1)
+ July 2008(3)
¥ June 2008(7)

| My details

J My new blog post

Summary of the blog post.

Posted: 2/16/2010 10:02:43 AM by Global Administrator | with 0 comments

J Saying goodbye Europe

Paris, our final destination. B there's no up g
trip, the tension between P1 and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to lock at pictures we've taken during our month in
Europe.

I N

each

Today, P] went to do some pping and we've p
other go out have dinner tonight.

29
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Adding web parts

4.1

31

Adding web parts

Adding text

In this chapter, you will learn how to add the new editable text region into your website.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web partin

zoneRight.

Switch to Site Manager ~ Site:| Personal Site[+] User: Global Administrator v5.0.3688 Sign out
232 Kentico
#4%  CMS Desk Content | Mydesk  Tools  Administration
C u ] 1
0 G Ber #e | 3 o[g o
New Delete |=bMove & Down || Edit  Preview Livesite List | Search |
Content management | View mode || other |
——=L =
n:'/-{-_;) Personal Site Page | Design | Form  Properties Display web part content @
'] My Blog - . P ;
T Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. -
[ ]/About Me E
_] Forums

(#-[] Photo Gallery
(1)%3J Special pages
(-5 Images

Current user: Global Administrator| My detsils | Sign out

Bl plcasiiESE= Oscar Wilde.

= [About Me - page template: Personal Site - About Me
¥ zoneleft + + zoneRight

> LeftText @ ~ TitleRegion @

|About Me

What can vou find on mv weh

2. Select Text/EditableText web part.
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M
#| Select web part -- Webpage Dialog ﬁ

B selectweb part

Q Recently used web parts Web part name:
=-%5) All web parts
-.i5) Abuse report
-5 Articles =
..75) Attachments if
) BizForms dal
-.i5) Blogs
-5 Booking system
] '{_L-j‘ Community
) Community services
%) Content rating
-.i5) Custom tables
-.i5) Data sources
-.74) E-commerce
) Events
-.i5) Forums
-5 Full-text search
.35 General
) Google services
) Listings and viewers
i) Media
-5 Media library
) Membership
i) Message board
-.i5) Messaging
-5 Navigation
-.15) News
) Newsletters
) Notifications
-5 Polls
-5 Reporting
) Silverlight
'i(j‘ Tagaging & categories
-5 [Text

-8 User contributions .
= Editable text
-] Web services

) widgets The Editable text web part displays an editable region that enabled content editors to edit page content.

Editable image Editable text Paged text Static HTML Static text

http://localhost/Manuals/CMS5Modules/PortalEngine/Ul/Webparts/WebPartSelector.aspx € Local intranet | Protected Mode: Off

3. In the Web part properties dialog, enter the following information for the new web part.
e Editable region title: AboutWebPageTitle
e Content before: <hl>
e Content after: </h1>

Then click OK.

4. Click Add web part again and select the same Text/EditableText web part.

5. In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click OK.

6. Now you have the new web parts ready and you can enter some new text. Switch to the Page tab
and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.

7. Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.

© 2011 Kentico Software



Adding web parts 33

E Save Spell check

Esorce|[Qid BB B EI&Giw |

MEO-O &S BIBl0| w8
Style ~ | Format ~ | Font v | Size M= AR

gives you a ride. Meeting her
family was great. We weren't
apparently the first hitchhikers
invited into this family in its
history. Therefore, everybody
knew what to do. We had a s o m s oo oooooooooo -
great lunch and only because AboutWebPageTitle

our busy schedule we had to \bout my web page -

rafiicad tn cnand 2 ninht thara

B #iB I U #|x £

=

AboutWebPageText
This is a short text about my web page i

That is how you add a new editable region into your website.
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4.2

Current user: Global Administrator| My details | Sign out

L vee

What can you find on my web About Me
site? There isn't much stuff on it y o

so far, stil working on it. What you -

might be interested in & my blog This is the new About me text.
from a trip around Europe that we -

took with my friend PJ this P e About mvy web page
summer. Hope to upload more - Y Pag

photos in near future. — This is a short text about my web page

My latest blog posts

6/11/2008 | Traffic in Trieste

They say Trieste is one charming
city. We barely had a time to
notice it, though, because we
were really busy taking care of
not being run over by the
insane Italian drivers.

Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll (&).

2 Kentico

#1N CMS Desk Content My desk Tools Administration

2~ Tools s Polls
-
@] Abuse report
BizForms @&l New pol
Blogs

P} Booking system
9& Content staging
-Fill custom tables
PR E-commerce

- [[q File import

&4 Forums

& Groups

..ol Media libraries
Message boards
£ Newsletters

& Polls

: Eﬁ] Reporting

‘..fall Web analytics

Mo data found.
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2. Enter the following information for the new poll.

e Display name: My poll
e Code name: MyPoll
e Question: How do you like my pictures?

Then click OK.

3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers
tab and click New answer (“#). Into the Text text box, enter | love them! and click OK.

@ Poll properties
Palls » My pall

General Answers Security Sites View

Answers » Mew answer

i New answer

Text: || love them!

4. Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.
Then click OK.

5. Click New answer again and enter Waste of time! into the text box provided. Click OK.

6. Now we are ready to add your new poll to website. Go to CMS Desk -> Content -> Personal Site ->
Photo Gallery and switch to the Design tab. Click Add web part in zoneLeft.
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232 Kentico
#4%  CMS Desk

@ Copy

New Delete [ Move

Content management

Tools Administration

Edit Preview Live site

View mode

List | Search ‘
|

pe

Switch to Site Manager

@ {‘"J Personal Site
(15 My Blog

-~ About Me

Forums

[+)-|1|Photo Gallery

|ﬂ 5] Special pages

-5 Images

Page | Design | Form  Properties

Other

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Site: | Personal Site[w] User: Global Administrator v5.0.3688

Current user: Global Administrator| My details | Sign out

Sign out

==
Display web part content @

= [Photo Gallery - page template: Personal Site - List of galleries

¥ zoneleft

(+

* zoneRight

v LeftText {8

About my photos

¥ HeaderText @

List of galleries

7. In the Select web part dialog, select Polls\Poll web part.
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#| Select web part -- Webpage Dialog

B selectweb part

Q Recently used web parts
=-%5) All web parts
Abuse report
Articles
Attachments
BizForms
Blogs
Booking system
Community
Community services
Content rating
Custom tables
Data sources
E-commerce
Events
Forums
Full-text search
General
Google services
Listings and viewers
Media
Media library
Membership
Message board
Messaging
Navigation
News
Newsletters
Notifications
Polls
Reporting
Silverlight
Tagaging & categories
Text
User contributions
Web services
Widgets

GLLLBELEELLLLBLELEBLLLLBLLEBELELLLLD

Web part name:

Poll

Poll

The Poll web part allows you to insert your own Poll on the page.

http://localhost/Manuals/CMS5Modules/PortalEngine/Ul/Webparts/WebPartSelector.aspx

€ Local intranet | Protected Mode: Off

8. In the Web part properties dialog, make sure My poll is selected as Poll name and click OK.

Congratulations, you've just learned how to add a new poll to your website.
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Current user: Global Administrator| My details | Sign out

o moer sowme roums

About my photos List of galleries

Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload

more pictures in near future.
I'm far from being a professional

photographer. Therefore, if you're
looking for mesmerizing pictures, European Trip
advise you to search somewhere :

else. Set of pictures, we've taken on our hitchhiking trip around
Europe with my friend P1. Additional pictures are to come.
How do you like my pictures?

1 love them!

©) Mot bad.
) Waste of time!

Sweet Home Arizona

MNothing compares to smell of desert after moonson rain.
Mothing compares to sound of coyote howling at the Moon.
MNothing compares to view of blossoming saguaro.

MNothing compares to Arizona.

New gallery
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Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

e Kentico CMS Tutorial
e Kentico CMS Developer's Guide

e Kentico DevNet at http://www.kentico.com/DeviNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.

com/Support.aspx.
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