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1.1

1.2

Introduction

About this guide

Welcome to Kentico CMS Community Guide. This guide will provide you assistance with building on-
line communities using Kentico CMS.

Kentico CMS comes with the sample Community Starter site. This sample website template can be
conveniently used as a starting point of your own community site development. In the first part of this
guide, we will go through the various customization tasks that need to be done if you want to develop
your community site based on this template. The second part will describe building community sites
from scratch.

Sign In

Community

Starter site

Home  Blogs  News  Media F I._,_I“L - Examples | ||Search

H Sign in
Welcome to our community 0
Iml |W|
Log on
This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new Shortcuts
people and all the things related to it. Join the community
If you are interested in this sort of things, don't hesitate and
join now!
Latest news
Latest blog posts Latest forum posts Travellers’ communil
site launched
The long long flight RE:Hostels in London We have just Iauljdﬂ_ed our
Finally, after some 23 hours of fight, I am on the other side of the world well, ok...well...there is actually not enough room for two guests in my ggﬁmiﬂsﬁﬂ:ggzd
than I was yesterday around this time. I feel terribly tired after the long place... paint for travellers from al
fiight, but before I go to sleep, I found some time to write about the first Posted on 1/7/2009 3:13:50 PM around the world.

impressions of my journey.

Posted on 10/26/2008 3:05:12 PM
RE:Hostels in London

Hying tomorrow Thanks, but the reason why I'm looking for a hostel in London is actually
Hi everybody, my name is Kelly Taylor and I come from Brna, Czech that I'm gonna b_e waiting for my boyfriend there. He'll be returning from
Republic. Tomorraw is my big day. Finally, after six months of hard ﬂ:f Sbiahehs and ;1’:5 plane lands Iat Heaﬁ:lrow. - But we can c_(]:cme o Latest Groups
everyday work, I dedded to have some nice time and go on holiday. Edinburgh together some time later and stay at your place if you N
want...? African travellers

Australia has always been one of the places I had wanted to visit one
day, and now, with my great new job and the wage I get for it, itis Posted on 1/7 /2009 3:11:33 PM
finally affordable for me to get there,

Posted on 10/26/2008 2:19:18 PM

This is a group of
B travellers living in Africa,
1f you are one of them, please
register to the group. Itis a

RE:Hostels in London great chance f...

Community features

Community sites are such websites that bring the possibility of on-line interconnection of people, usually
those who share the same interests or who are members of some real-world group and have the need to
meet on-line. For the purposes of the community, such site should provide the possibility of gathering in

groups, discussing in forums, blogging, advanced membership with the possibility of friendship between

users, customized user profiles, various sign-in possibilities, etc.
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Kentico CMS is a full-featured solution for building complex community sites without any complex
programming. Here is a list of the most important built-in community features of Kentico CMS:
e Community Groups

* Forums

e Blogs

e User profiles

e Badges

e Friends

e Bad words

e Abuse report

e Polls

e Content rating

e Time zones

All the implementation processes have been diminished to only a few clicks, so that you can use most
of the features out-of-the-box.

© 2011 Kentico Software
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2 Part 1

2.1 Getting started
2.1.1 Installing the site

To get started, you need to have the sample Community Site installed. There are two ways how this can
be achieved:

1. If you are performing a new installation, you can choose the site in the Starter Site step of the
Database Setup (the number of the step may vary). Select the Choose starter site radio-button and
choose the Community Site from the list of starter sites. Click Next to finish the setup procedure.

Step 5 - Starter Site

2 - 8- @ -
— - \
=y " ”ES

SOL Settings Database Starter Site Finish

partal engine and it is the recommended choice for
developers who are new to Kentico CM3.

Community Site

This is a web site template for a sample community site.
Social networking features of Kentico CMS are used on the
site to give you an idea of how they can be used on your web

~ site. You can also modify this web site and use it as a base
for the development of your own site. It uses the portal engine

Blank Site

This template is intended for developers who wantto create a
new web site from scratch. It uses the portal engine.

(7 Continue to the New site wizard
() Import existing Kentico CMS web site

Version: 5.0 Build: 5.0.3693

2. If you already have Kentico CMS installed, but without the Community Site, you can easily add the
site in Site Manager -> Sites.

a) Click the New site wizard link at the top left corner of the page.
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e Kentico
#9%  CMS Site Manager Sites Administration Settings

EJ Sites

[;’_']. Import site or objects [3 Export objects

b) In Step 1, choose Use website template and click Next.

Choose default web site

If you choose to create a blank site, the wizard will guide you through the process of creating a new site. If
you choose to use atemplate, you will be able to choose one of the predefined web site templates.

() Create a new site using a wizard
I @ Use web site template I

Step 1

¢) In Step 2, choose Community Site form the list of available website templates and click Next.
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Choose web site template
Step 2 Choose the predefined web site template that will be used for your new web site. The web site template
may contain site structure, design, basic content, new document types and other settings.

[ | * | capabilities and it can be used as a starting site that you modify as needed. It uses the portal engine and its the a
recommended choice for developers who are new to Kentico CMS.

Personal Site
This is a web template for a sample Personal site. Several Kentico CMS features, such as blogs, forums and photo

galleries, are included. It can be used as a cornerstone for the custom personal site development. The template uses the
portal engine and it is the recommended choice for developers who are new to Kentico CMS.

Community Site

m

This is a web site template for a sample community site. Social networking features of Kentico CMS are used on the site to
give you an idea of how they can be used on your web site. You can also modify this web site and use it as a base for the
development of your own site. It uses the portal engine and is recommended for developers who are new to Kentico CMS.

Blank Site

This template is intended for developers who want to create a new web site from scratch. It uses the portal engine.

d) In Step 3, specify the display name, code name and domain name of your site and click Next.

Enter new site settings

Step 3 Enter the display name and code name of the web site. The Domain field must contain the domain that you
will use to access the web site during development (you may change it when the site goes live). The default
culture is the main language of the web site.

Site display name: Community Site
Site code name: | CommunitySite

Domain name: localhost
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e) In Step 4, leave the settings at their default values and click Next.

Objects selection

Step 4 Please select objects which should be imported.

(=)- All objects - I . ol
i @ mport objects {
d@ Web site ) P J @

‘[l Documents

Please note: The import process may overwrite your existing objects. The existing objects are
marked with * and will be overwritten if checkad.

@€l Administration

: Please selectthe object type from the tree if you wish to change the default selection.
- Settings Click Next to startthe import of selected objects.
| [x)-=5 Development
= Global objects Global selection
|1l°5' Tools Load default selection Selectall objects Select only new objects  Deselect all objects

(- €] Administration
(x5 Development

m

Import settings

Assign all objects to the imported site (recommended)
Run the site after import

[T pelete incomplete site when import fails

Import files (recommended)

[ oo not import objects where parent object is missing
Import tasks (recommended)

f) Wait until the end of site import process, you will be redirected to the following step of the wizard.
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Import progress
Step 5 Objects are being imported.

Importing ‘Page templates’ objects
Importing ‘Page template categories® objects
Importing ‘Page layouts' objects

Importing ‘Countries’ objects

Importing ‘Ul cultures’ objects

Importing ‘CSS stylesheets’ objects
Importing "Settings' objects

Importing "Settings categories’ objects

Objects are being imported " =Preious | cancel [Tl
E =

g) In the last step, you can click the Edit your new website link to go to CMS Desk, where you can
start editing the site immediately.

The web site has been created successfully
Step 6 Mow you can view and edit your new web site.

Edit your new web site

Ifthis is your first web site, the default user account is administrator without password.
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212

You can also click the Finish button to go back to Site Manager -> Sites, where the site should be

listed with the name specified in Step 3.

@ Sites

) New site wizard [} Import site or obiects

Actions Site name »

/%95 b8 o (o]

First sight

[ Export obiects

Status

Running

When you have the Community Site installed and running, why not go to the live site and see it in
action. To see all the features working, sign in using the Sign in form at the top of the right side column.
Use e.g. user name David with blank password. Once signed-in, you should see the site as in the

screenshot below:

{& Community Starter Site - Home - Windaows Internet Explorer

m@g

u @ A4 |-:i:- http://localhost/KenticoCMS/default.aspx

[ x | 50s

PRl

¢ Favorites =i= Community Starter Site - Home | |

i~ v [ gm v Pagev Safetyw Took~w @@~
-

1.

Groups  Members

Current user: David Sitver (David) | My home page | Edit my profile | Inbox | Sign out

Examples

Welcome to our community

This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new

Sign in to CMS Desk. Sign in to CMS Site Manager. The default acoount is administrator with blank password.

-

m

|| search

The long long flight

Finally, after some 23 hours of fiight, T am on the other side of the world
than I was yesterday around this time. [ feel terribly tired after the long
flight, but before I go to sleep, I found some time to write about the first
impressions of my jouney,

Posted on 10/26/2008 3:05:12 PM

finally affordable for me to get there.
Posted on 10/26/2008 2:19:18 PM

RE:Hostels in London

Well, ok...well.. there is actually not enough room for two guests
place...

Posted on 1/7/2009 3:13:50 PM Repor

hmy

abuse

(

Shortcuts

My profile

Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog

people and all the things related to it. \ Sign out
If you are interested in this sort of things, don't hesitate and
join now! / Latest n
.
Latest blog posts Latest forum posts Abi's got a blog

RE:Hostels in London

RE:Hostels in London

Elying tomorrow Thanks, but the reason why Tm looking for a hostel in London is adtually

Hi everybady, my name is Kelly Taylor and I come from Brma, Czech that I'm gonna be waiting for my boyfriend there, He'll be returning from Latest Groups

Republic. Tomorrow is my big day. Finally, after six months of hard g‘f itabe:;nd E“s plane \aﬁnds ‘agaaﬂ;ro‘v;. o E”t we clan came ey African travellers
everyday work, I decdded to have some nice time and go on holiday. y " urg ‘gether some time later and stay at your place I you This is a group of
Australia has always been one of the places 1 had wanted to visit one want...? B2 yravellers living in Afiica.
day, and now, with my great new job and the wage I get for it, it is Posted on 1/7/2009 3:11:33 PM Reportfabuse s e e e e

Abigail Woodwarth, our site
member from LA, California,
has recently set off for
Europe. You can look forward
to reading posts about all the
interesting places she is going
to visit,

register to the group. Ttis a
great chance f...

L i

l Australian travellers
Saying dbye Europe Dear young lady, don't go to London, you won't like it there, @me to \ ai Thisisagroupof 2
‘-‘-"-_ Tocal intranet | Protected Mode: O H100% -

1. At the very top of the page, you can see the CMS Desk and CMS Site Manager links. These can be
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used to access the administration interface from the live site. Default user name is administrator with
blank password. Alternatively, the administration interface can be accessed via the following URLs: <site
domain>/CMSDesk or <site domain>/CMSSiteManager.

2. Links to the current user's public profile, profile editing, internal messaging inbox and the Sign
out link that can be used to log off the site.

3. Main menu. The menu reflects site structure, particular items in the menu lead to the following
sections:

e Home - home page of the website, displaying latest blog and forum posts in the main area and various
other information in the side column

e Blogs - in this section, you can read blog posts in site users' blogs or easily create your own blog
right on the live site and start blogging immediately

e News - the news section is designed for displaying news items created by authorized CMS Desk
users, typically site administrators and editors

e Media - in this section, you can view content of the site's public media libraries; various types of files
can be stored in these libraries, while large file sizes (several GB) are supported

e Forums - discussion forums, you can read or join discussions on various topics and create new
topics; both classical and Q-A forum types are supported

e Groups - in this section, you can view existing community groups and join some of them or even
create your own new group; groups can have their own media libraries, forums, polls and message
boards

e Members - this is where you can see a complete list of site members; by right clicking their avatars,
you can display a context menu allowing you to do several actions related to the clicked user; by left-
clicking a user's avatar, you can view the user's public profile

e Examples - in this section, you can find isolated examples of particular community web parts; these
examples are particularly useful when you access them from CMS Desk, where you can view web part
properties settings

4. This is the main zone where the content is displayed. On the Home page, it displays the Sign-in/Join
banner and extracts from the latest blog and forum posts.

5. Integrated full-text search of all documents on the site.

6. The shortcuts box displays shortcuts to various community functions. It offers different actions
depending on which section of the site is currently displayed.

7. The rest of the side column displays various repeaters and information boxes depending on which
section of the site is currently displayed.
2.2 User registration and Sign-in

2.2.1 Current functionality

In the following example, you will learn how to register to the site and become its member.

1. If you come to the site as a site \visitor and want to register, there are sewveral links to click. All of the
links highlighted in the screenshot below will take you to the Logon page where registration can be
performed. Click one of them.
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Community

Starter site

|| searcn

Home  Blogs MNews Media F up: b  Examples

Welcome to our community sign in

This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new
people and all the things related to it.

If you are interested in this sort of things, don't hesitate and
join now!

Latest news

Latest blog posts Latest forum posts P S ———

2. On the logon page, site \isitors can register by filling in the Join the community form. Enter some
sample details and click Register.

Sign In

Community

Starter site

Home  Blogs  HNews  Media F . up. “‘IIExamﬂmI | ||Search

Sign in Join the community
User name: User name: Derek
Password: First name: Derek
[“I remember me Last name: McKenzie
—— Email: ckenzie@localhost.local
Password: "TTIT]

Forgotten password
Confirm password: gesee

Gender: @ Male ) Female

3. You will be redirected to your public profile. This profile is visible to all site visitors and users and gives
them an ovenview about yourself. Let's modify your details a bit now. Click the Edit my profile link in
the Shortcuts menu. You will be redirected to the profile editing page.
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Current user: Derek McKenzie (Derek) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Member profile

Shortcuts

Derek

Badge: My messages
My friends
My invitations

Create a new group
Email: mckenzie@localhost.local Create a new blog

Created: 2/16/2010 Sign out
Gender: Male
Date of birth: N/a My friends

Currently doesn't have any
friends.

Fullpame:  Derek McKenzie

Forum posts:

Message board posts:
Blog posts:

Blog comments:
Community points: My blogs

Currently doesn't have any
blogs.

o o oo

My announcements

There are currently no announcements,
My groups
Currently is not member of any
aroup.
Leave message Subscribe

4. Let's choose some avatar so that your profile looks more personal. Click the Select pre-defined
avatar link as highlighted in the screenshot below.
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Current user: Derek McKenzie (Derek) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home Blogs HNews Media F up Memb . Examples | || searcn
My profile
Shortcuts
Personal settings | Change password | Notifications | My profie
Edit my profile
Username: Derek My messages
- My friends
Full name: Derek McKenzie My invitations
il Lreste a new group
Email: mckenzie@localhost local Create a new arou
Create a new blog
Display my e-mail to: () Nobody () (all) @) Site members (7 Friends Sign out
Mickname: Derek
- My blogs
‘fou currently do not have any
Signature: blogs.

M rou
Messaging notification e-mail: L
‘fou are currently not member
Time zone: | (none) |Z| of any group.
Avatar: Upload: Browse...
Select pre-defined avatar Forum favorites
Gender: @ Male ) Female No favorites found
Date of birth: @No_w

5. The gallery of pre-defined avatars will be displayed. Choose one and click OK.

e ™y
& | Avatars gallery -- Webpage Dialog u

Please select an avatar

[
I~
[3%]
I

Ok Cancel

http://localhost/KenticoCMS/CMSM €&s Local intranet | Protected Mode: Off

6. Let's also add your date of birth. Click the calendar icon next to the Date of birth field, pick a date
and click OK.

7. Finally, click OK on the profile editing page to save the changes. If you click the My profile link in
the Shortcuts menu again, you will see your profile with the avatar and date of birth added.

© 2011 Kentico Software



Part 1 19

Current user: Derek McKenzie (Derek) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

. Media F . up. Memb || | ||Search

Shortcuts

My profie
Dere" Edit my profile
Badge: My messages

My friends
My invitations
Create a new group

Fullpame:  Derek McKenzie

Email: derek.mckenzie @localhost. local Create a new blog
Created: 2/16/2010 Sign out
Gender: Male
Date of birth: 11/13/1335 My friends
Forum posts: o Currently doesn't have any
Message board posts: i} friends.
Blog posts: ]
Blog comments: ]
Community points: My blogs
Currently doesn't have any
blogs.
My announcements

Further steps: This was only a brief example of what can be done. Try playing around with the settings
and explore the various possibilities. You can for example use an image from your local disk instead of
the pre-defined avatars. You can also go to the Members section, where profiles of all sample site users
can be accessed from. Notice that the Shortcuts menu displays various actions depending on what
content is currently displayed. Performing the actions is very intuitive, so don't be afraid and try them
out.

2.2.2 Modifying the registration form

In the following example, you will learn how to modify the registration form used on the logon page. For
the purpose of this example, we will want the Middle name field to be specified by users on
registration.

The registration form is displayed using the Custom registration form web part. This web part enables
user registration based on an alternative form of the CMS_User system table. For more information
about the Alternative forms concept, please refer to the Module Alternative forms chapter of Kentico
CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the User (CMS_User) system table.
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212 Kentico

#¢% CMS Site Manager

=)~ Development

-&Jl Categories

-4 Countries

g Css stylesheets

- Cultures

-fiill Custom tables
: Document types
f'_] E-mail templates
4’} Form controls
/= Inline controls
{4 Modules
‘..l Notifications
--{H Page layouts
ﬁ Page templates
.-E5 Relationship names
ﬁ System tables
.+&§ Tag groups
4 Time zones
@ UI cultures

—

Switch to CMS Desk

MNewsletter - Subscriber newsletter.subscriber

User Cms.user

Sites Administration Settings Development Licenses Support
@ System tables
Actions = Class display name - Class name
V4 Ecommerce - Customer ecommerce.customer
f Ecommerce - Order ecommerce.order
f Ecommerce - Order item ecommerce.orderitem
& Ecommerce - Shopping cart ecommerce.shoppingeart
f Ecommerce - Shopping cart item ecommerce.shoppingcartitem
f Ecommerce - SKU ecommerce.sku
& Group Community. Group
Va Media file mediafile
4
s

Lser - Settings cms.usersettings

User: Global

Table name
COM_Customer
COM_Order
COM_Orderltemn
COM_ShoppingCart
COM_ShoppingCartskU
COM_SKU
Community_Group
Media_File
Mewsletter_Subscriber
CMS_User
CMS_UserSettings

2. Switch to the Alternative forms tab. Choose to Edit (#) the Registration form alternative form,
which is the one currently used on the logon page. As you can see, the other alternative forms are used
for user profile displaying and editing.

212 Kentico

#1% CMS Site Manager

=) Development

..l Categories

@ Countries

G CSS stylesheets

- Cultures

“.fi} custom tables
cﬂ Document types
E-mail templates

Switch to

Sites Administration Settings Development Licenses Support

ﬁ System table properties

System tables » User

Figlds Queries Alternative forms

E‘ﬁ, Create new form

{‘5 Form contrals Actions = Display name «
@ Inline controls 7R Display profic
"¢ Modules
| Notifications # &  Editprofile
.-[H page layouts # % Ediprofile (Community)
@ Page templates # 38 Editprofile (MyDesk)

...e8 Relationship names
fHl system tables
-4 Tag groups

- Time zones

.

Registration form

Code name
DisplayProfile
EditProfile

EditProfile Community
EditProfileMyDesk

RegistrationForm

3. Switch to the Fields tab. This is where you can define which fields of the User system table will be
displayed in the form. Select the MiddleName field from the list on the left and check the Display
attribute in the editing form check-box. Enter the following details:

e Field caption: Middle name
e Field type: Text box

Click OK.
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4% CMS Site Manager

=)~ Development

- Categories

@ Countries

.- €55 stylesheets

@) cultures

--fifl custom tables
.-l Document types
i Q E-mail templates
‘& Form controls
o[ Inline controls
- (3 Modules

.| Notifications
.-['H page layouts
-[@ Page templates
-5 Relationship names
[ System tables
-&# Tag groups
& Time zones
3 UI cultures
Web part containers
- % web parts
.[@] Web templates
-[8] widgets
ol Workflows

Sites Administration Settings Development

@ System table properties
System tables » User

Fields Queries Alternative forms

Alternative forms » Registration form
Fields

General Layout

Licenses

Switch to CMS Desk

Support

UserlD
UserMame

T lDispIay attribute in the editing form ]

Firsttlame

LastMame

FullMame

Email

UserPassword
PreferredCultureCode
PreferredUICultureCode

Field
Default visibility:

m

Visibility contral:

Allow user to change field
visibility:

Displayto all
Visibility (drop down list)

]

21

User: Global Administrator v5.0.

] [E]

UserEnabled

UserlsEditor
UserlsGlobalAdministrator
UserlsExternal
UserPasswordFormat
UserCreated

Field caption:

Field type:

Middle name

Text box

LastLogon
UserStartingAliasPath
UserGUID

UserLastModified
UserLastLogoninfo
UserlsHidden

UserVisibility

UserlsDomain -

Field description

m

4. Switch to the Layout tab. This is where you can define the layout of the form. Right-click the line with
the FirstName controls. From the context menu, choose Row -> Insert row after. Select MiddleName
from the Available fields list and use the Insert label, Insert input and Insert validation label
buttons below to insert the label, input and validation controls into the new table row. The result should
look as in the following screenshot.

Click Save.
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Switch to CMS Desk  User: Global Administrator v5.0

232 Kentico

#§% CMS Site Manager

(=) Development

5 Categories

@ Countries

& CSS stylesheets
& cultures

‘..fH]l Custom tables
{1 Document types
@ E-mail templates
é Form controls
Inline controls
¢ Modules

L] Notifications

['H Page layouts

i Page templates
.08 Relationship names
@ System tables

i &P Tag groups

.0 Time zones

UI cultures

: Web part containers
<& web parts
[@] Web templates

[+ workflows

{

Sites Administration Settings | Development | Licenses Support
ﬁ System table properties

System tables » User

Fields Queries | Alternative forms |
Alternative forms » Registration form

General Fields | Layout |

= sz

Use custom form layout

Generate table layout

£ Source | @ E ‘ iy f.;xg

E <
en

v | Size

- | Fant

Style - | Farmat

G- Wil

$5label:Userramess $SinputUserMame$§$svalidation:UserName$s

S5label:Firsthamess BSinputFirstName$5$Svalidation:FirsthName 53
|$$IabeI:MiddIeName$$ $$input-MiddleName$$$5validation:MiddleName$s|

$5labelLastNamess BhinputLasthNameddbdvalidation:Lasti aAMess
$5label:Emailss B8input:Email$$$svalidation:Emailss

$5label:UserPassword$s
S%inputUserPassword$$Sbvalidation:UserPassword$$
Confirm password:

$5lapelUserGenderss  $SinputUserGender$$$svalidation:UserGenderss

3

m

Available fields:

UserName

Firsthame

LastMame

Email

UserPassword
UserlsDomain
UserHasAllowedCultures
UserGender
UserWaitingFordpproval
UserDialogsConfiguration
UserDescription

Insert label
Insert validation label

Insert submit button

Insert visibility control

5. If you go to the live site now and open the Logon page, you should see the modified version of the
alternative form, just as in the screenshot below.

Sign In

Community

Starter site

| | Search

Sign in Join the community
User name: User name:
Password: First name:
[E1Remember me [ Middle name: ]
Log on Last name:
Email:
Forgotten password
Password:

Confirm password:

Gender: D male ) Female
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Further steps: You hawe learned how to modify the registration alternative form. The same way, you can
add other fields to the form according to your needs. You may also try creating a completely new
alternative form and using it for registration. The new alternative form needs to be specified in the
Alternative form property of the Custom registration form web part. You can find a step-by-step
tutorial on how to do this in Kentico CMS Deweloper's Guide -> Membership and User reqistration ->
Creating a custom registration form.

Modifying user profiles

You can define which information will be displayed on users' public profiles. In the following example, you
will learn how to add the User ID field to the public profiles.

User public profiles display information from the CMS_User system table using an alternative form. In
our case, it is the Display profile alternative form. We will have to modify the alternative form to achieve
the required functionality. For more information about the Alternative forms concept, please refer to the
Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the User (CMS_User) system table.

=3£ Kentico
#¢% CMS Site Manager

=) Development

-&Jl Categories

-4 Countries

g Css stylesheets

- Cultures

-fiill Custom tables

n]1 Document types
[ E-mail templates
«‘f} Form controls
/= Inline controls
- Modules
/.| Notifications
--{H Page layouts
ﬁ Page templates
.-E5 Relationship names
- fii|System tables
.+&§ Tag groups
@ Time zones
) Ul cultures

—

Sites Administration

Settings

@ System tables

xgxxxxxxxxxg

Class display name -
Ecommerce - Customer
Ecommerce - Order
Ecommerce - Order item
Ecommerce - Shopping cart
Ecommerce - Shopping cart item
Ecommerce - SKU

Group

Media file
Newsletter - Subscriber
User

Lser - Settings

Development

Switch to CMS Desk

Licenses Support

Class name
ecommerce.customer
ecommerce.order
ecommerce.orderitem
ecommerce.shoppingcart
ecommerce.shoppingcartitem
ecommerce.sku
Community. Group
media.file
newsletter.subscriber
cms.user

cms.usersettings

User: Global

Table name
COM_Customer
COM_Order
COM_Orderltemn
COM_ShoppingCart
COM_ShoppingCartskU
COM_SKU
Community_Group
Media_File
Mewsletter_Subscriber
CMS_User
CMS_UserSettings

2. Switch to the Alternative forms tab and choose to Edit (#°) the Display profile alternative form.
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212 Kentico

#¢% CMS Site Manager

=) Development

-l Categories
-4 Countries
¢ css stylesheets
@) Cultures
*fill custom tables
..l Document types
Q E-mail templates
{35 Form controls
+[E Inline controls
¢ Modules
<. Notifications
--[H Page layouts
i Page templates
B8 Relationship names
[ system tables
\-%¥ Tag groups

Sites Administration

Settings

Switch to CMS Desk

Development Licenses Support

@ System table properties

System tables » User

Fields Queries

E‘ﬁ, Create new form

Actions
7R
7R
7R
7R

Display name =
Display profile

Edit profile

Edit profile (Community)
Edit profile (MyDesk)

Registration form

Alternative forms

Code name
DisplayProfile
EditProfile
EditProfileCommunity
EditProfileMyDesk

RegistrationForm

3. Switch to the Fields tab. Select the UserID field from the list on the right and check the Display
attribute in the editing form check-box. Click OK to save the changes.

232 Kentico

4% CMS Site Manager

=) Development
.5 Categories
@) Countries
G CSS stylesheets
-3 Cultures
--fil Custom tables
G’ﬂ Document types
f_c} E-mail templates
- Form controls
| Inline controls
¢ Modules
-Ji. Notifications
-.[HPage layouts
i Page templates
-0 Relationship names
-{f System tables
-.&9 Tag groups
- Time zones
5 UI cultures

i Web part containers
-.g® web parts

-.[@] web templates
-.[@] widgets

[ Workflows

—

Sites Administration

Settings

Switch to CMS Desk

Development Licenses Support

ﬁ System table properties

Systemtables » User

Fields Queries

Alternative forms » Display profile

General Fields Layout

UserMName

Firsthame
MiddleName
LastMame

FullName

Email

UserPassword
PreferredCultureCode
PreferredUICultureCode
UserEnabled
UserlsEditor
UserlsGlobalAdministrator
UserlsExternal
UserPasswordFormat
UserCreated
LastLogon
UserStartingAliasPath
UserGUID
UserLastModified
UserLastLogoninfo
UserlsHidden
UserVisibility
UserlsDomain

-

m

Alternative forms

Database
Affribute name:
Attribute type: Integer number
Aftribute size:

Allow empty value: [

Attribute defaultvalue:

Display attribute in the editing form

Field

Default visibility: Display to all

Visibility control: Visibility (drop down list)
Allow user to change field m
visibility:

Field caption: UserlD

User: Global Administrator v5

»

m

ENJEN

4. Now we need to modify the layout of the profile, so switch to the Layout tab. Place the cursor in the
first column of the empty line below the FullName line and choose UserID from the Available fields list

on the right.
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Click the Insert label button. Select the text that was entered and make it bold so that it looks the
same as the other labels. Place the cursor to the second column of the line and click the Insert input
button.

The result should look as in the screenshot below. Finally, click Save to save the changes.

.\2’- Kel'l thO Switch to CMS Desk  User: Global Administrator v5.0
’.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
=)~ Development @ System table properties
- Categories
0 Countries System tables » User
i..gf CSS stylesheets
: Fields Queries Alternative forms
€ cultures
-fi}l Custom tables Alternative forms » Display profile
ﬂ Document types
[2) E-mail templates General  Fields | Layout
<.§ Form controls
- E Save
Inline controls
¢ Modules
| Notifications
Use custom form layout
--['# page layouts ___
i Page templates Generate table layout
.= Relationship names . . . ) .
: § E Sowce | [& £ =) ey 7 Available fields:
5 ; :
. Tag groups IB 7 U sm|x @IS E=E = = & UserName B
@ Time zones HE == == =1 1Ak EuIIN_lame
. mai
ul C:Itures . H £ Style - | Farmat - Font - Size - UserCreated =
Web part containers f e UserlsDomain
Web parts i N-iOR UserHasAllowedCulture
. - | |UserMickMName
[el W.Eb templates $$|nput:UserNamE$$ || |UserfvatarlD B
(8] widgets : UserBadgelD
* & Workflows $$label:UserBadgelD$$  SSinputUserBadgelD$3 _| |UseractvitPaints
$$labelFullName$$ $SinputFullNames$s 7| |UserForumPosts
UserBlogComments -
I $$label:UserlD$$ $8inputUseriD3S ]
$$label:Email$$ $SinputEmail3s W
$$label:UserCreated$$ $SinputUserCreated$s W
$$label:UserGender$$ $SinputUserGenderss MR

$$label:UserDateOfBirth$$  55inputUserDateOfBithss Insert submit button

]

[ | v

Insert visibility control

5. Now if you switch to the live site and sign in as some of the sample users (e.g. David with blank

password), you should see the UserlID field present on their profile, as highlighted in the screenshot
below.
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Current user: Davwid Silver (David) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home  Blogs MNews Media F ._.. “L|| | || search

Member profile
Shortcuts
- My profil
DaVId Edit mog ;oﬁle
Badge: 338 My messages

My friends

My invitations
Create a new group
david.silver @localhost.local Create a new blog

Full name:  David Silver

Created: 10/25/2008 Sian out
Gender: Male
Date of birth: 5/5/1987 My friends
Forum posts: 3 Y Kell
Message board posts: 1] 6 Gender: Female
3 .
Blog L 0 Age: _2?
Tessie
Blog comments: 0 l Gender: Female
Community points: 20 Age: 25

Further steps: You have learned how to modify the user public profile. This way, you can add any other
field to the profile. You may also try creating your own alternative form and use it for displaying user
profiles. The new alternative form needs to be specified in the Form name property of the User public
profile web part. You may also try modifying the Edit profile (Community) alternative form the same
way. Like this, you can allow users to modify some additional details of their profile on the profile editing
page.

Enabling public profile fields visibility controls

You can let users specify who will see particular details on their public profiles. By default, this is
enabled for the e-mail field, as you can see in the screenshot below. Using the highlighted radio-buttons,
users can make their e-mail address \isible to:

Nobody - nobody can see the e-mail address

All - everyone including anonymous site \isitors can see the e-mail address

Site members - only authenticated site users can see the e-mail address

Friends - only authenticated site users who are among the user's friends can see the e-mail address
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Currentuser: Mia Lee {(Mia) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home  Blogs MNews  Media F up Memb | Examples | || searcn

My profile
Shortcuts
Personal settings | Change password | Notifications | My profie
Edit my profile
Username: Mia My messages
- My friends
Full name: Mia Lee My invitations
Email: mia.lee@localhost local Create a new arou
Create a new blog
[ Display my e-mail to: () Nobody () (all) @ Site members () Friends ] Sign out
Mickname: Mia
$-Ma-Ma-Mia-3% o My blogs
‘fou currently do not have any
Signature: blogs.

M rou
Messaging notification e-mail: ¥Yg ps ;
Asian travellers
Time zone: | (none) |Z| This is a group of Asia-

based travellers, If you
are living in Asia, please
register to the group. Itis a
great chance for ...

In the following example, you will learn how to let users set the visibility of their full name.

User profiles display data stored in the CMS_User system table based on the specified alternative form.
In our case, it is the Edit profile (Community) alternative form. We will have to modify it to achieve the
required functionality. For more information about the Alternative forms concept, please refer to the
Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Signin to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the User (CMS_User) system table.
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#¢% CMS Site Manager

=)~ Development

.45 Categories

@ Countries

& €S5S stylesheets

) cultures

il Custom tables

0]1 Document types
<] E-mail templates

4’} Form controls

= Inline controls

‘B Modules

| Notifications

['H Page layouts

ﬁ Page templates

=5 Relationship names
ﬁ System tables

¥ Tag groups

@ Time zones

UI cultures

—

MNewsletter - Subscriber

User

Switch to CMS Desk

newsletter.subscriber

CMS&.Uuser

Sites Administration Settings Development Licenses Support
@ System tables
Actions = Class display name - Class name
V4 Ecommerce - Customer ecommerce.customer
f Ecommerce - Order ecommerce.order
f Ecommerce - Order item ecommerce.orderitem
& Ecommerce - Shopping cart ecommerce.shoppingeart
f Ecommerce - Shopping cart item ecommerce.shoppingcartitem
f Ecommerce - SKU ecommerce.sku
& Group Community. Group
Va Media file mediafile
4
s

Lser - Settings

cms.usersettings

User: Global

Table name
COM_Customer
COM_Order
COM_Orderltemn
COM_ShoppingCart
COM_ShoppingCartskU
COM_SKU
Community_Group
Media_File
Mewsletter_Subscriber
CMS_User
CMS_UserSettings

2. Switch to the Alternative forms tab and choose to Edit (#) the Edit profile (Community)

alternative form.

-\':'- Kenti.co Switch to
'.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
=)~ Development @ System table properties
.5 Categories
@ Countries System tables » User

G CSS stylesheets

: Fields Queries Alternative forms

@ Cultures

@ Custom tables @ Create new form

-l Document types

- [3) E-mail templates

d’} Form controls Actions = Display name - Code name

% Inline controls 7R Display profile DisplayProfile

(9 Modules _ )

-2 Notifications & ®  Editprofile EditPrafile

- [#Page layouts | 7|98 Edit profile (Community)  EditProfileCommunity

ﬁ Page templates # 8  Editprofils (MyDesk) EditProfilehyDesk

55 Relationship names

g = P f x Registration form RegistrationForm

- [ System tables
{3 Tag groups
. Time zones

{3 U1 cultures H

3. Switch to the Fields tab and select FullName from the list on the left. Check the Allow user to
change field visibility check box and switch the value of the Visibility control drop-down list to
Visibility (radio buttons - horizontal). Click OK to save the changes.
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Switch to CMS Desk U 1 Global Administrat: Ve
-‘:’- Kentlco witch to es ser: Global Administrator

'.‘ CMS Site Manager Sites Administration Settings Development Licenses Support

=l Development

-5 Categories
4@ Countries
-§f CSS stylesheets
3B Cultures
--fill custom tables
E]1 Document types
--[3) E-mail templates
.. Form controls
--[=] Inline controls
B Modules

. Notifications
-.[HPage layouts
i Page templates
.= Relationship names
- ff System tables
--%&¥ Tag groups
) Time zones

=1 UI cultures
- Web part containers
- g® web parts
-.[@] web templates
-.[@] widgets
- Workflows

L& I

ﬁ System table properties

Systemtables » User

Fields Queries

Alternative forms

Alternative forms » Edit profile (Community)

General Fields Layout

UserlD

UserMName

FirstMame

MiddleName

LastName

=
Email 1
UserPassword
PreferredCultureCode
PreferredUICultureCode
UserEnabled =
UserlsEditor
UserlsGlobalAdministrator
UserlsExternal
UserPasswordFormat
UserCreated

LastLogon
UszerStartingAliasPath
UserGUID

UserLastModified
UserLastLogoninfo
UserlsHidden

UserVisibility

UserlsDomain -

Display attribute in the editing form

Field

Default visibility:

Display to all

Visibility contral:

Allow userto change field

Visibility (radio buttons - horizontal)

L]

visibility:
Field caption: Full name 3
Field type: Text box =]
A
Field description:

4. Switch to the Layout tab. Place the cursor to the FullName line, right-click and from the context
menu, select Row -> Insert Row After. Type 'Display full name to:' into the first column of the new
line. Then place the cursor into the second column, choose FullName from the Available fields list and
click the Insert visibility control button. The result should look as in the screenshot below.

Click Save to save the changes.
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212 Kentico
£ CMS Site Manager

=) Development
-5 Categories
- Countries
- CSS stylesheets
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-.[HPage layouts
-[@ Page templates
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£ system tables
-.&9 Tag groups
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4% Web parts

-.[@] web templates
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2 Workflows
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Switch to CMS Desk  User: Global Administrator v5

Sites Administration Settings Development Licenses Support

ﬁ System table properties
Systemtables » User
Fields Queries Alternative forms

Alternative forms » Edit profile (Community)

General Fields

b s=ee

Layout

Use custom form layout

Generate table layout

£ [ Souce | [§ £ Available fields:

= UserMame ~

W ml 5 & FullMame F

mME=E0 &= e Email

. > ® UserVisibility

i Sble || Fames - | Font v | Size - UserlsDomain

- i [E UserHasAllowedCulture|
aclhe e K UserNickName 3

$SinputUseramess * | |UserSignature

o UserMessagingMotifical
$Bvalidation:UserName$$ UserTimezonelD

$SinputFullame$$ $dvalidation:FullName$$ — | |UserAvatarlD

P " | |UserGender
ﬁwmb'“w'Fu_”Name“ — I UserDateOfBirth il
$hinputEmailss $dvalidation:Emailss
$visibilityEmail$
$SinputUserMickMame$s
$Svalidation:UserNickName3$3s

$Blabel:UserNamess

$5label:FullNamess
Display full name ta:
SSIabel Emaiss

Display my e-mail to:

$8label:UserNickName$s

" insert validation label |
$BinputUserSignature$s ——
$validation:UserSignature$$ Insert submit button
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$&inputUserllessaqinaNotificationEmailss 7| | EMIECISIEIIIVESII

5. Now if you go to the live site and sign in as some of the sample users (e.g. David with blank
password) and go to the profile editing section (click Edit my profile in the Shortcuts menu), you
should be able to choose the Full name field visibility, as shown in the screenshot below.

Examples | | | Search

Home  Blogs  News | b |
My profile
Shortcuts
Personal settings  Change password ~ Notifications My profie
I I I Edit my profile
Username: David My messages
— My friends
Full name: David Silver My invitations
[ Display full name to: @ Nobody () (all) © Site members () Friends ] Create a new arou
Create a new blog
Email: david_silver@localhost.local Sign out
Display my e-mail to: (7) Mobody () (all) @) Site members (7) Friends
Mickname: David My blogs
h{ ty do not b
v % Doacv—i_d = * bl::;:lrren y do nat have any
Signature:

Messaging notification e-mail:

Time zone:

My groups

Czech Republic fans

This group is intended

for people who are
interested in the Czech
Republic. Czech Republic
residents, travellers who have
Vi...

© 2011 Kentico Software



Part 1 31

225

232 Kentico
4% CMS Site Manager

(global)

(=)-Settings

@ Web site

: = Files

a Membership
@ Security

+=5 URLs and SEO
- P output filter
... system

2 E-mails

(7 Bad words

- Blogs

: F4 Booking system
.- &4 Community

Ba Content staging
&4 Forums

Iy Media libraries
] Message boards
f_] Messaging
"nj Web analytics
- Windows LivelD
PR E-commerce

'§] Content management

Registration approval and double opt-in

Sites Administration Settings

=]

a Membership

=

Reset these settings to defau

Licenses

It

Further steps: You hawe learned how to let site users specify who will see their full name. The same
way as described above, \isibility controls can be added to any other field of their profiles.

By default, users are signed-in to the site and their user account becomes active immediately after
successful registration. However, the two options highlighted in the following screenshot can be enabled
in Site Manager -> Settings -> Membership. By enabling these options, you can include additional
steps in the registration procedure.

Switch to CMS Desk  User: Global Administrator

Support

These settings are global, they can be overridden by the local site settings. Please select the site to see or change

Administrators e-mail

Monitor online users

Store online users in database

Deny login interval

Update online users (minutes)

Reserved user names

admin@localhost. local
]

O

10

1

admin:root;administrator;sysadmin;sa

Reqgistration requires e-mail confirmation

PIOO OO OO

Reqgistration requires administrator's approval @

]

{ [

- Payment gateway - Authorize.NET
“..i5} Payment gateway - PayPal

Delete non-activated user after (days)

Shared user accounts

Require unique user e-mails

Exportthese settings

Registration requires e-mail confirmation

2]
2]
2]

If checked, newly registered users will receive confirmation e-mail to the e-mail address specified on
registration. This e-mail contains a confirmation link that needs to be clicked in order to activate the
account. The e-mail is based on the Membership - Registration e-mail template.
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=

Message

_,ql. _,QB _.;% x _j :} :ﬁ % &, safe Lists ~

(Ca 6ev)?
o

Add-Ins

Reply Reply Forward | Delete Moveto Create  Other Block [ not Junk
to All Folder~ Rule Actions = || Sender
Respond Actions lunk E-mail F}

From: no-reply@localhost, local
To: John Mewman
o

Subject: Confirm your registration

Confirm your registration - Message (HTRL)

B Yo
Cateqorize Follow Mark as

= Up~ Unread
Optinns (P

- = x
@)

32 Find &
En)
12y Related ~ ——
Send to

b Select OneMote

Find Onehlote

Sent: Mon 2/22/2010 3:46 Ph

Tharnk: you for registering at our site. Please click the link below to complete your registration:
httpeile cathe st entic o CHE S pecial-pagesiFegistration-approval asprTusermnd=36584ba72-03a4 -4672-85e4 -8k d4a20f# a1

13

You can find your credentials below:
Tzemame: johnn
Password: 123456

4

After clicking the link, a special page will be opened in user's web browser, displaying the following

message:

continue.

Your user account is now active. You can sign in using your user name and password. Click here to

The link at the end of the message will redirect the user to the title page of the website. The user can
then log in using the registration details received in the e-mail.

Registration requires administrator's approval

If this option is enabled, users will not be able to sign-in immediately after registration. Their registration
will have to be approved by site administrator. At this point, users will receive an e-mail based on the
Membership - Registration waiting for approval e-mail template. You can see the default version of

the e-mail in the screenshot below.
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p— ) = Registration information - Message (HThL - = x
( E‘g = 5 4 ¥ q qe | )
- hessage Add-Ins @
L. = Y- j 34 Find &)
._,ﬁ\l | ak % x A S = Safe Lists = ¥ 5 ]
— Had 1/ € o == i 2 Related ~ d;
Reply Reply Forward | Delete Move to Create  Other Block [ mat Junk Categorize Follow Mark as Send to
fo &l Folder= Rule Actions~ || Zender - Up~* Unread || Wi Select~ Oreiote
Respond Actions Junk E-mail I} Options Ta Find Onerote
Fram: nio-reply@localhost, local Sent: Tue 2/23/2010 2:57 PM
To: John Mewmar
Co
Subjedt: Registration information

Eegistration details:

Tsematne; johnn
Password: 123456

Thank you for registering at our site CotnmunitySite. Tour registration must be approved by administrator,

(3

In case that the option is enabled, the Waiting for approval tab will be displayed in Site Manager ->
Administration -> Users. On this tab, site administrators can Approve (¥) or Reject (@) users'

registration.

22 Kentico

#§%  CMS Site Manager

(=)~ Administration

...[t] Avatars

-7 Bad words

& Badges

eﬁ Banned IPs
ﬂ E-mail queue
[ Event log

@ Permissions

4l Recyde bin
84 Roles

“-{2) Scheduled tasks
‘.10 Smart search
. System

@ UI personalization
i [Users

... g web farm

Switch to CMS Desk

User: Global Administrator v5.0.3693 Sign out
Sites Administration Settings Development Licenses Support
=
& Users
Users Waiting for appraval Mass e-mail Onine users
=

% Waiting for approval

[aIIJ| A B C D E F G H I J K L M N o P Q@ R 13 T u Y

~ Display advanced filter
E| Approve all selected users Reject all selected users

Actions | [ |  User name «

Yo O

Full name Email Nickname  Created Enabled

johnn 2/2212010 45452 PM Mo

John Newman  johnn@localhostlocal — johnn

Tterns per page: 25 ||

After the administrator's approval, users receive another e-mail, confirming that their account has been
approved and can be used. The e-mail is based on the Membership - Registration approved e-mail
template. You can see the default appearance of the e-mail in the screenshot below.
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2.2.6

2.26.1

e ;\. = & ¥ |5 Registration approved - Message (HTRL) - = x
o -
—/J Message Add-Ins 7]
LI : = | A Find &)

] i] x 1 Ny |e— % Safe Lists - v ¥ g '
o i i =] % =] B || @ petatea- | B
Reply Reply Forward | Delete Move to Create  Other Block Mot Junk Categorize Follow Mark as send to

o Al Folder= Rule &ctions< | Sender - Up~= Unread | b Select~ OreMote
Respond Actiohs Junk E-mail F} Optians Ts Fird Onelote
Fram: no-reply@localhost. local Sentt Mamn 272272010 447 PM
To: John Mewman
o
Subject: Registration approved

[

Your registration has been approved by adminstrator. Wow you can sign i using vour username and password.

Clck here to navigate to the web site

Enabling both options

In case that you enable both of the options mentioned abowve, e-mail with the confirmation link will be
sent first. After user's confirmation, registration will have to be approved by the administrator.

= Please note

e
F
™,

If you have one or both of the options enabled, it is important to set the Redirect to
URL property of the registration web part properly. This means that users should not be
redirected to any page displaying information about their user account (just as the
Members -> Profile page on the sample Community Starter site). Because the
account is not active yet (it is waiting for e-mail activation or approval), such page would
display an error message, which might be misleading for the users.

Further steps: You have learned how to enable registration approval and double opt-in. At this point, you
may want to try enabling the options and registering to the site to see how they work in practice. In this
case, it will be necessary to set up the SMTP sener in Site Manager -> Settings -> E-mails in order
for the e-mails to be sent correctly. You may also want to go to Site Manager -> Development -> E-
mail templates and modify some of the notification e-mail templates mentioned in the text above.

Windows Live ID
Overview

Windows LivelD is a single sign-on service provided and maintained by Microsoft. By integrating LivelD
into your website, you can allow site \isitors to log in to your website using their LivelD login and
password.

More information about integration of Windows Live ID with Kentico CMS can be found in Kentico CMS
Deweloper's Guide -> Membership and User registration -> Windows Live ID.
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2.2.6.2 Adding the sign in button

After registering your website at msm.live.com and making the necessary settings, you only need to
place the Membership -> Windows LivelD web part to your site. This web part works fine without any
additional settings and can be placed on any page of your website.

In the following example, you will learn how to add the Windows LivelD web part to the sample
Community Starter site. We will add the web part to the zoneTopMembership web part zone of the
master page, next to the sign-in link. Like this, the LivelD sign-in button will always be displayed, no
matter which particular page is currently displayed.

1. Sign in to CMS Desk (login administrator with blank password by default). Select the master page
(the root of the content tree) and switch to the Design tab.

2. Click the Add web part (%) icon of the zoneTopMembership web part zone.

N7 Kentico Switch to Site Manager  Site:| Community Site[«| User: Global Administrator v5.0.3693 Sign out
-
% CMS Desk Content | Mydesk Tools  Administration
[=) c U =~ ry
B & Pow 1w | @ & =y o
New Delete |=bMove & pown | Edit  Preview Livesite  List | Search |
Content managemeant | View mode | other |
=
1) Community Site Page | Design | Form  Masterpage  Properties Display web part content @
‘-] Home =
e .- te: Con ity Site - Master P -
&[] Blogs { -page templa mmunity r Page (2]~
5[] News ~ zoneToplnfo 4|
f a Media » txtTriallnfo @ Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.
(-2 Forums
(4[] Groups
(- |] Group pages + zoneTopMembership I |
® D Members  SignOutButton @ L2
o o | |+
§ - M jingInfoPanel nbox | | [=
& Files essagingInfoPanel (3
(-3 Special pages = statichtml {3 Edit my profile |
g g Logaon page  MyHomePage (@ My home page |
*-[] search . .
[.J  zoneTopimage e
= Toplmage {3
L
—_
x
= zoneTopMenu o

n gs News Media Forums Groups Members Bxamples
= zoneContent

ke

= [ subContent {5}

3. In the Web part selection dialog which pops-up, choose Membership -> Windows LivelD and

click OK. The web part properties dialog pops-up. As mentioned above, no properties need to be set, so
just click OK.

4. The web part is now placed on the master page. The web part itself is not visible now, but it is
represented by the blue rectangle labeled WindowsLivelD. If you log-off now, you should see the web
part on the page and it should be fully functional.
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2.3
2.3.1

[3 Signin |

Community

Starter site

Home  Blogs MNews  Media F b

Welcome to our community Sign in

s v b0 Baadm

Further steps: You hawe learned how to add the Windows LivelD sign-in functionality to your website. In
some cases, you may want the users to provide some additional details on registration via Windows
LivelD. In this case, you would use the LivelD required data web part. A detailed description of this
web part and the way it can be used can be found in Kentico CMS Developer's Guide -> Membershi

and User registration -> Windows LivelD -> Available web parts.

Groups

Current functionality

1. Go to the live site and sign-in as Kelly with blank password. Click Groups in the main menu. You will
be redirected to the Groups title page.

The Your groups section of this page displays all groups where the current user is a member. The
Recently added groups section displays all groups on the site. If you click a group name or avatar,
you will be redirected to the group's profile page. Enter the African travellers group profile.
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Current user: Kelly Taylor (Kelly) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home  Blogs  News  Media  F ps  Memb . Examples | ||Search

Groups
Shortcuts

Right dick the group to get available actions. My profile
Edit my profile

Your groups o ——
My friends

h Czech Republic fans My invitations

This group is intended for people Create a new grou
who are interested in the... Create a new blog
Sign out

Recently added groups
Sort by: Group name Created

African travellers Australian travellers European travellers
3 This is & group of travellers living in This is a group of Australian This is a group of Europe-based

B Africa. If you are ... travellers. If you are one of. travellers. If you are one ...

& Asian travellers = American travellers Czech Republic fans
’ This is a group of Asia-based . This is a group of American This group is intended for people

travellers. If you are living... travellers. If you live in Amer who are interested in the...

2. You can see the group profile page now, just as in the screenshot below. The page has the following
sections:

e Group profile - basic information about the group - its avatar, name, description, type of access and
date of creation

e Group announcements - this is a message board where group administrators can leave important
group-related messages

e Latest in forums - displays latest posts in the group's forums

e Most recent pages - displays latest articles in the group pages section

e Shortcuts menu - the following group-related actions are offered in the menu:
e Create a new group - can be used for creating new groups
e Leave the group - by clicking this link, the current user leaves the currently displayed group so
that she is no longer a member of it
e Invite to a group - by clicking this link, group members can send invitations to the currently
displayed group to other site members or via e-mail

e Group links menu - this menu offers links to all sections of the currently displayed group:

e Home - group profile page

e Pages - group pages section with articles related to the group's field of interest, added by group
members directly on the live site

e Media - group's media libraries where various types of files can be stored

e Members - page displaying a list of all members of the group; after clicking a user, you will be
redirected to the user's public profile; right-clicking the users' avatars displays a context menu with
other possible actions

e Forums - group's discussion forums

e Group administrators - displays administrators of the current group; right-clicking the avatars
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displays a context menu with possible actions
e Recent members - displays the latest group members; right-clicking the avatars displays a context
menu with possible actions

Try browsing the sections and using the actions listed above. The site was designed to be very intuitive
to work with, therefore you should not encounter any problems playing around with it.

Home Blogs News Media F ps Memb Examples Search

Groups » Czech_Republic_fans

Shortcuts

ofil

Czech Republic fans o orofie
Edit my profile

My messages
This group is intended for people who are interested in the Czech Republic. Czech Republic residents, travellers My friends
who have visited it and those who are planning to do so are all more than welcome to join this group. My invitations

Create a new group
Leave the group

Access: Only group members can view the content Invite to aroup
Create a new blog
Created: 2/19/2010 Sian out
Group announcements Group finks
There are no announcements at this time Home
Pages
Discover the Czech Republic
Media
Members
Forums
Latest in forums
RE:The Czech republic Group administrators
David
Hi, I was in Prague for 5 days last week, and I can honestly say it is one of the most interesting and mesmerising places I've ever seen in Europe. ﬁr: Male
Posted on 10/28/2008 8:10:19 PM Age: 22
The Czech republic
I love the Czech Republic ) Recent members
Posted on 10/25/2008 6:33:10 PM David
Gender: Male
Age: 22
Most recent pages | Kelly
@ Gender: Female
Age: 27

Discover the Czech Republic

Discover the Czech Republic - a small country in the very heart of Europe that has got something for everyone, No matter what your interests are, you
will be surprised at what a variety of places to see and things to do there is. Don't miss out on any of the country's natural wonders, histaric landmarks
and breathtaking sceneries., You will be amazed at how even a small European country can significanty contribute to the world's cultural heritage.

And after a nice day full of impressions, why not spend the evening in one of the typical Czech pubs, drinking some of the best beers in the world that
are brewed in this country?

3. If you want to become a member of some other group, you can do it on the Groups title page. Right
click the group you want to join. A context menu appears. Select the Join the group command.

b View grou
&gm S deidon

e A @ Join the grou

g in

A pop-up window appears, asking you if you really want to join the group. Click Join. Depending on the
group settings, you will either become a group member immediately, or your request will have to be
approved by the group administrator.
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.~ ™y
& | Join the group -- Webpage Dialog M
@ Join the group

Do you want to join African travellers?

http://localhost/K € Local intranet | Protected Mode: Off

Alternatively, you can also join a group by clicking the Join the group command in the Shortcuts menu
when viewing a group profile.

Shortcuts

My prafile
Edit my profile

My messages
My friends
My invitations

Create a new blog
Sign out

4. You hawe just learned what the group member can see and do in this section. Now let's switch to the
group administrator's point of view. Log-off the site and sign-in again as David with blank password.
Davd is the administrator of the Czech Republic fans group, so view this group's profile the same
way as you did above with Kelly.

The first thing you will probably notice is that there is the Leave message section below the Group
announcements message board. Because David is the admin of this group, he can leave
announcements. Try leaving one.

Leave message Subscribe

Mame: David
Your URL:  http://
Your e-mai: david_silver@localhost local

Message! 53 everyone, I'm just -
sending a testing message to
try how this Group
announcements message board
works.

[T subscribe me to this message board
Add

After clicking the Add button, you should see the message present on the board:
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Group announcements

David
Hi everyone, I'm just sending a testing message to try how this Group announcements message board works.
2/19/2010 4:44:42 PM
Edit Delete Reject
Report abuse

5. You might have also noticed the Manage the group link in the Shortcuts menu.

Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group

Create a new blog
Sign out

Click it, you will be redirected to the group management section, which is also available only for group
administrators. Try going through all the tabs and changing some settings. As this on-site group
management interface is identical to the groups management interface in CMS Desk, you can refer to
Kentico CMS Developer's Guide -> Module Groups -> Editing a group for a detailed description and
explanation of all the available settings. Other topics of the Module Groups chapter can be used as a
source of other detailed information on the Groups module.
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Home Blogs News Media F Group. Memb Examples Search

Groups » Czech Republic fans » Management

General Securiy Members Roles  Forums — Media libraries  Message boards = Polls

Thi=s group i=s intended for people who are -
interested in the Czech Repubklic. Czech
Republic residents, travellers who have
wisited it and those who are planning to do

=0 are all more than welcome to join this

Description:
ription group.
Avatar:
Jeewssic, %

Upload:
Select pre-defined avatar
(2 any site member can join

Approve members: @ Only approved members can join

@ Only approved members can join except for invited members

5 ! Anybody can view the content
() site members can view the content
Content access:

@ Only group members can view the content

Notify group admins when a user joins/leaves:

Notify group admins on pending b
Created by: administrator
Approved by: administrator

2.3.2 Creating anew group

New groups can be created two ways:

e Site users can create new groups on the live site using the Create a new group link in the
Shortcuts menu. This is the most common way and most of the groups on most sites are created
this way.

e Alternatiwely, if you want to pre-define a group manually from the administration interface, this can be
done in CMS Desk -> Tools -> Groups.

In the following example, you will learn about both ways of creating groups:

1. Go to the live site and sign in as David with blank password. Click the Create a new group link in
the Shortcuts menu.
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Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

ICreate a new group I
Create a new blog
Sign out

2. Enter the following details into the Create new group form:

e Group name - name of the group displayed on the live site and in the administration interface
Description - text describing the group, displayed in the list of groups

e Approve members - determines if users can join the group with or without group admin's approval,
the last options allows invited members to join without the approval

Content access - determines who can view content of the group pages

Click OK. You will receive a message saying that your group has been created, but needs
administrator's approval.

Home Blogs News Media F Group Memb Examples Search
Create new group
Shortcuts
By entering the details into the form below, you can create your new user group. Make sure you give the group a name and description according to the My profle
group's field of interest. 1t is a good way of attracting site users with the same interest to join your group. Ecitmy orolle
Edit my profile
My messages
Group name: Kentico CMS fans My friends
My invitations
Join us if you love this outstanding CMS. = Create a new blo
Sign out
Description:
Recent groups
. African travellers
= - This is & group of
i@
i Any site member can join S ravellers living in Africa,
Approve members: () Only approved members can join If you are one of them, please
= register to the group. Itis a
_' Only approved members can join except for invited members areat chance f...
@ aAnybody can view the content Australian travellers

This is a group of

- Australian travelers, If
) only group members can view the content you are one of them, please
register to the group. Itis a
great chance for you...

European travellers

This is a group of Europe

Contentaccess: () site members can view the content

3. Let's switch to the administrator's perspective now. Sign in to CMS Desk (use login administrator with
blank password) and go to Tool -> Groups. You should see the new group present in the list, with the
Approved column saying No. Click the Approve (¥) icon. From now on, the group is approved and
published on the live site.
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232 Kentico Switch to Site Manager
‘.‘ CMS Desk Content My desk Tools Administration
[z~ Tools & Groups
H [}
@ Abuse report

[El BizForms S New aroup
Blogs

Pﬂl Booking system

5‘8 Content staging Group name: | LIKE |Z|

ﬁ Custom tables Status: (all) El

PR conmerc ==

--[[q File import

g Forums Actions Display name = Approved

- 44 Groups

5---l§| Mediz = F R D Amicantravellers Yes

. . Message boards f x qf @ American travellers Yes

: Newsletters F RS D Asiantravellers Yes

g 20”5 . AR D sustraliantravellers Yes

- |&] Reporting

5....'3j Web analytics SRS D Czech Republic fans Yes
f x qf @ European travellers Yes

H f Kentico CMS fans No

4. Now we will try the second way how groups can be created - pre-defining a group in the administration
interface. Our group will be named ASP.NET Developers. At first, we will have to go to CMS Desk ->
Content and create the group pages section. Select Groups -> Template from the content tree and
copy the document under the Group pages node.
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.‘!:. Kentico

Switch to Site Manager

‘l CMS Desk Content My desk Tools Administration
[= [=) Co u ~ = =
B R Bew fw» | 3 [@ @ B [ L
New Delete = Move & Down | Edit  Preview Livesite  List | Search |
Content management | . View mode | _ Other
— % . -
Ij-b‘___'! Community Site Page Design Form Properties

i Home

(-] Blogs

-1 News

D Media

(- L] Forums

|_| D Groups

[ Management

[] Media

[] Media list

[[] Members

[] Access

[] Forums

-.[= Create

= D Template

: ~[1] Pages

|_| .| Group pages

@ ] czech_Republic_fans

- D American_travellers

(-] Asian_travellers

ma European_travellers

wa Australian_travellers

(-[] African_travellers

1] Kentico CMS_fans

Q- D Template
D Pages

u |_] Members

() L] Examples

E Save Spell check

Sign in to CMS Desk. Sign in to CMS Site Manager. 1

Community

Starter site

Groups * Template
Requested profile not found.

Latest in forums

Current

There are currently no posts,

Most recent pages

There are currently no pages.

5. Select the new Template document that was copied under the Group pages node. Switch to the
Form tab and change its name to ASP_NET_Developers. Click Save.
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Switch to Site Manager
232 Kentico
‘.‘ C€MS Desk Content My desk Tools Administration
= Co U =
] [y Do Ww [ql pe
New Delete |= Move & Down | Preview Live site List | Search |
Content management | iew mode | Other |
|:'l't'|_;'}| Community Site Page Design Form Properties
i-[] Home
[&-[] Blogs I 52 Spell check
._| [ News
i) Media
ul_] Forums [Documentname: ASP_MET_Developers I
(-] Groups Teaser image: 4 Upload file

I_| I_] Group pages
H- ] czech_Republic_fans
._| ] American_travellers
(5] Asian_travellers
._| ] European_travellers
._| [ Australian_travellers
,ﬂ |1 African_travellers
¢|,_1 Kentico_CM5_fans
.;| ,_] Template
-[] Pages l
|_| I_] Members

PR

Publish from:

Publish to:

=

= no
B

Mo

=

6. Switch to the Properties -> URLs tab and change the Document alias also to

ASP_NET_Developers. Click Save.

Switch to Site Manager
22 Kentico
"\ CMS Desk Content My desk Tools Administration
3 c U — —
5 Howy  #u [q) P
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
C."{“_l,':' Community Site Page Design Form Properties
'J Lome General |
(#-|_| Blogs E Save
g = URLs
-] News
|_] Media Template
[&-|] Forums Metadata b
J ] Groups Categories Document alias: ASP_NET_Developers
._| ] Group pages Menu Document URL path: |
L [l Czech_Republic_fans Workflow [Vl Use custom URL path
+-|| American_travellers
'1‘ '_] Asi G - I Versions
‘1“—] Sian_travellers Extended properties
. Related docs
[+-|| European_travellers URL extensions:
5[] Australian_travellers Linked docs
';‘ ‘—] i - g [l use custom URL extensions
[+)-| African_travellers Security o
= = ) Track campaign:
-] Kentico_CMS_fans Attachments
B I_] ASP_NET_Developers
: i.[] pages H Document aliases
(-] Members )
|1l|_] Examples o Add new alias
-G9) Files
() Special pages

Site: Community Site [+

7. As we have the group pages section prepared, we can proceed to creating the group itself. Go to
Tools -> Groups and click the New group link at the top of the page.
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232 Kentico Switch to Site Manager
1% CMS Desk Content My desk | Tools Administration
@- Tooks & Groups

i Abuse report
- [El BizForms aroup
-l Blogs

Pﬂl Booking system
... content staging

Group name: | LIKE E

ﬁ Custom tables Status: (all) E
 PhE-commerce .

[ File import

34 Forums Actions Display name » Approved
& Groups

: f x \f @ African travellers Yes

..l Media libraries

8. The New group form appears. Compared to the on-site form described in step 2, this one contains
some additional fields. We won't describe all of them now, you can find detailed descriptions in the
context help (accessible via the green '?' icon at the top right corner of the page). Enter the following
details:

e Display name - ASP.NET Dewelopers

e Code name - ASP_NET_Dewlopers

e Description - Building websites using this Microsoft technology? Join us!!!
e Group pages location - /Group-pages/ASP_NET_Developers

e Avatar - click Select pre-defined avatar and pick one

e Approve members - Any site member can join

e Content access - Anybody can view the content

e Notify group admins when a user joins/leaves - leave unchecked
e Notify group admins on pending members - leave unchecked

Click OK.
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& New group

Groups » MNew group

Display name: ASP NET Developers
Code name: ASP_MET_Developers
Building web sites using this -

Microsoft technology? Join us!!

Description:

Group pages location: /Group-pages/ASP_NET_Develope
’ ]

Avatar:

Uploac:

Select pre-defined avatar

@ Any site member can join
Approve members: = Only approved members can join
() Only approved members can join except for invited members
i@ Anybody can view the content
() Site members can view the content

Content access:
() Only group members can view the content

Motify group admins when a user joins/leaves: [

Motify group admins on pending members: ]
ok |
9. The group is now created. If you go to the live site now, you should see it listed in the Groups

section, as depicted below. If you enter the group profile, all sections should be fully functional (but of
course with no content).
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Home Blogs HNews  Media
Groups

Right diick the aroup to get available actions.
Recently added groups

Sort by: Group name Created

|~ ASP.NET Developers

Building web sites using this
ki Microsoft technology? Join us...

European travellers

S Thisis a group of Europe-based
SR travellers. If you are one ...

Czech Republic fans
This group is intended for people

~

who are interested in the...

233

Forums

Groups

& African travellers

: = This is a group of travellers living in

_ Africa. If youare ...

Asian travellers

Thiz ig a group of Asia-based
travellers, If you are living...

Modifying the group public profile

Members

Examples

Australian travellers
. . This is a group of Australian
travellers. If you are one of...

¥ ...  American travellers
. This is a group of American
travellers. If you live in Amer...

You can define which details will be displayed on group public profiles. The process is quite similar to
modifying user public profiles described here. In the following example, you will learn how to add the
Group ID field to the group public profiles.

Group public profiles display information from the Community_Group system table using an alternative
form. In our case, it is the Display profile alternative form. We will have to modify the alternative form to
achieve the required functionality. For more information about the Alternative forms concept, please refer

to the Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the Group (Community_Group) system table.

232 Kentico

#g%  CMS Site Manager Sites
=) Development

-3 Categories
@ Countries
Q’ CSS stylesheets
- Cultures
-fill custom tables
Qﬂ Document types
Q E-mail templates
<& Form controls
+-[H Inline controls
- { Madules
.| Notifications

: B Page layouts

ﬁ Page templates

:-E5 Relationship names

@ System tables

,{3 Tag groups

.. Time zones

@ UI cultures IJ

xxxxgxxxxxxg

Administration

Settings

ﬁ System tables

Class display name »
Ecommerce - Customer
Ecommerce - Order
Ecommerce - Order item
Ecommerce - Shopping cart
Ecommerce - Shopping cart item
Ecommerce - SKU

Group

Media file
Mewsletter - Subscriber
User

User- Settings

Development

Licenses Support

Class name
ecommerce.customer
ecommerce.order
ecommerce.orderitem
ecommerce.shoppingcart
ecommerce.shoppingcartitem
ecommerce.sku
Community. Group
mediafile
newsletter.subscriber
CMSs.user

cms.usersettings

Switch to CMS Desk

Table name
COM_Customer
COM_Order
COM_Orderltem
COM_ShoppingCart
COM_ShoppingCartskL
COM_SKU
Community_Group
Media_File
Mewsletter_Subscriber
CMS_User
CMS_UserSettings

2. Switch to the Alternative forms tab and choose to Edit (#) the Display profile alternative form.
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232 Kentico
#§% CMS Site Manager

=) Development

-l Categories
.. Countries
d CSS stylesheets
@) Cultures
~Fill custom tables
..l Document types
f}j E-mail templates
< Form controls
+[E Inline contrals
“- (% Modules
| Notifications
+-[H Page layouts
. [@ Page templates
=8 Relationship names
ﬁ System tables
...+&p Tag groups

Sites Administration Settings Development
@ System table properties
System tables » Group

Fields Queries Alternative forms

E‘q. Create new form

Actions = Display name =«

Display profile

Code name

DisplayProfile

Licenses

Support

3. Switch to the Fields tab, select GrouplID from the list of available fields and check the Display
attribute in the editing form check-box. Click OK.

=32 Kentico
#§% CMS Site Manager

=) Development
‘.45 Categories
@ Countries
2 d CSS stylesheets
-3 Cultures
..l custom tables
Document types
<] E-mail templates
2 <& Form controls
++{E Inline controls
(P Modules
.| Notifications
+-{ A Page layouts
. [@ Page templates
.28 Relationship names
@ System tables
47 Tag groups
L4 Time zones

=1 UI cultures
Web part containers
&% web parts
--{@] web templates
.[@] widgets
| Workflows

L& I

Sites Administration Settings Development Licenses

ﬁ System table properties
System tables » Group

Fields Queries Alternative forms

Alternative forms » Display profile

General Fields Layout

GroupGUID

GroupLastModified

GroupsitelD
GroupDisplayMame
GroupMame

GroupDescription
GroupModeGUID
GroupApproveMembers
GroupAccess
GroupCreatedByUserlD
GroupApprovedByUserlD
GroupAvatarlD

GroupApproved
GroupCreatedWhen
GroupSendJoinLeaveMotification | Field
GroupSendWaitingForApprovalk,
GroupSecurity

Database

Aftribute name:
Aftribute type:
Aftribute size:
Allow empty value:

Attribute default value:

Field caption:

Field type:

Support

Integer number

]

isplay attribute in the editing form

GrouplD

Label

Switch to CMS Desk

»

m

4. Switch to the Layout tab. We will place the GroupID field above the GroupAccess field. Place the
cursor in the line with GroupAccess controls, right-click and choose Row -> Insert Row Before from
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the context menu.

General Figlds Layout

=

Use custom form lyout

Generate table layout
Source | [& | & | #4 4] &7 Available fields:
L =
IB I U s:|x &P = = =EED P GroupDisplayName
im0 =E Q@ sk = | @ | 4_)| oy | % GroupDescription
) GroupAccess
: Style = | Faormat = | Font * | Size @ GroupAvatarlD
T - iE GroupCreatedWhen
a0 R GroupSendJoinLeaveNotifi
. . = | |GroupSendWaitingForAppr
$$input:GroupDisplayName$$ | | GroupSecurity
S5input GroupAvatar D5 $5input GroupDescription$s
$$label:GroupAccess$$ $5input GroupAccess 59|
$$label:GroupCreatedWhen$$ 55input GroupCreatediWh a
®
Cell »
Row » g Insert Fow Before
Calumn » =2 Insert Row After
Delete Table | 5 Delete Rows

[T Table Properties

5. The former layout gets a bit scrambled by this action. We will need to make this right before we
proceed. Delete the three empty cells highlighted in the screenshot below by placing the cursor in each
of them, right-clicking and choosing Cell -> Delete Cells from the context menu.
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General Fields Layout

[ 522

Use custom form layout

" Generate table layout |
s Source | [& 7 Available fields:
IB 7 U s x < E & U p|

GroupDisplayName
GroupDescription
GroupAccess
GroupAvatarlD
- GroupCreatedWhen

3
(0 & GroupSendJoinLeaveNotifi
. = | | GroupSendWaitingForAppr
Disp IayName$$ ‘_| GroupSecurity

RRinnut-CronnDescrintinn® %

w0 = @ &5

tyle * | Farmat - | Font - | Size -

&
¥

$8input GroupAvatarlDE§

& ¥ | =5 Insert Cell Before W
Row NSRS insertinput—]
o B Coc
< i Delete Table | L Merge Right

[T Table Properties 3 Merge Down
A Spiit Cell Horizontally

A Spiit Cell Verically
=] Cell Properties

6. Now we have the layout as we want it, so we can proceed to adding the controls. Select GroupID
from the Available fields list, place the cursor in the first empty cell and click Insert label. Highlight
the entered text and make it bold, so that it looks the same as the other two labels. Place the cursor in

the second empty cell and click Insert input. The result should look as in the screenshot below. Click
Save to save the changes.
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234

General Fields

[ s2e

Layout

Use custom form layout

Generate table layout

{ Elsouce |[&( &

2 i —
i

m O =0 &S0 D 0|8

Style

i E A

=]
y

=
E

i~

- | Format - | Font

B &

v | Size

Available fields:

GroupDisplayMame
GroupDescription
GroupAccess

v GroupAvatarlD
GroupCreatedWhen
GroupSendJoinLeaverotifi

$$input:GroupDisplayName$$

»

GroupSendWaitingFarAppr
GroupSecurity

$5input GrouplDEE

SSinput GroupAvatarlD I
$$label:GrouplD$$
label:GroupAccess$$

$!1?input:Gr0upAccess$_$
$$label:GroupCreatedWhen$$ $3input GroupCreatedWhen$s

Insert validation label

- Insert submit button

7. Go to the live site now and view some group's profile. You should see the GrouplID field as highlighted

in the screenshot below.

Home Blogs Hews Media Forums Groups

Groups * American_travellers

American travellers

—

\ GrouplID: 2

Access: Site members can view the content

Created: 2/13/2010

Modifying templates for group pages

Members

Examples

-~ = This is a group of American travellers. If you live in America and like traveling, please register to the group. Itiz a
great chance for you to getin touch with other travellers from your region. They can share their experience and
maybe even become your travel mates. On the other hand, if you are planning a trip to America, users from this

S . Oroup can serve you as a source of valuable information and may even invite you to meet them during your trip.

The Groups -> Template page and its child (Pages) are the group pages template. Based on this
template, group pages section for user-contributed articles is created for each group. As you may have
noticed in the Creating a new group chapter, these pages are copied under the Group pages node when
a group is created on-site. The Template page is renamed to the name of the new group in this case.
When creating a group Via the administration interface, you need to copy the pages manually, rename
the Template page, change its alias and specify the path in the group creating form.

In the following example, you will learn how to add the Content rating web part to the template so that
users will be able to rate the articles in the group pages sections.

1. Log in to CMS Desk (login administrator with blank password by default). Switch to the Edit ->
Design tab and select Groups -> Template -> Pages from the content tree.
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2. Click the Add web part () icon of the zoneList web part zone and choose the Content rating ->
Content rating web part.

3. In the web part properties window, set only the following property:

e Show for document types: CMS.SimpleArticle

This ensures that the web part will be displayed only for the articles and not in the list. Click OK.

& | CMS Desk - Web Part properties - Webpage Dialog

General

Default
Visibility

Scale settings
Messages
Permissions
HTML Envelope
AJAX

Time zones

Partial caching

Refresh content

& Web part properties (Content rating)

Visibility
Visible:
Hide on subpages:

Show for document types:

Display to roles:

Scale settings

Rating value:

Rating type:

Max rating value:

Messages

Show rasilis

y
@ Documentation

>[ CMS._SimpleArticle

W et | ceor |

3

» | Stars

m

http://localhost/KenticoCM5_0219/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii €& Local intranet | Protected Mode: Off

L

4. The web part is now placed on the page. Notice that when you switch to some of these pages in the
Group pages section (e.g. Group pages -> American travellers -> Pages), the web part appears there
too. This happens because these pages share the same page template - Community Site - Group

pages. Any modifications that you make to the original page or to the copies will be reflected on all the

pages using this page template.
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Switch to Site Manager  Site: Community Site User: Global Admini
332 Kentico y Sitel~]

CMS Desk

’l Content My desk Tools Administration
Co u
Booor %o 2 [ B 1 L
New Delete |= Move & pown Edit Preview Live site List Search
Content management View mode Other
d'\:l‘_"l Community Site Page Design Form Properties
J Home T B T WU SEEE P S — )
-] Blogs Home Blogs Hews Media Forums Groups Members Examples
G- News Groups } American travellers b Pages
| Media _
\1‘_‘ Forums ‘ ¥ [Group pages/American_travellersfPages - page template: Community Site - Group pages ‘y|
d._l Groups T zonelist *
=)-| Group pages |v Gri ityAccess @}|
1. | Czech Republic fans -
5 = ¥ GroupContributionList @
| American_travellers
= ‘_‘ P_ages X ¥ GroupEditContribution @
g - =] My flight to Australia
? = =
[+ Asian_travellers ¥ ArtideRepeater {53
B N [Ty Thoht To Ausiralia
-] Buropean_travellers
‘;‘ '_I ¥ - I recently had the experience of flying from Europe to Australia. For those of you who haven't ever flown such a long distance: you can'timagine
[+-1E Australian_travellers how long it actually is. Even today's best airplanes are not able to fly the whole distance from Europe to Australia, so they have to make a refuel
@ J African_travellers stop, The usual waypoints are Hong Kong and Bangkok., We made a stop at the second mentioned,
.ﬂ .| ASP_NET_Developers " While the plane was being refueled and prepared for the second half of our fiight, we had to leave it and spend about one hour at the airport.
5.3 Members | Impressive at least, It was many times the size of the Prague airport and watching the traffic there was just breathtaking, It seemed to me like one
o of the world's biggest crossroads. Right here was where I realized the true sense of the well know phrase that the world is getting smaller and
¥-l=] Examples smaller,
& Ei
- Files After then, we entered the plane again and began the rest of our fight. Even though I slept the most of the time, 1 fieel rather tired at the moment,
\ﬂ"{:-l\‘_‘ Special pages so 1 dedided to accomodate as soon as possible and start exploring the city tomorrow, after a proper portion of good sleep.
. _| Logon page
.| Search

¥ ContentRating @

pr—

5. If you go to the live site now, you should see the Content rating web part on all articles in all group
pages sections. If you create a new group and create some article in its group pages section, the web
part will appear on it too.

M h

Home Blogs News Media Search

T
]
i

Groups * American travellers » Pages * My flight to Australia

fm *Delete

Shortcuts

My profie
Edit my profile

My messages

My friends

My invitations
Create a new group
Join the aroup
Manage the aroup
Invite to group

Create a new blog
Sign out

My flight to Australia

I recently had the experience of flying from Europe to Australia. For those of you who haven't ever flown such a long distance: you can't imagine how
long it actually is. Even today's best airplanes are not able to fly the whole distance from Europe to Australia, so they have to make a refuel stop. The
usual waypoints are Hong Kong and Bangkok. We made a stop at the second mentioned.

While the plane was being refueled and prepared for the second half of our flight, we had to leave it and spend about one hour at the airport.
Impressive at least, It was many times the size of the Prague airport and watching the traffic there was just breathtaking. It seemed to me like one of
the world's biggest crossroads. Right here was where I realized the true sense of the well know phrase that the world is getting smaller and smaller.

After then, we entered the plane again and began the rest of our flight. Even though I slept the most of the time, I feel rather tired at the moment, so
I decided to accomodate as soon as possible and start exploring the dty tomorrow, after a proper portion of good sleep.

Group links

Current rating: 4 (1 ratings) Home
Sge:!

My flioht to Australia
Media

i

Further steps: You have learned how to add the Content rating web part to the group pages. This way,
you can place any web part to the pages and achieve your required functionality. As you have seen,
modifications made to any of the group pages are automatically reflected on all other group pages
because of the shared page template. If you want to achieve different functionality on some of the group
pages, you will have to switch to the Properties -> Template tab and click Clone as ad-hoc template.
Changes made to a page with this cloned ad-hoc template will not be reflected on pages using the
original page template.
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2.4 Forums

2.4.1 Current functionality

The Forums section contains the typical discussion forums that can be found on most websites on
today's Web, allowing site users to read and contribute to discussions on various topics. While forums
are one of the most common features on today's websites, we won't go deep into describing how they
can be used, as we beliewe it should be a familiar subject for you already. For detailed information on the
Kentico CMS Forums module, please refer to Kentico CMS Developer's Guide -> Module Forums.

If you enter the Forums section as a site visitor, you can see that the forums are divided into two main
sections - Community forums and Back-packer forums. These sections are called forum groups.
Forum groups contain forums (Announcements, Community FAQs, ...) and the forums contain
particular threads. There are two types of threads:

e Discussion forums - threads contain standard discussion on a given topic
e Question-Answer forum - threads are structured so that the first post is a question and the following
posts are trying to answer the given question

Home Blogs News Media F ps Memb Examples Search
Forums
Search forums:

Advanced search

Forum Threads Posts Last post

Community forums

This is a general forum for both registered and not registered site users,

Announcements
Find out the |atest news about our community here 2 2

Lock

C

=

Jenny
(10/25/2008 11:58:09 AM)

Community FA
Answers to Frequently Asked Questions about our community 1 1

Lock

Jenny
(10/25/2008 2:01:55 PM)

General discussion

\;E’_]E\ General discussion without rules and limitations 2 & (10;25;203;\;?10: 11PM)
Lock
Members discussion
=) Pogo
5] Discussion for community members anly 1 5 (11/5/2008 4:20:25 PM)
Lock
Forum Threads Posts Last post

Back-packer forums

This forum is intended for user groups, their members and topics related to the particular groups.

Announcements
\:=)E\ Find out the latest news about groups here 1 1 (10,.’25,.’20%‘28'1;“51'40 pM)
Lodk
FAQs
\:=)E\ Answers to Frequently Asked Questions about groups 1 1 (10,.’25,.’20%!%“6“"‘15' 576M)
Lodk
General discussion
=

General discussion without rules and limitations 5 19

“
i

Jimba
(1/7/2009 3:13:50 PM)
Lock

If you view the Forums page in CMS Desk's Design tab, you can see that each forum group is
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displayed via one Forum group web part. You can place a forum group to any page of your website by
placing the Forum group web part on the page and setting its Group name property.

22 Kentico

#§% CMS Desk Content | My desk

[ [ cony 4 up
SR
New Delete |=Move & pown

Content management

Switch to Site Manager  Site:| Community Site[w]| User: Global Administrator v5.0.3656 Sign out

Tools Administration

(4 [d =B _|.~L
| Edit Preview Live site List ‘ Search ‘

] View mode || other |

=1 ) Community Site
[ Home

a Blogs

] News

1 Media

:] Forums

D Groups

a Group pages
|1 Members

D Examples

& Files

BB EE B EE

.5 Special pages
: a Logon page
[ search

Page | Desgn | Form  Properties

¥ ForumGroup &3

[

Threads Posts

=
Display web part content @

Last post

Community forums

Thisis a general farum for both registered and not registered site users.

Announcements

T)%/\ Find out the latest news about our community here
Lock
Community FA

C

(.
1)

W

Answers to Frequently Asked Questions about our community
Lock

General discussion

(
0

<

General discussion without rules and limitations

EI Lock

Members discussion
Discussion for commurity members only
Lock

v ForumGroupl {53 I
}

(
0

g

Threads Posts

Jenny
(10/25/2008 11:53:09 AM)

Jenny
(10/25/2008 2:01:55 PM) m

David
(10/25/2008 3:10: 11PM)

Pogo
(11/5/2008 4:20:25 PM)

m

Last post

Back-packer forums

This forum is intended for user groups, their members and topics related to the particular groups.

| Announcements
-VE%/« Find out the latest news about aroups here
Lock
X FAQs
f)ﬁ/\ Answers to Frequently Asked Questions zbout groups
Lock

General discuscinn

Jenny
(10/25/2008 5:51:40 PM)

Jenny
(10/25/2008 6:15:57PM)

Forums management can be performed in CMS Desk -> Tools -> Forums. On the page, you can see a
list of existing forum groups. By clicking the Edit (#) icon, you can enter the Forum group properties

section.

232 Kentico
#§% CMS Desk

=)~ Tools

‘.|a Abuse report
BizForms

W Blogs

P} Booking system
9& Content staging
-fiill Custom tables
- E-commerce

- [[q File import

- &4[Forums

& Groups

Il Media libraries

Content My desk Toolz Administration
&l Forum groups

&4 New forum aroup

Actions Group name

T & Community forums

Z R T+ §  Backpackerforums

There are three tabs available in this section:

e Forums - a list of forums in the forum group; you can change the order in which the forums will be
displayed by clicking the Move up () and Move down (#) arrows; you can also Delete (¥)
particular forums or click the Edit (#) icon, which displays the forum's management section described

below
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e General - on this tab, you can set some basic properties of this forum group; the properties can be
inherited by particular forums
e View - displays a preview of how the forum group appears on the live site

&ﬂ Forum group properties @

Eorum groups » Community forums

Forums General View
=]
ﬁ Add forum
Actions Forum name Status = Moderated = Threads = Posts = Last post Last post by
# 8 & & Announcements Open No 2 2 10/25/2008 11:59:09 AW Jenny
f x T & Community FAQ Open Mo 1 1 10/25/2008 2:01:55 PM Jenny
W& & ceneraldiscussion Open No 2 6 10/25/2008 3:10:11PM David
F R AT L Wembers discussion Open No 1 5 11/5/2008 4:20:25 PM Pogo

The forum management section accessible by clicking the Edit (#”) icon offers the following tabs:

e Posts - tree-like view of threads in the forum, with the possibility of performing management tasks like
editing or deleting posts, replying to them, approving or rejecting, etc.

e General - general properties of the forum, which can be inherited from the forum group's general tab
mentioned above

e Subscriptions - management of subscriptions; users can subscribe to receiving notifications about
new posts

e Moderators - on this tab, you can set if the forum is moderated and assign site users with the rights
to moderate this forum

e Security - on this tab, you can set permissions for particular actions in the forum

e View - displays a preview of how the forum group appears on the live site

& Forum group properties 2]

Forum groups » Community forums

Forums General View
|t |
Forums » Announcements @
Posts General Subscriptions Moderators Security View
=

=)~ Announcements @ Forum post
L2 |Welcome to our forum -

.42 Forum rules [A Edit x Delete (= Reply (3 Stickthread (& Unlock thread @ Reject @ Reject sub-tree (5 Move

Jenny(10/25/2008, 11:32 AM)
Welcome to our forum

Hithere,

welcome to the community forum. My name is Jane Oakley and | am one of the founders of this community site. In this
forum, you can find discussions on various travelling-related topics. You can discuss your recent or future destinations,
Valued ways of travelling, travelling equipment, just anything you would like to know something about or, on the other hand,
member share your opinion about with others.
We hope that this forum will become a source of valuable information for you and that it will be a place to that you will
always like to return. And one lastthing, please read the forum rules and do your best to follow them. It will just make this
forum a much better place for all of us

d

ﬁ Post attachments
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242

Modifying the forums structure

When developing your community site from the Community Starter site template, you will probably want
to modify the forums structure so that it matches the needs of your community. In the following
example, you will learn how to create a new forum group and replace the Back-packer forums with

It.

1. Go to CMS Desk -> Tools -> Forums and click the New forum group link at the top of the page.

2Y2 Kentico

#§N CMS Desk

=) Tools

8] Abuse report

: BizForms

Blogs

Pj} Booking system
9@ Content staging
-fiill Custom tables
- TR E-commerce
--[[q File import

- &d[Forums

& Groups

- Igal Media libraries

Content

My desk Toaols

& Forum groups

&l New forum aroup

Actions
FRT Y
FRT S

Administration

Group name
Community forums

Back-packer forums

2. On the New forum group page, enter the following details:

Switch to Site Manager

e Group display name - name of the forum group displayed on the live site and in the administration

interface

e Group code name - name of the forum group used in website code
e Description - text describing the forum group, displayed abowve the list of forums in the group on the

live site

e Forum group base URL - URL of the page where the Forum group web part displaying this forum
group resides; leave the Inherit from settings check-box checked
e Forum group unsubscription URL - URL of the page where the Forum unsubscription web part
resides; leave the Inherit from settings check-box checked

Click OK.

2)2 Kentico

#§% CMS Desk

=) Tools

‘..|@ Abuse report
BizForms
2 Blogs
f—ﬂl Booking system
3& Content staging
i}l custom tables
.- PR E-commerce
--[f@ File import
- &4Forums
& Groups
- lgal Media libraries
Message boards
i) Newsletters
@ Polls
[E] Reporting

Content

My desk Toals

&4 New forum group

Groups » MNew forum group
Group display name:

Group code name:

Description:

Forum group base URL:

Forum group unsubscription URL:

Administration

Web development forums

WebDevelopmentForums

Switch to Site Manager

This forum group contains -
dizcuszion related to web

development, related

technologies, job offers in this

field and many more.

e

Site: Community

[¥! Inherit from settings

[#linherit from settings
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3. The Forum group properties page will be displayed. Let's make some additional settings which you
may find useful before we start defining the forums within this forum group. Switch to the General tab
and set the following properties:

e Forum type - User can choose; this option enables users to choose from classical or Question-
Answer type when creating a new thread

e User can edit own posts - enable this option so that users can edit their own posts

e User can delete own posts - enable this option so that users can delete their own posts

e Enable * in posts - enable all the check-boxes so that users can use all BBcode macros in their
posts; for more details on supported BBcode macros, please refer to Kentico CMS Developer's Guide
-> Module Forums -> BBcode support

Leave the rest of the properties at their default values and click OK.

-‘!’- Kentico Switch to Site Manager ~ Site:| Community Site [+ |
'.\ CMS Desk Content My desk Tools Administration
& Tools &l Forum group properties

Q Abuse report
El BizForms Forum aroups » Web development forums

Blogs

e . Farums General View
--[fd Booking system
Ba Content staging -
ﬁ Custom tables Forum group base URL: Inherit from settings
m E-commerce o
. Forum group unsubscription URL: [ Inherit from settings
-1 File import
- &d/Forums _ _
& Groups Require e-mail addresses: [}
|§| Media libraries Display e-mail addresses: =
; Message boards Enable WYSIWYG editor: [

Newsletters Use security code (CAPTCHA): |

@ WUsercan choose
Forum type: () Discussion forum
() Question-Answer forum

Minimum votes to mark post as answer: 5

——

Maximum image side size: 400

Attachment max. file size (kB): 0

User can edit own posts:

= =

User can delete own posts:

Enable links in posts: No ) Simple dialog ) Advanced dialog

Enable images in posts: Mo ) Simple dialog ) Advanced dialog
Enable quotes in posts:

Enable code snippets in posts :
Enable bold font in posts:
Enable italics font in posts:
Enable underline font in posts:

Enable strike font in posts:

FEEEEEEE®®

Enable font colors in posts:

4. Now we will define the forum group structure - the particular forums. Switch to the Forums tab and
click the Add forum link.
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232 Kentico

#§% CMS Desk

=) Tools
‘.8 Abuse report

: I Booking system
5@ Content staging
~fill Custom tables
- T E-commerce

- (g File import

- &d[Forums

.. &4 Groups

|§| Media libraries

Content

My desk Tools

Administration

&2 Forum group properties

Forum groups » Web development forums

Forums General View

No data found.

5. Enter the following details:

e Forum display name - name of the forum displayed on the live site and in the administration

interface

e Forum code name - name of the forum used in website code
e Description - text describing the content of the forum, displayed in the list of forums in the group on

the live site

You can set the rest of the properties to inherit the settings from the parent forum group and click OK to

sawve the forum.

232 Kentico

1% CMS Desk

= Tools
‘./a| Abuse report
BizForms

Blogs

--|fé Booking system
Ba Content staging
-fi}l custom tables
PR E-commerce
{3 File import

- &d[Forums

83 Groups

[l Media libraries

: Message boards

Newsletters

é Polls
[&] Reporting

Content

——

My desk Tools

Administration

3& Forum group properties

Forum groups » Web development forums

Forums General View

Forums » Mew forum

Forum display name:

Forum code name:

Description:

Forum base URL:

Forum unsubscription URL:
Require e-mail addresses:
Display e-mail addresses:
Enable WYSIWYG editor:

Use security code (CAPTCHA):
Forum is open:

Forum is locked:

Forum is moderated:

ASP _MET Discussion
ASP_MET_Discussion

Switch to Site Manager

Discussion related to this -

Microsoft technology.

Inherit from forum group
Inherit from forum group
Inherit from forum group
Inherit from forum group

IDDH

Site: | Community Site [«

Inherit from forum group

Inherit from forum group

6. You are redirected to the forum editing section. If you switch to the Forums tab again, you should see
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the newly created forum in the list. Repeat the procedure and define some other forums in this forum
group. When you are finished, you should see all the forums in the list on the Forums tab like in the

screenshot below.

&ﬂ Forum group properties
Forum groups » Web development forums

Forums General View

&a Add forum
Actions Forum name
f x T & Web development jobs
f X T 3é PHP Discussion
# ® & & ASPNETDiscussion

Status  Moderated Threads Posts Last post  Last post by
Open MNo V] V]
Open No 0 0
Open Mo 0 0

7. Now when the forum group is created and the forums in it defined, we can publish the forum group on
the live site. We will place it instead of the original Back-packer forums.

Go to CMS Desk -> Content -> Edit. Select the Forums document from the content tree and switch to
the Design tab. Scroll down the page and choose to Configure () the ForumGroup1l web part.

Switch to Site Manager

232 Kentico
’l‘ CMS Deslk Content My desk Tools Administration
— —, = T — .
B g B ®#we | 3 [q [6 = | R
New Delete |= Move & pown | Edit  Preview Livesite  List | Search |
Content management | View mode | Other |
Iﬂ'!l‘_.ﬁ Community Site Page Design Form Properties
-[] Home v
i Lock
]| Blogs
@1 News General discussion
'ﬂ_'—J BT ff} General discussion without rules and limitations
dg Forums Lok
-] Groups
(-] Group pages Members discussion
|ﬂ|_] Members Discussion for community members only
-] Examples e
(=5 Files

[+ "5 Special pages
a Logon page
i search

¥ ForumGroup @

Back-packer forums

Thizs forum is intended for user groups, their members and topics related to the particular g

8. In the web part properties window, change the value of the Group name property to the name of the
new forum group created abowve, which is Web development forums in our case. Click OK.
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& | CMS Desk - Web Part properties -- Webpage Dialog M
& Web part properties (Forum group) @ Documentation
General Layout
Default i

Visibiity Display to roles: 3 Add roles

Group settings

Post options .
Group settings
Post extended options|

m

Behawviour Forum layout: ¥ | Flat |Z|
Abuse report ™
Paging Group name: v | Back-packer forums
el Back-packer forums
FrienE Community forums
Tree forum properties Web development forums
Post options
HTML Envelope
AJAX Enable favorites: 3
Time zones
Partial caching Enable signature: 2
Display attachment image: y O
Attachment image maximal side v 1100
size:
Redirect to user profile: 3
VIRefresn content [ ok [ Cancel [ Apiy |

http://localhost/KenticoCM5_0217/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii €& Local intranet | Protected Mode: Off

9. If you switch to the live site now, you should see that the Back-packer forums have been replaced
by the Web development forums defined earlier in this example. The forum group is fully functional
and the discussion may begin.
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Home Blogs News Media F ps Memb Examples Search
Forums
username Log on Search forums:
Advanced search
Forum Threads Posts Last post

Community forums

This is a general forum for both registered and not registered site users,

Announcements

Find out the latest news about our community here

0
=]
.

“
i

Jenny
(10/25/2008 11:59:09 AM)

Community FA

Answers to Frequently Asked Questions about our community

0
-

“
i

Jenny
(10/25/2008 2:01:55 PM)

General discussion
General discussion without rules and imitations

0
=]
-

“
i

David
(10/25/2008 3:10:11 PM)

Members discussion

Discussion for community members only

0
-

“
i

Pogo
(11/5/2008 4:20:25 PM)

Forum Threads Posts Last post

Web development forums
This forum group contains discussion related to web development, related technologies, job offers in this field and many more.

\;EJ_%) Web development jobs o 0 {1/1/0001 12:00:00 AM)
\;EJ_’E\ PHP Discussion 0 0 (1/1/0001 12:00:00 AM)
SL, ASP.NET Discussion 0 0 (1/1/0001 12:00:00 AM)

[
i

Discussion related to this Microsoft technology.

Further steps: You hawe learnt how to define a new forum group and publish it on the live site. Like this,
you can define another forum group and publish it instead of the Community forums forum group. In case
that you wanted to have more than two forum groups published, you only need to place another Forum
group web part on the page and define its Group name property. You may also want to have only one
forum group published, in which case you only need to remove one of the Forum Group web parts.

2.5 Blogs

2.5.1 Current functionality

The Blogs module is a ready-made’ solution and you will probably not need to make any customization
tasks to it. Howewver, we will at least describe its functionality from the site user's perspective in brief.
Detailed information on the Blogs module can be found in Kentico CMS Deweloper's Guide -> Module

Blogs.

1. Go to the live site and sign in as David with blank password. Click Blogs in the main menu.

On the Blogs section's title page, you can see recent blog posts from all blogs on the site.You can
browse the posts by topic - by clicking a keyword in the Tag cloud, a list of blog posts tagged with the
keyword will be displayed. You can also browse the posts by particular blogs. The Recent blogs box
displays links to the most recently created blogs and a link to the list of all blogs. After clicking a blog
link, both in this box or in the list of blogs, you will be redirected to its title page.
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Home Blogs News Media F ps Memb

Examples
Recent blog posts

—

| The long long flight

Finally, after some 23 hours of flight, I am on the other side of the world than I was yesterday around this time.
1 feel terribly tired after the long flight, but before I go to sleep, I found some time to write about the first
impressions of my journey.

Posted to Holiday in Australia by Kelly Taylor on 10/26/2008 3:05:12 PM | with O comments

—

| Flying tomorrow

Hi everybody, my name is Kelly Taylor and I come from Brno, Czech Republic. Tomorrow is my big day. Finally,
after six months of hard everyday work, I decided to have some nice time and go on holiday. Australia has
always been one of the places I had wanted to visit one day, and now, with my great new job and the wage 1
get for it, it is finally affordable for me to get there.

Posted to Holiday in Australia by Kelly Taylor on 10/256/2008 2:19:18 PM | with 0 comments

Search

Sign in

Log on

RSS Feed
|- Recent blog posts

Shortcuts
Join the community

Tag cloud

sirport Australia Austria bus
cuising Czech Repubiic flight
France Germany

hitchhiking nesdsy
hostel Ttahy luggage sacher torte
Slovenia SPaIN subwiay toursm
traffic train

2. Click some blog in the Recent blogs box to display its title page. The blog's title page is similar to
the Blogs section's title page, but displays only posts from the current blog. In addition to the Tag cloud,
you can browse posts in the current blog by months too. By clicking a month link in the Post archive

box, you can display only posts from the clicked month.

Home Blogs News Media Forums Groups Members Examples

Abi's european trip

J Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhiking trip, the tension between PJ1 and me is all
gone. I have a friend here, so the last night we spend in his place, drinking wine and using his computer to look
at pictures we've taken during our month in Europe.

L

Today, P1 went to do some

and we've pr d each other go out have dinner tonight.

Posted to Abi's european trip by Abigail Woodwarth on 7/5/20038 1:56:04 PM | with D comments

—

U Wir sind Berliners

Berlin, after a long time the city we both wanted to see. And as we're almost done with our trip, we're getting
much more relaxed in comparison with just week ago. We are almost able to joke with each other again. We
dont have much money left, though, so we're mostly h ing around, considering every Euro, spent for the
gallery ticket.

Posted to Abi's european trip by Abigail Woodwarth on 7/3/2008 1:54:27 PM | with 0 comments

—

U Disapointment in Prague

I'm supposed to pick up PJin Bratislava. Again, I don't have to hitchhike so I'm taking a bus. 0ddly enough, P1's
rather glad to see me. The trip to Prague is one smooth ride. But the city center is jammed with people again.
Why all tourists share the need of visiting same places at the same time?

Search

RSS Feed
|- Recentblog posts

Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign Out

Tag doud

sirport Australia Austria bus
cuisine Czech Republic flight
France Germany

hitchhiking neis=y
hostel izl luggage sacher torte
Sloveniz Spain subway tourism
traffic train

Recent blogs
Abi's european trip
Holiday in Australia

View all blogs

Latest blog comments

3. Click some blog post to display it. Below the text, you can find the Content rating web part, social
bookmarking links, trackbacking URL and the comments section where you can post comments on the

blog post.
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Home Blogs News Media F up Memb Examples |

| | Search

Abi's european trip > July 2008

fm xDeIete
J Wir sind Berliners

Berlin, after a long time the city we both wanted to see. And as we're almost done with our trip, we're
getting much more relaxed in comparison with just week ago. We are almost able to joke with each other
again. We don't have much money left, though, so we're mostly b il d, idering

every Euro, spent for the gallery ticket.

Because that Euro might have been the next breakfast.

Tomorrow morning, we're setting of for our last hitchhiking trip. So far, I didn't tell you how we manage to hitchiking with all the luggage we have,
though. The few of you were curious about it. Well, let's put some light on the subject. First of all, we have barely any luggage at all. Oddly as it may
seem, together with PJ, we have succeeded in fitting everything into two badkpacks. To be honest with you, one really doesn't need to have much
stuff. A camera, two pair of shoes and some dothes but not much. We take advantage of the public laundries that are usually conveniently located
near hostels a lot. We have our sleeping bags in case of emergency as well. Everything else is just junk that you can do without.

When we're waiting for the ride, we always form our backpacks into a sophisticated pile that looks much smaller than itis, in reality. And I don't recall

waiting for more than an hour for a ride, beside those troubles in Pyrenees. Everyone who has ever tried hitchhiking must admit that it is more than
impressive,

Posted by Abigail Woodwarth on 7/3/2008 1:54:27 PM
Filed under: Germany, lugaaage, hitchhiking

Current rating: 0 (0 ratings)
'y | =) L2 L L] ir ]
Bookmark this page to:o ki ¢ l.-" QJE; g\"ﬂ B R4 ,osﬁ JEE@I L™ l] [} ﬂ - @w%‘:@ﬂ+
Trackback URL: http:/flocalhost/KenticoCMS_0217 ftrackbadk/bcé0d 227-73b6-4d21-b 388-35ccaded 1ade/Wir-sind-Berliners. aspx
v Comments
Blog post currently doesn't have any comments.

Leave comment Subscribe

Name:

Admin

RSS Feed
H Recent blog posts

Shortcuts
My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign Out

Latest blog comments

There are currently no
comments.

Post archive

July 2008(3)
June 2008(7)

4. When we have seen what the Blogs section on the site looks like, we can try creating our new blog.
This can be done anywhere on the live site by clicking the Create a new blog link in the Shortcuts

menu.

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create @ new group
Create a new blog
ian ou

5. On the Create new blog page, you only need to enter the name and description of your new blog

and click OK.
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Home Blogs News Media F ps Memb Examples Search

Create new blog
Shortcuts

You can create your new blog by entering the required details into the fields below. You will be able to change the entered data later. After submitting My profile

these details, you will be able to edit your blog's properties or start blogging immediately. E_Uj_dit my profile

My messages

My friends

My invitations
Create a new group

Blog name: My first blog
Sign out

This is my first attempt to create a blog. =

Recent blogs
Abi's european trip
- Holiday in Australia

View all blogs

Blog description:

6. The blog is now created and you are redirected to the blog's title page, where you can Edit blog (#)
properties or write a New blog post.

Home Blogs News Media F ps Memb Examples Search

My first blog
RSS Feed

fEdit blog I} Recent blog posts

New blog post

Shortcuts

My profie
Edit my profile

My messages
My friends
My invitations

7. From now on, the blog is fully functional. You can find a link to the blog in the Recent blogs box on
the Blogs title page, in the list of all blogs and on your public profile page.

2.6 Media libraries

2.6.1 Current functionality

The media libraries allow convenient storage of large amounts of files. Not only media files, but also
files of any other types can be stored within the libraries, while even large file sizes (sewveral GB) are
supported. Media libraries can be either global or related to a particular group. For detailed information

on the module, please refer to Kentico CMS Deeloper's Guide -> Module Media libraries.

1. If you go to the live site, you can enter the site's global media libraries section by clicking the Media
link in the main menu. This section displays the content of the only global media library on the site,
which is named Media. You can see the library's folder structure tree on the left. By clicking a folder,
files stored within the folder will be displayed in the main area.
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Home  Blogs

Media gallery

(=) Media
f{j‘ Documents
’{j‘ Music
{S‘ Pictures
75 Video

News

| Media F

Sort by: Name Date Size

Buildings
Size: 31 kB
Uploaded: 2/18/2010

MP3

WIN XP startup so...
Size: 76 kB
Uplcaded: 2/18/2010

Street
Size: 35 kB
Uploaded: 2/18/2010

WAV

WIN XP startup so...
Size: 415 kB
Uploaded: 2/18/2010

l£21 2 >>z|Results 1-80f 16

River
Size: 26 kB
Uploaded: 2/18/2010

WIN XP startup so...
Size: 26 kB
Uploaded: 2/18/2010

| | | Search

Shortcuts

My profile

Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

Nature
Size: 42 kB
Uploaded: 2/18/2010

M5 Word document
Size: 9.7 kB
Uploaded: 2/18/2010

2. If you click a file's thumbnail, the file will be displayed in the main area. Depending on the type of file,
the display may vary. Images will be displayed in large size, videos or sound files display a player where
the files can be played. Documents are displayed only in form of the document type icons. Additional
information about the file is displayed in the bottom left corner. All files can be downloaded using the
Download link at the bottom right corner.

Home  Blogs

Media gallery

(=) Media
{j‘ Documents
{j‘ Music
{j‘ Pictures
f{j‘ video

News

.~ Media  F

Buildings

Size: 31kB

Description: Sample picture description.

Uploaded: 2/18/2010
Type: . JPG

| | | Search

Shortcuts

My profie
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog

Sign out

-
<4 Download

3. As we mentioned abowve, groups can also have their own media libraries. This is the case of the
Czech Republic fans group on this sample site. If you go to Groups -> Czech Republic fans and
click the Media link in the Group links box, media libraries of the group will be displayed.
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2.6.2

Home Blogs News Media Forums Groups

Groups P Czech Republic fans » Media

Bellow you can find list of group media libraries.

Czech nature

Czech nature is really nice.

Czech cities

Czech cities are amazing.

Creating custom media libraries

Members

Examples

| | Search

Shortcuts

My profie
Edit my profile

My messages

My friends

My invitations
Create a new group
Join the group
Manage the aroup
Invite to group

Create a new blog
Sign out

Group links

Home

In the following example, you will learn how to create a new global media library and publish it on the

site.

1. Go to CMS Desk -> Tools -> Media libraries and click the New media library link at the top of the

page.

232 Kentico
#gS  CMS Desk

=) Tools

8] Abuse report

: BizForms

Blogs

: ' Booking system
sg Content staging
[}l custom tables
PR E-commerce

- [ File import

&4 Forums

& Groups

- IgalMedia libraries
- [ Message boards

Content My desk Tools Administration

g Media libraries

ew media library

Actions  Name  Folder

R Media

2. Enter the following details into the form:

Description

Here you can find different kinds of media files.

located under <web project>/<site name>/media/

Click OK.

Switch to Site Manager

Display name - name of the library displayed on the live site and in the administration interface
Code name - name of the library used in website code
Description - text describing the media library, displayed in the list of media libraries on the live site
Teaser image - upload some image which will be used as a teaser in the list of media libraries

Folder name - name of the physical folder in the file system which will contain the library files; it is
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Y2 Kentico
P4%  CMS Desk

=) Toaols

...a Abuse report
[El BizForms

. Blogs

- 'f2 Booking system
Da Content staging
“fill custom tables
--FR E-commerce
[ File import

-84 Forums

& Groups

- Iga|Media libraries
...[[] Message boards
f:ﬂ Newsletters
@ Polls

...[&] Reporting

nj Web analytics

Switch

My desk Tools Administration
New media library
Media libraries » Mew media library
Display name: My first media library

Code name:  |MyFirstMediaLibrary

This is my first media library. -
Description:

Teaserimage: | Upload: C:\Users\petrpe\Desktop\:
Folder name: |my_first_library

3. You will be redirected to the media library management interface, which is also accessible by clicking
the Edit (#") icon in CMS Desk -> Tools -> Media libraries.

First, we will define the folder structure. Select the root of the tree and click the New folder (54) icon.
Enter the name of the new folder and click OK. Repeat the procedure so that you have at least two
different folders in the library.

Please note: due to ASP.NET architecture, site restart occurs whenever a folder is moved, renamed or
deleted. To prevent this, it is a good practice to define the library structure when creating it and not to
modify it when the site is already running.

2¥2 Kentico
#§% CMS Desk

=)~ Tools

i Abuse report
[El BizForms

Blogs

F4 Booking system
9& Content staging
-fill Custom tables
- PR E-commerce
--[[q File import

- &4 Forums

& Groups

- Iga|Media libraries
...[] Message boards
£l Newsletters

& Polls

[&] Reporting

“.4afl Web analytics

Switch to Site Manager  Site: Commt

My desk Tools Administration

g Media library properties

Media libraries » My first media library

Files General Security
[:IH New folder |_71 New file % List Tiles
i Delete & Copy 5 Move Name:

@ Thumbnails
I

..... my_first_library (0) e
£ | MNew folder -- Webpage Dialog

==

g New folder

Folder name: photos_from_usa

[ ORCanee—

htt €& Local intranet | Protected Mode: Off

4. Now we can upload the files. Select one of the folders and click the New file ([4) icon at the top right
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caorner.

The Choose file dialog appears, letting you choose a file from your local disk. Select some image and
click Open. Repeat the procedure so that you have several files in both folders.

22 Kentico

#§% CMS Desk Content

=~ Tools
|@] Abuse report
BizForms
- Blogs
--Fé Booking system
BQ Content staging
--fiJl custom tables
- E-commerce
I File import
- &4 Forums
& Groups
. lgd Media libraries
Message boards
-l Newsletters
@ Polls
[&] reporting
--fafl Web analytics

Switch to Site Manager

My desk Tools Administration

Media library properties

Site:| Community Site[«] User: Global Administrator v5

Media libraries » My frst media liorary | (© C95€ File o Upload i
QQ\7| | » community b pictures b europe + [ # ||| Search curope o]
Files General Security
- Organize = New folder =~ B @
L_ﬂ Mew folder n —_—
[ Favorites T - — s
GeDelete  SCooy S Move B Desktop . 1 r‘ E'[
(=) my_first_library (0) = Downloads ut >
.75 photos_from_europe (0) & Recent Places budapest madrid paris prague
4 photos_from_usa (0)
4 Libraries L
@ Documents i
J‘ Music
[E=] Pictures
B Videos
18 Computer T
&, Local Disk (C3)
l. licons
. 50 builds
File name: budapest ~ [AllFiles ) -
[ Open |v] l Cancel ]
Lk - _ Lk

5. Our media library is now finished and we can publish it. Switch to CMS Desk -> Content -> Edit ->
Design tab and choose the Media page from the content tree. Choose to Configure (‘&) the
MediaGallery web part.

Switch to Site Manager

=32 Kentico

‘.‘ €MS Desk Content My desk Tools Administration

— — - T — — —

B [ B %w 3@ Q@ = | L |

MNew Delete |= Move & Down | Edit Preview Live site List | Search |

Content management | . View mode | _ Other |

|ﬂ'$_;'3 Community Site Page Design Form Properties

D Home

] Blags

D News
[1/Media

D Forums

D Groups

D Group pages
L] Members

mﬁ‘ Special pages
D Logon page
L[] Search

Home  Blogs  News = Media  Forums Men
|'J'Melia-pageﬁemdate:0mmulitvﬁte—m
¥ zoneCenter

¥ HeaderText @
v MediaGaller I Sort by: Name Date Size

-5 Documents

;---ﬂMusic
;---@PiMres
15 Videa

6. In the web part properties window, select your new media library in the Media library drop-down list
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and click OK.
Content

Media library: v [Media [~]
(current media library)
IMedia

Path: LI Iy first media library

Show subfolders content: 3

Display file count: y O

7. If you switch to the live site now, you should see that the original media library has been replaced by
your new media library.

Home Blogs News Media F up Memb Examples | | | Search
Media gallery

Shortcuts
- my_first_library Sortby:tians pese e I'l;.lldit mogﬁgle ofile

1] photos_from_europe

: My messanes
My friends
My invitations

Create a new group
Create a new blog
Sign out

{S‘ photos_from_usa

arizonal arizona2 arizona3 arizonad
Size: 791 kB Size: 791 kB Size: 791 kB Size: 791 kB

Further steps: You have created a new media library, defined its structure, uploaded some files and
published it on the live site instead of the original sample media library. As obvious, you can publish only
one global media library this way. This might be fine for many sites, but if you want to have more global
media libraries published on the site, go to the next chapter where you can find more information on how
to achieve this functionality.

2.6.3 Publishing more than one global media library

In the following example, you will learn how to publish more than one global media library on the site.
We will try to achieve a functionality similar to group media libraries (see Groups -> Czech Republic
fans and click Media in the Group links box). As you can see, we have two pages where a list of
available libraries is on the first page. Links in the list lead to the second page where the content of the
clicked library is displayed dynamically.

1. Go to CMS Desk -> Content -> Edit and select the Media page from the content tree. Click the New
icon above the content tree to create a new page under the Media page.
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232 Kentico
#§% CMS Desk Content | My de:

2 2 [ copy T up
EN .
MNew JDelete =k Move & Down

Content management

clv_’l Community Site
|_] Home
|1||_] Blogs
l_"l 1 Mewr
[l [Media
[+ Forums
|:||_] Groups
|1||_] Group pages
¢||_1 Members
|1||_] Examples
(4.5 Files
|:|'\5:| Special pages
,_] Logon page
‘.. ] Search

2. Choose the Page (menu item) document type. For Page name, enter Media gallery and choose
the Community site -> Community site - Media page template. Click Save.

Page name: Media gallery

@ Use page template () Inheritfrom parentpage () Create a blank page
d--iﬂ’ All page templates Template name:
T Articles Cenmnunty e CUnnmunLy i ConnnunLy e CunmnunLy e

Group registration Group template Groups Home page

.:)]‘ Blank pages for widgets
= Blogs

Community Site

.3’ Corporate Site ASPX
E-commerce

) Events =
) FAQs
Forums
3, Genaral Community Site - Community Site - Community Site - List Community Site - i
= Home Page Invitation of blogs Logon page
3 Home pages Authenticated Acceptation

Images
Job openings

Knowledge base
Master templates %
P} Membership and security

Message boards

m

‘:j‘ News Community Site - Community Site - Community Site -
) Newsletter Master Page Media Member profile

Offices R
%) Personal Site -
) Press releases 123

Products

Templates with editable regig
Wiki

4 1 | 3

Community Site - Media

3. Now we have two pages showing the same content because they use the same page template. But
the required functionality is the following: the Media page should display a list of global media
libraries; after clicking a library, users should be redirected to the Media gallery page, which shall
display the content of the clicked library.

First, select the Media gallery page and switch to the Properties -> Template tab. Select the Select
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inherited levels radio-button and choose to inherit from Root only. Click Save.

Switch to Site Manager  Site:  Community SItEEl User: Glob

232 Kentico
#g% CMS Desk

Content My desk Toals Administration
EE T . L 4  [d A
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |

= !;_’J Community Site Page Design Form Properties
\—] Home General
[3J-.] Blogs E Save
-] News i
|:/;_] Media Template
: i..[1[Media gallery Metadata Template
(-] Forums Categories Community Site - Media Select
.ﬂ_] Groups Menu .
¢AJ Group pages oS 4 Save as newtemplate...
jj :::r:;;ss Versions gf‘ Inherit template
. Related docs .
[xJ- Files ) =/ Clone template as ad-hoc
(-3 Special pages SuEiie ~
~..[] Logon page Security [f Evittemolate proverties
‘.. Search Attachments

Inherit content
H ) Use page template settings
(= Do notinherit any content

@ Selectinherited levels

- ¥ Root

[ Media

4. Switch to the URLSs tab and enter /Media/{LibraryName} into the Document URL path filed. This
wildcard URL will ensure dynamic loading of the media library into the media gallery web part (configured
to behawe like this in step 5). Click Save.

232 Kentico

#§N  CMS Desk

Switch to Site Manager  Site: Community

Content My desk Tools Administration
2 2y c u = =
2[5 e o 2 [ e
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other |
C‘!‘_,] Community Site Page Design Form Properties
'—] plome General |
()| Blogs E Save
L URLs
-] News
|:l|_] Media Template
: i..[) Media gallery Metadata The changes were saved.
|1|,_] Forums Categories path
|1l|_] Groups Menu Document alias: Media-gallery
(-] Group pages Workfiow [ Document URL path: |/\edia/{LibraryName} I
‘1"—] Members Ve T Use custom URL path
[+)- | Examples
‘1‘,_\,_:3 Files Related docs endad .
oS : Linked docs ended properties
';‘ \")” Srzeslrare [ URL extensions:
:~|_] Logon page Security B -
...[J) search P Use custom URL extensions
Track campaign:

5. For the Media gallery web part to load the library dynamically, we also need to tune its Media
library property. Switch to the Design tab and choose to Configure () the Media gallery web part.

© 2011 Kentico Software



74

Kentico CMS 5.5 R2 Community Site Guide

Set the value of the Media library property to (current media library) and click OK.

& | CMS Desk - Web Part properties -- Webpage Dialog

General Layout

Default
Visibility
Content
Upload settings

Content
transformations

Filter settings
Content filter
Pager

Pager design

Mo data behavior
HTML Envelope
AJAX

Time zones

Partial caching

Refresh content

& Web part properties (Media gallery)

Content

==

y
@ Documentation

Media library:

Path:

(current media library)

(current media library)
Media
My first media library

m

Show subfolders content:

Display file count:

Display active content:

Preview suffix:

lcon setname:

Hide folder tree:

Use secure links:

Linlaad eattinme

|

b

[ Ok | Cancel | _Apply |

http://localhost/KenticoCM5_0217/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii el'. Local intranet | Protected Mode: Off

6. Select the Media page and on the Properties -> Template tab, click the Clone as ad-hoc
template link. Click Save.
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212 Kentico

Switch to Site Manager

Site:

Community Sitelz| User: Glo

’.‘ CMS Desk Content My desk Tools Administration
Glcoy  @ue (q = r
New Delete = Move & pown Edit  Preview Live site List Search
Content management View mode Other
C";‘_," Community Site Page Design Form Properties
e Hlome General
|| Blogs Save
. l_l URLs E
-] News
|:l._l Media Template
-[] Media gallery Metadata Template
(=)-| Forums Categories Community Site - Media Select
|1l._| Groups Menu .
nil-_l Group pages Workfow ,—gﬁ: Save as new template...
[#)-l-] Members 3 =
™ Versions /' Inherit template
[=-|.| Examples i
S Fil Related docs N
(- Files ] =/ Clone template as ad-hoc
d{;‘ Special pages Linked docs =
[ Logon page Security E Edit template properties
-.[] Search Attachments
) Inherit content
ﬂ @ Use page template settings
@ Do notinherit any content
) Selectinherited levels
7. Switch to the Design tab and choose to Remove the MediaGallery web patrt.
|',-‘Me|lia—pagehemplabe:ad—hnc ﬂ|
T zoneCenter
* = zoneRight +

¥ HeaderText @

v logonminiform {23
v Shorteuts {23 ]

v MediaGallery @,! Shortcuts
{3 Confiqure My profile

Edit my profie

ﬁ‘ Up... My messages
3D My friends
oW ... P

My invitations

Move to zone ...

#p Duplicate web part

(o)

Create a new group
Create a new blog
Sign out

8. Add (4F) the Media Library -> Media libraries viewer web part to the zoneCenter web part zone,
to the place of the removed MediaGallery web part. In the web part properties window, choose to Edit
the Transformation Name property.
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& | CMS Desk - Web Part properties - Webpage Dialog | 22 |

y
@ Documentation

& Web part properties (Media libraries viewer)

No data behaviour

Hide if no record found: »

Mo record found text: + Mo data found

Refresh content

General
Default Display to roles: 4 Add roles &
Visibility
Repeater
No data behaviour Repeater v
= Transformation Name: » |Community. Transformations_Media Select =
Pager
Pager design Alternatingltem Transformation > ﬁ i
Mame:
System settings
HTML Envelope Separator Transformation » ﬁ
Mame:
AJAX
Time zones Header Transformation Mame: 3 ﬁ
Partial caching
Footer Transformation Name: 3 ﬁ

http://localhost/KenticoCM5_0217/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii €& Local intranet | Protected Mode: Off

9. In the pop-up window, replace the original transformation code with the following code. The

transformation below is the original transformation with the highlighted code added.

This code ensures that library teasers and names will work as links leading to the /Media/{LibraryName}

URL, where {LibraryName} will be replaced with the name of the clicked library. This

is the URL we hawe

set in step 4 for the Media gallery page. Because the Media library property of the Media gallery

web part on the page is set to (current media library), it will display content of the
the URL.

Click Save.

media library from

<di v class="MediaListlten>
<t abl e>

<tr>

<td class="Medi aLi brarylLi st Phot 0" >

|<a href ="~/ Medi a/ <% Eval ("Li braryNanme") %.aspx"> |
<%t | f Enpty(Eval ("Li braryTeaserPath"), "<inmg border='0"
Conmuni tySi t e/ | mages/ Def aul t Medi aTeaser.gi f\" alt=\"\" />", "<ing sr
Ur | Hel per. Get Absol uteUr| W t hPort (Val i dati onHel per. Get Stri ng(Eval ("
Li braryTeaserPath"), "")) + "?w dth=180\" alt=\""+ Eval ("name") +"\"
>") %

</td>

src=\"~/ App_Thenmes/

c=\"" +

border="0" /
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<td class="MediaLi braryLi st Description">
<a href="~/Medi a/ <% Eval ("Li braryNane") %.aspx"> |

<b>
<%t Lim tLengt h(ResHel per. LocalizeString(Convert.ToString(Eval (
"Li braryDi spl ayName", true))), 20, "...") %

</ b>

<di v cl ass="Medi aLi braryLi stDescriptionText">
<%t Lim tLengt h(ResHel per. LocalizeString(Convert. ToString(Eval (
"Li braryDescription", true))), 40, "...") %

</ di v>

</td>

</tr>
</ tabl e>

<di v cl ass="Medi aLi stltenBotton></div>
</ di v>

10. If you go to the live site now and click the Media link in the main menu, you should see the
functionality described in the beginning of this chapter. A list of all global media libraries on the site will
be displayed. After clicking a library in the list, its content will be displayed.

Current user: Global Administrator (administrator) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

o=
i

Home  Blogs News Media F | _rI"LIExanq:ksl | || searcn

Media gallery
Shortcuts

My profie
Edit my profile

Medi My messages
ia ) ) My friends
;| “— Here you can find different kinds of ... My invitations

Create a new group
Create a new blog
Sign out

My first media li...
= This is my first media library.
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2.7
27.1

Design and styles

Changing the header image

Changing the header image is a procedure of a few clicks. You only need an image of the same width as
the original image, which is 960 pixels. For the purpose of this example, you may use the
community_header02.gif. The file can be found in the attached files package that can be found at

http://www.kentico.com/Downloads/Community Guide/CommunitySiteGuide_files.zip. Once you have the

image prepared, follow these steps:

1. Go to CMS Desk, select the Files folder from the content tree and click New. Choose the File

document type.

232 Kentico

’.‘ €MS Desk Content My desk Tools Administration
= = C U
I [x Boer ®w | 3 [Q @ BE
New |Delete | = Move & Down Edit Preview Live site List
| View mode

- Content management

clp_il Community Site » Files

i--[] Home Yy

u j Blogs New document

+]-- -1

-1 News

L[] Media Please select new document type:
‘1"—| Forums [[] Page (menu item)

[+~ Groups

i Folder

£] Link an existing document
% button_signin

= community_header_img
= CommunityHomeImage
= group_australia

= paris2

f

e plane

Switch to Site Manager

A

Search
Other

2. Click the Upload file (_#) link and browse for your file on your local drive. Enter some text describing

the image if you like and click Save.

© 2011 Kentico Software


http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip

Part 1

79

Switch to Site Manager
=32 Kentico
#8% CMS Desk Content My desk Tools Administration
— — - i — . —
D g Jew e | [ [ [ B | L
New Delete |=kMove & pown | Edit Preview Live site List | Search |
. Content management | . View mode | _ Other |
Iﬂ-{u‘_"'?l Community Site » Files

[ Home
D Blogs
D News
D Media
(-] Forums
ILID Groups
ma Group pages
@

3]

=

] Members

%7 button_joinnow

1% button_signin

= community_header_img
= CommunityHomelmage
= group_australia

{=| paris2

“e=| plane

E Save F‘ Save and create another Spell check
Upload file: 4 Upload file

Thi= i= an alternative to the Community Site header
image.

File description:

d

Site: Commur

3. The image is now uploaded, so let's use it on the master page. Select the root of the content tree in
Page tab and click the Select... button at the top left corner of the header image.

Switch to Site Manager
232 Kentico
'.\ €MS Desk Content My desk Tools Administration
= Doory  Bdioy | [d] (y=a
Mew Delete = Move & Down | Edit Preview Live site List | Search |
Content management | . View mode | _ Other |
- % = -
C"F‘_ﬁ Community Site Page Design Form Master page Properties

D Home

D Blogs

[ News

D Media

+)-|_] Forums
ma Groups
ma Group pages
ma Members
€3]
=

@ button_joinnow
---{# button_signin

/=] community_header_img

{88 community_header02
i [&] CommunityHomeImage
-f= group_australia

- paris2

“=] plane

E Save Spell check

Sign in to CMS Desk. Sign in to CMS Site Manager. T

Current

0 :
Community

Starter site

4. In the pop-up dialog which opens, select your previously uploaded image from the content tree and

click Select.
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| Insert -- Webpage Dialog

@ Selectimage
Attachments | Content

l;a Mew folder

(l New file

Site: | Community Site E

= 7 Community Site
|| Home
|| Blogs

Media libraries

Web

= ust

General

Tiles @ Thumbnails

URL:  |/KenticoCMS_0217/Files/community_header02.aspx

Width: 960
=] )

Height 148

] News

] Media

|| Forums

|| Groups

|| Group pages
|| Members

FEeEEEEE

|| Examples
%3 Files

{8 button_joinnaw

button_signin

(1) 3] Special pages
|| Logon page
-] Search

http://localhost/KenticoCMS_0217/CMSFormCantrols/Selectors/InsertlmageOrhedia/Default.aspx?output=url&amp;content=img&amp;documentid=40 €& Local intranet | Protected Mode: Off

5. Finally, click Save to save the changes made to the master page.

22 Kentico
785 CMS Desk

Content

i up

4} Down
Content management

My desk

2y '_] Copy
X .
New Delete = Move

| Community Site

Home
Blogs
News
Media
Forums

Groups
Group pages
Members
Examples
Files

- DD DD D D D D G

1% button_joinnow

v button_signin

= community_header_img
v community_header02
= CommunityHomelmaage

Switch to Site Manager

Tools Administration

[ = ~r

Edit Preview Live site List Search
View mode Other

Page Design Farm Master page Properties

Spell check

Sign in to CMS Desk. Sign in to CMS Site Manager. 1

Current

x@|
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6. If you switch to the live site now, you should see the new header image in its full beauty.

Current user: Global Administrator (administrator) | My home page | Edit my profile | Inbox | Sign out

> % | . h 1
TR B [ | | [ | immm m. ()

Home Blogs News Media Fi ps Memb Examples Search

Welcome to our community shortcuts
Edit my profile

[ Sign'in > Toin now >

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

This community site is a virtual meeting point for those who like f
travelling, adventure, discovering new places, meeting new L
people and all the things related to it.

fwou are interested in this snrt of thines. don't hesitate and

Further steps: You have learned how to change the header image on the master page. As you will
probably not be satisfied with this level of customization, you can try modifying the site's CSS
stylesheet. Like that, you will be able to fully customize the site's design according to your needs. In the
next chapter, you can find a simple example showing how the site's CSS stylesheet can be modified.

2.7.2 Modifying the stylesheet

In this example, you will learn how to edit the site's CSS stylesheet. We will follow the previous example
and modify the main menu so that it matches the new header image. Any other modifications of your
choice can be done to the stylesheet the same way as described below.

1. Go to Site Manager -> Development -> CSS Stylesheets and choose to Edit (#) the Community
Site stylesheet.

232 Kentico

’.‘ CMS Site Maﬂager Sites Administration Settings Development Licenses Support
|z Development (f CSS stylesheets
- Categories
@ Countries g Mew Css stylesheet
G CSS stylesheets
- cultures
il Custom tables HELLE Display name Code name
c]] Document types I:j Community Site CommunitySite
f_j E-mail templates # R 3 Corporate Site CorporateSite

d’} Form controls
~.[53 Inline controls
‘_’} Modules / x I:j Corporate site printer styles CorporateSitePrinter
“Jii] Netifications

f x I:‘j Corporate Site - Gray and Blue  CorporateSiteGrayBlue

2. The CSS stylesheet is divided into sections so that you can easily find the appropriate classes. The
sections can be quickly accessed by selecting from the listbox on the right. Choose the Top menu
section. Within this section, you can find all classes defining the appearance of the main menu.
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d CS88 stylesheet properties

CS8 stylesheets » Community Site

ICO

I sz a Check out

Check outthe stylesheetto file cinetpubiwwwroot\KenticoCMS_0217\CMSCS S Stylesheets\Community Site.css to edit the stylesheet externally.

Stylesheet display name: |Cnmn1|.|nity Site |
Stylesheet code name: |Cnmn'l.|nity3ite |

Stylesheet text:

/*4Main styles/Top menuf*/
. zoneTopMenu
{
width: 960px;
background: #fff url{(../App_ Themes/Community3Site/Images/topmenu-bg.¢
padding: Opx;
margin: Opx;
H

Group management
Group pages

User contributions
Groups
Home page
Logon page
Logon page
Main styles

Membership top zone
‘Search box

op mer

.PagePlaceholder .zoneTopMenu To

{ Media |
height: 90px; Members
background-color: $#BABABA; Messaging

H Modal popup

i My account

.DesignMode .zoneTopMenu .CMSListMenuUL Ne“_VS page

I Online members
background: #BABABA url(../App Themes/CommunitySite/Images/topmenu-k E::Mswers

- s

: / Registration form

. CHSListMenuUL gﬁ;ﬂnp:ge

{ ) Tab menu
list-style-type: none; Tags

T — | L3 Widgets

3. Replace the text of this section (all classes before the /*#Main styles/Search box#*/ line, which
indicates the beginning of the new section) with the code below. Click Save to save the changes.
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4. If you switch to the live site now, you can see that the colors of the main menu have changed as
defined in the pasted stylesheet code.
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Current user: Global Administrator (administrator) | My home page | Edit my profile | Inbox | Sign out

TN L

Home Blogs News Media Forums Groups Members Examples

Shortcuts
My profie
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

Welcome to our community
[ STETTIT= = JONT OV =>

This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new
people and all the things related to it.

£ramin men indarnctad in bhic caed af hinee dan# hacidadn s

Further steps: You have learned how to access, modify and save changes to the site's CSS stylesheet.
If you are familiar with CSS in general, it should be no problem for you to fully customize any class of
the site's CSS stylesheet and thereby customize the site's design as you wish.
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3

3.1

Part 2

Introduction

In this part of Kentico CMS Community Site Guide, you will learn how to create a community site from
scratch. Our goal in the following series of step-by-step tutorials will be to create an identical site to the
sample Community Starter site from the very beginning, so that you can see all the stages of the
website development process.

You will learn how to define the site structure, populate the pages with web parts and set the web parts'
properties to achieve the required functionality. Finally, you will make some settings to specify pages
with certain special functionalities.

Here are some things to keep on mind when reading the tutorials in order to get the most out of them:

e These tutorials are intended for web dewvelopers with at least the basic knowledge of Kentico CMS. If
you are new to Kentico CMS, please read at least the portal engine version of Kentico CMS Tutorial to
get familiar with the basics of the system.

e Most of the code examples are self-explaining for people with a certain knowledge of HTML, CSS and
transformations, so they are therefore not always commented. It is therefore highly recommended that
you have a solid understanding of these languages.

e The most important part of the tutorials are the web part properties settings. Because it would take
many times as much space to describe all the settings in detail, some of them are just listed without
further explanation. The good thing is that when you click the Documentation link at the top right
corner of each web part properties window, you get detailed explanation of each of the properties
directly within the application interface.
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p
& | CMS Desk - Web Part properties -- Webpage Dialog

General Layout
Default

Visibility

Content

Content filter
Transformations
Paging
Relationships
System settings
Mo data behavior
Editing buttons
HTML Envelope
AJAX

Time zones

Partial caching

Refresh content

& Web part properties (Repeater)

Content filter

Document types:

Combine with default culture:

Culture code:

Maximum nesting level:

ORDER BY expression:

Select only published:

Selecttop N documents:

Site name:

3

3

cms.blogpost
™ Yes

@ No

@ Use site settings

-1
BlogPostDate DESC

6l

S

y
@ Documentation

Soect | Clear

m

[ select | Ciear ]

[ select [ Clear |

http://localhost/kenticocms/CMSModules/PortalEngine/UL/Webparts/WebPartProperties.asp: el'. Local intranet | Protected Mode: Off

After clicking the link, you get the web part's documentation with all the properties explained.
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' ™y
@ ‘Web part - Documentation - Windows Internet Explorer [ == é]

|§, http://localhost/kenticocms/CMSModules/PortalEngine/UL/WebParts/WebPartDocumentationPage.aspxwebpartid=repeater | b |

i Documentation - Repeater

| »

The Repeater web part renders specified documents using given
ASCX transformation.

m

\J
Default =l
Web part control ID: Web partID.
Web part title: Web part title.
Disable view state: If checked, the view state for this web partis disabled.
Disable macros: If checked, the macro resolving for this webpart is disabled.
Visibility =
Visible: Indicates if web partis visible.

Indicates if web part should be hidden on sub-pages. If you check this box, the web part
Hide on subpages: will be displayed only on the page that uses the page template with this web part and it
will be hidden on sub-pages that inherit the page template.

Indicates for which document types should the web part be displayed. Ifthe type of the

S e CC RS currently selected document is different, the web part is not displayed.

The list of roles whao should see the web part. Ifno role is specified, the web partis

Display to rales: displaved to all roles.

|

Done €& Local intranet | Protected Mode: Off F v HI100% v

Other valuable information can be found in Kentico CMS Deweloper's Guide. References to this
reference guide can be found throughout the tutorials. In addition, going through the particular modules’
chapters can enrich your knowledge and understanding of the system too. So for example if you don't
understand something related to Groups, just open the Module Groups chapter of the guide and see
if you can find the answers.

Wildcard URLs are used throughout the whole website, mainly in the Groups section and on user
profiles. If you are not familiar with the wildcard URLs concept, please read this chapter of Kentico CMS
Developer's Guide.

e Last but not least, Kentico CMS is well-known for its outstanding technical support. So if you get

really stuck, don't hesitate and contact our support team at http://www.kentico.com/Support.aspx.
They are always there to help you.
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3.2 Pre-development tasks
3.2.1 Creating the site

To get us started, we need to create a new website. This can be achieved using the New site wizard.
You can access it both when making new installation and when you already have Kentico CMS
installed.

e When making a new installation, you can choose Continue to the New site wizard in Step 4 of the
Database Setup. After clicking Next, you will be redirected to the first step of the wizard.

r D |
Database Setup - Step 4

SQL Settings Database Starter Site nish

1 Choose starter site

»

Companylcge Corporate Site i
e

—— } This is a web template for a general corporate site. It's used
B = as a showcase of Kentico CMS capabilities and it can be
-y used as a starting site that you modify as needed. lt uses the —

- portal engine and its the recommended choice for developers
" who are new to Kentico CMS.

m

Companyl o Corporate Site ASPX

—— } This is a web template for a general corporate site. It's used
[ g as a showcase of Kentico CMS capabilities and it can be
P -t used as a starting site that you modify as needed. It uses the

- — ASPX page templates that require a higher level of NET
YT knowledge than the portal engine.

@ Next = 3
4

Version: 5.0 Build: 5.0.3688

e Alternatiwely, if you already have Kentico CMS installed, you can access the New site wizard by
clicking the alike named link in Site Manager -> Sites.

232 Kentico
#g% CMS Site Manager Sites

Administration Settings Development Licenses Support

(t_) Sites

E_-ﬂl Mew site wizard [:’:1. Import site or objects [3 Export objects

1. In the first step of the wizard, choose Create a new site using a wizard and click Next.
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Choose default web site

Step 1 If you choose to create a blank site, the wizard will guide you through the process of creating a new site. If
you choose to use a template, you will be able to choose one of the predefined web site templates.

i@ Create a new site using a wizard
0 Use web site template

2. In the second step, enter the following details:

Site display name: My Community Site
e Site code name: MyCommunitySite

e Domain name: localhost

Site culture: English - United States

Click Next to proceed.
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Enter new site settings
Step 2 Enter the display name and code name of the web site. The Domain field must contain the domain that you
will use to access the web site during development (you may change it when the site goes live). The default
culture is the main language of the web site.
Site display name: My Community Site
Site code name: | MyCommunitySite
Domain name:  |localhost
Site culture: English - United States |Z|
3. In Step 3, leave all settings at their default values and click Next.
Objects selection
Step 3 Flease select objects which should be imported.
=) |All objects . | . |-
i @ mport objects (2]
,j@ Web site ) P ) @
¢ [} Documents Please note: The import process may overwrite your existing objects. The existing objects are
€] Administration marked with * and will be overwritten if checked.
| .4 Settings i ) ) )
g 2 Please selectthe object type from the tree if you wish to change the default selection.
| [z)-55 Development Click Next to startthe import of selected abjects.
=-2) Global objects
[+ ¥ Tools Global selection
wﬂ Administration Load default selection  Selectallobjects Select onlynew objects  Deselect all objects
=2 Development E
Import settings
Assign all objects to the imported site (recommended)
Run the site after import
[ Delete incomplete site when import fails
Import files (recommended)
[l Do not import objects where parent object is missing
Import tasks (recommended)
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4. An import log will be displayed. When it finishes, you will be redirected to the following step.

Import progress
Step 4 Objects are being imported.

Importing ‘Roles’ objects

Importing Web site’ objects

Importing "Settings’ objects

Importing "Settings categories’ objects

Objects are being imported " =Preious | cancel [Tl
E_=

5. In Step 5, you can choose from three default master page layouts. Choose the Blank master page,
as we will define the layout later on.
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Select master page
Step 5 The master page defines the layout of the main menu, logo and content placeholders. You can change it at

any ti

Blank master page

L

m
!}ml 4|

me later.

Blank master page

Generic default page template.

Community Site - Master Page

Top logo and left menu

Master page template with logo on the top and menu on the left side.

93

'lle>

6. The sixth step of the wizard allows you to define basic site structure. As we will create the pages
when creating the particular sections, you can skip this step by clicking the Next button.

Def|

ine basic site structure

efine the site map of your new web site. The pages you create will be displayed in the site menu. Every
Ste 6 Define the sit f b site. Th te will be displayed in the sit E
page must have some template specified or it can inherit page template from the parent page.

= = PO
=i = 4
New Delete & Down

Content management

| a Page properties

Page name:

----- & My Community Site

Page template: Blank master page

m Remove template

'lle:-

»

m
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7. If you have reached the seventh step, you have created the site successfully. Click Finish to return
to Site Manager -> Sites.

The web site has been created successfully
Step ? Mow you can view and edit your new web site.

Edit your new web site

Ifthis is your first web site, the default user account is administrator without password.

3.2.2 Assigning the CSS stylesheet

Once you hawe the site created, you can create its CSS stylesheet and assign it to the site. For the
purposes of this guide, you should use the CommunitySite.css, which is the Community Starter site's
original CSS stylesheet. The file can be found in the attached files package that can be found at http://
www. kentico.com/Downloads/Community Guide/Community SiteGuide_files.zip.

1. Go to Site Manager -> Development -> CSS Stylesheets and click the New CSS stylesheet link
at the top of the page.

212 Kentico

'.‘ CMS Site Manager Sites Administration Settings Development Licenses Support

& Development ()' CSS stylesheets
.5l Categaories

@ Countries <l New CSS stylesheet

- ¢f|CSs stylesheets

- cultures

ﬂ Custom tables Actions Display name - Code name

E]] Diocument types f x |3 Corporate Site CorporateSite

Q I TR # 8 |3  Corporate site printer styles  CorporateSitePrinter

<§ Form controls
i Inline controls

2. Enter the following details:
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e Stylesheet display name: My community site
e Stylesheet code name: MyCommunitySite

e Stylesheet text: copy and paste the stylesheet text from the CommunitySite.css file

Leave the Assign to website My Community Site check-box checked and click OK.

232 Kentico

#4% CMS Site Manager

=) Development
& Categories
@ Countries
-4 |CSS stylesheets
B Cultures
--fiifl Custom tables
E]1 Document types
-3 E-mail templates
<.§ Form controls
-.[= Inline controls
B Modules
-] Notifications
[H Page layouts
i Page templates
-.=5 Relationship names
@ System tables
&% Tag groups
- Time zones
3 UI cultures
i3 Web part containers
- ¢% web parts
[@] Web templates
-.[@] widgets
!' Workflows

f—,

Sites Administration Settings Development Licenses Support

<§. New stylesheet

CSS stylesheets » Mew CSS styleshest

Stylesheet display name: My community site
Stylesheet code name:
Stylesheet text:

/*$Clobalé*/
body
{

MyCommunitySite

font-family: Tahoma, Arial, Verdana:;
font-size: 1llpx;
}

body.LTR, body.RTL
i

Switch to CMS Desk

95

User: Global Ad

o

background: #585858 url('../App Themes/CommunitySite/Images/main-bg.gif') repeat-x

top left:
padding: Opx:
margin: Opx;

color: #000000;

assign to web site My Community Site

3. Go to Site Manager -> Sites and choose to Edit (#) your site.

[}
=

Kentico

#1% CMS Site Manager

(t‘) Sites

gt New site wizard

Actions

[;’_']. Impart site or objects

Sites Administration Settings Development Licenses

| Export obiects

Site name -

X el W i M CommunitySite

Support

4. On the General tab, select the new stylesheet in both Site CSS stylesheet and Editor CSS
stylesheet drop-downs and click OK.
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3.2.3

232 Kentico

‘l‘ CMS Site Manager Sites Administration Settings Development Licenses Support

&) Site properties
Sites » My Community Site

General Domain aliases Cultures

Site display name: My Community Site
Site code name: MyCommunitySite
Site domain name: localhast

Default content culture: English - United States

Default visitor culture: | (Automatic)

Site C33 stylesheet: My community site Eﬁ
Editor C35 stylesheet. | My community site Eﬁ

Site description: Sample blank web site

You hawve learned how to create a new CSS stylesheet and assign it to your site.

Creating page templates category

Throughout the process of the website creation, you will create various pages. It is a good practice to
store the pages as page templates so that they can be reused later on at some other part of the
website, without the need to define the page structure again. For you to keep the page templates

organized neatly, it is recommended to create a new page template category where the templates will
be stored.

1. Go to Site Manager -> Development -> Page templates. Select the root of the template
categories tree (Page Templates) and click the New category link. Enter the following details:

e Category display name: My Community Site templates

e Category name: MyCommunitySiteTemplates

e Category image path: path to the image which will be used instead of the default category icon in
the page template selection dialog; the recommended dimensions are 16x16px, while larger images
may cause problems with design of the administration interface

Click OK. Your category is now created and you can sawe all your page templates for this site in it.
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-‘2’- Kent_i.co Switch to CMS Desk  User: Global Administrator v5.0.2688
‘l\ CMS Site Manager Sites Administration Settings Development Licenses Support
=) Development E Page templates
-:@ Categories
‘@ Countries = x @ New category
:.4j CS5 stylesheets = —
i Cultures asialEt Ifj
il custom tables o Category display name: My G ity Site templat
: {1l Document types EES '}” page templates soraiealay v amimunty S0 [empates
- &4 Ad-hoc Category name: MyCommunitySiteTemplates
E Q E-mail templates D=
i..< Form contrals = .:‘]' Articles Category image path:
i -y Blank fi dget: A
. Inline controls @ 3 Flank pages for widgers o]
- {# Modules 'l/ = Fogs —

3.2.4 Defining web part containers

Web part containers are elements of the website which can encapsulate web parts. They consist of a
HTLM code before the web part and a after the web part. Throughout the website, we will use six different
web part containers which we will define in the following example.

1. Go to Site Manager -> Development -> Web part containers and click the New container link
abowe the list.

212 Kentico

'l‘ CMS Site Manager Sites Administration Settings Development Licenses Support
(=) Development i@ Web part containers
.5 Categories =
- Countries  Mew container
¢ css stylesheets
- Cultures
fiill Custom tables Actions Display name ~
- {i) Document types # ® 3  Blackbox
: (3 E-mail templates # |3  Breadcrumbs Box
‘..« Form controls

. [# Inline controls 4/ 83 cContentpadding
% Modules # |3 Divelement
|| Notifications A RE  Graybox

I] Page layouts —
@ page templates # %3  Orange box

EE Relationship names # R I searchbox
[ system tables

--%¥ Tag groups

40 Time zones

: UI cultures

Web part containers H

.- web parts

2. In the New container dialog, enter the following details:

e Display name: Community Site - Blue Box
e Code name: CommunitySite.BlueBox
e Text before web part:

<di v cl ass="bl ueBoxTop" ></di v>
<di v cl ass="bl ueBox" >
<h3 cl ass="bl ueBoxTi t| e">{ %ont ai ner Ti t | e% </ h3>
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e Text after web part:

</ di v>
<di v cl ass="bl ueBoxBot t om' ></ di v>

Click OK.

3. Switch to the Sites tab, click the Add sites button and add My Community Site using the pop-up

dialog. Click OK.

-
& | Select sites —- Webpage Dialog

==

@ Select sites
Site name orits part:

Selectall Deselectall

= Site name

My Community Site

ltems per page: 10 |Z|

ok [ cancel |

http://lecalhost/kenticocms/CMSAdmin €L Local intranet | Protected Mode: Off

=

4. Repeat the same procedure for the following five web part containers:

Display name: Community Site - Blue Box Light
Code name: CommunitySite.BlueBoxLight
Text before web part:

<di v cl ass="boxBl ueLi ght ">
<h3>{%ont ai ner Ti t | €% </ h3>

Text after web part:
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</ di v>

Display name: Community Site - Gray Box
Code name: CommunitySite.GrayBox
Text before web part:

<di v cl ass="grayBoxTop"></di v>
<di v cl ass="grayBox" >
<h3 cl ass="grayBoxTi t| e">{%Cont ai nerTi t| e% </ h3>

Text after web part:

</ di v>
<di v cl ass="grayBoxBotton ></di v>

Display name: Community Site - Orange Box
Code name: CommunitySite.OrangeBox
Text before web part:

<di v cl ass="orangeBoxTop" ></di v>
<di v cl ass="or angeBox" >
<h3 cl ass="or angeBoxTi t| e">{ %Cont ai ner Ti t | e% </ h3>

Text after web part:

</ di v>
<di v cl ass="or angeBoxBot t oni' ></ di v>

Display name: Community Site - Red Box
Code name: CommunitySite.RedBox
Text before web part:

<di v cl ass="redBoxTop"></di v>
<di v cl ass="redBox">
<h3 cl ass="redBoxTi tl e">{%Cont ai ner Ti t | e% </ h3>

Text after web part:

</ di v>
<di v cl ass="redBoxBot t ont' ></ di v>

99
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® Display name: Community Site - Red Box Light
e Code name: CommunitySite.RedBoxLight
Text before web part:

<di v cl ass="boxRedLi ght ">
<h3>{ %Cont ai ner Ti t| e% </ h3>

Text after web part:

</ di v>

You hawe created six new web part containers. These containers can now be used to encapsulate any
web part on the site, using the Web part container property. This property is common to all web parts.

3.25 Uploading images

We will upload some images that we will use later on. You can find the images in the images folder
inside the files package attached to this guide, which can be downloaded at http://www.kentico.com/
Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Please extract the images from the archive
into a separate folder on your local disk before you start with the following steps.

1. Go to CMS Desk, select the root of the content tree and click New.

232 Kentico

‘.‘ CMS Deslc Content My desk
=) =) [ Copy T up

=l S 4 N

Mew |Delete |= Move & Down

Content management

----- f /My Community Site

2. As the document type, choose Folder.
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Switch

232 Kentico
'l‘ C€MS Desk Content My desk Tools

= = = = — —

B B @ opy W Up LR Z E = | /D I
New Delete |= Move Edit Preview Live site List Search |
Content management | View mode | Other |

Administration

4} Down

..... !:_,3 My Community Site My Community Site

=] New document

Please select new document type:

|| Page (menu item)

‘T Blog

%] Link an existing document

3. Enter Files as the Document name and click Save.

Switch to Site Manager

232 Kentico
'l‘ CMS Desk Content My desk Tools

B [x Beew . tw | [ [q 2 | L |
New Delate = Move 4 pown Edit Preview Live site List Search |
| View mode | Other |

Content management

Administration

My Community Site

E Save E‘ Save and create anather Spell check

----- Q_’J My Community Site

Document name: |Files

4. Now you hawve the folder ready in the content tree. Select it and click New. Choose the File

document type.
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Switch
22 Kentico -
'l‘ CMS Desk Content My desk Tools Administration
| x Do T [d] A
New | Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
clb_il My Community Site } Files
-5y Files

=] New document

Please select new document type:

| ] Page (menu item)

i) Folder

£] Link an existing document

5. Browse into the folder with the images, choose one of them, enter some text describing of the image
and click Save.

Switch to Site Manager  Site: My Community Site
232 Kentico " ty Site=]

‘l‘ CMS Desk Content My desk Tools Administration

Ci u ! & |
5 [ Boer (4 [d] o
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
cl!t_’l My Community Site b Files
.75 Files

" Spell check

E Save E‘ Save and create another

Actions Update Name Size
Upload file: .
7R % [=] community header ima.ipg 36 kB
Thi=s is the default header image. -

File description:

6. Repeat the same procedure for the rest of the images in the folder. The result should look as in the
following screenshot.

© 2011 Kentico Software



Part 2 103

232 Kentico
#§% CMS Desk Content | My desk

A 3 [E copy i up
=| x -
Mew Delete |= Move & Down

Content management

clp_’l My Community Site
2.5 Files
- [# button_joinnow
- [8 button_signin
- [= community_header_img
‘.l community_home_img

3.2.6 Creating a sample poll
In this exmple, you will learn how to create a sample poll that you will publish on the Home page later

on. More information about Kentico CMS Polls module can be found in Kentico CMS Deweloper's Guide -
> Module Polls.

1. Go to CMS Desk -> Tools -> Polls and click the New poll link.

-\.ll. Kentlco Switch to Site Manager
“1% CMSDesk Content My desk | Tools Administration

& Toals & Polis
‘..@ Abuse report

BizForms @& New poll
Blogs —
';_-‘i} Booking system
9& Content staging
-fill custom tables
.- E-commerce
--[[g File import
- &4 Forums
& Groups
- I98l Media libraries
[l Message boards
fﬂ Newsletters
- @ Palls
rﬂ Reporting
“.4afl Web analytics

No data found.

2. Enter the following details:

Display name: Continents

Code name: Continents

Title: leave blank

Question: Which continent are you planning to visit during your next trip?

Click OK.
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232 Kentico Switch to Site Manager

71%  CMS Desk Content My desk Tools Administration
BT @ New poll
‘..|@ Abuse report
BizForms Polls » Mew poll
Blogs
P8 Booking system Display name: [Continents

Da Content staging
il custom tables

TR E-commerce
L_ﬁFiIe import Which continent are you planning -
to visgit during yvour next trip?

Code name: |Continents

Title:

&2 Forums

& Groups Question:

Ial Media libraries

Message boards

=1 Newsletters ok |
& Polls

[ﬂ Reporting

“fafl Web analytics

3. The poll appears in the Edit mode, offering you five tabs where settings can be done. On the General
tab, enter the following:

e Message after vote: Thank you for your vote.

Click OK.

-‘!’- Kel'l ti.C'O Switch to Site Manager
'.‘ CMS Deslc Content My desk Tools Administration

= Tools @ Poll properties
R
@ Abuse report
BizForms Polls » Continents
Blogs
4 Booking system
5& Content staging
£l custom tables Display name: Continents
_m E-commerce Code name: Continents
L]‘,? File import Title:
&4 Forums
Which continent are you planning -

&Groups - - .
o . to vi=sit during your next trip?
lyal Media libraries

General Answers Security Sites View

Message boards Question.
£ Newsletters
& Polls =
[E_I Reporting Open from: @Now
= i
sl Web analytics Open to: & nNow

Thank vou for your wvote -

1
H Message after vote:

Allow multiple choices: [7]

—d

4. Switch to the Answers tab and click the New answer link.
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232 Kentico Switch to Site Manager
'.\ €MS Desk Content My desk Tools Administration
@ Tools @ Poll properties

|@ Abuse report

BizForms Polls » Continents

Blogs

¥ Booking system
Da Content staging
il custom tables
TR E-commerce

[{y File import

General Answers Security Sites View

% Reset answers

Mo data found.

lval Media libraries
Message boards
f:ﬁ Newsletters

& Polls

[E_I Reporting

“..faf) web analytics

5. Enter Africa into the Text field and click OK.

232 Kentico Switch to Site Manager
1% CMS Desk Content My desk Tools Administration
TR @ Poll properties
H ™
@ Abuse report

BizForms Polls » Continents

'P& BOOking system General Answers Security Sites View
¥§ Content staging Answers » MNew answer

i custom tables B

TR E-commerce g New answer

{5 File import

&4 Forums Text Amca

& Groups -

Idl Media libraries [ OK |

Message boards
MNewsletters

&|Palls

[h] Reporting

~{afl Web analytics

6. Repeat the procedure so that you have all five continents entered as answers.
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3.2.7

232 Kentico Switch to Site Manager
74%  CMS Desk Content My desk Tools Administration
ChhTELE @ Poll properties

---|@| Abuse report
BizForms Bolls » Continents
Blogs
|2 Booking system
¥ Content staging
-fill custom tables
m E-commerce

General Answers Security Sites View

Tl New answer gy Reset answers

[ File import Actions Text Count | Enabled
g FERE FRT L Aca 0 Yes

&4 Groups _ )

- Igal Media libraries ZRT & America 0 Yes
i-[] Message boards FRT I rsia 0 Yes
{—'B Newsletters R T L Austaia 0 Yes

- @|Polls

... Reporting FRT S Euope 0 Yes

“..faf) Web analytics

Creating the tag groups

Kentico CMS Tags module enables assigning documents with key words for better content-related
navigation and search. These key words are called tags and they are organized in tag groups. There is
one tag group called Content in the default instalation. We will create two additional tag groups called
Blogs and News, so that blog posts and news can be tagged with tags from separate groups.

More information about the Tags module can be found in Kentico CMS Developer's Guide -> Module
Tags.

1. Go to Site Manager -> Development -> Tag groups and click the New tag group (=4) link at the
top of the page.
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=32 Kentico
#g% CMS Site Manager

=)~ Development

. Categories
@ Countries
"¢ css stylesheets
- Cultures
il Custom tables
.l Document types
Q E-mail templates
<% Form controls
Inline controls
(% Modules
Notifications
.[H Page layouts
.--[@ Page templates
.= Relationship names
@ System tables
{3 Tag groups
- Time zones
“ 8 UI cultures
______ Web part containers
.- ¢# web parts
--[@] web templates

Sites Administration Settings Development Licenses

</ Tag groups

Site: | My Community Site [=]

Actions

7R

Name ~

Content

d

2. Enter the following details into the form:

Code name: Blogs

Click OK.

=32 Kentico
#§% CMS Site Manager

=) Development

&l Categories

-4 Countries

.- css stylesheets

@) Cultures

*fill custom tables
.. fiJ) Document types
[ E-mail templates
45 Form controls
[ Inline controls
- Modules
“-i.] Notifications
--[H Page layouts
i Page templates
=5 Relationship names
~f System tables
.<¥|Tag groups
- Time zones
L) UI cultures
Web part containers
-4l Web parts
.-[@] web templates

Display name: Blogs

Description: This is the group of tags used for blog posts.

Sites Administration Settings Development Licenses

< New tag group

Tag groups » Mewtag group

Display name: Blogs
Code name:  Blogs

Descripion:  |This is the group of tags used

for blog posts

{

Support

Support

107
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3.2.8

w

Display name: News
Code name: News

Description: This group contains tags used for news items.

Click OK.

. Repeat the same procedure and create a tag group with the following details:

4. If you go back to the list of tag groups, you should see the Blogs, Content and News tag groups.

=) Development

212 Kentico

#§% CMS Site Manager Sites  Administration

</ Tag groups
-&J Categories

@ Countries Site: | My Community Site
G CSS stylesheets
@ Cultures &3 New tag group

ﬂ Custom tables
cﬂ Document types

Q E-mail templates Actions =~ Name =
45 Form controls 7R Blogs
@ Inline controls /% Conent
(% Modules

7. Notifications 7R News

|] Page layouts

ﬁ Page templates
.= Relationship names
[ system tables
.-+P|Tag groups

- Time zones

: UI cultures

!'Web part containers
- web parts

--[@] web templates

d

Settings Development

[=]

Creating the News notification template

Licenses

Support

There will be the News page on the site, where news will be added by content editors or site
administrators. On the page, users will have the possibility to sign up for receiving notifications about
new news items published on the site. You can find a tutorial on creating the page here.

In this chapter, we will create a notification template. Notification e-mails will be based on this template.
More information about Kentico CMS Notifications module can be found in Kentico CMS Developer's

1. Go to Site Manager -> Notifications and switch to the Templates tab.

Guide -> Module Notifications.

2. From the Sites drop-down list, select My Community Site and click the New template (%) icon.
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=32 Kentico
#¢% CMS Site Manager

=) Development
&l Categories
@ Countries
- qf Css stylesheets
- cultures
[}l custom tables
EI] Document types
- [3) E-mail templates
{.§ Form controls
.-[E Inline controls
- Modules

‘..z [INotifications

--[A page layouts
i Page templates

Sites Administration Settings Development Licenses

4| Notifications
Gateways Templates
site: | My Community Site [+]

5_:‘. MNew template

Mo data found.

3. In the next dialog, enter the following details:

e Display name: News notification
e Code name: NewsNotification

Click OK.

3% Kentico
#i% CMS Site Manager

= Development

-l Categories

@ Countries

G CSS stylesheets

D cultures

“fill Custom tables
£l Document types
--[3) E-mail templates
<.§ Form controls
+[E nline controls
- Modules
| Notifications

--[H Page layouts
i Page templates

4. Switch to the Text tab and define the template’'s text the following way:

Sites Administration Settings Development Licenses

‘L Notifications

Gateways Templates

Templates » Mew template

Display name: MNews notification

Code name: NewsNatification

e Subject: Community Site News

Support

Support

Enter the following template text into both HTML text and Plain text fields:

109

Hel | o,

news item {%otificationcustondata. newstitle%% has been just published on the

Community site. You can see it at {%ocunent!ink%.

You are subscribed for receiving this automatic e-nail
| onger wish to receive these notifications,

notification.
pl ease change your preferences in your

If you no
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user profile at the Community Site.

Click Save. The template is ready to be used.

232 Kentico

#§% CMS Site Manager

=) Development

- Categories
.. @) Countries
2 d CSS stylesheets
- cultures
[} Custom tables
.. f) Document types
f_c] E-mail templates
<.§ Form controls
+[H Inline controls
¢ Modules

.|| Notifications

[B Page layouts
i Page templates

Switch to CMS Desk

Sites Administration Settings Development Licenses Support

¢ Notifications

Gateways Templates
Templates » Mews notification

Text

General

Click here for template macro examples

Gateway: Email gateway

User: Global Administrator v5.0.3688

: . . Subject  |Community Site News
...=8 Relationship names Y
B HTML text: z —
[l System tables ! WJiB I |EE|@
...&# Tag groups Hello, -
@ Time zones news item {#notificationcustomdata.newstitled} has been just publizhed on the Community =ice. You | |
U1 CUltUreS can see it at {%documentlink®}.
Web part containers You are subscribed for receiving this automatic e-mail notification. If you no longer wish to
& Web part receive these notifications, plea=ze change your preferences in your user profile at the Community
S eb parts Site.
..[@] web templates
...[@] widgets
- |o# Workflows E
H
Flain text:

Hello, -

news item {%notificationcustomdata.newstitle%} has been just published on
the Community site. You can see it at {%documentlink%}.

¥You are subscribed for receiving this automatic e-mail notification. If
you no longer wish to receive these notifications, please change your
preferences in your user profile at the Community Site.

3.2.9 Creating asample Media library

In the following example, we will create a sample media library. This media library will be global, which
means that all site users and visitors will be able to see its content on the Media page. We we will
create the Media page later on in this chapter.
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Detailed information about the Media libraries module can be found in Kentico CMS Deweloper's Guide
-> Module Media libraries.

1. Go to CMS Desk -> Tools -> Media libraries and click the New media library link.

232 Kentico
‘l\ C€MS Desk Content My desk Tools Administration

- Tools B Media libraries
HE -
@ Abuse report

[E] BizForms

Wl Blogs

: I% Booking system
DQ Content staging
-fill Custom tables
- TR E-commerce
--[[q File import

.- &4 Forums

& Groups

... Jygl Media libraries
] Message boards
fﬂ MNewsletters

MNew media library

Mo data found.

2. In the following dialog, enter the details listed below:

Display name: My Community Site Media

e Code name: MyCommunitySiteMedia

e Description: enter some text describing the media library
e Teaser image: you can leawve the field blank

Folder name: MyCommunitySiteMedia

Click OK.
-‘:’. Kentico Switel
1% CMSDesk Content My desk | Tools Administration

& Tools New media library

y| Abuse report
. BizForms Media libraries » Mew media library

- Elogs

Pa' R Display name: |My Community Site Media
Ba Content staging
-fill Custom tables
... E-commerce

{fg File import

.. &4 Forums Description:

- Groups

... Jga| Media libraries -
=

] Message boards Teaserimage: | Upload:
£ Newsletters
@ Paolls Folder name:  MyCommunitySiteMedia

B Reporting [ ok |

“4afl Web analytics

Code name:  |MyCommunitySiteMedia

Thi= i= the global media library -
of My Community Site.

3. The media library has been created and you are redirected to the library's editing interface. We will
define the folder structure first.
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Click the New folder button while the root of the library is selected. Enter the name of the new folder
into the Folder name field and click OK.

Repeat the procedure so that you have the following four folders in the root of your library:

e Documents

* Music
* Pictures
e Video
-‘!’- Kel'l thO Switch to Site Manager  Site: My Community Site El

1% CMS Desk Content My desk Tools Administration

&- Tools g Media library properties

|8 Abuse report
g BizForms Media libraries » My Community Site Media
Blogs : |
Lo . Files General Security
?ﬂl Booking system
.. Content stagin = :
; %c rom ¢ blg g [_:,ﬂ New folder D_ New file =] uist [:=] iles [EE] Thumbnails
ustom tables -
... E-commerce o -
[y File import Sosee Glomr §fes | name:
SEI Forums (=) MyCommunitySiteMedia (0) - tles to disol
‘.8 Groups . Documents (0) ere are no files to display.
- lndl Media libraries 75 Music (0) |

5 L) pi = 5

Message boards 4 Pictures (0) £ New folder — Webpage Dialog ﬂ
- f5 Newsletters
@ pols gl New folder
Eﬁ] Reporting
‘..fal) Web analytics

Folder name: Video|
H
htt € Local intranet | Protected Mode: Off

4. Now that we have the folders ready, we can start uploading some files. We will use files from the
media_library_files folder inside the files package attached to this guide. The package can be found

at http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Inside the folder,
you will find four sub-folders with the same names that you defined in the previous step. Each of the
folders contains seweral files. For the purposes of this example, you don't need to upload them all.
Uploading at least one file into each folder will do the job.

There are several ways how you can achieve this. You can find a detailed description of how files can be
uploaded into the media libraries in Kentico CMS Deweloper's Guide -> Module Media libraries ->
Uploading files into media libraries.

Here, we will describe how you can upload files via the administration interface:

Select the target folder from the tree on the left and click the New file icon at the top right corner of the
page. In the pop-up dialog, browse to the folder where your files are stored and click Open.
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3.2.10

Switch to Site Manager  Site: My Community Site User: Global Administrator
=32 Kentico Y ty Sie[=]

‘l‘ CMS Desk Content My desk Tools Administration
&) Tools Media library properties
i Abuse report
: BizForms Media libraries » My Community Site Media

Blogs
¢l Booking system

% gz::s;t;t;i:g (O Newoiger =) ust Tiles [Z2] thumbnails

Files General Security

@ E-commerce
g3 File import Sepskle  Gomy  Htee | yome:
&i Forums =~ MyCommunitySiteMedia (0)
‘.. Groups ‘4@ Documents (0) ‘ There are no files to display.
g i L.y i ' N
Media libraries i M.usm (0) @ Choose File to Upload @
Message boards 5| Pictures (0) P
il Newsletters .15 Video (0) u@v| . <« media_library files » Pictures - |£, | | Search Pictures )
Polls
E] Reporting Organize + New folder =~ I @
.4 Web analytics C 3
7 Favorites Documents library P
Pictures
i Libraries MName ‘ Date modified Type
H /8l Computer = IMO001775 3.4.2009 22:26 JPEG image
: = IM002595 3.4.2009 22:26 JPEG image
9‘ Network = IM002601 3.4.2009 22:26 JPEG image
= IM002628 3.4.2009 22:26 JPEG image
4| i ] 3
File name: IMO001775 ~ | All Files (**) -
Open Iv Cancel

Repeat the same procedure so that you have at least one file in each of the folders. Once finished, the
library is ready to be published on the site.

Creating a Smart search index

Kentico CMS Smart search module enables index-based search through the content of your site. For
this to work, you need to have at least one index created for your site. This index will contain information
about the content of your site and is much faster to be searched than using the standard SQL queries

search approach.

Further information on Kentico CMS Search Engine can be found in Kentico CMS Deweloper's Guide ->
Modules -> Smart search -> Oveniew.

In this example, we will create a new smart search index and configure it so that it can be used on our
site.

1. Make sure that your site is running (in Site Manager -> Sites) and go to Site Manager ->
Administration -> Smart search. Click the New index (&) link.
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Switch
232 Kentico M
‘l‘ CMS Site Manager Sites Administration Settings Development Licenses Support
=)~ Administration Wi Smart search indexes

w[d] Avatars

-1 Bad words
-4 Badges

-2 Banned IPs

.. & E-mail queue Actions Display name - Last rebuild time Index type = Index status
[:I Event log F 8B community site - default  219/2010 35449 PM  Documents  Ready
‘ﬁf FEOLEELIE # B ®  Ccommunitysite-Forums  2/19/2010 25451 P Forums Ready
;i zzr::le o # P Ecommerce site - default Documents Ready

@ Scheduled tasks
.- f]|Smart search
-3 system

E UI personalization
& Users

...y web farm

2. Enter the following details into the New index form:

Display name: My Community Site

Code name: MyCommunitySite

Analyzer type: Standard

Index type: Documents

Assign index to website <your site name>: enabled

Click OK.

232 Kentico
’l‘ CMS Site Manager Sites Administration Settings Development Licenses Support

(=) Administration Wy New search index
L. [H] Avatars

%) Bad words Search indexes » New index
g Badaes

-2 Banned IPs
4!7 E-mail queue

Display name: My Community Site
Code name:  |MyCommunitySite

[ Eventlog

... & permissions Analyzer type: | Standard |Z|
4] Recycle bin Index type: Documents [~]
33 Roles [¥] Assign index to website My community site

() scheduled tasks m-

-73)|Smart search
- M system

3. Now switch to the Index tab and click the Add allowed content ('4) link. Add the following values
into the form:

e Path: /%

Document types: leave the field empty
Including ad-hoc forums: enabled
Including blog comments: enabled
Including message boards: enabled

Click OK. This ensured that the whole content of the site will be indexed.
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232 Kentico

’.‘ CMS Site Manager Sites Administration Settings Development Licenses Support

=)+ Administration Wy Smart search indexes
...[] Avatars
-7 Bad words Smart search indexes » My Community Site
& Badges General | Ind Stes  Cultu
Gﬁ Bal"ll"led IPs Eneral Naex es ultures
1!7 E-mail queue ltemn list » Mew allowed item
[ Event log
.../ Permissions e ——
Lo . Path: /% Select
-] Recycle bin N
-84 Roles Documenttypes: [ select [ Clear ]
@ Scheduled tasks Leave the field empty if you wish to choose all document types.
-] Smart search Including ad-hoc forums:
System Including blog comments:
E UL personalization Including message boards:
ﬂ Users
89 web farm ok |

4. Now switch to the Cultures tab and click the Add cultures button. Select the only available culture -
English - United States and click OK.

Wy Smart search indexes

Smart search indexes » My Community Site

General Index Sites Cultures

The following culture versions & | Select cultures -- Webpage Dialog ﬂ

Mo cultures selected @ Select cultures

Add cult
i — site: | My community site [=]

Culture name or its part:

Selectall Deselectall

[Tl | Culture name

English - United States

ltems per page: | 10 E

o[ cancel |

http://lecalhost/KenticoCMS_0219/CMS4 e'l. Local intranet | Protected Mode: Off

5. Finally, go back to the General tab and click the Rebuild () link at the top. This needs to be done
only for the first time. Any further changes made to the site will be indexed automatically.
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3.3

Creating the Master page

As we hawe the site created and the pre-development tasks carried out, we can start defining the master
page. The master page is represented by the root of the content tree. It is the page from which all other
pages inherit the default content, such as the main menu, header image, etc. Like this, you can awoid
laborious adding and setting of these elements for all pages. Instead, you only use them on the master
page and all other pages will inherit it.

In Step 5 of the New site wizard, we chose to use the Blank master page page template. This is the
most simple master page with two web part zones. As we want the master page to be a bit more
complex, we will have to modify its layout.

Further information on master pages can be found in chapters The master page concept and Editing the
master page of Kentico CMS Developer's Guide.

1. The master page uses the Blank master page page template. If you made any changes to the page
now, the changes would be reflected on the page template too so that the original page template
definition would be overwritten and could not be reused anymore.

To prevent this, you need to save the page as a new page template. We will stick to this practice
throughout the whole guide.

Go to CMS Desk -> Edit, select the master page from the content tree and switch to the Properties ->
Template tab. Click the Save as new template link.

Switch to Site Manager  Site:| My Community Site User: Global
32 Kentico v ty sie[=]
‘l‘ CMS Desk Content My desk Tools Administration
S & Boer #uw 4 [ [ E F
New Delete = Move & Down || Edit Preview Livesite Lt | Search |
Content management | View mode Other
‘Z."!‘_;'] My Community Site Page Design Form Master page Properties
&) Files General
E Save
URLs
Template
Metadata Template
Categories Blank master page ﬁ
Menu .
=
="
ok [ =1 Save as new template ]
Versions x Clear
Related docs -
A/ Clone template as ad-hoc
Linked docs =f
Security E Edit template properties
Attachments

2. In the pop-up window, enter the following details:

Template display name: My Community Site - Master Page
Template code name: MyCommunitySite.MasterPage
Template category: My Community Site templates
Template description: some text describing the template

Click OK.
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' ™
& | Page template - Save as new -- Webpage Dialog ﬁ

'\_:_IZ Save as new page template

Template display name: My Community Site - Master Page
Template code name:  |MyCommunitySite_MasterPage
Template category: My Community Site templates |Z|

Thi=z is the master page of My -
Community Site.

Template description:

httpe//localk Q.. Local intranet | Protected Mode: Off

" 4

3. Now we can start making modifications to the page. First, we will re-define the page layout so that we
get more web part zones on the page. Switch to the Master page tab and replace the original layout in
the main text area (within the <body> tags) with the following piece of code.

Click Save to save the changes.

<l-- Top info -->
<di v cl ass="zoneTopl nf 0" >
<ccl: CvBWbPar t Zone | D="zoneTopl nfo" runat="server" />
</ di v>
<di v cl ass="mai nDi v">
<di v cl ass="zoneTopMenber shi p">
<ccl: CvBWebPar t Zone | D="zoneTopMenber shi p* runat="server" />
</ di v>
<di v cl ass="zoneTop" >
<ccl: CvBWbPar t Zone | D="zoneTopl mage" runat="server" />
</ di v>
<di v cl ass="zoneTopMenu">
<ccl: CVB\WbPar t Zone | D="zoneTopMenu" runat="server" />
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>
<di v cl ass="zoneMi n">
<ccl: CVB\WebPart Zone | D="zoneContent" runat="server" />
</ di v>
<di v cl ass="zoneBott ont' >
<ccl: CvBWbPar t Zone | D="zoneBottoni runat="server" />
</ di v>
</ di v>

4. If you switch to the Design tab now, you should see that the master page has been populated with
several web part zones. The layout is now ready and we can start populating the page with web parts.
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Page | Design | Form Master page Properties Display web part content \E

= [ - page template: My Community Site - Master Page .&'

= zoneTopInfo *

| ¥ zoneTopMembership *|
dr

+ zoneTopImage

= zoneTopMenu

v zoneContent o
v [ |pageplaceholder {13
|V zoneBottom +|I

5. Let's start from the top where the logon bar with links to CMS Desk and Site Manager is located.

Click the Add web part (4) icon of zoneTopInfo. In the pop-up window, choose the Text -> Static
text web part and click OK.

In the web part properties window, you only need to set the value of the Text property. Use the following
code for the value:
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<div style="border: 1px solid #cecfce; background: #f 7f 3ef ; col or: #555555; f ont - wei ght
: bol d; paddi ng: 3px; f ont - si ze: 10px; t ext - al i gn: center" >

Sign in to <a href="~/ QvBPages/ | ogon. aspx?Ret ur nUr | =~/ cnsdesk/ def aul t . aspx&anp;
user nane=adm ni strator">CV5 Desk</a>. Sign in to <a href="~/ CVBPages/ | ogon. aspx?
Ret ur nUr | =~/ cnrssi t emanager / def aul t . aspx&anp; user nanme=adm ni strator">CVS Site
Manager </ a>. The default account is adm nistrator with bl ank password.

</ di v>

Leawve the rest of the properties at their default values and click OK. You should see the logon bar appear
in the web part zone.

T zoneTopInfo *

= ctatictext @ Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is inistrator with blank

6. Let's move on to zoneTopMemebership. This web part zone will contain the sign in/out link, link to
the current user's private messaging inbox, link to the current user's profile editing page and information
about the current user with link to their public profile.

Click the Add web part (4) icon, choose the Membership -> Sign out button web part and click OK.
Set the following properties of the web part, leave the rest at the default values:

Show as link: enabled

Button text for sign out: Sign out

Show only when authenticated: disabled
Sign in page path: /Logon

Return page path: /Home

Content before: <div class="signOut">
Content after: </div>

Click OK.

Click the Add web part (4) icon again, choose the Messaging -> Messaging info panel web part
and click OK. Set the following properties of the web part, leave the rest at the default values:

Display to roles: _authenticated_

Inbox link URL: ~/Members/Management/Messages.aspx

Show outbox: disabled

Show new message: disabled

Content before: <div class="messagesPanel">

Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the
string begins with a blank space)

Click OK.

Click the Add web part (4) icon again, this time, choose the Text -> Static HTML web part and click
OK. Set the following properties of the web part, leave the rest at their default values:

e Display to roles: _authenticated_

e Content before: <div class="myAccountinfo">

e Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the
string begins with a blank space)

e Text: place the cursor into the text area, click the Source (=) icon on the WYSIWYG editor toolbar
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and replace the original HTML code with the following code:

<a title="My profile" href="/KenticoCV5 5.5/ Menber s/ Managenent . aspx" >Edit ny
profil e</a>

You will also need to replace the KenticoCMS_5.5 string with the name of the virtual directory where
your Kentico CMS project is located.

Click OK.

Click the Add web part (4) icon again and finally choose the Membership -> Current user web part.
Click OK. Set the following properties of the web part, leave the rest at their default values:

Authenticated URL link: ~/Members/{%CurrentUser.UserName|(encode)true%}.aspx

User text CSS class: userName

Content before: <div class="currentUser">

Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the
string begins with a blank space)

Click OK.

7. Next on is the zoneToplmage web part zone, where the header image should be placed. Click the
Add web part (4) icon of this web part zone and choose the Text -> Editable image web part. Set its
following properties, the rest can be left at their default values:

e Image width: 960
e Image height: 148
e Alternate text: Community Site

Click OK.

Now switch to the Page tab. The added web part is represented here only by the two link buttons as in
the screenshot below. Click the Select button of the added web part.

7. In the pop-up window, select the previously uploaded community_header_img.jpg and click the
Select button.
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- N
|| Insert - Webpage Dialog [
Selectimage

Attachments. Content Media libraries Web

=
g newrorcer [ g Newfie List Tiles Thumbnails (2]
Site: | My Community Site E General
6 My Community Site URL:  |/kenticocms/Files/community_header_img aspx [~}
5151 Files width: 960
L i Height: 148 -
bt s Community

Starter site

*. =/ community_header_img
“ k= community_home_img

< . ] v

s

http://localhost/kenticocms/CMSFermControls/Selectors/InsertimageOrMedia/Default. aspxfoutput=url&amp; content=img&amp;documentid=407&am ?'l. Local intranet | Protected Mode: Off
S

8. The header image is now at its place. Click Save to save the master page.

Page Desigi Master page Properties i

n Form
Spell check

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is admini:

with blank p

Community

Starter site

9. Now we need to populate the zoneTopMenu web part zone where the search box and the main
menu will reside. Click the Add web part (%) icon of this web part zone and choose the Full-text
search -> Smart search box web part. Set the following properties of the web part, the rest can be left
at their default values:

e Disable view state: enabled
e Search button text: Search
e Search button CSS class: buttonSearch
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e Search textbox CSS class: inputSearch
e Search results page URL: ~/Search.aspx
e Show search label: disabled

Click OK.

10. Let's add the main menu now. Click the Add web part (%) icon of the zoneTopMenu web part
zone again and choose the Navigation -> CSS list menu web part. Set the following properties of the
web part, the rest can be left at their default values:

e Path: /%

e Document types: CMS.Menultem;CMS.Blog
e Maximum nesting level: 1

e Render CSS classes: enabled

11. The zoneContent web part zone is where content of all the pages will be loaded. To achiewe this
behavior, you need to have the Page placeholder web part in the web part zone. As you can see, the
web part has been added to the web part zone automatically, so you can go on to zoneBottom.

12. Finally, we will add the Kentico logo into the zoneBottom web part zone. Click the Add web part
(4F) icon and choose the General -> Powered by Kentico web part. Replace the value of the Text
property with the following code:

<a href="http://ww. kentico.com' title="Kentico CVS for ASP. NET - the WEB 2.0
Cont ent Managenent System for . NET devel opers"><ing border="0" src="~/ App_Themes/
Communi tySi t e/ | mages/ Power ed_by_kentico_cns. gif" alt="This website uses Kentico
CVS, the content managenent system for ASP. NET devel opers." /></a>

Click OK.

13. And that's us finished with the master page. If you switch to the Live site mode now, you should
see the page appear as in the screenshot below. The main menu is not visible yet as there are no pages
defined. The rest of the page is already at its required appearance. Content of all site's pages will be
loaded into the main white zone where the Page placeholder web part resides.
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Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is

with blank p

Current user: Global Administrator (administrator) | Edit mv profile | Inbox | Sian out

Community

Starter site
ES

!
il

e §

| | Search

Vo o
e:s- Kentico

3.4 Creating the Search page

In the previous chapter, you have defined the master page. In the ninth step, you placed the Smart
search box web part next to the main menu and set its Search results page URL property to ~/
Search.aspx. This is where the user will be redirected after submitting the search request and where the
search results will be displayed. On this page, users will also be able to perform full-text search with
extended options using the Smart search dialog with results web part.

Further information on Kentico CMS Search Engine can be found in Kentico CMS Deweloper's Guide ->
Modules -> Smart search -> Oveniew.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.
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Switch
22 Kentico e
'l\ CMS Desk Content My desk Toals Administration
C U a
)G B Tu [d P
New | Delete | = Move & pown | Edit Preview Live site List | Search |
Content management | View mode | other |
= /My Community Site My Community Site
)& Files

3 New document

Please select new document type:

I |1 Page (menu item) ]

') Blog

) Folder

%] Link an existing document

2. Choose to Create a blank page using the Simple layout. For Page name, enter Search and click

Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.2688 Sign out
22 Kentico v ty Stel=]
#4% CMS Desk Content | Mydesk  Tooks  Administration
> 2 C u 3 3
S G o e Q@ @ 5L o
New Delete = Move & pown Edit Preview Live site st || search |
Content management | View mode Il other |
=
=-§My Community Site My Community Site
S
()<< Files
E Save E‘ Save and create another

Page name: Search

1 Usepagetemplate  Inheritfrom parentpage @ Create a blank page

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells Grid 3x2 cells (CS5) Simple

m

Three columns Three columns (CSS) Top row, three columns, Top row, two columns, Two columns
bottom row bottom row

12

Simple

Simple layout with one web part zone.

Copy this layout to my page template

3. Switch to the Properties -> Template tab and click the Edit template properties link.
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Switch to Site Manager  Site:| My Community Site[=] User: Global

22 Kentico

1% CMS Desk Content My desk Tools Administration
— — = i — —_—
B [ Bew Tw | [Z [Q @ B | L |
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
d'!"_‘;’ My Community Site Page Design Form Properties
‘ﬂfﬂ Eiles General
[ ]|search s E Save
s
Template
Metadata Template
Categories Ad-hoc: Search Select
Menu o
Workflow = Save as new template...
Versions € Inherit template
Related docs
Edit template properties
Linked docs [ ﬁ ]
Security
Attachments Inherit content
@ Use page template settings
) Da natinherit any content
H () Selectinherited levels

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
layout with the following code:

<di v cl ass="subcontent D v">
<di v cl ass="zoneCent er Hone" >
<ccl: CvBWbPart Zone | D="zoneCenter" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>

Click Save.
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' ™
& | Page Templates -- Webpage Dialog g

Page template properties @

Templates » Ad-hoc: Search

General Layout Web parts Header Documents

E Save — Checkouttofile

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplatelLayouts\8062ec48-1616-43a9-
a401-1b1a02666310.ascx to edit the Ryout externally.

() Use shared layout
Grid 2x2 cells

@ Use custom layout
<div clasa="subcontentDiv"> *
<div class="zoneCenterHome">
<ccl:CMSWebPartZone ID="zonelenter"™ runat="server" />
</div>
<div clazs="clear"»snbapr</divs
<Sdive

http://lecalhost/kenticocms/CM5Medules/PortalEngine/Ul/Pz el'. Local intranet | Protected Mode: Off

5. Switch to the Design tab. You should see one web part zone named zoneCenter on the page, just
as you defined by the layout above. Let's add some heading text first. Click the Add web part () icon
of this web part zone and choose the Text -> Static text web part. In the web part properties window,
set the following values. The rest of the properties can be left at the default values:

e Text: <hl class="header">Search results</h1>

Click OK.

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Search . : . | | | search |
|V /5earch - page template: ad-hoc _—é|
= zoneCenter +

v statictext {0 ults

6. Displaying search results and the search function itself will be achieved using the Smart search
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dialog with results web part. Click the Add web part (4F) icon again and choose the Full-text
search -> Smart search dialog with results web part. In the web part properties window, enter the
following values. The rest of the properties can be left at their default values:

e Indexes: My Community Site (created here)
e Paging mode: Postback

e Web part container: Content padding

e Content after: <br/>

Click OK.

From this moment on, if you switch to the Live site, the page should be fully functional. Try searching
both using the Search box next to the main menu and the Smart search dialog with results web
part. Use e.g. community as the keyword, since this word is included in two previously uploaded images'
names and the master page's name. You will get the results as in the following screenshot.

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Search | || search

Search results

search for:  community

Search mode: |Any word El

community header imgq

e hitp:/flocalhost kenticocms Files/community_header_img.aspx 2/16/2010 3:08:16 PM

community home img
e hittp:/flocalhost kenticocms Files/community_home_img.aspx 2/16/2010 3:09:34 PM

L

mmm=— http:/flocalhost/kenticocms /default.aspx 1/1/0001 12:00:00 AM

7. We don't want the Search page to be displayed in the main menu. To prevent this, select the page in
CMS Desk and switch to the Properties -> Menu tab. Disable the Show in navigation check-box and
click Save.
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Switch to Site Manager

232 Kentico
1% CMS Desk Content My desk Tools Administration
= = = i — —
2 Poopy Hup 2 [ = [ L |
New Delete |=»Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other |
Iﬂ'!’th;'! My Community Site Page Design Form Properties
”:‘J L_j' Hes h General
] [ Seard Save
URLs E
Template
Metadata Basic properties
Categories IMenu caption:
Menu Show in navigation
Workflow Show in sitemap:
Versions

Site: | My Community Site[«| User: Global

8. Finally, we will save the page as a page template so that it can be reused in the future. This is a good
practice to awvoid repeating laborious task. Switch to the Edit mode and go to the Properties ->

Template tab. Click the Save as new template link and enter the following details:

Template display name: My Community Site - Search page
Template code name: MyCommunitySite.SearchPage
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. The page is now saved as a new page template and can be reused when creating new pages
with similar layout or content.

Switch to Site Manager

=32 Keatico
"‘ CMS Desk Content My desk Tools Administration
B EE A L 4 [ =2 1 A~
New Delete = Move & pown | Edit  Preview Livesite  List | Search ‘
Content management | View mode | Other |
(24 My Community Site Page  Design  Form | Properties
‘ﬂﬁ Files General
“..[[search Save
= URLs E
Template
Metadata Template
Categories My Community Site - Search page ﬁ
Menu - i o N
/ AUe A5 Rew fempiate | Page template - Save as new -- Webpage Dialog ﬂ
Workflow B
Versions @ \nherit template 4 Save as new page template
Related docs .
43/ Clone template as ad-hog
Linked docs < Template display name: My Community Site - Search page
Seakiy E Edittemplate properties Template code name:  MyCommunitySite.SearchPage
Attachments
me Template category Iy Community Site templates [=]
This is the Search page of My -

Site: My Community Site E| User: Global Administrator v5.0.3688

Inherit content
@ Use page template settings

) Do notinherit any content
() Selectinherited levels

Template description

Community Site.

http://localk € Local intranet | Protected Mode: Off
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3.5 Creating the Logon page

On the Master page, we placed the Sign out button web part and set its Sign in page path property
to /Logon. This is where the user will be redirected in order to sign in. This can also happen in other
cases such as when a user tries to access a section which is available only to authorized users.

The page will provide the sing-in functionality via the Logon form web part, as well as the possibility to
register for anonymous site visitors, which will be achieved using the Custom registration form web
part.

Information about the Custom registration form and how you can modify the appearance of the form can
be found in this chapter.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

Switch ¢
232 Kentico Switch:
#1% CMS Desk Content My desk Toolz Administration
Ci U e r3
S ) B B @ (4  [d P
New | Delete = Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | COther
(I My Community Site My Community Site
. Files 4
T = New document
‘] Search —

Please select new document type:

[ [ Page (menu item) ]

‘¥ Blog

i Folder

#] Link an existing document

2. Choose to Create a blank page using the Simple layout. For Page name, enter Logon page and
click Save.
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Kentico
CMS Desk Content
‘* D Copy T up
New Delete bMove & Doy

Content management

Switch to Site Manager

Mydesk  Tools  Administration
wn | Edit Preview Live site st || search |
] View mode Gther

n:/'ﬁ") My Community Site
(-G Files
|1 Search

My Community Site
E Save E‘ Save and create another

Page name: Logon page

(") Use page template ) Inheritfrom parent page @ Create a blank page

Site:| My Community Site[+| User: Global Administrater v5.0.3628

Sign out

e

Layout name:

Grid 2x2 cells

Three columns

12

Simple

Grid 2x2 cells (CSS) Grid 3x2 cells

Three columns (CSS)

Top row, three columns,
bottom row

Simple layout with one web part zone.

Gopy this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

Simple

Two columns

(]

3. Switch to the Properties -> Template tab and click the Edit template properties link.

Switch to Site Manager

3% Kentico
#1% CMS Desk Content My desk Tools Administration
) [y D Tw Q@ @ B2 | L
New Delete |=Move & pown | Edit Preview Live site List | Search |
Content management | View mode COther
=] !;_’J My Community Site Page Design Form Properties
'ﬂL‘)' flles General
- |/Logon page E Save
= URLs
|| Search
Template
Metadata Template
Categories Ad-hoc: Logon page
Menu _
]
plate...
Vi = Save as new template
Versions Q Inherit template
Related docs
Edit template properies
Linked docs [ E ]
Security
Attachments Inherit content
@ Use page template settings
) Do notinherit any content
ﬂ © Selectinherited levels

Site: | My Community Site[=] User: Global

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original

layout with the following code:
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<l-- Container -->
<di v cl ass="| ogonReg" >
<l-- Left zone -->

<di v class="zoneLeft" style="wi dth: 50% float: left;">
<div style="wi dth: 270px; margin: 30px Opx 10px 90px; ">
<ccl: CvBWbPart Zone | D="zonelLeft" runat="server" />
</ di v>
</ di v>
<l-- Right zone -->
<di v class="zoneR ght" style="wi dth: 50% float: left;">
<di v style="wi dth: 280px; margin: 30px auto;">
<ccl: CvBWbPar t Zone | D="zoneRi ght" runat="server" />

</ di v>
</ di v>
</ di v>
Click Save.
( & | Page Templates -- Webpage Dialog [é]w
:J’ Page template properties @

Templates » Ad-hoc Logon page

General Layout Web parts Header Documents

—="1

E Save ff—jl Check outto file
Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplatelLayouts\edc61a27-c677-477a-
8d71-20949944798d.ascx to edit the kyout externally.
) Use shared layout
Grid 2x2 cells
@ Use custom layout
<!-- Container --> -
<div class="logonReg">

<!-- Left zone --»

<div class="zoneleft™ atyle="width: 50%; float: left;">
<div style="width: 270px; margin: 30px Opx 10px 90px:">
<ccl:CMSWebPartZone ID="zoneleft"™ runat="server" />
<fdivs
< fdive
<!-- Right zZone -->
<div class="zoneRight™ style="width: 50%; float: left:">
<div style="width: 280px; margin: 30px auto;">
<ccl:CMSWebPartZone ID="zoneRight™ runat="server™ />
</dive
</divy
< /divy

http://localhost/kenticocms/CMSModules/PortalEngine/Ul/Page €i Local intranet | Protected Mode: Off

5. Switch to the Design tab. You should see two web part zones on the page - zoneLeft and
zoneRight - just as you defined by the layout code above. The left web part zone will host the logon
form, the registration form will be placed in the right one. Click the Add web part (4#) icon of the
zoneleft web part zone and choose the Membership -> Logon form web part. Set the following
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properties of the web part, the rest can be left at their default values:

Default target URL: ~/Home.aspx

Web part container: Community Site - Blue Box Light
Web part container title: Sign in

Content before: <div style="min-height: 160px;height:auto">
Content after: </div>

Click OK.

6. User registration will be achieved using the Custom registration form web part. This web part has no
default appearance - the way it will look like is defined by an alternative form of the cms.user system
table. We will use the pre-defined Registration form alternative form. However, you can customize the
alternative form according to your needs, as described here, or even create your own form a similar way.

First, click the Add web part (%) icon of the zoneRight web part zone and choose the Membership -
> Custom registration form web part. Set the following properties of the web part, all other properties
can be left at their default values:

e Alternative form: cms.user.RegistrationForm

Redirect to URL: ~/Members/{%CMSContext.CurrentUser.UserName%}.aspx

e Registration error message: There was an error during registration. Please see details below.
e E-mail confirmation page: ~/Special-pages/Registration-approval.aspx

e Web part container: Community Site - Blue Box Light

e Web part container title: Join the community

Click OK.

7. If you switch to the Live site mode, you should see the following appearance of the page.
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Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Logon page | | | | Search
Sign in Join the community
User name: User name:
Password: First name:
[ElRemember me Last name:
Email:
Log on
Password:

Forgotten password
Confirm password:

Gender: O Male ) Female

3:3 Kentico

8. Switch back to the Edit mode and go to the Properties -> URLSs tab. Enter the following details:

e Document alias: Logon
e Document URL path: /Join

Click Save.
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232 Kentico

Switch to Site Manager  Site: | My Community

#g% CMS Desk Content My desk Tools Administration
Ci U e -
5 [z Boer Ww 4 [d F
New Delete = Mave & pown | Edit Preview Live site List | Search |
Content management | View mode | Other

cltu_’l My Community Site
(#)-59) Files
I_] Logon page
‘.| ] search

Page Design Form Properties

General
URLs
Template
Metadata
Categories
Menu
Workflow
Wersions
Related docs
Linked docs
Security
Attachments

Path

[ 52

The changes were saved.

Document alias: Logon
Document URL path: |fJgin

Use custom URL path

Extended properties
URL extensions:

[[Tuse custom URL extensions

Track campaign:

9. We don't want the Logon page to be displayed in the menu. Go to the Properties -> Menu tab and

disable the Show in navigation check-box. Click Save.

Switch to Site Manager
23 Kentico
‘l‘ CMS Desk Content My desk Tools Administration
2 B Bor  dw (4 [d ~r
New Delete |= Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other |
‘Zl'{‘_;'l My Community Site Page Design Form Properties
General
E Save
Lo URLs
|| Search
Template
Metadata Basic properties
Categories Menu caption:
Menu Show in navigation'@
Workflow Show in sitemap:
Versions

Site:| My Community SiteEl User: Global

10. Finally, we will save the page as a page template for further re-usability. Go to the Properties ->
Template tab and click the Save as new template link. Enter the following details:

Click OK.

Template display name: My Community Site - Logon Page
e Template code name: MyCommunitySite.LogonPage
Template category: My Community Site templates

Template description: some text describing the page template

© 2011 Kentico Software



Part 2 135

Switch to Site Manager

Site: | My Community Site[=| User: Global Administrator v5.0 3688

age Select

232 Kentico
#4%  CMS Desk Content | Mydesk Tooks  Administration
= c U e -1
B [x Beor #uw (4 [d = »r
New Delete =¢Move & pown ‘ Edit Preview Live site List | Search
Content management | View mode | Other
12 My Community Site Page  Design  Form | Propertiss
o @ files General
| |/Logon page E Save
HE URLs
i | Search
Template
Metadata Template
Categories My Community Site - Logon P
Menu
Voins : ; ave as new template
Versions *ﬁ Inherit template
Related docs .
kel :}v‘ Clone template as ad-hoc
Security [ Edittemolste properties
Attachments

3.6

Inherit content
@ Use page template settings

) Do notinherit any content
) Selectinherited levels

Creating the Home page

|

-
& | Page template - Save as new -- Webpage Dialog

:j Save as new page template

Template display name: My Community Site - Logon page
Template code name:  MyCommunitySite LogonPage
Template category: My Community Site templates

This is the Logon page of My -
Community Site.

Template description

http://localk €& Local intranet | Protected Mode: Off
5

In this chapter, you will see how to create the Home page. This is the initial landing page - the page that
the site visitors will see at first when they enter the URL of your site into the browser. It is important to
set the alias path of this page in Site Manager -> Settings -> Web site -> Default alias path, as

described here.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)

document type.

Switch
22 Kentico e
‘l‘ CMS Desk Content My desk Tools Administration
— — = 0 — —
D) Bowr *w [ L @ B | AL
New |Delete |=» Move & Down | Edit Preview Live site List | Search |
Content management | View mode Other
& /My Community Site My Community Site

mfj‘ Files
a Logon page
‘[ ] search

_ New document

Please select new document type:

[ ] Page (menu item)

') Blog

) Folder

%] Link an existing document

© 2011 Kentico Software



136 Kentico CMS 5.5 R2 Community Site Guide

2. Choose to Create a blank page using the Simple layout. For Page name, enter Home and click

.‘24- Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out
% CMS Desk Content | Mydesk  Tools  Administration
2 X [5H Copy i up 4 @ @ E] o) @
New Delete [=bMove & pown [ Edit Preview Live site st || search |
Content management | View mode |l other
n:/'ﬁ") My Community Site My Community Site
- &
()5 Files
B Logon page [ S2ve.and create anotner Spell check
| ] Search

Page name: Home

(") Use page template ) Inheritfrom parent page @ Create a blank page

Layout name:

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells Grid 3x2 cells (CSS) Simple

(]

Three columns Three columns (CSS) Top row, three columns, Top row, two columns, Two columns
bottom row bottom row W

12
Simple

Simple layout with one web part zone.

Gopy this layout to my page template

3. Switch to the Properties -> Template tab and click the Edit template properties link.

Switch to Site Manager  Site: My Community Site User: Global
=34 Kentico v ty Site[=]
’.\ CMS Desk Content My desk Tools Administration
- Y i u
2 [ Boer  #w 2 [d [e HE ~r
New Delete |=Move & pown | Edit Preview  Live site List | Search |
Content management | View mode | COther
= !;_’J My Community Site Page Design Form Properties
'ﬂL‘)' fes General
- |/Home E Save
~ URLs
1] Logon page
L[] search Template
Metadata Template
Categories Ad-hoc: Home E
Menu

Save as new template...

Warkflow =

Versions Q Inherit template

Related docs

s [ [H eattempiate pro emes]
Security

Attachments Inherit content

@ Use page template settings
) Do notinherit any content
) Selectinherited levels

T,

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
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layout with the following code:

Click Save.
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' ™
& | Page Templates -- Webpage Dialog ﬁ

%) Page template properties (2]
Templates » Ad-hoc: Home

General Layout Web parts Header Documents
E Save El Check out to file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\fdch91eb-ee8d-4486-
acac-156414878297.ascx to edit the ayout externaly.

) Use shared layout

Grid 2x¢2 cells

@ Use custom layout

<div class="subcontentDiv">
<div class="zoneCenterHomePage">
<div class="centerlefit">
<ccl:CMSWebPartZone ID="zoneCenterLeft" runat="server" />

»

< /dive
<div class="centerRight™>
<ccl:CMSWebPartZone ID="zoneCenterRight™ runat="server" />
< fdive
<div class="clear">snbsp;</div>

m

<div class="centerHome">
<div claga="left">
<ccl:CMSWebPartZone ID="zoneCenterBottomleft™ runat="server"™ />
</div>r
<div clasa="right">
<ccl:CMSWebPartZone ID="zoneCenterBottomRight™ runat="server" />
</divr
<div class="clear">snbap;</div>

</dive

http//localhost/kenticocms/CMSModules/PortalEngine/UlL/Pag Q.. Local intranet | Protected Made: Off

5. Switch to the Design tab. You should see an empty page with five web part zones. Let's start with
zoneRight, where the right side column with various info boxes will be placed. Click the Add web part (
1) icon of the zoneRight web part zone and choose the Membership -> Logon miniform web part.
Set the following properties of the web part, leave the rest of them as they are:

Display to roles: _notauthenticated

e Logon failure text: Error logging in.

Web part container: Community Site - Red Box
Web part container title: Sign in

Click OK. The next web part to add is the handy Shortcuts web part, displaying shortcuts to various
actions and sections depending on the current context. Click the Add web part (4¥) icon again, choose
the Community -> Shortcuts web part and click OK. In the web part properties window, set the
following properties:

e Display Join/Leave the group link: disabled
e Display Friendship links: disabled

e Display Add to contact list link: disabled

e Display Add to ignore list link: disabled

e Display manage group link: disabled

e Display Sign in link: disabled

e My messages path: /Members/Management/Messages
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My friends path: /Members/Management/Friends

My invitations path: /Members/Management/Invitations
e Sign out path: /Home

Web part container: Community Site - Red Box

Web part container title: Shortcuts

Click OK. Let's go on with the scrolling news. This will be the Scrolling text web part set up so that it
displays news from the News section. The News section will be created later on in this guide. Click the
Add web part (4F) icon again, choose the Listings and viewers -> Scrolling text web part and click
OK. In the web part properties window, set the following properties:

e Path: /News/%

e Document types: CMS.News

e ORDER BY expression: NewsReleaseDate DESC
e Select top Ndocuments: 5

e Transformation: CMS.News.Preview

e Cache dependencies: nodes|{%currentsite.sitename|(tolower)%}/cms.news|all
e Width (px): 150

e Height (px): 150

e Script stop time (milliseconds):4000

e Web part container: Community Site - Blue Box
e Web part container title: Latest News

Leave the rest of the properties at their default values and click OK.

So now we have a web part displaying the latest five news items. Let's have a similar info box displaying
the latest groups. Again, the Groups section is not created yet, but we will get to it later in this guide.
Click the Add web part (%) icon again, choose the Community -> Groups viewer web part and click
OK. In the web part properties window, set the following properties:

e Disable view state: enabled

e Transformation name: Community. Transformations.GroupsPreviewList

e Show filter: disabled

e ORDER BY condition: GroupCreatedWhen DESC

e No record found text: There are currently no groups.

e Web part container: Community Site - Gray Box

e Web part container title: Latest Groups

e Content after: <div class="clear"></div> <div><a href="~/Groups.aspx">View all</a></div>

Leave the rest of the properties at their default values and click OK.

One more info box to go. This time, it will be displaying three latest registered site users. Click the Add
web part (4F) icon again, choose the Membership -> Users viewer web part and click OK. In the web
part properties window, set the following properties:

e Disable view state: enabled

e Transformation name: Community. Transformations.MembersPreviewList

e No record found text: There are currently no members.

e Show filter: disabled

e ORDER BY condition: UserCreated DESC

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatarlD,UserCreated,
UserName,AvatarGuid

e Use default cache dependencies: enabled
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e Web part container: Community Site - Gray Box
e Web part container title: Latest Members
e Content after: <div class="clear"></div><div><a href="~/Members.aspx">View all</a></div>

Leave the rest of the properties at their default values and click OK.

That's us finished with the info boxes in this web part zone. However, we will place the sample poll
created in this chapter to the bottom of the web part zone. Click the Add web part () icon for the last
time, choose the Polls -> Poll web part and click OK. In the web part properties window, set the
following properties:

¢ Poll name: Continents

e Web part container: Community Site - Blue Box

e Web part container title: Poll

Click OK. That's us finished with the zoneRight web part zone. Now we can move on and populate the
other web part zones.

6. We will place the community_home_img.jpg image, which we uploaded earlier in this chapter, to
the zoneCenterRight web part zone. Click the Add web part (%) icon, choose the Text -> Editable
image web part and click OK. In the web part properties window, set the following properties:

e Alternate text: Community photo

Click OK.

Switch to the Page tab and click the Select link of the Editable image web part.

Community

Starter site

Home | || searcn

Shortcuts

My profie
Edit my profile

Select the file from the content tree and click the Select link. Click Save to save the content of the
page.
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|| Insert - Webpage Dialog [

@ Selectimage

Attachments | Content | Medialibraries  Web

[\a New folder (l New file E List Tiles @ Thumbnails @
Site: | My Community Site E General
s URL:  |/kenticocms/Files/community_home_img.aspx 1)
=4 7 My Community Site = =
\
=5 Files Wwidth: |374 l’g Q
+- {5 button_joinnow Height | 205

*. [ button_signin
i-[=] community_header_img
|kl community_home_img
-] Home
|| Logon page
-] Search

P—

e Canes

http://localhost/kenticocms/CMSFormControls/Selectors/InserfimageOrMedia/Default.aspxioutput=url&amp:content=img&amp;documentid=415&am € Local intranet | Protected Mode: Off

7. The zoneCenterLeft web part zone will host the welcome text and links for sing-in and registration.
Click the Add web part (4) icon, choose the Text -> Editable text web part and click OK. You can
left all web part's properties at the default values and click OK.

8. Switch to the Page tab. Using the WYSIWYG editor, try to achieve the same result that you can see
in the screenshot below. You can find detailed description of the WYSIWYG editor's capabilities in
Kentico CMS Deweloper's Guide -> Content management -> WYSIWYG editor. However, you can see
the controls that you will use highlighted in the screenshot.

You will need to write the heading and change its Format to Heading 1. Then you will need to add a
table with one row and two columns. Set the Border size property of the table to 0. You will insert the
images into the table. Then you will select each of the images and add a hyperlink to the Logon page
to it. Then you will have to select both of the images in the table and choose the center alignment.
Finally, you will have to type the remaining text and set its Format to Normal.
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Page Design Form Properties E
E Save Spell check
£ =l souce | [& ] |&: FHIEEHE RTINS I EEE &
FE=R-os2:iag/olxs

‘ Style o - | Format | Heading 1 - [Font - | Size = E T-' %'E m

The changes were saved.

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is admini: with blank p:

Current user: Global Administrator {administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Home . | | | Search

e oo

fi -
| Welcome to our community Sl
: My profile
! | ‘ Edit my profile
| o 0 oW
; —SRERTIT—. N ST W) My messages
! A My friends
! This community site is a virtual point for those who like traveling, |= My invitations

|| adventrure, discovering new places, meeting new people and al
the things related to it. If you are interested in this sort of
things, don't hesitate and join now!

Create a new group
Create a new blog
Sign out

e —————————————— - Latest News
No data found

9. Two web part zones are remaining. In the zoneCenterBottomLeft, we will place a repeater displaying
extracts from the latest blog posts. The Blogs section from that the extracts will be displayed will be
created later in this guide. Click the Add web part (%) icon, choose the Listings and viewers ->
Repeater web part and click OK. Set the following properties of the web part, leave the rest of them at
their default values:

¢ Disable view state: enabled

e Path: /Blogs/%

e Document types: CMS.BlogPost

e ORDER BY expression: BlogPostDate DESC

e Select top N documents: 6

e Transformation: Community. Transformations.HomeBlogPostsCenter

e Cache dependencies: nodes|{%CurrentSite. SiteName|(tolower)%}|cms.blogpost|all
e No record found text: There are currently no posts.

e Web part container: Community Site - Blue Box Light

e Web part container title: Latest blog posts

Click OK.

10. Last but not least, we will place a similar repeater to the zoneCenterBottomRight web part zone.
This repeater will be displaying latest forum posts. The Forums section will be created later in this
guide. Click the Add web part (%) icon, choose the Forums -> Forum posts viewer web part and
click OK. Set the following properties of the web part, leave the rest of them at their default values:

e Disable view state: enabled
e Top N: 6
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e Order by: PostTime DESC

e Web part container: Community Site - Blue Box Light
e Web part container title: Latest forum posts

Click OK.

11. You hawe just finished creating the Home page. Most of the web parts are not displaying any
content because the related sections of the web are not created yet. Howewer, as you will be creating
these sections further in this guide, you will see the related content appear on the home page. In the

Design tab, the page should look as in the following screenshot.

|V /Home - page template: ad-hoc

P

= zoneCenterleft

= zoneCenterRight

|

v editabletext {3

e to our
community

[This community site is a virtual meeting point for those who like

all the things related to it. If you are interested in this sort of things,
don't hesitate and join now!

traveling, adventure, discovering new places, meeting new people and

¥ EditableImage @,!

= zoneCenterBottomLeft + = zoneCenterBottomRight
¥ repeater @,! ¥ ForumPostsViewer @,!

* zoneRight *

* logonminiform !@Z‘!
{v Shortcuts {53

Shortcuts

My profile

Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog

Sign out

= ScrolingText @,!

Latest News
Mo data found

¥ GroupsViewer ’,:e_:‘,!

Latest Groups

There are currently no groups.

View all

Latest Members

There are currently no
members.

View all

‘
Pol
Which continent are you
planning to visit during
your next trip?
) Africa
[ 1
) America
[ 1
O Asia
[ 1
') Australia
[ 1

! : ! Europe
[ 1

12. The last step is to save the page as a page template for further reusability. Switch to the Properties
-> Template tab and click the Save as new template link. Enter the following details:
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Template display name: My Community Site - Home page
Template code name: MyCommunitySite. HomePage

e Template category: My Community Site templates

Template description: some text describing the page template

Click OK.

Switch to Site Manager Site: My Community Site E User: Global Administrator v5.0.

232 Kentico
#4%  CMS Desk Content Mydesk  Toals Administration

[ Copy i up A E })

New Delete = Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other |
I:-l'!‘b‘_."l My Community Site Page  Design Form | Properties
= G
= L._.‘/ (== General
i |Home E Save
i URLs
i L] Logon page
|| search Template
Metadats Template
Categories Ad-hoc: Home Select
Menu H i i ]
e e & Page temp Save as new -- Webpage Dialog ﬂ
Workflow : H ‘,_
3 - - Save as new e template
Versions Q Inherit template “‘4 b B
Related docs
Edittemplate properties
Linked docs E Template display name: My Community Site - Home page
Security Template code name:  MyCommunitySite HomePage
Attachments Inherit content Template category: My Community Site templates E
@ Use page template setting -
- This is the Home page of My -
Do notinherit any content Community Site
H () Selectinherited levels Template description
http://localk € Local intranet | Protected Mode: Off
|

3.7 Creating a starter page template

Many pages on the site will have the same layout and contain the same web parts. To prevent repeating
the same dewvelopment tasks again and again, it is a good practice to create a starter page template.
This template will contain the required layout with two web part zones and three web parts - Editable
text for heading in zoneLeft web part zone and the Logon mini form and Shortcuts web parts in
zoneRight web part zone.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.
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Switch ©

232 Kentico
‘l‘ CMS Desk Content My desk Tools Administration
— = it — —
G Clco  Hus [d] »r
Delete | = Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other
=& /My Community Site My Community Site

New document

|| Logon page
‘..[[] Search

Please select new document type:

| ] Page (menu item)

‘T Blog

i Folder

& Link an existing document

145

2. Choose to Create a blank page using the Simple layout. For Page name, enter starter page

template and click Save.

.‘:’. Kentico Switch to Site Manager

#4% CMS Desk Content | Mydesk  Tooks  Administration
= ooy e 3
New Delste =k Move & Down | Edit  Preview Live site  List | Search \
Content management | view mode Il other |

= {-"l My Community Site My Community Site

- &
(=) Q) Files
] Home E Save Save and create another
,:] Logon page
[0 search Page name: starter page template

) Usepagetemplate  Inheritfrom parentpage @ Creale a blank page

Layout name:

Grid 2x2 cells

Grid 2x2 cells (CSS) Grid 3x2 cells

Top row, three columns,
bottom row

Three columns Three columns (CSS)

12
Simple

Simple layout with one web part zone.

Copy this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

Site:| My Community Site[=| User: Global Administrator v5 03638

Simple

Two columns

3. Switch to the Properties -> Template tab and click the Edit template properties link.

Sign out

(2]

=

n
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232 Kentico
#i% CMS Desk

Tools Administration

Switch to Site Manager

EE E] Copy A [al E_| /O
New Delete = Move Edit Preview Live site List | Search |
Content management View mode | Other |
l:‘l'!‘l_‘;] My Community Site Page  Design  Form | Properties
‘ﬂ@ Files General
-] Home E Save
/] Logon page -
a Search Template
g [1[starter page template Metadata Template
Categories Ad-hoc: starter page template
Menu -
iaton _j’: Save as new template...
Versions @ Inherit template
Related docs
el [ E Edit template properties ]
Security
Attachments Inherit content

@ Use page template settings
= Do notinherit any content
) Selectinherited levels

Site: | My Community Site[=] User: Global

Select

4. In the pop-up window, switch to the Layout tab and replace the original layout with the following code:

</ di v>

</ di v>

</ di v>

<di v cl ass="subcontentD v">
<di v cl ass="zoneCent er Hone" >
<ccl: QvB\WbPart Zone

<di v cl ass="zoneRi ght">
<ccl: CvBWebPar t Zone | D="zoneRi ght" runat="server" />

| D="zoneCenter"

<di v cl ass="cl ear">&nbsp; </ di v>

runat ="server"

/>

Click Save.
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' ™
& | Page Templates -- Webpage Dialog ﬁ
-

=

Page template properties @
Templates ¥ Ad-hoc: starter page template

General Layout Web parts Header Documents

E}l Check outto file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\57331e54-4040-410b-
842f-d96b7aefScec.ascx to edit the layout externally.

@ Use shared layout

Grid 22 cells

@ Use custom layout

<div class="subcontentDiv"> -
<div class="zoneCenterHome">
<ccl:CMSWebPartZone ID="zoneCenter” runat="server"” />
</div>
<div class="zoneRight">
<ccl:CMSWebPartZone ID="zoneRight™ runat="server™ />
</div>
<div class="clear">snbap;</div>
</div>

http//localhost/kenticoems/CMSModules/PertalEngine/UL/Pag Q. Lecal intranet | Protected Mode: Off

" 4

5. Switch to the Design tab. You can see a page layout with two web part zones - zoneCenter and
zoneRight. This layout is common to many of pages that we will create on the site. In the zoneCenter
web part zone, all of the pages will contain a heading, provided by the Editable text web part. We will
add the web part now. Click the Add web part (%) icon, choose the Text -> Editable text web part
and click OK. In the web part properties window, set the following properties:

e Editable region type: Text box
e Content before: <hl class="header">
e Content after: </h1>

Click OK.

6. In the zone zoneRight web part zone, two web parts will be common to all the pages. The first of
them will be the Logon mini form. Click the Add web part () icon of the zoneRight web part zone
and choose the Membership -> Logon mini form web part. Set the following properties of the web
part, leave the rest of them as they are:

Display to roles: _notauthenticated

Logon failure text: Error logging in.

Web part container: Community Site - Red Box
Web part container title: Sign in

Click OK.
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7. The next web part common on all the pages is the handy Shortcuts web part, displaying shortcuts to
various actions and sections depending on the current context. Click the Add web part () icon again,
choose the Community -> Shortcuts web part and click OK. In the web part properties window, set the
following properties. Leave the rest of the properties at the default values:

e Display Join/Leave the group link: disabled
e Display Friendship links: disabled

e Display Add to contact list link: disabled

e Display Add to ignore list link: disabled

e Display manage group link: disabled

e Display Sign in link: disabled

e My messages path: /Members/Management/Messages
e My friends path: /Members/Management/Friends

e My invitations path: /Members/Management/Invitations
e Sign out path: /Home

e Web part container: Community Site - Red Box

e Web part container title: Shortcuts

Click OK.

When you are finished, the page in Design tab should look as in the following screenshot.

|' [starter page | - page late: _StarterT I 2’|

v zoneCenter o

= zoneRight o
v editabletext {3 =
+ logonminifarm @
-
Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

8. We will save the page template so that it can be reused later. Switch to the Properties -> Template
tab and click the Save as new template link. Enter the following details into the pop-up dialog:

e Template display name: StarterTemplate

e Template code name: StarterTemplate

e Template category: My Community Site templates

e Template description: enter some text describing the page template

Click OK. Click Save.
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\l' Kel'lti.co Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.36
-
1% CMS Desk Content | Mydesk  Tools  Administration
O g Bow  Hw 4  [d
New Delete = Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other
=) My Community Site page  Desgn  Form | Properties
o
u \'l’ fles General
-] Home E Save
2 URLs
-] Logon page
J Search Template
-] starter page template Metadata Template
Categories Ad-hoc: starter page template Select
Menu ’ N
& Page template - Save as new -- Webpage Dialog ﬂ
Workflow
Versions E Inherit template 4 Save as new page template
Related docs )
EEdnlem late properties
Linked docs Template display name: |_StarterTemplate
Security Template code name:  |_StarterTemplate
Attachments
- In_hert content ) Template category: My Community Site templates |z|
@ Use page template settings
- This is the starter page template =
) Do naotinherit any content of My Community Site, It will be
H ©) Selectinherited levels  |used as the starting poinc for
Template description: development of many pages on the
site.
http://localk € Local intranet | Protected Mode: Off
\:

9. As the page template is now saved, we do not need the page created in this chapter anymore. Delete
the page from the content tree. The page template will remain saved and can be used in the future.

= 4
Delete

ontent management

3

[0 Copy T up

-5 Mowve & Down

New

clbg! My Community Site
(x-°5] Files
: ,_1 Home

,_] Logon page

i-[] search

,_] starter page template

3.8 Creating the Blogs section

3.8.1 Creating the Blogs page

In this part of the guide, we will create the Blogs section. This section will allow users to read blog posts
from any number of blogs. Users will also be able to create a new blog directly on the site, as well as
add new blog posts.

Most of this functionality is is achieved using the User contributions module web part. For more

information about the module, please refer to Kentico CMS Deweloper's Guide -> Module User

contributions.

Detailed information about the Blogs module can be found in Kentico CMS Developer's Guide -> Module
Blogs.
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1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)

document type.

232 Kentico

“1% CMSDesk Content My desk
[=) X [ copy T up

New |Delete = Move & Down

Content management

d-é_"l My Community Site
x-S Files

: ] Home

; I_| Logon page

‘..[[] Search

Switch
Tools Administration
(4 [d = »r
Edit Preview Live site List Search
View mode Other
My Community Site

;' New document

Please select new document type:

| ] Page (menu item)

‘T Blog

i Folder

& Link an existing document

2. We will use the starter page template created in this chapter as the starting point for this page.
Choose the My Community Site templates -> _StarterTemplate. For Page name, enter Blogs and

click Save.

22 Kentico
#1% CMS Desk

Content | Mydesk Toos  Administration
2) [ U
) ® [Hlcopy T up (M7
New Delete |=»Move

& Down Edit

Content management
d'éq’) My Community Site My Community Site

(-5 Files

View mode

E‘ Save and create another

Switch to Site Manager  Site:| My Community Site =] User: Global Administrator v5.0 3688 Sign out

Q& 2| L] o

Preview Live site List

Search
Other

Spell check

-] Home
| Logon page
-] Search

@ Use page template

Page name: Blogs

) Inheritfrom parentpage ) Create a blank page

Template name:
_ StarterTemplate My Community Site - My Ci ity Site - My C ity Site -
Home page Logon Page Master Page

My Community Site -
Search page

) Templates with editable regig

L wiki

_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.

3. Go to the Properties -> Template tab and click the Save as new template link. Enter the following
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details in the pop-up dialog:

Template display name: My Community Site - Blogs

e Template code name: MyCommunitySite.Blogs

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

::’- Kentlco Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.36!
'l\ CMS Desk Content My desk Tools Administration
= c U — -
B g Bor %w | 3@ Q O 3 | L |
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
= ;“_,3 My Community Site Page Design Form Properties
~[gl[Blogs General
-] Home :
. a Logon page Template
1 a Search Metadata The changes were saved.
Categories Template
Menu _StarterTemplate Select
Workflow ' B
. Eave as new templat & | Page template - Save as new -- Webpage Dialog ﬂ
ersions FRuResnErlEmERE.
Related does @ herttempists -’.::T'E Save as new page template
Linked docs .__‘
@/ Clone template as ad-hoc
Securi =/ - "
& Template display name: My Community Site - Blogs
Attachments i
E Edit templale properties Template code name:  |MyCommunitySite Blogs
Template category My Community Site templates [=]
Inherit content This is the starter page template =
@ Use page template settings of My Community Site. It will be

used as the starting point for
development of many pages on the
() Selectinherited levels site.

) Do notinheritany content Template description

[ ok [ cancel |

http://localk € Local intranet | Protected Mode: Off

4. On the same tab, click the Edit template properties link. In the pop-up Page template properties
window, switch to the Layout tab and replace the original layout with the following code:

<di v cl ass="subcontent D v">
<di v cl ass="zoneCent er Bl og" >
<ccl: QvBWbPart Zone | D="zoneCenter" runat="server" />
</ di v>
<di v cl ass="zoneRi ght">
<ccl: CVBWebPar t Zone | D="zoneRi ght" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>

Click Save.
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' A’
& | Page Templates - Webpage Dialog M

;__J'l Page template properties @
Templates » My Community Site - Blogs

General Sites Layout Web parts Header Documents

|E Save E‘?l Check outto file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSTemplateLayouts\ MyCommunitySite\Blogs.ascx
to edit the kyout externally.

) Use shared layout

Grid 242 cells

@ Use custom layout
<div class="subcontentDiv"> -
<div class="zonelCenterHome">
<ccl:CMSWebPartZone ID="zoneCenter" runat="server" />
</dive
<div class="zoneRight">
<ccl:CMSWebPartZone ID="zoneRight™ runat="server" />
</fdive
<div class="clear">rsnbsp;</div>
< fdive

http://lecalhost/kenticocms/CMSModules/PortalEngine/UL/Pag €L Local intranet | Protected Mode: Off

" =

5. Switch to the Design tab. You should see two web part zones - zonelLeft and zoneRight - just as
you defined by the layout above. Let's add web parts to the zoneRight web part zone first.

First of all, we will create an RSS feed of blog posts. Click the Add web part (#) icon, choose the
Syndication -> Blog posts RSS feed web part and click OK. In the web part properties window, set the
following properties:

e Link text: Recent blog posts

e Feed name: blogs

e Feed title: Recent blog posts

e Feed description: Blog posts RSS feed

e Path: /Blogs/{1}/%

e Transformation name: cms.blogpost.rssitem
e Document types: cms.blogpost

Leave defaults for the remaining properties and click OK. When the web part is added to the page, drag
and drop it up between the Shortcuts menu and the Logon miniform.

Below the Shortcuts menu, the Tag cloud web part will be displayed. After clicking a tag in the web
part, users will be redirected to the /Blogs/Blog-posts page, where a list of blog posts tagged with the
clicked tag will be displayed. Click the Add web part (3F) icon again, choose the Tagging &

categories -> Tag cloud web part and click OK. In the web part properties window, set the following
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properties:

e Tag group name: Blogs

e Document list URL: /Blogs/Blog-posts

Show for document types: CMS.Blog;CMS.Menultem
Web part container: Community Site - Orange Box
Web part container title: Tag cloud

Click OK.

Below the Tag cloud, we will place an info-box displaying links to 3 latest blogs on the site. This will be
achieved using the Repeater web part. Click the Add web part (4) icon again, choose the Listings
and viewers -> Repeater web part and click OK. In the web part properties window, set the following
properties:

e Web part control ID: rptBlogList

¢ Disable view state: enabled

e Show for document types: CMS.Menultem

e Path: ./%

e Document types: CMS.Blog

e Select top Ndocuments: 3

e Transformation: Community.Transformations.BlogsListRight

e Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blog|all

e Web part container: Community Site - Gray Box

e Web part container title: Recent blogs

e Content after: <a href="~/Blogs/Blog-list.aspx" title="All blogs" class="viewAllBlogs">View all
blogs</a>

Click OK.

Next on is another similar info box. This one will be displaying latest blog comments. Click the Add
web part (3) icon again, choose the Blogs -> Blogs comments viewer web part and click OK. In the
web part properties window, set the following properties:

e Transformation name: Community. Transformations.BlogComments

Selected columns: CommentPostDocumentID,CommentDate, CommentUserName,CommentText
Hide if no record found: disabled

No record found text: There are currently no comments.

Web part container: Community Site - Gray Box

Web part container title: Latest blog comments

Click OK.

The last web part in the right column will be the Posts archive web part. This web part will be displaying
links to the latest blog months. The web part will not be displayed on this page, but only when a blog,
blog month or blog post is displayed. Click the Add web part () icon again, choose the Blogs ->
Post archive web part and click OK. In the web part properties window, set the following properties:

e Show for document types: cms.blog;cms.blogmonth;cms.blogpost
e Hide if no record found: disabled

¢ No record found text: No data in archive.

e Web part container: Community Site - Gray Box

e Web part container title: Post archive
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Click OK.

The zoneleft web part zone is finished. You can see the desired appearance in the screenshot below.
Notice that some of the web parts are not displaying any content yet. This is because there is no
content to be displayed yet, but when the content is added, all the web parts should work fine. You will
see later on in this guide.

¥ zoneRight L

= logonminiform @}

v BlogPostsRSSFeed il
RSS

|52 Recent blog posts

v Shortouts {5

Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blof
Sign Out

¥ TagCloud @
¥ rptBlogsList @}

|' LatestBlogComments @|
Latest blog comments

There are currently no
comments.

¥ PostArchive @,‘! ‘

We will move to the zoneCenter web part zone now. First, let's enter the heading text. Switch to the
Page tab and enter Recent blog posts into the text box representing the web part. Click Save.

_____________________

The heading that we've just added will be displayed only on the title page. When a content of a blog is
displayed, the heading will be replaced by breadcrumbs of the same size. These breadcrumbs will be
clickable and will indicate the current position in the blogs hierarchy. Click the Add web part (4F) icon
again, choose the Navigation -> Breadcrumbs web part and click OK. In the web part properties
window, set the following properties:

e Show for document types: CMS.BlogMonth;CMS.BlogPost;CMS.Blog
e Starting path: /Blogs

e Document types: CMS.Blog;CMS.BlogMonth;CMS.Menultem

e Content before: <div class="blogsTopBreadcrumbs">

e Content after: </div>

Click OK.

© 2011 Kentico Software



Part 2 155

Now we have the heading ready, so let's get to the three web parts enabling users to edit blog
properties, create blog posts and edit blog posts directly on the live site. As mentioned abowe, this
functionality will be achieved using the User contributions module web parts.

The first one will be used for blogs editing. Click the Add web part (3) icon again, choose the User
contributions -> Edit contribution web part and click OK. In the web part properties window, set the
following properties:

Web part control ID: EditBlog

Show for document types: CMS.Blog
Alternative form name: CMS.Blog.EditBlog
Edit button label: Edit blog

Allow delete: disabled

Content before: <div class="EditPanel">
Content after: </div>

Click OK.

The second of the User contributions web parts will be used to enable users edit blog posts. Click the
Add web part (4) icon again, choose the User contributions -> Edit contribution web part and click
OK. In the web part properties window, set the following properties:

Web part control ID: EditBlogPost

Show for document types: CMS.BlogPost
Alternative form name: CMS.BlogPost.EditBlogPost
Content before: <div class="EditPanel">

Content after: </div>

Click OK.

The last of the three User contributions web parts will enable adding of new blog posts. Click the Add
web part (4F) icon again, choose the User contributions -> Contributions list web part and click OK.
In the web part properties window, set the following properties:

e Web part control ID: NewBlogPost

e Show for document types: CMS.Blog

e Path for new documents: "." (do not include the parentheses, these are only indicating that you
should enter the dot only)

Allowed new document types: CMS.BlogPost
Alternative form name: CMS.BlogPost.EditBlogPost
Display list of documents: disabled

New item button label: New blog post

List button label: My blog posts

Allow delete: disabled

Content before: <div class="EditPanel">

Content after: </div>

Click OK.

Now we will add two repeaters with similar settings. The first repeater will be displayed only on Blog
month documents and will display a list of all blog posts in the month, paged by 5 posts. Click the Add
web part (%) icon again, choose the Listings and viewers -> Repeater web part and click OK. In the
web part properties window, set the following properties:
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Web part control ID: rptMonthPosts

Show for document types: cms.blogmonth

Path: ./%

Document types: CMS.BlogPost

Transformation: Community.Transformations.BlogsAllBlogsPosts

Selected item transformation: Community. Transformations.BlogPostDetail
Enable paging: enabled

Page size: 5

Cache dependencies: nodes[{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

The second repeater will display a list of 5 latest blog posts on the Blogs title page (the page that you
are creating now) and on a particular blog's title page. The repeater will also be used for displaying
particular blog posts. Click the Add web part () icon again, choose the Listings and viewers ->
Repeater web part and click OK. In the web part properties window, set the following properties:

Web part control ID: rptLatestPostsAllBlogs

Disable view state: enabled

Show for document types: CMS.Blog;CMS.BlogPost;CMS.Menultem

Path: ./%

Document types: cms.blogpost

Order by expression: BlogPostDate DESC

Select top N documents: 5

Transformation: Community.Transformations.BlogsAllBlogsPosts

Selected item transformation: Community. Transformations.BlogPostDetail
Cache dependencies: nodes[{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

Three web parts remaining. The next one will be the Content rating web part. It will be displayed only
for blog posts and will enable users to rate the content of the blog posts. Click the Add web part ()
icon again, choose the Content rating -> Content rating web part and click OK. In the web part
properties window, set the following properties:

e Show for document types: CMS.BlogPost
e Content before: <div class="blogContentRating">
e Content after: </div><br />

Click OK.

The Social bookmarking web part will be placed below the Content rating web part and will enable
users to bookmark blog posts via a large number of social bookmarking senices. Click the Add web
part () icon again, choose the Community services -> Social bookmarking web part and click OK.
In the web part properties window, set the following properties:

e Show for document types: CMS.BlogPost

e Bookmarking services: enable the check-boxes for all social bookmarking senices that you want to
be available

e Content after: <br /><br />

Click OK.
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The last web part on the page will also be displayed only for blog posts. It is the Comments view web
part, enabling users to post blog comments and displaying the comments. Click the Add web part ()
icon again, choose the Blogs -> Comment view web part and click OK. In the web part properties
window, set the following properties:

e Show for document types: CMS.BlogPost

e Check permissions: disabled

e Comment separator: <div class="PostCommentSeparatorLine">&nbsp;</div>
e Show edit button: enabled

e Enable user pictures: enabled

e User picture width: 66

e User picture height: 66

e Content before: <div class="blogComments">

e Content after: </div>

Click OK.

In the screenshot below, you can see the desired appearance of the page in Design tab. As mentioned
abowe, no content is displayed as there is no content (no blogs, no posts, ...) on the site yet. Howeer,
as the site gets populated with content, all web parts should be fully functional.

|V /Blogs - page template: My Community Site - Blogs y|
-
Zonecents = T zoneRight op)
w editabletext i =
wacrrrw‘ré%y pOStS = logonminiform @
_ ¥ BlogPostsRsSFeed (3
= breadcrumbs @ RSS Feed
v EditBlog {03 F Recent blog posts
v EditlogPost {03 prm——
or
¥ NewBlogPost {3 Shortcuts
My profile
¥ rptMonthPosts @ Edit my profie
|' rptLatestPostsAllBlogs @| My messages
My friends
— Create a new group
¥ SodalBookmarking @ T
Lreate a new blog
¥ TagCloud @}
¥ rptBlogsList @,!
¥ LatestBlogComments @
Latest blog comments
There are currently no
comments.
¥ PostArchive @} ‘

3.8.2 Creating the Create page

The Create page is where users are redirected when they want to create a new blog. The page is
accessible via the Shortcuts menu, after clicking the Create a new blog link. In the following example,
you will learn how to create the page. We will use the My Community Site - Blogs page template
created in the previous chapter so that we don't have to waste time by adding the same web parts
again.
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1. Go to CMS Desk, select the Blogs page in the content tree and cli
Page (menu item) document type.

ck the New icon. Choose the

Switch
232 Kentico
‘l‘ C€MS Desk Content My desk Tools Administration
) 3 Blcw  Tw 4 [d A
New | Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | ‘iew mode Other
(=) My Community Site » Blogs
i..[]/Blogs )
3 :‘—l ) New document
- Files —
“[] Home
‘[ Logon page Please select new document type:
i.[] search

| ] Page (menu item)

2. Choose the My Community Site templates -> My Community S
Page name, enter Create and click Save.

-‘2,- Kenl:ico Switch to Site Manager  Site: My Commu
#1% CMS Desk Content | Mydesk Tools  Administration

S 4  [d = 2
New Delete = Move & pown ‘ Edit Preview Live site Lst | search |

Content management View mode other |

l:/'!"_," My Community Site } Blogs

- | Blogs
(&5 Files . Save and create another %, Spell check
|| Home
-] Logon page Page name: Create
|| Search

@ Use pagetemplate ) Inheritfrom parent page ) Create a blank page
(=<4 All page templates
&) Articles
&y Blank pages for widgets
::‘} Blogs
) Community Site
) Corporate Site ASPX
&) E-commerce
&y Events
-5} FAQs
& Forums
i3] General
&) Home pages
- Images
::'Q' Job openings
) knowledge base
i3 Master templates
ﬂ' Membership and security
i) Message boards
- ::'Q' My Community Site templates
&) News
&) Newsletter
&) offices
- Press releases
&) Products
&y Templates with editable regia

- _":‘} Wiki

Template name:

_ StarterTemplate

My Community Site -

Master Page Search page

My Community Site - Blogs
This is the Blogs page of My Community Site.

. |

3. Now we hawe the Create page created. It uses the My Community

My Community Site -
Blogs

ite - Blogs page template. For

nity Site[~| User: Global Administrator v5.0.3688 Sign out

o

—=

My Community Site -
Logon Page

My Community Site -
Home page

My Community Site -

Site - Blogs page template. If we

started making modifications to the page now, the page template would also get modified, so that the
Blogs page would be modified too. To prevent this, we will have to save the page as a new page template

before the actual modification. Switch to the Properties -> Template
template link. Enter the following details in the pop-up dialog:

e Template display name: My Community Site - Blog creation
e Template code name: MyCommunitySite.BlogCreation

tab and click the Save as new
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e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.36!

22 Kentico

'l\ CMS Desk Content My desk Tools Administration
SR [ Copy T up {2 @ = | /O
New Delete | = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
=] ;“_,'3 My Community Site Page  Design  Form | Properties
= 3 Blogs General
-[J[Create
(-G Files i
] 3 Home Template
-] Logon page Metadata Template

-] search Categories Iy Community Site - Blogs ﬁ

Menu r h
& | Page template - Save as new -- Webpage Dialog ﬂ

J Save as newtempiate.;

Workflow

Versions ¥ el Gk /4 Save as new page template

Related docs .

" &/ Clone template as ad-hoc

Linked docs e Template display name: My Community Site - Blog creation

Secaly [ Eotttempiate properties Template code name:  [MyCommunitySite. BlogCreation

Attachmegy Template category: My Community Site templates E|
Inherit content This is tl'_\e hl?g creation page of =«

H @ Use page template settings My Community 3ite.

) Do natinherit any content Template description

() Selectinherited levels

[ ok | cancel |

http:/{localk € Local intranet | Protected Mode: Off

4. Now switch to the Design tab. Because the page template already contains some web parts that we
will need on the page, we can focus on deleting the not-needed ones first. You can delete a web part by
opening the web part's context menu (down-pointing arrow on the left) and selecting the Remove
command.

{u3 Confiqure

4 Up...

J} Down ...

i Move to zone ...
‘ Duplicate web part

x Remove

From the zoneRight web part zone, delete the Logon miniform, Post archive and Blog comments
viewer web parts.

5. We will add two more web parts to this web part zone. The first one will be a repeater displaying the
current user's blogs. Click the Add web part (%) icon of the zoneRight web part zone and choose the
Listings and viewers -> Repeater web part. Set the following properties of the web part, leave the rest
of them as they are:

e Web part control ID: repeaterYourBlogs
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e Path: /Blogs/%

Document types: CMS.Blog

ORDER BY expression: DocumentCreatedWhen DESC

e WHERE condition: NodeOwner={%CurrentUser.UserlD%}'
Transformation: Community. Transformations.BlogsListRight
No record found text: You have currently no blogs.

e Web part container: Community Site - Orange Box

Web part container title: Your blogs

Click OK.

The second web part that we will add to the zoneRight web part zone is the Users viewer. We will set it
up so that it displays the four most active bloggers on the site. Click the Add web part (4) icon and
choose the Membership -> Users viewer web part. Set the following properties of the web part, leave
the rest of them as they are:

Web part control ID: TopBloggers

Transformation name: Community. Transformations.MembersPreviewList
Hide if no record found: disabled

No record found text: There are currently no bloggers.

Show filter: disabled

ORDER BY condition: UserBlogPosts DESC

Select top N members: 4

Use default cache dependencies: enabled

Web part container: Community Site - Blue Box

Web part container title: Top bloggers

Click OK.

Now that you have the web parts in place and configured, let's just reorder them by dragging and
dropping. In the result, they should be ordered as in the screenshot below:

¥ zoneRight a9k

|

Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sian out

Top bloggers

Sort by: User name Activity

Admin

l Gender: N/A
Age: 0
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6. In the zoneCenter web part zone, we will need only the Editable text web part at the top, hence you
canremove all the other web parts in this web part zone. Switch to the Page tab and enter Create
new blog into the web part's text box. Click Save.

.....................

7. Switch back to the Design tab. You should see the heading displayed in the appropriate font size.
The rest of the zoneCenter web part zone will host only another Editable text web part displaying
some info text and the New blog web part. Click the Add web part (%) icon and choose the Text ->
Editable text web part. You can leave all properties of the web part at their default values and click OK.

Switch to the Page tab and enter some info text into the web part's text area. You can use the following
sample text:

You can create your new blog by entering the required details into the fields
bel ow. You will be able to change the entered data |later. After submtting these
details, you will be able to edit your blog's properties or start bl ogging

i medi atel y.

Click Save.

E Y¥ou can create your new blog by entering the required details into the fields below. You will be able to change the entered data later. After
| submitting these details, you will be able to edit your blog's properties or start blogging immediately.

m

8. Switch back to the Design tab. Let's finish the page by adding its main part - the New blog web part.
Click the Add web part () icon and choose the Blogs -> New blog web part. Set the following
property of the web part, leave the rest at their default values:

e Blog parent path: /Blogs

Click OK. You have just finished creating the blogs creation page. In Design tab, it should look as in the
following screenshot.
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|V /Blogs/Create - page template: My C ity Site - Blog i y|
T zoneCenter *

= zoneRight +‘

ditabl & =
v editabletext {3 blog iv Shortcuts @M
Shortcuts

- DescrlptlonText tg} blog by entering the required details into the fields below. You will be able to change the entered data later. After submitting M_\"__ profile
O able to edit your blog's properties or start blogging immediately. Edit my profie

» NewBlog 31;‘3."3 My messanes

My friends

My invitations
Create a new group
- Create a new blog
Sign out

:
Top bloggers

Sort by: User name Activity

Admin

Gender: NfA
Age: 0

Blog name:

EBlog description:

3.8.3 Creating the Blog list page

The Blog list page displays a list of all blogs on the site. This functionality will be achieved using the
Repeater web part. The page is accessible from the Recent blogs repeater on the Blogs title page, by
clicking the View all blogs link.

1. Go to CMS Desk -> Edit mode, select the Blogs page from the content tree and click New.

-‘!’- Kentico Switch :

#1% CMS Desk Content My desk  Tools Administration

A X (1 Copy T up . @ = )_)

New |Delete |=»Move & Down Edit Preview Live site List Search
Content management iew mode COther
&) My Community Site * Blogs
Blogs 9

=4 New document

¢ ol Create

l_| \___. Files

"._l Home Please select new document type:

] Logon page

. B search | ] Page (menu item)
"] Seard

2. We will use the page template from the previous chapter so that we can save time by eliminating
adding some identically configured web parts. Choose the My Community Site templates -> My
Community Site - Blog creation page template. For Page name, enter Blog list and click Save.
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232 Kentico
#1%  CMSDesk Content | Mydesk  Tools  Adminstration
D [ O e |3 @ @ =
New Delete |=»Move & Down Edit  Preview Livesite  List
Content management View mode
=] Q_;l My Community Site » Blogs

Switch to Site Manager

Search
Other

2 .T‘-i??:s;eata E‘ Save and create another | Spell check
(-5 Files
|| Home Page name: Biog list
--|_| Logon page
[ search @ Use pagetemplate () Inherit from parent page
54 All page templates Template name:
;‘] Articles
: J Blank pages for widgets
. Blogs

: ;'} Community Site
(3 ;ﬂ Corporate Site ASPX
;‘} E-commerce
i) Events
-3y FAQs
: &) Forums
H i) General
: ;'} Home pages
i) Images
;‘} Job openings
) Knowledge base
;‘] Master templates
: J Membership and security
i) Message boards
: ;'} My Community Site templates
) News
;‘} Newsletter
i@y offices
;‘] Press releases
: &) Products
i.:4) Templates with editable regio

E ;'} Wiki

My Community Site -

_StarterTemplate

Logon Page

() Create a blank page

My Community Site -
Blog creation

My Community Site -

163

Site:| My Community Site[+| User: Global Administrator v5.0.2688

=

ity Site -
Blogs

My Ci My C

Home page

My Community Site -

Master Page Search page

My Community Site - Blog creation

This is the blog creation page of My Community Site.

ity Site -

Sign out

3. Switch to the Properties -> Template tab. We will save the page as a new page template so that
the modifications made to this page will not be reflected on the Blog creation page. Click the Sawve as
new template link and enter the following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Blog list
Template code name: MyCommunitySite.BlogList
Template category: My Community Site templates
Template description: some text describing the page template

2]

=
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Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.36
232 Kentico - ty Stelz] '
#1% CMS Desk Content | Mydesk  Tools  Administration
2 Doy 4  [d pl
New Delete |= Move & Down | Edit Preview Live site List ‘ Search |
Content management | View mode || other |
(=& ) My Community Site Page  Desgn  Form | Properties
c-a ?_!;:IS - General
og lis
™ URLs
|| Create
54 Files Template
[] Home Metadata Template
[l Logon page Categories Iy Community Site - Blog creation Select
~[1] search Menu p ,
vt | Page template - Save as new -- Webpage Dialog @
Versions ﬁ}, Inherit template /= Save as new page template
Related docs .
Lred :TJ Clone template as ad-hoc
Template display name: My Community Site - Blog list
Security E Edit template properties -
Template code name:  |MyCommunitySite BlogList
Attachments
Template category: My Community Site templates |z|
Inherit content This is the Blog list page of My -
@ Use page template settings Community Site.
1 _
H ) Donotinherit any content Template description
(@ Selectinherited levels
http://locall €& Local intranet | Protected Mode: Off

4. Switch to the Design tab. Let's start with zoneRight web part zone. Remowe the
repeaterYourBlogPosts and LatestBlogs web parts. These web parts wouldn't make sense in this
context, so you can leave them out.

Click the Add web part (4) icon and choose the Membership -> Logon mini form web part. Set the
following properties of the web part, leave the rest of them as they are:

Display to roles: _notauthenticated

e Logon failure text: Error logging in.

Click OK.

Web part container: Community Site - Red box
Web part container title: Sign in

Drag and drop the web part to the top of the web part zone, above the Shortcuts box. The web part zone
is ready now and should look as in the screenshot below.
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¥ zoneRight 9k
[ e
Shortcuts
My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

\
w TopBloggers @

Top bloggers

Sort by: User name Activity
Admin
I Gender: MN/A
Age: 0

5. Modifying the zoneCenter web part zone will also be a task of a few clicks. Firstly, remowve the
DescriptionText and NewBlog web parts so that the only web part remaining is the Editable text for
the heading.

Now we will add the main part of the page - the repeater for displaying blogs. Click the Add web part (
) icon and choose the Listings and viewers -> Repeater web part. Set the following properties of the
web part, leave the rest of them at the default values:

Web part control ID: rptListOfBlogs

Show for document types: CMS.Menultem

Path: /Blogs/%

Document types: CMS.Blog

Transformation: Community. Transformations.BlogPostDetail

Selected item transformation: Community. Transformations.BlogPostDetail
Paging: enabled

Page size: 5

Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blog]all

Click OK.

6. Finally, switch to the Page tab and enter Blogs list into the text field of the heading Editable text
web part. Click Save.

_____________________

In the screenshot below, you can see the desired appearance of the page in Design tab. The page is not
displaying anything yet, because there are no blogs on the site. If you create one, it will be displayed
here.
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3.8.4

|V /Blogs/Blog list - page template: My Community Site - Blog list y|
T zoneCenter *

— ¥ zoneRight +
v editabletext {} ¥ logonminiform ’@}
v Shorteuts :
v rptlistOfblogs (U3 Sl ortcuts‘g:;

My profile
Edit my profie

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

* TagCloud @} ‘

+ TopBloggers @
Top bloggers

Sort by: User name Activity
Admin
‘ Gender: NfA
Age: 0

Creating the Blog posts page

The last page in the Blogs section is the Blog posts page. When a user clicks a tag in the Tag cloud
web part, they are redirected to this page. On the page, all blog posts will be displayed by the Repeater
web part based on a querystring parameter.

1. Go to CMS Desk, select the Blogs page from the content tree and click New. Choose the Page
(menu item) document type.

Switch
232 Kentico C
’.‘ CMS Desk Content My desk Toaols Administration
EEC L 4 [ = r
New |Delete = Move & pown Edit Preview Live site List Search
Content management View mode Other
=& ) My Community Site » Blogs
=.[1)[Blogs Y
SRS i New document
-] Blog list
i 5[ create
d{__,‘." Files Please select new document type:
s Home [ Page (menu item)
|_| Logon page
.| ] search

2. We will use the page template of the Blog list page created in the previous chapter. The page
template is almost identical, only the settings of the main repeater will be modified. Choose the My
Community Site template -> My Community Site - Blog list page template. For Page name, enter
Blog posts and click Save.
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:!,- Kentico Switch to Site Manager
#1%  CMSDesk Content | Mydesk  Tools  Adminstration
) G O e |3 q @ =
New Delete |=»Move & Down Edit  Preview Livesite  List Search
Content management View mode Other
=] \;_;l My Community Site » Blogs

(zJ-.| Blogs .
...[]] Blog list E‘ Save and create another Spell check
B I_] Create
=)-GJ Files Page name: Blog posts
-] Home
|1 Logon page @ Use pagetemplate () Inherit from parent page
- | Search .
=& All page templates Template name:
:‘] Articles
: ::i Blank pages for widgets
& Blogs

: ;'} Community Site
(3 :ﬂ Corporate Site ASPX
:‘} E-commerce
i) Events
-3y FAQs
: &) Forums
H i) General
: ;'} Home pages
i) Images
:‘} Job openings
) Knowledge base
:‘] Master templates
: ::i Membership and security
i) Message boards
: ;'} My Community Site templates
) News
:‘} Newsletter
i@y offices
:‘] Press releases
: &) Products
i.:4) Templates with editable regio

E ;'} Wiki

My Community Site -

_StarterTemplate

Home page

() Create a blank page

My Community Site - My C
Blog creation

My Community Site -

Site: | My Community Site [+

User: Global Administrator v5.0.3688 Sign out

(2]

=

=

ity Site - My C ity Site -
Blog list Blogs
ity Site - My C ity Site -

My C
Logon Page

My Community Site - Blog list
This is the Blog list page of My Community Site.

Master Page

Search page

3. View the new page in Page tab. Enter Blog posts into the heading Editable text web part's text box

and click Save.

Blog posts

l
|
'
e

4. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details into the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Blog posts
Template code name: MyCommunitySite.BlogPosts
Template category: My Community Site templates

Template description: some text describing the page template
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Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

22 Kentico

‘.‘ CMS Desk Content My desk Tools Administration
B L 2 & B B2 | A
New Delete |=»Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
E‘"Y“‘_.,'J My Community Site Page Design Form Properties
‘j a B!ogs General
=

. URLs

| |Blog posts

| -[J] Create Template

(]3] Files Metadata Template

; J Home Categories My Community Site - Blog list Select

[ Logon page Men sw—— : % )

i search warnl [ ;';_; SaVE a3 neiw tempiate. | ] & Page template - Save as new -- Webpage Dialog
Versions \Q{ Inherit template ,\.gﬁ Save as new page template
Related docs .
e :}d Clone template as ad-hoc
sl = Template display name: My Community Site - Blog posts
Seauy ﬁ Edit template properfies Template code name:  |MyCommunitySite BlogPosts
Attachments

Template category: Wy Community Site templates [~]

This is the Blog post page of My -
Community Site.

Inherit content
@ Use page template settings
= Do notinheritany content Template description:

I,

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

5. Switch to the Design tab. There is the rptListOfBlogs web part already on the page in the
zoneCenter web part zone. It is configured for the purposes of the Blog list page, so we will have to
modify its properties. Click the Configure (‘&) icon of the web part and set the following properties:

Web part control ID: rptBlogPosts

Show for document types: CMS.Blog;CMS.BlogPost;CMS.Menultem
Document types: cms.blogpost

ORDER BY expression: BlogPostDate DESC

WHERE condition:

({?tagid|(toint)?} = 0 AND '{?tagnane?}'=""') OR (DocunentlD IN (SELECT Docunent|D
FROM CVB_Docurent Tag WHERE Tagl D = {?tagid| (toint)?})) OR (Docunent|ID IN ( SELECT
Docunent | D FROM CVB_Docunent Tag WHERE Tagl D I N ( SELECT Tagl D FROM CMS_Tag WHERE
TagName = '{?tagnane?}' AND TagG oupl D = {?groupid|(toint)?})))

® Transformation: Community.Transformations.BlogsAllBlogsPosts
e Selected item transformation: clear the value as it wouldn't make sense in this context
e Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

The page is now finished. In Design tab, it should look as in the following screenshot:
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| = /Blogs/Blog posts - page template: My Community Site - Blog posts

B

w zoneCenter

= zoneRight *

v editabletext {2

= rpiblogPosts @}

= |ogonminiform ’;é‘,!

Shortcuts

3.9 Creating the News page

My profile
Edit my profie

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

* TagCloud ’{é‘,s

+ TopBloggers ’;a‘u',!
Top bloggers

Sort by: User name Activity

Admin

Gender: NfA
Age: 0

The News page will contain a repeater displaying news. News items can be created by users with
access to CMS Desk, typically content editors or site administrators. They are useful for announcing

important information to all site users and visitors.

Creating the News page will be very simple. We will re-use the starter page template created in this
chapter and add some web parts, mainly the Repeater for displaying news items.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)

document type.

22 Kentico

"‘ CMS Deslk Content My desk Tools
3 Copy o Up 'A
& Down Edit

Content management

Administration

4 [ =

Preview Live site List

x

New |Delete [=b Move

View mode

-;l-\é_'l My Community Site My Community Site

_|_, Blogs
L[] Blog list
|| Blog posts

| New document

Please select new document type:

: 4 Create
—‘ﬂ Files [[] Page (menu item)
o] Home

4 Logon page ] Blog

|| Search & Folder

Switch

/O
Search
Other

2. Choose the My Community Site templates -> _StarterTemplate page template. For Page name,

enter News and click Save.
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22 Kentico
#1%  CMS Desk

Content
3 [ copy T up
= *® =
New Delete |=»Move & Down

Content management

=] Q_;l My Community Site
(=)-l] Blogs
.| Blog list
fm ._I Blog posts
*- [ create
(-5 Files
| Home
-] Logon page
.| Search

My desk

Switch to Site Manager
Tools Administration

(4 [ [ B

Edit Preview Live site List Search

View mode Other

My Community Site

Page name: MNews

Spell check

E‘ Save and create another

@ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:

_StarterTemplate
Blog creation

My Community Site -

Blogs Home page

_StarterTemplate

My Community Site -

My Community Site -

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

=

My C ity Site - My C ity Site -
Blog list Blog posts

My C ity Site - My C ity Site -
Logon Page Master Page

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. View the page in Page tab and enter News into the heading Editable text web part's text box. Click

Save.

4. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details into the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - News
Template code name: MyCommunitySite.News

Template category: My Community Site templates

Template description: some text describing the page template
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Switch to Site Manager Site: My Community Site E| User: Global Administrator 5.0

212 Kentico
”7lh

CMS Desk Content My desk  Tools Administration
C Ui ol @
E Blooy  Wup 2 [ r
New Delete =k Move & Down ‘ Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
(=4 ) My Community Site Page  Desgn  Form | Properties
&1 Blogs General
W s
= URLs
i |1 Home
L] Logan page Template
Lo [News Metadata Template
L] search Categories StarterTemplate Select
Mend & | Page template - Save as new -- Webpage Dialog ﬂ
Workflow —
Versions Q Inherit template /3l Save as new page template
Related docs —
a3/ Clone template as ad-hoc
Linked docs =/ Template display name: My Community Site - News
e [ Edittemplate properties Template code name:  |MyCommunitySite News
Attachments Template category My Community Site templates [=]
Inherit content This i§ the _News page of My =
@ Use page template settings Community Site.
H @ Do notinherit any content Template description
() Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

5. Switch to the Design tab. Firstly, we will add a tag cloud that will display tags from the News tag
group. After clicking a tag, users will be redirected to this page again, where the repeater in the
zoneCenter web part zone will display all news items tagged with the clicked tag.Click the Add web
part (%) icon of the zoneRight web part zone and choose the Tagging & Categories -> Tag cloud
web part. Set the following properties of the web part, leave the rest of them at their default values:

Tag group name: News

Document list URL: /News

Web part container: Community Site - Orange Box
Web part container title: Tag cloud

Click OK.

6. Now we will add the Content subscription web part to enable users subscribe to receiving
notifications about new news items. Click the Add web part (4F) icon of the zoneRight web part zone
and choose the Notifications -> Content subscription web part. Set the following properties of the web
part, leave the rest of them at their default values:

Display to roles: _authenticated

Path: /News/%

Document types: CMS.News

Create event enabled: enabled

Create event display name: Community news notification
Create event template name: News notification

Web part container: Community Site - Blue Box

Web part container title: News subscription

Click OK. The zoneRight web part zone is finished and in Design tab, it should look as in the
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screenshot below.

¥ zoneRight 9k
w logonminiform @

|
Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

w TagCloud @

|' ContentSubscription @|
News subscription

E-mail:
administrator@localhost.lo

7. Now to the zoneCenter web part zone. The main web part will be a repeater displaying the news
items. Click the Add web part (4) icon, choose the Listings and viewers -> Repeater web part and

click OK. In the web part properties window, set the following properties:

Web part control ID: NewsRepeater
Path: /News/%
Document types: CMS.News

WHERE condition:

ORDER BY expression: NewsReleaseDate DESC

WHERE Tagl D = {?tagid| (toint)?} ))

({?tagid|(toint)?} = 0) OR (Docunent|D IN ( SELECT Docunent| D FROM CV5_Docunent Tag

Show new button: enabled

New button text: Add news<br />

Show Edit and Delete buttons: enabled
Content before: <div class="newsRepeater">
Content after: </div>

Click OK.

Transformation: Community. Transformations.NewsPreview
Selected item transformation: Community.Transformations.NewsDetail

8. Now let's add the Breadcrumbs web part. This web part will be displayed only when a news item is
displayed, not in the list of news items. When the News item is displayed, the breadcrumbs will make
the heading of the page in format News > Title of the news item. Click the Add web part () icon of
the zoneCenter web part zone and choose the Navigation -> Breadcrumbs web part. Set the

following properties of the web part, leave the rest of them at their default values:

e Show for document types: CMS.News

e Breadcrumb separator: <span class="TitleBreadCrumbSeparator'>&nbsp;</span>
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Encode name: disabled

Web part container: Breadcrumbs box

Content before: <div class="blogsTopBreadcrumbs">
Content after: </div>

Click OK and drag-and-drop the web part between the NewsTitle and the NewsRepeater web part.

9. Finally, we will add the possibility to sign up for RSS notifications about new news items. Click the
Add web part (3F) icon of the zoneCenter web part zone and choose the Text -> Static text web part.
Set the following properties of the web part, leave the rest of them at their default values:

e Web part control ID: RSSImage
e Text:

<br /><a href ="~/ CMSPages/ NewsRss. aspx" styl e="border:0; padding-left: 10px;
paddi ng-right: 10px;"><ing src="~/ App_Thenes/ Def aul t/ | mages/rss. gi f" border="0"
al t="RSS" /></a>

Click OK. The News page is now ready. You can try out its functionality by adding some news items
under the News page via CMS Desk. The page should display the news items correctly. In Design tab,
the page should look as in the screenshot below.

|'ﬂlew5—pagebemplabe: My Community Site - News 2’|
= zoneCenter * ¥ zoneRight +
: -

= editabletext {3 ¥ logonminiform @}

_ v Shorteuts {28 ]
¥ breadcrumbs B3 Shortcuts
¥ NewsRepeater @} I'é'ldyj_tgoﬁle a

Edit my profie

T RS55image @} My messages
== My friends

My invitations
Create a new group
Create a new blog
Sign out

* TagCloud @} ‘
¥ ContentSubscription @}

News subscription

E-mail:
administrator@localhost.lo

3.10 Creating the Media page
The Media page will display content of the site's global media library created in this chapter. As you will
see, the page is very easy to create as all the required functionality will be achieved using the Media
gallery web part.

Further information can be found in the Module Media libraries chapter of Kentico CMS Developer's
Guide.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
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document type.

232 Kentico
'l‘ CMS Deslk Content My desk Toals Administration

Y

"“ Elcopy Tup 2 E

Switch

A

New | Delete |2 Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
=& /My Community Site My Community Site
5[] Blogs Y
T :‘—l i New document
= Files —
[ Home
i.[]] Logon page Please select new document type:
‘—] e [ Page (menu item)
| Search
) Blog
i Folder

2. Enter Media into the Page name field. Select the My Community Site templates ->
_StarterTemplate page template and click Save.

232 Kentico
#1%  CMS Desk Content | Mydesk  Tools  Administration
[ copy I up w @ = /O
New Delete =k Move & pown | Edit Preview Live site Lst || search |
Content management | View mode || other
(=-6_[My Community Site My Community Site
()| Blogs ==
-G Files .| Save and create another == Spell check
-] Home
|] Logon page Page name: Media
-] News
J Search @ Use pagetemplate () Inheritfrom parentpage () Create a blank page
= :}]' All page templates Template name:
L) Articles
: ;'} Blank pages for widgets
1.4y Blogs

:'} Community Site
(45 Corporate Site ASPX
(i) E-commerce

: 3 Events _StarterTemplate My Community Site -

;‘] FAQS Blog creation
: ;'} Forums
H i) General
:'} Home pages
L. Images
i ) Job openings
E ::i Knowledge base
i) Master templates
: ;'} Membership and security
i) Message boards
:'} My Community Site templates
L) News
:‘] Newsletter
E ::i Offices
i) Press releases
: ;'} Products
.y Templates with editable regio
L) wiki _StarterTemplate

Home page

My Community Site - My Community Site -
Blogs

My C

My

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3638 Sign out

.

. .

ity Site
Blog list

ity Site
Blog posts

n

Y
Logon Page

Site -

My C v Site -
Master Page

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Now we will save the page as a new page template so that the changes made to the page would not
be reflected to the _StarterTemplate. Select the Media page from the content tree, switch to the

Properties -> Template tab and the Save as new template link. Enter the following details into the
pop-up dialog:

e Template display name: My Community Site - Media
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e Template code name: MyCommunitySite.Media
e Template category: My Community Site templates
e Template description: enter some text describing the page template

Click OK.
Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.
=32 Kentico v o Site =] v
‘.‘ CMS Desk Content My desk Tools Administration
2 g Bow Tuw (4 [d Ve
New Delete = Move & pown | Edit Preview Live site List | Search |
Content management | View mode | other |
E‘"Y""_.,'J My Community Site Page Design Form Properties
';/ ‘—] E.\Dgs General
-G Files
= URLs
o] Home
3 Logon page Template
| Media Metadata Template
E J News Categories _StarterTemplate Select
‘.|| search ( )
d B ) Sae 3 e tempiate & Page template - Save as new -- Webpage Dialog ﬂ
Workflow FREARDEvIemRAE. —
vt W, E—— /=g, Save as new page template
Related docs —
&3/ Clone template as ad-hoc
Linked docs = Template display name: My Community Site - Media
Seaurity [ Edttemolate properties Template code name: | MyCommunitySite. Madia
Attachments Template category: My Community Site templates |Z|
Inherit content This is the Media page of My -
@ Use page template seftings Community Site.
H @ Do notinheritany content Template description
) Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

4. The only web part that we need to add is the Media gallery web part. Obviously, it will be placed in
the zoneCenter web part zone. Click the Add web part (4) icon of the zoneCenter web part zone
and choose the Media library -> Media gallery web part. Set the following properties of the web part,
leave the rest of them as they are:

Media library: My Community Site Media

Show subfolders content: enabled

Use secure links: disabled

Page size: 8

Group size: 8

No record found text: There are no files in the library.

Click OK.

5. The last step is to change the header text. Switch to the Page tab and enter Media gallery into the
Editable text web part's text field. Click Save.

Media gallery

l
'
'
e e
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6. And that's the Media page finished. If you switch to the live site now, you should see the page
displaying content of the previously created sample media library.
Blogs Home Media News Search
Media gallery
Shortcuts
(=) MyCommunitySiteMedia  S0rt by: Name Date Size My profie
"\S' Documents Edit my profile
75 Music My messages
X My friends
-+ Pictures My invitations
5---{S‘Video |EH] =H Create a new group
il Create a new blog
Sian out
Sample-document
SE-: 3 k:Ez_- 23/2010
_.viden
3.11 Creating the Forums section
3.11.1 Creating the Forums page

The forums page will host the site's discussion forums. All the forum content will be displayed by this
single page using the Forum group web part. In order for the page to display some content, there has
to be some forum group defined via the administration interface.

Before you start creating the page, it is therefore recommended to create one forum group. In this
chapter, you can see how a sample forum group can be created.

If you needed some more information about the Kentico CMS Forums module, you can find it in Kentico
CMS Deweloper's Guide -> Module Forums.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.
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Switch
22 Kentico e
'.‘ CMS Deslk Content My desk Toals Administration
1) g Doy Fwe 4  [d pe
New |Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode COther
=4 J[My Community Site My Community Site
5[] Blogs —,
= 4.‘—]_‘ . New document
[+]- = Files =l
‘[ ] Home
i.[]] Logon page Please select new document type:
| ‘—] s [] Page (menu item)
L] News
“..[] search |
Blog
) Folder
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2. In the following dialog, choose to Create a blank page using the Simple layout. Enter Forums into

the Page name field and click Save.

Switch to Site Manager
212 Kentico
#1% CMSDesk Content | Mydesk  Tools  Administration
o u B 3

2 [ Bew Huw 4 [d
New Delete = Move & Down | Edit Preview Live site List | Search ‘

Content management | View mode Il other |
(=] {-") My Community Site My Community Site

@ Create a blank page

Grid 3x2 cells

] j Blogs =
-G Files E. Save and create another Spell check
j Home
|| Logon page Page name: Forums
j Media
3 News (7 Use page template () Inherit from parent page
j Search
Layout name:
Grid 2x2 cells Grid 2x2 cells (CSS)

Three columns Three columns (CSS)

Top row, three columns,
bottom row

12
Simple

Simple layout with one web partzone.

Copy this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

Simple

Two columns

Site:|My Community Site[v] User: Global Administrator v5.0.3688

3. Switch to the Properties -> Template tab and click the Edit template properties link.

Sign out

2]

—

n
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2Y2 Kentico

Switch to Site Manager

#1% CMSDesk Content My desk Tools Administration
[2 E [ Capy T up | E = /0
New Delete |sbMove & Down | Edit Preview Live site List | Search
Content management | View mode | Other
(= My Community Site Page  Design  Form | Properties
'ﬂa Blogs General
()-"3) Files E Save
a Forums =
a Home Template
| Logon page Metadata Template
[ Media Categories Ad-hoc: Forums
2 Menu -
vaies \_# Save as new template..
Versions Qg Inh erit te mplate
Related docs
Lrled E Edit template properties
Security
Attachments Inherit content
@ Use page template settings
) Do notinherit any content
E| ) Selectinherited levels

Site: | My Community Site [+

4. In the pop-up window, switch to the Layout tab and replace the layout code with the following code:

<l-- Container -->
<di v cl ass="foruntearch">

</ di v>

<ccl: OvBWebPart Zone | D="zonelLeft" runat="server"

/>

Click Save.
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( & | Page Templates -- Webpage Dialog [é]
:j Page template properties @

Templates ¥ Ad-hoc: Forums

General Layout Web parts Header Documents

b 522 | (S} checkouttorie

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\960a99e2-aecd-43cd-
8205-e60c34baddd0.ascx to edit the layout externally.

) Use shared layout

Grid 2x2 cells

@ Use custom layout
<!-- Container --> -
<div clasa="forumSearch">
<ccl:CMSWebPartZone ID="zoneleft"™ runat="server" />
</div>

http://localhost/kenticocms/CMSModules/PartalEngine/Ul/Pag €& Local intranet | Protected Mode: Off

5. Switch to the Design tab. You can see only one web part zone on the page, so let's start adding web
parts to it. First, we need a heading. Click the Add web part () icon of the zoneLeft web part zone
and choose the Text -> Editable text web part. Set the following properties of the web part, leave the
rest of them as they are:

e Web part control ID: editabletextHeader
Editable region title: Header

Editable region type: Text box
Content before: <hl class="header">
Content after: </h1>

Click OK.

6. Switch to the Page tab and enter Forums into the Editable text web part's text box. Click Save.

7. Switch back to the Design tab. Because some forums might be accessible only to authenticated
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users, we will add the Logon miniform web part below the heading. It will be displayed only to
unauthenticated anonymous site \isitors. Click the Add web part () icon of the zoneLeft web part
zone and choose the Membership -> Logon miniform web part. Set the following properties of the
web part, leave the rest of them as they are:

e Display to roles: _notauthenticated

e Logon failure text: Error logging in.

e Username text: username

Content before: <div class="ForumLogonBox">
Content after: </div>

Click OK.

8. Below the logon mini form, the Forum search box web part will reside. It will enable users to search
in the forum contents. Click the Add web part (#) icon of the zoneLeft web part zone and choose the
Forums -> Forum search box web part. Set the following properties of the web part, leave the rest of
them as they are:

e Advanced search path: /Forums/Forum-search
e Context search: enabled

e Content before:

<di v cl ass="For untear chBox" >

<tabl e cel | spaci ng="0" cel | paddi ng="0">

<tr><td style="vertical -align:top; paddi ng-top: 3px; " ><b>Sear ch foruns: &bsp; </ b></
td>

<td style="text-align: right">

* Content after:

</td></tr></tabl e></di v><div class="cl ear"></di v>

Click OK.

9. Below the Forum search box, we will place the Forum group web part. In order for it to display any
content, you should have created some sample forum group as mentioned in the beginning of this
chapter. Click the Add web part () icon of the zoneLeft web part zone and choose the Forums ->
Forum group web part. Set the following properties of the web part, leave the rest of them at the default
values:

e Group name: choose your previously created forum group

e Enable favorites: enabled

e Thread view mode: Flat - oldest to newest

e Allow private messaging: enabled

e Allow friendship request: enabled

e Access denied page URL: ~/Special-pages/Access-denied.aspx
e Use friendly URLs: enabled

e Friendly Base URL: ~/Forums

e Content after: <div style="height: 15px;"></div>
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10. Below the Forum group, we will place the Forum search results. The web part will be displaying
results of forum search performed by the Forum search box web part abowe. Click the Add web part (
2k) icon of the zoneLeft web part zone and choose the Forums -> Forum search results web part.

You can leawe all properties of the web part at the default values.

11. The last web part on the page is the On-line users web part. We will set it up so that it displays the
number of users who are currently browsing the forums section. Click the Add web part (4) icon of the
zoneleft web part zone and choose the Membership -> On-line users web part. Set the following

properties of the web part:

e Transformation name: Community. Transformations.MembersOnline
Path: /Forums

Use default cache dependencies: enabled

Content before: <br />

Click OK.

12. The page is now finished. In Design tab, it should look as in the following screenshot.

| = [Forums - page template: Community Site - Forums

2

¥ zoneleft

¥ editsbletextHeader @

= logonminiform @
v Forumsearch { -
Go

Advanced search

¥ ForumGroup @ Threads Posts

Last post

Sample Forum Group

Thig iz a sample forum group.

Sample Forum 2
This is the second sample forum. i) 0

@

&
Il

Lock

Sample Forum 1
This is the first sample forum. 0 0

@

(
i,

Lock

¥ ForumSearchResults @
= OnlineUsers (&
[ orirevsers B e onine

(1/1/0001 12:00:00 AM)

(1/1/0001 12:00:00 AM)

13. Finally, we will save the page as a new page template so that it can be reused in the future (we will
use it when creating the Forum search page). Switch to the Properties -> Template tab and click the

Save as new template link. In the pop-up dialog, enter the following details:

Template display name: My Community Site - Forums
Template code name: MyCommunitySite.Forums

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.
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Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.
232 Kentico v iy Sie =] v
‘.‘ CMS Desk Content My desk Tools Administration
2 S c U —= 3
2 G Bow ®w 4 [d L
New Delete | = Move & Down Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
(26} My Community Site Page  Design  Form | Properties
‘%‘ ‘—l Blogs General
URLs
i | |Forums
[l Home Template
:] Logon page Metadata Template
i Media Categories Ad-hoc: Forums [ select |
|1 News Menu

J Search £ | Page template - Save as new -- Webpage Dialog ﬂ

Workflow

;__.[ Save as new page template

Versions E Inherit template
Related docs
1 E Edit template properties
Linked docs Template display name: My Community Site - Forums
Security Template code name:  MyCommunitySite. Forums
Ataceig In_herrt content i Template category: My Community Site templates E
@ Use page template settings
) Do notinheritany content E:rlﬂ;u;;;h:iizmms page of My i
A (@) Selectinherited levels
Template description

http://localk € Local intranet | Protected Mode: Off

3.11.2 Creating the Forum search page

The Forum search page is accessible from the Forums page, after clicking the Advanced search link
of the Forum search box web part. The page contains the Forum search - advanced dialog web part
which enables searching the forums with extended search criteria.

1. Go to CMS Desk, select the Forums page from the content tree and click New. Choose the Page
(menu item) document type.

Switch :
232 Kentico S
‘.‘ €MS Desk Content My desk Tools Administration
) g Do W 4 [d yo
New | Delete | = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other
& ) My Community Site » Forums
5[] Blogs y
-y :‘—l . New document
= Files =]
- [1[Forums
i[] Home Please select new document type:
: d Logc_m JELE [ Page (menu item)
o] Media
'—] [eWs = Article
| Search —
‘¥] Blog

2. We will use the page template created in the previous chapter as the starting point. Choose the My
Community Site templates -> My Community Site - Forums page template. Enter Forum search into
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the Page name field and click Save.

aV2 Kentico Switch to Site Manager  Site: | My Community Site[+] User: Global Administrator v5.0.3688 Sign out
-y -
#1% CMS Desk Content | Mydesk  Tools  Administration
: Blocoey Wuw 4 L B = F 2]
New Delete +Move & Down | Edit  Preview Liveste Lst | Search |
Content management | View mode || other
=) My Community Site » Forums
(- Blogs =
@ S Files == Spell check
|| Forums
-] Home Page name: Forum search
|| Logon page
- J Media @ Usepagetemplate . Inheritfrom parentpage @ Create a blank page
] News _ JE—
[ search (=5 All page templates Template name:

&y Articles
©) Blank pages for widgets

_StarterTemplate My Community Site - My C ity Site My C ity Site
Blog creation Blog list Blog posts
i
My Community Site - My Community Site - My C ity Site - My C ity Site -
Blogs Forums Home page Logon Page
i) Templates with editable regio
Ly wiki My Community Site - Forums

This is the Forums page of My Community Site.

3. Switch to the Properties -> Template tab and click the Save as new template link. In the pop-up
dialog, enter the following details:

Template display name: My Community Site - Forum search
Template code name: MyCommunitySite.ForumSearch
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

m
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Switch to Site Manager Site: My Community Site E User: Global Administrator v5.0.

22 Kentico

’.‘ CMS Desk Content My desk Tools Administration
| R O e |3 Q@ @ =],
New Delete = Move & pown Edit Preview Live site List Search
Content management | View mode | Other
126} My Community Site Page  Desion  Form | Propertes
w :Flw E.\IOQS General
+)- ] Files Save
& .| Forums
[} [Forum search Template
[ Home Metadata Template
; _| Logon page Categories My Community Site - Forums Select
: [ Media ( I
i ‘_I - M | | & Page template - Save as new -- Webpage Dialog @
il News Workflow ]
‘] search o =
= o @ ‘herittemplale /5l Save as new page template
Related docs —
&/ Clone template as ad-hog|
Linked docs = Template display name: My Community Site - Forum search
Seaurity ﬁ Edittemplate properties Template code name:  |MyCommunitySite.ForumSearch
Attachments Template category: Iy Community Site templates [=]

This is the Forum search page of -
My Community Site.

Inherit content
@ Use page template settings
) Do notinheritany content Template description

[y

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Design tab. Firstly, delete all web parts so that only the editabletextHeader and
ForumSearchResults web parts remain.

| = [Forums/Forum search - page template: My Community Site - Forum search y|

- zoneleft +

v editabletextHeader @
¥ ForumSearchResults @}

5. Click the Add web part () icon of the zoneLeft web part zone and choose the Forums -> Forum
search - advanced dialog web part. You can leave all properties of the web part at the default values.
Drag and drop the web part between the other two web parts on the page.

6. Switch to the Page tab and enter Forums advanced search into the Editable text web part's text box.
Click Save.

7. The page is finished. If you view it in Design tab, it should look as in the following screenshot.
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| - [Forums/Forum search - page template: My Community Site - Forum search y|

v zoneleft *

v editabletextHeader @

| ¥ ExtendedForumSearchDialog @} | @

Written by:

Community forums -
Announcements
Community FAQ
General discussion
Members discussion

Back-packer forums
Announcements
FAQs

Search within: Subject and text

m

Search in forums:

ENJEN|K

Sortresultsby: | Post time

¥ ForumSearchResults @}

@ Ascending @ Descending

3.12 Creating the Groups section
3.12.1 Creating the Groups page

The Groups page is the title page of the Groups section. Users will see two Groups viewer web parts.
The first one of them will be displaying the groups where the user is a members. The second one will be
displaying all groups sorted from the newest to the oldest, paged by 9 groups.

If you right-click a group in one of the Groups viewers, you will be offered some actions by a context
menu. This functionality is provided in the transformation and here, you can find a description of how
exactly it is achieved.

In case you needed detailed information about Kentico CMS Groups module, please refer to the Module
Groups chapter of Kentico CMS Developer's Guide.

1. Select the root of the content tree and click New. Choose the Page (menu item) document type.

Switch
232 Kentico -
’l‘ CMS Desk Content My desk Tools Administration

x Poo v | [P [Q @@ B2 | L

New | Delete | Move & Down Edit Preview Live site List Search
Content management | iew mode | Other
& My Community Site My Community Site
3] Blogs >
= :'_IL. . New document
[+]- = Files -
|1|,_| Forums
‘[ Home Please select new document type:
o Loggn FELE [ [[] Page (menu item) ]
] Media
-~ News T Blog
“-|2] Search
i) Folder

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Groups and click Save.
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22 Kentico
#1% CMS Desk

Content
3 [Elcopy i up
=| ®
New Delete = Move & Down

Content management

d'v'_,') My Community Site
-] Blogs
(-5 Files
(+]-|.] Forums
-] Home
| Logon page
-] Media
] News
-] Search

My desk

Switch to Site Manager

Tools Administration

B & & 8 A,

Edit Preview Live site List Search

View mode Other

My Community Site

Page name: Groups

E‘- Save and create another Spell check

@ Usepagetemplate () Inheritfrom parentpage () Create a blank page

= :_\]‘ All page templates
Ty Articles
“J Blank pages for widgets

Template name:

_StarterTemplate My Community Site -

Blog creation

My Community Site - My Community Site -
Blogs

Forum search

_StarterTemplate

Site:| My Community Site[+| User: Global Administrator v5.0.3688

Sign out

Search

My C ity Site
Blog list

My C ity Site
Blog posts

m

My C
Forums

ity Site -

My C ity Site -

Home page

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Groups
Template code name: MyCommunitySite.Groups

Template category: My Community Site templates

Template description: some text describing the page template
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Switch to Site Manager Site: My Community S\teEI User: Global Administrator v5.0.

212 Kentico

#4%  CMS Desk Content Mydesk  Toals Administration
= (=) c u 8 @
B & Bew ®w | [ [d B | AR
New Delete |=rMove & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
(26} My Community Site Page  Design  Form | Properties
'?J ‘—l Blogs General
@ {j e
= URLs
.| Forums
:I Groups Template
: :l Home Metadata Template
i [] Logon page Categories _StarterTemplate W
i [ Media Mo P
= 5 i & Page template - Save as new -- Webpage Dialog ﬂ
. :I News workil Save as new template ]
i s h = =
] Seard Versions @ et tomplato LJ'I Save as new page template
Related docs _
8 &/ Clone template as ad-hoc
Linked docs s Template display name: |My Community Site - Groups
Security E Edittemplate properties Template code name: | MyCommunitySite. Groups
Attachments Template category: My Community Site templates |Z|
Inherit content This is the Groups page of My -
@ Use page template settings Community Site.
H () Do notinherit any content Template description.

(@) Selectinherited levels

hitp://localk @ Local intranet | Protected Mode: Off

4. Switch to the Design tab. First, we will add another Editable text web part to zoneCenter. This web
part will be displaying a text informing users that they can get context menus with available group-
related actions by right clicking a group. Click the Add web part (%) icon of the zoneCenter web part
zone and choose the Text -> Editable text web part. You do not need to set any properties of the web
part, just leave all of them at the default values.

5. Switch to the Page tab. Enter Groups into the first Editable text web part's text field. Into the second
one, enter: Right click the group to get available actions. Click Save.

Blogs Forums Groups Home Media News | | | Search

__________________________________________________________________________________________________________________________ Shortcuts

| \ My profile
| Right click the group to get available actions. = \ Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

m

6. Switch back to the Design tab. We will add the first Groups viewer for displaying the current user's
groups. Click the Add web part () icon of the zoneCenter web part zone and choose the
Community -> Groups viewer web part. Set the following properties of the web part, leave the rest at
the default values.

e Web part control ID: YourGroups
e Display to roles: _authenticated
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e Transformation name: Community. Transformations.GroupsList

e Show filter: disabled

e ORDER BY condition: GroupDisplayName

e WHERE condition: GroupID IN (Select MemberGrouplD FROM Community _GroupMember WHERE
MemberUserID = {%currentuser.userid%} AND MemberStatus = 0)

e Selected columns: GroupCreatedWhen,GrouplD,GroupName, GroupDisplayName,GroupDescription,
GroupAvatarlD, AvatarGuid

e Hide if no record found: disabled

e No record found text: You are not currently in any group.

e Web part container: Community Site - Red Box Light
e Web part container title: Your groups
e Content after: <div class="clear">&nbsp;</div>

Click OK.

7. The second Groups viewer will be displaying all groups ordered from the newest to the oldest, paged
by 9 groups. Click the Add web part () icon of the zoneCenter web part zone and choose the
Community -> Groups viewer web part. Set the following properties of the web part, leave the rest at
the default values.

e Web part control ID: RecentlyAddedGroups

e Display to roles: _authenticated

e Transformation name: Community. Transformations.GroupsList

e ORDER BY condition: GroupCreatedWhen DESC

e Selected columns: GroupCreatedWhen,GrouplD,GroupName, GroupDisplayName,GroupDescription,
GroupAvatarlD,AvatarGuid

e Hide if no record found: disabled

e No record found text: There are no recently added groups at this moment.

e Page size: 9

e Paging mode: PostBack

e Web part container: Community Site - Blue Box Light
e Web part container title: Recently added groups
e Content after: <div class="clear">&nbsp;</div>

8. The page is now finished. In Design tab, it should look as in the following screenshot.

| T /Groups - page template: My Community Site - Groups £|
= zoneCenter * > zoneRight +
- =
w editabletext @ S @
|
v editabletextl &b to get available actions. Shortcuts
Your groups Edit my profile
My messanes
'You are not currently in any group. My friends
My invitations
Create a new group
¥ RecentlyAddedGroups @ Create a new blog
Recently a groups Sign out
Sort by: Group name Created

[There are no recently added groups at this moment.
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3.12.2 Creating the Create page

On this page, users will be provided with the possibility to create new groups. This is achieved using the
Group registration web part. There will also be the Groups viewer web part in zoneRight, which will
be displaying the latest 5 groups. The page is accessible from the Shortcuts menu, by clicking the

Create a new group link.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

Y2 Kentico

1% CMS Desk Content
3 3 [ copy T ue
SR N
Mew | Delete = Move & Down

Content management

Tools Administration

4  [d
Edit Preview Live site List

View mode

Switch :

A

Search |
Other

= ) My Community Site
=[] Blogs
(455 Files
,1,,_] Forums
I_] Groups
[ Home
I_] Logon page
[ Media
|_] MNews
“..[] search

» Groups

3 New document

Please select new document type:

| ] Page (menu item)

=) Article

‘T Blog

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Create and click Save.
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232 Kentico

1% CMS Desk Content | My desk
;‘ [E Copy i up

New Delete =bMove & Down

Content management

=] {-_/'l My Community Site
(+]-.] Blogs
(-G Files
[#-1] Forums
| Groups
--|_] Home
.| Logon page
-] Media
] News
-] Search

Tools Administration

A [& [ H
Edit Preview Live site List

View mode

» Groups

Switch to Site Manager

)

Search
Other

Spell check

Page name: Create

i 1 Save and create anather

@ Use page template

(53 All page templates
-G Articles
ij‘ Blank pages for widgets
-3 Blogs
.ﬂ' Community Site
(=) &y Corporate Site ASPX
&) E-commerce
& Events
-i3) FAQs
&) Forums
i) General
.ﬂ' Home pages
iﬂ‘ Images
.j‘ Job openings
) knowledge base
i3 Master templates
ij‘ Membership and security
i) Message boards
.ﬂ' My Community Site templates
&) News
&) Newsletter
& offices
-3 Press releases
&) Products
i) Templates with editable regia

.ﬂ' Wiki

) Inheritfrom parent page

() Create a blank page

Template name:

_StarterTemplate
Blog creation

My Community Site -

Blogs Forum search

_StarterTemplate

My Community Site -

My Community Site -

Site: | My Community Site[+| User: Global Administrator v5.0.3688

Sign out

.

My Community Site -

Blog list

My Community Site -

Forums

My Community Site -
Blog posts

m

My Community Site -
Groups

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Groups create
Template code name: MyCommunitySite.GroupsCreate
Template category: My Community Site templates

Template description: some text describing the page template
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Switch to Site Manager  Site: My Community Site User: Global Administrator ¥5.0
.:!:. Kentico v o site[=] "

CMS Desk Content My desk Tools Administration

[=H copy I up » @ /O

New Delete [ohMove & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
=14} My Community Site Page  Design  Form | Properties
2 :r—l B.Iogs General
= URLs
[+)-.] Forums
d J Groups Template
..[[] [Create Metadata Template
i ] Home Categories _StarterTemplate Select
[ Logon page (f )
; ‘:] Ve Mo - || €] Page template - Save as new -- Webpage Dialog ﬂ
l—] edia Warkfiow i —
L] News = =
e verson @ mhertempiate /= Save as new page template
] Search
Related docs -
&5/ Clone template as ad-hoc
Linked docs & Template display name: [My Community Site - Groups create
Sensig [H Edittemplate properties Template code name: | MyCommunitySite. GroupsCreate
Attachments Template category My Community Site templates El
Inherit content This i‘_?l grm?p creation page of My =+
@ Use page template settings Commanity Site.|
H Do netinheritany content Template description
) Selectinherited levels
http://localk €L Local intranet | Protected Mode: Off

4. Switch to the Design tab. Firstly, delete the Logon mini form in zoneRight. We will not need it on

this page as the page is accessible only to authenticated users (the Shortcuts menu doesn't display the
link to unauthenticated users).

5. Now that the Logon mini form is deleted, we will add the Groups viewer below the Shortcuts menu.
Click the Add web part (4) icon of the zoneRight web part zone and choose the Community ->

Groups viewer web part. Set the following properties of the web part, the rest of them can be left at the
default values:

e Transformation name: Community. Transformations.GroupsPreviewList
e Show filter: disabled

e ORDER BY condition: GroupCreatedWhen DESC

e Select Top N groups: 5

e Hide if no record found: disabled

e No record found text: There are currently no groups.

e Web part container: Community Site - Blue Box
e Web part container title: Recent groups

Click OK.

6. Let's move on to zoneCenter. First, we will add another Editable text web part for displaying
additional info text. Click the Add web part () icon of the zoneCenter web part zone and choose the

Text -> Editable text web part. You do not need to set any properties of the web part, just leave all of
them at the default values.

7. Below the second Editable text web part, we will add the main web part of this page - the Group
registration web part. Click the Add web part (4) icon of the zoneCenter web part zone and choose

© 2011 Kentico Software



192

Kentico CMS 5.5 R2 Community Site Guide

the Community -> Group registration web part. Set the following properties of the web part, leave the

rest of them at the default values.

e Template source alias path: /Groups/Template
e Template target alias path: /Group-pages

e Text after successful registration: Group has been succesfully registered. <a href="{0}">Click here

to view group profile</a>

Click OK.

8. Switch to the Page tab. Enter Create new group into the first Editable text web part's text field. Into

the second Editable text web part's HTML area, enter the following text:

By entering the details into the form below, you can create your new user group. Make sure you give the
group a name and description according to the group's field of interest. It is a good way of attracting site

users with the same interest to join your group.

Click Save.

to the group's field of interest. Itis a good way of attracting site users with the same interest to join your group.

By entering the details into the form below, you can create your new user group. Make sure you give the group a name and description according

m

9. The page is now finished. In Design tab, it should look as in the following screenshot.

| + [Groups/Create - page template: My Community Site - Groups create

B

¥ zoneCenter *

v editabletext {3 group

into the form below, you can create your new user group. Make sure you give the group a name and description according to the
==T. Itis a good way of attracting site users with the same interest to join your group.

) i
v GroupRegistration (&3

Description:

® any site member can join

Approve members: (£ Only approved members can join
@ Only approved members can join except for invited members
@ Anybody can view the content

Contentaccess: () Site members can view the content

8] Only group members can view the content

= zoneRight o
[~ shortats s
Shortcuts
My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

¥ GroupsViewer @}

Recent groups

There are currently no groups.
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3.12.3 Creating the Management page

On the Management page, group administrators will be able to manage the profile and settings of their
groups. This functionality is provided by the Group profile web part. The page is accessible by clicking
the Manage the group link in the Shortcuts menu. This link is displayed only to group administrators
when viewing the group's profile.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico -
#1% CMS Desk Content My desk Toolz Administration
: 5 C u =~ r
2 ) G Do R 2 @ @ =2 | A
New | Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
[E& ) My Community Site » Groups
5[ Blogs Y
Y :‘—l . New document
[EafR=? Files =
-] Forums
dl_] Groups Please select new document type:
‘—] EEEIE [ Page (menu item)
++|] Home
‘—] Logon page = Article
o[ Media —
|_] News ‘T Blog
‘[ ] search B Cell phone

2. Choose to Create a blank page using the Simple layout. Into the Page name field, enter
Management and click Save.
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Switch to Site Manager

232 Kentico
#1%  CMS Desk Content | Mydesk  Tools  Administration
BN T B - I =
New Delete [=»Move & pown Edit  Preview Livesite  List Search
Content management View mode Other |

=] {-_;J My Community Site
-] Blogs
-5 Files
(&) Forums
(=) ||Groups
B0 _] Create
| ] Home
-] Logon page
] Media
-] News
-] Search

» Groups

E‘ Save and create another |

Spell check

Page name: Management
(©) Use page template () Inheritfrom parent page

Layout name:

@ Create a blank page

T

E
Il]

Grid 2x2 cells Grid 2x2 cells (CSS)

Grid 3x2 cells Grid 3x2 cells (CSS)

Three columns Three columns (CSS)

Top row, three columns,
bottom row

12
Simple

Simple layout with one web part zone.

Copy this layout to my page template

Site: | My Community Site[+| User: Global Administrator v5.0.3688

Top row, two columns,
bottom row

Sign out

Q

=

Simple

i

Two columns

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Groups management
e Template code name: MyCommunitySite.GroupsManagement

e Template category: My Community Site templates

e Template description: some text describing the page template

Click OK. Click Save.
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232 Kentico

"\ CMS Desk Content My desk
= = Copy T up
=l = £

New Delete = Move & Down |

Content management

Switch to Site Manager Site: My Community S\teEI User: Global Administrator v5.0.

Tools Administration

4 & @ 52 | £

Edit Preview Live site List ‘ Search ‘

View mode | Other |

=14} My Community Site
(L] Blogs
.ﬂ & Files
[+ ] Forums
d ;] Groups
- i.[] create
i “[[Management
i.[] Home
|1 Logen page
] Media
1] News
|| search

Page Design
General
URLs
Template
Metadata
Categories
Menu
Workflow
Versions
Related docs
Linked docs
Security

Attachments

Form Properties

Template
Ad-hoc: Management Select

e e e & | Page P - Save as new -- Webpage Dialog ﬂ

,\;ﬁ Save as new page template

.@ Inherittemplate

[H Edittemplste properties _ .

Template display name: My Community Site - Groups management
Template code name:  MyCommunitySite. GroupsManagement
Inherit content Template categary My Community Site templates E
@ Use page template settings|

This is the Groups management
) Donotinherit any content

page of My Community Site.

»

(@) Selectinherited levels
- Template description

http://localk €L Local intranet | Protected Mode: Off

4. On the same tab, click the Edit template properties link. In the pop-up window, switch to the Layout
tab and replace the original layout with the following code:

<di v cl ass="f orunSear

</ di v>

</ di v>

<di v cl ass="subcontent D v">

chn>

<ccl: CvBWebPart Zone | D="zoneCenter" runat="server" />

<di v cl ass="cl ear">&nbsp; </ di v>

Click Save.
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£ | Page Templates -- Webpage Dialog

;_j Page template properties
Templates » My Community Site - Groups management

General Sites Layout Web parts Header

@l Check out to file

Check out the layout to file

Documents

C:\inetpub\wwwroot\50screenshots\ CMSTemplateLayouts\| MyCc
layout externally.

) Use shared layout

Grid 2x2 cells

@ Use custom layout
<div class="subcontentDiv">
<div class="forumSearch">
<ccl:CMSWebPartZone ID="zoneCenter" runat="server" />
</div>
<div class="clear">»snbap;</div>
</divs]

itySite\GroupsI g t.ascx to edt the

http://localhost/kenticocms/CM5SModules/PortalEngine/Ul/Pag & Local intranet | Protected Mode: Off

5. Switch to the Properties -> URLs tab and enter /Groups/{GroupName}/Management into the

Document URL path field.

Switch to Site Manager  Site: | My Community Site
232 Kentico Y v Ste[<]
’.‘ CMS Desk Content My desk Tools Administration
S [ Bow tw 2 & 6 = | L
New Delete = Move & Down Edit Preview Live site List Search
Content management View mode Other
C."!“‘_;'J My Community Site Page Design Form Properties
'1“—] B.Iogs General |
lﬂ@ Fles
T = URLs
[+ Forums
|:l._] Groups Template
i L[] Create Metadata Path
._] Management Categories Document alias: Management
._] Home Menu Document URL path: /Groups/{GroupName}/Management
I_] Logon page Workflow Use custom URL path
] Media
'J. - Versions
‘—] ews Related da Extended properties
-] search URL extensions:
Linked docs
X [[luse custom URL extensions
Security .
Track campaign:
Attachments

6. Switch to the Design tab. First, we will add the Group security access web part. This web part
checks if the user has the appropriate permissions for this group and redirects them to the Access page,
which we will create later in this chapter, in case that the permissions are insufficient. Click the Add
web part () icon of the zoneCenter web part zone and choose the Community -> Group security
access web part. You do not need to set any properties of the web part, just leave all of them at the
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default values. Click OK.

7. Below the Group securtity access, we will add the Static text web part, which will show the path to
the currently managed group in a form of breadcrumbs. Click the Add web part (<) icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties of
the web part, leave the rest of them at the default values.

e Web part control ID: Breadcrumbs
e Text:

<di v cl ass="G oupBreadcrunbs" >

<a href="~/ G oups. aspx" cl ass="CVBBreadCrunbsLi nk">G oups</ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Conmuni t yCont ext .
Current G oup. G oupNane% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %Comuni t yCont ext .
Current G oup. G oupD spl ayNane| (encode) t rue% </ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span cl ass="CVSBr eadCr unbsCurrent | t ent >
{ ¥€&VsCont ext . Cur r ent Docunent . Docunent Nane| (encode) t rue% </ span>

</ di v>

Click OK.

8. Finally, we will add the Group profile web part. Click the Add web part (4F) icon of the zoneCenter
web part zone and choose the Community -> Group profile web part. Set the following properties of
the web part, leave the rest of them at the default values.

e Group name: (current group)

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.

|V /Groups/Management - page template: My C ity Site - Group t p|

¥ Breadcrumbs (i3 ent
= GroupProfile @ manage this group.

3.12.4 Creating the Access page

Many of the pages in the Groups section contain the Group security access web part. This web part
checks if the user is permitted to see the content of the page. When a user tries to access such a page
with insufficient permissions, they are redirected to the Access page. Here, a message is displayed
telling that access is not permitted. This message is displayed by the Group security message web
part.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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Switch
232 Kentico -

‘l\ CMS Desk Content My desk Tools Administration

=] = C U =
Sl G Fom  Tu [d] »r
New | Delete = Move &4 pown | Edit Preview Live site List Search |
Content management | iew mode | other |
¥ Groups

clb_’l My Community Site
-] Blogs
|1|"\5? Files
,ﬂ,_] Forums
|_| I_] Groups
L[] Create
I_] Management
Home
I_] Logon page
Media
] News
“..[] Search

=] New document

Please select new document type:

[ ] Page (menu item)

') Blog
5 Cell phone
P Event

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the

Page name field, enter Access and click Save.

=12 Kentico

#1% CMS Desk Content | Mydesk  Tools
=) E [l Copy i up 2
New Delete = Move $oown | Edit

Switch to Site Manager

Administration

& & 82 Wk,

Preview Live site List ‘ Search |

View mode Other

Content management

» Groups

d'@q’) My Community Site
(-] Blogs

2= Spell check

E‘ Save and create another

(-5 Files
-] Forums
=+ |/Groups
: I_] Create
|1 Management
-] Home
|| Logon page
-] Media
] News
- | Search

Page name: Access

@ Use page template " Inheritfrom parent page

-4 All page templates Template name:
:'} Articles
.1 Blank pages for widgets

_ StarterTemplate

My Community Site -
Blogs

2

_StarterTemplate

) Templates with editable regig

Loy wiki

() Create a blank page

Site:| My Community Site[~] User: Global Administrator v5.0.3688 Sign out
=
]
My Community Site - My Ci ity Site My C ity Site
Blog creation Blog list Blog posts
My Community Site - My C ity Site - My C ity Site -
Forums Groups

Forum search

of many pages on the site.

0 ]

This is the starter page template of My Community Site. It will be used as the starting point for development

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

e Template display name: My Community Site - Access
e Template code name: MyCommunitySite.Access
e Template category: My Community Site templates
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e Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager  Site:| My Community Site User: Global Administrator v5.0
232 Kentico y o site ] v
‘.‘ CMS Desk Content My desk Tools Administration
Y Y Cy U — e
2 g Bow 1w 4 [d 2 | R
New Delete = Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other |
E‘"Y“‘_.,'J My Community Site Page Design Form Properties
v a B.Iogs General
£ URLs
[#)-] Forums
d ;_] Groups Template
|1/ Access Metadata Template
-[] Create Categories _StarterTemplate Select
[ Management ( )
: = 2 Mo S e & Page template - Save as new -- Webpage Dialog @
i [] Home Workflow S SR asnewlemeile. —
¢ Logon page :
: Ve ¥ et /=3l Save as new page template
L] Media inherfiiemplate
g ;_] N Related docs .
il News ; 43/ Clone template as ad-hoc
i..[] search Linked docs &/ Template display name: My Community Site - Access
B [ Edittemplate properties Template code name: | MyCommunitySite Access
Attachments

Template category: Wy Community Site templates

This is the Access page of My -
Community Site.

Inhert content
@ Use page template settings
) Do netinheritany content Template description:

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Access into the Document URL
path field and click Save.

Switch to Site Manager  Site: | My Community Site
232 Kentico £ ty Ste ]
‘l‘ CMS Desk Content My desk Tools Administration
|5 Eiceer R A [d A
New Delete [=hMove & Down | Edit Preview Live site List | Search |
Content management | View mode | Other
C."{“_;'J My Community Site Page Design Form Properties
'1"—] B_Iogs General |
[)-"5) Files E Save
L= URLs =
[+~ Forums
|:l|_] Groups Template
i [ ])[Access Metadata Path
[ create Categories Document alias: Access
] || Management Menu Document URL path: /Groups/{GroupMame}/Access
|_] Home Workflow Use custom URL path
Logon page
'—.] ¥ gd pag Versions
e Ne 3 Related do Extended properties
|_] ST . URL extensions:
.| ] search QLIS T
'—] X [T use custom URL extensions
Security .
Track campaign:
Attachments

5. Switch to the Design tab. First, remowe the Editable text web part from zoneCenter. We will add
the Static text web part instead of it. The Static text web part will be set up so that it displays the path
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to the page in a form of breadcrumbs. Click the Add web part () icon of the zoneCenter web part
zone and choose the Text -> Static text web part. Set the following properties of the web part, leave the
rest of them at the default values.
e Web part control ID: Breadcrumbs
e Text:
<di v cl ass="G oupBreadcrunbs" >
<a href="~/ G oups. aspx" cl ass="CVBBreadCrunbsLi nk">G oups</ a> <span cl ass
="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Communi t yCont ext .
Current G oup. G oupNane% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %Comuni t yCont ext .
Current G oup. G oupD spl ayNane| (encode) t rue% </ a> <span cl ass
="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span cl ass="CVSBr eadCr unbsCurrent | t ent >
Access deni ed </span>
</ di v>
Click OK.
6. The main part of this page is the Group security message web part. The web part will display the
warning message about insufficient permissions. Click the Add web part () icon of the zoneCenter
web part zone and choose the Text -> Static text web part. You do not need to set any properties of
the web part, leave all of them at the default values.
7. The page is finished. In Design tab, it should look as in the following screenshot.
|V /GroupsAccess - page template: My Community Site - Access y|
w zoneCenter *
= = zoneRight +
¥ Breadcrumbs @lenied = logonminiform ‘@}
|' GroupSecurityMessage @| .
Shortcuts
My profile
Edit my profile
My messages
My friends
My invitations
Create a new group
Create a new blog
Sign out
3.12.5 Creating groups starter template

In this example, we will create another starter template. In the Groups section, there will be pages
displaying content of particular groups - group's profile, pages (articles), media libraries, group members
and group forums. All of the pages will contain the same three web parts, so we will create a starter
template with these web parts to facilitate development of these pages.

The page template will be based on the _StarterTemplate page template created in this chapter.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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Switch
232 Kentico e
‘l\ CMS Desk Content My desk Tools Administration
= C U ~e =
RN L [d] P
Delete = Mave & Down | Edit Preview Live site List | Search |
Content management | iew mode | other |
5 ) My Community Site » Groups
5[] Blogs -
= :'_l . New document
[+]- = Files =l
,ﬂ,_] Forums
=-11/Groups Please select new document type:
‘—] (e [[) Page (menu item)
|| Create
: _:_----,_] Management = Article
] Home —
- I_] Logon page Ealﬂ
2 B cell phone
| Event

i..[]] search ) .
I Event (booking system)

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter _GroupsTemplate and click Save.

-‘!4- Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3638 Sign out
#1%  CMSs Desk Content | Mydesk Tools  Administration
C Uy E D
2 G Bowr T 4  [d =i Py
New Delete = Move & pown | Edit Preview Live site Lst || search |
Content management | View mode || other |
(-6 My Community Site » Groups
()| Blogs
250 Files E‘ Save and create another
(©-L] Forums
(=)-[] [Groups Page name: _GroupsTemplate
|4 Access
H |_I Create @ Use pagetemplate () Inheritfrom parentpage () Create a blank page
.| Management _ R
B Home =& All page templates Template name:
@ Logon page t‘} Articles
[ Media &) Blank pages for widgets
|1 News - Blogs
-[3 search i) Community Site

5] Corporate Site ASPX
(i) E-commerce
L_:i Events _StarterTemplate My Community Site - My C Y Site -
PR Access Blog creation
=1
L. FAQs
: ;'} Forums
H i) General
:'} Home pages
L. Images
i ) Job openings
E ::i Knowledge base
i) Master templat.
i Master templates My Community Site - My Community Site - My C ity Site - My C ity Site -
: :.i Membership and security Blog posts Blogs Forum search Forums
i) Message boards
:'} My Community Site templates
L) News
Newsletter
“y Offices

ity Site
Blog list

i) Press releases

: &) Products

.y Templates with editable regio 2

Ly wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: _GroupsTemplate
e Template code name: _GroupsTemplate

m
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e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

22 Kentico

"‘ CMS Desk Content My desk Tools Administration
B L] 4 & @ B | £
New Delete |shMove & Down Edit Preview Live site List Search
Content management | View mode || other
(€} My Community Site Page  Design  Form | Propertes
‘%‘ &) Blogs General
(-3 Files E Save
o[ Forums i
[£3}
-1 Groups Template
i -[J|_GroupsTemplate Metadata Template
Ij Access Categories StarterTemplate Select
= P
-[] Create Moy : 0 )
B b 3 & | Page template - Save as new -- Webpage Dialog @
P E [ Management wors Save as newltemplate..;
i[] Home s =
- Y @ mhenttempiate .‘4 Save as new page template
] Logon page Inheritiemplate
[ Med Related docs —
;i Media . 43/ Clone template as ad-hoc
L] News Linked docs e Template display name: _GroupsTemplate
¢ [] Search Security [ Edittemplate properties Template code name: |_GroupsTemplate
Attachments Template category: My Community Site templates |Z|

This is the template for some -

Inherit content
pages of the Groups section.

@ Use page template seftings
(=) Do notinherit any content Template description

e

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Design tab. First, we will add the Group links menu into zoneRight web part zone.
The menu will contain links interconnecting particular pages of the currently displayed group like its
forums, media, etc. The menu will be created using the Static text web part. Click the Add web part (
) icon of the zoneRight web part zone and choose the Text -> Static text web part. Set the following
properties of the web part, leave the rest of them at the default values.

e Web part control ID: Links
e Text:

<a href="~/ G oups/{% omruni t yCont ext . Curr ent G oup. G oupNane% . aspx" >Hone</ a><br />
<a href ="~/ G oup- pages/ { %Conmuni t yCont ext . Curr ent G oup. G oupNane% / Pages. aspx" >
Pages</ a><br />

<a href ="~/ G oups/{ % omuni t yCont ext . Curr ent G oup. G oupNane% / Medi a- | i st . aspx" >
Medi a</ a><br />

<a href ="~/ G oups/{ % omuni t yCont ext . Curr ent G oup. G oupNane% / Menber s. aspx" >

Menmber s</ a><br />
<a href ="~/ G oups/{ % Comuni t yCont ext . Curr ent G oup. G oupNanme% / For uns. aspx" >For uns

</ a><br />

®* Web part container: Community Site - Blue Box
e Web part container title: Group links
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Click OK.

5. In zoneCenter, you first need to remove the Editable text web part that is already in the template.
Now that zoneCenter is clear, we can add Group security access web part to the top of the web part
zone. Click the Add web part () icon of the zoneCenter web part zone and choose the Community
-> Group security access web part. You do not need to set any properties of the web part. Just use the

default values and click OK.

6. The page is now finished. In Design tab, it should look as in the following screenshot.

| - jGroups/_GroupsTemplate - page template: _GroupsTemplate

B

ok

= zoneRight

e

= |ogonminiform @}
¥ Shortcuts {23

Shortcuts

My profile
Edit my profie

Create a new group
Create a new blog

7. Finally, delete the _GroupsTemplate page from the content tree. The page template will remain

saved and available.

2Y2 Kentico
#§%  CMS Desk Content | My desk

2 2 copy T up
L x]?
New [Delete] = Move & Down

Content management

d-é_"l My Community Site
- Blogs
dﬂ Files
|1|._| Forums
|;I | Groups
i ,_| _GroupsTemplate ]
-2l Access
._I Create

,_| Management

3.12.6 Creating the Profile page

The Profile page displays a profile of a group besed on the {GroupName} wildcard part of the URL, which

gets translated into a query string parameter and is then taken as the current group. More information

about wildcard URLs can be found in this chapter of Kentico CMS Developer's Guide.

The profile is displayed using the Group public profile based on the Community.Group.DisplayProfile
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alternative form. You can learn how to modify the alternative form here.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

Switch
=32 Kentico S
‘l\ CMS Desk Content My desk Tools Administration
= C U ~e
g Doy W 4 & [ = F
Delete = Mave &4 pown | Edit Preview Live site st | Search |
Content management | iew mode | other |
5 ) My Community Site » Groups

5[] Blogs -
= :'_l . New document
[+]- = Files —
,ﬂ,_] Forums
=-11/Groups Please select new document type:

‘—] (e [[) Page (menu item)

i|d] Create
: :_----,_] Management = Article
-] Home —
I_] Logon page Ealﬂ

2 B cell phone
L] News | Event

I_] Search

I Event (booking system)

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Profile and click Save.

N Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3638
-
#1%  CMS Desk Content | Mydesk  Tools  Administration
> ) [ U .
2 & Bl 2 & @ B | L
New Delete = Move & pown | Edit Preview Live site Lst || search |
Content management | View mode Other
(-6 My Community Site » Groups
(-] Blogs
a ’\S Files E‘ Save and create another
(©-L] Forums
=-]|Groups Page name: Profile
|4 Access
: |_I Create @ Use pagetemplate () Inheritfrom parentpage () Create a blank page
.| Management _ R
B Home o-& All page templates Template name:
L.y Articles
|| Logon page =
3 Media : @) Blank pages for widgets
[] News : ‘_ﬂ Blogs
[ Search i) Community Site
£ Corporate Site ASPX
:.ia) E-commerce
: :ﬂ Events _GroupsTemplate _StarterTi My C ity Site - My C ity Site -
- Access Blog creation
i) FAQs
: ;'} Forums
H i) General
:'} Home pages
& Images
Job openings
Knowledge base
i3 Master ts |3t
: ) Master templates My Community Site - My Community Site - My C ity Site - My C ity Site -
: d Membership and security Blog list Blog posts Blogs Forum search
i) Message boards
i) [My Community Site templates
L) News
b)) Newsletter
E ::i Offices
i) Press releases
: ;'} Products
.y Templates with editable regio
L) wiki _GroupsTemplate

This is the template for some pages of the Groups section.

Sign out

m
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Groups profile
Template code name: MyCommunitySite.GroupsProfile
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

] Switch to Site Manager Site: My Community Site User: Global Administrator v5.0.
=¢= Kentico [=] v

"‘ CMS Desk Content Mydesk  Tools Administration

_x [ Copy T up ¥ @ p

N;N De\éte = Move & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
(26} My Community Site Page  Design  Form | Properties
‘ﬂ Il Blogs General
(&[] Forums =
8 :I Groups Template
: |_] Access Metadata Template
[ create Categories _GroupsTemplate Select
[l Management Menu ( N
S5 1| | &] Page template - Save as new -- Webpage Dialog ﬁ
: _:"'._] Profile i #;Save as newtemplate, ! =
] Home 2 ooy =
| 3l Lonom page Versio @ et ot (=g Save as new page template
g u:l Med Related docs —
il Media ) 4= Clone template as ad-hoc
o[ News Linked docs = Template display name: My Community Site - Groups profile
‘| search Security E Edittemplate properties Template code name:  MyCommunitySite. GroupsProfile
Attachments Template category My Community Site templates E
Inherit content This is the Groups profile page =
@ Use page template settings of My Community Site.
H ) Do natinherit any content Template description

(@) Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName} into the Document URL path
field and click Save.
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Switch to Site Manager  Site: | My Community Site
232 Kentico v ty Ste =]
’.‘ CMS Desk Content My desk Tools Administration
Ci u e &
5 [ Boer R (4 [d F
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
C.l'{“_;'l My Community Site Page Design Form Properties
'1"_',_?]_‘ Bllogs General |
g Fles
T = URLs
[#--|| Forums
|:||_] Groups Template
i L[] Access Metadata path
B Categaries Document alias: Profile
Menu Document URL path: |/Groups/{Grouplame}
Workflow Use custom URL path
2 | Versions
ogon page -
2 ™ gd =L Related oot Extended properties
ELE URL extensions:
Linked docs

E = X [[luse custom URL extensions
|_] Search Security

Attachments

Track campaign:

5. Switch to the Design tab. We will start with zoneRight web part zone. Below the Group links info
box, we will add two more info boxes. The first one of them will be displaying the current group's
administrators. Click the Add web part () icon of the zoneRight web part zone and choose the
Community -> Group members viewer web part. Set the following properties of the web part, leave
the rest of them at the default values.

Web part control ID: GroupMembersAdministrators

Transformation name: Community. Transformations.MembersPreviewList
No record found text: There are currently no administrators.

Show filter: disabled

WHERE condition:

Menber User ID | N ( SELECT User| D FROM CVB_User Rol e WHERE Rol el D I N ( SELECT Rol el D
FROM CVB_Rol e WHERE Rol eG oupl D = ' { %Communi t yCont ext . Current G oup. G oupl D%4' AND
Rol el sG oupAdmi ni strator = 1))

® Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatarlD,UserCreated,
UserName, AvatarGuid

e Web part container: Community Site - Red Box
e Web part container title: Group administrators

Click OK.

6. Below the group administrators, we will add the same Group members viewer web part, but this
one will be displaying the latest 5 approved members of the group. Click the Add web part () icon of
the zoneRight web part zone and choose the Community -> Group members viewer web part. Set
the following properties of the web part, leave the rest of them at the default values.

e Transformation name: Community.Transformations.MembersPreviewList

e No record found text: There are currently no members.
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e Show filter: disabled

e ORDER BY condition: MemberApprovedWhen DESC

e Select Top N members: 5

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatarlD,UserCreated,
UserName, AvatarGUID

e Web part container: Community Site - Red Box
e Web part container title: Group administrators

Click OK.

7. The zoneRight web part zone is finshed, so let's move to zoneCenter. To the top of the web part
zone, we will add a breadcrumbs heading using the Breadcrumbs web part. Click the Add web part (
4k) icon of the zoneCenter web part zone and choose the Navigation -> Breadcrumbs web part. Set
the following properties of the web part, leave the rest of them at the default values.

e Breadcrumb separator: <span class="TitleBreadCrumbSeparator'>&nbsp;</span>

e Content before: <div class="GroupBreadcrumbs">
e Content after: </div>

Click OK.

8. Below the breadcrumbs, we want the group's public profile to be displayed. This can be achieved
using the Group public profile web part, which displays the group's public profile based on the
specified alternative form. By default, the Community.Group.DisplayProfile alternative form is used. Click
the Add web part () icon of the zoneCenter web part zone and choose the Community -> Group
public profile web part. You do not need to set any properties of the web part. Just use the default
values and click OK.

9. Below the Group public profile, we will add a message board where group administrators will be able
to leave announcements. Click the Add web part (#) icon of the zoneCenter web part zone and
choose the Community -> Group message board web part. Set the following properties of the web
part, leave the rest of them at the default values.

e Message transformation: Community.Transformations.MessageBoardComments

e No messages text: There are no announcements at this time

e Display name: Group {%CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%} board
e Access: Only group admin

e Enable subscriptions: enabled

e Board base URL: ~/Groups/Profile.aspx

e Web part container: Community Site - Blue Box Light

e Web part container title: Group announcements

Click OK.

10. Now we will add a Group forum posts viewer. This web part will be set so that it will display the 5
latest posts in the group's forums. Click the Add web part (4) icon of the zoneCenter web part zone
and choose the Community -> Group forum posts viewer web part. Set the following properties of the
web part, leave the rest of them at the default values.

e Transformation name: Community. Transformations.ForumGroupPostsList
e Top N: 5
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Order by: PostTime DESC

Selected columns: PostIDPath,PostForumID,PostText,PostTime,PostSubject
Hide if no record found: disalbed

e No record found text: There are currently no posts.

Web part container: Community Site - Blue Box Light
Web part container title: Latest in forums

Click OK.

11. The last web part on the page will be a Repeater displaying articles in the Group pages section.
Click the Add web part (4) icon of the zoneCenter web part zone and choose the Listings and
viewers -> Repeater web part. Set the following properties of the web part, leave the rest of them at the
default values.

e Web part control ID: MostRecentPages

e Path: /Group-pages/{%Community Context.CurrentGroup.GroupName%}/Pages/%
e Document types: CMS.SimpleArticle

e ORDER BY expression: DocumentCreatedWhen DESC

e Transformation: CMS.SimpleArticle.SimplePreview

e Selected item transformation: CMS.SimpleArticle.Default
e Hide if no record found: disabled

e No record found text: There are currently no pages.

e Web part container: Community Site - Blue Box Light

e Web part container title: Most recent pages

e Content before: <div class="GeneralList">

e Content after: </div>

Click OK.

12. The page is now finished. In Design tab, it should look as in the following screenshot.

|V JGroups [ Profile - page template: My Community Site - Groups profile y|
= zoneCenter *
= zoneRight
|' GroupSeq.nntyﬁccEss @| = +
""" = |ogonminiform g:}
¥ breadcrumbs @} e @
- 0| i n
= GroupPublicProfile @} ' %
My profile
¥ GroupMessageBoard @ Edit my profie
|V GroupForumPostsViewer @}| %"ﬁﬁ
Latest in forums My invitations

Create a new group
Create a new blog
Sign out

[There are currently no posts.

Most recent pages
Group finks

[There are currently no pages.

|
|V GroupMembersAdministrators @

|V GroupMembersViewer 1 @}| ‘
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3.12.7 Creating the Members page

On the Members page, users of the current group will be displayed. This will be achieved using the
Group members viewer web part.

If you right-click a user, you will be offered some actions by a context menu. This functionality is
provided in the transformation and here, you can find a description of how exactly it is achieved.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

-‘!’. Kentico Switch
1% CMS Desk Content My desk  Tools Administration

> c u = =

3 ) g ey Fuw (4 [d ~r

New | Delete |= Move & Down | Edit Preview Live site List | Search |
Content management ‘iew mode | Other
= ) My Community Site » Groups

3-[.] Blogs Y

T :‘—l ) New document

B Files =l

-] Forums

-2l [Groups Please select new document type:

j (e [ Page (menu item)
-] Create

I_] Management

| I_] Profile S amde

|_] Home ] Blog

|_] Logon page 3 Cell phone

[ Media @ Event

j :::’ih & Event (booking system)
[ Ja\e]

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Members and click Save.
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22 Kentico Switeh to Site Manager

#1%  CMS Desk Content | My desk

5% [ Copy T up w
& Down Edit Search

Content management

Tools Administration

[ B &

New Delste = Move Preview Livesite  List

View mode Other

=] n_;_;l My Community Site
(x-l] Blogs
(-G Files
(#-l.] Forums
(=]-|] (Groups
E ._I Access
+|] Create
i-[] Management
E I_| Profile
-] Home
-] Logon page
] Media
-] News
|| Search

» Groups

Page name: MVembers

E‘ Save and create another Spell check

@ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

2]

=

=

ity Site -

m

ity Site -

_GroupsTemplate _StarterT: My C ity Site - My C
Access Blog creation
N
Lhy Knowledge base
Master ts |3t
QY Master templates My Community Site - My Community Site - My C: ity Site - My C
&) Membership and security Blog list Blog posts Blogs Forum search
“J Message boards
“.&) [My Community Site templates
_GroupsTemplate

This is the template for some pages of the Groups section.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Group members
Template code name: MyCommunitySite.GroupsMembers
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.
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] Switch to Site Manager Site: My Community Site User: Global Administrator v5.0.
=¢= Kentico [=] v

"‘ CMS Desk Content Mydesk  Tools Administration

[ Copy T up ¥ @ p

New Delete |=bMove & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other |
(26} My Community Site Page  Design  Form | Properties
‘;‘ ] Blogs General
@ o Fes
B URL:
[#-] Forums 2
5[] Groups Template
i [l Access Metadata Template
2 Categories _GroupsTemplate Select
| Management Menu - - : @
~ 5 3 £ | Page template - Save as new -- Webpage Dialog
!_.] Members Wi ;Save as newtemplate,.! =
-] Profile 3 = £
3 Home Versions @ et ot /=g, Save as new page template
g Related docs .
|| Logon page ; 4+ Clone template as ad-hoc
Sl Media Lrked = Template display name: |My Community Site - Group members
[0 News Security [ Edittemplate properties Template code name:  |MyCommunitySite GroupsMembers
“ ] search Attachments Template categary: My Community Site templates [=]
Inherit content This is t,}_ue Gr?up members page of =
@ Use page template settings My Community Site.
H ) Do natinherit any content Template description:
(@) Selectinherited levels
hitp://localk € Local intranet | Protected Mode: Off

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Members into the Document
URL path field and click Save.

Switch to Site Manager  Site: | My Community Site
232 Kentico y ty site[ =]
‘l\ CMS Desk Content My desk Tools Administration
Ci u &
S [ Boer [4  [d A
MNew Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
|:'l'{l_;'] My Community Site Page Design Form Properties
'1"_‘,_?]\_‘ B.Iogs General |
- Files 7 E Save
[#-|| Forums s
B =" Template
=] Groups
i -] Access Metadata Path
;_'] Create Categories Document alias: Members
!__] Management Menu Document URL path: | /Graups/{GroupName)/Members
“[]|Members Workflow Use custom URL path
| Profile 3
B h Versions
!—.] ome Related docs Extended properties
5__] Logon page . URL extensions:
Media ke GoE
!—.] E [l use custom URL extensions
L] News Security .
- Track campaign:
‘|| Search Attachments

5. Switch to the Design tab. We can leave zoneRight as it is and go straight to zoneCenter. First, we
will add a breadcrumbs heading using the Static text web part. Click the Add web part (%) icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties of
the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
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e Text:

<di v cl ass="G oupBreadcr unbs" >

<a href="~/ G oups. aspx" cl ass="CVBBreadCrunbsLi nk">G oups</ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Communi t yCont ext .
Current G oup. G oupNane% . aspx" cl ass="CVBBr eadCr unbsLi nk" >{ %Communi t yCont ext .
Current G oup. G oupD spl ayNane| (encode) t rue% </ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span cl ass="CVSBr eadCr unbsCurrent | t ent >
{ ¥€VsCont ext . Cur r ent Docunent . Docunent Nane| (encode) true% </ span>

</ di v>

Click OK.

6. Below the heading, it will be useful to add some info text. We will use the Editable text web part for
this purpose. Click the Add web part () icon of the zoneCenter web part zone and choose the Text -
> Editable text web part. You do not need to set any properties of the web part, just leave all of them at
the default values.

Click OK.

7. Switch to the Page tab and enter the following text into the Editable text web part's text area.

Bel | ow you can find |ist of group nenbers. R ght click the user to get avail able
actions.

Click Save.

8. Switch back to Design tab. Now we will add the Group members viewer web part, which displays
members of the current group. Click the Add web part () icon of the zoneCenter web part zone and
choose the Community -> Group members viewer web part. Set the following properties of the web
part, leave the default values for the rest of them.

e Transformation name: Community. Transformations.MembersList

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatariD,
UserActivityPoints,UserName, AvatarGuid

e Page size: 9

e Paging mode: PostBack

e Group size: 9

e Web part container: Community Site - Blue Box Light
e Web part container title: All members

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.
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| - /Groups/Members - page template: My Community Site - Group members

B

3.12.8 Creating the Media list page

* zoneCenter +
= zoneRight
|' " GroupSecurityAccess @| _ Gl
v logonminiform {23
¥ Breadcrumbs @} — @
i _' o n
+ editabletext @ of group members. Right dick the user to get available actions. Shortcuts
_ My profile
|V GroupMembersViewer ’,&M Edit my profile
My messages
My friends
My invitations

Create a new group
Create a new blog

Groups can have any number of media libraries. Because of this fact, we will create the Media list page.
On this page, a list of all media libraries of the current group will be displayed by the Group media
libraries viewer web part. After clicking a media library, users will be redirected to the Media page,
created in this chapter, where the content of the library will be displayed.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

=32 Kentico
’.‘ €MS Desk Content My desk Tools
(5 Copy i ue ¥

& Down Edit

Content management

Administration

[d [ E

Preview Live site List

x

New [Delete |=Move

View mode

.;l-é_"l My Community Site v Groups

3-[] Blogs N

iy ;J, Files New document

3R]

¢I._I Forums

|:I._| Groups Please select new document type:
L icceis [ Page (menu item)
-] Create

J Management

- =1 Article
-] Members
“.[] Profile Y Blog

Switch

A

Search
Other

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the

Page name field, enter Media list and click Save.
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Switch to Site Manager  Site: | My Community Site User: Global Administrator ¥5.0.3682
242 Kentico v ¢ Site[x]
#1% CMS Desk Content | Mydesk  Tools  Administration
2 [ U
) [k B T 4  [d = .
New Delete =Move & Down Edit  Preview Livesite  List Search
Content management View mede Other
=4} My Community Site » Groups

-] Blogs
(-5 Files
-] Forums
(=)-1] (Groups
[0 Access
: I_| Create
[ 1] Management
g I_| Members
[ profile
| Home
-] Logon page
| Media
-] News
|| Search

E‘- Save and create another Spell check

Page name: Media list

@ Use pagetemplate () Inheritfrom parentpage () Create a blank page

54 All page templates
& Articles
“J Blank pages for widgets

Template name:

“ Community Site
= & Corporate Site ASPX
&) E-commerce

Sign out

2]

==

=

Site -

m

ity Site -

_ GroupsTemplate _ StarterT: My Ci ity Site Ci y Sil
Access Blog creation
f
My Community Site - My Community Site - My C: ity Site - My C
Blog list Blog posts Blogs Forum search
12
_GroupsTemplate

This is the template for some pages of the Groups section.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the

Click OK. Click Save.

pop-up dialog:

Template display name: My Community Site - Media list
Template code name: MyCommunitySite.MediaList
Template category: My Community Site templates

Template description: some text describing the page template
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-‘1,- Kenti.co Switch to Site Manager  Site: My Community Sitelzl User: Global Administrator v5.0
‘.‘ CMS Desk Content My desk Tools Administration
Ci Ui g o
2 g Bow 1w 4 [d 2 | R
New Delete | =¢Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
E‘"Y“‘_.,'J My Community Site Page Design Form Properties
v a B.Iogs General
(- Files
: URL:
[#)-] Forums :
d ;_] Groups Template
[0 Access Metadata Template
,_] Create Categories _GroupsTemplate Select
-] Management Menu ( : N
[ [Media list - e e R | Page template - Save as new -- Webpage Dialog ﬂ
-[[] Members v =
Q) Profile Vers @ mherttempiate (=, Save as new page template
H BH Related docs .
i il Home ; 43/ Clone template as ad-hoc
] Logon page Linked docs & Template display name: My Community Site - Media list
L] Media S E Edit template properlies Template code name:  MyCommunitySite MediaList
: j Newsh Attachments Template category: My Community Site templates [=]
§ Seardl
This is the Media list page of My =~
Inhert content = .
H @ Use page template settings Community Site.
) Do natinheritany content Template description:
) Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Media-list into the Document
URL path field and click Save.

Switch to Site Manager  Site:| My Community Site
232 Kentico " ty Site =]
’l‘ CMS Desk Content My desk Tools Administration
3 2 C U = r
ERE e T [d] p
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
|:'|'{l‘_."l My Community Site Page  Design  Form | Properties
d_‘;l B_logs General |
(+)- Files E Save
T = URLs =
[#--|| Forums
|:l|_] Groups Template
i L[] Access Metadata Path
Create Categories Document alias: Media-list
-] Management Menu Document URL path: |/Groups/{GroupMame)/Media-list
!—.1 Media list Workflow Use custom URL path
] Members 3
= Profile Versions
& Pro Related i Extended properties
URL extensions:
Linked docs
X [l use custom URL extensions
Security .
Track campaign:
Attachments

,_] Search

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Static text web part.
Click the Add web part (4F) icon of the zoneCenter web part zone and choose the Text -> Static text
web part. Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
e Text:
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<di v cl ass="G oupBreadcr unbs" >

<a href="~/ G oups. aspx" cl ass="CVBBreadCrunbsLi nk">G oups</ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Communi t yCont ext .
Current G oup. G oupNane% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %Comuni t yCont ext .
Current G oup. G oupD spl ayNane| (encode) t rue% </ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span cl ass="CVSBr eadCr unbsCurrent | t ent >
Medi a </ span>

</ di v>

6. Now we will add some info text using the Editable text web part. Click the Add web part () icon of
the zoneCenter web part zone and choose the Text -> Editable text web part. You do not need to set
any properties of the web part, just leave all of them at the default values.

Click OK.

7. Switch to the Page tab and enter the following text into the Editable text web part's text area.
Bel | ow you can find |ist of group nedia libraries.

Click Save.

8. Switch back to Design tab. We will add the Group media libraries viewer web part. Click the Add
web part (%) icon of the zoneCenter web part zone and choose the Community -> Group media
libraries viewer web part. Set the following properties of the web part, leave the default values for the
rest of them.

e Hide if no record found: disabled
e No record found text: There are currently no media libraries.

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.

|V /Groups/Media list - page template: My Community Site - Media list y|
w zoneCenter * = zoneRight +
w {iGr ityAccess i =
| Lot z‘?M = |ogonminiform ’te‘z,!
¥ Breadcrumbs (i3 ~ shortauts
or .
- editabletext @ of group media libraries. %
My profile
|V GroupMediaLibrariesViewer ’ty}| Edit my profile

My Community Site...

My messages

My friends

My invitations
Create a new group
Create a new blog

This is the global media library of M...
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3.12.9 Creating the Media page

When a user clicks a media library in a list on the Media list page, created in the previous chapter, they
are redirected to this page where the Media gallery web part displays the content of the selected
library. The name of the library is passed in the {GroupName}/{LibraryName} wildcard part of the URL of
this page. Then it gets translated into a query string parameter and displayed by the Media gallery web
part as the current group.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

Switch
232 Kentico
'l‘ C€MS Desk Content My desk Tools Administration
2 C u = —
El B L (4 [d P
New | Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
() My Community Site » Groups
3-[.] Blogs -,
'—' _‘;l ) New document
[+ Files =
[-|] Forums

= [ 1/Groups Please select new document type:
© L[] Access

I_] Create

I_] Management

|1 Page (menu item)

p= L = Article
~] Media list .
-] Members ] 8log
[ Profile 5 Cell phone

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Media and click Save.
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22 Kentico
#1% CMS Desk

Content My desk Tools Administration
2 c U
) [k B T 4  [d =
New Delete = Move & Down Edit  Preview Livesite  List

Content management

n:/';") My Community Site
-] Blogs
(-5 Files
-] Forums
(=)-1] (Groups
[0 Access
: I_| Create
[ 1] Management
g I_| Media list
[ Members
E I_| Praofile
-] Home
| Logon page
-] Media
] News
-] Search

View mode

» Groups

E‘- Save and create another

Switch to Site Manager

Search
Other

Spell check

Page name: Media
@ Use page template
54 All page templates

& Articles
“J Blank pages for widgets

“ Community Site
= & Corporate Site ASPX
&) E-commerce

() Inherit from parent page

() Create a blank page

Template name:

Site:| My Community Site[+| User: Global Administrator v5.0.3688

Sign out

2]

==

=

Site -

m

ity Site -

_ GroupsTemplate _ StarterT: My Ci ity Site Ci y Sil
Access Blog creation
My Community Site - My Community Site - My C: ity Site - My C
Blog list Blog posts Blogs Forum search
12
_GroupsTemplate

This is the template for some pages of the Groups section.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Group media
Template code name: MyCommunitySite.GroupMedia
Template category: My Community Site templates

Template description: some text describing the page template
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-\='- Kentl.co Switch to Site Manager  Site: | My Community Site[+] User: Global Administrator v5.0.
#1% CMS Desk Content  Mydesk  Tools  Administration

E ooy WU 4 [ yo)
New Delete = Move & Down | Edit Preview Live site List Search ‘
Content management View mode | Other

(=4 My Community Site Page  Design  Form | Properties

';/ ‘—I B.Iogs General
-G Files e
(-] Forums 2
d u:l Groups Template
¢ L) Access Metadata Template
-] Create Categories _GroupsTemplate Select
,:1 Management Menu ( N N
I:] Media i e E e R & | Page template - Save as new -- Webpage Dialog ﬂ
= Workflow _
Media list =
-_1 Versions @ hen empiate .‘4 Save as new page template
-] Members Aherllempate
C L profil Related docs .
. |1 Profile n &/ Clone template as ad-hoc
¢ Home Lok=CLES =~ Template display name: My Community Site - Group media
_I Logon page Security E Edittemplate properties Template code name:  MyCommunitySite. GroupMedia
g j Media Attachments Template category: My Community Site templates [=]
News — =
g 1) search Inherit content ;hlimln:ui:: g;‘i:“:i Media page of 1
H @ Use page template settings ¥ ¥ "
) Do netinherit any content Template description
) Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Library-{LibraryName} into the
Document URL path field and click Save.

-\2'- Kel'lthO Switch to Site Manager  Site:| My Community SiteEl
#p% CMS Desk

Content My desk Tools Administration

R [q] ye
New Delete |= Move & pown | Edit Preview Live site List | Search |
Content management View mode | other |

cl!l_’l My Community Site Page Design Form | Properties

(-] Blogs

lﬂ{j‘ Fles . |
T URLs

[#-|| Forums

clnj Groups Template
i o] Access Metadata Path

Create Categories Document alias: Media

L] Management Menu Document URL path: |/Groups/{GrouplName)/Library-{LibraryMame}
Media Workflow Use custom URL path

‘J :::::;Irsst Versions )

B Profie Relateddate Extended properties

i — ; URL extensions:
[ ] Home Linked docs

,:] Logon page Security
Attachments

[l use custom URL extensions
Track campaign:

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Static text web part.
Click the Add web part (4F) icon of the zoneCenter web part zone and choose the Text -> Static text
web part. Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
* Text:
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<di v cl ass="G oupBreadcr unbs" >

<a href="~/ G oups. aspx" cl ass="CVBBreadCrunbsLi nk">G oups</ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Communi t yCont ext .
Current G oup. G oupNane% . aspx" cl ass="CVBBr eadCr unbsLi nk" >{ %Communi t yCont ext .
Current G oup. G oupD spl ayNane| (encode) t rue% </ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span cl ass="CVSBr eadCr unbsCurrent | t ent >
{ ¥€VsCont ext . Cur r ent Docunent . Docunent Nane| (encode) t rue% </ span>

</ di v>

Click OK.

6. Below the breadcrumbs, we will add another Static text web part. This one will provide a link back to
the list of the group's media libraries. Click the Add web part () icon of the zoneCenter web part
zone and choose the Text -> Static text web part. Set the following properties of the web part, leave the
rest at the default values.

e Web part control ID: BackLink
e Text:

<a style="margin: 20px Opx Opx 98px;" cl ass="Medi aBack" href="~/ G oups/{%
Communi t yCont ext . Curr ent G oup. G oupNane% / Medi a- Li st. aspx">Back to |ibraries</a>

Click OK.

7. The last web part in zoneCenter will be the Media gallery web part. This web part displays content of
the particular libraries based on the library name passed in query string. Click the Add web part (<)
icon of the zoneCenter web part zone and choose the Media library -> Media gallery web part. Set
the following properties of the web part, leave the rest at the default values.

Show subfolders content: enabled

Hide folder tree: enabled

Content before: <div style="padding: 10px Opx Opx 100px">
Content after: <div class="clear"></div></div>

Click OK.

8. The page is now finished. In Design tab, it should look as in the following screenshot.
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|V JGroups{Media - page template: My Community Site - Group media y|
= zoneCenter *
= zoneRight
|' HEGroupSeG.nrityhmess %Za_;‘}| _a *
= |ogonminiform {g‘,!
¥ Breadcrumbs @,! T @3
- 0| n
S
<t Back to libraries My profile
Edit my profile
T MediaGallery @‘! My messages
My friends
My invitations

Create a new group
Create a new blog

Sign out

3.12.10 Creating the Forums page

The forums page will provide the group forums functionality using the Group forum list web part. It will
display the content of the group forums based on the {GroupName} wildcard part of the URL.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

-‘!’- Kentico Switch

#1% CMS Desk Content My desk  Tools Administration

* [ Copy T up 2 @ = )3

New | Delete [=h Move & Down Edit Preview Live site List Search
Content management iew mode Other
(=4 ) My Community Site ¥ Groups
3-[2] Blogs N
= New document
[+]- 0 Files
[&)-|] Forums
|| Groups Please select new document type:
i [ Access

|| Page (menu item)

l_'j Create

=l Management = Article

.| Media
[0 Media list ' Bloa
._l Members 9 Cell phone
:.----l_j Profile ¥ Event

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Forums and click Save.
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Switch to Site Manager

22 Kentico
#1% CMS Desk Content | Mydesk  Tools  Administration

2 [ U

) [ B #w 4 & B = |

New Delete =Move & Down Edit  Preview Livesite  List Search

Content management View mode Other
=4 ) My Community Site » Groups

Site: | My Community Site[+]| User: Global Administrater v5.0.26288

Sign out

ity Site -

m

=1 | Blogs
a & Files - E‘ Save and create another Spell check
-] Forums
(=)-| (Groups Page name: Forums
[ Access
H ._I Create @ Use page template () Inheritfrom parent page () Create a blank page
[ ] Management e R
[ Media (2 All page templates Template name:
o[ Media list ) Articles
: ._I e &3 Blank pages for widgets
[ Profile :
I Home & Community Site
[8 Logon page ® &) Corporate Site ASPX
) Mod i) E-commerce
= Media : _GroupsTemplate _StarterTi My C ity Site - My C
-] News Access Blog creation
|| Search
]
My Community Site - My Community Site - My C ity Site - My C
Blog list Blog posts Blogs Forum search

12

_GroupsTemplate

This is the template for some pages of the Groups section.

ity Site -

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Group forums

Template code name: MyCommunitySite.GroupForums
Template category: My Community Site templates

Click OK. Click Save.

Template description: some text describing the page template
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Switch to Site Manager  Site: My Community Site User: Global Administrator ¥5.0
.:!:. Kentico v o site[=] "

CMS Desk Content My desk Tools Administration

[=H copy I up » @ /O

N;N‘ De\éte = Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
(26} My Community Site Page  Desgn  Form | Properties
‘ﬂ ] Blogs General
()] Forums =
8 3 Groups Template
i [ Access Metadata Template
|| Create Categories _GroupsTemplate Select
- ||Forums . ( N
'—] e s i e & Page template - Save as new -- Webpage Dialog @
-] Management Workfow (53l Bave as newlemplate.; =
-] Media s =
B modia st Voo T /=gl Save as new page template
:] Memb Related docs .
il Members ; 43/ Clone template as ad-hoc
-] profile Linked docs = Template display name: My Community Site - Group forums
i1 Home Security E Edit template properties Template code name: | NyCommunitySite. GroupForums
: j Logon page Attachments Template category: My Community Site templates E
Media ——
:] News Inherit content This is t},‘E Gz?up forums page of -
= _ " My Community Site.
H [l Search H @ Use page template seftings
) Do netinheritany content Template description

() Selectinherited levels

http://localk € Local intranet | Protected Mede: Off

4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Forums into the Document URL
path field and click Save.

N2 Kel'lti.CO Switch to Site Manager  Site:| My Community SiteE
-y
#9% CMSDesk Content My desk Tools Administration
=) =] Co U ri
5 5 By #w 7 @ @ B2 | A,
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
=) My Community Site Page  Design  Form | Properties
'1“—] B_|OQS General |
-G) Files
= URLs
[--L] Forums
B lj Groups Template
] Access Metadata Path
7 Create Categories Document alias: Forums
-] /Forums Menu Document URL path: |/Groups/{GroupMame)/Farums
| Management Viorkiog Use custom URL path
Media 2
> Media list Versions
ELELE Related docs Extended properties
| Members s URL extensions:
-] Profile e
a E [l use custom URL extensions
| Home Security )
Track campaign:
|| Logon page Attachments

5. Switch to the Design tab. We will leave zoneRight web part zone as it is and start modifying
zoneCenter right off. First, we will add a breadcrumbs heading using the Static text web part. Click
the Add web part (4) icon of the zoneCenter web part zone and choose the Text -> Static text web
part. Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
e Text:
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<di v cl ass="G oupBreadcr unbs" >

<a href="~/ G oups. aspx" cl ass="CVBBreadCrunbsLi nk">G oups</ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Communi t yCont ext .
Current G oup. G oupNane% . aspx" cl ass="CVBBr eadCr unbsLi nk" >{ %Communi t yCont ext .
Current G oup. G oupD spl ayNane| (encode) t rue% </ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span cl ass="CVSBr eadCr unbsCurrent | t ent >
{ ¥€VsCont ext . Cur r ent Docunent . Docunent Nane| (encode) t rue% </ span>

</ di v>

Click OK.

6. Below the breadcrumbs, we will add the Forum search box web part that will enable users to search
the forum content. Click the Add web part (%) icon of the zoneCenter web part zone and choose the
Forums -> Forum search box web part. Set the following properties of the web part, leave the rest at
the default values.

e Content before:

<di v cl ass="For unBSear chBox" ><t abl e cel | spaci ng="0" cel | paddi ng="0"><t r ><t d><b>
Sear ch forums: &bsp; </ b></t d><t d>

* Content after:

</td></tr></tabl e></di v><div cl ass="cl ear"></div>

Click OK.

7. The forum functionality itself is provided by the Group forum list web part. This is the only web part
that is needed for the whole forums structure, all forum content will be displayed from this page by this
web part. Click the Add web part (%) icon of the zoneCenter web part zone and choose the
Community -> Group forum list web part. Set the following properties of the web part, leave the rest at
the default values.

e Groups separator: <br />
e Base URL: ~/{%CommunityContext.CurrentGroup.GroupName%}/Forums.aspx
e Unsubscription URL: ~/Special-Pages/Forum-Unsubscribe.aspx

Click OK.

8. In step 6, we added the Forum search box web part to the page. Now we need to add another web
part to the page where the search results will be displayed. This can be achieved by the Group forum
search results web part. Click the Add web part () icon of the zoneCenter web part zone and
choose the Community -> Group forum search results web part. You do not need to set any
properties of the web part, just leave all of them at the default values.

Click OK.

9. The last web part in this web part zone will be the On-line users web part. It will be set up so that it
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displays the number of users currently accessing the group's forum section. Click the Add web part (4
) icon of the zoneCenter web part zone and choose the Membership -> On-line users web part. Set
the following properties of the web part, leave the rest at the default values.

e Transformation name: Community. Transformations.MembersOnline
e Path: /Groups/{GroupName}/Forums

e Use default cache dependencies: enabled

e Content before: <br />

Click OK.

10. The page is now finished. In Design tab, it should look as in the following screenshot.

|V JGroupsfForums - page template: Community Site - Group forums y|
T zoneCenter
...... = * ¥ zoneRight +
|V i iGroupSecurityAccess §§,§| =
------ = |ogonminiform @
-
(o v Shorteuts {23
¥ ForumSearch @‘g %
=S oo My profile
Edit my profie
¥ GroupForumList i My messages
My friends
|V GroupForumSearchResults ’@,!| My invitations
- Create a new group
| :
b users ondine. Create a new blo
Sign out
Group finks
Home
Pages
Media
Members
Forums

3.12.11 Preparing the Group pages section

3.12.11.1 Creating the Template page

This page is a special one. It will be used as a template for the group pages section, which is created for
each group under a specified page of the content tree, which we will create in this chapter. The group
pages section enables members of a group to create and edit articles related to the group and displayed
within the group's section.

On this page, there will be a Repeater displaying a list of articles of the particular group. This page will
also be used as a master page for the Pages page, which will be displaying the particular articles
placed under it. The Pages page will be created in the following chapter.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.
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Switch
232 Kentico e
'l‘ CMS Desk Content My desk Toaols Administration
=] | C U ~
)5 Oer e | [ [ @ B L
New |Delete = Move 4 Down Edit Preview Live site List Search
Content management | iew mode Cther
() My Community Site > Groups

-2l Blogs
¢|”£j‘ Files
&[] Forums

Groups

> New document

Please select new document type:

|1 Page (menu item)

') Blog
8 Cell phone
P Event

¥ Event (booking system)

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Template and click Save.

Suiteh to Site Manager  Site: | My Community Site
242 Kentico i by sitex]
#1% CMS Desk Content | Mydesk  Tools  Administration
. oL 2 & B = | L
New Delete oMove & Down | Edit  Preview Liveste Lst | Search |
Content management | View mode Other
=4} My Community Site » Groups

-] Blogs
(-5 Files
[#-.] Forums
=-1]/Groups
[0 Access
: ,_I Create
|] Forums
: ,_I Management
o[ Media
g ,_I Media list
[ Members
E ,_I Praofile
-] Home
|| Logon page
-] Media
] News
-] Search

- E‘ Save and create another

Page name: Template

Spell check

@ Use pagetemplate () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:

“J Blank pages for widgets

&) Community Site
(i3 Corporate Site ASPX
@) E-commerce

User: Global Administrator v5.0.3688

Sign out

=

ity Site -

m

ity Site -

_ GroupsTemplate _ StarterT: My Ci ity Site - My C
Access Blog creation
i
“J Knowledge base
Master ts |3t
) Master templates My Community Site - My Community Site - My C: ity Site - My C
&) Membership and security Blog list Blog posts Blogs Forum search
“J Message boards
“J My Community Site templates
12

&) Templates with editable regio _GroupsTemplate

& wiki

< I, | »

This is the template for some pages of the Groups section.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Group pages template
e Template code name: MyCommunitySite.GroupPages Template
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e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager Site: My Community S\teEI User: Global Administrator v5.0.

212 Kentico

#4% CMS Desk Content | Mydessk  Toals Administration
B R Do fw 4 [d L
New Delete | =¢Move & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other |
(26} My Community Site Page  Desian  Form | Properties
‘5 L] Blogs General
£ URLs
.| Forums
1) Groups Template
LB Metadata Template
Categories _GroupsTemplate W
Menu

£ Page template - Save as new -- Webpage Dialog @

._] Management ave s newlemplate

H Workflow =

L] Media 3 2 I=

= ' Versions @ Imentendat /. Save as new page template

o] Media list

g 1_1 Memb Related docs .

il Members g &/ Clone template as ad-hoc

] Profila Linked docs = Template display name: My Community Site - Group pages template
i -[STemplste o (B Edittemplate properies Template code name:  |MyCommunitySite.GroupPagesTemplate
j iome Attachments Template categary Wy Community Site templates [~
; ogon page -
: ;_I Media Inherit content This the E_%qup_pages template of -
[ News H @ Use page template settings My Community Site.
"] search @ Do natinherit any content Template description:

(@) Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Still on the Properties tab, click the Edit template properties link. In the pop-up window, scroll
down and check the Show as master template option. Also change the inheritance so that the page
template inherits from Level 0 and Level 2. Click Save in the pop-up window to save the changes and
close it.
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& | Page Templates - Webpage Dialog M

¢j Page template properties @
Templates » My Community Site - Group pages template

General Sites Layout Web parts Header Documents

Template display name: My Community Site - Group pages template

Template code name: MyCommunitySite. GroupPagesTemplate
Category: My Community Site templates [~]
Template description: This the Group pages template of -

My Community Site.

Thumbnail Upload:

Template type: @ Portal page () ASPX page

m

[Showas master template: I
Inherit content: ) Inherit all

Do notinherit any content

@ Selectinherited levels

----- Levell
|:| Levell
Level2
“[ Lever3
[ Levela
I Levels -
http://localhost/kenticocms/CM5Modules/PortalEngine/Ul/Page € Local intranet | Protected Mode: Off

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Breadcrumbs web
part. Click the Add web part (4) icon of the zoneCenter web part zone and choose the Navigation ->
Breadcrumbs web part. Set the following properties of the web part, leave the rest at the default values.

e Starting path: /{0}/{1}/
e Breadcrumb separator: <span class="TitleBreadCrumbSeparator'>&nbsp;</span>

e Content before:

<di v styl e="paddi ng-1eft:10px" cl ass="G oupBreadcrunbs" >

<a href="~/ G oups. aspx" cl ass="CQVBBreadCr unbsLi nk" >G oups</ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { “Conmuni t yCont ext .
Current G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %Comuni t yCont ext .
Current G oup. G oupDi spl ayNane| (encode)true% </ a> <span cl ass

="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span>

® Content after: </div>
Click OK.
6. Now we will add a repeater displaying a list of pages of the current group. Click the Add web part (4

) icon of the zoneCenter web part zone and choose the Listings and viewers -> Repeater web part.
Set the following properties of the web part, leave the rest at the default values.
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e Web part control ID: repeaterPages

e Hide on subpages: enabled

e Path: ./Pages/%

e Document types: CMS.SimpleArticle

e Transformation: CMS.SimpleArticle.SimplePreview

e Hide if no record found: disabled

e No record found text: There are currently no pages.

e Web part container: Community Site - Blue Box Light
e Web part container title: Most recent pages

e Content before: <div class="GenerallList">

e Content after: </div>

Click OK.

7. Finally, we will add the Page placeholder in which the page with the particular article will be
displayed. Click the Add web part (%) icon of the zoneCenter web part zone and choose the General
-> Page placeholder web part. Leave all the properties of the web part at the default values and click

OK.

8. The page is now finished. In Design tab, it should look as in the following screenshot.

B

| - /Groups/Template - page template: My Community Site - Group pages template
= zoneCenter *
= zoneRight
| w {7 iGroupSeq.nrityﬁccEss @| o +
...... = |ogonminiform ’,ﬁ}
¥ breadcrumbs @} Shortuts @
{ = Shor i
My profile
Most recent pages Edit my profile
[There are currently no pages. My messages

3.12.11.2 Creating the Pages page

My invitations
Create a new group
Create a new blog

Sign out

Group finks

This page also senes as the template for the group pages section. It will be copied along with the
Template page to the specified path on each group's creation to form the group's group pages section.

On the page, there will be a Repeater for displaying the articles. We will also need the User
contributions module web parts providing on-site adding and editing of articles. For more details about
the User contributions concept, please refer to the Module User contributions chapter of Kentico CMS

Developer's Guide.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.
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Switch
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B Files =l
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dl_] Groups Please select new document type:

[] Page (menu item)

) Blog
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P Event
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@ EAQ

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the

Page name field, enter Pages and click Save.

-\l,- Kentico Switch to Site Manager  Site: |My Community Site[»]| User: Global Administrator v5.0.3683
#1%  CMS Desk Content | Mydesk  Tools  Administration
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[0 Access
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* [/ Template
L] Home Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells Grid 3x2 cells (CSS) Simple
|| Logon page
-] Media
|| News H
-] Search
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[—— ] — — _— —
12
Simple

Simple layout with one web part zone

Copy this layout to my page template

Sign out

3. Switch to the Properties tab and click the Edit template properties link. In the pop-up window,
scroll down and select the inheritance so that the page template inherits from Level 0 and Level 2.

Click Save.

(2]

=

mn
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& | Page Templates -- Webpage Dialog ﬁ

3 Page template properties @

Templates » Ad-hoc: Pages

General Layout Web parts Header Documents

Template display name:  |Ad-hoc: Pages
Template code name: 296cf491-8286-4732-b8d2-c20467b89b46
Category: Ad-hoc [~] -

Template description: Generic default template -

Template type: @ Portal page ) ASPX page

ik}

Show as master template: O
Inherit content: () Inherit all

© Do notinherit any content

@ Selectinherited levels

Leveld
D Levell i
Level2
|:| Leveld
[ Leveld
] Levels =
http:/flocalhost/kenticocms/CMSModules/PortalEngine/Ul/Page € Local intranet | Protected Mode: Off

4. Switch to the Layout tab and replace the original layout code with the following code:

<di v cl ass="subcontentD v">
<di v cl ass="cont ent G oupPages" >
<ccl: CvBWebPart Zone | D="zonelLi st" runat="server" />
</di v>
</ di v>

Click Save.
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& | Page Templates -- Webpage Dialog lé]

2] Page template properties )

Templates » Ad-hoc: Pages

General Layout Web parts Header Documents

E Save f?l Check outto file T

»

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\e96cf491-8286-47a2-
b8d2-c20467b89b46.ascx to edit the kyout externally.

() Use shared layout

Grid 242 cells

@ Use custom layout
<div class="subcontentDiv">
<div class="contentGroupPages">
<ccl:CMSWebFartZone ID="zonelist" runat="server"” />

m

</divy
</div>

http://localhost/kenticecms/CMSModules/PortalEngine/Ul/Page €& Local intranet | Protected Mode: Off

5. Back on the Properties -> Template tab, click the Save as new template link. Enter the following
details in the pop-up window:

Template display name: My Community Site - Group template - Pages
Template code name: MyCommunitySite.GroupTemplatePages
Template category: My Community Site templates

Template description: some text describing the page template

Click OK.
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Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

212 Kentico

#1% CMS Desk Content My desk Tools Administration
Ci u ] O |
2 B Bor Tw 4 @ P
New Delete |=kMove & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
(26} My Community Site Page  Desgn  Form | Propertes
‘%‘ _‘Fl Blogs General
i
= URLs
.| Forums
8 :] Groups Template
i [ Access Metadata Template
-[J] Create Categories Ad-hoc: Pages Select
|1 Forums Menu = i R ﬂ
= 1% 1| | &) Page template - Save as new -- Webpage Dialog
._] Management wore Save as new template, f =
|| Media =
Vo @ ‘et lempiate 4 Save as new page template
-] Media list erlempae
l] Memb Related docs
I& Members 1 EEdittem late properties X -
¢ [0 profile Linked docs Template display name: |My Community Site - Group template - Pages
IR Template Security Template code name: | MyCommunitySite GroupTemplatePages
P [lPages Attachments Inherit content Template category. My Community Site templates =]
‘] Home @ Use page template settings
N . : " This is the Pages page of the -
J Lug?n page = Do natinheritany content group pages template of My
‘o] Media H ) Selectinherited levels _ Community Site.
= - Template description
il News
[l search
http://localk € Local intranet | Protected Mode: Off

6. Switch to the Design tab. First, we will need the Group security access web part to ensure that only
users with appropriate permissions can access the group pages. Click the Add web part () icon of
the zoneList web part zone and choose the Community -> Group security access web part. You do
not need to set any properties of the web part, just leave the default values for all of them.

7. Click the Add web part (%) icon of the zoneList web part zone and choose the Community ->
Group contribution list web part. Set the following properties of the web part, leave the rest of them at
the default values.

e Hide on subpages: enabled

e Path: ./%

e Path for new documents: ./%

e Allowed new document types: CMS.SimpleArticle
e Alternative form name: PublicSimpleArticle

e Display list of documents: disabled

e New item button label: New page

e List button label: Pages

e Select only published: disabled

e Allow editing by users: Authenticated

Click OK.
8. Click the Add web part () icon of the zoneList web part zone and choose the Community ->
Group edit contribution web part. Set the following properties of the web part, leave the rest of them at

the default values.

e Show for document types: CMS.SimpleArticle
e Alternative form name: PublicSimpleArticle
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e Allow editing by users: Authenticated
e Content before: <div class="Contributions">
e Content after: </div>

Click OK.

9. Finally, we will add a Repeater for displaying the articles. Click the Add web part (%) icon of the
zonelList web part zone and choose the Listings and viewers -> Repeater web part. Set the following
properties of the web part, leave the rest of them at the default values.

e Web part control ID: ArticleRepeater

e Path: ./%

e Document types: CMS.SimpleArticle

e Transformation: CMS.SimpleArticle.SimplePreview

e Selected item transformation: CMS.SimpleArticle.Default
e Navigation buttons: None

e Hide if no record found: disabled

e No record found text: There are currently no pages.
e Content before: <br /><div class="GeneralList">

e Content after: </div><br />

Click OK.

10. The page is finished. In Design tab, it should look as in the following screenshot.

Blogs Forums Groups Home Media News Search
Groups » ¥
| - [Groups/Template/Pages - page template: My Community Site - Group template - Pages j| Shortcuts
- My profile
T zonelist 4k Edit my profile
| v || GroupsecurityAccess @| My messages
- My friends
| ¥ GroupContributionList Qﬂ My invitations

Create a new group

v GroupEditContribution
| = tgl,!| Create a new blog

¥ ArticdeRepeater @} s Sign out
Group links
Home
Pages

Media
Members
Forums

3.12.11.3 Creating the Group pages title page

The Group pages page will not be displayed in the site navigation. It will also not contain any content.
The only purpose of this page it for the group pages sections of particular groups to be placed under it. It
is important to set the alias path of this page in the Template target alias path property of the Group
registration web part, which was added to this page.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.
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Switch
232 Kentico
'.‘ CMS Deslk Content My desk Toals Administration
— — = i — —
EN NSNS T [ ~r
MNew | Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode COther
=4 J[My Community Site My Community Site
3] Blogs —,
= 4.‘—]_‘ . New document
[+]- = Files —
|1||_] Forums
= Please select new document type:

[+)-] Groups
; j HPIE [] Page (menu item)

Logon page
= T

I_] Search

) Folder

235

2. Choose to Create a blank page using the Simple layout. For Page name, enter Group pages and

click Save.

Switch to Site Manager ~ Site: | My Community Site[v] User: Global Administrator v5.0.3688

212 Kentico

#1% CMS Desk Content | Mydesk  Tools  Administration
2 g Boer 4  Od p
New Delete & Move & Down | Edit Preview Live site List ‘ Search |
Content management | view mode | other |
My Community Site

l:'/'!;") My Community Site

] j Blogs .
(=) Files E Save E‘ Save and create another Spell check
= j Forums
(=11 Groups Page name: Group pages
j Home
3 Logon page (") Use page template (") Inheritfrom parentpage @ Create a blank page
j Media
B Layout name:
|| News
j Search

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells

Three columns Three columns (CSS) Top row, three columns,
bottom row
—— ] ——— —
12
Simple

Simple layout with one web partzone.

Copy this layout to my page template

Search

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

|-

|

Simple

Two columns

Sign out

3. Switch to the Properties -> Menu tab and disable the Show in navigation option. Click Save.

(2]

==

i
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-‘:’- Kenti.co Switch to Site Manager  Site: My Community

#2% CMS Desk Content My desk Tools Administration

5 [ Bloer T (4 [d [ E F

New Delete = Mowve & Down Edit Preview Live site List | Search |

Content management View mode Other
C‘!‘_,] My Community Site Fage Design Form Properties
()-[] Blogs —
2 Files eneral E sae
. URLs
[+-|_] Forums
~[1/Group pages e
|1I|_] Groups Metadata Basic properties
|_] Home Categories Menu caption:
._] Logon page Menu Show in navigation
n_] Media Waorkflow Show in sitemap:
] News ]
g = Versions
‘] 5earch
4. That's the page finished, now you've got to enter its alias path in the site settings and the group pages
of particular groups may be stored under it.
3.13 Creating the Members section
3.13.1 Creating the Members page

This page will be the title page of the Members section. We will base it on the _StarterTemplate page

template created in this chapter. Besides the web parts from this page template, the page will contain
two Users viewer web parts in the zoneCenter web part zone. The first one will be displaying the 6
most active users of the site. The second one will be displaying all site users, with the pager enabled
and 9 records by page. In zoneRight, there will also be the On-line users web part showing who is

currently on-line.

If you right-click a user in of of the Users viewer, you will be offered some actions by a context menu.
This functionality is provided in the transformation and here, you can find a description of how exactly it

is achieved.

1. Select the root of the content tree and click New. Choose the Page (menu item) document type.

212 Kentico

#§n  CMS Desk

Switch

Content Toolz Administration
> C U —
S g Do R 2 Q@ & B85 AL
New | Delete = Move 4 Down Edit Preview Live site List | Search |
Content management iew mode Other
=4 /My Community Site My Community Site
3-[.] Blogs .
= :'_l . New document
[+]- 2 Files =l
|1||_] Forums
‘.[] Group pages Please select new document type:
'1“—] Groues |1 Page (menu item)
-] Home
I_] Logc.m page ] Blo
Lo ] Media
H . ol
ol News i) Folder
‘[ ] search
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Members and click Save.

.\!4- Kentico Switch to Site Manager  Site: |My Community Site[+] User: Global Administrator v5.0.3688 Sign out
“1% CMSDesk Content | Mydesk  Took  Administration
3 5 D copy T up w [d @] = /O
New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management | View mode || other
=] \;_;l My Community Site My Community Site
(zJ-.| Blogs -
25 Files Save and create another Spell check
(&)-L] Forums
|1 Group pages Page name: MVembers
()| Groups
J Home @ Use page template () Inheritfrom parentpage () Create a blank page
-] Logon page -
B Media (240 All page templates Template name:
2 News T‘] Articles
[ search : tﬂ Blank pages for widgets
i) Blogs

: ;'} Community Site
3 :ﬂ Corporate Site ASPX
i) E-commerce

_GroupsTemplate __StarterT: My C ity Site - My C ity Site -
Access Blog creation

: ;'} Home pages
iy Images

:‘} Job openings
) Knowledge base
:‘] Master templates

= My Community Site - My Community Site - My C ity Site - My C ity Site -
tﬂ Membership and security Blog list Blog posts Blogs Forum search
i) Message boards

: ;'} My Community Site templates
L) News

:‘} Newsletter

L) Offices

:‘] Press releases

: ::i Products

i.:4) Templates with editable regio
La) wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.

12

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Members
Template code name: MyCommunitySite.Members
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

m
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Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

212 Kentico
s

CMS Desk Content My desk Tools Administration
C Ui B 3}
3 G 3ot (3 [g =R
New Delete | =¢Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
':."‘"._.,'J My Community Site Page Design Form | Properties
‘ﬂ | Blogs General
H ﬁ e
: URLs
[#)-] Forums
3 Template
i1 Group pages
(2-[2] Groups Metadata Template
| Home Categories _StarterTemplate Select
i..[] Logon page M f I
; [ Med . £ | Page template - Save as new -- Webpage Dialog @
;i@ Media Worlflow J
g Members = =
| — T TTT /. Save as new page template
o] News Q Innerittemplate
g Bs h Related docs .
eard i :}u‘ Clone template as ad-hoc
Lin s = Template display name: |My Community Site - Members
Seasny [H Edittemplate properties Template code name: | MyCommunitySite. Members
Attachments Template category: Wy Community Site templates E
Inherit content This is the Members page of My -
@ Use page template settings Community Site.
H () Do notinherit any content Template description:
) Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

4. Switch to the Design tab. Click the Add web part (4) icon of the zoneRight web part zone and
choose the Membership -> On-line users web part. Set the following properties of the web part, leave
the default values for the rest of them:

e Transformation name: Community. Transformations.MembersOnline
Select top N: 20
Additional info text: {2} member(s) on-line:<br />

Web part container: Community Site - Orange Box
Web part container title: On-line members
Content after: <div><br /><a href="~/Members/Online.aspx">View all on-line members</a></div>

Click OK.

5. In the zoneCenter web part zone, we will want an info text displayed above the Users viewers. Click
the Add web part (4) icon of the zoneCenter web part zone and choose the Text -> Editable text
web part. Set the following properties of the web part, leave the default values for the rest of them:

e Web part control ID: editabletextContent

Click OK.

6. Switch to the Page tab. Enter the following texts into the Editable text web parts' text fields:

e Heading: Members
e Content: Bellow you can find list of site members. Right click the user to get available actions.

Click Save.
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............................................................................................................................

E Bellow you can find list of site members, Right dick the user to get available actions. i .

m

7. Now we will add the first Users viewer which will display the 6 most active users. Switch back to the
Design tab. Click the Add web part () icon of the zoneCenter web part zone and choose the
Membership -> Users viewer web part. Set the following properties of the web part, leave the default
values for the rest of them:

e Transformation name: Community. Transformations.MembersList

e Show filter: disabled

e ORDER BY condition: UserActivityPoints DESC

e Select Top N members: 6

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatariD,
UserActivityPoints,UserName, AvatarGuid

e Web part container: Community Site - Red Box Light
e Web part container title: Top members
e Content after: <div class="clear">&nbsp;</div>

Click OK.

8. The second repeater will display all site members paged by 9. Click the Add web part (%) icon of
the zoneCenter web part zone and choose the Membership -> Users viewer web part. Set the
following properties of the web part, leave the default values for the rest of them:

e Web part control ID: AllUsers

e Transformation name: Community. Transformations.MembersList

e Hide if no record found: disabled

e No record found text: No users found

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatariD,
UserActivityPoints,UserName, AvatarGuid

e Page size: 9

e Paging mode: PostBack

e Group size: 9

e Use default cache dependencies: enabled

e Web part container: Community Site - Blue Box Light

e Web part container title: All members

e Content after: <div class="clear">&nbsp;</div>

Click OK.
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3.13.2 Creating the Online page

9. The page is now finished. In Design tab, it should look as in the following screenshot. Obviously,
because there are no users on the site yet, only the Administrator is displayed by the viewers. However,
you may try creating a few users via the administration interface or registering on-site. You will see the

new users listed on this page.

B

| T /Members - page template: My Community Site - Members
= zoneCenter
= * = zoneRight e
v editabletext {2 —
= |ogonminiform g:}
- } ) { v Shortcuts {23
i % nembers. Right dick the user to get available actions.
v editabletextContent ,@ Shoricuts
Top members Edit my profile
My messages
My friends
My invitations

Admin
Gender: N/A
Age: NfA
v AllUsers @}
All members

Sort by: User name Activity

Admin
Gender: NfA
Age: NfA

Create a new group
Create a new blog
Sign out

¥ Onlinelsers @}
On-line members
There are currently no users on

View all onine members

In the previous example, we have put the On-line users web part to the right column. There is a link
added by the Content after property of the web part, leading to this page. On this page, there will be
another On-line users web part, which will display all users that are currently on-line.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)

document type.

22 Kentico
#g%  CMS Desk Content

(=8 Copy i up

x

New | Delete |k Move

Content management

|;'l'\_;_":l My Community Site
-2l Blogs
¢|”\f___.7‘ Files
.1|,_| Forums
I_| Group pages
-] Groups
- [2 Home
Logon page
Media
Members
News

D ) Y D D

Search

@ Down

Tools Administration

Switch

7, I O R = R =

Edit Preview Live site List

View mode

» Members

New document

Please select new document type:

| ] Page (menu item)

0 Blog
3 cell phone
P Event

Search
Other

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
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Page name field, enter Online and click Save.

Switch to Site Manager  Site:| My Community Site User: Global Administrator v5.0.3688 Sign out
232 Kentico v ¢ Site[x]
#1%  CMS Desk Content | Mydesk  Tools  Administration
LT @4 & & =2 L
New Delste |sMove 4 Down Edit  Preview Livesite  List Search
Content management | View mode || other
d'iq’) My Community Site » Members
(- Blogs ==
5 Files - E‘ Save and create another E Spell check
[+)-.] Forums
-] Group pages Page name: Online
-] Groups
-] Home @ Use pagetemplate () Inheritfrom parentpage () Create a blank page
|| Logon page - —_—
[0 Media (=43} All page templates Template name:
&y Articles
||/ Members =
[ News -3} Blank pages for widgets
|| Search 4 Blogs

&) Community Site
£33 :j' Corporate Site ASPX

- _":‘}‘ E-commerce
I _GroupsTemplate _StarterTemplate My Community Site - My Community Site -
) Events
;‘} Access Blog creation

-3 FAQs

’ &) Forums
ﬂ - General
T ) Home pages
- Images
::'Q' Job openings
&y Knowledge base
N T‘} Master templates 3 My Community Site - My Community Site - My Community Site - My Community Site -
l_j' Membership and security Blog list Blog posts Blogs Forum search
-3} Message boards
ij‘ My Community Site templates

&) News

& Newsletter

i) Offices

&) Press releases

i) Products

&) Templates with editable regio .z

i) wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

< o I of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Members Online
e Template code name: MyCommunitySite.MembersOnline

e Template category: My Community Site templates

e Template description: some text describing the page template

Click OK. Click Save.

m
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Switch to Site Manager  Site:| My Community Site User: Global Administrator v5.0
232 Kentico 8 2 site[-] :
#1%  CMSDesk Content | Mydesk  Tools Administration
L L 2 & B B2 | A
New Delete = Move & pown Edit Preview Live site List Search
Content management View mode Other
l:.‘"‘_) My Community Site Page  Design  Form | Properties
‘%‘ ] Blogs General
T URLs
[#)-.] Forums
|| Group pages Template
& ;_I Groups Metadata Template
|| Home Categories _StarterTemplate Select
| Logon page 3 ( 1
;& Logon pag Menu = emrssssisicn | | €. Page template - Save as new — Webpage Dialog =
~@ Media wori =yl Save asnewtemplate.: —
3 L] Members - /=i, Save as new e template
: : Versions @/ Inherttempizte e o P
|||Online
g — T Related docs —
il News . 43/ Clone template as ad-hoc R .
i [ search Linked docs =/ Template display name: |My Community Site - Members Online
Security ﬁ Edit template properties Template code name:  |MyCommunitySite.MembersOnline
Attachments Template category: My Community Site templates E
Inhert content This is the Cnline page of My -

- " Community Site.
@ Use page template settings ¥

) Do notinheritany content Template description:

() Selectinherited levels

e

hitp://localk €& Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Members on-line to the heading Editable text web part's text field.
Click Save.

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Membership -> On-line users web part. Leave all properties of the web part at their default
values and click OK.

6. The page is now ready. In Design tab, it should look as in the following screenshot.

| = fMembers/Online - page template: My Community Site - Members Online p|

¥ zoneCenter o = &
¥ zone
v editabletext 3| |+
Lm—rmv.—.r—‘g’ﬂl-hne = |ogonminiform @
) ¥ Shortauts .
Shortits

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

© 2011 Kentico Software



Part 2 243

3.13.3 Creating the Profile page

On the Profile page, public profiles of users will be displayed based on the wildcard part of the URL. We
will set the page's URL to /Members/{UserName}. This means that if you type <sitename>/Members/
David.aspx into the browser, David will be recognized as the wildcard part of the URL and David's profile
will be displayed by this page.

The profile is displayed using the User public profile web part and is based on the cms.user.
EditProfileCommunity alternative form. You can find more information on how to modify the alternative

form in this chapter.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.

-‘='. Kenti.co Switch
#§% CMS Desk Content My desk  Tools Administration
2 C u E D

S )G B e 4 [d 2

New |Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | WView mode | other |
=4 ) My Community Site ¥ Members

-] Blogs Y

iy :‘—l 9 New document

- Files —

=[] Forums

|_] Group pages Please select new document type:

‘1"—] Groups | ] Page (menu item)

+~|.] Home

|_] Logon page = Article

bl Media -

=-[1[Members ] Blog

: i) online B cell phone

I_] News [ Event

| Search

¢ Event (booking system)

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Profile and click Save.

© 2011 Kentico Software



244

Kentico CMS 5.5 R2 Community Site Guide

22 Kentico Switeh to Site Manager
“I% OMS Desk Content | Mydesk Toos  Administration
* [ Copy T up 3 E] = /O

& Down

Content management

New Delste = Move Edit  Preview livesite  List Search

View mode Other

b Members

=] n_;_;l My Community Site
(-] Blogs
(-G Files

E‘ Save and create another Spell check

(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
=11 | Members
e ._I Online
] News
-] Search

Page name: Profile

@ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

=

ity Site -

m

ity Site -

_GroupsTemplate __StarterT: My C ity Site - My C
Access Blog creation
N
My Community Site - My Community Site - My C: ity Site - My C
Blog list Blog posts Blogs Forum search
12
_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

e Template display name: My Community Site - Members Profile
e Template code name: MyCommunitySite.MembersProfile

e Template category: My Community Site templates

[ ]

Template description: some text describing the page template

Click OK. Click Save.
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-‘1,- Kentl.co Switch to Site Manager Site: My Community Site E| User: Global Administrator 5.0
#1% CMS Desk Content | Mydesk Tools  Administration
G U e 1
=) e [l A~
New Delete =k Move & Down ‘ Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
C‘\‘_,] My Community Site Page  Design  Form | Properties
';/ _l_'—l B.Iugs General
[BR=] Files - E Save
(-] Forums :
‘[] Group pages Template
& ._l Groups Metadata Template
L] Home Categories StarterTemplate [ Select |
i1 Logon page Meru ( § ==\
H= " : £ | Page p - Save as new -- Webpage Dialog
. ._I Media ok ave as new template, : —
=] Members =
3 onlne vl @ et emgite (=g Save as new page template
q 1:] Profil Related docs —
i = JiLS a3/ Clone template as ad-hoc X - -
[ News Linked docs = Template display name: My Community Site - Members Profile
“-|] search Security ﬁ Edit template properties Template code name:  |MyCommunitySite MembersProfile
Attachments Template category: My Community Site templates |Z|
Inherit content T:i; is the ]:[:mb:?: Profile page -
@ Use page template settings ° ¥ LOommERity Site.
H ) De notinherit any content Template description
() Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

4. Switch to the Properties -> URLs tab and enter /Members/{UserName} into the Document URL
path field. Click Save.

Switch to Site Manager  Site: | C
:1’- Kent[co WALC (s} e anager a: or
’l‘ CMS Desk Caontent My desk Toolk Administration
[ cop u
] ) cory ¥ up o B H | |
New Delete o Move & Down Edit Preview Live site List Search
Content management | View mode | Cther
=% ) My Community Site Page Design Form | Properties
-2 Bl
) .Dg‘s General |
|+)- "5 Files E Save
- URLs
(%) |l Forums
|| Group pages Enr s
[+).] Groups Metadata Path
_.i Home Categories Document alias: Profile
|| Logon page Menus Document URL path:  mlembersi{UserMame}
| Media Workflow Use custom URL path
-] Memb
=i Fm Ejrs Varsions
4 OI‘I|II-'IE Reloted G Extended properties
el Profile N URL extensions:
= Linked docs
M
5:] Ews I [Tl use custom URL extensions
|| Search Security .
Track campaign:
Attachments

5. Switch to the Design tab. In the zoneRight web part zone, we will want three info boxes - for
displaying the user's friends, blogs and groups. Let's start with the first one. Click the Add web part (4F
) icon of the zoneRight web part zone and choose the Community -> Friends -> Friends viewer web
part. Set the following properties of the web part, leave the default values for the rest of them:

e Transformation name: Community. Transformations.MembersPreviewList
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No record found text: Currently doesn't have any friends.

Friend status: Approved

Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatarID,UserCreated,
UserName, AvatarGuid

Web part container: Community Site - Gray Box

Web part container title: My friends

Click OK.

6. The second info box will be displaying links to the user's blogs. Click the Add web part (#) icon of
the zoneRight web part zone and choose the Listings and viewers -> Repeater web part. Set the
following properties of the web part, leave the default values for the rest of them:

Web part control ID: repeaterBlogs

Path: /Blogs/%

Document types: CMS.Blog

ORDER BY expression: DocumentCreatedWhen DESC

WHERE condition: NodeOwner = {%SiteContext.CurrentUser.UserlD%}'
Transformation: Community. Transformations.BlogsListRight

Hide if no record found: disabled

No record found text: Currently doesn't have any blogs.

Web part container: Community Site - Orange Box

Web part container title: My Blogs

Click OK.

7. The third info box will be displaying the groups where the user is a member. Click the Add web part (
4k) icon of the zoneRight web part zone and choose the Community -> Groups viewer web part. Set
the following properties of the web part, leave the default values for the rest of them:

Transformation name: Community. Transformations.GroupsPreviewList

Show filter: disabled

ORDER BY condition: GroupDisplayName ASC

WHERE condition: GroupID IN (Select MemberGrouplD FROM Community_GroupMember WHERE
MemberUserID = {%SiteContext.CurrentUser.UserID%}' AND MemberStatus = 0)

Hide if no record found: disabled

No record found text: Currently is not member of any group.

Use default cache dependencies: enabled

Web part container: Communty Site - Gray Box

Web part container title: My groups

Click OK.
8. In the zoneCenter web part zone, the main web part is the User public profile. Click the Add web
part () icon of the zoneCenter web part zone and choose the Membership -> User public profile

web part. Set the following properties of the web part, leave the default values for the rest of them:

e Apply visibility settings: enabled
e Use visibility settings from: cms.user.EditProfileCommunity

Click OK.

9. Below the user's profile, there will be two message boards. The first one will be used only by the
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owner of the profile. This will be where the user can post announcements for the other users. Click the
Add web part (3F) icon of the zoneCenter web part zone and choose the Message boards ->
Message board web part. Set the following properties of the web part, leave the default values for the
rest of them:

e Web part control ID: MessageBoardAnnouncements

e No messages text: There are currently no announcements.

e Display name: Anouncements of {%SiteContext.CurrentUser.FullName|(encode)true%}
e Message board owner: User message board

e Access: Only Owner

e Enable subscriptions: enabled

e Board base URL: ~/Members/Profile.aspx

e Web part container: Community Site - Blue Box Light

e Web part container title: My announcements

Click OK.

10. Below the first message board, there will be another one. This one will be a public board, which
means that anybody can post messages on it. This is where users can leave comments on the user.
Click the Add web part (4) icon of the zoneCenter web part zone and choose the Message boards -
> Message board web part. Set the following properties of the web part, leave the default values for the
rest of them:

e Web part control ID: MessageBoardComments

e No messages text: There are currently no comments.

e Display name: Comments on {%SiteContext.CurrentUser.FullName|(encode)true%}
e Message board owner: User message board

e Access: Only authenticated users

e Enable subscriptions: enabled

e Board base URL: ~/Members/Profile.aspx

e Web part container: Community Site - Red Box Light

e Web part container title: Comments on me

Click OK.

11. The page is now ready. In Design tab, it should look as in the following screenshot.
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| + {Members/Profile - page template: My Community Site - Members Profile

B

¥ zoneCenter

v editabletext {3
= UserPublicProfile ’{Ey} d.

|V MessageBoardAnnouncements ’{éj,!|
My announcements

[There are no messages,

¥ MessageBoardComments ’{éj,!|
Comments on me

= zoneRight +
= |ogonminiform @,!
-

Shortcuts

My profile
Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

[There are no messages.

3.13.4 Creating the Members management starter template

v FriendsViewer
My friends

Currently doesn't have any
friends.

¥ repeaterBlogs ’,:e_:‘,!

My Blogs

Currently doesn't have any
blogs.

¥ GroupsViewer @,!

My groups

Currently is not member of any
aroup.

Next on in the Members section, we will create a series of five pages that will be used by the users for
their accounts management. All the pages will have three web parts common in the zoneRight web part
zone. These will be info boxes displaying the user's blogs, groups and forum favorites. We will create a
starter page template to facilitate the creation of these pages.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico

#1% CMS Desk Content My desk Toolz Administration
=] = Co U
w [Hooer W (4  [d =
New |Delete |=bMove & Down Edit  Preview Livesite  List
Content management iew mode
-;l-é_"l My Community Site r Members
-] Blogs Y
el New document
[+]- =/ Files
(-1 Forums
._| Group pages Please select new document type:
2 SR [] Page (menu item)
-|2] Home
'—‘ Lononipage =1 Article
L[] Media -
| .
=) [Members ] Blog
¢ ie[ online § Cell phone
._| Profile F_. Event
- News =) Event (booki tem)
.[g search I Event (booking system

© 2011 Kentico Software



Part 2

249

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the

Page name field, enter members management template and click Save.

.\!4- Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688
% CMSDesk Content | Mydesk  Tools  Adminstration

;‘ [ Copy T up w @ @] = })

New Delste =Move 4 Down Edit  Preview Livesite  List Search
Content management | View mode || other
=] \;_;l My Community Site » Members
(zJ-.| Blogs -
25 Files E Save E‘ Save and creale another |2 Spell check
o) =
(&)-L] Forums
|1 Group pages Page name: members management template
()| Groups
[} Home @ Use page template () Inheritfrom parentpage () Create a blank page
-] Logon page -
1 Media =& All page templates Template name:
& B Members ) Articles

©y Blank pages for widgets

B ,_] Online
] profile
[0 News ‘&) Community Site
| search ©J Corporate Site ASPX

) E-commerce

_GroupsTemplate __StarterT: My C ity Site - My C ity Site -

Access Blog creation

N

My Community Site - My Community Site - My C: ity Site - My C ity Site -

Blog list Blog posts Blogs Forum search

. 12
&) Templates with editable regio
La) wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

Sign out

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

Template display name: _MembersManagement

Template code name: MembersManagement

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

m
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22 Kentico

Switch to Site Manager

Site: My Community Site E| User: Global Administrator v5.0.31

“1% CMSDesk Content | Mydesk  Tooks
= = c u = —
2 & Bew %w | 3[4 =2
New Delete |= Move & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
=] {‘_,'J My Community Site Page  Design Properties
-] Blogs
(+)-% Files e E Save
[#-[] Forums =
+
|1 Group pages Template
Metadata Template
Cat=gories _StarterTemplate W
LB Logon page . B
: S Media Me | Page template - Save as new -- Webpage Dialog ﬂ
§ Workflow
-] Members 2 s _-_‘
i [ )/members management templa: - Q Inheittemplate S0
H O onl Related docs .
i Yniine ; 45/ Clone template as ad-hoc
[ profile Linked docs &/ Template display name: _Membershanagement
i..[J] News Security E Edit template properties Template code name:  |MembersManagement
+L search Attachments Template category: My Community Site templates [=]
Inherit content This is the starter template for -
@ Use page template settings the Membe%'s mar}agement section of
‘ ) . .. My Community Site.
) Do notinherit any content Template description:
(©) Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

4. Switch to the Design tab. We will place the three info boxes into the zoneRight web part zone. The
first info box will be displaying links to the user's blogs. Click the Add web part () icon of the
zoneRight web part zone and choose the Listings and viewers -> Repeater web part. Set the
following properties of the web part, leave the default values for the rest of them:

Path: /Blogs/%
Document types: CMS.Blog

Click OK.

Web part control ID: BlogsRepeater

ORDER BY expression: DocumentCreatedWhen DESC
WHERE condition: NodeOwner = {%CurrentUser.UserlD%}
Transformation: Community. Transformations.BlogsListRight
Hide if no record found: disabled

No record found text: You currently do not have any blogs.
Web part container: Community Site - Orange Box
Web part container title: My Blogs

5. The second info box will be displaying the groups where the user is a member. Click the Add web
part (%) icon of the zoneRight web part zone and choose the Community -> Groups viewer web
part. Set the following properties of the web part, leave the default values for the rest of them:

e Transformation name: Community. Transformations.GroupsPreviewList

e Show filter: disabled

e ORDER BY condition: GroupDisplayName ASC

e WHERE condition:
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Goupl D IN (Sel ect Menber G oupl D FROM Communi ty G oupMenber WHERE Menber User | D =
{%urrentuser.useri d%4 AND Menber Status = 0)

Hide if no record found: disabled

No record found text: Currently is not member of any group.
Web part container: Communty Site - Gray Box

Web part container title: My groups

Click OK.

6. The last info box will be displaying the user's forum faworites. Click the Add web part (4) icon of the
zoneRight web part zone and choose the Forums -> Forum favorites web part. Set the following
properties of the web part, leave the default values for the rest of them:

e Web part container: Community Site - Gray Box
e Web part container title: Forum favorites

Click OK.

7. That's the page template finished. In Design tab, it should look as in the following screenshot.

|' [Members/ b t late - page template: _MembersManagement f|

* zoneCenter + ik *

v editabletext
|—‘€‘:§| = |ogonminiform @}
v Shorteuts {28 ]

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

* BlogsRepeater @}

My Blogs

‘You currently do not have any
blogs.

My groups

Currently is not member of any
group.

‘

Forum favorites

Mo favorites found

8. Finally, you can delete the page created in this example. We will not need it anymore as the page
template is already saved and can be reused.

3.13.5 Creating the Management page

The Management page can be used by site members to manage the details in their public profiles. This
functionality is achieved using the My account web part, based on the cms.user.
EditProfileCommunity alternative form.
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1. Select the Members page in the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico

#§S  CMS Desk

Content My desk Administration

@ © =2 A

Tools

Y _"‘ [ Copy T up ¥

Edit

New |Delete

= Move & Down | Preview Live site List | Search
Content management | View mode Other
= ) My Community Site » Members
4[] Blogs oy
& :‘—l ) New document
B Files —
-] Forums
..[ ] Group pages Please select new document type:
-] Groups

[ ] Page (menu item)

‘[ ] Home

,j Logon page
[ Media
|:|,_] Members ) Blog
¢ i.[] online 3 Cell phone
: L[] Praofile 1 Event
j :z:r:h I Event (booking system)

Switch

2. Select the My Community Site templates -> _MembersManagement page template created in

this chapter. Into the Page name field, enter Management and click Save.

Switch to Site Manager
232 Kentico
#1%  CMSDesk Content | Mydesk  Tools  Adminstration
N . - " —
2 & Boe  ®uw (4 [ & E P
New Delete |=»Move $oown | Edit  Preview Liveste List | Search |
Content management | View mode || other

» Members

E‘ Save and create another

Page name: Management

=] \;_/') My Community Site
-] Blogs
(-5 Files
(&)-L] Forums
|| Group pages
-] Groups
|| Home
-] Logon page
] Media
=)+ |/ Members
fm I_] Online
* [ profile
-] News
|| Search

== Spell check

@ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates
) Artides
;-:i Blank pages for widgets
Blogs
E ;'} Community Site
3 :ﬂ Corporate Site ASPX
:‘} E-commerce
i) Events
-3y FAQs
E &) Forums
H i) General
: ;'} Home pages
i) Images
:‘} Job openings
) Knowledge base
:‘] Master templates

Template name:

_GroupsTi

Site:| My Community Site[+| User: Global Administrator v5.0.2688

_StarterTemplate

Sign out

=

My Community Site -
Access

m

My Community Site -
Blog creation

My Community Site - My C:

: ::i Membership and security Blog list

i.:4) Message boards

: ;'} My Community Site templates
L) News

:‘} Newsletter

L) Offices

:‘] Press releases

;-:i Products

i.:4) Templates with editable regio

E ;'} Wiki

_MembersManagement

ity Site - My C
Blog posts

ity Site -
Blogs

This is the starter template for the Members management section of My Community Site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

© 2011 Kentico Software



Part 2 253

following details in the pop-up dialog:

e Template display name: My Community Site - Members management
e Template code name: MyCommunitySite.MembersManagement
e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.

22 Kentico
#1%  CMS Desk

Switch to Site Manager

Tools Administration

Site: My Community Site E| User: Global Administrator v5.0.31

= - — .
E._& Hcwy 2 [ =2 | L
New Delete |=»Maove Edit Preview Live site List ‘ Search ‘
Content management View mode | Other |
d'!"__" My Community Site Page Design  Form | Properties
‘ﬂ'—l Blogs General
d-‘fj Files o E Save
-] Forums :
a Group pages Template
@[] Groups Metadata Template
i..[]] Home Categories _MembersManagement W
i[] Logon page Menu r A
- . & | Page template - Save as new -- Webpage Dialog ﬂ
: 9 Media Workflow =Sa\te as new template_ : =
-] Members 3 — =
Frilx e @ Dhenttemoiate /=g Save as new page template
il |Management Inherittemplate
= Related docs —
Q Online s/ Clone template as ad-hoc
i L] profile Linked docs = Template display name: |My Community Site - Members management
g News Seaai E Edit template properties Template code name:  MyCommunitySite MembersManagement
-] Search Attachments Template category: My Community Site templates [=
Inherit content This is the Mamha¥5 mar}agemant -
/@ Use page template settings page of My Community Site.
) Do notinherit any content Template description:
) Selectinherited levels
[ ok | Cancel |
http://localk € Local intranet | Protected Mode: Off
b

4. Switch to the Design tab. We will only need to place the My account web part to the zoneCenter
web part zone and set it up properly. Click the Add web part (4F) icon of the zoneCenter web part
zone and choose the Membership -> My account web part. Set the following properties of the web
part, leave the default values for the rest of them:

Form name: cms.user.EditProfileCommunity
Allow user to edit field visibility: enabled

Display my address: disabled
Display my orders: disabled
Display my credit: disabled

Display my subscriptions: disabled
Display my messages: disabled

Display my friends: disabled

Content before: <div class="myAccMenu">

Content after: </div>

Click OK.

5. Switch to the Page tab and enter My profile into the heading Editable text web part's text field. Click
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Save.

My profile

h
'
'
e

6. The page is now finished. In Design tab, it should look as in the following screenshot.

2

|V /Members/Management - page template: My C ity Site - Memb:
¥ zoneCenter
= * = zoneRight +
v editabletext (i3 =
* logonminiform ’tg:!
_ ¥ Shortcuts {23
¥ MyAccount "g} Change password ~ Motifications Shortcuts
My profile
Username: Edit my profie
Full name: Global Administrator My messages
— My friends
Email: administrator@localhost.local My invitations

Display my e-mail to:

Mickname:

Signature:

Messaging notification e-mail:

Time zone:

Avatar:

Gender:

Date of birth:

Select pre-defined avatar

) (al) @ Site members ()

Friends

[=]

Create a new group
Create a new blog
Sign out

- BlogsRepeater ’,@
My Blogs

‘fou currently do not have any
blogs.

¥ GroupsViewer @,!
My groups

Currently is not member of any
group.

¥ ForumFavorites ’,@ ‘
rum favorites

Mo favorites found

3.13.6 Creating the Invitations page

On the Invitations page, users will see their invitations to groups and will be able to manage them. This
functionality will be provided by the My invitations and My sent invitations web parts. The page is

accessible from the Shortcuts menu, by clicking the My invitations link.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)

document type.
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2. Select the My Community Site templates -> _MembersManagement page template created in
this chapter. Into the Page name field, enter Invitations and click Save.

=32 Kentico

#1%  CMS Desk Content | My desk
3 x [ Copy T up

New Delete = Move & pown ‘

Content management

Switch to Site Manager
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» Members » Management
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I 1\ Save and create anather

@ Use page template () Inheritfrom parent page
=] :}] All page templates
-1 Artices
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i) Master templates
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&y Templates with editable regio

- ::'Q' Wiki

Template name:

_GroupsTemplate

My Community Site -
Blog creation

My

_MembersManagement

_MembersManagemen

Site: | My Community Site [«

() Create a blank page

Community Site -
Blog list

_StarterTemplate

My Community Site -
Blog posts

User: Global Administrator v5.0.3688

.

My Community Site -
e

My Community Site -
Blogs

This is the starter template for the Members management section of My Community Site.

Sign out

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Invitations

2]

=

m
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e Template code name: My Community Site.Invitations

e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.

232 Kentico
1% CMSDesk Content

[ copy T up

L%

Tools

Switch to Site Manager

4 O =@ B | A~

New Delete = Move & pown Edit Preview Live site List | Search |
Content management View mode | Other
d-{-__'l My Community Site Page  Design Properties

‘ﬂ'—l Bloos General
(-G Files
t URL:
(-] Ferums =
a Group pages Template
(i) Groups Metadata Template
L[ Home Categories _MembersManagement
- Logon page Menu
9 Media okl ;Save as newtemplate
5[] Members 2 -
g = Versions

= Innerttemplate
" &-B management Q Inherit template
T a TR Related docs —

S & Clone template as ag-hoc

D Online Linked docs =
5 : [ profile Security E Edit template properties
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i..[] search

Ny invitations
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'
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Click OK.

Site: My Community Sitelzl User: Global Administrator v5.0.3

Inherit content

@ Use page template seftings
) Do notinherit any content
() Selectinherited levels

Zero rows text: You hawe currently no invtations.

Hide control for zero rows: disabled

Web part container: Community Site - Blue Box Light
Web part container title: Received invitations

Select
4 »
| Page template - Save as new -- Webpage Dialog @
.\.!iﬂ Save as new page template
Template display name: |My Community Site - Invitations
Template code name: My Community Site.Invitations
Template categary: My Community Site templates El
This is the Invitations page of -
My Community Site.
Template description:
http://localk @ Local intranet | Protected Mode: Off

4. Switch to the Page tab. Enter My invitations into the Editable text web part's text field and click Save

5. Switch to the Design tab. First, we will add the My invitations web part, which will display the user's
received invitations. Click the Add web part (%) icon of the zoneCenter web part zone and choose
the Community -> My invitations web part. Set the following properties of the web part, leave the
default values for the rest of them:

6. The second web part on this page will be displaying the user's sent invitations. Click the Add web
part () icon of the zoneCenter web part zone and choose the Community -> My sent invitations
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web part. Set the following properties of the web part, leave the default values for the rest of them:

e Web part container: Community Site - Blue Box Light
e Web part container title: My sent invitations

Click OK.

7. The page is now finished. In Design tab, it should look as in the following screenshot.

|V /Memb fr it/ Invitati - page template: My C ity Site - ritati ﬁ|
* zoneCenter * Right +
¥ zonel
v editabletext { =
Lr’—rrm%hs = logonminiform {ej,!
_ v Shorteuts
——
Recewved invitations My profie
Edit my profie

fou have currently no invitations.
My messages
= My friends
T MySentInvitations ;e‘z,! My invitations
Create a new group
Create a new blog
Sign out

+ BlogsRepeater !@Z‘!

My Blogs

You currently do not have any
blogs.

|
My groups
Currently is not member of any
group.

‘

Forum favorites

Mo favorites found

3.13.7 Creating the Messages page

The Messages page will provide users with the functionality of private messaging. The page is
accessible from the Shortcuts menu, by clicking the My messages link. Its main part is the My
Messages web part. For more information on the Messaging module, please refer to Kentico CMS

Deweloper's Guide -> Module Messaging.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.
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Switch
232 Kentico e
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i
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2. Select the My Community Site templates -> _MembersManagement page template created in
this chapter. Into the Page name field, enter Messages and click Save.

-\l,- Kentico Switch to Site Manager  Site: |My Community Site[»]| User: Global Administrator v5.0.3683 Sign out
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Content management | View mode || Other —]
=] {.J My Community Site » Members » Management
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(©-] Forums
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-] Search cess
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i.:4) Job openings
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&y Templates with editable regig =
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This is the starter template for the Members management section of My Community Site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Messages
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e Template code name: My Community Site.Messages
e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.
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1™ CMS Desk Content | Mydesk  Toos  Administration
B [ Be #w | 3 [ &€ 2 | P |
New Delete |=Move & Down ‘ Edit Preview Live site List | Search |
Content management | View mode | Other |
=€) My Community Site Page  Desgn  Form | Properties
&[5 Blogs General
() & Files
= URL:
[#-L] Forums 2
-] Group pages Template
@ L] Groups Metadata Template
-] Home Categories _MembersManagement Select
-] Logon page Menu [ i i
i a Media e =Save 35 Tiew fempiate & | Page template - Save as new -- Webpage Dialog ﬂ
5[] Members =
o4 M Ve ‘nhert template .‘.!.l Save as new page template
|=J-.] Management Q
a Invitati Related docs —
il Invitations i :;3’ Clone template as ad-hoc
-] Messages L = Template display name: My Community Site - Messages
_n_] Online EECREY E Edittemplate properties Template code name: | My Community Site Messages
-] Profile
3 Nn_] Attachments Template category Iy Community Site templates [+]
- ews
| a Search Inherit content This i= the Messages page of My -
@ Use page template setings Communicy Site.
El @ Do notinheritany content Template description

() Selectinherited levels

ok [ Cancel |

http:/flocalr € Local intranet | Protected Mode: OFf

4. Switch to the Page tab. Enter My messages into the Editable text web part's text field and click
Save.

My messages

h
'
'
e

5. Switch to the Design tab. Here, we will only need to add the My messages web part into the
zoneCenter web part zone. Click the Add web part (4) icon of the zoneCenter web part zone and
choose the Messaging -> My messages web part. You do not need to set any properties of the web
part, leave all of them at the default values.

6. The page is now finished, in Design tab, it should look as in the following screenshot.
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3.13.8 Creating the Friends page

[ /membersit /M

-page template: My C

ity Site - M

B

w zoneCenter

v editabletext {2 s

ot

Mew message Delete all messages

Ignore list

0 unread message(s) of 0 total

= zoneRight +

232 Kentico
#g%  CMS Desk

[ copy

New JDelete = Mowve

Content

T up

J} Dxawn

Content management

.;l-t;_"] My Community Site

@[] Blogs

-5 Files

ﬂ,_, Forums

,_, Group pages
-] Groups

_, Home

,_, Logon page
[ Media

;|,_, Members

jl_, Management
o ol Invitations

L[] Profile

My desk

Tools Administration

4 [ =
Edit Preview Live site List

View mode

+ Members » Management

| New document

Please select new document type:

|| Page (menu item)

] Blog
3 cell phone
| Event

I Event (booking system)
@ EAQ

Switch

)3
Search
Other

= |ogonminiform @,!
-

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

+ BlogsRepeater !@Z‘!

My Blogs

You currently do not have any
blogs.

|
My groups

Currently is not member of any
group.

‘

Forum favorites

Mo favorites found

On the Friends page, users will see an oveniew of their friends, provided by the Friends viewer web
part. Users will be able to request new friendships from this page too. There will also be a link to the
Manage friends page which we will create in the following example. Detailed information on the Friends

module can be found in Kentico CMS Deweloper's Guide -> Module Friends.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _MembersManagement page template created in
this chapter. Into the Page name field, enter Friends and click Save.

22 Kentico

1% CMSDesk Content | My desk
;‘ [ Copy T up
New Deleste =bMove & Down

Content management

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688

Tools Administration

2 @ @@ =5 | L

Edit Preview Live site List Search

View mode || other

=] \;_;l My Community Site
-] Blogs
(-5 Files
(&)-L] Forums
|| Group pages
-] Groups
|| Home
-] Logon page
] Media
=)+ | Members
2 [1[Management
|| Invitations
: -] Messages
~-|] online
[ Profile
] News
- | Search

» Members » Management

Save and create another

Page name: Friends

= Spell check

@ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates Template name:
:‘] Articles
: ::i Blank pages for widgets
. Blogs

: ;'} Community Site
3 :ﬂ Corporate Site ASPX
i) E-commerce

Access

: ;'} Home pages
iy Images

:‘} Job openings
) Knowledge base
:‘] Master templates

tﬂ Membership and security Blog creation Blog list Blog posts Blogs
i) Message boards

: ;'} My Community Site templates
L) News

:‘} Newsletter

L) Offices

:‘] Press releases

: ::i Products

i.:4) Templates with editable regio
La) wiki _MembersManagement

123

This is the starter template for the Members management section of My Community Site.

_GroupsT I _Member _StarterTemplate My Community Site -

My Community Site - My Community Site - My C: ity Site - My C ity Site -

Sign out

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Friends
Template code name: My Community Site.Friends

Template category: My Community Site templates

Template description: some text describing the page template

m

© 2011 Kentico Software




262

Kentico CMS 5.5 R2 Community Site Guide

-‘:’- Kentico Switch to Site Manager
1% CMSDesk Content | Mydesk  Tools  Administration
— — = 5 = —
ENFEEERE TN o - IO =N N
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
=] {‘_," My Community Site Page  Design  Form | Properties
‘?J '—I B.Iogs General
(4[] Forums =
i..[] Group pages Template
5--3 Groups Metadata Template
[] Home Categories _MembersManagement Select
[ Logon page Menu g - )
[l Media - S A e | Page template - Save as new -- Webpage Dialog @
-2 Members — =
2 B Mot Versions @ bt empigte /= Save as new page template
7 H a 3 d Related docs .
Ll iFnends g =3/ Clone template as ad-hoc
i [] Invitations Linked docs = Template display name: |My Community Site - Friends
B || Messages 2 E Edit template properties Template code name: | My Community Site Friends
5 On';_n‘e - Template category My Community Site templates [=]
] Profile
D News Inherit content This i? t.he_l-‘riends page of My -
H D Search @ Use page template settings Community Site.
H @ Do notinherit any content Template description:
() Selectinherited levels
http://localk @ Local intranet | Protected Mode: Off

Site: My Community Sitalzl User: Global Administrator v5.0.3

4. Switch to the Page tab. Enter My friends into the Editable text web part's text field and click Save.

EI'U'Iy friends

5. Switch to the Design tab. Frist, we will add the Request friendship web part, which will enable users
to request other users' friendship. Click the Add web part (%) icon of the zoneCenter web part zone
and choose the Community -> Friends -> Request friendship web part. Set only the following

property of the web part, leave the rest at the default values.

e Link text: Add a friend

Click OK.

6. Below, we will place the Static text web part with a link to the Manage friends page. Click the Add
web part (4F) icon of the zoneCenter web part zone and choose the Text -> Static text web part. Set
the following properties of the web part, leave the rest at the default values.

e Web part control ID: ManageFriendsLink
e Text:

<span cl ass="ManageFri ends"><a href ="~/ Menber s/ Managenent / Manage- f ri ends. aspx" >
Manage ny friends</a></span><br /><br /><br />

Click OK.
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7. Finally, we will add the Friends viewer web part, which will display the user's friends. Click the Add
web part (4F) icon of the zoneCenter web part zone and choose the Community -> Friends ->
Friends viewer web part. Set the following properties of the web part, leave the rest at the default
values.

e Transformation name: Community. Transformations.MembersList
Hide if no record found: disabled

No record found text: You currently do not have any friends.
Friend status: Approved

Click OK.

8. The page is finished. In Design tab, it should look as in the following screenshot.

|V /Members/Management/Friends - page template: My Community Site - Friends y|
T zoneCenter
= * = zoneRight +
v editabletext {2 =
= |ogonminiform g:}
v Shorteuts
* RequestFriendship @} S ortcuts@
= ManageFriendsLink @} My profile
Edit my profie

My invitations
Create a new group
Create a new blog
Sign out

+ BlogsRepeater @}

My Blogs

You currently do not have any
blogs.

|
My groups

Currently is not member of any
group.

‘

Forum favorites

Mo favorites found

3.13.9 Creating the Manage friends page

The Manage friends page, as its nhame should indicate, will provide users with the friendship
management functionality. It is accessible from the Friends page created in the previous chapter. The
friendship management functionality will be provided by the My friends web part.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.
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212 Kentico

#g% CMS Desk

— N c
% (=1 Copy

New | Delete |=b Move

Content management

cl\-_’J My Community Site
@2l Blogs
(5.5 Files
|1|,_| Forums
I_| Group pages
-] Groups
I_| Home
|1 Logon page
[ Media
5[] Members
; 5-L1/Management
¢ . Friends

,_| Invitations

i -] Messages
-] online

Content

Switch
My desk Tools Administration
T 4 & [ = e
& Down Edit Preview Live site List Search
View mode Other

» Members » Management

-] New document

Please select new document type:

[] Page (menu item)

¥ Blog
B cell phone
P Event

[ Event (booking system)
@ Ea0

2. Select the My Community Site templates -> _MembersManagement page template created in
this chapter. Into the Page name field, enter Manage friends and click Save.

212 Kentico
#1%  CMS Desk

Content | My desk
3 D Copy T up
=| x =
New Delete = Move & pown

Content management
= v)") My Community Site
(#-|] Blogs
(-5 Files
@] Forums
|| Group pages
[#-.| Groups
| Home
|| Logon page
-] Media
[=1-l-] Members
=) |.1|Management
i | Friends
-] Invitations
H L] Messages
+- ] online
e ._I Profile
] News
-] Search

Switch to Site Manager

Tools  Administration

A @ @ = L

Edit Preview Live site List Search
View mode Other

» Members » Management

E‘ Save and create another

Page name: Manage fiiends

@ Usepagetemplate . Inheritfrom parentpage @ Create a blank page

=] .'_w}' All page templates Template name:
L) Articles

P Blank pages for widgets

L&y Blogs

;‘] Community Site

i.%) Corporate Site ASPX.

i) E-commerce

Site: | My Community Site[»| User: Global Administrator v5.0.3682

_GroupsT:

_Member

: &) Events

L) FAQs

i Forums

‘) General

;‘] Home pages

& Images

i.:4) Job openings

: ;'} Knowledge base

.4y Master templates

i i5) Membership and security
i3 Message boards

i) [My Community Site templates
@) News

i) Newsletter

: &) offices

(.1 Press releases

i) Products

i) Templates with editable regio

Loh) wiki

My Community Site -
Blog creation

My Community Site -
Blog list

_MembersManagement

Sign out

.

_StarterTemplate My Community Site -
Access

m

My Ci ity Site -

Blog posts

My C ity Site -

Blogs

This is the starter template for the Members management section of My Community Site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Manage friends
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e Template code name: My Community Site.ManageFriends
e Template category: My Community Site templates
e Template description: some text describing the page template

Click OK. Click Save.

265

-\21- Kentlco Switch to Site Manager Site: My Community Site E| User: Global Administrator v3.0.31
1% CMSDesk Content | Mydesk  Took  Administration
2 & Bew %w | G [q 2 | L |
New Delete |= Move & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | other |
(2§ My Community Site Page  Desgn  Form | Properties
‘?J '—I B.Iogs General
(-5 Files
B URL:
(+]-L] Forums i
.| ] Group pages Template
[#-|-] Groups Metadata Template
[] Home Categories _MembersManagement Select
-++[] Logon page Menu s )
H . H #  Page template - Save as new -- Webpage Dialog
: |_| Media Vorkflaw =Sa\te as new template_: =
| Members = =
T @ Management Veri @ Dhertiempiote /=gl Save as new page template
i 8 8 3 F 4 Related docs -
= nends n a3/ Clone template as ad-hoc
|| Invitations Linked docs e Template display name: |My Community Site - Manage friends
g Manage friends Seaai E Edit template properties Template code name: My Community Site ManageFriends
. g] ‘Messages Attachments Template category My Community Site templates [=]
nline
D Profile Inherit content This is the 1:Ianag§ friends page -
a News @ Use page template settings of My Community Site.
: a Search H ) Do notinherit any content Template description
() Selectinherited levels
http://localk € Local intranet | Protected Mode: Off
\

4. Switch to the Page tab. Enter Manage my friends into the Editable text web part's text field and click

Save.

Manage my friends

h
'
'
e

5. The zoneCenter web part zone will host two web parts. The first one of them will be the Static text

web part with a link leading back to the Friends page. Click the Add web part (4) icon of the

zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties of
the web part, leave the rest at the default values.

e Web part control ID: BackToFriends

e Text:

<span cl ass="ManageFri ends"><a href ="~/ Menber s/ Managenent/ Fri ends. aspx">& t;
to friends</a></span><br /><br /><br />

Back

Click OK.
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6. Now we will add the My friends web part used for friends management. Click the Add web part ()
icon of the zoneCenter web part zone and choose the Community -> Friends -> My friends web part.
You do not need to set any properties of the web part. Just leave all of them at the default values and
click OK.
7. The page is finished. In Design tab, it should look as in the following screenshot.
|V /Memb fr it/Manage friends - page template: My Community Site - Manage friends y|
- zorTeCenber _ * ¥ zoneRight +
= editabletext ;e‘z,! ﬂ‘iends * |ogonminiform ’t:!‘,".g
_ ¥ Shorteuts
——
My profile
pending requests  Rejected friends Edit my profile
My messages
Add a friend My friends
My invitations
My current friends Create a new aroup
Mo approved friendships were found. Create a new blog
Sign out
My Blogs
You currently do not have any
blogs.
My groups
Currently is not member of any
group.
‘
Forum favorites
Mo favorites found
3.14 Creating the Special pages
3.14.1 Creating the Special pages folder

The special pages section consists of pages that do not display any content. Instead, these pages
contain special web parts for performing actions like user registration approval, unsubscription from
various notifications, acceptation for group invitation, etc.

In the following example, we will create a folder in which the special pages will be stored.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Folder document
type.
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-‘!’- Kentico Switch

#g% CMS Desk Content My desk  Tools Administration

[=) [=) c u 1 =
D)R B e | 3 Q €@ 2 | L |
| New | Delete |=» Move & pown | Edit  Preview Livesite  List Search |
Content management | iew mode | Other |
n;'l-{n_';a My Community Site My Community Site
-] Blogs =
'ﬂ = ) g New document
(-9 Files ==
(&[] Forums
] Group pages Please select new document type:
g Groups [[] Page (menu item)
-] Home
g Logc_m page T Blo
] Media
(&[] Members <y Eolder
a News
“.[] search £] Link an existing document

2. Enter Special pages into the Document name filed and click Save.

-\ll- Ken tlco Switch to Site Manager

£ CMS Desk

Content My desk Toolz Administration

_\ _x\ E] Copy T up | j E %] | }) |

New Delete [ Move & Down | Edit  Preview Livesite  List | Search |
Content management | iew mode | Other |
n;'l-{n_';a My Community Site My Community Site
-] Blogs
&) Files E Save E‘ Save and create another Spell check
-] Forums
‘.| ] Group pages
: Q PLEL Document name: |Special pages
1| Groups

a Home

a Logon page
a Media
wa Members

3. The folder has been created and the special pages can now be placed under it.
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2)¢ Kentico

‘.‘ CMS Desk Content My desk
[ Copy T up
N;v De_léte = Mave & Down |

Content management

clv_’l My Community Site

(-] Blogs

¢|’£j‘ Files

|1||_] Forums

I_] Group pages
(#-L] Groups

I_] Home

I_] Logon page
[ Media

(1-] Members
I_] News

i[0 search

“..75) Special pages

3.14.2 Creating the Access denied page

The first special page will be the Access denied page. This is where users with insufficient permissions
will be redirected after accessing some secured page. The page will contain only an Editable text web
part which will display the access denied message.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

Switch
232 Kentico
#4% CMS Desk Content My desk Tools Administration
S| [k Blcer W 4  [d = A
New | Delete | = Move & Down | Edit Preview Live site List | Search |
Content management | Wiew mode | COther
.;'l-{-_';: My Community Site b Special pages

3-[2] Blogs -,

-y 4.‘—]_‘ . New document

[+]- = Files =]

|1||_] Forums

‘.[] Group pages Please select new document type:

'1“—] Groups || Page (menu item)

-] Home

I_] Logc.m page il

o] Media

T i) Eolder

-] Members rolder

|_] News

-] search £] Link an existing document

*.75]Special pages

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Access denied and click Save.
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232 Kentico
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-] Logon page
| Media
-] Members
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|| Search
.15 Special pages

Tools Administration
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Edit Preview Live site List

View mode

» Special pages
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Search
Other
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E‘ Save and create another

Page name: Access denied
@ Use page template

54 All page templates

) Artides

;-:i Blank pages for widgets
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E ;'} Community Site

3 ;ﬂ Corporate Site ASPX
;‘} E-commerce

i) Events

-3y FAQs

E &) Forums

i) General

: ;'} Home pages

i) Images
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;‘] Master templates

: J Membership and security
i.i4) Message boards

L) News

;‘} Newsletter
L) Offices

;‘] Press releases
;-:i Products

i.:4) Templates with editable regio

E ;'} Wiki

() Inherit from parent page

: ;'} My Community Site templates

() Create a blank page

Template name:

_Member

_GroupsTi

My Community Site -

Blog creation Blog list

123

_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

My Community Site -

269

Site:| My Community Site[+| User: Global Administrator v5.0.2688

=

_StarterTemplate
Access

My C: ity Site -

Blog posts

My C
Blogs

My Community Site -

ity Site -

Sign out

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Access Denied
Template code name: MyCommunitySite.AccessDenied
Template category: My Community Site templates

Template description: some text describing the page template

m
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Switch to Site Manager Site: My Community Sitelzl User: Global Administrator v5.0.3

22 Kentico

1% CMSDesk Content | Mydesk  Tools  Administration
2 c U
] [ Bow W @ @ =2 | AP
New Delete = Move & pown Edit Preview Live site List Search
Content management | View mode | Other
l:"!‘__" My Community Site Page Design  Form | Properties
‘ﬂ_‘LTIL' Bllogs General
-4 Files Save
e =
(+]-| | Forums
+] Group pages Template
(i) Groups Metadata Template
i ] Home Categories _StarterTemplate ﬁ
i-[] Logon page Mer y
& | Page template - Save as new -- Webpage Dialog &J

©o ] Media

B Workflow
-[| Members

=g e a \nherittemplate 4 Save as new page template
i News f |nnertiempiate
Y s h Related docs .
;id Searc e :}J Clone template as ad-hoc
)5 Special pages L £ h Template display name: |My Community Site - Access Denied
“|]|Access denied Sec E Edit template properties Template code name: | MyCommunitySite AccessDenied
Attachments

Template category: My Community Site templates |E|

This is the Access denied page of =
My Community Site.

Inherit content
@ Use page template settings

—

) Do notinherit any content Template description:

(@) Selectinherited levels

http://localk €L Local intranet | Protected Mode: Off

4. Switch to the Design tab. We will only need to add the Editable text web part into the zoneCenter
web part zone, below the Editable text web part for heading. Click the Add web part (%) icon of the
zoneCenter web part zone and choose the Text -> Editable text web part. You do not need to set any
properties of the web part, just leave all of them at the default values.

In Design tab, the page should now look as in the following screenshot.

|' /special pages/Access denied - page template: My Community Site - Access Denied 2|
w zoneCenter * ¥ zoneRight *
v editabletext {3 ¥ logonminiform {23
v editabletext {3
- or t "

Shortcuts
My profile
Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

5. Switch to the Page tab. You can see two editable text regions on the page now - one for heading and
one for the warning text. Enter the following texts into the text areas:

e Heading: Access denied
e Warning text: You're not allowed to access the required page. Please contact the administrator if
you think you should be allowed to access it.

Click Save.
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Switch to Site Manager  Site: User: Global Adminis

=32 Keatico y ty i [<]

0% CMSDesk | |'conent | Mydesk  Tools  Administration

= = — —

1 Co u

LB g Gon R | [d [e] A
| New Delete = Move & Down | Edit Preview Live site List | Search
'_ Content management '_ View mode | other
=) My Community Site | Page | Desgn  Form  Froperties

(i-[] Blogs

-3 Files Spell check
-1 Forums

D Group pages

&L Groups

Esowce | BI) RRBEEIS! o M %
HED=0& S0 0w d

Style + | Format | Nomal - Font *| Size

B #iB 7 U #¢|x x

[ Home

i.[]] Logon page
; [ Media
(-] Members
L[] News

‘.| ] Search Current user: Global Administrator (administra
=)-%5) Special pages
“..[][Access denied

i}

-

The changes were saved.

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is

with blanle p

Community

Starter site

| You're not allowed to access the required page. Please contact the administrator if you think you should be allowed to access it.|

n

The page is complete. If you view it in Live site mode, you should see the page as in the following
screenshot. Please note that the Logon mini form is displayed only to unauthenticated users.

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Blogs Forums  Groups Home  Media  Members  News | | || searcn

Access denied

Shortcuts

My profie
Edit my profile

‘fou're not allowed to access the required page. Please contact the administrator if you think you should be allowed to access it.

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out
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3.14.3 Creating the Blog unsubscribe page

The Blog unsubscribe page will be used to handle blog post unsubscription requests. Users are able to
subscribe to receiving notifications about new blog comments on a particular blog post. Notification e-
mails contain an unsubscription link leading to this page with the subscription GUID in the query string
parameter. By clicking this link, users can unsubscribe from receiving the notifications. The
unsubscription request is handled by the Blog post unsubscription web part on this page.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings -> Blogs
-> Blog unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

Switch
=32 Kentico S
#1% CMS Desk Content My desk Tools Administration
] g B W (4 [d = r
New | Delete = Move & pown | Edit Preview Live site List Search |
Content management | iew mode | Other |

.;'l-{-_';: My Community Site » Special pages

7-[] Blogs -
= cr";. Files New document
&- =
|1||_] Forums

-] Group pages Please select new document type:
'ﬂj Eroups [ Page (menu item)

..[7] Home

[ Logon page e

L] Media :L‘_

(&[] Members ) Folder

|_] MNews

+--[] search %] Link an existing document

=) Special pages
i..[] Access denied

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Blog unsubscribe and click Save.
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232 Kentico

1% CMSDesk Content | My desk
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(-5 Files
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(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
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|| Search
(=) %5 Special pages
~-|.] Access denied

Tools Administration
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Edit Preview Live site List

View mode

» Special pages

Switch to Site Manager

Search
Other
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E‘ Save and create another

Page name: Blog unsubscribe
@ Use page template

54 All page templates

) Articles
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Blogs
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L& Events

-3y FAQs

: J Forums
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: ;'} Home pages

iy Images
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) Knowledge base

;‘] Master templates

: J Membership and security
i.:4) Message boards

: ;'} My Community Site templates
L) News

;‘} Newsletter

L) Offices

;‘] Press releases

;-:i Products

i.:4) Templates with editable regio

E ;'} Wiki

() Inherit from parent page

() Create a blank page

Template name:

_Member

_GroupsTi

My Community Site -

Access Denied Blog creation

123

_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

My Community Site -

273

Site:| My Community Site[+| User: Global Administrator v5.0.2688

=

_StarterTemplate

Access
My C: ity Site - My C ity Site -
Blog list Blog posts

My Community Site -

Sign out

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Blog unsubscribe
Template code name: MyCommunitySite.BlogUnsubscribe
Template category: My Community Site templates

Template description: some text describing the page template

m
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Switch to Site Manager Site: My Community Sitelzl User: Global Administrator v5.0.3

22 Kentico

1% CMSDesk Content | Mydesk  Tools  Administration
(= = Co u o S|
B [ Bee #w | 3 [q =2 | L
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
=14 ) My Community Site Page  Design  Form | Propertes
‘ﬂa Blogs General
‘ﬂﬁ e
L= URL:
(-] Ferums =
.[] Group pages Template
L a Groups Metadata Template
i..[]] Home Categories _StarterTemplate Select
‘| Logon page Menu g N
= £ | Page template - Save as new -- Webpage Dialog @
9 Media Workflow
-] Members 2 i =
I Ve @ Inhenttempiate ,\.!.ﬂ Save as new page template
i) News A, lnherilemplate
Bs h Related docs —
EETRe il :;J Clone template as ad-hoc
)5 Special pages Linl = = Template display name: |My Community Site - Blog unsubscribe
g Access denied e E Edit template properies Template code name:  MyCommunitySite. BlogUnsubscribe
--|_||Blog unsubscribe
|I/Blog Attachments Template category: Wy Community Site templates [+
Inherit content This 1is the l?lug \_Jnsubscribe page =
@ Use page template setings of My Community Site.
H ) Do notinherit any content Template description

(@) Selectinherited levels

[ ok [ cancel |

http://localk €& Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Blog unsubscribe into the Editable text web part's text box. Click
Save.

Blog unsubscribe

h
'
'
e

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Blogs -> Blog post unsubscription web part. Set the following properties of the web part,
leave the default values for the rest of them:

e Confirmation text: You have been successfully unsubscribed.
e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.
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| - [Special pages/Blog unsubscribe - page template: My C

B

w zoneCenter

v editzbletext {3 cribe

| * BlogPostUnsubscription @,! |

= zoneRight o
¥ |ogonminiform @}
|

Shortcuts

3.14.4 Creating the Board unsubscribe page

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

This page will be used to handle message board unsubscription requests. There are several message
boards throughout the whole site. Users can subscribe to receiving e-mail notifications about new
messages on a particular board. The notification e-mails contain an unsubscription link leading to this
page. When a user clicks it, they are redirected to this page with the subscription GUID in query string
parameter. On the page, the Message board unsubscription web part will handle the request and

perform unsubscription.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings ->
Message boards -> Board unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico

’.‘ CMS Desk Content My desk
> Copy ¥ up
iz B
MNew |Delete |= Move & Down

Content management
|:'l-\_;_"1 My Community Site
-] Blogs
.ﬂfj Files
|1|,_| Forums
,_| Group pages
@2 Groups
._I Home
,_| Logon page
[ Media
1] Members
|_| News
i) search
=)&) Special pages
-] Access denied
“..[] Blog unsubscribe

Tools Administration

4 [d B H

Edit Preview Live site List

View mode

» Special pages

New document

Please select new document type:

| Page (menu item)

%] Link an existing document

Switch

A

Search
Other

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Board unsubscribe and click Save.
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:!:_. Kentico

[ Copy T up
& Down

Content management

%

New Delete [ Move

=] n_;_;l My Community Site
(x-l] Blogs
(-G Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
-] News
|| Search
(=)-GSpecial pages
-] Access denied
B || Blog unsubscribe

CMS Desk Content | My desk

Tools Administration

2 [d =
Edit Preview Live site List

View mode

» Special pages

Switch to Site Manager

P

Search
Other

Spell check

Page name: Board unsubscribe

E‘ Save and create another

@ Use page template

54 All page templates

) Articles

;-:i Blank pages for widgets
Blogs

: ;ﬂ Community Site

3 ;ﬂ Corporate Site ASPX
;‘J E-commerce

L& Events

-3y FAQs

: j Forums

i) General

: ;ﬂ Home pages

iy Images

;‘J Job openings

) Knowledge base

;‘] Master templates

: j Membership and security
i.:4) Message boards

: ;ﬂ My Community Site templates
L) News

;‘J Newsletter

L) Offices

;‘] Press releases

;-:i Products

i.:4) Templates with editable regio

E ;ﬂ Wiki

() Inherit from parent page

() Create a blank page

Template name:

Site:| My Community Site[+| User: Global Administrator v5.0.2688

_Member

_GroupsTi

My Community Site -

Access Denied Blog creation

123

_StarterTemplate

_StarterTemplate

Sign out

=

My Community Site -
Access

m

My Community Site - ity Site - My C

ity Site -
Blog posts

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Board unsubscribe
Template code name: MyCommunitySite.BoardUnsubscribe
Template category: My Community Site templates

Template description: some text describing the page template
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Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.3

2 Kentico

1% CMS Desk Content | Mydesk Took  Administration
= B Co U = -
B @ Bew % | 3 [q =2 | L
New Delete = Move & pown ‘ Edit Preview Live site List | Search |
Content management | View mode | other |
d-{-__'l My Community Site Page Design  Form | Properties
@-[2 Blogs General
‘ﬂﬂj les =
(#)-|] Forums =
‘[ Group pages Template
L D Groups Metadata Template
i..[]] Home Categories _StarterTemplate ﬁ
‘| Logon page Menu i N
= & | Page template - Save as new -- Webpage Dialog ﬂ
g Hedia Workflow
)-|] Members 2 o =
B News Versa @ Iohenttemolate ;;gl: Save as new page template
search Related docs —
|_] e L :;J Clone template as ad-hoc
)5 Special pages L = = Template display name: |My Community Site - Board unsubscribe
g Access denied Seasug E Edit template properties Template code name: | MyCommunitySite BoardUnsubscribe
.| Blog unsubscribe Attachments
g = . Template category: My Community Site templates
‘.| |Board unsubscribe - Ll B E
Inherit content This is the Bnardr\mgulrjscriba -
@ Use page template settings page of My Community Site.
H () Do notinherit any content Template description:

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off
\

4. Switch to the Page tab and enter Blog unsubscribe into the Editable text web part's text box. Click
Save.

Blog unsubscribe

h
'
'
e e e

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Message board -> Message board unsubscription web part. Set the following properties
of the web part, leave the default values for the rest of them:

e Confirmation text: You have been successfully unsubscribed.
e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.
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|'fSpeu'alpags,anard bscribe - page late: My C ity Site - Board unsubscribe

B

= zoneCenter

v editabletext (&3 cribe

|v MessageBoardUnsubscription @|

¥ zoneRight o
= logonminifarm @
-

Shortcuts

3.14.5 Creating the Forum unsubscribe page

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

The last of the unsubscription pages is the Forum unsubscribe page. In the Forums section, users have
the possibility to subscribe to receiving notification e-mails about new posts in a particular forum thread.
The notification e-mails contain unsubscription links leading to this page. The GUID of the subscription is
contained in the querystring parameter. The main part of this page is the Forum unsubscription web
part. When a user clicks the unsubscription link, they are redirected to this page where the web part

handles the unsubscription request.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings ->

Forums -> Forum unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)

document type.

Switch
232 Kentico —
#§% CMS Desk Content My desk  Tools Administration
> C u
1 ) Boer Tw | 3 [{ = | L
New |Delete |=Move & Down Edit Preview Live site List Search
Content management | View mode | Other
(=€) My Community Site > Special pages
3-[ Blogs Yy
e New document
B Files .
-] Forums
._I Group pages Please select new document type:
‘1"—‘ EIELIE [] Page (menu item)
-] Home
i-[] Logen page i File
L[] Media R
L =
-] Members &y Folder
-] News
-] search %] Link an existing document

=)&) Special pages
-] Access denied
-] Blog unsubscribe
“..[] Board unsubscribe

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the

Page name field, enter Forum unsubscribe and click Save.
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232 Kentico

1% CMSDesk Content | My desk
3 x [ Copy T up

New Delste =Move 4 Down

Content management

=] Q_;l My Community Site
(x-l] Blogs
(-5 Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
-] News
|| Search
(=) %5 Special pages
-] Access denied
:--|] Blog unsubscribe
E I_| Board unsubscribe

Tools Administration
(4 [ [ B
Edit Preview Live site List

View mode

» Special pages

Switch to Site Manager

Search
Other

Spell check

E‘ Save and create another

Page name: Forum unsubscribe
@ Use page template

54 All page templates

) Articles

;-:i Blank pages for widgets
Blogs

: ;'} Community Site

3 ;ﬂ Corporate Site ASPX
;‘} E-commerce

L& Events

-3y FAQs

: J Forums

i) General

: ;'} Home pages

iy Images

;‘} Job openings

) Knowledge base

;‘] Master templates

: J Membership and security
i.:4) Message boards

: ;'} My Community Site templates
L) News

;‘} Newsletter

L) Offices

;‘] Press releases

;-:i Products

i.:4) Templates with editable regio

E ;'} Wiki

() Inherit from parent page

() Create a blank page

Template name:

_Member

_GroupsTi

My Community Site -

Access Denied Blog creation

123

_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

My Community Site -

279

Site:| My Community Site[+| User: Global Administrator v5.0.2688

=

_StarterTemplate

Access
My C: ity Site - My C ity Site -
Blog list Blog posts

My Community Site -

Sign out

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Forum unsubscribe
Template code name: MyCommunitySite.ForumUnsubscribe
Template category: My Community Site templates

Template description: some text describing the page template

m
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Switch to Site Manager Site: My Community Site E| User: Global Administrator v5.0.31

22 Kentico

1% CMSDesk Content | Mydesk  Took  Administration
) B O fw |3 @ @ B | AL
New Delete |=»Move & Down Edit Preview Live site List Search
Content management | View made |l other
(2§ My Community Site Page  Desgn  Form | Properties
4 — B.Iogs General
(-5 Files E Save
e URL: =
[)-|] Farums £
.| ] Group pages Template
-1 Groups Metadata Template
i+|2] Home Categories _StarterTemplate Select
;"L Legon page Mem P Jate - S Webpage Dial i |
P . H & | Page template - Save as new - Webpage Dialog
o[ Media Vorkflaw Save as newlemplate i
-] Members 2 =
T ere @ bhertempiate ,__.gﬁ Save as new page template
L[] News
[ h Related docs -
i ear«.: i :,J Clone template as ad-hoc
(=)-5) Spedial pages e h Template display name: |My Community Site - Forum unsubscribe
[l Access denied S [H Edittemplate properties Template code name: | MyCommunitySite. ForumUnsubscribe
|| Blog unsubscribe Attachments
;g blog el Template category My Community Site templates [=]
i | Board unsubscribe
This is the Forum unsubscribe -

“...| )|[Forum unsubscribe Inherit content

@ Use page template settings page of My Community Site.

(©» Do notinherit any content Template description

—

() Selectinherited levels

http://localk €& Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Forum unsubscribe into the Editable text web part's text box. Click
Save.

Forum unsubscribe

h
'
'
e e e

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Forums -> Forum unsubscription web part. Set the following properties of the web part,
leave the default values for the rest of them:

e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

|v /5pecial pages/Forum bscribe - page late: My C ity Site - Forum unsubscribe p|

w zoneCenter *

= zoneRight o

v editabletext & i . %
FEEED ‘fﬁ:} Scl‘lbe = logonminiform Qg‘n:!
|
s

My profile
Edit my profie

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out
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3.14.6 Creating the Friend management page

One of the community features in Kentico CMS is the Friends module. It provides users the possibility of
creating social relations - friendships. This special page will contain the Friendship management web
part, which handles the friendship approval or rejection requests.

In order to for the page to be functional, you need to set its alias path in Site Manager -> Settings ->
Community -> Friend management path, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico

'l\ CMS Desk Content My desk Tools
[ Copy T up [
New |Delete mMove  $Down | Edi

Content management

Switch
Administration

@ @© B2 A

Preview Live site List | Search |
View mode Other

:lp_’l My Community Site

+ Special pages

5[] Blogs -
- f‘—;‘ Fiod New document
@ =]

|1||_] Forums

|_] Group pages Please select new document type:
‘ﬂj EmuDs [] Page (menu item)

L[] Home

I_] Logon page (e File

] Media -

= &

-] Members 9 Folder

|_] News

“[] search %] Link an existing document

25| Special pages

i[] Access denied
I_] Blog unsubscribe
:-[] Board unsubscribe
“..[] Forum unsubscribe

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Friend management and click Save.
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22 Kentico
% CMS Desk

“1 Content | My desk
3 3 [ copy T up
= ® -

New Delete |=»Move & Down

Content management

=] n_;_;l My Community Site
(x-l] Blogs
(-G Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
-] News
|| Search
(=)-GSpecial pages
-] Access denied
B || Blog unsubscribe
: |1 Board unsubscribe
“[] Forum unsubscribe

Tools Administration

2 [d =
Edit Preview Live site List

View mode

» Special pages

Switch to Site Manager

P

Search
Other

Spell check

E‘ Save and create another

Page name: Friend management
@ Use page template

54 All page templates

) Artides

;-:i Blank pages for widgets
Blogs

E ;ﬂ Community Site

3 ;ﬂ Corporate Site ASPX
;‘J E-commerce

i) Events

-3y FAQs

E &) Forums

i) General

: ;ﬂ Home pages

i) Images

;‘J Job openings

) Knowledge base

;‘] Master templates

: j Membership and security
i.i4) Message boards

L) News

;‘J Newsletter
L) Offices

;‘] Press releases
;-:i Products

i.:4) Templates with editable regio

E ;ﬂ Wiki

() Inherit from parent page

: ;ﬂ My Community Site templates

() Create a blank page

Template name:

_Member

_GroupsTi

My Community Site -

Access Denied Blog creation

123

_StarterTemplate

My Community Site -

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

=

_StarterTemplate

My Community Site -

Access
My C: ity Site - My C ity Site -
Blog list Blog posts

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Friend management
Template code name: MyCommunitySite. FriendManagement
Template category: My Community Site templates

Template description: some text describing the page template
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Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.
22 Kentico v ty Site [+
‘.‘ CMS Desk Content My desk Tools Administration
E Hleeey Hup ¥ E = | j)
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
d'?"{_.,'i My Community Site Page Design Form Properties
(-] Blogs
(-G Files e E Save
u a Forums i
+
; [l Group pages Template
@ a Groups Metadats Template
a Home Categories StarterTemplate Select
g L p!
.- [ Logon page Menu [ i )
1 Media s . e e A & Page template - Save as new -- Webpage Dialog ﬂ
(@[] Members 2 e /=
" 3 News Versians @ oherttempiate /=g, Save as new page template
P Related docs -
LB s h ]
H R 1 @3/ Clone template as ad-hoc
[ % Special pages gLl = Template displayname: [My Community Site - Friend management
L] Access denied Searng [ Edittemplate properties Template code name | MyCommunitySite. FriendManagement
_'—j Blog unsubscribe Attachments Template categary My Community Site templates |Z|
-] Board unsubscribe — -
D Forum unsubscribe Inherit content This is the FIlEnt}s mar}agament -
[ [Friend management @ Use page template settings page of My Community Site.
H Do notinherit any content Template description:

() Selectinherited levels

ok " Cancel |

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Friend management into the Editable text web part's text box.
Click Save.

Friend management

h
'
'
e e e e e

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Community -> Friends -> Friendship management web part. Set the following properties
of the web part, leave the default values for the rest of them:

My friends page path: /Members/Management/Friends
Send notification message: enabled

Send notification e-mail: enabled

Content after: <br /><br />

Click OK. The page is now finished and ready to handle the friendship management requests.
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| = [Special pages/Friend management - page template: My Community Site - Friend management y|
¥ zoneCenter *

= zoneRight *
v editabletext & z

FLESEEN \‘?B gement = logonminiform ’tg‘,!
|
|V FriendshipManagement @,!| Sl ortcuts@

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

3.14.7 Creating the Invitation acceptation page

This special page is related to Kentico CMS Groups module. Members of a group can send e-mail
invitations to join the group. In the e-malil, there is a link leading to this page with the invitation GUID in
query string parameter. When a user clicks the link, they will be redirected to this page where the
Group invitation web part handles the invitation and makes the user a member of the group.

In order to for the page to be functional, you need to set its alias path in Site Manager -> Settings ->
Community -> Invitation acceptation path, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

Switch
232 Kentico Switeh
'l‘ CMS Desk Content My desk Tools Administration
= C u
x [Jooer  Ww 4 [d = r
New | Delete |=» Move & Down Edit Preview Live site List Search
Content management iew mode Other
.:l-\;_"l My Community Site » Special pages
|| Blogs >
e ;'_‘ . New document
[+ Files
(&[] Forums
‘.[] Group pages Please select new document type:
‘1“—| Groups [[] Page (menu item)
=] Home
i] Logon page g File
[ ] Media T
T i Eolder
[~ Members
._I News
‘[ ] search %] Link an existing document

.;Mf_;‘ Special pages
] Access denied
_| Blog unsubscribe
i-[] Board unsubscribe
[ Forum unsubscribe
,_| Friend management |:|

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Invitation acceptation and click Save.
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.}!‘. Kentico Switch to Site Manager  Site: |My Community Site[+] User: Global Administrator v5.0.3688
1% CMSs Desk Content | Mydesk  Took  Administration
> 3 c U
0 [ Do Tw 4 [ [ &
New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management | View mode || other
=] Q_;l My Community Site + Special pages
(x-l] Blogs
)G Files E‘ Save and create another
(#-l.] Forums
|| Group pages Page name: Invitation acceptation
(+)-.| Groups
[] Home @ Use page template () Inheritfrom parentpage () Create a blank page
-] Logon page _ ]
T Media =& All page templates Template name:
= ) Articles
-] Members [
-3 News : ©y Blank pages for widgets
[] search a3 Blogs

: ;'} Community Site

(3 ;ﬂ Corporate Site ASPX

i) E-commerce

&y Events _GroupsT

()5 Special pages
-] Access denied
:--|] Blog unsubscribe
E [ Board unsubscribe
“[] Forum unsubscribe
e ._I Friend management H

_Member

B ;'} Home pages
Images

H Job openings

4y Knowledge base

) Master templates My Community Site - My Community Site -
{i Membership and security Access Denied Blog creation
i) Message boards

: ;'} My Community Site templates

L) News

;‘} Newsletter

L) Offices

;‘] Press releases

;-:i Products

. 123
Templates with editable regig —

La) wiki _StarterTemplate

_StarterTemplate My Community Site -

Access

ity Site - My C ity Site -
Blog list Blog posts

Sign out

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

e Template display name: My Community Site - Invitation acceptation
e Template code name: MyCommunitySite.InvitationAcceptation

e Template category: My Community Site templates

e Template description: some text describing the page template

Click OK. Click Save.

m
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Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.3

2 Kentico

1% CMS Desk Content | Mydesk Took  Administration
= c U
] [w Dleew  Ww 4 [d =2 | A
New Delete = Move & pown Edit Preview Live site List Search
Content management | View mode | Other
(=) My Community Site Page  Design  Form | Properties
‘1“—‘ Bloos General
()-53) Files
A LRL
(#)-l] Forums . —_—
[ ) Group pages Template
(-] Groups Metadats Template
] Home Categories _StarterTemplate ﬁ
R Y
g ‘—‘ Dg?n (it i, | Page template - Save as new -- Webpage Dialog Iﬁ
| Media Workflow —
-] Members 2 - sl Save as new e template
il Wersions Q Inherit template “'4 o -
o[ News
s h Related docs —
¢ lEl Seard &+ Clone template as ad-hoc
5 Special pages Linked docs = Template display name: My Community Site - Invitation acceptation
; [] Access denied Security E Edit template properties Template code name:  |MyCommunitySite. InvitationAcceptation
-] Blog unsubscribe Attachments Template category My Community Site templates [=]
‘|| Board unsubscribe R . .
g N . This i= the Invitation -
i |1 Forum unsubscribe Tnherit content

_ acceptation of My Community Site.
@ Use page template settings = o ¥

; || Friend management X
) Do natinherit any content Template description

§ _1 Invitation acceptation

==

(@) Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Invitation acceptation into the Editable text web part's text box.
Click Save.

Invitation acceptation

h
'
'
e

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Community -> Group invitation web part. Set the following properties of the web part,
leave the default values for the rest of them:

e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the invitations.

|' /5pecial pages/Invitation acceptation - page template: My C ity Site - itati i y|

¥ zoneCenter *

= zoneRight o

ditabletext & - =
v editabletex “é} ceptat|on + logonminiform ’@‘:}
-
o

My profile
Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out
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3.14.8 Creating the Registration approval page

After registration to the page, users don't become members immediately. Instead, an e-mail is sent to
them with the registration approval link. The link is leading to this page and contains the registration
GUID in query string parameter. When the user clicks this link, the Registration e-mail confirmation
web part on this page handles the registration approval request and the user becomes a member.

In order to for the page to be functional, you need to set its URL into E-mail confirmation page
property of the Custom registration form web part, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

Switch
22 Kentico

'l\ CMS Desk Content My desk Toals Administration

)| [ o W 4 & [ = p2
New | Delete = Move & Down | Edit Preview Live site List | Search |

Content management | View mode | Other
.;'l-{-_';: My Community Site + Special pages

3-[.] Blogs .

'—' _‘;l ) g New document

[+ Files —

|1||_] Forums

‘[ ] Group pages Plaase select new document type:

'1“—] Srotes |1 Page (menu item)

++|] Home

I_] Logon page File

o] Media

i = =

[#)-|] Members S Folder

|_] News

-] search %] Link an existing document

=)&) Special pages

i Access denied

I_] Blog unsubscribe
i-[] Board unsubscribe
:-[] Forum unsubscribe
I_] Friend management
L[] Invitation acceptation

—

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Registration approval and click Save.
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232 Kentico

1% CMSDesk Content | My desk
3 x [ Copy T up

New Deleste =bMove & Down

Content management

=] n_;_;l My Community Site
(x-l] Blogs
(-5 Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
-] News
|| Search
(=) %5 Special pages
-] Access denied
:--|] Blog unsubscribe
g I_| Board unsubscribe
:.[] Forum unsubscribe
3 ._I Friend management
* ] Invitation acceptation

Tools Administration
2 [d =
Edit Preview Live site List

View mode

» Special pages

Switch to Site Manager

P

Search
Other

Spell check

E‘ Save and create another

Page name: Registration approval
@ Use page template

54 All page templates

) Articles

;-:i Blank pages for widgets
Blogs

: ;ﬂ Community Site

3 ;ﬂ Corporate Site ASPX
;‘J E-commerce

L& Events

-3y FAQs

: j Forums

i) General

: ;ﬂ Home pages

iy Images

;‘J Job openings

) Knowledge base

;‘] Master templates

: j Membership and security
i.:4) Message boards

: ;ﬂ My Community Site templates
L) News

;‘J Newsletter

L) Offices

;‘] Press releases

;-:i Products

i.:4) Templates with editable regio

E ;ﬂ Wiki

() Inherit from parent page

() Create a blank page

Template name:

_Member

_GroupsTi

My Community Site -

Access Denied Blog creation

123

_StarterTemplate

My Community Site -

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

=

_StarterTemplate

My Community Site -

Access
My C: ity Site - My C ity Site -
Blog list Blog posts

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Registration approval
Template code name: MyCommunitySite.Registration approval
Template category: My Community Site templates

Template description: some text describing the page template
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-\21- Kentlco Switch to Site Manager Site: My Community Site E| User: Global Administrator v3.0.31
1% CMSDesk Content | Mydesk  Took  Administration
= Co U — —
2 G Bew ®w | 3 g SR
New Delete |= Move & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | other |
(2§ My Community Site Page  Desgn  Form | Properties
@ a Blogs General
‘ﬂ @ les -
(4] Forums :
i..[]] Group pages Template
-] Groups Metadata Template
|| Home Categories _StarterTemplate [ Select |
] Logon page Menu . = N
: [ Media " [ e e ferniate ] & | Page template - Save as new -- Webpage Dialog ﬂ
(-1 Members j = =
B News Vs @ ‘henttempiate ,\.!.ﬁ Save as new page template
q :I S h Related docs -
: e o ;:‘4 Clone template as ad-hoc
[5-%5) Special pages =l = Template display name: |My Community Site - Registration approval
g Access denied Seasy E Edittemplate properties Template code name: | MyCommunitySite. Registration approval
Blog unsubscribe
g I} Attachments Template category Wy Community Site templates |Z|
|| Board unsubscribe — - -
a Fonan msuhsaibe Inherit content Il’fu; 1§ the l?egl:?rat,lun approval =~
a Friend management @ Use page template settings © ¥ Community Site.
i-[] Invitation acceptation H (» Do notinherit any content Template description
D Registration approval ) Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Registration approval into the Editable text web part's text box.
Click Save.

Registration approval

h
'
'
..

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Membership -> Registration e-mail confirmation web part. Set the following properties of
the web part, leave the default values for the rest of them:

e From address: no-reply @mycommunitysite.com

e Administrator e-mail: admin@mycommunitysite.com

e Notify administrator: enabled

e Successful approval text: Your user account is now active. You can sign in using your user name
and password. <a href="~/Logon.aspx" title="Logon page">Click here to continue</a>

e Unsuccessful approval text: Your registration wasn't approved.

e User deleted text: The user account has been already deleted.

e Content after: <br /><br />

Click OK. The page is now finished and ready to handle the registration approval requests.
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| - /Special pages/Registration approval - page template: My Community Site - Registration approval y|
* zoneCenter _ v zoneRight +
[zt Bl approval ~ logonmiiform (53
w 5h i
|V RegistrationConfirmation @g‘
My profile
Edit my profile
My messages
My friends
My invitations
Create a new group
Create a new blog
Sign out
3.15 Ordering pages in the content tree
Once all the pages are created, it is a good idea to give them a logical organization in the content tree.
Use the Up and Down buttons to move pages to achieve the same page order as in the screenshot
below.
232 Kentico
"‘ CMS Desk Content My desk
3 3 il Copy i up
x .
New Delete |=¢Move & Down
Content management
-;l't;_"] My Community Site
+|.] Home
_|__, Blogs
-] News
[ Media
(-] Forums
(-] Groups
-] Group pages
(5] Members
_|’E:\J' Files
_|’E:\J' Special pages
__, Logon page
‘.| ] search
3.16 Making the settings

To get the site working, you also have to make seweral settings in the Site manager -> Settings

section.

1. First, select the name of your site from the Site drop-down list in the top left corner of the page.
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Switch to CMS Desk  User: Global Administrator v5.0.3688 Sign out
22 Kentico
#1%  CMS Site Manager Stes  Admnistaon | Setbngs | Development  licenses  Support
=
peie: @ Wwebsite (2]
My Community Site El
[l s 7 meset these setins o defout
|=)-Settings
° Web site
'ﬁj Content management
Files
E . Cache content (minutes) @ [¥] inherit from alobal settings
a Membership
- #% Security Cache images (minutes) [2] [#I inherit from global settings
URL: d SEQ
EE S an Cache page info (minutes) @ Inherit from global settings
? Qutput filter
& system Combine with default culture 2] Inherit fram global settings
" E-mails Combine files with default culture [2] [#] inherit from global setiings
Avatars
(@ Bad words Default alias path [2] Select [Clinnerit from global settings
E'ngs_ Default culture of the content @ |English - United States [=] [Clinheritfrom global settings
Pﬂ Booking system
-84 Community Page description prefix [2] Inherit from global settings
Content stagin
D? aing Page key words prefix @ Inherit from global settings
--&& Forums
Il Media libraries H Page title format [2] Inherit fram global settings
- M board "
@ essage boards Page title prefix @ |My site [Tlinherit from global settings
@ Messaging
-4l web analytics Page not found for non-published documents € Inherit from global setings
9 Windows LivelD Page notfound URL [~ ] Inherit fram global settings
m E-commerce
-5} Payment gateway - Authorize.NET Exclude document types from SQL search &) L Inherit from global settings
& payment gateway - PayPal Exclude documents from SQL search @ Inherit fram global settings
Control element @ [dv [¥] nherit from global settings

Export these settings

2. In Site Manager -> Settings -> website, make the following settings. Remember that you need to
uncheck the Inherit from global settings check-box in order to be able to enter values into the fields.

Default alias path: /Home

Default culture of the content: English - United States
Page title prefix: My Community Site

Exclude documents from search: /Special-Pages/%

Click Save.
3. In Site Manager -> Settings -> Security, make the following settings:

e Check page permissions: No page
e Website logon page URL: ~/Logon.aspx

Click Save.

4. In Site Manager -> Settings -> Blogs, set the following value:

e Blog unsubscription URL: ~/Special-Pages/Blog-Unsubscription.aspx
Click Save.

5. In Site Manager -> Settings -> Community, enter the following values:
e Group security access denied path: /Groups/{GroupName}/Access

e Group management path: /Groups/{GroupName}/Management

Group profile path: /Groups/{GroupName}

e Member management path: /Members/Management

Member profile path: /Members/{UserName}
e |nvitation acceptation path: /Special-Pages/Invitation-Acceptation
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e Friend management path: /Special-Pages/Friend-Management
Click Save.
6. In Site Manager -> Settings -> Forums, enter the following values:

e Forum unsubscription URL: ~/Special-Pages/Forum-Unsubscribe.aspx
e Forum base URL: ~/Forums.aspx

Click Save.

7. In Site Manager -> Settings -> Message boards, adjust the following property:

e Board unsubscription URL: ~/Special-Pages/Board-Unsubscribe.aspx
Click Save.

8. The settings are done. The whole website should now be fully functional.
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