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1.1

Personal Site Guide

Overview

Kentico CMS Personal Site allows you to easily run your own personal web site. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:
e Content editing

e Blogs

e Forums

e Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.
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2.1

Getting Started

Editing content

In this chapter, you will learn how to change the About text on your web site.

1. Go to CMS Desk -> Content -> Personal Site -> About me.

CMS Desk

Content

D & | = & e+

New  Delete, Copy Move Up

24 personal Site
@[3 My Blog
s = About Me
Forums

[#-[=] Photo Gallery
o] Special pages
€3 Images

Documents | Szarch

. f a ite: | Personal Site v B Adminis Sign Out
My Desk | Tools | Admnistraton Switch to Site Manager  Site: | Perscnal Site | User: Global Administrater  Sigi

@ @ Edit Preview

Down

Live site List @
Properties @)

Page | Desgn | Form | Product

Hsave =5) Spell check

: =l Souree | [& ¢ | &t |4 2L B #iB 7 U se|x & 1T S +
HeOD=0ssinale
_|i stle ~| Fomat - | Fort ~ | Size T -0 @3

Sign in to CMS Desk. Sign in to CMS Site Manager. The default sccount is administrator with blank password,

Sign out

Current user: Global Administrator | My details

"Tlusion is the first of all pleasures.” - Oscar Wide.

About Me Photo Gallery

at can you find on my web
jsite? There isn't much stuff
lon it so far, stil working on it
(What you might be interested
{in is my blog from a trip
feround Europe that we took
|with my friend PJ this
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2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This the new About me text. Then click Save at the top-left.

Page Design Form Product Properties

Q=

Erce“ﬁ% E.Eﬁl@n |MA:B|OB 1g.u;c|x2 =
@O0 &=03 ©

~ | Format |Momal {DIV) ~ | Font - | Size ME T'v %v m ‘ @
lon it so far, stil working on it. | : Main Text
I\What you might be interested | [ —
fin is my blog from a trip
‘[sround Europe that we took i !
Iwith my friend PJ this -
lsummer. Hope to upload more | 1 - e
iuhutus in near future. 1 | =

Spell check

A

1 y
L s (o~

My latest blog posts

fo

! .
| This is the new About me text.
6/1/2008 | Destination Madrid f

Spain welcomed us with the
entirely Spanish-only
environment. You would think
that they would bother to have
SOMme Signs our announcements
in English at the international
airport. Fortunately, PJ knows
little Spanish so we were able to
find our way out of airport and
take the right bus to our hostel.

’IT Powered by
% KENTICO
CMS

|>

3]
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3. Now switch to the Preview viewing mode. You can see that the About me text has been updated.

What can you find on my web
site? There isn't much stuff on it
so far, still working on it. What you
might be interested in is my blog
from a trip around Europe that we
‘took with my friend PJ this
summer. Hope to upload more
phatos in near future.

My latest blog posts

6/1/2008 | Destination Madrid

Spain welcomed us with the
entirely Spanish-only
environment. You wauld think
that they wiould bother to have
SOME SIgNs OLF aNNoUnCemerts
in English at the intemational
airport, Fortunately, P1 knows
little Spanish so we were abls to
find our way out of airport and
take the right bus to our hostel,

| My details | SignIn

"Husion is the first of all pleasures.” - Oscar

About Me Forums Photo Gallery

My Blog

About Me

This is the new About me text.
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2.2 Adding a blog post
In this chapter, you will learn how to add a new post to your blog.

1. Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action
toolbar.

CMS Desk

i qer Site: ite v : i Sign out
Content | My Desk | Tools | Administration Switch to Site Manager, Personal Site v | User: Global Administrator

O & 2 & « % [ ea [T Preview  [@] Lvesits =] List

Mew Delete Copy Move Up Down

2 Personal Site

ere

Page | Desgn | Form | Properties

(237 My Blog
About Me l ! Save |=o
_ . Spellcheck
Farums _d

= Photo Gallery
Special pages
Images

Sowcs | [& ¢ BB S: @t B Fim 7w o
PODEFOSSIHRIO% R IEE R =
tole | Farmat - | Font - | Size - T dm-: 00 (8

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. =)

L

Current user: Global Administrator | My detais | Sign out

About Me

Forums Phota Gallery

Tags 1
Saying goodbye Europe

airport  Austria bus cuisine ~

Czach Republic Frante Germany

hitchhiking hostel Paris, our final destination. Because there’s no upcoming hitchhiking

— trip, the tension between P and me is all gone. I have a friend here,

Ttal ! her tork
89 LI S UG 50 the last night we spend in his place, drinking wine and using his

Slovenia SDaiN  subwav o L |

Documents | Search

2. Choose Blog post as a new document type.

CMS Desk

Content || My Desk | Tools || Administration
D D @ @ G G "7 | Edit | Preview jl Live site E List
Mew | Delete. Copy | Move Up Down @

24 personal Site

: My Blog
(- My BElog
[ About M
ouETe ) New document
Forums

[=-[-| Photo Gallery
(1| Special pages
et Images

Please select new document type:

sz Blog manth
] Blog post

@ Link an existing document
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3. Next, enter information for your new blog post.
e Post title: My new blog post
e Post Summary: Summary of the blog post.
e Post text: The entire text of the blog post.

Then click Save at the top.

My Blog » MyBlog » June 2008

@ bj Save and create another é—‘a Spell check

¢ Souee | (&2 BR@®(Gio o (M%IEFIB 7 U w|x <= = = &
O =0s=sBIBl0

‘E Style ~ | Farmat | Momal ~ | Fant * | Size v Ty My E & | @)
Pasttitle: |r'.f|y new blog post

=
Post date: 6/27/2008 12:05:25 WM

Summary of the blog post

Post Summary:

The entire text of the blog post.

Posttext:

© 2009 Kentico Software
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Your new blog post has been added to My Blog.

Current user: Global Administrator | My details | Sign out

My Blog About Me Forums Photo Gallery

Tags

My new blog post

airport  Austria bus cuisine L=
Czech Republic France Germany

hitchhiking nostel Summary of the blog post.
Italy luggage sacher torte

Slovenia Spain  subway
tourisma  traffic  train Posted: 5/18/2009 4:53:46 PM by Global Administrator | with 0 comments

D Recent posts Saying goodbye Europe
S
¥ My new blog post
¥ Saying goodbye Europe
¥ Wir sind Berliners [ Paris, our final destination. Because there’s no upcoming hitchhiking
» Disappointment in Prague . trip, the tension between PJ and me is all gone. I have a friend here,
» Sweetness of loneliness 5 ; 50 the last night we spend in his place, drinking wine and using his
2 computer to look at pictures we’ve taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each

L) Syndication other go out have dinner tonight.

FR5S

Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

© 2009 Kentico Software
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Adding a photo gallery
In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document
action toolbar.

2. Choose Image gallery as a new document type.
Fhaota Gallery

D New document

Please select new document type:

() Article
@ Blog
l Cell phone
[® Event
E‘ Event (booking svstem)
@ Ea0
i File
Folder
| Image gallery
i Job opening
& Knowledge base article
E. Laptop
¥ lews
Page (menu item)
& eo2
%2, Press release
[E Product
D Simple article

@ Link an existing document
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Getting Started 13

3. Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then
click Save at the top.

Spell check

H Save Hj Save and create another |

MName: Mew gallery

Description:

Teaserimage: Upload: [C:\Documents and Setting[ Browse...
)

Publish from: | | Mow
e

Publish to | | Now

[JcCreate a new product

4. Now, go to Properties -> Template and click Select to choose template to use. Choose Personal
Site\Personal Site - Photo Gallery. Click Save at the top.

Page Design Form Product Properties

General

H Save
Template
Metadata
Menu Template:  |Personal Site - Photo Gallery |[_Select
workfiow =\ Save as new template...
NERTLE rQ\? Inherit template
Related docs .

'3_-.5 Clone as ad-hoctemplate

Linked docs
security [T Eatttempiate properties

Inherit content:
® Use page template settings
(O Do notinherit any content
O Select inherited levels

© 2009 Kentico Software
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5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.

D New document

Please select new document type:

k= File

Page (menu item)

@ Link an existing document

6. Click the Upload file (_#) icon and choose a picture to upload.

H Save hﬁ Save and create another I"_ >

Upload file:

File description:

Spell check

Uploadfile

Then enter The description of the first picture. into the File description text box and click Save at the

top.

Upload file:

File description:

H Save Ej Save and create another I",

Spell check

Actions Update Name Size
M%) & waterfallipg 281 kB

The description of the first picture.

© 2009 Kentico Software
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Congratulations, you've just learned how to create a new gallery and add some pictures into it.

| My detais | SignIn

"Hiusion i the first of al pleasures." - Oscar V

My Blog About Me Photo Gallery

About my photos List of galleries

Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload
mare pictures in near future.

I'm far from being 2 professional

photographer. Therefore, if you're

looking for mesmerizing pictures, I

advise you to search somewhere = ~

else. o= =¥ Set of pictures, we've taken on our hitchhking trip around
L Europe with my friend PJ. Additional pictures are to come.

European Trip

Sweet Home Arizona

Mothing compares to smell of desert after moonson rain.
Nothing compares to nd of coyote howling at the Moon.
Nothing compares to view of blossoming saguaro.

Nothing compares to Arizona.

New gallery

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import.

2.4 Adding aforum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.

© 2009 Kentico Software
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CMS Desk Content | My Desk | Tools | Administration
=) Tools
-] BizForms 83 Forum groups
.. Booking system
...y Content staging 82 add forum aroup

il E-commerce

Ty File import
: ; FI < ImPo Actions Group name
arums
;---L@Newsletter 8 & B wyroums
@ Polis
.- |gd Reporting _ .
.3 Web Analytics W Posts waiting for my approval

2. In the Forum group properties, click Add forum & Add forum
3. Add the following information for the new forum:

e Forum display name: New forum

e Forum code name: newForum

e Description: The description of the new forum.

Then click OK.

Forums | General || View

& New forum

Forums » Mew forum

Forum display name: ‘New forum | Farum is open:
Forum code name: ‘newForum | Forum is moderated: [}
The description of the new Require e-mail addresses: O
forum.
Display e-mail addresses L}
Description:
Enable WYSIWYG editor: O
Use security code (CAPTCHAY []

Forum base URL: ‘ |

Inherit fram farum aroup

Forum unsubscription URL: ‘ |

Inherit fram farum aroup

© 2009 Kentico Software
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4. The forum has been added as you can see in the following screenshot.

Forums

Forum

| My details | SignIn

"Tlusion is the first of al pleasures.” - Oscar Wide.

About Me Forums Photo Gallery

Threads Posts Last post

My Forums

Goedbye party

New forum
The description of the new forum

Where to go in Europe

(5/28/2008 3:5T7:25 PI)

administrator
(71712008 1:57:32 PM)

{5/22/2008 8:16:15 FM)

17
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3 Adjusting Design

3.1 Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will learn
which stylesheets are available and how you can choose the CSS stylesheet you want to use on your
web site.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site
next to the Personal Site.

CMS Site Manager

o Sites

@ New site wizard @ Import site or ohiects .ﬁ Export objects

Sites || Administration Settings Development Licenses Support

Actions Site name Status

% i r_? EI |§> Cd Corparate Site Stopped
Q} 8 "_? @ D ':@ E-commerce site Stopped
@ =@ P @@ PersonalSite Running
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In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.

CMS Site Manager Sites Administration Settings Development

Q Site Properties

Sites » PersonalSite

General | Domain alizses | Cultures

Site display name: |F'ersu:una| Site |
Site code name: |F'ersnna|8ite |
Site damain name: |Ioca|host |
Default content culture: gnglish - United States

Default visitor culture: | (Automatic) "|
Site CSS stylesheet | [FEEEICICEL M |
Editor CSS stylesheet | Personal Site v
Site description: Sample personal web =ite

Licenses

Support

© 2009 Kentico Software
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The following CSS stylesheets are available in the sample Personal Site:

Personal Site

(_____lesm

Tags

airport  Austria bus  cuisine
Czech Republic France Germany
hitchhiking hostel
Ttaly luggage  sacher torte
Slovenia 5pain  subway
tourism  traffic train

[ Recent posts

» Saying goodbye Europe

» Wir sind Berliners

» Disappointment in Prague
» Sweetness of loneliness

» Sacher torte and Austrian
capital

£ Syndication

»RSS

Personal Site - Blue

| My details |

My Blog About Me Forums Photo Gallery

J Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhi

s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, P1went to do some shopping and we've promised each
other go out have dinner tonight.

Fosted; 7/5/2008 1:56:04 FM by Abigail Woodwarth | with 3 commerts

Wir sind Berliners
J

Berlin, after a lang time the city we both wanted to see. And as we're
almost done with our trip, we’re getting much more relaxed i
comparison just week ago. We are almost able to joke

each other again. We don't have much money left, though, so we're
maostly hanging around, considering every Euro, spent for the gallery
ticket.

| My details |

Personal starter site

"

» sirport ¥ Austria * bus ¥ cuisine
¥ Czech Republic * France

+ germany * hitchhiking
» hostel » 1taly ¥ luggage b sacher
torte F Slovenia » SPain b subway
¥ tourism * traffic ¥ train

[ Recent posts

g goodbye Europe
¥ Wi sind Berliners

+ Disappointment in Prague
+ Sweetness of loneliness

¥ Sacher torte and Austrian
capital

EJ syndication

»RSS

My Blog About Me Forums Photo Gallery

J Saying goodbye Europe

Par ot finaldestation: Becatise there < in uneoindng Itchiaiing

trij

50 the last night we spend in his place, drinking wine and usmg his
computer to look at pictures we’ve taken during our month in
Europe.

Today, P] went to do some shopping and we've promised each
ather go out have dinner tonight.

Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

Wir sind Berliners
J

Berlin, after a long time the city we both wanted to see. And as we're
almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. we don’t have much money left, though, so we're
mostly hanging araund, considering every Eura, spent for the gallery
ticket.

21
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Personal Site - Green

| My details |

I:l = MyBlog i AboutMe @ Forums i Photo Gallery

Tags
Saying goodbye Europe
¥ airport * Austria ¥ bus * cuisine
¥ Czach Republic * France
ng

»Germany * hitchh
rhostel » italy ¥ luggage b sacher

torte » slovenia ¥ Spain » subway
¥ tourism b teaffic b brain

vip,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PIwent to do some shopping and we've promised each
other go out have dinner tonight.

£ Recent posts Pasted: 7/5(2005 1:56:04 PH by Abigail Woodwarth | with 3 camments
» Saying goodbye Europe

» Wir sind Berliners

+ Disappointment in Prague

» Sweetness of loneliness

» Sacher torte and Austrian

capital wir sind Berliners

= o Berlin, after along time the city we both wanted to see. And as we're

B syndication almost done with our trip, we're getting much more relaste

+rss camparison with just week age. We are almost able to joke with
each other again. We don't have much money left, though, so we're

mastly hanging around, cansidering every Eura, spent for the gallery

ticket.

Personal Site - Red

| My details |

Personal starter site

"lusion is the first of al pleasures.” - Oscar Wilde,

% MyBlog % AboutMe ¥ Forums ¥ Photo Galle

Tags

Saying goodbye Europe
¥ airport * Austria * bus * cuisine
¥ Czech Republic * France

+cermany * hitchhiking our final destination, Because there’s no upcoming hitchhiking

o [N Dt , the tension between P1 and me is all gone. I have a friend here,
e et . so the last night we spend in his place, drinking wine and using hi

torte > Slovenia * Spain » subway ; computer to look at pictures we’ve taken during our month in

¥ tourism b traffic b train Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

[ Recent posts Posted: 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments
¥ Saying goadbye Europe

» Wir sind Berliners

» Disappointment in Prague

» Sweetness of loneliness

¥ Sacher torte and Austrian

capital J Wir sind Berliners

E‘ - Berlin, after a long time the city we both wanted to see. And as we're
£ Syndication almost dane with our trip, we're getting much more relased in
comparison with just week ago. We are almost able to joke with
each other again. We don’t have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

»RSS

© 2009 Kentico Software
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3.2

Editing CSS stylesheets

In this chapter, you will learn how to change the design of your web site by modifying the CSS

stylesheets.

Changing the header picture

23

1. Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site
and choose Main styles -> Master page section in the text box on the left side.

CMS Site Manager

Switch to CMS Desk  User: Global Administrator  Sign Out

Sites on | settings Licenses | Support
EHEerEme: 5 C883 stylesheet properties
& CsS stylesheets
i@ Countries C3% stlesheets b Personal Site
@ Cultures
g Document types General | Sies
() E-mail templates
- Farm controls L sze 0 checrouttonie
- [E Inline controls
% Modules Check outthe stylesheet to file c:linetpub otiKenticoCMSICMSC css to edit the stylesheet externally

:[[JPage layouts
;& Page templates Stylesheet display ‘P s
.= Relationship names name ersenal Site
*[f] System tables

code name: ‘F‘. nalSit ‘

LUl cultures
&) Web part containers /##Main styles/Master page#*/ || Blogs
& Web parts -mainDiv Forums
i { Global
:..[3) Web templates Ta6px; Boxes
g Workflows 35px auto; =| | Logon page
: Tpx Tpx Opx: Main styles
background-color: $fff; Left menu
P } Master page
Membership top zone
.zoneTop Search box
{ Top menu
My profile
Stylesheet text. Photogallery
d-coloxr: #Lff; Search page
1 Opx Opx Tpx:
marg. Opx Opx Opx;
background: #£ff url(../hpp_Themes /FersonalSite/Images/bg_head.ipg)
}
.zoneTopMembership
width: 795px;
padding: 2px Opx 4px; v
< | >

2. In the .zoneTop style, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

.zoneTop

hei ght: 239px;

wi dt h: 795px;

background- col or: #fff;

paddi ng: Opx Opx 7pX;

mar gi n: Opx Opx Opx;

background: #fff url(../App_Thenes/ Personal SiteG een/| mges/ bg_head. j pg)
no-repeat top left;

Then click Save at the top-left.

© 2009 Kentico Software



24

Kentico CMS 5.0 Personal Site Guide

3. Now click Sign out at the top-right. You can see that the header image has been changed.

| My details |

I ccrch | blos | Aboute | Foms | PhotoGallery

Tags 1
‘ Saying goodbye Europe
airport  Austria bus cuisine J
Czech Republic  France Germany
hitchhiking hostel : Paris, our final distinatiun. Bec.:]use thErItI:'s no up;uming hit::hliking
. trip, the tension between PJ and me is all gone. I have a friend here,
Ttals I her tort ’ '
sl:v"mh"“‘g;:i"“i“‘h;:' * so the last night we spend in his place, drinking wine and using his
e T (o v 4 computer to look at pictures we’ve taken during our month in
ourism traffic train : ooy

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

Recent posts
B B Posted; 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

} Saying goodbye Europe
+ Wir sind Berliners

+ Disappointment in Prague

+ Sweetness of loneliness

+ Sacher torte and Austrian

capital U wir sind Berliners

e -~ Berlin, after along time the city we both wanted to see. And as we're
&) Syndication almost done with our trip, we're getting much more relased in
\ RSS compatison with just week ago. We are almost able to joke with
each other again. We don't have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Changing the top menu

1. Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master
page section in the text box on the left side.

© 2009 Kentico Software
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2. Scroll down to see .zoneTopMenu style.

CMS Site Manager

Sites

[=)-Development
& CsS stylesheets
@ Countries
i@ Cultures
& Document types
() E-mail templates
i Form controls
: [l Inline controls
B - Modules
i ..@ Page layouts
i 43 Page templates
i..=@ Relationship names
+-[3f] System tables
g ) UI cultures
Web part containers
8§ Web parts
*[3) web templates
4 Workflows

! < B Adminis Sign Out
Administration | Settrgs | Dewelopment | Licenses | Support | Buy Switchto CMS Desk  User: Global Administrator | _Zign (u
5 CS$8 stylesheet properties
£S5 stylesheets » Personal Site
General | Sites
H Save 5 Check outto file
Check out the stylesheet to file c:linetpub ot KenticoCMS\ICMSC css to edit the stylesheet externally
Stylesheet display
ame ‘F‘ersonal Site ‘
Stylesheet code name: ‘F‘eraunalsne ‘
font-weight: nozmal; ~|[Blogs
font-size: 32px; ~ || Forums
margin-top:0px; Global
¥ Boxes
Logon page
= | Main styles
A Left menu

Stylesheet text }
.DesignMode .zoneTopMenu

height: 120px;

¥

.zoneBottom

./Bpp_Themes/FersonalSite/Images/bo_topmenu. ol

Membership top zone
Search box
Top menu

My profile

Photagallery

Search page

®

3. Change the background color to #B0OC4DE and erase the URL part so that the entire section reads
as follows:

. zoneTopMenu

hei ght: 43px;

wi dt h: 795px;
background: #BOCADE;
paddi ng: Opx;

mar gi n: 0px;

This will change the background of the navigation at the top to dark blue.
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4. Now, switch to the Top menu section and find .CMSListMenuLl a:hover style. This style modifies
the appearance of menu item when mouse is ower it.

i Switch to CMS Desk U : Global Administrat Sign Out
CMS Site Manager 1 siicaton Settings | Development | Licenses | Support | Buy — = sex: Global Administrator | g

[=)-Development

& CsS stylesheets

@ Countries

i@ Cultures

g Document types
() E-mail templates
i Form controls
[l Inline controls
L. Modules
i ..@ Page layouts
44 Page templates
i..=@ Relationship names
+-[3f] System tables
) UI cultures

5 CS3 stylesheet

properties

£S5 stylesheets » Personal Site

General | Sites

Check out the stylesheet to file c:linetpub

Stylesheet display
name

Stylesheet code name:

’J Check outto file

otKenticoCMSICMSC

‘F‘ersonal Site ‘

‘F‘eraunalS\lE ‘

css to edit the stylesheet externally

Opx 25px;

Web part containers Blogs
Web parts .CM3ListMenulink, .CM5ListMenuLinkHighligh Ec‘w;m‘s
;-] web templates coloxr: $#000; ’ aEnxas
L4 Workflows text—decoration: none; Logon page
block: Main styles
Left menu

Master page

‘. margin-right: 2px:
3 Membership top zone
Search box
R R gy, .CHSListMenulinkHighlignted, .CMSListMenuLIlast a:hc
r My profile
Stilesheet text v
color: #000; Photagallery

background: url(../kpp_Themes/PerscnalSite/Images/bg topment | | Search page
text-decoration: none;

}

*$Main styles/Left menu#*
.leftMenu .CMSListMenulI, .leftMenu .CMSListMenuHighlightedLI

5. Change color to #fff and replace the url part with #87CEFA. The entire style should read as follows:

. CMSLi st MenuLi nkHi ghl i ght ed, .CMSLi st MenuLl | ast a: hover,
. CMSLi st MenuHi ghl i ght edLI a

. CMSLi st MenuLIl a: hover,
. CMSLi st MenuHi ghl i ght edLI | ast a,
{

color: #fff;

background: #87CEFA;

t ext-decorati on: none;

This will change the background of the menu item to light blue and its font color to white when mouse
hovers abowe it.

© 2009 Kentico Software



Adjusting Design 27

You've just learnt how modify CSS stylesheets to change design of your web site.

| My details |

I i aboucrizl [ Forumel || ehoco calley

Tags oo
Saying goodbye Europe
airport  Austria bus cuisine =
Czech Republic France Germany
hitchhiking hostel Paris,'ll]ur final distinatiun. Be(:luse ther"E’s no upﬁumingfhitd&h'ilking
. trip, the tension between PJ and me is all gone. I have a friend here
Ttal I her tort: " "
sl::’m:““;;';in““m‘,;:' ¢ 3] 50 the last night we spend i place, drink ine and using his
e T e v computer to look at pictures we've taken during our month in
ourism  traffic train ooy

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.

Recent posts
B B Posted: 7/5/2006 1:56:04 PM by Abigail Woodwarth | with 3 comments

» Saying goodbye Europe
» Wit sind Berliners

» Disappointment in Prague
+ Sweetness of loneliness

» Sacher torte and Austrian

capital Wir sind Berliners

- - Berlin, after a long time the city we both wanted to see. And as we're
&Y Syndication f almost done with our trip, we're getting much more relaxed in
VRSS comparison with just week ago. We are almost able to joke with
each other again. We dont have much money left, thotigh, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.
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4 Adding web parts

4.1 Adding text

In this chapter, you will learn how to add the new editable text region into your web site.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web partin
zoneRight.

Switch to Site Manager  Site: | Personal Site v B Adminis Sign Out
CMS Desk Content || wy Deck | Tooks | Admmstaton Switch to Site Manager  Site: | Personal Site | User: Global Administrator  Sig

D D B ﬁ 0 @ Edit Preview Live site List

New  Delete, Copy Move Up Down

@

B o=l Page | Design | Fom | Product | Propertes [ Display web part content (@)
(=-[# My Blog
w- = About Me

~

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.
Forums

= Photo Gallery
- [~ Special pages
- Images

Current user: Global Administrator| My details | Sign out

Photo Gallery

« [About Me - page template: Personal Site - About Me
~ zoneleft o) ~ zoneRight (f‘}

¥ LefiText & « TileRegion &
About Me

What can you find on my web
site? There isn't much stuff on it

o MainRs &
5o far, stil working on i Eatw Hi there,

[E3

Documents | Szarch
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2. Select Text/EditableText web part.

2 Portal engine - Web part selection, - Webpage Dialog
& Select web part

) s s s

(- Listings and viewers —| Editable text

clu Media

wu Membership () Sounce | |4, & L
|5,..;].3I\a'1essat_?lir1i_?l ",_.:: = ®_:'r;w L =

d.j_:] MNavigation P,

- QNews I o = et 1 Sy
&) Newsletters

lﬂ,]_j Palls

ulu Reparting

l3..:;“]Te><t

: -k Editable image

¥k Paged text The Editable text web part displays an editable region that enabled
& Static HTML content editors to edit page content.

i ol Static text
(- User contributions
x-J Web services

[=]

I oK H Cancel

Rkt filocalhostKenticoCrMse/ CMSDeskiPortalEngine/SelectebPart, aspx ‘ﬂ Local intranet

3. In the Web part properties dialog, enter the following information for the new web part.
e Editable region title: AboutWebPageTitle
e Content before: <hl>
e Content after: </h1>

Then click OK.
4. Click Add web part again and select the same Text/EditableText web part.

5. In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click Ok.

6. Now you have the new web parts ready and you can enter some new text. Switch to the Page tab

and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.
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7. Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.

Edit

@ Preview @ Live site

Page Design Form Product Properties

Spell check

E List

to see me. The trip to Prague is
one smoaoth ride. Butthe city
center is jammed with people
again. Why all tourists share the
rnead nfviciting came nlaras at

f AboutWebPageTitle

[8bout my web page

. AboutWebPageText

fThis is a shor text about my web page.

,\L?g Powered by
% KENTICO
CMS

|

1=
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That is how you add a new editable region into your web site.

| My detais | SignIn

[ S

What can you find on my web About Me

site? There isnt much stuff on it - P .

<0 far, stil working on £, What you This is the new About me text.

might be interested in is my blog

from 3 trip around Europe that we About my web page

took with my friend PJ this = y pag

summer. Hope to upload more < This is 3 short text about my web page.
photos in near future.

My latest blog posts

6/4/2008 | Along the coast of
Dragon to Montpellier

France, eventually, For a whils,
it seemed like we wouldn't be
able to make it. We spent more
than three hours waiting for a
tide at the Spanish — French
border in Pyrenees, The scenery
was cool, though, Finally, an old
man in the rusty Seat took us
on board, As if unaware of his
wehicle condition, he drove lke
nuts so that we sat in silence
with terror i our eves, He
couldm't speak English amyway.
However he took us all the way

e Mentnaliar

© 2009 Kentico Software



Adding web parts 33

4.2 Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll.

CMS Desk Content | My Desk | Tools | Administration

=)-Tools
i..[E] BizFarms !J Polls
E....@Booking system
!ﬁ; Content staging © New pol
_g E-commerce
E....QFiIe import
3.] Forums
,;,; Newsletter
Q Polls
1.3 Reporting
j,, Web Analytics

2. Enter the following information for the new poll.
e Display name: My poll
e Code name: MyPoll
e Question: How do you like my pictures?

Then click OKk.
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3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers
tab and click New answer # Mewanswer |nto the Text text box, enter | love them!. Make sure that
the Enabled check box is checked and click OK.
General | Answers | Security | Sites || View
ﬁ, New answer
Answers k MNew answer

% MNew answer

Text: |I love them!
Enabled:

4. Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.
Then click Ok.

5. Click New answer again and enter Waste of time! into the text box provided. Click Ok.

© 2009 Kentico Software



Adding web parts 35

6. Now we are ready to add your new poll to web site. Go to CMS Desk -> Content -> Personal Site ->
Photo Gallery and switch to the Design tab. Click Add web part in zoneLeft.

CMS Desk Content || My Desk | Toos || Adminstration Switch to Site Manager  Site: | Personal Site %| User: Global Administrator  Sign Out

* 8 - Buese 5
I\IIejw D?me (I:?Ey h% " | [ @Ed\t Prewew leesne L\st @

4 Personal Site
#-3 My Blog
(5] About Me Sign in to C1S Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. ~

Page | Design | Form | Product | Properties [ Display web part content (@)

Forums
® Phota Gallery
= Special pages
3] Images

Current user: Global Administrator| My details | Sign out

« [Photo Gallery - page template: Personal Site - List of galleries E/ﬂ
~ zoneleft (d} ~ zoneRight ]

» leftText & = HeaderText &P
About my photos List of galleries

Alright,, lat’s be clear on this. + DescriptonText @Ergnd pictures I toek in past few months. I'm planning to upload

I'm far from being a p

| PR |

Documents | Search

7. In the Select web part dialog, select Polls\Poll web part.

2 Portal engine - Web part selection -- Webpage Dialog

e selectweb part
(= = -~
|ﬂL:| Events —|| Poll
[-J Forums
- {2 Full-text search
-{J General Do you like our product?
|ﬂL:| Google services  vas, | do.
(- Listings and viewers [ !
&I Media ' Mo, | don't.
- [ ]
(-2 Membership

& | den't knov your product.
- {Z)Messaging ! :

(- Navigation
- News
(- Newsletters

C‘U Polls The Poll web part allows you to insert your own Poll on the page.

Mu Repaorting
- Text b
(- User contributions

|£

[ Ok ][ Cancel

http:fflocalhostfKenticoCMs6/CMSDesk/PortalEnginefSelectwebPart, aspx ‘ﬁ Local intranet
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8. In the Web part properties dialog, make sure My poll is selected as Poll name and click Ok.

Congratulations, you've just learned how to add a new poll to your web site.

I scarch

About my photos
Alright,, let's be clear on this.

I'm far from being a professional
photographer. Therefore, if you're
looking for mesmerizing pictures, I
advise you to search somewhere
else.

How do you like my pictures?

1 love them!

O ot bad.

O waste of time!

My Blog

List of galleries

| My detals | Sign In

In these galleries, you can find pictures I took in past few months. I'm planning to upload

more pictures in near future.

European Trip

e've taken on our hitchhiking trip around

Set of pictures,
end PJ. Additional pictures are to come.

Europe with my

Sweet Home Arizona

Nothing compares to smel of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
Nothing compares to view of blossoming saguaro.

Nothing compares to Arizona.
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Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

e Kentico CMS Tutorial
e Kentico CMS Developer's Guide
e Kentico DevNet at http://www.kentico.com/DeviNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.

com/Support.aspx.
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