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1.1

Introduction

Community

Starter site

.—E“-_ e

Home  Blogs  News

Welcome to our community

This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new

About this guide

Welcome to Kentico CMS Community Guide. This guide will provide you assistance with building on-
line communities using Kentico CMS.

-

il_l

Media

people and all the things related to it.

If you are interested in this sort of things, don't hesitate and

join now!

Latest blog posts

Latest forum posts

Kentico CMS comes with the sample Community Starter site. This sample web site template can be
conveniently used as a starting point of your own community site development. In the first part of this
guide, we will go through the various customization tasks that need to be done if you want to develop
your community site based on this template. The second part will describe building community sites
from scratch.

Sign In

| | Search

Shortcuts
Join the community

The long long flight

Finally, after some 23 hours of fight, I am on the other side of the world
than I was yesterday around this time. I feel terribly tired after the long
fiight, but before I go to sleep, I found some time to write about the first

impressions of my journey.
Posted on 10/26/2008 3:05:12 PM

Hying tomorrow

Hi everybody, my name is Kelly Taylor and I come from Brno, Czech
Republic. Tomorrow is my big day. Finally, after six months of hard
everyday work, I dedded to have some nice time and go on holiday.
Australia has always been one of the places I had wanted to visit one
day, and now, with my great new job and the wage I get for it, itis

finally affordable for me to get there,
Posted on 10/26/2008 2:19:18 PM

RE:Hostels in London

well, ok...well...there is actually not enough room for two guests in my

place...
Posted on 1/7/2009 3:13:50 PM

RE:Hostels in London

Thanks, but the reason why I'm looking for a hostel in London is actually
that I'm gonna be waiting for my boyfriend there. He'll be returning from
the States and his plane lands at Heathrow. .. But we can come to
Edinburgh together some time later and stay at your place if you

want...?
Posted on 1/7 /2009 3:11:33 PM

RE:Hostels in London

Latest news

Travellers' community
site launched

We have just launched our
new community site intended
to become a virtual meeting
point for travellers from all
around the world.

Latest Groups

African travellers

This is a group of
B travellers living in Africa,
1f you are one of them, please
register to the group. Itis a
great chance f...
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1.2 Community features

Community sites are such web sites that bring the possibility of on-line interconnection of people,
usually those who share the same interests or who are members of some real-world group and have the
need to meet on-line. For the purposes of the community, such site should provide the possibility of
gathering in groups, discussing in forums, blogging, advanced membership with the possibility of
friendship between users, customized user profiles, various sign-in possibilities, etc.

Kentico CMS is a full-featured solution for building complex community sites without any complex
programming. Here is a list of the most important built-in community features of Kentico CMS:
e Community Groups

e Forums

¢ Blogs

e User profiles

e Badges

e Friends

e Bad words

e Abuse report

e Polls

e Content rating

e Time zones

All the implementation processes have been diminished to only a few clicks, so that you can use most
of the features out-of-the-box.

© 2010 Kentico Software
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2 Part 1

2.1 Getting started
2.1.1 Installing the site

To get started, you need to have the sample Community Site installed. There are two ways how this can
be achieved:

1. If you are performing a new installation, you can choose the site in Step 3 of the Database Setup.
Select the Choose starter site radio-button and choose the Community Site from the list of starter
sites. Click Next to finish the setup procedure.

Database Setup - Step 3

—iﬁ- @ = @

SOL Settings Database Starter Site Finish

partal engine and it is the recommended choice for
developers who are new to Kentico CM3.

This is a web site template for a sample community site.
Social networking features of Kentico CMS are used on the
site to give you an idea of how they can be used on your web
site. You can also modify this web site and

devel oD

This template is intended for developers who wantto create a
new web site from scratch. It uses the portal engine.

(7 Continue to the New site wizard
() Import existing Kentico CMS web site

Version: 5.0 Build: 5.0.3693

2. If you already have Kentico CMS installed, but without the Community Site, you can easily add the
site in Site Manager -> Sites.

© 2010 Kentico Software
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a) Click the New site wizard link at the top left corner of the page.

e Kentico
#9%  CMS Site Manager Sites Administration Settings

;’_']. Import site or objects [3 Export abjects

b) In Step 1, choose Use web site template and click Next.

Choose default web site

If you choose to create a blank site, the wizard will guide you through the process of creating a new site. If
you choose to use atemplate, you will be able to choose one of the predefined web site templates.

() Create a new site using a wizard
I @ Use web site template I

Step 1

© 2010 Kentico Software
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c) In Step 2, choose Community Site form the list of available web site templates and click Next.

Step 2

Choose web site template
Choose the predefined web site template that will be used for your new web site. The web site template
may contain site structure, design, basic content, new document types and other settings.

capabilities and it can be used as a starting site that you modify as needed. It uses the portal engine and it's the -
recommended choice for developers who are new to Kentico CMS.

Personal Site
This is a web template for a sample Personal site. Several Kentico CMS features, such as blogs, forums and photo

galleries, are included. It can be used as a cornerstone for the custom personal site development. The template uses the
portal engine and it is the recommended choice for developers who are new to Kentico CMS.

Community Site

m

This is a web site template for a sample community site. Social networking features of Kentico CMS are used on the site to
give you an idea of how they can be used on your web site. You can also modify this web site and use it as a base for the
development of your own site. It uses the portal engine and is recommended for developers who are new to Kentico CMS.

Blank Site

This template is intended for developers who want to create a new web site from scratch. It uses the portal engine.

© 2010 Kentico Software
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d) In Step 3, specify the display name, code name and domain name of your site and click Next.

Enter new site settings

Step 3 Enter the display name and code name of the web site. The Domain field must contain the domain that you
will use to access the web site during development (you may change it when the site goes live). The default
culture is the main language of the web site.

Site display name: Community Site
Site code name:  CommunitySite
Domain name:  |localhost

© 2010 Kentico Software
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e) In Step 4, leave the settings at their default values and click Next.
Objects selection
Step 4 Flease select objects which should be imported.
—J--|All objects - . i
Qe 22 . @ Import objects (2]
d@ Web site )
: E] Documents Please note: The import process may overwrite your existing objects. The existing objects are
.1]-05' Tools marked with * and will be overwritten if checked.
(5-€] Administration ; ) ) )
; . Please selectthe object type from the tree if you wish to change the default selection.
- Settings Click Next to startthe import of selacted objects.
| [x)-=5 Development
= Global objects Global selection
|1|05! Tools Load default selection Selectall objects Select only new objects  Deselect all objects
(€] Administration =
7-=8 Devel t
= EE EHETHIEL Import settings
Assign all objects to the imported site (recommended)
Run the site after import
[T pelete incomplete site when import fails
Import files (recommended)
[ oo not import objects where parent object is missing
Import tasks (recommended)

© 2010 Kentico Software
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f) Wait until the end of site import process, you will be redirected to the following step of the wizard.

Import progress
Step 5 Objects are being imported.

Importing ‘Page templates’ objects
Importing ‘Page template categories® objects
Importing ‘Page layouts' objects

Importing ‘Countries’ objects

Importing ‘Ul cultures’ objects

Importing ‘CSS stylesheets’ objects
Importing "Settings' objects

Importing "Settings categories’ objects

Objects are being imported
E__ =

© 2010 Kentico Software
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g) In the last step, you can click the Edit your new web site link to go to CMS Desk, where you can
start editing the site immediately.

The web site has been created successfully
Step 6 Mow you can view and edit your new web site.

Edit your new web site

Ifthis is your first web site, the default user account is administrator without password.

You can also click the Finish button to go back to Site Manager -> Sites, where the site should be
listed with the name specified in Step 3.

6_) Sites

EﬂJ Newy site wizard [;f]. Import site or objects [:‘j Export obijects

Actions Site name » Status

/XIS DBG

© 2010 Kentico Software
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212

First sight

When you have the Community Site installed and running, why not go to the live site and see it in
action. To see all the features working, sign in using the Sign in form at the top of the right side column.
Use e.g. user name David with blank password. Once signed-in, you should see the site as in the
screenshot below:

:EIQ

o~

& Community Starter Site - Home - Windows Internet Explorer

U @ o |':i:' http://localhost/KenticoCMS/default.aspx

-[B]4]x[lo sing

¢ Favorites i+ Community Starter Site - Home | |

[ il v [ g v Pagev Safetyw Toolsw @@~
—

1 - Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. f

Current user: David Silver (David) | My home page | Edit my profile | Inbox | Sign out

. Groups  Members

| Examples

Welcome to our community

This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new
people and all the things related to it.

If you are interested in this sort of things, don't hesitate and
join now!

Latest blog posts

Latest forum posts

1

| | Search

The long long flight

Finally, after some 23 hours of flight, I am on the other side of the world
than I was yesterday around this time. [ feel terribly tired after the long

flight, but before T go to sleep, 1 found some time to write about the first
impressions of my journey.

Posted on 10/26/2008 3:05:12 PM

Hlying tomorrow

Hi everybody, my name is Kelly Taylor and I come from Brno, Czech
Republic. Tomorrow is my big day. Finally, after six months of hard
everyday work, I decided to have some nice time and go on haliday.
Australia has always been one of the places 1 had wanted to visit one
day, and now, with my great new job and the wage [ get for it, itis
finally affordable for me to get there.

Posted on 10/26/2008 2:19:18 PM

RE:Hostels in London

Well, ok, well... there is actually not enough room for two guests
place...

hmy

(

Shortcuts

My profile

Edit my profile

My messages

My friends

My invitations
Create & new group
Create a new blog
Sign out

N/

Posted on 1/7/2009 3:13:50 PM Reportfabuse e
RE:Hostels in London

Thanks, but the reason why I'm looking for a hostel in London is adtually

that I'm gonna be waiting for my boyfriend there. He'll be returning from Latest Groups

the States and his plane lands at Heathrow. .. But we can come to
Edinburgh together some time later and stay at your place if you
want...?

Posted on 1/7/2009 3:11:33 PM Bepor!

labuse

RE:Hostels in London

Latest news

Abi's got a blog

Abigail Woodwarth, our site
member from LA, California,
has recently set off for
Europe, You can look forward
to reading posts about all the
interesting places she is going

African travellers

This is a group of
S travellers living in Africa,
If you are one of them, please
register to the group. Itis a
great chance f...

l Australian travellers
Saying dbye Europe Dear young lady, don't go to London, you won't like it there @bme to N i Thisis agroup of 2
S — — S

‘-‘-“-_ Tocal intranet | Protected Mode: Uff

TR R 100% <

1. At the very top of the page, you can see the CMS Desk and CMS Site Manager links. These can be
used to access the administration interface from the live site. Default user name is administrator with
blank password. Alternatively, the administration interface can be accessed via the following URLs: <site
domain>/CMSDesk or <site domain>/CMSSiteManager.

© 2010 Kentico Software
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2. Links to the current user's public profile, profile editing, internal messaging inbox and the Sign
out link that can be used to log off the site.

3. Main menu. The menu reflects site structure, particular items in the menu lead to the following
sections:

e Home - home page of the web site, displaying latest blog and forum posts in the main area and
various other information in the side column

e Blogs - in this section, you can read blog posts in site users' blogs or easily create your own blog
right on the live site and start blogging immediately

e News - the news section is designed for displaying news items created by authorized CMS Desk
users, typically site administrators and editors

e Media - in this section, you can view content of the site's public media libraries; various types of files
can be stored in these libraries, while large file sizes (several GB) are supported

e Forums - discussion forums, you can read or join discussions on various topics and create new
topics; both classical and Q-A forum types are supported

e Groups - in this section, you can view existing community groups and join some of them or even
create your own new group; groups can have their own media libraries, forums, polls and message
boards

e Members - this is where you can see a complete list of site members; by right clicking their avatars,
you can display a context menu allowing you to do several actions related to the clicked user; by left-
clicking a user's avatar, you can view her public profile

e Examples - in this section, you can find isolated examples of particular community web parts; these
examples are particularly useful when you access them from CMS Desk, where you can view web part
properties settings

4. This is the main zone where the content is displayed. On the Home page, it displays the Sign-in/Join
banner and extracts from the latest blog and forum posts.

5. Integrated full-text search of all documents on the site.

6. The shortcuts box displays shortcuts to various community functions. It offers different actions
depending on which section of the site is currently displayed.

7. The rest of the side column displays various repeaters and information boxes depending on which
section of the site is currently displayed.

© 2010 Kentico Software
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2.2  User registration and Sign-in
2.2.1 Current functionality
In the following example, you will learn how to register to the site and become its member.
1. If you come to the site as a site visitor and want to register, there are several links to click. All of the

links highlighted in the screenshot below will take you to the Logon page where registration can be
performed. Click one of them.

Community

Starter site

Home  Blogs  News  Media  F up b . Examples | || searcn

H Sign in

Welcome to our community =
[~ Sigrin>> g™ toin now> |
Log on
This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new o
people and all the things related to it. Et
If you are interested in this sort of things, don't hesitate and
join now!
Latest news

Latest blog posts Latest forum posts P S ———

2. On the logon page, site \isitors can register by filling in the Join the community form. Enter some
sample details and click Register.

Sign In

Community

Starter site

Home  Blogs  HNews  Media F . up. Memb . Examples | ||Search

Sign in Join the community
User name: User name: Derek
Password: First name: Derek
[“I remember me Last name: McKenzie
—— Email: ckenzie@localhost.local
Password: "TTIT]

Forgotten password
Confirm password: gesee

Gender: @ Male ) Female

© 2010 Kentico Software
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3. You will be redirected to your public profile. This profile is visible to all site visitors and users and gives
them an oveniew about yourself. Let's modify your details a bit now. Click the Edit my profile link in

the Shortcuts menu. You will be redirected to the profile editing page.

Community

Starter site

Member profile

Derek
Badge:

Gender: Male
Date of birth: N/A
Forum posts: 1]
Message board posts: [1]
Blog posts: 0
Blog comments: ]

Community points:

My announcements

Current user: Derek McKenzie (Derek) | My home page | Edit my profile | Inbox | Sign out

| | Search

Fullpame:  Derek McKenzie

Email: mckenzie@localhost.local

Created: 2/16/2010

Shortcuts

Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

My friends

Currently doesn't have any
friends.

There are currently no announcements,

Leave message Subscribe

My blogs
Currently doesn't have any
blogs.

My groups
Currently is not member of any
aroup.

© 2010 Kentico Software
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4. Let's choose some avatar so that your profile looks more personal. Click the Select pre-defined
avatar link as highlighted in the screenshot below.

Current user: Derek McKenzie (Derek) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home Blogs HNews Media F ._.. Memb . Examples | || searcn

My profile
Shortcuts
Personal settings | Change password | Notifications | My profie
Edit my profile
Username: Derek My messages
- My friends
Full name: Derek McKenzie My invitations
il Lreste a new group
Email: mckenzie@localhost local Create a new arou
Create a new blog
Display my e-mail to: () Nobody () (all) @) Site members (7 Friends Sign out
Mickname: Derek
- My blogs
‘fou currently do not have any
Signature: blogs.
M rou
Messaging notification e-mail: L
‘fou are currently not member
Time zone: | (none) |Z| of any group.
Avatar: Upload: Browse...
Select pre-defined avatar Forum favorites
Gender: @ Male ) Female No favorites found
Date of birth: @No_w

5. The gallery of pre-defined avatars will be displayed. Choose one and click OK.

e ™y
& | Avatars gallery -- Webpage Dialog u

Please select an avatar

[
I~
[3%]
I

Ok Cancel

http://localhost/KenticoCMS/CMSM €&s Local intranet | Protected Mode: Off

© 2010 Kentico Software



Part 1 21

6. Let's also add your date of birth. Click the calendar icon next to the Date of birth field, pick a date
and click OK.

7. Finally, click OK on the profile editing page to save the changes. If you click the My profile link in
the Shortcuts menu again, you will see your profile with the avatar and date of birth added.

Current user: Derek McKenzie (Derek) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

. Media F up Memb . Examples | || search

Shortcuts

My profie
DerEk Edit my profile
Badge: My messages

My friends
My invitations
Create a new group

Fullpame:  Derek McKenzie

Email: derek.mckenzie @localhost. local Create a new blog
Created: 2/16/2010 Sign out
Gender: Male
Date of birth: 11/13/1335 My friends
Forum posts: o Currently doesn't have any
Message board posts: i} friends.
Blog posts: ]
Blog comments: ]
Community points: My blogs
Currently doesn't have any
blogs.
My announcements

Further steps: This was only a brief example of what can be done. Try playing around with the settings
and explore the various possibilities. You can for example use an image from your local disk instead of
the pre-defined avatars. You can also go to the Members section, where profiles of all sample site users
can be accessed from. Notice that the Shortcuts menu displays various actions depending on what
content is currently displayed. Performing the actions is very intuitive, so don't be afraid and try them
out.
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222

Modifying the registration form

In the following example, you will learn how to modify the registration form used on the logon page. For
the purpose of this example, we will want the Middle name field to be specified by users on

registration.

The registration form is displayed using the Custom registration form web part. This web part enables
user registration based on an alternative form of the CMS_User system table. For more information
about the Alternative forms concept, please refer to the Module Alternative forms chapter of Kentico
CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the User (CMS_User) system table.

212 Kentico

#g% CMS Site Manager

=) Development

&l Categories

@ Countries

(}' 55 stylesheets

43 cultures

- fill custom tables
£l Document types
- [3) E-mail templates
d;’} Form controls
: Inline controls
-{h Modules
-] Notifications
.-[H page layouts
ﬁ Page templates
-5 Relationship names
. ffH| system tables
¥ Tag groups
@D Time zones
-3 UI cultures

!

Sites

Administration

Settings

@ System tables

xﬂxxxxxxxxxg

Class display name -
Ecommerce - Customer
Ecommerce - Order
Ecommerce - Order item
Ecommerce - Shopping cart
Ecommerce - Shopping cart item
Ecommerce - SKU

Group

Media file
Newsletter - Subscriber
User

Lser - Settings

Development

Switch to CMS Desk

Licenses Support

Class name
ecommerce.customer
ecommerce.order
ecommerce.orderitem
ecommerce.shoppingcart
ecommerce.shoppingcartitem
ecommerce.sku
Community. Group

media file

newsletter. subscriber
cms.user

cms.usersettings

User: Global

Table name
COM_Customer
COM_Order
COM_Orderltem
COM_ShoppingCart
COM_ShoppingCartSklU
COM_SKU
Community_Group
Media_File
Newsletter_Subscriber
CMS_User
CMS_UserSettings
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2. Switch to the Alternative forms tab. Choose to Edit (#) the Registration form alternative form,

which is the one currently used on the logon page. As you can see, the other alternative forms are used
for user profile displaying and editing.

Switch t
-":'. Kenti.CO witch to
l.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
& Development @ System table properties
&l Categories
Countries System tables » User
L..¢J €55 stylesheets
: Fields Queries Alternative forms
(P cultures

ﬂ Custom tables

. Document types
: () E-mail templates
d,’} Form controls Actions = Display name - Code name
...J5 Inline controls 7R

Modules
| Notifications # ®  Editprofile EditProfile

E‘q Create new form

Display profile DisplayProfile

[E Page layouts # &  Editprofile (Community)  EditProfile Community
@ Page templates # &  Editprofile (MyDesk) EditProfileMyDesk
...e8 Relationship names
g ’ Registration form RegistrationForm
ﬁ System tables g 9

-<¥ Tag groups
@ Time zones
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3. Switch to the Fields tab. This is where you can define which fields of the User system table will be
displayed in the form. Select the MiddleName field from the list on the left and check the Display
attribute in the editing form check-box. Enter the following details:

e Field caption: Middle name

e Field type: Text box

Click OK.

232 Kentico

4% CMS Site Manager

=)~ Development

- Categories
@ Countries
.- €55 stylesheets
@) cultures
--fifl custom tables
-l Document types
[2) E-mail templates
‘& Form controls
o[ Inline controls
- (3 Modules
++J| Notifications
.-['H page layouts
-[@ Page templates
-5 Relationship names
[ System tables
-&# Tag groups
& Time zones
3 UI cultures
Web part containers
- % web parts
.[@] Web templates
-[8] widgets
ol Workflows

L— & F

Sites Administration

Settings

Development Licenses

@ System table properties

Systemtables » User

Fields Queries

Alternative forms

Alternative forms » Registration form

General Fields Layout

UserlD

UserMame

Firsttlame

LastMame

FullMame

Email

UserPassword
PreferredCultureCode
PreferredUICultureCode
UserEnabled
UserlsEditor
UserlsGlobalAdministrator
UserlsExternal
UserPasswordFormat
UserCreated

LastLogon
UserStartingAliasPath
UserGUID
UserLastModified
UserLastLogoninfo
UserlsHidden
UserVisibility
UserlsDomain -

m

Switch to CMS Desk

Support

T lDispIay attribute in the editing form ]

Field
Default visibility:

Visibility contral:

Allow user to change field
visibility:

Displayto all
Visibility (drop down list)

]

User: Global Administrator v5.0.

] [E]

Field caption:

Field type:

Middle name

Text box

m

Field description

© 2010 Kentico Software



Part 1 25

4. Switch to the Layout tab. This is where you can define the layout of the form. Right-click the line with
the FirstName controls. From the context menu, choose Row -> Insert row after. Select MiddleName
from the Available fields list and use the Insert label, Insert input and Insert validation label
buttons below to insert the label, input and validation controls into the new table row. The result should
look as in the following screenshot.

Click Save.

=32 Kentico
#§% CMS Site Manager

(=) Development

i Categories

@ Countries
& CSS stylesheets
@ Cultures
R ﬁ Custom tables
- fi) Document types
{3 E-mail templates
<_§ Form controls
Inline controls

L] Notifications

o[ page layouts

i Page templates
.08 Relationship names
[ system tables

i &P Tag groups

- @ Time zones

UI cultures

Web part containers
- % web parts

--[@] web templates
--[@] widgets

L[ Workflows

Sites Administration

Settings

Switch to CMS Desk

Development Licenses Support

ﬁ System table properties

System tables » User

Fields Queries

Alternative forms

Alternative forms » Registration form

General Fields

= sz

Use custom form layout

Layout

Generate table layout

Source | [, £

B I U |x it

MO = Q &S

¢4 kB &
e s

03 ol B

- | Fant

Fiormat v | Size

User: Global Administrator v5.0

$5label:UserName$s
58labelFirstNames$

BSinputUserName$$sdvalidation:UserName$s
BSinputFirsttlame$58Evalidation Firstamess

$5label:MiddleName§$

$$input-MiddleName$$$5validation:MiddleName$s|

$5labelLastNamess
$5label:Emailss
$5label:UserPassword$s

Confirm password:
$5label:UserGenders$

$5inputLasthame$$FSvalidation:.LastNamess
B8input:Email$$$svalidation:Emailss

BfinputUserPassword$$bbvalidation:UserPassword$s

BfinputUserGenderf$bbvalidation:UserGenderss

m

Available fields:

UserName

Firsthame

LastMame

Email

UserPassword
UserlsDomain
UserHasAllowedCultures
UserGender
UserWaitingFordpproval
UserDialogsConfiguration
UserDescription

Insert validation label
Insert submit button
Insert visibility control
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5. If you go to the live site now and open the Logon page, you should see the modified version of the
alternative form, just as in the screenshot below.

Sign In

Community

Starter site

. = e e | _'. 3208
Home  Blogs MNews  Media F up Memb | Examples | | || searcn

Sign in Join the community
User name: User name:
Password: First name:
[E]Remember me [ Middle name: ]

Last name:

Log on
Email:
Forgotten password
Password:

Confirm password:

Gender: D male ©) Female

Further steps: You have learned how to modify the registration alternative form. The same way, you can
add other fields to the form according to your needs. You may also try creating a completely new
alternative form and using it for registration. The new alternative form needs to be specified in the
Alternative form property of the Custom registration form web part. You can find a step-by-step
tutorial on how to do this in Kentico CMS Deweloper's Guide -> Membership and User reqgistration ->
Creating a custom registration form.
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2.2.3

Modifying user profiles

You can define which information will be displayed on users' public profiles. In the following example, you
will learn how to add the User ID field to the public profiles.

User public profiles display information from the CMS_User system table using an alternative form. In
our case, it is the Display profile alternative form. We will have to modify the alternative form to achieve
the required functionality. For more information about the Alternative forms concept, please refer to the

Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the User (CMS_User) system table.

=32 Kentico
#g% CMS Site Manager

=) Development

&l Categories

@ Countries

(}' 55 stylesheets

43 cultures

- fill custom tables

ﬁ]] Document types
- [3) E-mail templates
d;’} Form controls
{2 Inline controls
-{h Modules
-] Notifications
.-[H page layouts
ﬁ Page templates
-5 Relationship names
. ffH| system tables
¥ Tag groups
@D Time zones
-3 UI cultures

| —

Sites A

@ System tables

xaxxxxxxxxxg

Switch to CMS Desk

dministration Settings Development Licenses Support
Class display name - Class name
Ecommerce - Customer ecommerce.customer
Ecommerce - Order ecommerce.order
Ecommerce - Order item ecommerce.orderitem
Ecommerce - Shopping cart ecommerce.shoppingcart
Ecommerce - Shopping cart item ecommerce.shoppingcartitem
Ecommerce - SKU ecommerce.sku
Group Community. Group
Media file media file

Newsletter - Subscriber
User

Lser - Settings

newsletter subscriber
cms.user

cms.usersettings

User: Global

Table name
COM_Customer
COM_Order
COM_Orderltem
COM_ShoppingCart
COM_ShoppingCartSklU
COM_SKU
Community_Group
Media_File
Newsletter_Subscriber
CMS_User
CMS_UserSettings

2. Switch to the Alternative forms tab and choose to Edit (¢) the Display profile alternative form.

3£ Kentico
#g% CMS Site Manager

=)~ Development

-&J Categories

@ Countries

¢ css stylesheets

- Cultures

-fiill Custom tables
[l Document types
Q E-mail templates
<§ Form controls
[ Inline controls
i-{7y Modules
\i.] Notifications

I] Page layouts

ﬁ Page templates
.= Relationship names
ﬁ System tables
--+%J Tag groups

Switch to CMS Desk

Sites Administration Settings Development Licenses Support
@ System table properties
System tables » User
Fields Queries Alternative forms
[El create new form
Actions = Display name - Code name
Display profile DisplayProfile
# R Editprofile EditPrafile
# Editprofile (Community)  EditProfileCemmunity
# Editprofile (MyDesk) EditProfileMyDesk
f x Registration form RegistrationForm
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3. Switch to the Fields tab. Select the UserID field from the list on the right and check the Display
attribute in the editing form check-box. Click OK to save the changes.

212 Kentico

4% CMS Site Manager

=) Development
.5 Categories
@) Countries
G CSS stylesheets
-3 Cultures
--fil Custom tables
G’ﬂ Document types
Q E-mail templates
- Form controls
b Inline controls
¢ Modules
. Notifications
-.[HPage layouts
i Page templates
-0 Relationship names
-{f System tables
-.&9 Tag groups
- Time zones
UI cultures

: Web part containers
-.g® web parts

-.[@] web templates
--[@] widgets

! Workflows

L = 1T

Sites Administration

Settings

Switch to CMS Desk

Development Licenses Support

ﬁ System table properties

Systemtables » User

Fields Queries

Alternative forms » Display profile

General Fields Layout

-
UserMName F
Firsthame

MiddleName

LastMame

FullName

Email

UserPassword
PreferredCultureCode
PreferredUICultureCode
UserEnabled m
UserlsEditor
UserlsGlobalAdministrator
UserlsExternal
UserPasswordFormat
UserCreated

LastLogon
UserStartingAliasPath
UserGUID

UserLastModified
UserLastLogoninfo
UserlsHidden

UserVisibility

UserlsDomain -

m

Alternative forms

Database
Affribute name:
Attribute type: Integer number
Aftribute size:

Allow empty value: [

Attribute defaultvalue:

Display attribute in the editing form

Field

Default visibility: Display to all

Visibility control: Visibility (drop down list)
Allow user to change field m
visibility:

Field caption: UserlD

User: Global Administrator v5

m

ENJEN

ok |
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4. Now we need to modify the layout of the profile, so switch to the Layout tab. Place the cursor in the
first column of the empty line below the FullName line and choose UserID from the Available fields list
on the right.

Click the Insert label button. Select the text that was entered and make it bold so that it looks the
same as the other labels. Place the cursor to the second column of the line and click the Insert input
button.

The result should look as in the screenshot below. Finally, click Save to save the changes.

Switch to CMS Desk  User: Global Administrator v5.0
232 Kentico s
’.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
=)~ Development @ System table properties
- Categories
... Countries System tables » User
i..gf CSS stylesheets
: Fields Queries Alternative forms
€ cultures
-fi}l Custom tables Alternative forms » Display profile
i)l Document types
@ E-mail templates General Figlds Layout
<.§ Form controls
- E Save
=2 Inline controls

¢ Modules
Notifications

iyl

[Hpage! . Use custom form layout
age layouts

... [@ Page templates Generate table layout

‘..=§ Relationship names

- £[System tables § ElSowce | [ | & |dh 0B & Available fields:
= fi= 1= = usero |
-9 Tag groups B 7 U a|x <Pz iz : -E .2 Userlame I
. Time zones HE == == =1 1Ak El:rhlgl”ame
UL cultures . H E Style - | Farmat - Font - Size - UserCreated =
Web part containers R Tiv %’ = m UserlsDomain

¥ web parts UserHasAllowedCulture

. |« UserMickMame
e $$input:UserName$$ UserAvatarlD .
--[@] widgets : UserBadgelD
* & Workflows $$labelUserBadgelD$$  $SinputUserBadgelD§$ | |useractivityPoints
$$label:FullName$$ SSinputFullNamess 7| |UserForumPosts
UserBlogComments -
| $$labetuseriD$$ $SinputUserDS5 |

$$label:Email$$ $5inputEmail$$ %

$$label:UserCreated$$ $SinputUserCreated$s

$$labelUserGender$$ $SinputUserGenderss

$$label:UserDateOfBirth$$  55inputUserDateOfBithss Insert submit button

4 1 | » Insert visibility control
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5. Now if you switch to the live site and sign in as some of the sample users (e.g. David with blank
password), you should see the UserlID field present on his profile, as highlighted in the screenshot
below.

Current user: Davwid Silver (David) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home  Blogs MNews Media F up Memb . Examples | || search

Shortcuts

= My profie
DaVId Edit my profile

Badge: 3338 My messages

My friends

My invitations
Create a new group
david.silver @localhost.local Create a new blog
Created: 10/25/2008 Sign out

Gender: Male

Date of birth: 5/6/1957 My friends

Full name:  David Silver

Kelly

Gender: Female
Age: 27

3
0
0 -
Tessie
Blog comments: 1] Gender: Female
20 Age: 25

Further steps: You have learned how to modify the user public profile. This way, you can add any other
field to the profile. You may also try creating your own alternative form and use it for displaying user
profiles. The new alternative form needs to be specified in the Form name property of the User public
profile web part. You may also try modifying the Edit profile (Community) alternative form the same
way. Like this, you can allow users to modify some additional details of their profile on the profile editing
page.
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224

Enabling public profile fields visibility controls

You can let users specify who will see particular details on their public profiles. By default, this is
enabled for the e-mail field, as you can see in the screenshot below. Using the highlighted radio-buttons,
users can make their e-mail address visible to:

Nobody - nobody can see the e-mail address

All - everyone including anonymous site \isitors can see the e-mail address

Site members - only authenticated site users can see the e-mail address

Friends - only authenticated site users who are among the user's friends can see the e-mail address

Current user: Mia Lee (Mia) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home  Blogs  HNews  Media F up. Memb . Examples | ||Search
My profile
Shortcuts
Personal settings | Change password | Notifications | My profie
Edit my profile
Username: Mia My messages
- My friends
Full name: Mia Lee My invitations
i Lreste a new group
Email: mia_lee@Iocalhost local Create 3 new arou
Create a new blog
[ Display my e-mail to: () Nobody () (all) @) Site members (7 Friends ] Sign out
Mickname: Mia
$-Ma-Ma-Mia-3# - My blogs
‘fou currently do not have any
Signature: blogs.
My groups

Messaging notification e-mail: pRm— =
1an travellers
Time zone: (none) |Z| This is a group of Asia-
based travellers. If you
are living in Asia, please
register to the group. Itis a
great chance for ...
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In the following example, you will learn how to let users set the \visibility of their full name.

User profiles display data stored in the CMS_User system table based on the specified alternative form.
In our case, it is the Edit profile (Community) alternative form. We will have to modify it to achieve the
required functionality. For more information about the Alternative forms concept, please refer to the

Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the User (CMS_User) system table.

=3£ Kentico
#¢% CMS Site Manager

=)~ Development

-&Jl Categories

-4 Countries

g Css stylesheets
LD cultures
il Custom tables
Document types
f'_] E-mail templates
4’} Form controls
/= Inline controls
{4 Modules
| Notifications

--{H Page layouts

..[@ Page templates

=5 Relationship names
ﬁ System tables
.+&§ Tag groups

4 Time zones

@ UI cultures

—

Sites Administration

Settings

@ System tables

xﬂxxxxxxxxxg

Class display name -
Ecommerce - Customer
Ecommerce - Order
Ecommerce - Order item
Ecommerce - Shopping cart
Ecommerce - Shopping cart item
Ecommerce - SKU

Group

Media file
Newsletter - Subscriber
User

Lser - Settings

Development

Switch to CMS Desk

Licenses Support

Class name
ecommerce.customer
ecommerce.order
ecommerce.orderitem
ecommerce.shoppingcart
ecommerce.shoppingcartitem
ecommerce.sku
Community. Group
media.file
newsletter.subscriber
cms.user

cms.usersettings

User: Global

Table name
COM_Customer
COM_Order
COM_Orderltemn
COM_ShoppingCart
COM_ShoppingCartskU
COM_SKU
Community_Group
Media_File
Mewsletter_Subscriber
CMS_User
CMS_UserSettings
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2. Switch to the Alternative forms tab and choose to Edit (#) the Edit profile (Community)

alternative form.

232 Kentico
#¢% CMS Site Manager

=)~ Development
-3l Categories
@ Countries
g Css stylesheets
@) Cultures
- fill Custom tables
c'ﬂ Document types
f_} E-mail templates
<§ Form controls
+[E Inline contrals
(% Modules
;. Notifications
--[H Page layouts
ﬁ Page templates
=5 Relationship names
@ System tables
--+¥ Tag groups
- @ Time zones
) UI cultures

Switch to

Sites Administration Settings Development Licenses Support

@ System table properties
System tables » User
Figlds Queries

Alternative forms

[l create new form

Actions = Display name - Code name

f x Display profile DisplayProfile

# 8  Editprofile EditPrafile

* Edit profile (Community)  EditProfileCommunity
# $  Editprofile (MyDesk) EditProfilelyDesk
/ x Reqistration form RegistrationForm
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3. Switch to the Fields tab and select FullName from the list on the left. Check the Allow user to
change field visibility check box and switch the value of the Visibility control drop-down list to
Visibility (radio buttons - horizontal). Click OK to save the changes.

] Switch to CMS Desk  User: Global Administrator v5
~¢= Kentico '
'.‘ CMS Site Manager Sites Administration Settings Development Licenses Support

=l Development

ﬁ System table properties

-5 Categories

4@ Countries

-§f CSS stylesheets

3B Cultures

--fill custom tables

E]1 Document types

--[3) E-mail templates

.. Form controls

122 Inline controls
B Modules

.| Notifications

-.[HPage layouts

i Page templates

.= Relationship names

- ff System tables

--%&¥ Tag groups

) Time zones

UI cultures

: Web part containers

- g® web parts

-.[@] web templates

-.[@] widgets

- Workflows

L& I

Systemtables » User

Fields Queries

Alternative forms

Alternative forms » Edit profile (Community)

General Fields Layout

UserlD

UserMName

FirstMame
MiddleName
LastName

Email

UserPassword
PreferredCultureCode
PreferredUICultureCode
UserEnabled
UserlsEditor
UserlsGlobalAdministrator
UserlsExternal
UserPasswordFormat
UserCreated
LastLogon
UszerStartingAliasPath
UserGUID
UserLastModified
UserLastLogoninfo
UserlsHidden
UserVisibility

m

UserlsDomain -

Display attribute in the editing form

Field

Default visibility:

Display to all

Visibility contral:

Allow userto change field

L]

Visibility (radio buttons - horizontal)

visibility:
Field caption: Full name 3
Field type: Text box =]

Field description:

ok |
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4. Switch to the Layout tab. Place the cursor to the FullName line, right-click and from the context
menu, select Row -> Insert Row After. Type 'Display full name to:'into the first column of the new
line. Then place the cursor into the second column, choose FullName from the Available fields list and
click the Insert visibility control button. The result should look as in the screenshot below.

Click Save to save the changes.

242 Kentico
£ CMS Site Manager

=) Development
-5 Categories
- Countries
- CSS stylesheets
- cultures
--fill custom tables
- fiJl Document types
--[3) E-mail templates
<.§ Form controls
-.[=] Inline controls
(B Modules
-] Notifications
-.[HPage layouts
-[@ Page templates
-2 Relationship names
£ system tables
-.&9 Tag groups
@ Time zones
=1 UI cultures
i3 Web part containers
4% Web parts
-.[@] web templates
..[@] widgets
- Workflows

Sites Administration

ﬁ System table properties

Systemtables » User

Fields Queries

Settings

Alternative forms

Switch to CMS Desk

Development Licenses

Support

Alternative forms » Edit profile (Community)

General Fields Layout

b s=ee

Use custom form layout

Generate table layout

§ E Souce | [& § BR®ES |
IB 7 U ax|x X iiE 0T E]= %
=T LHEEIOIE
: Shle - | Farmat - | Fant - | Size -
A w-iE R

$SinputUserNamess ol

$Blabel:UserNamess

$5label:FullNamess

$Bvalidation:UserName$$
$SinputFullName$$ §Svalidation:FullName$$ L

Display full name ta:

$dvisibilityFullName$$ I

b5label:Emailss
Display my e-mail to:

$8label:UserNickName$s

§5label:UserSignature$s

$BinputEmails$ $5validation:Emailss
F5visibility Email$%
$SinputUserMickMName®s
$Svalidation:UserNickName3$3s

$8inputUserSignature$s
$dvalidation:UserSignature$s

SSinout m B ficationEmailss -

User: Global Administrator v5

Available fields:
UserName -

FulName |y
Email

UserVisibility
UserlsDomain
UserHasAllowedCulture| -
UseriickName r
UserSignature
UserMessagingMotifical
UserTimeZonelD
UserAvatarlD

UserGender
UserDateOfBirth -

Insert validation label

Insert submit button
Insert visibility control
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5. Now if you go to the live site and sign in as some of the sample users (e.g. David with blank
password) and go to the profile editing section (click Edit my profile in the Shortcuts menu), you
should be able to choose the Full name field visibility, as shown in the screenshot below.

My profile

Personal settings | Change password | Notifications |

Username:

Full name:

David
David Silver

| | Search

—

Display full name to:

@ Mobody () (all) () Site members

(7) Friends

Email:
Display my e-mail to:

Nickname:

Signature:

Messaging notification e-mail:

Time zone:

david.silver@localhost.local
() Nobody () (all) @) Site members
David

# % D-a-v-i-d * *

(7 Friends

Shortcuts

My profie
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog

Sign out

My blogs
‘fou currently do not have any
blogs.

My groups

Czech Republic fans

This group is intended

for people who are
interested in the Czech
Republic. Czech Republic
residents, travellers who have
Viun

Further steps: You hawe learned how to let site users specify who will see their full name. The same
way as described above, \isibility controls can be added to any other field of their profiles.
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2.2.5 Registration approval and double opt-in

By default, users are signed-in to the site and their user account becomes active immediately after
successful registration. However, the two options highlighted in the following screenshot can be enabled
in Site Manager -> Settings -> Membership. By enabling these options, you can include additional
steps in the registration procedure.

:!{- Kel'lthO Switch to CMS Desk  User: Global Administrator

’.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
il a Membership
{global) [=]
X E Save f Reset these settings to default
=)-Settings
@ web site
'§:] Content management These settings are global, they can be overridden by the local site settings. Please select the site to see or change
[l Files
a Membership Administrator's e-mail @ admin@localhost local
M Securi
ﬁ URLs ;:d SEO Maonitor online users @ [
? Qutput filter Store online users in database @ [}
.. system
: ' ¥ Deny login interval @ 10
Update online users (minutes) @ 1
Reserved user names @ |admin;root;administrator;sysadmin:sa
I8 Booking system Registration requires e-mail confirmation @ O
&‘ Community i ! Reqgistration requires administrator's approval @ |
Bﬁ Content staging ﬂ
‘.. &4 Forums L Delete non-activated user after (days) @ 5
li‘ Media libraries Shared user accounts (2]
@ Message boards
Messaging Require unique user e-mails (2]

Web analytics

; - Windows LivelD

PR E-commerce

...i5} Payment gateway - Authorize.NET
@ Payment gateway - PayPal

Exportthese settings
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Registration requires e-mail confirmation

If checked, newly registered users will receive confirmation e-mail to the e-mail address specified on
registration. This e-mail contains a confirmation link that needs to be clicked in order to activate the
account. The e-mail is based on the Membership - Registration e-mail template.

!./mg He U e = Confirm your registration - Message (HTRL) - = x
- Message Add-Ins @
I L &4 Find €
1 d CJ x g oy [ 7 % Safe Lists ~ = v Qj g :
\ - Hed S L & == L 12 Related ~ i'
Reply Reply Forward | Delete Moveto Create  Other EBlack ] Mot Junk Categorize Follow Mark as Send to
to &l Faolder~ Rule Ackions ~ | Sender - Up~ Unread lg Select~ Cneklote
Respond Actions Iunk E-mail (F] Cptions IF] Find Cneklote
From: no-reply@localhost. local Semtt Mon 2/22/2010 3:46 PM
To: John Mewman
Co
Subject: Confirm your registration

[ ¥

Thank you for registering at our site. Please click the link below to cormplete your registration:
hitp Mo calhostE entico CWME/Special-pagesRemstration-approval asprTusermnd=32684ba72-03a4-4672-85ed -Bb d4 a3 0fbEF

Tou can find vour credentials below:
Tzemame: johnn
Password: 123456

4

After clicking the link, a special page will be opened in user's web browser, displaying the following
message:

Your user account is now active. You can sign in using your user name and password. Click here to
continue.

The link at the end of the message will redirect the user to the title page of the web site. The user can
then log in using the registration details received in the e-mail.
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Registration requires administrator's approval

If this option is enabled, users will not be able to sign-in immediately after registration. Their registration
will have to be approved by site administrator. At this point, users will receive an e-mail based on the
Membership - Registration waiting for approval e-mail template. You can see the default version of
the e-mail in the screenshot below.

p— S| E Reqistration infarmation - hMessage (HTML - = X
[ E% = 5 e ¥ q gz | )
- Message Add-Ins ':@
I WL 44 Find &)
= i} % x 1 S g jﬁ % Safe Lists - = ¥ 5 !
" - el G L o == . 2h Related - d;
Reply Reply Forward | Delete Move to Create  Other Block [ Wat Junk Categorize Follow Mark as Send to
to &l Faolder~ Rule Actions~ | Sender - Up~= Unread | b§ Select~ OneMote
Respond Actions Junk E-mail Ia Cptians Ia Find Cnelote
Fram: no-reply@localhost, local Sent Tue 2/23/2010 2:57 PM
To John Newman
Co
Subject: Reqgistration information
F

Thank you for registering at our site ComtrumitySite. Your registration must be approved by administrator.

Eegistration details:

Tsername: johnn
Password: 123456

In case that the option is enabled, the Waiting for approval tab will be displayed in Site Manager ->
Administration -> Users. On this tab, site administrators can Approve (¥) or Reject (@) users'
registration.

-‘!’. Kentico Switch to CMS Desk  User: Global Administrator v5.0.3693 Sign out
£ CMS Site Manager Sites Administration Settings Development Licenses Support
| e |
(=~ Administration & Users
... [t Avatars
(7 Bad words Users Mass emal  Ondine users
‘.44 Badges = =
.. M ganned 1Ps & Waiting for approval ©
‘.9 E-mail queue 5
Ij Event log [all]l A B C D E F G H | J K L M N o] P Q R 5 T U v
. -F Permissions
-4l Recytle bin ﬁ
a‘ ::rljasduled tasks ~ Display advanced fifter
) Smart search
.3 system H
; UI personalization Actions 7 User name - | Full name Email Nickname = Created Enabled

i"%users o @ [ johnn John Newman  johnn@localhostlocal  johnn 212212010 45452 PM Mo
R Web farm

Items per page: 25 |Z|

After the administrator's approval, users receive another e-mail, confirming that their account has been
approved and can be used. The e-mail is based on the Membership - Registration approved e-malil
template. You can see the default appearance of the e-mail in the screenshot below.
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."{t!g;\‘- = & ¥ |5 Registration approved - Message (HTRL) - = x
o .
—/J Message Add-Ins 7]
¥ T 5 = 5 34 Find & o1 b
] 1] x 2y 2 % Safe Lists - v ¥ g !
o i i =] % =] B || @ petatea- | B
Reply Reply Forward | Delete Move to Create  Other Block Mot Junk Categorize Follow Mark as send to
o Al Folder= Rule &ctions< | Sender - Up~= Unread | b Select~ OreMote
Respond Actiohs Junk E-mail F} Optians Ts Fird Onelote
Fram: no-reply@localhost. local Sentt Mamn 272272010 447 PM
To: John Mewman
o
Subject: Registration approved

[

Your registration has been approved by adminstrator. Wow you can sign i using vour username and password.

Clck here to navigate to the web site

Enabling both options

In case that you enable both of the options mentioned abowve, e-mail with the confirmation link will be
sent first. After user's confirmation, registration will have to be approved by the administrator.

= Please note

e
F
™,

If you have one or both of the options enabled, it is important to set the Redirect to
URL property of the registration web part properly. This means that users should not be
redirected to any page displaying information about their user account (just as the
Members -> Profile page on the sample Community Starter site). Because the
account is not active yet (it is waiting for e-mail activation or approval), such page would
display an error message, which might be misleading for the users.

Further steps: You have learned how to enable registration approval and double opt-in. At this point, you
may want to try enabling the options and registering to the site to see how they work in practice. In this
case, it will be necessary to set up the SMTP sener in Site Manager -> Settings -> E-mails in order
for the e-mails to be sent correctly. You may also want to go to Site Manager -> Development -> E-
mail templates and modify some of the notification e-mail templates mentioned in the text above.

© 2010 Kentico Software



Part 1 41

2.2.6 Windows Live ID

2.2.6.1 Overview

Windows LivelD is a single sign-on service provided and maintained by Microsoft. By integrating LivelD
into your web site, you can allow site \isitors to log in to your web site using their LivelD login and
password.

More information about integration of Windows Live ID with Kentico CMS can be found in Kentico CMS
Deeloper's Guide -> Membership and User registration -> Windows Live ID.
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2.2.6.2 Adding the sign in button

After registering your web site at msm.live.com and making the necessary settings, you only need to
place the Membership -> Windows LivelD web part to your site. This web part works fine without any
additional settings and can be placed on any page of your web site.

In the following example, you will learn how to add the Windows LivelD web part to the sample
Community Starter site. We will add the web part to the zoneTopMembership web part zone of the
master page, next to the sign-in link. Like this, the LivelD sign-in button will always be displayed, no
matter which particular page is currently displayed.

1. Sign in to CMS Desk (login administrator with blank password by default). Select the master page
(the root of the content tree) and switch to the Design tab.

2. Click the Add web part (%) icon of the zoneTopMembership web part zone.

N7 Kentico Switch to Site Manager  Site:| Community Site[«| User: Global Administrator v5.0.3693 Sign out
-
“a%  CMS Desk Content | Mydesk  Tools  Administration
[=) c U =~ ry
B & Pow 1w | @ & =y o
New Delete |=bMove & pown | Edit  Preview Livesite  List | Search |
Content managemeant | View mode | other |
=
1) Community Site Page | Design | Form  Masterpage  Properties Display web part content @
i[] Home —
Hi= = { -page template: Community Site - Master Page 21~
(+J-1] Blogs -
5[] News ~ zoneToplnfo 4|
f a Media » txtTriallnfo @ Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.
(-2 Forums
(4[] Groups
(- |] Group pages + zoneTopMembership I |
® D Members  SignOutButton @ L2
o o | |+
§ - M jingInfoPanel nbox | | [=
& Files essagingInfoPanel (3
(-3 Special pages = statichtml {3 Edit my profile |
g g Logaon page  MyHomePage (@ My home page |
*-[] search . .
Current user: Global 1
[.J  zoneTopimage e
= Toplmage {3
L
—
x
= zoneTopMenu o

s News Media Forums Groups Members Examples

ke

~ zoneContent
= [ subContent {5}

3. In the Web part selection dialog which pops-up, choose Membership -> Windows LivelD and
click OK. The web part properties dialog pops-up. As mentioned above, no properties need to be set, so
just click OK.
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4. The web part is now placed on the master page. The web part itself is not visible now, but it is
represented by the blue rectangle labeled WindowsLivelD. If you log-off now, you should see the web
part on the page and it should be fully functional.

[3 Signin |

Community

Starter site

_{; _".___,‘ : e : £ : ) 5
Home  Blogs MNews  Media  F up b . Examples \ || Search

Welcome to our community P Sign in
(" Signin > I Join now > | w ﬁ g €
. s ﬂ ﬁ.ﬂ‘

Further steps: You have learned how to add the Windows LivelD sign-in functionality to your web site. In
some cases, you may want the users to provide some additional details on registration via Windows
LivelD. In this case, you would use the LivelD required data web part. A detailed description of this
web part and the way it can be used can be found in Kentico CMS Developer's Guide -> Membershi

and User registration -> Windows LivelD -> Available web parts.
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2.3
231

Groups

Current functionality

1. Go to the live site and sign-in as Kelly with blank password. Click Groups in the main menu. You will
be redirected to the Groups title page.

The Your groups section of this page displays all groups where the current user is a member. The
Recently added groups section displays all groups on the site. If you click a group name or avatar,
you will be redirected to the group's profile page. Enter the African travellers group profile.

Current user: Kelly Taylor (Kelly) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

| | Search

Home News Examples |
Groups
Shortcuts
Right dick the group to get available actions. My profie
Edit my profile
Your groups o —
My friends
Czech Republic fans My invitations
) . aroup
This group is intended for people Create a new grou
who are interested in the... Create a new blog
Sign out
Recently added groups
Sort by: Group name Created
African travellers Australian travellers European travellers
3 This is & group of travellers living in This is a group of Australian This is a group of Europe-based
B Africa. If you are ... travellers. If you are one of... travellers. If you are one ...
7= Asian travellers P American travellers Czech Republic fans
§ This is a group of Asia-based . + This is a group of American This group is intended for people
§ travellers, If you are living... travellers. If you live in Amer... who are interested in the...

2. You can see the group profile page now, just as in the screenshot below. The page has the following
sections:

e Group profile - basic information about the group - its avatar, name, description, type of access and
date of creation

e Group announcements - this is a message board where group administrators can leave important
group-related messages

e Latest in forums - displays latest posts in the group's forums

e Most recent pages - displays latest articles in the group pages section

e Shortcuts menu - the following group-related actions are offered in the menu:
e Create a new group - can be used for creating new groups
e Leave the group - by clicking this link, the current user leaves the currently displayed group so
that she is no longer a member of it
e Invite to a group - by clicking this link, group members can send invitations to the currently
displayed group to other site members or via e-mail
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e Group links menu - this menu offers links to all sections of the currently displayed group:

e Home - group profile page

e Pages - group pages section with articles related to the group's field of interest, added by group
members directly on the live site

e Media - group's media libraries where various types of files can be stored

e Members - page displaying a list of all members of the group; after clicking a user, you will be
redirected to her public profile; right-clicking the users' avatars displays a context menu with other
possible actions

e Forums - group's discussion forums

e Group administrators - displays administrators of the current group; right-clicking the avatars
displays a context menu with possible actions

e Recent members - displays the latest group members; right-clicking the avatars displays a context
menu with possible actions

Try browsing the sections and using the actions listed above. The site was designed to be very intuitive
to work with, therefore you should not encounter any problems playing around with it.

Home Blogs News Media F ps Memb Examples Search

Groups » Czech_Republic_fans

Shortcuts

My profie
Edit my profile

Czech Republic fans

My messages
This group is intended for people who are interested in the Czech Republic. Czech Republic residents, travellers m
who have visited it and those who are planning to do so are all more than welcome to join this group. My invitations
Create a new group
Leave the aroup
Access: Only group members can view the content Invite to aroup
Create a new blog
Created: 2/19/2010 Sian out

Group announcements Group links

There are no announcements at this time Home

Latest in forums

RE:The Czech republic Group administrators
David

Hi, I was in Prague for 5 days last week, and I can honestly say it is one of the most interesting and mesmerising places I've ever seen in Europe. Ger:::ler: Male

Posted on 10/28/2008 8:10:19 PM Age: 22

The Czech republic

I love the Czech Republic ) Recent members
Posted on 10/25/2008 6:33:10 PM David
Gender: Male
Age: 22
Most recent pages | Kelly
@ Gender: Female
Discover the Czech Republic hEE
Discover the Czech Republic - a small country in the very heart of Europe that has got something for everyone, No matter what your interests are, you
will be surprised at what a variety of places to see and things to do there is. Don't miss out on any of the country's natural wonders, histaric landmarks
and breathtaking sceneries., You will be amazed at how even a small European country can significanty contribute to the world's cultural heritage.

And after a nice day full of impressions, why not spend the evening in one of the typical Czech pubs, drinking some of the best beers in the world that
are brewed in this country?

3. If you want to become a member of some other group, you can do it on the Groups title page. Right
click the group you want to join. A context menu appears. Select the Join the group command.
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ﬂ a View group

L. Afl g8 Join the aroup

gin

A pop-up window appears, asking you if you really want to join the group. Click Join. Depending on the
group settings, you will either become a group member immediately, or your request will have to be

approved by the group administrator.

i~ ™y
& | Join the group -- Webpage Dialog ﬂ

@ Join the group

Do you want to join African travellers?

—on | _cancor |

httpe//localhost/K el‘.\ Local intranet | Protected Made: Off

Alternatively, you can also join a group by clicking the Join the group command in the Shortcuts menu
when viewing a group profile.

Shortcuts

My profile
Edit my profile

My messages
My friends

My invitations

Create a new blog
Signi out
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4. You hawe just learned what the group member can see and do in this section. Now let's switch to the
group administrator's point of view. Log-off the site and sign-in again as David with blank password.
David is the administrator of the Czech Republic fans group, so view this group's profile the same
way as you did above with Kelly.

The first thing you will probably notice is that there is the Leave message section below the Group
announcements message board. Because Dawvid is the admin of this group, he can leave
announcements. Try leaving one.

Leave message Subscribe

Name: David
Your URL:  http://
Your e-mai: david._silver@localhost local

Message: @i everyone, I'm just -
gending a testing message to
try how this Group
announcements message board
works.

[C] subseribe me to this message board
Add

After clicking the Add button, you should see the message present on the board:

Group announcements

David
Hi everyone, I'm just sending a testing message to try how this Group announcements message board works.
2{19/2010 4:44:42 PM
Edit Delete Reject
Report abuse

5. You might have also noticed the Manage the group link in the Shortcuts menu.

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new blog
Sign out
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Click it, you will be redirected to the group management section, which is also available only for group
administrators. Try going through all the tabs and changing some settings. As this on-site group
management interface is identical to the groups management interface in CMS Desk, you can refer to

Kentico CMS Deweloper's Guide -> Module Groups -> Editing a group for a detailed description and

explanation of all the available settings. Other topics of the Module Groups chapter can be used as a
source of other detailed information on the Groups module.

Home  Blogs News = Media

Groups » Czech Republic fans » Management

General Security  Members

Description:

Avatar:

Approve members:

Content access:

Roles

b Examples

Forums  Media libraries ~ Message boards  Polls

This group is intended for people who are
interested in the Czech Repubklic. Czech
Republic residents, travellers who have
wisited it and those who are planning to do
=0 are all more than welcome to join this

group.

s W
Upload:

Select pre-defined avatar

(2 any site member can join
@ Only approved members can join

@ Only approved members can join except for invited members

8] Anybody can view the content
() site members can view the content

@ Only group members can view the content

Notify group admins when a user joins[leaves:

.

L

Notify group admi
Created by:
Approved by:

on

administrator
administrator

Search
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2.3.2 Creating anew group

New groups can be created two ways:

e Site users can create new groups on the live site using the Create a new group link in the
Shortcuts menu. This is the most common way and most of the groups on most sites are created
this way.

e Alternatively, if you want to pre-define a group manually from the administration interface, this can be
done in CMS Desk -> Tools -> Groups.

In the following example, you will learn about both ways of creating groups:

1. Go to the live site and sign in as David with blank password. Click the Create a new group link in
the Shortcuts menu.

|
Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

ICreate @ new group I
Create a new blog
Sign out
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2. Enter the following details into the Create new group form:

e Group name - name of the group displayed on the live site and in the administration interface

e Description - text describing the group, displayed in the list of groups

Approve members - determines if users can join the group with or without group admin's approval,
the last options allows invited members to join without the approval

Content access - determines who can view content of the group pages

Click OK. You will receive a message saying that your group has been created, but needs
administrator's approval.

Home Blogs News Media F Group

Create new group

By entering the details into the form below, you can areate your new user group. Make sure you give the group a name and description according to the
group's field of interest, 1t is a good way of attracting site users with the same interest to join your group.

Group name:

Description:

Approve members:

Content access:

Kentico CMS fans

Join us if you love this outstanding CMS.

@ Any site member can join

@ Only approved members can join

(@] Only approved members can join except for invited members
@ Anybody can view the content

(2 site members can view the content

@ Only group members can view the content

Examples

Search

Shortcuts

My profie
Edit my profile

My messages

My friends

My invitations
Create a new blog
Sign out

Recent groups

African travellers
" This is a group of
B travellers living in Africa,
If you are one of them, please
register to the group. Itis a
great chance f...
Australian travellers
This is a group of
Australian travelers, If
you are one of them, please
register to the group. Itis a
great chance for you...
European travellers
This is a group of Europe
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3. Let's switch to the administrator's perspective now. Sign in to CMS Desk (use login administrator with
blank password) and go to Tool -> Groups. You should see the new group present in the list, with the
Approved column saying No. Click the Approve (¥) icon. From now on, the group is approved and
published on the live site.

232 Kentico Switch to Site Manager

#4% CMS Desk Content My desk | Tools Administration

- Tools & Groups

‘@ Abuse report
[El BizForms S New aroup
i Blogs

Fﬂl Booking system
Da Content staging

Group name: | LIKE |Z|

i}l custom tables Status: (all) [~]

PR commerce =

--[[q File import

g Forums Actions Display name Approved
- 44 Groups )

... Media libraries F R D Amicantravellers Yes
Message boards f x qf @ American travellers Yes

Newsletters F RS D Asiantravellers Yes
G Polls ) & B D Australian travellers Yes
-[&] Reporting
E___fh:i Web analytics f x qf @ Czech Republicfans Yes

f x qf @ European travellers Yes
H Ve - ) Kentico CMS fans No
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4. Now we will try the second way how groups can be created - pre-defining a group in the administration
interface. Our group will be named ASP.NET Developers. At first, we will have to go to CMS Desk ->
Content and create the group pages section. Select Groups -> Template from the content tree and
copy the document under the Group pages node.

.‘!:. Kentico

CMS Desle Content | My desk

Switch to Site Manager

Tools Administration

= [ Blcopy T up
New Delete =k Move & Down

Content management

g 2|
Edit  Preview Livesite  List | Search |
View mode | Other |

Ij{-:‘__! Community Site

i Home

-] Blogs

&ID News

D Media

& L] Forums

|_| D Groups
i-[] Management
[ Media
[ Media list
i-[] Members
.- [E Access
-] Forums
L[S Create
- D Template
i D Pages
|_| .| Group pages
u ] czech_Republic_fans
(-] American_travellers
|:|D Asian_travellers
ma European_travellers
wa Australian_travellers
wa African_travellers
|»::|--|_W Kentico CMS_fans
B- D Template

D Pages

u |_] Members
() L] Examples

FPage Design Form Froperties

E Save Spell check

Sign in to CMS Desk. Sign in to CMS Site Manager.

Current

Community

Starter site

Groups * Template
Requested profile not found.

Latest in forums

There are currently no posts,

Most recent pages

There are currently no pages.

5. Select the new Template document that was copied under the Group pages node. Switch to the
Form tab and change its name to ASP_NET_Developers. Click Save.

© 2010 Kentico Software



Part 1

232 Kentico

’.‘ CMS Desk Content My desk
3 3 Copy T up
) [z O

New Delete |=rMove & Down

Content management

=% <) Community Site

-

[ Home

(z-L] Blogs

|1I._I News

I_| Media

(&-L] Forums

|1I._I Groups

d,_| Group pages

: I_| Czech_Republic_fans
,_| American_travellers
-] Asian_travellers

I_| European_travellers
,_| Australian_travellers
-] African_travellers
I_| Kentico_CM5_fans
,_| Template

: ‘.[] Pages

¢|._| Members

0EBDEBEBE

—

Tools Administration

4 [ [ B

Edit Preview Live site List

View mode

Page Design Form Properties

o 52

Spell check

[Documentname: ASP_NET_Developers I

Teaserimage: .;;.Ugload file
Publish from:
Publish to:

A

Search
Other

X
=
=]
=

=
=]
=

Switch to Site Manager

53
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6. Switch to the Properties -> URLs tab and change the Document alias also to
ASP_NET_Developers. Click Save.

Site: Community Site [+

-‘g'- Kentlco Switch to Site Manager
"\ CMS Desk Content My desk Tools Administration
2 & [ Copy T up ¥ @ /O
New Delete |=b Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
d'\;‘_;’:l Community Site Page Design Farm Properties
lJ Home General |
[#-|] Blogs E Save
oI Mews URLs
|_] Media Template
|| Forums Metadata D
¢l._] Groups Categaries ﬁ)fcumentalias: ASP_NET_Developers
|:||_1 Group pages Menu Document URL path: |
i |1l|_] Czech_Republic_fans Workflow Use custom URL path
,1,,_] Amer|can_trave|lers Yo
,1,,_] Asian_travellers Rclatd Extended properties
()| European_travellers URL extensions:
|1l|_1 Australian_travellers N [[luse custom URL extensions
,1,,_] African_travellers Security Track campaign:
[+]-| Kentico_CM5_fans Attachments
l;|,_] ASP_NET_Developers
. ._] Pages H Document aliases
(-] Members i
,1,,_] Examples = Addnew alias
(4.5 Files
(i) Special pages

7. As we have the group pages section prepared, we can proceed to creating of the group itself. Go to
Tools -> Groups and click the New group link at the top of the page.

22 Kentico

#4% CMS Desk

= Tools

i./a| Abuse report
BizForms

Blogs

: Pﬂl Booking system
9@ Content staging
-fiill Custom tables
- E-commerce
[ File import
&4 Forums

& Groups

..l Media libraries

Content

My desk Tools Administration

& Groups
——

Group name: | LIKE

[=]

Status: (all)
Actions Display name «
f x \f @ African travellers

Switch to Site Manager

Approved

Yes

© 2010 Kentico Software



Part 1 55

8. The New group form appears. Compared to the on-site form described in step 2, this one contains
some additional fields. We won't describe all of them now, you can find detailed descriptions in the
context help (accessible via the green '?' icon at the top right corner of the page). Enter the following

details:

e Display name - ASP.NET Dewelopers

e Code name - ASP_NET_Dewlopers

e Description - Building web sites using this Microsoft technology? Join us!!!
e Group pages location - /Group-pages/ASP_NET_Developers

e Avatar - click Select pre-defined avatar and pick one

e Approve members - Any site member can join

e Content access - Anybody can view the content

e Notify group admins when a user joins/leaves - leave unchecked
e Notify group admins on pending members - leave unchecked

Click OK.

& New group

Groups » MNew group

Display name:

Code name:
Description:

Group pages location:

Avatar:

Approve members:

Content access:

ASP NET Developers
ASP_MET_Developers

Building web sites using this -
Microsoft technology? Join us!!

/Group-pages/ASP_NET_Develope

Uploac:

Select pre-defined avatar

@ Any site member can join
= Only approved members can join

() Only approved members can join except for invited members

i@ Anybody can view the content
() Site members can view the content
() Only group members can view the content

Motify group admins when a user joins/leaves: [

Motify group admins on pending members:

]
ok |
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9. The group is now created. If you go to the live site now, you should see it listed in the Groups
section, as depicted below. If you enter the group profile, all sections should be fully functional (but of

course with no content).

Home Blogs Hews Media Forums Groups Members
Groups
Right dick the group to get available actions.

Recently added groups

Sort by: Group name Created

ASP.NET Developers African travellers
| = Building web sites using this . Thisis a group of travellers living in

Microsaft technology? Join us... | Africa. If you are ...

-

European travellers Asian travellers

S Thisis a group of Europe-based
SR travellers. If you are one ...

Czech Republic fans
This group is intended for people

who are interested in the...

a § Thisis a group of Asiz-based
§ travellers. If you are living...

~

Examples

Australian travellers

This is a group of Australian
travellers. If you are one of...

American travellers

. This is a group of American

travellers. If you live in Amer...
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2.3.3 Modifying the group public profile

You can define which details will be displayed on group public profiles. The process is quite similar to
modifying user public profiles described here. In the following example, you will learn how to add the
Group ID field to the group public profiles.

Group public profiles display information from the Community_Group system table using an alternative
form. In our case, it is the Display profile alternative form. We will have to modify the alternative form to
achieve the required functionality. For more information about the Alternative forms concept, please refer
to the Module Alternative forms chapter of Kentico CMS Developer's Guide.

1. Sign in to Site Manager (login administrator with blank password by default). Go to Development ->
System tables and choose to Edit (#) the Group (Community_Group) system table.

Switch to CMS Desk
232 Kentico
"‘ CMS Site Manager Sites Administration Settings Development Licenses Support
(=)~ Development @ System tables
-3 Categories
@ Countries
Q’ €55 stylesheets Actions = Class display name - Class name Table name
@ Cultures rd Ecommerce - Customer ecommerce.customer COM_Customer
-t Custom tables
: @ & Ecommerce - Order ecommerce.order COM_Order
0]1 Document types
[‘_‘} E-mail templates f Ecommerce - Order item ecommerce.arderitem COM_Orderltem
4’} Form controls f Ecommerce - Shopping cart ecommerce.shoppingcart COM_ShoppingCart
% Inline controls / Ecommerce - Shopping cartitem  ecommerce.shoppingcartitem  COM_ShoppingCarntskL
Modules

) Notifications & Ecommerce - SKU ecommerce.sku COM_SKU
..['H Page layouts Group Community.Group Community_Group
@ page templates & Media file media file Media_File
...=5 Relationship names _ ) )
: / Mewsletter - Subscriber newsletter.subscriber Mewsletter_Subscriber
[l System tables
,{j Tag groups f User CMs.user CMS_User
@ Time zones f User - Settings cms.usersettings CMS_UserSettings
B Ul cultures [l

2. Switch to the Alternative forms tab and choose to Edit (#) the Display profile alternative form.

=32 Kentico
#g% CMS Site Manager Sites

Administration Settings Development Licenses Support
=)~ Development ﬁ System table properties
- Categories
... §@) countries System tables » Group
L.4f CSS stylesheets
: Fields Queries Alternative forms
@ Cultures

“fi}l Custom tables
E]] Document types
- [3) E-mail templates

E‘ﬁ Create new form

“-<% Form controls Actions | Display name - | Code name
@ Inline controls Display profile DisplayProfile
- Modules

| Notifications

--[H page layouts

ﬁ Page templates
-5 Relationship names
[ System tables
.- Tag groups
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3. Switch to the Fields tab, select GrouplID from the list of available fields and check the Display
attribute in the editing form check-box. Click OK.

232 Kentico
4% CMS Site Manager

=) Development

- Categories

@ Countries
\..gf €55 stylesheets
@ Cultures
..l custom tables
g Eﬂ Document types
f_] E-mail templates
<% Form controls
i [& Inline controls
-{ Modules
.| Notifications
[B Page layouts
i Page templates
28 Relationship names
@ System tables
--&¥ Tag groups
D Time zones
: UI cultures

f i Web part containers
% web parts

--[@] web templates
--{@] widgets

L.l Workflows

Sites Administration Settings

ﬁ System table properties
System tables » Group

Fields Queries Alternative forms

Alternative forms » Display profile

General Fields Layout

GroupGUID
GrouplLastModified
GroupSitelD
GroupDisplayMame
GroupMame
GroupDescription
GroupModeGUID
GroupApproveMembers
GroupAccess
GroupCreatedByUserlD
GroupApprovedByUserlD
GroupAvatarlD
GroupApproved
GroupCreatedWhen

L& I

Aftribute type:

Development Licenses Support

Database

Aftribute name:

Integer number

Aftribute size:
Allow empty value: [}

Attribute default value:

Display attribute in the editing form

GroupSendJoinLeaveMotification | Field

GroupSendWaitingForApprovalk,
GroupSecurity

Field caption:

GrouplD

Field type: Label

Switch to CMS Desk

»

m

0K
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4. Switch to the Layout tab. We will place the GrouplD field above the GroupAccess field. Place the

cursor in the line with GroupAccess controls, right-click and choose Row -> Insert Row Before from
the context menu.

General Figlds Layout

=

Use custom form lyout

Generate table layout
Souce | (& | & Available fields:
) =
IB I U s:|x &P = E=E =§= P GroupDisplayName
im0 =0 &SiE D OB GroupDescription
) GroupAccess
: Style = | Faormat = | Font * | Size @ GroupAvatarlD
T - iE GroupCreatedWhen
a0 R GroupSendJoinLeaveNotifi
. . = | |GroupSendWaitingForAppr
$$input:GroupDisplayName$$ | | GroupSecurity
S5input GroupAvatar D5 $5input GroupDescription$s
$$label:GroupAccess$$ $5input GroupAccess 59|
$$label:GroupCreatedWhen$$ 55input GroupCreatediWh a
®
Cell »
Row » g Insert Fow Before
Calumn » =2 Insert Row After
Delete Table | = Delete Rows

[T Table Properties

5. The former layout gets a bit scrambled by this action. We will need to make this right before we

proceed. Delete the three empty cells highlighted in the screenshot below by placing the cursor in each
of them, right-clicking and chooseing Cell -> Delete Cells from the context menu.
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General Fields Layout

[ 522

Use custom form layout

Generate table layout

Source | [&,

IB 7 U s x < £ &
ImMO=0 &S 000w |8
ESter * | Farmnat ~ | Fant * | Size
R =T
GroupDisplayName$$ H
$$inputGr0upAvatarlD$ Linnut GronnDescrintinn®%
Cell ¥ | =5 Insert Cell Before
Row » | g*= Insert Cell After
Column y B Delete Cells
1 " Delete Table P Merge Fight

[T Table Properties

fF] Merge Down

Available fields:

GroupDisplayName
GroupDescription
GroupAccess
GroupAvatarlD
GroupCreatedWhen
GroupSendJoinLeaveNotifi
GroupSendWaitingForAppr
GroupSecurity

Insert validation label
Insert submit button

A Spiit Cell Horizontally

A Spiit Cell Verically

=] Cell Properties
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6. Now we hawe the layout as we want it, so we can proceed to adding the controls. Select GroupID
from the Available fields list, place the cursor in the first empty cell and click Insert label. Highlight
the entered text and make it bold, so that it looks the same as the other two labels. Place the cursor in
the second empty cell and click Insert input. The result should look as in the screenshot below. Click
Save to sawve the changes.

General Fields Layout

[ s2e

Use custom form layout

Generate table layout

ESource|Q_§‘% |§

| 7 Available fields:

& GroupDisplayMame

ml = @ a5 ] | El ) | e | % GroupDescription
Grouphccess

- | Famat - | Font * | Size @ GroupAvatarlD
GroupCreatedWhen
GroupSendJoinLeaverotifi
GroupSendWaitingFarAppr

$$input:GroupDisplayName$$ | | GroupSecurity

SSinput GroupAvatarlD I
$$label:GrouplD$$ SSinput GrouplDES ]
label:GroupAccess$s SHINPULGIOUPACCES 565

$$label:GroupCreatedWhen$$ $3input GroupCreatedWhen$s

=

ERE =

»

Insert validation label

- Insert submit button

7. Go to the live site now and view some group's profile. You should see the GrouplID field as highlighted
in the screenshot below.

Home Blogs Hews Media Forums Groups Members Examples

Groups * American_travellers

American travellers

= This iz a group of American travellers. If you live in America and like travelling, please register to the group. Itis a
great chance for you to getin touch with other travellers from your region. They can share their experience and
maybe even become your travel mates. On the other hand, if you are planning a trip to America, users from this

S . Oroup can serve you as a source of valuable information and may even invite you to meet them during your trip.

—

\ GrouplID: 2

Access: Site members can view the content

Created: 2/13/2010
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234

Modifying templates for group pages

The Groups -> Template page and its child (Pages) are the group pages template. Based on this
template, group pages section for user-contributed articles is created for each group. As you may have
noticed in the Creating a new group chapter, these pages are copied under the Group pages node when
a group is created on-site. The Template page is renamed to the name of the new group in this case.
When creating a group via the administration interface, you need to copy the pages manually, rename
the Template page, change its alias and specify the path in the group creating form.

In the following example, you will learn how to add the Content rating web part to the template so that
users will be able to rate the articles in the group pages sections.

1. Log in to CMS Desk (login administrator with blank password by default). Switch to the Edit ->
Design tab and select Groups -> Template -> Pages from the content tree.

2. Click the Add web part () icon of the zoneList web part zone and choose the Content rating ->
Content rating web part.

3. In the web part properties window, set only the following property:
e Show for document types: CMS.SimpleArticle

This ensures that the web part will be displayed only for the articles and not in the list. Click OK.

& | CMS Desk - Web Part properties -- Webpage Dialog | &= |
ﬂ Web part properties (Content rating) @ Documentation
General
Default A LT 0
Visibility
Visibility
Scale settings Visible: »
Messages
Permistan Hide on subpages: y O
HTML Envelope E
e Show for document types: >[ CMS.SimpleArticle I
Time zones | &
E ] Display to roles: 4 Add roles
Partial caching

Scale settings

Rating value: 3
Rating type: b | Stars |Z|
Max rating value: [
Messages
Show racilte: v [ 2
[¥] Refresh content “-m--ﬂm-

http://localhost/KenticoCM5_0219/CMSModules/PortalEngine/UL'Web parts/WebPartPropertis €& Local intranet | Protected Mode: Off
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4. The web part is now placed on the page. Notice that when you switch to some of these pages in the
Group pages section (e.g. Group pages -> American travellers -> Pages), the web part appears there
too. This happens because these pages share the same page template - Community Site - Group
pages. Any modifications that you make to the original page or to the copies will be reflected on all the
pages using this page template.

22 Kentico
#1™ CMS Desk

Content
| 3 [Hcopy  fup
New Delete |=Move & Down

Content management

.:A-\:-IQ'J Community Site

-] Home
(-] Blogs
(£}~ Mews
] Media
-] Forums
d_l Groups
:A_I Group pages
+ | Czech Republic fans

| American_travellers
=-21[Pages

“.[2] My flight to Australia
-] Asian_travellers

_| European_travellers

] Australian_travellers

|1 African_travellers

.| ASP_NET_Developers
Members

Examples

Files

(2

Special pages

Rt

Logon page
Search

=

My desk

Switch to Site Manager ~ Site: Community Site[«| User: Global Admini

Tools Administration

2 & @ =2 | L

Edit Preview Live site List Search
View mode Other
Page Design Form Properties
T T TR D PP —" ]
Home Blogs Hews Media Forums Groups Members Examples
Groups P American travellers » Pages
‘ ¥ [Group pages/American_travellersfPages - page template: Community Site - Group pages ‘y|

= zonelist *
GroupSecurityAccess 123
— =
- =
&
0 Austraha

¥ GroupContributionList ,ﬁ!

¥ GroupEditCantribution @
¥ ArtideRepeater
Iy Thght To Australia

I recently had the experience of flying from Europe to Australia. For those of you who haven't ever flown such a long distance: you can't imagine
how long it actually is. Even today's best airplanes are not able to fiy the whole distance from Europe to Australia, so they have to make a refuel
stop, The usual waypoints are Hong Kong and Bangkok., We made a stop at the second mentioned,

While the plane was being refueled and prepared for the second half of our fiight, we had to leave it and spend about one hour at the airport.
Impressive at least, It was many times the size of the Prague airport and watching the traffic there was just breathtaking, It seemed to me like one
of the world's biggest crossroads. Right here was where I realized the true sense of the well know phrase that the world is getting smaller and
smaller,

After then, we entered the plane again and began the rest of our fight. Even though I slept the most of the time, 1 fieel rather tired at the moment,
so 1 dedided to accomodate as soon as possible and start exploring the city tomorrow, after a proper portion of good sleep.

pr—

¥ ContentRating
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5. If you go to the live site now, you should see the Content rating web part on all articles in all group
pages sections. If you create a new group and create some article in its group pages section, the web

part will appear on it too.

Home Blogs News Media Fi ps Memb Examples

Groups * American travellers » Pages * My flight to Australia

#Edit 8 Delete
My flight to Australia

I recently had the experience of flying from Europe to Australia. For those of you who haven't ever flown such a long distance: you can't imagine how
long it actually is. Even today's best airplanes are not able to fly the whole distance from Europe to Australia, so they have to make a refuel stop. The
usual waypoints are Hong Kong and Bangkok. We made a stop at the second mentioned.

While the plane was being refueled and prepared for the second half of our flight, we had to leave it and spend about one hour at the airport.
Impressive at least, It was many times the size of the Prague airport and watching the traffic there was just breathtaking. It seemed to me like one of
the world's biggest crossroads. Right here was where I realized the true sense of the well know phrase that the world is getting smaller and smaller.

After then, we entered the plane again and began the rest of our flight. Even though I slept the most of the time, I feel rather tired at the moment, so
I decided to accomodate as soon as possible and start exploring the dty tomorrow, after a proper portion of good sleep.

Current rating: 4 (1 ratings)

Search

Shortcuts

My profie
Edit my profile

My messages

My friends

My invitations
Create a new group
Join the aroup
Manage the aroup
Invite to group

Create a new blog
Sign out

Group links

Home
Sge:!

My flioht to Australia
Media

i

Further steps: You have learned how to add the Content rating web part to the group pages. This way,
you can place any web part to the pages and achieve your required functionality. As you have seen,
modifications made to any of the group pages are automatically reflected on all other group pages
because of the shared page template. If you want to achieve different functionality on some of the group
pages, you will have to switch to the Properties -> Template tab and click Clone as ad-hoc template.
Changes made to a page with this cloned ad-hoc template will not be reflected on pages using the

original page template.
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2.4 Forums

2.4.1 Current functionality

The Forums section contains the typical discussion forums that can be found on most web sites on
today's Web, allowing site users to read and contribute to discussions on various topics. While forums
are one of the most common features on today's web sites, we won't go deep in describing how they can
be used, as we believe it should be familiar to you already. For detailed information on the Kentico CMS

Forums module, please refer to Kentico CMS Deweloper's Guide -> Module Forums.

If you enter the Forums section as a site visitor, you can see that the forums are divided into two main
sections - Community forums and Back-packer forums. These sections are called forum groups.
Forum groups contain forums (Announcements, Community FAQs, ...) and the forums contain
particular threads. There are two types of threads:

e Discussion forums - threads contain standard discussion on a given topic
e Question-Answer forum - threads are structured so that the first post is a question and the following
posts are trying to answer the given question

Home Blogs News Media F ps Memb Examples Search
Forums
Search forums:

Advanced search

Forum Threads Posts Last post

Community forums

This is a general forum for both registered and not registered site users,

Announcements
Find out the |atest news about our community here 2 2

Lock

C

=

Jenny
(10/25/2008 11:58:09 AM)

Community FA
Answers to Frequently Asked Questions about our community 1 1

Lock

Jenny
(10/25/2008 2:01:55 PM)

General discussion

\;E’_]E\ General discussion without rules and limitations 2 & (10;25;203;\;?10: 11PM)
Lock
Members discussion
=) Pogo
5] Discussion for community members anly 1 5 (11/5/2008 4:20:25 PM)
Lock
Forum Threads Posts Last post

Back-packer forums

This forum is intended for user groups, their members and topics related to the particular groups.

Announcements
Find out the latest news about groups here 1 1
Lodk

@

F
]

Jenny
(10/25/2008 5:51:40 PM)

FAQs
- Answers to Frequently Asked Questions about groups 1 1

All
.”}_'

Jenny
(10/25/2008 &:15:57 PM)
Lodk

General discussion

General discussion without rules and limitations 5 19

@

“
i

Jimba
(1/7/2009 3:13:50 PM)
Lock
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If you view the Forums page in CMS Desk's Design tab, you can see that each forum group is
displayed via one Forum group web part. You can place a forum group to any page of your web site
by placing the Forum group web part on the page and setting its Group name property.

Switch to Site Manager

site:| Community Site[»| User: Global Administrator v5.0.3656 Sign out

=
Display web part content @

Threads  Posts Last post

Kentico
CMS Desk Content | Mydesk Tools  Administration
: :x Hcopy  Tup @ = ):)
New Delete [shMove  § Down Edit  Preview Liveste Lst | Search |
Content management | View mode || other |
=1 ) Community Site Page | Design | Form  Properties
* [ Home AuvaRcuseATT
(@[] Blogs
-1 News
(i) [] Media Community forums
(- [1[Forums This is a general forum for both registered and not registered site users,
#- D Groups
&-B Group pages Announcements
51 Members Find out the latest news about our community here
® |1 Examples (=23
- Files Community FAI
) Special pages Answers to Frequently Asked Questions about our commurity

-] Logon page

o Lock
-] search =

General discussion

EI Lock

Members discussion
Discussion for commurity members only

Lock

v ForumGroupl {53 I

General discussion without rules and limitations

3 5 Jenny
(10/25/2008 11:53:09 AM)
1 s Jenny
(10/25/2008 2:01:55 PM)
3 s David
(10/25/2008 3:10: 11PM)
i s Pogo
(11/5/2008 4:20:25 PM)

m

Threads Posts Last post

—
Back-packer forums

This forum is intended for user groups, their members and topics related to the particular groups.

Announcements

Lock

FAQs

Lock

General discuscinn

Find out the latest news about groups here

Answers to Frequently Asked Questions about groups

Jenny
(10/25/2008 5:51:40 PM)

Jenny
(10/25/2008 6:15:57PM)
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Forums management can be performed in CMS Desk -> Tools -> Forums. On the page, you can see a
list of existing forum groups. By clicking the Edit (#) icon, you can enter the Forum group properties
section.

232 Kentico
#1% CMS Desk Content My desk Tools Administration

- Tools &l Forum groups
H =
--|@ Abuse report

[El BizForms &4 new forum group
W Blogs
: 2 Booking system
9@ Content staging Actions Group name
ﬁ Custom tables ¥ &  Community forums
_@ E-commerce # ® 1 & Backpackerforums
-~ File import
- &d[Forums
... &a Groups

lﬂ Media libraries
There are three tabs available in this section:

e Forums - a list of forums in the forum group; you can change the order in which the forums will be
displayed by clicking the Move up () and Move down (#) arrows; you can also Delete (¥)
particular forums or click the Edit (#) icon, which displays the forum's management section described
below

e General - on this tab, you can set some basic properties of this forum group; the properties can be
inherited by particular forums

e View - displays a preview of how the forum group appears on the live site

ﬂ Forum group properties @
Forum groups » Community forums

Forums | General  View

=]
ﬁ Add forum
Actions Forum name Status = Moderated | Threads @ Posts | Last post Last post by
8 & & Announcements Open No 2 2 10/25/2008 11:59:09 AW Jenny
f x i & Community FAQ Open Mo 1 1 10/25/2008 2:01:55 PM Jenny
# 8 & §  ceneral discussion Open No 2 8 10/25/2008 210:11PM David
8 & & Wembers discussion Open No 1 5 11/5/2008 4:20:25 PM Pogo
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The forum management section accessible by clicking the Edit (#”) icon offers the following tabs:

e Posts - tree-like view of threads in the forum, with the possibility of performing management tasks like
editing or deleting posts, replying to them, approving or rejecting, etc.
e General - general properties of the forum, which can be inherited from the forum group's general tab

mentioned above

e Subscriptions - management of subscriptions; users can subscribe to receiving notifications about

new posts

e Moderators - on this tab, you can set if the forum is moderated and assign site users with the rights

to moderate this forum

e Security - on this tab, you can set permissions for particular actions in the forum
e View - displays a preview of how the forum group appears on the live site

&2 Forum group properties

Forum groups » Community forums

Forums General View
Forums » Announcements
Posts General Subscriptions

=)~ Announcements
2 [Welcome to our forum

Forum rules

Moderators Security View

@ Forum post

[AEdit $§ Delete & Reply (@ stickthread (& Unlockthread () Reject () Rejectsub-tree (5 Move

Jenny(10/25/2008, 11:32 AM)
Welcome to our forum

Hithere,

welcome to the community forum. My name is Jane Oakley and | am one of the founders of this community site. In this
forum, you can find discussions on various travelling-related topics. You can discuss your recent or future destinations,
Valued ways of travelling, travelling equipment, just anything you would like to know something about or, on the other hand,
member share your opinion about with others.
e hope that this forum will become a source of valuable information for you and that it will be a place to that you will
always like to return. And one lastthing, please read the forum rules and do your best to follow them. It will just make this
forum a much better place for all of us

ﬁ Post attachments

© 2010 Kentico Software



Part 1 69

2.4.2 Modifying the forums structure

When developing your community site from the Community Starter site template, you will probably want
to modify the forums structure so that it matches the needs of your community. In the following
example, you will learn how to create a new forum group and replace the Back-packer forums with
it.

1. Go to CMS Desk -> Tools -> Forums and click the New forum group link at the top of the page.

.\=l- Kentico Switch to Site Manager
’.‘ CMS Desk Content My desk Tools Administration
=) Tools &l Forum groups

8] Abuse report

E BizForms &l New forum aroup

: Blogs
Pi} Booking system

SQ Content staging Actions Group name

~{il Custom tables R4 4 community forums
;m E-commerce ﬁ? X T & Back-packer forums
--[{g File import

- &d[Forums

& Groups

- Igal Media libraries
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. On the New forum group page, enter the following details:

Group display name - name of the forum group displayed on the live site and in the administration

interface

Group code name - name of the forum group used in web site code

Description - text describing the forum group, displayed abowve the list of forums in the group on the

live site

Forum group base URL - URL of the page where the Forum group web part displaying this forum
group resides; leave the Inherit from settings check-box checked
Forum group unsubscription URL - URL of the page where the Forum unsubscription web part
resides; leave the Inherit from settings check-box checked

Click OK.

212 Kentico

#g% CMS Desk

=)~ Tools

‘.|a Abuse report
[E] BizForms

- Blogs

?& Booking system
9& Content staging
-fiill custom tables
- PR E-commerce

.- [{g File import

- &4/Forums

&1 Groups

. Igal Media libraries
- Message boards
{ﬁ Newsletters
@ Polls

[E] Reporting

Content

My desk Tools Administration
& New forum group

Groups » Mew forum group

Group display name:
Group code name:

Description:

Forum group base URL:

Forum group unsubscription URL:

Web development forums

WebDevelopmentForums

This forum group contains
discussion related to web
dewvelopment, related
technologies, Jjob offers in this
field and many more.

e

Switch to Site Manager  Site: Community

[ Inherit from settings
[¥! Inherit from settings
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3. The Forum group properties page will be displayed. Let's make some additional settings which you
may find useful before we start defining the forums within this forum group. Switch to the General tab
and set the following properties:

e Forum type - User can choose; this option enables users to choose from classical or Question-
Answer type when creating a new thread

e User can edit own posts - enable this option so that users can edit their own posts

e User can delete own posts - enable this option so that users can delete their own posts

e Enable * in posts - enable all the check-boxes so that users can use all BBcode macros in their
posts; for more details on supported BBcode macros, please refer to Kentico CMS Developer's Guide

-> Module Forums -> BBcode support

Leave the rest of the properties at their default values and click OK.

-‘!’- Kentico Switch to Site Manager ~ Site:| Community Site [+ |
'.\ CMS Desk Content My desk Tools Administration
- Tools &l Forum group properties
Q Abuse report

El BizForms Forum groups » Web development forums
Blogs
D e . Forums General View
--[fd Booking system
Ba Content staging -
ﬁ Custom tables Forum group base URL: Inherit from settings
m E-commerce o
. Forum group unsubscription URL: [ Inherit from settings
-1 File import
- &d/Forums _ _
& Groups Require e-mail addresses: [}
|§| Media libraries Display e-mail addresses: =
Message boards Enable WYSIWYG editor: [}
fﬁ Newsletters Use security code (CAPTCHA): [
@ polls
; Fﬁ] Reporting @ WUser can choose
“fa) Web analytics Farum type: () Discussion farum

() Question-Answer forum

Minimum votes to mark post as answer: 5

——

Maximum image side size: 400
Attachment max. file size (kB): 0

User can edit own posts:
User can delete own posts:

Enable links in posts: No ) Simple dialog ) Advanced dialog

Enable images in posts: Mo ) Simple dialog ) Advanced dialog
Enable quotes in posts:

Enable code snippets in posts :
Enable bold font in posts:
Enable italics font in posts:
Enable underline font in posts:

Enable strike font in posts:

FEEEEEEE®®

Enable font colors in posts:
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4. Now we will define the forum group structure - the particular forums. Switch to the Forums tab and
click the Add forum link.

232 Kentico
#4% CMS Desk Content My desk | Tools Administration

- Tools & Forum group properties

5

/@] Abuse report

BizForms Forum groups » Web development forums
Blogs

: 'Fé Booking system
ia Content staging
ﬁ Custom tables
- T E-commerce

- (g File import

- &d[Forums

& Groups

...l Media libraries

Forums General View

No data found.

. Enter the following details:

Forum display name - name of the forum displayed on the live site and in the administration

interface
Forum code name - name of the forum used in web site code

Description - text describing the content of the forum, displayed in the list of forums in the group on

the live site
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You can set the rest of the properties to inherit the settings from the parent forum group and click OK to

sawve the forum.

232 Kentico

#1% CMS Desk

Content My desk Tools

=] Tools
|8 Abuse report

Forums General View

Pﬁ} Booking system
B& Content staging
£l Custom tables
m E-commerce

[ File import

84 Forums

& Groups

[yl Media libraries
Message boards
Newsletters

& polls

[&] Reporting

fall Web analytics

Eorums » Mew forum

Forum display name:

Forum code name:

Description:

Forum base URL:
Forum unsubscription URL:

Require e-mail addresses:

=

Display e-mail addresses:
Enable WYSIWYG editor:

Use security code (CAPTCHA):
Forum is open:

Forum is locked:

Forum is moderated:

Switch to Site Manager  Site:| Community Site El

Administration
&d Forum group properties

Forum groups » Web development forums

ASP _MET Discussion
ASP_MET_Discussion

Discussion related to this -
Microsoft technology.

Inherit from forum group
Inherit from forum group
Inherit from forum group
Inherit from forum group
Inherit from forum group
Inherit from forum group
O
O
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6. You are redirected to the forum editing section. If you switch to the Forums tab again, you should see
the newly created forum in the list. Repeat the procedure and define some other forums in this forum

group. When you are finished, you should see all the forums in the list on the Forums tab like in the
screenshot below.

& Forum group properties @
Forum groups » Web development forums

Forums General View

89} Add forum
Actions Forum name Status  Moderated Threads Posts Last post  Last post by
F BT & Webdevelopment jobs Open No 0 0
# 8 & & PHPDiscussion Open No 0 0
& ® T §  ASPNET Discussion Open No 0 0
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7. Now when the forum group is created and the forums in it defined, we can publish the forum group on
the live site. We will place it instead of the original Back-packer forums.

Go to CMS Desk -> Content -> Edit. Select the Forums document from the content tree and switch to
the Design tab. Scroll down the page and choose to Configure () the ForumGroup1 web part.

232 Kentico

Switch to Site Manager

‘l‘ CMS Desk Content My desk Tools Administration

[= [=) c u =% =

B [ B v | 3  [g B |l L |

New Delete |=»Move & Down | Edit  Preview Livesite  List | Search |
Content management | View mode | Other |

db_ﬁi Community Site
i~ [1] Home

a Blogs

a News

1] Media

a Forums

a Groups

] Group pages

] Members

[&)-| Examples

.ﬂ@ Files

&’Eﬂ Special pages

a Logon page

L[] search

DO ETOE

Page Design Form Properties

Lock

General discussion

General discussion without rules and limitations

Lock

Members discussion

Discussion for community members only

Back-packer forums

This forum is intended for user groups, their members and topics related to the particular g
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8. In the web part properties window, change the value of the Group name property to the name of the
new forum group created above, which is Web development forums in our case. Click OK.

& | CMS Desk - Web Part properties -- Webpage Dialog M
& Web part properties (Forum group) @) Documentation
General Layout
Default i

Visibiity Display to roles: 3 Add roles

Group settings

Post options .
Group settings
Post extended options.

m

Behaviour Forum layout: » |Flat |Z|

Abuse report

Paging Group name: » | Back-packer forums
Back-packer forums
Community forums

Web development forums

Friendly URLs

Tree forum properties )
Post options

HTML Envelope
AJAX Enable favorites: »
Time zones
Partial caching Enable signature: 2
Display attachment image: y O
Attachment image maximal side v 1100
size:
Redirect to user profile: 3
VIRefresn content [ ok [ Cancel [ Apiy |

http://localhost/KenticoCM5_0217/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii el'. Local intranet | Protected Mode: Off
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9. If you switch to the live site now, you should see that the Back-packer forums have been replaced
by the Web development forums defined earlier in this example. The forum group is fully functional

and the discussion may begin.

Home Blogs News Media F ps Memb Examples

Forums

username Log on Search forums:

Forum Threads

| | Search

Advanced search

Last post

Community forums
This is a general forum for both registered and not registered site users,

Announcements

= 2
. Find out the latest news about our community here
=) | Community FA 1
M=
. Answers to Frequently Asked Questions about our community
=) | General discussion 5
M=
) General discussion without rules and imitations
=) | Members discussion :
M=
. Discussion for community members only
Forum Threads

Jenny
(10/25/2008 11:59:09 AM)
Jenny
(10/25/2008 2:01:55 PM)
David
(10/25/2008 3:10:11 PM)
Pogo
(11/5/2008 4:20:25 PM)

Last post

Web development forums
This forum group contains discussion related to web development, related technologies, job offers in this field and many more.

Web development jobs 0
PHP Discussion 0

=) ASP.NET Discussion
Discussion related to this Microsoft technology.

(1/1/0001 12:00:00 AM)

(1/1/0001 12:00:00 AM)

(1/1/0001 12:00:00 AM)

Further steps: You hawe learnt how to define a new forum group and publish it on the live site. Like this,
you can define another forum group and publish it instead of the Community forums forum group. In case
that you wanted to have more than two forum groups published, you only need to place another Forum
group web part on the page and define its Group name property. You may also want to have only one
forum group published, in which case you only need to remove one of the Forum Group web parts.
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2.5 Blogs

2.5.1 Current functionality

The Blogs module is a ready-made' solution and you will probably not need to make any customization
tasks to it. However, we will at least describe its functionality from the site user's perspective in brief.
Detailed information on the Blogs module can be found in Kentico CMS Developer's Guide -> Module

Blogs.

1. Go to the live site and sign in as David with blank password. Click Blogs in the main menu.

On the Blogs section's title page, you can see recent blog posts from all blogs on the site.You can
browse the posts by topic - by clicking a keyword in the Tag cloud, a list of blog posts tagged with the
keyword will be displayed. You can also browse the posts by particular blogs. The Recent blogs box
displays links to the most recently created blogs and a link to the list of all blogs. After clicking a blog
link, both in this box or in the list of blogs, you will be redirected to its title page.

Home Blogs News Media F ps Memb Examples | | | Search
Recent blog posts
Sign in
-
| The long long flight
U
Finally, after some 23 hours of flight, I am on the other side of the world than I was yesterday around this time. Log on
1 feel terribly tired after the long flight, but before I go to sleep, I found some time to write about the first
impressions of my journey.
Shortcuts
Join the community
Posted to Holiday in Australia by Kelly Taylor on 10/26/2008 3:05:12 PM | with O comments
Recent blogs
- L
| Flying tomorrow Abi's european trip
U
Holiday in Australia
Hi everybody, my name is Kelly Taylor and I come from Brno, Czech Republic. Tomorrow is my big day. Finally, View all blogs

after six months of hard everyday work, I decided to have some nice time and go on holiday. Australia has

always been one of the places I had wanted to visit one day, and now, with my great new job and the wage 1
et for it, it is finally affordable for me to get there.

9 B v ¢ Latest blog comments

There are currently no

comments.

Posted to Holiday in Australia by Kelly Taylor on 10/256/2008 2:19:18 PM | with 0 comments
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2. Click some blog in the Recent blogs box to display its title page. The blog's title page is similar to
the Blogs section's title page, but displays only posts from the current blog. In addition to the Tag cloud,

you can browse posts in the current blog by months too. By clicking a month link in the Post archive
box, you can display only posts from the clicked month.

Home

Blogs

News Media Forums Groups Kembers Examples

Abi's european trip

| .
Saying goodbye Europe
w

Paris, our final destination. Because there’s no upcoming hitchhiking trip, the tension between P1 and me is all
gone. I have a friend here, so the last night we spend in his place, drinking wine and using his computer to look
at pictures we've taken during our month in Europe.

L

Today, PJ went to do some and we've pr d each other go out have dinner tonight.

Posted to Abi's european trip by Abigail Woodwarth on 7/5/2008 1:56:04 PM | with 0 comments

T "
Wir sind Berliners
w

Berlin, after a long time the city we both wanted to see. And as we're almost done with our trip, we're getting
much more relaxed in comparison with just week ago. We are almost able to joke with each other again. We
dont have much money left, though, so we’re mostly h ing around, considering every Euro, spent for the
gallery ticket.

Posted to Abi's european trip by Abigail Woodwarth on 7/3/2005 1:54:27 PM | with 0 comments

' Disapointment in Prague
w

I'm supposed to pick up PJin Bratislava. Again, I dont have to hitchhike so I'm taking a bus. Oddly enough, P1’s
rather glad to see me. The trip to Prague is one smooth ride. But the city center is jammed with people again.
Why all tourists share the need of visiting same places at the same time?

Search

Shortcuts

My profile
Edit iy profile:

My messages
My Friends
My invitations

Create a new group
Create a new blog
Sign aut

Tag cloud

sirport Austria bus cuisine
Czech Republic France Germany

hitchhiking hostel
ek U eErn ey [
Slovenia SPAIN subway tag tags
tourism traffic train

Latest blog comments

There are currently no
comments.

Post archive

July 2008(3)
June 2003073
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3. Click some blog post to display it. Below the text, you can find the Content rating web part, social
bookmarking links, trackbacking URL and the comments section where you can post comments on the
blog post.

Home Blogs News Media F up Memb Examples | | | Search
- .
Abi's european trip > July 2008
Shortcuts
fm x_Delete My profile
Edit my profile
J Wir sind Berliners My messages
My friends
My invitations
Berlin, after a long time the city we both wanted to see. And as we're almost done with our trip, we're Create a new group
getting much more relaxed in comparison with just week ago. We are almost able to joke with each other Create a new blog
again. We don't have much money left, though, so we're mostly b il d, idering N
every Euro, spent for the gallery ticket. Sign out
Latest blog comments
There are currently no
Because that Euro might have been the next breakfast. comments.
Tomorraw morning, we're setting of for our last hitchhiking trip. So far, I didn't tell you how we manage to hitchiking with all the luggage we have,
though. The few of you were curious about it. Well, let's put some light on the subject. First of all, we have barely any luggage at all. Oddly as it may
seem, together with PJ, we have succeeded in fitting everything into two badkpacks. To be honest with you, one really doesn't need to have much Post archive
stuff. A camera, two pair of shoes and some dothes but not much. We take advantage of the public laundries that are usually conveniently located
near hostels a lot. We have our sleeping bags in case of emergency as well. Everything else is just junk that you can do without. July 2008(3)
June 2008(7)

When we're waiting for the ride, we always form our backpacks into a sophisticated pile that looks much smaller than itis, in reality. And I don't recall
waiting for more than an hour for a ride, beside those troubles in Pyrenees. Everyone who has ever tried hitchhiking must admit that it is more than
impressive,

Posted by Abigail Woodwarth on 7/3/2008 1:54:27 PM
Filed under: Germany, lugaaage, hitchhiking

Current rating: 0 (0 ratings)
'y | =) L2 L L] ir ]
Bookmark this page to:o ki ¢ l.-" QJE; g\"ﬂ B R4 ,osﬁ JEE@I L™ l] [} ﬂ - @w%‘:@ﬂ+
Trackback URL: http:/flocalhost/KenticoCMS_0217 ftrackbadk/bcé0d 227-73b6-4d21-b 388-35ccaded 1ade/Wir-sind-Berliners. aspx
v Comments
Blog post currently doesn't have any comments.

Leave comment Subscribe

Name:

Admin
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4. When we have seen what the Blogs section on the site looks like, we can try creating our new blog.
This can be done anywhere on the live site by clicking the Create a new blog link in the Shortcuts
menu.

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create & new group
Create a new blog
i0n U

5. On the Create new blog page, you only need to enter the name and description of your new blog

and click OK.

Home Blogs News Media F ps Memb Examples Search

Create new blog
Shortcuts

‘fou can create your new blog by entering the required details into the fields below. You will be able to change the entered data later. After submitting My profie

these details, you will be able to edit your blog's properties or start blogging immediately. Edit my profile
My messages
My friends
My invitations
Lreate a new group

Blog name: My first blog Create a new grou
Sign out

This is my first attempt to create a blog. o

Recent blogs

Blog description:

Abi's european trip
Holiday in Australia

View all blogs

6. The blog is now created and you are redirected to the blog's title page, where you can Edit blog (#)

properties or write a New blog post.

Home Blogs News Media F ps Memb Examples Search
My first blog
Shortcuts
4 Edit blog My profile
Edit my profile
MNew blog post My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

7. From now on, the blog is fully functional. You can find a link to the blog in the Recent blogs box on

the Blogs title page, in the list of all blogs and on your public profile page.

2.6 Media libraries

2.6.1 Current functionality

The media libraries allow convenient storage of large amounts of files. Not only media files, but also
files of any other types can be stored within the libraries, while even large file sizes (several GB) are
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supported. Media libraries can be either global or related to a particular group. For detailed information
on the module, please refer to Kentico CMS Deeloper's Guide -> Module Media libraries.

1. If you go to the live site, you can enter the site's global media libraries section by clicking the Media
link in the main menu. This section displays the content of the only global media library on the site,
which is named Media. You can see the library's folder structure tree on the left. By clicking a folder,
files stored within the folder will be displayed in the main area.

Home Blogs News Media F

Examples

Media gallery

Sort by: Name Date Size

(= Media
{S‘ Documents
{S‘ Music
{S‘ Pictures
75 Video

WIN XP startup so...
Size: 415 kB

Uploaded: 2/18/2010

l€< 1 2 =z|Results1-80f 16

WIN XP startup so...
Size: 26 kB

Uploaded: 2/18/2010

Nature
Size: 42 kB

Uploaded: 2/18/2010

M5 Word document
Sizt kB

| | Search

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out
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2. If you click a file's thumbnail, the file will be displayed in the main area. Depending on the type of file,
the display may vary. Images will be displayed in large size, videos or sound files display a player where
the files can be played. Documents are displayed only in form of the document type icons. Additional
information about the file is displayed in the bottom left corner. All files can be downloaded using the
Download link at the bottom right corner.

Home  Blogs News  Media  F up Memb . Examples | | | Search
Media gallery
Shortcuts

5 Media << Back My profie

’Ej‘ Documents Edit my profile

. My messages

"S‘ Music My friends

@ Pictures My invitations

75 Video Create a new group

Create a new blog
Sign out

1
< Download

Buildings

Size: 31kB

Description: Sample picture description.
Uploaded: 2/13/2010

Type: PG
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3. As we mentioned abowve, groups can also have their own media libraries. This is the case of the
Czech Republic fans group on this sample site. If you go to Groups -> Czech Republic fans and
click the Media link in the Group links box, media libraries of the group will be displayed.

Home Blogs News Media F ps Memb Examples | | | Search

Groups P Czech Republic fans » Media

Shortcuts
My profie
Czech nature Edit my profile

My messages

My friends

My invitations
Create a new group
Join the group
Manage the aroup
Invite to group

Create a new blog
Czech cities Sign out

Czech cities are amazing.

Bellow you can find list of group media libraries.

Czech nature is really nice.

. e — S

Group links

Home
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2.6.2 Creating custom media libraries

In the following example, you will learn how to create a new global media library and publish it on the
site.

1. Go to CMS Desk -> Tools -> Media libraries and click the New media library link at the top of the

page.
22 Kentico Suitch to Site Manager
’.‘ CMS Desk Content My desk Toolz Administration
& Tools W Media libraries
H —
@] Abuse report

: BizForms
: Blogs

Pﬁ Booking system
...y Content staging Actions = Name Folder = Description

ew media library

ﬁ Custom tables f x Media  Media Here you can find different kinds of media files.
PR E-commerce

- [ File import

-84 Forums

& Groups

- Iga|Media libraries

Message boards

2. Enter the following details into the form:

Display name - name of the library displayed on the live site and in the administration interface
Code name - name of the library used in web site code

Description - text describing the media library, displayed in the list of media libraries on the live site
Teaser image - upload some image which will be used as a teaser in the list of media libraries
Folder name - name of the physical folder in the file system which will contain the library files; it is
located under <web project>/<site name>/media/

Click OK.
232 Kentico —
#1% CMS Desk Content My desk Tools Administration

- Tools @ New media library

‘..|@| Abuse report
Media libraries » Mew media library

Pﬂl Booking system
Ba Content staging
“fi}l Custom tables
- TR E-commerce
--[[q File import

‘.. 88 Forums Description:

- Groups

- IgalMedia libraries -
..-[] Message boards ) )

: Teaserimage: | Upload: C:\Users\petrpe\Desktoplc
Eﬁ MNewsletters

-8 Polls Folder name: |my first_library

8] Reporting o]

“..fall web analytics

Display name: My first media library
Code name:  |MyFirstMediaLibrary

Thi= i= my first media library. -
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3. You will be redirected to the media library management interface, which is also accessible by clicking
the Edit (#") icon in CMS Desk -> Tools -> Media libraries.

First, we will define the folder structure. Select the root of the tree and click the New folder (L) icon.
Enter the name of the new folder and click OK. Repeat the procedure so that you have at least two
different folders in the library.

Please note: due to ASP.NET architecture, site restart occurs whenever a folder is moved, renamed or
deleted. To prevent this, it is a good practice to define the library structure when creating it and not to
modify it when the site is already running.

-‘!’- Kenti.co Switch to Site Manager  Site: | Commt
#4% CMS Desk Content My desk Tools Administration
=)~ Tools Media library properties
i Abuse report
BizFarms Media libraries » My first media library

Blogs

F& P e s Files General Security
¥y Content stagin = !
g %c o blg g g Newrolder | [ Newdie =] uist Tiles [22] Thumbnails
ustom tables B
...J'R E-commerce
i Delete Copy Move . :
[ File import = & 9 Mame: i
& Forums . my_first_library (0) ¢
: & Groups £ | New folder -- Webpage Dialog M
|§| Media libraries \J__i New folder
[ Message boards
-5 Newsletters
Folder name: |photos_from_usa
Eﬂ Reporting
“fal) web analytics

{ ok |

htt €& Local intranet | Protected Mode: Off

4. Now we can upload the files. Select one of the folders and click the New file ([4) icon at the top right
corner.

The Choose file dialog appears, letting you choose a file from your local disk. Select some image and
click Open. Repeat the procedure so that you have several files in both folders.
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~e= Kentico
#§% CMS Desk
=~ Tools
|@] Abuse report

BizForms
- Blogs
----- m Booking system
BQ Content staging
--fiJl custom tables
- E-commerce
I File import
- &4 Forums
& Groups
. lgd Media libraries
- Message boards
s Newsletters
@ Polls
[&] reporting
--fafl Web analytics

Content

My desk Tools Administration
Media library properties

Media libraries » My first media library

Files General Security
L_ﬂ Mew folder
3¢ Delete o Copy 5§ Move

=) my_first_library (0)
.75 photos_from_europe (0)
5 photos_from_usa (0)

Switch to Site Manager

Site:| Community Site[«] User: Global Administrator v5

@ Choose File to Upload

==

Qu 7| .. » community » pictures ¥ europe

+ [ #4 | Search europe ol
L&

Organize « New folder

[ Favorites T
Bl Desktop
& Downloads

=1 Recent Places

madrid

4 Libraries
@ Documents
J1 Music
[E=] Pictures

B Videos

[

18 Computer
&, Local Disk (C3)
l. licons
. 50 builds

File name:

budapest

=~ 0 @

prague

~ [AllFiles ) -

[ oeer I |

Cancel ]
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5. Our media library is now finished and we can publish it. Switch to CMS Desk -> Content -> Edit ->
Design tab and choose the Media page from the content tree. Choose to Configure (‘&) the
MediaGallery web part.

.‘!’. Kentico Switch to Site Manager

‘.\ €MS Desk Content My desk Tools Administration

_’. _x’ [} Copy T up | E | fO |

New Delete |=Move & Down | Edit Preview Live site List | Search |

Content management | View mode | Other |
B';‘_'ﬁ Community Site Page Design Form Properties

[ Home
-] Blogs
@ News . 3 = =
- [0Media Home  Blogs News Media Forums  Groups  Men
(-] Forums .
A |v JMedia - page template: Community Site - Media
-] Groups
ma Group pages L sELE
@D Members ¥ HeaderText @

(i) | Examples

i [ e G| sertism e is

(+-5) Special pages

— P =ty ts
:-[] Logon page ey PocmEn
8 = 75 Music
‘| Search :

o7 Pictures
15 Videa

6. In the web part properties window, select your new media library in the Media library drop-down list

and click OK.
Content

Media library: v [Media [~]
(current media library)
Media

Path: LI Iy first media library

Show subfolders content: 3

Display file count: y O
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7. If you switch to the live site now, you should see that the original media library has been replaced by
your new media library.

Home  Blogs HNews  Media  F | ups  Memb - Examples | ||Search

Media gallery

Shortcuts
Sort by: [ame Date Size My profie
Edit my profile
My messages
My friends
My invitations
Create a new group
Create a new bl
Sign out

(=) my_first_library
’{j‘ photos_from_europe
{S‘ photos_from_usa

arizona3 arizonad
Size: 791 kB Siz kB

Uploaded: 2182010

Further steps: You hawe created a new media library, defined its structure, uploaded some files and
published it on the live site instead of the original sample media library. As obvious, you can publish only
one global media library this way. This might be fine for many sites, but if you want to have more global
media libraries published on the site, go to the next chapter where you can find more information on how
to achieve this functionality.
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2.6.3

Publishing more than one global media library

In the following example, you will learn how to publish more than one global media library on the site.
We will try to achieve a functionality similar to group media libraries (see Groups -> Czech Republic
fans and click Media in the Group links box). As you can see, we have two pages where a list of
available libraries is on the first page. Links in the list lead to the second page where the content of the
clicked library is displayed dynamically.

1. Go to CMS Desk -> Content -> Edit and select the Media page from the content tree. Click the New
icon above the content tree to create a new page under the Media page.

=32 Kentico

“1%  CMS Desk Content My de:
;“ [ Copy i up

New |Delete |2 Move W Down

Content management

cl\-_ﬁl Community Site
[ Home

.ﬂ,_| Blogs

Iﬂ"

A

|1||_| Groups
.ﬂ,_| Group pages
|1||_| Members
.ﬂ,_| Examples

[-3] Files

.ﬂfj‘ Special pages
I_| Logon page
i..[]] search
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2. Choose the Page (menu item) document type. For Page name, enter Media gallery and choose
the Community site -> Community site - Media page template. Click Save.

Page name: Media gallery

@ Use pagetemplate () Inheritfrom parentpage () Create a blank page

=) All page templates Template name:

Articles LUnnnunniLy e LUNIIUILy e ULy e LUNIIULy e
Blank pages for widgets Group registration Group template Groups Home page
Blogs

Community Site
Corporate Site ASPX

Logon  Rugevanon
E-commerce =] E
Events =
FAQS
Forums
Genaral Community Site - Community Site - Community Site - List Community Site -

Home Page Invitation of blogs Logon page

Home pages Authenticated Acceptation
Images

Job openings

Knowledge base
Master templates %
Membership and security

Message boards

News Community Site - Community Site - Community Site -
Newsletter Master Page Media Member profile
Offices

Personal Site

Press releases 12 3

Products . . -

Templates with editable regig Communlty Site - Media

Wiki

1 | 3

m
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3. Now we have two pages showing the same content because they use the same page template. But
the required functionality is the following: the Media page should display a list of global media
libraries; after clicking a library, users should be redirected to the Media gallery page, which shall
display the content of the clicked library.

First, select the Media gallery page and switch to the Properties -> Template tab. Select the Select

inherited levels radio-button and choose to inherit from Root only. Click Save.

23 Kentico

#g% CMS Desk Content | My desk
D] Copy T up

Q Down

Content management

New Delete = Move

Switch to Site Manager

= t-_’l Community Site
-] Home
(&1 Blogs
.ﬂ_] MNews
-] Media
: L[ ]Media gallery
(%] Farums
¢[J Groups
.ﬂ_] Group pages
.ﬂ_] Members
(4]-] Examples
-G Files
.ﬂ’\’;—j‘ Special pages
-] Logon page
‘.. Search

Tools Administration
[d] L
Edit Preview Live site List | Search |
View mode | Other
Page Design Form Properties
General
Save
URLs E
Template
Metadata Template
Categories Community Site - Media
Menu _
(=]
= plate...
woril = Save as new template
Versions gf‘ Inherit template
Related docs .
w+ Clone template as ad-hoc
Linked docs =/
Security [f Evittemolate proverties
Attachments

Inherit content
) Use page template settings
(= Do notinherit any content

@ Selectinherited levels

- ¥ Root

[ Media

Site: | Community SItEEl User: Glob

Select

4. Switch to the URLSs tab and enter /Media/{LibraryName} into the Document URL path filed. This
wildcard URL will ensure dynamic loading of the media library into the media gallery web part (configured
to behawe like this in step 5). Click Save.

© 2010 Kentico Software



Part 1 93

Switch to Site Manager  Site: | Communit
=32 Kentico ¥
’.‘ CMS Desk Content My desk Tools Administration

2 2y c u
] [x Be ®w | G [q =2 | R
New Delete |= Move & Down Edit Preview Live site List Search
Content management | iew mode | Other
'i"‘;_;] Community Site Page Design Form Properties
'_I ;lome General |
ik 0gs Save
l_‘ I_I URLs E
)= News
|:l|_| Media Template
i..[) Media gallery Metadata The changes were saved.
|1|,_| Forums Categories path
|1l._| Groups Menu Document alias: Media-gallery
(-8 Group pages Workfiow [ Document URL path: |/\edia/{LibraryName} I
- Members Ve T Use custom URL path
[+]-|| Examples
R — Related docs
L Extended properti
oS : Linked docs ended properties
';‘ u_; Srzeslrare [ URL extensions:
-] Logon page Security & -
...[J) search P Use custom URL extensions
Track campaign:
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5. For the Media gallery web part to load the library dynamically, we also need to tune its Media
library property. Switch to the Design tab and choose to Configure (‘) the Media gallery web part.
Set the value of the Media library property to (current media library) and click OK.

& | CMS Desk - Web Part properties -- Webpage Dialog

==

General Layout
Default

Visibility

Content

Upload settings

Content
transformations

Filter settings
Content filter
Pager

Pager design

Mo data behavior
HTML Envelope
AJAX

Time zones

Partial caching

Refresh content

& Web part properties (Media gallery)

Content

y
@ Documentation

Media library:

Path:

(current media library)

(current media library)
Media

My first media library

m

Show subfolders content:

Display file count:

Display active content:

Preview suffix:

lcon setname:

Hide folder tree:

Use secure links:

Linlaad eattinme

|

b

[ Ok | Cancel | _Apply |

http://localhost/KenticoCM5_0217/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii el'. Local intranet | Protected Mode: Off
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6. Select the Media page and on the Properties -> Template tab, click the Clone as ad-hoc
template link. Click Save.

Switch to Site Manager  Site:| Community Site User: Glo
32 Kentico v site[z]
"‘ CMS Desk Content My desk Tools Administration
) ) Co U
% Dcoer  Wue [4 [d = r
New Delete = Move & pown Edit Preview Live site List Search
Content management View mode Other
a2 Community Site Page Design Form Properties
‘—‘ Hlome General
+-|| Blogs Save
. l_l URLs E
-] News
=1 |Media jremplate
-[] Media gallery Metadata Template
(=)~ Forums Categories Community Site - Media ﬁ
[)-|| Groups Menu
(=
= ] Group pages - Save as new template
[#)-l-] Members 3 =
™ Versions /' Inherit template
[=-|.| Examples i
S Fil Related docs N
(- Files ] =/ Clone template as ad-hoc
d{;‘ Special pages Linked docs =
[ Logon page Security E Edit template properties
-.[] Search Attachments
) Inherit content
ﬂ @ Use page template settings
@ Do notinherit any content
) Selectinherited levels

7. Switch to the Design tab and choose to Remove the MediaGallery web patrt.

|'."Mellia—pagehemplabe:ad—hnc ﬂ|

¥ zoneCenter * = zoneRight +

¥ HeaderText ;g‘,s = logonminiform 31:31‘3
ﬂ -
v MediaGallery ’,g‘,! Sl l::n'l]:uts"gz‘g

2@‘,“; Configure My profile
Edit my profie

Tu... My messanes
' My friends
& Down ... My invitations
Move to zone ... Create a new group

X Create a new blog
#p Duplicate web part -
Sign out

(o)
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8. Add (#) the Media Library -> Media libraries viewer web part to the zoneCenter web part zone,
to the place of the removed MediaGallery web part. In the web part properties window, choose to Edit
the Transformation Name property.

& | CMS Desk - Web Part properties -- Webpage Dialog | 22 |
Q Web part properties (Media libraries viewer) @) Documentation
General
Default Display to roles: 4 Add roles a
Visibility
Repeater
No data behaviour Repeater F
= Transformation Name: » |Community. Transformations_Media Select E
Pager
Pager design Alternatingltem Transformation > _ Edit 8
Mame: o
System setlings
HTML Envelope Separator Transfarmation » ﬁ
Name: —
AJAX
Time zones Header Transformation Mame: 3 ﬁ
Partial caching
Footer Transformation Name: 3 ﬁ
No data behaviour
Hide if no record found: 3
Mo record found text: + Mo data found
Refresh content [ ok | Cancel | Appy |
http://localhost/KenticoCM5_0217/CMSModules/PortalEngine/UL'Web parts/WebPartPropertii ?n'.. Local intranet | Protected Mode: Off
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9. In the pop-up window, replace the original transformation code with the following code. The
transformation below is the original transformation with the highlighted code added.

This code ensures that library teasers and names will work as links leading to the /Media/{LibraryName}
URL, where {LibraryName} will be replaced with the name of the clicked library. This is the URL we have
set in step 4 for the Media gallery page. Because the Media library property of the Media gallery
web part on the page is set to (current media library), it will display content of the media library from
the URL.

Click Save.

<di v cl ass="Medi aLi stltent>
<t abl e>

<tr>

<td cl ass="Medi aLi braryLi st Phot 0" >

<a href="~/ Medi a/ <%t Eval ("Li braryNane") %.aspx">
<04t | f Enpty(Eval ("Li braryTeaserPath"), "<ing border='0" src=\"~/ App_Thenes/
Communi tySi t e/ | mages/ Def aul t Medi aTeaser. gi f\" alt=\"\" />", "<inmg src=\"" +
Ur | Hel per . Get Absol ut elUr | Wt hPort (Val i dat i onHel per. Get Stri ng(Eval
("LibraryTeaserPath"), "")) + "?w dth=180\" alt=\""+ Eval ("nane") +"\"
border='0" />") %

</ a>

</td>

<td cl ass="Medi aLi braryLi st Descri pti on">
<a href="~/ Medi a/ <%t Eval ("Li braryNane") %.aspx">

<b>
<%t Li m t Lengt h( ResHel per. Local i zeStri ng(Convert. ToStri ng(Eval
("Li braryDi spl ayNane", true))), 20, "...") %

</ b>

</ a>

<di v cl ass="Medi aLi brarylLi st Descri pti onText">
<%t Li m tLengt h( ResHel per. Local i zeStri ng(Convert. ToStri ng(Eval
("Li braryDescription", true))), 40, "...") %

</ di v>

</td>

</[tr>
</tabl e>

<di v cl ass="Medi aLi st|tenBottoni></di v>
</ di v>
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10. If you go to the live site now and click the Media link in the main menu, you should see the
functionality described in the beginning of this chapter. A list of all global media libraries on the site will
be displayed. After clicking a library in the list, its content will be displayed.

Current user: Global Administrator (administrator) | My home page | Edit my profile | Inbox | Sign out

Community

Starter site

Home  Blogs HNews Media F up Memb | Examples | || searcn

Media gallery

Shortcuts

My profie
Edit my profile

My messages
Media My friends
’ Here you can find different kinds of ... My invitations

Create a new group
Create a new blog
Sign out

My first media [i...
& This is my first media library.
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2.7 Design and styles
2.7.1 Changing the header image

Changing the header image is a procedure of a few clicks. You only need an image of the same width as
the original image, which is 960 pixels. For the purpose of this example, you may use the
community_header02.gif. The file can be found in the attached files package that can be found at

http://www.kentico.com/Downloads/Community Guide/CommunitySiteGuide_files.zip. Once you have the

image prepared, follow these steps:

1. Go to CMS Desk, select the Files folder from the content tree and click New. Choose the File

document type.

232 Kentico

Switch to Site Manager

’.‘ €MS Desk Content My desk Tools Administration

= = Co U

|G Ber te | 3 @ @ H | L
New [Delete = Move & Down Edit Preview Live site List Search

. Content management | View mode Other
cl\-_il Community Site » Files

il Home N

i C New document

(-] Blogs =

-1 News

._] Mediz Please select new document type:

‘1"—] JEITIE [[] Page (menu item)

[+ | Groups

i Folder

% button_signin

= community_header_img
= CommunityHomeImage
= group_australia

= paris2

f

e plane

£] Link an existing document

2. Click the Upload file (_#) link and browse for your file on your local drive. Enter some text describing

the image if you like and click Save.
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Switch to Site Manager  Site: | Commur
=32 Kentico
#8% CMS Desk Content My desk Tools Administration
2 2 i U
] [ Boe ®w | 3 [g =2 | R
New Delete | = Move & Down Edit Preview Live site List Search
Content management Wiew mode Other
d-é_"l Community Site ¥ Files
.[ ] Home

E Save E‘ Save and create another @ Spell check

,_| Media
._I Forums Upload file: Upload file

] Group pages image.
.| Members File description:
] Examples

SRORCHONO

(55 Files
¢ .[5F button_joinnow

| button_signin
community_header_img
CommunityHomelmage
group_australia

paris2

plane

|

I_| Groups Thi=s i= an alternative to the Commuanity Site header -
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3. The image is now uploaded, so let's use it on the master page. Select the root of the content tree in
Page tab and click the Select... button at the top left corner of the header image.

232 Kentico Switch to Site Manager

'.\ €MS Desk Content My desk Tools Administration
[=) [=) C u ~ = =)
B R Qe de. G Q B B | L
New Delete |=bMove & pown | Edit  Preview Livesite  List | Search |
Content management | . View mode | _ Other |
— % = -
I;l'bu;i Community Site Page Design Form Master page Properties
[ Home
-] Blogs E Save Spell check
@2 News .
D Madia Sign in to CMS Desk. Sign in to CMS Site Max e T
[&-|] Forums
@D Groups Current

@D Members

-

5[] Examples Com m u n Ity
5 Files Starter site
: {88 button_joinnow

{84 button_signin

-J=] community_header_img

{88 community_header02

1;| CommunityHomelmage

--{= group_australia
- paris2 I
~J= plane
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4. In the pop-up dialog which opens, select your previously uploaded image from the content tree and
click Select.

{2 Insert - Webpage Dialog [
@ Selectimage

Attachments | Content | Medialibraries  Web

=
[\a New folder (l New file E List Tiles @ Thumbnails @
Site: | Community Site E General
s URL:  |/KenticoCMS_0217/Files/community_header02.aspx 1)
= 7 Community Site
[ Home Width: |960 rﬂﬂ
@ || Blogs Height | 148
[+l News
@] Media
[+ Forums
@ || Groups ; ¢ ; ) A il 1
[)-1] Group pages B i L ] gl agBmpwm wallio:
@ || Members
(#)-| Examples
%3 Files

% button_joinnow
& button_signin

group_australia
1= paris2
plane
(1) 3] Special pages
|| Logon page
-] Search

http://localhost/KenticoCMS_0217/CMSFormCantrols/Selectors/InsertlmageOrhedia/Default.aspx?output=url&amp;content=img&amp;documentid=40 €& Local intranet | Protected Mode: Off
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5. Finally, click Save to save the changes made to the master page.

-\2’- Kenti.co Switch to Site Manager
#4% CMS Desk Content | Mydesk  Tools  Administration
% '_] Copy i up [ @ = )3
New Delete |=»Move & Down Edit Preview Live site List Search
Content management Wiew mode Other
';l";_,'-‘ Community Site Page Design Form Master page Properties
[ Home _
@-[) Blogs 5 Spell check
& News
__| Madiz Sign in to CMS Desk. Sign in to CMS Site Manager. 1
_|_, Forums
.g_| Groups Current
_|_, Group pages xml
[#-.| Members
_|_, Examples
(55 Files

% button_joinnow

% button_signin

= | community_header_img
% community_header02
--{=| CommunityHomelmage

6. If you switch to the live site now, you should see the new header image in its full beauty.

Current user: Global Administrator (administrator) | My home page | Edit my profile | Inbox | Sign out

Home Blogs News Media Fi Groups Memb Exampl Search

Shortcuts

My profie
Edit my profile

Welcome to our community

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new
people and all the things related to it.

fwou are interasted in this sort of thines. don't hesitate and

Further steps: You hawe learned how to change the header image on the master page. As you will
probably not be satisfied with this level of customization, you can try modifying the site's CSS
stylesheet. Like that, you will be able to fully customize the site's design according to your needs. In the
next chapter, you can find a simple example showing how the site's CSS stylesheet can be modified.
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2.7.2

Modifying the stylesheet
In this example, you will learn how to edit the site's CSS stylesheet. We will follow the previous example

and modify the main menu so that it matches the new header image. Any other modifications of your
choice can be done to the stylesheet the same way as described below.

1. Go to Site Manager -> Development -> CSS Stylesheets and choose to Edit (#") the Community
Site stylesheet.

Y2 Kentico

’.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
=)~ Development (; CSS stylesheets
-5 Categories
@ Countries gj. MNew CSS stylesheet
G C55S stylesheets
@ cultures
...ffi}l custom tables Actions Display name » Code name
[l Document types [  community Site CommunitySite
[3) E-mail templates # W3 corporate Site CorporateSite
... Form controls _
= Inline controls # 3 Corporate Site - Gray and Blue  CorporateSiteGrayBlue
LJ} Modules / x I:'j Corporate site printer styles CorporateSitePrinter

;.| Notifications
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2. The CSS stylesheet is divided into sections so that you can easily find the appropriate classes. The
sections can be quickly accessed by selecting from the listbox on the right. Choose the Top menu
section. Within this section, you can find all classes defining the appearance of the main menu.

Q’ CS88 stylesheet properties
CSS stylesheets » Community Site

General Sites

I sae @ Check out

Check out the stylesheetto file c:inetp ootiKenti MS_0217\CMSCSS Stylesheet ity Site.css to edit the stylesheet externally.

Stylesheet display name: |Community Site

Stylesheet code name: | CommunitySite

/*$Main styles/Top menuf*/ - | |Group management pL
. zoneTopMenu Group pages o
: = User contributions
width: 960px; S[]Orﬁgs age
background: #fff url{(../App_ Themes/Community3Site/Images/topmenu-bg.¢ Logon?}agge
padd]_.ng:O()px; Logon page
margin: Opx: Main styles
¥ Membership top zone
Search box
.PagePlaceholder .zoneTopMenu
{ Media library
height: 90px; Members F
Stylesheet text background-color: $#BABABA; Messaging
¥ Modal popup
i My account
.DesignMode .zoneTopMenu .CMSListMenuUL Nev_\fs page
I Online members
background: #BABABA url|../hpp Themes/CommunitySite/Images/topmenu-k EO::AHSWEFS 3
- olls
H
.7 Reagistration form
- Search page
. CMS5Li=stMenuUL Shortcuts
{ - Tab menu
list-style-type: none; T |Tags | 4
4 [ ’ Widgets =2
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3. Replace the text of this section (all classes before the /*#Main styles/Search box#*/ line, which
indicates the beginning of the new section) with the code below. Click Save to save the changes.

[ *#Mai n styl es/ Top nenu#*/

. zoneTopMenu
{
wi dt h: 960px;
backgr ound: #000000;
paddi ng: Opx;
mar gi n: 0px;
}
. PagePl acehol der .zoneTopMenu
{
hei ght: 90px;
backgr ound- col or: #BABABA
}
/*
. Desi gnMode . zoneTopMenu . CVBLI st MenuUL
{

background: #BABABA url (../ App_Thenes/ Comruni tySite/ | mages/t opnenu- bg. gi f)
repeat-x top center;

}

*/

. GVBLi st MenuUL

{
list-style-type: none;
|'i ne-hei ght: 27px;
font -wei ght: bol d;
font-size: 13px;
mar gi n: 0px;
paddi ng: Opx;
float: left;
col or: #000000;

}

. OVBLi st MenuLl, . QVBLi st MenuH ghl i ght edLlI
{

di spl ay: bl ock;

float: left;

paddi ng: Opx;

backgr ound: #000000;
}

. OVBLi st MenulLl | ast, . CVSLi st MenuHi ghl i ght edLI | ast
{

backgr ound: none;

di spl ay: bl ock;

float: left;

paddi ng: Opx;
}

. OVBLi st MenulLi nk, . QVBLi st MenuLi nkH ghl i ght ed
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col or: #ccccecc;
t ext -decorati on: none;
di spl ay: bl ock;
paddi ng: Opx 15px;
mar gi n-ri ght: 2px;
}

. CVBLi st MenuLl a: hover, . CWVBLi st MenuLi nkHi ghl i ght ed, . CVBLi st MenuH ghl i ght edLl a

{
col or: #FFFFFF;

backgr ound: #000000;
t ext - decor ati on: none;

4. If you switch to the live site now, you can see that the colors of the main menu have changed as
defined in the pasted stylesheet code.

Current user: Global Administrator (administrator) | My home page | Edit my profile | Inbox | Sign out

'EIIN RN L .lna [ " mmm == L]

Home Blogs News Media Forums Groups Members Examples

Shortcuts

My profie
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

Welcome to our community
[ B [ == R A

f
This community site is a virtual meeting point for those who like
travelling, adventure, discovering new places, meeting new
people and all the things related to it.

Funn ara intaractad in thic cark Af thiner dan's haridata and

Further steps: You hawe learned how to access, modify and save changes to the site's CSS stylesheet.
If you are familiar with CSS in general, it should be no problem for you to fully customize any class of
the site's CSS stylesheet and thereby customize the site's design as you wish.
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3 Part 2

3.1 Introduction

In this part of Kentico CMS Community Site Guide, you will learn how to create a community site from
scratch. Our goal in the following series of step-by-step tutorials will be to create an identical site to the
sample Community Starter site from the very beginning, so that you can see all the stages of the web
site development process.

You will learn how to define the site structure, populate the pages with web parts and set the web parts'
properties to achieve the required functionality. Finally, you will make some settings to specify pages
with certain special functionalities.

Here are some things to keep on mind when reading the tutorials in order to get the most out of them:

e These tutorials are intended for web dewvelopers with at least the basic knowledge of Kentico CMS. If
you are new to Kentico CMS, please read at least the portal engine version of Kentico CMS Tutorial to
get familiar with the basics of the system.

e Most of the code examples are self-explaining for people with a certain knowledge of HTML, CSS and
transformations, so they are therefore not always commented. It is therefore highly recommended that
you have a solid understanding of these languages.

e The most important part of the tutorials are the web part properties settings. Because it would take
many times as much space to describe all the settings in detail, some of them are just listed without
further explanation. The good thing is that when you click the Documentation link at the top right
corner of each web part properties window, you get detailed explanation of each of the properties
directly within the application interface.
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p
& | CMS Desk - Web Part properties -- Webpage Dialog

General Layout
Default

Visibility

Content

Content filter
Transformations
Paging
Relationships
System settings
Mo data behavior
Editing buttons
HTML Envelope
AJAX

Time zones

Partial caching

Refresh content

Q Web part properties (Repeater)

Content filter

Document types:

Combine with default culture:

Culture code:

Maximum nesting level:

ORDER BY expression:

Select only published:

Selecttop N documents:

Site name:

3

3

S

@ Documentation

@ Yes
@ No

m

@ Use site settings

-1
BlogPostDate DESC
6l

[ ok | Cancel | _Apply |

http://localhost/kenticocms/CMSModules/PortalEngine/UL/Webparts/WebPartProperties.asp: € Local intranet | Protected Mode: Off

After clicking the link, you get the web part's documentation with all the properties explained.

© 2010 Kentico Software



Part 2 111

' ™y
@ ‘Web part - Documentation - Windows Internet Explorer [ == é]

|§, http://localhost/kenticocms/CMSModules/PortalEngine/UL/WebParts/WebPartDocumentationPage.aspxwebpartid=repeater | b |

i Documentation - Repeater

| »

The Repeater web part renders specified documents using given
ASCX transformation.

m

\J
Default =l
Web part control ID: Web partID.
Web part title: Web part title.
Disable view state: If checked, the view state for this web partis disabled.
Disable macros: If checked, the macro resolving for this webpart is disabled.
Visibility =
Visible: Indicates if web partis visible.

Indicates if web part should be hidden on sub-pages. If you check this box, the web part
Hide on subpages: will be displayed only on the page that uses the page template with this web part and it
will be hidden on sub-pages that inherit the page template.

Indicates for which document types should the web part be displayed. Ifthe type of the

S e CC RS currently selected document is different, the web part is not displayed.

The list of roles whao should see the web part. Ifno role is specified, the web partis

Display to rales: displaved to all roles.

|

Done €& Local intranet | Protected Mode: Off F v HI100% v

e Other valuable information can be found in Kentico CMS Deweloper's Guide. References to this
reference guide can be found throughout the tutorials. In addition, going through the particular modules’
chapters can enrich your knowledge and understanding of the system too. So for example if you don't
understand something related to Groups, just open the Module Groups chapter of the guide and see
if you can find the answers.

Wildcard URLs are used throughout the whole web site, mainly in the Groups section and on user
profiles. If you are not familiar with the wildcard URLs concept, please read this chapter of Kentico CMS
Developer's Guide.

e Last but not least, Kentico CMS is well-known for its outstanding technical support. So if you get
really stuck, don't hesitate and contact our support team at http://www.kentico.com/Support.aspx.
They are always there to help you.

© 2010 Kentico Software


http://devnet.kentico.com/docs/devguide/index.html
http://devnet.kentico.com/docs/devguide/wildcard_urls.htm
http://www.kentico.com/Support.aspx

112

Kentico CMS 5.0 Community Site Guide

3.2
321

Pre-development tasks

Creating the site

To get us started, we need to create a new web site. This can be achieved using the New site wizard.
You can access it both when making new installation and when you already have Kentico CMS

installed.

e When making a new installation, you can choose Continue to the New site wizard in Step 4 of the
Database Setup. After clicking Next, you will be redirected to the first step of the wizard.

r D |
Database Setup - Step 4

SQL Settings Database Starter Site nish

1 Choose starter site

»

Companyloge Corporate Site —
e

— -1 This is a web template for a general corporate site. Its used
= as a showcase of Kentico CMS capabilities and it can be
-y used as a starting site that you modify as needed. lt uses the —

B e portal engine and its the recommended choice for developers
R “ who are new to Kentico CMS.

m

Companyl o Corporate Site ASPX
]

—— “1 This is a web template for a general corporate site. Its used |
[ g as a showcase of Kentico CMS capabilities and it can be
-t used as a starting site that you modify as needed. It uses the

- — ASPX page templates that require a higher level of NET
YT knowledge than the portal engine.

© =

Version: 5.0 Build: 5.0.3688
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e Alternatiwely, if you already have Kentico CMS installed, you can access the New site wizard by
clicking the alike named link in Site Manager -> Sites.

232 Kentico
’.‘ CMS Site Manager Sites Administration Settings Development Licenses Support

(t_) Sites

g New site wizard [:‘:1. Import site or objects [3 Export objects

1. In the first step of the wizard, choose Create a new site using a wizard and click Next.

Choose default web site
If you choose to create a blank site, the wizard will guide you through the process of creating a new site. If
you choose to use atemplate, you will be able to choose one of the predefined web site templates.

Step 1

i@ Create a new site using a wizard
() Use web site template
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2. In the second step, enter the following details:

Site display name: My Community Site
e Site code name: MyCommunitySite

e Domain name: localhost

Site culture: English - United States

Click Next to proceed.

Enter new site settings

Step 2 Enter the display name and code name of the web site. The Domain field must contain the domain that you
will use to access the web site during development (you may change it when the site goes live). The default
culture is the main language of the web site.

Site display name: My Community Site

Site code name: | MyCommunitySite

Domain name:  localhost

Site culture: English - United States |Z|
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3. In Step 3, leawe all settings at their default values and click Next.
Objects selection
Step 3 Flease select objects which should be imported.
=) |All objects D | - [
i @ mport objects {
d@ Web site ) P ) @I
. [l Documents Please note: The import process may overwrite your existing objects. The existing objects are
%] Administration marked with * and will be overwritten if checked.
g Settings . . . .
e i Please selectthe object type from the tree if you wish to change the default selection.
- 255 Development Click Next to startthe import of selected abjects.
=) Global objects
+J-&¥ Tools Global selection
wﬂ Administration Load default selection  Selectall objects Select only new objects  Deselect all objects
[+]- =5 Development E
Import settings
Assign all objects to the imported site (recommended)
Run the site after import
[ pelete incomplete site when import fails
Import files (recommended)
[ Do not import objects where parent object is missing
Import tasks (recommended)

4. An import log will be displayed. When it finishes, you will be redirected to the following step.
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Import progress
Step 4 Objects are being imported.

Importing ‘Roles’ objects

Importing Web site’ objects

Importing "Settings’ objects

Importing "Settings categories’ objects

Objects are g mported i e
e

5. In Step 5, you can choose from three default master page layouts. Choose the Blank master page,
as we will define the layout later on.

Select master page
Step 5 The master page defines the layout of the main menu, logo and content placeholders. You can change it at
any time later.

»

Blank master page ol
Blank master page

Generic default page template.

m

Community Site - Master Page

Top logo and left menu —

L

Master page template with logo on the top and menu on the left side.

m
Iy
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6. The sixth step of the wizard allows you to define basic site structure. As we will create the pages
when creating the particular sections, you can skip this step by clicking the Next button.

Define basic site structure

Step ﬁ Define the site map of your new web site. The pages you create will be displayed in the site menu. Every
page must have some template specified or it can inherit page template from the parent page.

— — T ue
=l =4 l
New Delete & Down |

Content management | Page name:

""" t_/My Community Site Page template: Blank master page Remove template

a Page properties

Next>
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7. If you have reached the seventh step, you have created the site successfully. Click Finish to return
to Site Manager -> Sites.

The web site has been created successfully
Step ? Mow you can view and edit your new web site.

Edit your new web site

Ifthis is your first web site, the default user account is administrator without password.
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3.2.2 Assigning the CSS stylesheet

Once you hawve the site created, you can create its CSS stylesheet and assign it to the site. For the
purposes of this guide, you should use the CommunitySite.css, which is the Community Starter site's
original CSS stylesheet. The file can be found in the attached files package that can be found at http://
www. kentico.com/Downloads/Community Guide/Community SiteGuide_files.zip.

1. Go to Site Manager -> Development -> CSS Stylesheets and click the New CSS stylesheet link
at the top of the page.

232 Kentico
l.‘ CMS Site Manager Sites Administration Settings Development Licenses Support
(=) Development (; CSS stylesheets
- Categories
G CSS stylesheets
D cultures
..} custom tables SISl e Code name
. i) Document types # W3 corporate Site CorporateSite
-[3) E-mail templates # |3  cCorporate site printer styles  CorporateSitePrinter

<.§,’} Form controls
-[E nline controls

2. Enter the following details:

e Stylesheet display name: My community site
e Stylesheet code name: MyCommunitySite
e Stylesheet text: copy and paste the stylesheet text from the CommunitySite.css file

Leave the Assign to web site My Community Site check-box checked and click OK.

Switch to CMS Desk  User: Global Ad

212 Kentico
#g% CMS Site Manager Sites

Administration Settings Development Licenses Support
- Development <j{, New stylesheet
-5 Categories
@ Countries C38 stilesheets » New CSS styleshest
(7 C55 stylesheets
D cultures Stylesheet display name: My community site
- Hijl Custom tables
ﬂ Stylesheet code name:  MyCommunitySite
- [i) Document types
Q E-mail templates Stylesheet text
<& Form controls /*#Globali~/ =
body =1
Inline controls ‘
L’} Modules font-family: Tahoma, Arial, Verdana;
/. Notifications font-size: 1llpx;
--[ B Page layouts
- @ Page templates body.LTR, body.RTL
-.=8 Relationship names {
@ System tables background: #585858 url('../App Themes/CommunitySice/Images/main-bg.gif') repeat-x

% Tag groups
-8 Time zones
3 UI cultures

i} Web part containers
% web parts

-.[@] web templates
(@] widgets

-|w Workflows

—

top left;
padding: Opx;
margin: Opx;

color: #000000;

assign to web site My Community Site
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3. Go to Site Manager -> Sites and choose to Edit (#) your site.

Y2 Kentico

#1% CMS Site Manager

(;-) Sites

Sites Administration Settings

fg! New site wizard [} Import site or obiects | 3 Export objects

Actions

Site name -

X 'ﬁ [e] b | Ej_i My Community Site

Support

4. On the General tab, select the new stylesheet in both Site CSS stylesheet and Editor CSS
stylesheet drop-downs and click OK.

22 Kentico

#1% CMS Site Manager

Sites Administration Settings

&) Site properties

Sites » My Community Site

General Domain aliases Cultures

Site display name:
Site code name:

Site domain name:
Default content culture:

Default visitor cultura:

My Community Site
My CommunitySite
localhost

English - United States

[~ Change

(Automatic)

Site C385 stylesheet:
Editor CSS stylesheet:

My community site E’ Edit

My community site

Site description:

-] T

Sample blank web =ite

Support

You have learned how to create a new CSS stylesheet and assign it to your site.
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3.2.3 Creating page templates category

Throughout the process of the web site creation, you will create various pages. It is a good practice to
store the pages as page templates so that they can be reused later on at some other part of the web
site, without the need to define the page structure again. For you to keep the page templates organized
neatly, it is recommended to create a new page template category where the templates will be stored.

1. Go to Site Manager -> Development -> Page templates. Select the root of the template
categories tree (Page Templates) and click the New category link. Enter the following details:

e Category display name: My Community Site templates

e Category name: MyCommunitySiteTemplates

e Category image path: path to the image which will be used instead of the default category icon in
the page template selection dialog; the recommended dimensions are 16x16px, while larger images
may cause problems with design of the administration interface

Click OK. Your category is now created and you can sawe all your page templates for this site in it.

Switch to CMS Desk  User: Global Administrator v5.0.3688
-‘ll- Kentlco WItCH 0 el ser: oDal ministrator
#g% CMS Site Manager Sites  Administation  Settings | Development | Licenses  Support

- Development @ Page templates

i Categories

i@ Countries = x @ New category

: Q’ CSS stylesheets = —

@ cuures o

i}l custom tables = Category display name:

£]1 Document types oS f\” ek gory display My CDmmul?lty .SHE templates

= 55 Ad-hoc Category name: MyCommunitySiteTemplates

3 E-mail templates = . )

" Form controls ® tj' Articles Category image path:

@ Inline controls = ) Blank pages for widgets “

= ;ﬂ' Blogs

B A imitg Cika

i (f Modules
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3.24

Defining web part containers

Web part containers are elements of the web site which can encapsulate web parts. They consist of a
HTLM code before the web part and a after the web part. Throughout the web site, we will use six

different web part containers which we will define in the following example.

1. Go to Site Manager -> Development -> Web part containers and click the New container link
abowe the list.

=32 Kentico
#1% CMS Site Manager

=) Development

- Categories

@) Countries

G CSS stylesheets
D cultures

“fill Custom tables
G]l Document types
--[3) E-mail templates
<.§ Form controls
-[E nline controls
- Modules

| Notifications

I] Page layouts
i Page templates
=5 Relationship names
ﬁ System tables
.-<J Tag groups
- Time zones
{3 UI cultures

# Web parts

Sites Administration Settings Development

Actions
7R3
7R3
7R3
783
/7R3
7R3
7R3

Display name =
Black box
Breadcrumbs Box
Content padding
Div element

Gray box

COrange box

Search box

2. In the New container dialog, enter the following details:

Display name: Community Site - Blue Box
Code name: CommunitySite.BlueBox
Text before web part:

<di v cl ass="bl ueBoxTop" ></ di v>
<di v cl ass="bl ueBox" >
<h3 cl ass="bl ueBoxTi t| e">{ %Cont ai nerTi t | e%§ </ h3>

Text after web part:

</di v>

<di v cl ass="hbl ueBoxBot t on' ></ di v>

Click OK.
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3. Switch to the Sites tab, click the Add sites button and add My Community Site using the pop-up

dialog. Click OK.

Selectall Deselectall

= Site name

My Community Site

ltems per page: 10 |Z|

ok [ cancel |

el ™
& | Select sites —- Webpage Dialog ﬁ
@ Select sites
Site name orits part:

http://lecalhost/kenticocms/CMSAdmin ei. Local intranet | Protected Mode: Off

4. Repeat the same procedure for the following five web part containers:

e Display name: Community Site - Blue Box Light
e Code name: CommunitySite.BlueBoxLight
e Text before web part:

<di v cl ass="boxBl uelLi ght ">
<h3>{ %Cont ai ner Ti t | e% </ h3>

* Text after web part:

</di v>

® Display name: Community Site - Gray Box
e Code name: CommunitySite.GrayBox
e Text before web part:
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<di v cl ass="grayBoxTop"></di v>
<di v cl ass="grayBox">
<h3 cl ass="grayBoxTi t| e">{%Cont ai nerTi t| e% </ h3>

* Text after web part:

</ di v>
<di v cl ass="grayBoxBot t on' ></ di v>
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e Display name: Community Site - Orange Box
e Code name: CommunitySite.OrangeBox
e Text before web part:

<di v cl ass="orangeBoxTop" ></ di v>
<di v cl ass="or angeBox" >
<h3 cl ass="orangeBoxTi t| e">{ %Cont ai ner Ti t | e% </ h3>

* Text after web part:

</ di v>
<di v cl ass="or angeBoxBot t on{ ></ di v>

® Display name: Community Site - Red Box
e Code name: CommunitySite.RedBox
e Text before web part:

<di v cl ass="redBoxTop" ></di v>
<di v cl ass="redBox">
<h3 cl ass="redBoxTi t| e">{%ont ai nerTi t| e%§ </ h3>

* Text after web part:

</ di v>
<di v cl ass="r edBoxBot t oni' ></ di v>

® Display name: Community Site - Red Box Light
e Code name: CommunitySite.RedBoxLight
e Text before web part:

<di v cl ass="boxRedLi ght">
<h3>{ %Cont ai ner Ti t | e% </ h3>

* Text after web part:

</ di v>

You have created six new web part containers. These containers can now be used to encapsulate any
web part on the site, using the Web part container property. This property is common to all web parts.
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3.25 Uploading images

We will upload some images that we will use later on. You can find the images in the images folder
inside the files package attached to this guide, which can be downloaded at http://www.kentico.com/
Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Please extract the images from the archive
into a separate folder on your local disk before you start with the following steps.

1. Go to CMS Desk, select the root of the content tree and click New.

2Y2 Kentico

“1%  CMS Desk Content My desk
2 3 copy T up
1)z B

New |Delete = Move & Down

Content management

----- & /My Community Site

2. As the document type, choose Folder.

-‘:’. Kentico Switch

#4% CMS Desk Content My desk  Tools Administration

[ Copy T up I ¥ @ [@] = | )3

New Delete |=bMove & Down Edit Preview Live site List Search
Content management | iew mode | Other
..... ,_FJ My Community Site My Community Site

=| New document
Please select new document type:
| Page (menu item)

‘¥] Blog

&1 Link an existing document
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3. Enter Files as the Document name and click Save.

|
=

s

Y T

Kentico
CMS Desk My desk

S

witch to Site Manager

&4
New Delete

Content management

P

| Search |
|

document type.

!;_';! My Community Site

Tools Administration
4 O E
| Edit Preview Live site List
| View mode
My Community Site

o s2e

Other

E‘- Save and create anather Spell check

Documentname: Files

4. Now you have the folder ready in the content tree. Select it and click New. Choose the File

Me

Kentico
s

CMS Desk

My desk

Switch

— — 3 copy
New | Delete = Move

Content management

Tools Administration
4 [ =
Edit Preview Live site List
View mode
» Files

P

| Search |

Other

d-ﬂ_"'i My Community Site

- i5)Files
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and click Save.

5. Browse into the folder with the images, choose one of them, enter some text describing of the image

2Y2 Kentico

Switch to Site Manager
71N CMS Desk

Content My desk Tools
2 [} Copy T up
x

New Delete & Move & Down

Administration

|@/0

Edit Preview Live site List |

Y

Search |
Other

Content management | View mode

cl\-_’l My Community Site

» Files
~..75] Files

E Save E‘ Save and create another

Spell check

Actions Update Name

78

Upload file:

|i=| community header imag.jpg

Thi=z iz the default header image.

File description:

following screenshot.

Site:| My Community Site [=]

Size

36 kB

6. Repeat the same procedure for the rest of the images in the folder. The result should look as in the

Y2 Kentico

1% CMS Desk Content | My desk

2 Copy i up
x
New Delete = Move & Down

Content management |

clt-h_l My Community Site

-G Files

-5 button_joinnow

54| button_signin
= community_header_ima
“..[i=] community_home_img
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3.2.6 Creating asample poll

In this exmple, you will learn how to create a sample poll that you will publish on the Home page later

on. More information about Kentico CMS Polls module can be found in Kentico CMS Deweloper's Guide -
> Module Polls.

1. Go to CMS Desk -> Tools -> Polls and click the New poll link.

-\.II- Kentlco Switch to Site Manager

#4% CMS Desk Content My desk | Tools Administration

[~ Tools s Polls
“..l@ Abuse report

g Blogs —

P‘:} Booking system
9@ Content staging
-fill custom tables
.- E-commerce
--[[g File import

- &4 Forums

& Groups

- I98l Media libraries
[l Message boards
fﬂ Newsletters

- @ Palls

Fh] Reporting

“fafl Web analytics

No data found.
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2. Enter the following details:

Display name: Continents

Code name: Continents

Title: leave blank

Question: Which continent are you planning to visit during your next trip?

Click OK.

232 Kentico

#g%  CMS Desk

=) Tools

| Abuse report
BizForms

Wl Blogs

Pﬁ} Booking system
Ba Content staging
“fill Custom tables
- TR E-commerce
I File import

& Forums

ﬂg Groups

- lgal Media libraries

=1 Newsletters
- @|Polls

rﬂ Reporting
“fafl Web analytics

...[[] Message boards

Content

My desk Tools Administration

ﬁ New poll

Baolls » Mew poll

Display name: |Continents
Code name: |Continents

Title:

Which continent are you planning
to visgit during yvour next trip?

Question:

Switch to Site Manager

=
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3. The poll appears in the Edit mode, offering you five tabs where settings can be done. On the General
tab, enter the following:

e Message after vote: Thank you for your wvote.

Click OK.

232 Kentico Switch to Site Manager
1% CMS Desk Content My desk Tools Administration

Rl @ Poll properties

‘..|@] Abuse report

Polls » Continents

T . General Answers Securi Sites View
Pi} Booking system ty

..y content staging

ﬂ Custom tables Display name: Continents
;@ E-commerce Code name: Continents
L{? File import Title:

.. 84 Forums

g &Groups Which continent are you planning -
to wvisit during your next trip?

lyal Media libraries

Message boards Question:
i Newsletters
-@|Polls ™
Fﬁ] Reporting Open from: @Nﬂ
“..faf) Web analytics Opento: & Now
Thank vou for vour wvote -

o

Message after vote:

Allow multiple choices: [O]
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4. Switch to the Answers tab and click the New answer link.

Switch to Site Manager
232 Kentico
g% CMS Desk Content My desk Tools Administration
@ Tools @ Poll properties
Abuse report
BizForms Polls » Continents
Blogs I
[ - G Answ Securi Sites Vi
P& Booking system eneral NEWErs ecurity ites iew
Da SLTETIIETE i& Reset answers
il custom tables
TR E-commerce
[ File import Mo data found.
Forums
$a Groups

lval Media libraries
Message boards
Newsletters
&pPolls

[E_I Reporting

“..faf) web analytics

5. Enter Africa into the Text field and click OK.

Switch to Site Manager
232 Kentico
‘l\ CMS Desk Content My desk Tools Administration
=) Tools @ Poll properties
™
@ Abuse report
BizForms Polls » Continents
Blogs G | A S i Site: Wi
IP& Bcoking SYStEI’T‘I eneral NSWers ECI..II'It}'I tes ew
§ Content staging Answers » Mew answer
fil Custom tables _
T E-commerce i New answer
{3 File impaort
4 Forums .
&4 Text: Africa
& Groups -
Ial Media libraries | OK |

Message boards
MNewsletters

& Polls

[h] Reporting

-5 web analytics
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6. Repeat the procedure so that you have all five continents entered as answers.

232 Kentico Switch to Site Manager

‘l\ CMS Desk Content My desk Tools Administration
=) Tools @ Poll properties

H )
@ Abuse report
...[E BizForms Polls » Continents
Blogs |
Hr— . G Answ 5 i Site i
Pi} Booking system eneral nswers ecurity ites iew
Ea Content staging i.;g. MNew answer i& Reset answers

-fill custom tables
.. E-commerce

L_H File import Actions Text Count | Enabled
E FERE FRT L Aca 0 Yes

&4 Groups _ )

- Igal Media libraries ZRT & America 0 Yes
i-[] Message boards FRRT G rsia 0 Yes

£ Newsletters R T L Austaia 0 Yes
~@|Palls

: ® FR T L Euope 0 Yes

. [®] Reporting
“..faf) Web analytics

3.2.7 Creating the tag groups

Kentico CMS Tags module enables assigning documents with key words for better content-related
navigation and search. These key words are called tags and they are organized in tag groups. There is
one tag group called Content in the default instalation. We will create two additional tag groups called
Blogs and News, so that blog posts and news can be tagged with tags from separate groups.

More information about the Tags module can be found in Kentico CMS Developer's Guide -> Module
Tags.

© 2010 Kentico Software


http://devnet.kentico.com/docs/devguide/tags_module_overview.htm
http://devnet.kentico.com/docs/devguide/tags_module_overview.htm

134

Kentico CMS 5.0 Community Site Guide

212 Kentico

#g% CMS Site Manager

=)~ Development

-&Jl Categories

@ Countries

Q’ 55 stylesheets
- Cultures

ﬂ Custom tables
.l Document types
Q E-mail templates
... Form controls

4| Inline controls

Modules

7. Notifications

..['H Page layouts

ﬁ Page templates
.= Relationship names
@ System tables

@ Tag groups

- Time zones

=1 UL cultures

Web part containers
-8 web parts

-[@] Web templates

i

Sites Administration
</ Tag groups
Site: | My Community Site

<3 Mew tag grou

Actions

7R

Name ~

Content

Settings

Development

Licenses

[=]

Support

1. Go to Site Manager -> Development -> Tag groups and click the New tag group (*4) link at the
top of the page.
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2. Enter the following details into the form:

Display name: Blogs

Code name: Blogs

Description: This is the group of tags used for blog posts.

Click OK.

212 Kentico

#g% CMS Site Manager

=) Development

-&J Categories

@ Countries

d CSS stylesheets
- Cultures

‘.fi} custom tables
cﬂ Document types
2 E-mail templates
4‘} Form controls
+[E nline controls
i Modules

| Notifications
--[[H Page layouts
i Page templates
.= Relationship names
. [} System tables
--4&p Tag groups

.4 Time zones

UI cultures

Web part containers
- web parts

i[®] web templates

Sites Administration Settings Development Licenses

< New tag group

Tag groups » Mewtag group

Display name: Blogs
Code name: |Blogs

Descripion:  |This is the group of tags used
for blog posts

Support

135

© 2010 Kentico Software




136 Kentico CMS 5.0 Community Site Guide

3. Repeat the same procedure and create a tag group with the following details:

Display name: News
Code name: News
Description: This group contains tags used for news items.

Click OK.

4. If you go back to the list of tag groups, you should see the Blogs, Content and News tag groups.

212 Kentico

#g% CMS Site Manager Sites Administration Settings Development Licenses Support
= Development {:? Tag groups
-] Categories
@ Countries Site: | My Community Site [=]
G C5S stylesheets
@ Cultures &3 New tag qrou
ﬂ Custom tables
Document types
f'_] E-mail templates Actions = Name =
<.§ Farm controls 7R Blogs
- [E] Inline controls /% Content
Modules
| Notifications 7R News

--[[H Page layouts

ﬁ Page templates
.= Relationship names
ﬁ System tables

{3 Tag groups

- Time zones

S UI cultures

Web part containers
- web parts

i[®] web templates
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3.2.8 Creating the News notification template

There will be the News page on the site, where news will be added by content editors or site
administrators. On the page, users will have the possibility to sign up for receiving notifications about
new news items published on the site. You can find a tutorial on creating the page here.

In this chapter, we will create a notification template. Notification e-mails will be based on this template.
More information about Kentico CMS Notifications module can be found in Kentico CMS Developer's

Guide -> Module Notifications.

1. Go to Site Manager -> Notifications and switch to the Templates tab.

2. From the Sites drop-down list, select My Community Site and click the New template (5') icon.

=3Z Kentico
#1 CMS Site Manager Sites

Administration Settings Development Licenses

=) Development
. Categories
- Countries
G CSS styleshesats
- Cultures
il Custom tables
: [l Document types
f_] E-mail templates
<§ Form controls
[ Inline controls
‘(% Modules
| Notifications
--[H Page layouts
ﬁ Page templates

4| Notifications
Gateways Templates

site: | My Community Site [=]

Mo data found.

3. In the next dialog, enter the following details:

e Display name: News notification
e Code name: NewsNotification

Click OK.

212 Kentico

#g% CMS Site Manager Sites

Administration Settings Development Licenses

=) Development
-&J Categories
i@ Countries

‘L Notifications

; Gateways Templates
...} €55 stylesheats

g »

@ cultures Templates » New template

*fill custom tables
G]] Document types

Q E-mail templates Code name:  NewsMotification
--<% Form controls <

+[E Inline controls | 0K |
t’l Modules

| Notifications

.-[H Page layouts

i Page templates

Display name: Mews notification

Support

Support
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4. Switch to the Text tab and define the template's text the following way:
e Subject: Community Site News

Enter the following template text into both HTML text and Plain text fields:

Hel | o,

news item {%otificationcustondata.newstitled% has been just published on the
Community site. You can see it at {%locunent!ink%.

You are subscribed for receiving this automatic e-nail notification. If you no
| onger wish to receive these notifications, please change your preferences in your
user profile at the Community Site.

Click Save. The template is ready to be used.
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~e= Kentico
#§% CMS Site Manager

=) Development

£ Categories

@ Countries

d CSS stylesheets
3 cultures

i Custom tables
E]1 Document types
f_c] E-mail templates
< Form controls
[ Inline controls
B Maodules

i) [Notifications

B Page layouts

i Page templates
=8 Relationship names
ﬁ System tables
%¥ Tag groups

@ Time zones

UI cultures

Web part containers
¥ web parts

[@] web templates

[@] widgets

|« Workflows

L— & F

Sites

Gateways

Administration

Switch to CMS Desk  User: Global Administrator v5.0.3688

Settings Development Licenses Support

¢ Notifications

Templates

Templates » Mews notification

General

Text

Click here for template macro examples

Gateway: Email gateway

Subject:

HTML text:

Flain text:

Community Site News

B I[iZi2|@

Hello,

news item {#notificationcustomdata.newstitle®} has been just published on the Commnity site. You
can see it at {%documentlink®}.

You are subscribed for receiving this automatic e-mail notification. If you no longer wish to
receive these notifications, please change your preferences in your user profile at the Community
Site.

m

Hello, -

news item {%notificationcustomdata.newstitle%} has been just published on
the Community site. You can see it at {%documentlink%}.

¥You are subscribed for receiving this automatic e-mail notification. If
you no longer wish to receive these notifications, please change your
preferences in your user profile at the Community Site.
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3.2.9 Creating asample Media library

In the following example, we will create a sample media library. This media library will be global, which
means that all site users and visitors will be able to see its content on the Media page. We we will
create the Media page later on in this chapter.

Detailed information about the Media libraries module can be found in Kentico CMS Deweloper's Guide
-> Module Media libraries.

1. Go to CMS Desk -> Tools -> Media libraries and click the New media library link.

232 Kentico
#4% CMS Desk Content My desk Tools Administration

& Tools B9 Media libraries
@ Abuse report

BizForms New media library

'Pi} Booking system
Ba Content staging
*fill custom tables
---FR E-commerce
[ File import

&4 Forums

& Groups

- lga|Media libraries
Message boards
- [E) Newsletters

Mo data found.
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2. In the following dialog, enter the details listed below:

Display name: My Community Site Media

e Code name: MyCommunitySiteMedia
e Description: enter some text describing the media library
e Teaser image: you can leawe the field blank

Click OK.

232 Kentico
#g% CMS Desk

=) Tools

~

B Abuse report
[E] BizForms

Wl Blogs

...'g Booking system

Bﬁ Content staging

-fill custom tables

PR E-commerce

[ File import

&4 Forums

& Groups

- IgalMedia libraries

...[[] Message boards

Newsletters

4] Reporting
“..faf) web analytics

Folder name: MyCommunitySiteMedia

Switcl

Content My desk Tools Administration
@ New media library

Media libraries » Mew media library

Display name: My Community Site Media
Code name:  |MyCommunitySiteMedia

Thi= i= the global media library -
of My Community Site.

Description:
Teaserimage: | Upload:
Foldername: |MyCommunitySiteMedia
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3. The media library has been created and you are redirected to the library's editing interface. We will
define the folder structure first.

Click the New folder button while the root of the library is selected. Enter the name of the new folder
into the Folder name field and click OK.

Repeat the procedure so that you have the following four folders in the root of your library:

e Documents
e Music

e Pictures

e Video

Switch to Site M q Site: My C ity Sit
.‘!’- Ken thO witch to Site Manager ite: | My Community Si EE'
'.‘ CMS Desk Content My desk Tools Administration

=)~ Tools @ Media library properties
Abuse report
BizForms Media libraries » My Community Site Media

Blogs I :
. Fil G S i
Booking system iles eneral ecurity

% gzz:::‘:;g:g [ g Newfie =] uist Tiles [£2] Thumbnails

@ E-commerce

G File import Qo Fom @ws ||, = Searen

ﬂ Forums (=) MyCommunitySiteMedia (0) )

.. §a Groups ’\ES‘ Documents (0) There are no files to display.

.. lya| Media libraries 75 Music (0) U

c L. Pi i R
Message boards ) Pictures (0) £ New folder — Webpage Dialog ﬂ
Newsletters
@ Polls gl New folder

[5] Reporting
‘..fal) Web analytics
Folder name: Video|

o | Cancel

htt ?l'. Local intranet | Protected Mode: Off

~—
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4. Now that we have the folders ready, we can start uploading some files. We will use files from the
media_library_files folder inside the files package attached to this guide. The package can be found

at http://www.kentico.com/Downloads/CommunityGuide/CommunitySiteGuide_files.zip. Inside the folder,
you will find four sub-folders with the same names that you defined in the previous step. Each of the
folders contains several files. For the purposes of this example, you don't need to upload them all.
Uploading at least one file into each folder will do the job.

There are several ways how you can achiewe this. You can find a detailed description of how files can be

uploaded into the media libraries in Kentico CMS Developer's Guide -> Module Media libraries ->
Uploading files into media libraries.

Here, we will describe how you can upload files via the administration interface:

Select the target folder from the tree on the left and click the New file icon at the top right corner of the
page. In the pop-up dialog, browse to the folder where your files are stored and click Open.

.\1'- Kenti.co Switch to Site Manager  Site: My Community Site EI User: Global Administrator
‘l‘ CMS Desk Content My desk Tools Administration
&) Tools Media library properties
i Abuse report
-..[E] BizForms Media libraries » My Community Site Media
Blogs

H . Fil G | Securi
m Booking system iles eneral ecurity

g Content staging [;H New folder %] List Tiles [E] Thumbnails

£} Custom tables

PR E-commerce
g3 File import ok Gemr Fee | yame:
ﬂ Forums =~ MyCommunitySiteMedia (0)
‘.. §a Groups ‘.5 Documents (0) ‘ There are no files to display.
; : 5 Musi s A
Media libraries oy M.usm (o) @ Choose File to Upload M
Message boards i Pictures (0) P
{\ﬂ Mewsletters 5] video (0) U@v| J < media_library_files » Pictures - |£, | | Search Pictures o |
-l
4@ Polls
g Reporting Organize * New folder =~ I @
.4 Web analytics C 3
7t Favorites Documents library P
Pictures
i Libraries MName ‘ Date modified Type
H /8l Computer = IMO001775 3.4.2009 22:26 JPEG image
: = IM002595 3.4.2009 22:26 JPEG image
9‘ Network = IM002601 3.4.2009 22:26 JPEG image
= IM002628 3.4.2009 22:26 JPEG image
4| [ | 3
File name: IMO001775 ~ | All Files (**) -
Open Iv Cancel
\

Repeat the same procedure so that you have at least one file in each of the folders. Once finished, the
library is ready to be published on the site.
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3.2.10 Creating a Smart search index

Kentico CMS Smart search module enables index-based search through the content of your site. For
this to work, you need to have at least one index created for your site. This index will contain information
about the content of your site and is much faster to be searched than using the standard SQL queries
search approach.

Further information on Kentico CMS Search Engine can be found in Kentico CMS Deweloper's Guide ->
Modules -> Smart search -> Ovenview.

In this example, we will create a new smart search index and configure it so that it can be used on our
site.

1. Make sure that your site is running (in Site Manager -> Sites) and go to Site Manager ->
Administration -> Smart search. Click the New index (&) link.

-":'- Ken ti_c,o Switch
’l‘ CMS Site Manager Sites Administration Settings Development Licenses Support
(- Administration W Smart search indexes
-{d] Avatars

a Badges

-3 Banned IPs

& E-mail queue Actions Display name - Last rebuild time Index type Index status
[0 Eventlog # 8B community site - default  219/2010 35449 PM  Documents  Ready

A Permissions # BB communitysite-Forums  2/19/2010 35451 PM Forums Ready

T;' Recycle bin

. & Roles F®®  Ecommerce site - default Documents  Ready

@ Scheduled tasks
70| Smart search
.' System

~[&] u1 personalization
‘@ Users

~. My web farm
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2. Enter the following details into the New index form:

Display name: My Community Site

Code name: MyCommunitySite

Analyzer type: Standard

Index type: Documents

Assign index to website <your site name>: enabled

Click OK.

232 Kentico
‘l‘ CMS Site Manager Sites Administration Settings Development Licenses Support

=)~ Administration 1§ New search index
{d] Avatars
7 Bad words Search indexes » Mew index

-4 Badges

Cg Banned IPs Display name: My Community Site

& E-mail queue

B g 5 Code name:  |MyCommunitySite

ﬂ Event log

%f Permissions Analyzertype: | Standard E
...l Recycle bin Index type: Documents |Z|
& Roles [¥] Assign index to website My community site

@ Scheduled tasks “

-.-f]|Smart search

. System
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3. Now switch to the Index tab and click the Add allowed content (<) link. Add the following values
into the form:

Click OK. This ensured that the whole content of the site will be indexed.

Path: /%

Document types: leave the field empty
Including ad-hoc forums: enabled
Including blog comments: enabled
Including message boards: enabled

=32 Kentico
#§% CMS Site Manager

=)+ Administration

- [d] Avatars

-7 Bad words

,B Badges

¥ Banned IPs
G E-mail queue
[ Event log

-/ Permissions

4] Recycle bin
-84 Roles

(D) Scheduled tasks
.43/ Smart search
System

[E] ut personalization
i Users

.. Mg web farm

Sites Administration

Settings

Ay Smart search indexes

Smart search indexes » My Community Site

General Index Sites

ltem list » Mew allowed item

Path:

Document types:

Including ad-hoc forums:

Including blog comments:

Cultures

/%

Support

Select

[ select | Clear |

Leave the field empty if you wish to choose all document types.

Including message boards:
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4. Now switch to the Cultures tab and click the Add cultures button. Select the only available culture -
English - United States and click OK.

Wy Smart search indexes

Smart search indexes » My Community Site

General Index Sites Cultures
The following culture versions & | Select cultures -- Webpage Dialog M
No cultures selected @ Select cultures

Add cultures

Site: | My community site [~]

Culture name or its part:

Selectall Deselectall

[Tl | Culture name

English - United States

ltems per page: | 10 E

[ ok | Cancel |

http://lecalhost/KenticoCMS_0219/CMS4 €& Local intranet | Protected Mode: Off

5. Finally, go back to the General tab and click the Rebuild () link at the top. This needs to be done
only for the first time. Any further changes made to the site will be indexed automatically.
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3.3

Creating the Master page

As we hawe the site created and the pre-development tasks carried out, we can start defining the master
page. The master page is represented by the root of the content tree. It is the page from which all other
pages inherit the default content, such as the main menu, header image, etc. Like this, you can awoid
laborious adding and setting of these elements at all pages. Instead, you only use them on the master
page and all other pages will inherit it.

In Step 5 of the New site wizard, we chose to use the Blank master page page template. This is the
most simple master page with two web part zones. As we want the master page to be a bit more
complex, we will have to modify its layout.

Further information on master pages can be found in chapters The master page concept and Editing the
master page of Kentico CMS Developer's Guide.

1. The master page uses the Blank master page page template. If you made any changes to the page
now, the changes would be reflected on the page template too so that the original page template
definition would be overwritten and could not be reused anymore.

To prevent this, you need to save the page as a new page template. We will stick to this practice
throughout the whole guide.

Go to CMS Desk -> Edit, select the master page from the content tree and switch to the Properties ->
Template tab. Click the Save as new template link.

Switch to Site Manager  Site:| My Community Site User: Global
32 Kentico v ty sie[=]
‘l‘ CMS Desk Content My desk Tools Administration
S & Boer #uw 4 [ [ E F
New Delete = Move & Down || Edit Preview Livesite Lt | Search |
Content management | View mode | Other
‘Z."!‘_;'] My Community Site Page Design Form Master page Properties
&) Files General
E Save
URLs
Template
Metadata Template
Categories Blank master page ﬁ
Menu .
=
="
ok [ =1 Save as new template ]
Versions x Clear
Related docs -
A/ Clone template as ad-hoc
Linked docs =f
Security E Edit template properties
Attachments
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2. In the pop-up window, enter the following details:

Template display name: My Community Site - Master Page
e Template code name: MyCommunitySite.MasterPage
Template category: My Community Site templates
Template description: some text describing the template

Click OK.

r ~
& | Page template - Save as new -- Webpage Dialog @

4 Save as new page template

Template display name: My Community Site - Master Page
Template code name:  |MyCommunitySite_MasterPage
Template category: My Community Site templates |Z|

This is the master page of My -
Community Site.

Template description:

| OK | Cancel

httpe//localk Q Local intranet | Protected Mode: Off

w .

3. Now we can start making modifications to the page. First, we will re-define the page layout so that we
get more web part zones on the page. Switch to the Master page tab and replace the original layout in
the main text area (within the <body> tags) with the following piece of code.

Click Save to save the changes.

<l-- Top info -->
<di v cl ass="zoneTopl nf 0" >
<ccl: CvB\WebPar t Zone | D="zoneTopl nf 0" runat="server" />
</ di v>
<di v cl ass="nai nDi v">
<di v cl ass="zoneTopMenber shi p">
<ccl: CvBWebPar t Zone | D="zoneTopMenber shi p* runat="server" />
</ di v>
<di v cl ass="zoneTop" >
<ccl: CvBWebPar t Zone | D="zoneTopl mage" runat="server" />
</ di v>
<di v cl ass="zoneTopMenu">
<ccl: CVB\WbPar t Zone | D="zoneTopMenu" runat="server" />
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>
<di v cl ass="zoneMai n">
<ccl: CvB\WebPar t Zone | D="zoneContent" runat="server" />
</ di v>
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<di v cl ass="zoneBottom >

<ccl: CvB\WbPart Zone | D="zoneBot t ont
</ di v>
</ di v>

runat ="server" />

4. If you switch to the Design tab now, you should see that the master page has been populated with
several web part zones. The layout is now ready and we can start populating the page with web parts.

Page Design Form Master page Properties

Display web part content \E

= [ - page template: My Community Site - Master Page /

w zoneToplnfo *

|V zoneTopMembership *|
ok

* zoneTopImage

T zoneTopMenu

= zoneContent +
= [ |pageplaceholder {&3
|

|v zoneBottom
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5. Let's start from the top where the logon bar with links to CMS Desk and Site Manager is located.

Click the Add web part () icon of zoneTopInfo. In the pop-up window, choose the Text -> Static
text web part and click OK.

In the web part properties window, you only need to set the value of the Text property. Use the following
code for the value:

<di v style="border: 1px solid #cecfce; background: #f 7f 3ef ; col or: #555555; f ont -

wei ght : bol d; paddi ng: 3px; f ont - si ze: 10px; text-al i gn: center">

Sign in to <a href="~/ QvBPages/ | ogon. aspx?Ret ur nUr | =~/ cnsdesk/ def aul t . aspx&anp;
user nane=adm ni strat or">CV5 Desk</a>. Sign in to <a href="~/ CVSPages/ | ogon. aspx?
Ret ur nUr | =~/ cnrssi t emanager / def aul t . aspx&anp; user nanme=adm ni strator">CVS Site
Manager </ a>. The default account is adm nistrator with bl ank password.

</ di v>

Leave the rest of the properties at their default values and click OK. You should see the logon bar appear
in the web part zone.

= zoneTopInfo o
w ctatictext @ Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is ini with blank
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6. Let's move on to zoneTopMemebership. This web part zone will contain the sign in/out link, link to
the current user's private messaging inbox, link to the current user's profile editing page and information
about the current user with link to her public profile.

Click the Add web part (4) icon, choose the Membership -> Sign out button web part and click OK.
Set the following properties of the web part, leave the rest at the default values:

e Show as link: enabled

e Button text for sign out: Sign out

e Show only when authenticated: disabled
e Sign in page path: /Logon

e Return page path: /Home

e Content before: <div class="signOut">

e Content after: </div>

Click OK.

Click the Add web part (4) icon again, choose the Messaging -> Messaging info panel web part
and click OK. Set the following properties of the web part, leave the rest at the default values:

e Display to roles: _authenticated

e Inbox link URL: ~/Members/{%UserName|(encode)true%}/Messages.aspx

e Show outbox: disabled

e Show new message: disabled

e Content before: <div class="messagesPanel">

e Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the
string begins with a blank space)

Click OK.

Click the Add web part (%) icon again, this time, choose the Text -> Static HTML web part and click
OK. Set the following properties of the web part, leave the rest at their default values:

e Display to roles: _authenticated

e Content before: <div class="myAccountInfo">

e Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the
string begins with a blank space)

e Text: place the cursor into the text area, click the Source ((Z]) icon at the WYSIWYG editor and
replace the original HTML code with the following code:

<a title="M profile" href="/KenticoCV5_40/ Menber s/ {%Curr ent User . User Nane| (encode)
true% / Managenent. aspx">Edit ny profil e</a>

Click OK.

Click the Add web part (%) icon again and finally choose the Membership -> Current user web part.
Click OK. Set the following properties of the web part, leave the rest at their default values:

e Authenticated URL link: ~/Members/{%CurrentUser.UserName|(encode)true%}.aspx
e User text CSS class: userName
e Content before: <div class="currentUser">
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e Content after: " |&nbsp;</div>" (do not enter the parentheses, these are here to indicate that the
string begins with a blank space)

Click OK.

7. Next on is the zoneToplmage web part zone, where the header image should be placed. Click the
Add web part (4) icon of this web part zone and choose the Text -> Editable image web part. Set its
following properties, the rest can be left at their default values:

e Image width: 960

e Image height: 148

e Alternate text: Community Site

Click OK.

Now switch to the Page tab. The added web part is represented here only by the two link buttons as in
the screenshot below. Click the Select button of the added web part.

[~ Seiect..| 3 Clear

7. In the pop-up window, select the previously uploaded community_header_img.jpg and click the
Select button.

- N
|| Insert - Webpage Dialog [
Selectimage

Attachments. Content Media libraries Web

g newrorcer [ g Newfie List Tiles Thumbnails (2]
Site: | My Community Site E General
URL:  |/kenticocms/Files/community_header_img.aspx [~}

=] \i_’i My Community Site

(2 Files Width: 960
-3 button_joinnow Height: | 14§ .
{3 button_signin Communlty

Starter site

*. =/ community_header_img
“ k= community_home_img

http://localhost/kenticocms/CMSFermControls/Selectors/InsertimageOrMedia/Default. aspxfoutput=url&amp; content=img&amp;documentid=407&am ?'l. Local intranet | Protected Mode: Off
S
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8. The header image is now at its place. Click Save to sawe the master page.

Form Master page Properties Q

Page Desigt

n
Spell check

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is adminit with blank

Community

Starter site

9. Now we need to populate the zoneTopMenu web part zone where the search box and the main
menu will reside. Click the Add web part (%) icon of this web part zone and choose the Full-text
search -> Smart search box web part. Set the following properties of the web part, the rest can be left
at their default values:

Disable view state: enabled

Search button text: Search

Search button CSS class: buttonSearch
Search textbox CSS class: inputSearch
Search results page URL: ~/Search.aspx
e Show search label: disabled

Click OK.

10. Let's add the main menu now. Click the Add web part (%) icon of the zoneTopMenu web part
zone again and choose the Navigation -> CSS list menu web part. Set the following properties of the
web part, the rest can be left at their default values:

e Path: /%

e Document types: CMS.Menultem;CMS.Blog
e Maximum nesting level: 1

¢ Render CSS classes: enabled

11. The zoneContent web part zone is where content of all the pages will be loaded. To achiewe this
behavior, you need to have the Page placeholder web part in the web part zone. As you can see, the
web part has been added to the web part zone automatically, so you can go on to zoneBottom.
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12. Finally, we will add the Kentico logo into the zoneBottom web part zone. Click the Add web part
(1) icon and choose the General -> Powered by Kentico web part. Replace the value of the Text
property with the following code:

<a href="http://ww. kentico.com title="Kentico CVS for ASP. NET - the WEB 2.0
Cont ent Managenent System for . NET devel opers"><ing border="0" src="~/ App_Themes/
Comuni tySi t e/ | mages/ Power ed_by_kentico_cns. gif" alt="This web site uses Kentico
CVS, the content managenent system for ASP. NET devel opers." /></a>

Click OK.

13. And that's us finished with the master page. If you switch to the Live site mode now, you should
see the page appear as in the screenshot below. The main menu is not visible yet as there are no pages
defined. The rest of the page is already at its required appearance. Content of all site's pages will be
loaded into the main white zone where the Page placeholder web part resides.

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is admini: with blank

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site
£

g
Ha

|| Ssearch

b o
eﬁ- Kentico
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3.4

Creating the Search page

In the previous chapter, you have defined the master page. In the ninth step, you placed the Smart
search box web part next to the main menu and set its Search results page URL property to ~/
Search.aspx. This is where the user will be redirected after submitting the search request and where the
search results will be displayed. On this page, users will also be able to perform full-text search with
extended options using the Smart search dialog with results web part.

Further information on Kentico CMS Search Engine can be found in Kentico CMS Deweloper's Guide ->

Modules -> Smart search -> Oveniew.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

Switch
232 Kentico
#1% CMS Desk Content My desk Toolz Administration
> C U
Il x B T I3 [ @ B | AP
New | Delete = Move 4 Down Edit Preview Live site List Search
Content management | View mode | COther
(- My Community Site My Community Site
-5 Files

> New document

Please select new document type:

I |1 Page (menu item) ]

i) Blog

i) Folder

%] Link an existing document
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2. Choose to Create a blank page using the Simple layout. For Page name, enter Search and click

Kentico Switch to Site Manager  Site:| My Community Site =] User: Global Administrater v5.0.3628 Sign out
CMS Desk Content | Mydesk  Tools  Administration
2 Co u
0 Bew #w 3 @ B [ o
New Delete = Move & pown Edit Preview Live site List Search
Content management | View mode || Other
=
(=] {\4‘) My Community Site My Community Site

[4)-%3] Files

E Save E‘ Save and create another

Page name: Search

) Use pagetemplate ) Inheritfrom parentpage @ Creale a blank page

Layout name:

-
i

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells Grid 3x2 cells (CSS) Simple
ﬂ
Three columns Three columns (CSS) Top row, three columns, Top row, two columns, Two columns
bottom row bottom row

Simple

1

12

Simple layout with one web part zone.

Copy this layout to my page template
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

22 Kentico

Switch to Site Manager

1% CMS Desk Content My desk Tools Administration
; j [Hcopy Tup | 2 (al = }) |
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode Other |
lﬂ'!’l_."! My Community Site Page  Design  Form | Properties
‘ﬂ@ Files General
||/ 5earch = E Save
Template
Metadata Template
Categories Ad-hoc: Search
Menu -
Wt _jlt: Save as new template...
Versions € Inherit template
Related docs
Lried g [ ﬁ Edittemplate properties ]
Security
Attachments Inheri: content
@ Use page template settings
) Do notinherit any content
H ©) Selectinherited levels

Site: | My Community Site[«| User: Global

Select

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original

layout with the following code:

<di v cl ass="subcont ent D v">
<di v cl ass="zoneCent er Hone" >
<ccl: CvBWbPart Zone | D="zoneCenter"
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>

runat ="server"

/>
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Click Save.

' ™
& | Page Templates -- Webpage Dialog g

Page template properties @

Templates » Ad-hoc: Search

General Layout Web parts Header Documents
E Save @ Check out to file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplatelLayouts\8062ec48-1616-43a9-
a401-1b1a02666310.ascx to edit the Ryout externally.

() Use shared layout
Grid 2x2 cells

@ Use custom layout
<div clasa="subcontentDiv"> *
<div class="zoneCenterHome">
<ccl:CMSWebPartZone ID="zonelenter"™ runat="server" />
</div>
<div clazs="clear"»snbapr</divs
<Sdive

http://lecalhost/kenticocms/CM5Medules/PortalEngine/Ul/Pz el'. Local intranet | Protected Mode: Off

5. Switch to the Design tab. You should see one web part zone named zoneCenter on the page, just
as you defined by the layout above. Let's add some heading text first. Click the Add web part () icon
of this web part zone and choose the Text -> Static text web part. In the web part properties window,
set the following values. The rest of the properties can be left at the default values:

e Text: <hl class="header">Search results</h1>

Click OK.

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Search : | | | SearchJ
—

2

|V /5earch - page template: ad-hoc
= zoneCenter +

v statictext {0 ults
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6. Displaying search results and the search function itself will be achieved using the Smart search
dialog with results web part. Click the Add web part (4F) icon again and choose the Full-text
search -> Smart search dialog with results web part. In the web part properties window, enter the
following values. The rest of the properties can be left at their default values:

e Indexes: My Community Site (created here)
e Paging mode: Postback

e Web part container: Content padding

e Content after: <br/>

Click OK.

From this moment on, if you switch to the Live site, the page should be fully functional. Try searching
both using the Search box next to the main menu and the Smart search dialog with results web
part. Use e.g. community as the keyword, since this word is included in two previously uploaded images
names and the master page's name. You will get the results as in the following screenshot.

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Search | || search

Search results

search for:  community

Search mode: |Any word El

community header imgq

e hitp:/flocalhost kenticocms Files/community_header_img.aspx 2/16/2010 3:08:16 PM
community home img

e hittp:/flocalhost kenticocms Files/community_home_img.aspx 2/16/2010 3:09:34 PM

L

mmm=— http:/flocalhost/kenticocms /default.aspx 1/1/0001 12:00:00 AM
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7. We don't want the Search page to be displayed in the main menu. To prevent this, select the page in

CMS Desk and switch to the Properties -> Menu tab. Disable the Show in navigation check-box and
click Save.

Switch to Site Manager  Site:| My Community Site User: Global
=32 Kentico x by Sie[=]
1% CMS Desk Content My desk Tools Administration

) [x Blcer  Tw o [ H y
New Delete |=»Move & own | Edit Preview Live site Lst || search |

Content management | View mode Other

I:II'!;"] My Community Site Page Design Form Properties

e

‘i‘q iles General

‘[ )[search E Save
URLs
Template
Metadata Basic properties
Categories Menu caption:
Menu Show in navigation
Workflow Show in sitemap:
Versions
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8. Finally, we will save the page as a page template so that it can be reused in the future. This is a good
practice to awid repeating laborious task. Switch to the Edit mode and go to the Properties ->

Template tab. Click the Save a

Template display name: My

e Template category: My Com
Template description: some

s new template link and enter the following details:

Community Site - Search page

Template code name: MyCommunitySite.SearchPage

munity Site templates
text describing the page template

Click OK. The page is now saved as a new page template and can be reused when creating new pages

with similar layout or content.

22 Kentico

Switch to Site Manager ~ Site: My Community Site[=] User: Global Administrator v5.0 36288

1% CMS Desk Content | Mydesk Tools  Administration
= = Ci 1] el Y
B RO v |3 Q@ @ =]/,
New Delete =¢Move & Down | Edit Preview Live site List | Search ‘
Content management | View mode | Other |
5] !"_,3 My Community Site Page  Design  Form | Properties
E @ Eies General
§ Search Save
& URLs E
Template
Metadata Template
Categories My Community Site - Search page Select
Menu i r - N
:t# ‘Shve as naw tempiate H | Page template - Save as new -- Webpage Dialog @
Workfiow -
Versions if Inhenttemplate /=l Save as new page template
Related docs .
/=5 Clone template as ad-hoc
e = Template display name: My Community Site - Search page
Seculiy E Edittemplate properies Template code name:  MyCommunitySite SearchPage
Attad e Template category: My Community Site templates |z|

This is the Search page of My -
Community Site.

Inhert content
@ Use page template settings

() Do notinherit any content Template description

() Belectinherited levels

http://localk € Local intranet | Protected Mode: Off
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3.5 Creating the Logon page

On the Master page, we placed the Sign out button web part and set its Sign in page path property
to /Logon. This is where the user will be redirected in order to sign in. This can also happen in other
cases such as when a user tries to access a section which is available only to authorized users.

The page will provide the sing-in functionality via the Logon form web part, as well as the possibility to
register for anonymous site visitors, which will be achieved using the Custom registration form web
part.

Information about the Custom registration form and how you can modify the appearance of the form can
be found in this chapter.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

Switch ¢
232 Kentico Switch:
#1% CMS Desk Content My desk Toolz Administration
] 3 B dw 2 @ @ =2 | A
New | Delete [= Move & pown | Edit Preview Live site List | Search |
Content management | iew mode | COther
(I My Community Site My Community Site
. Files 4
e = New document
‘] Search —

Please select new document type:

[ [ Page (menu item) ]

‘¥ Blog

i Folder

#] Link an existing document
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2. Choose to Create a blank page using the Simple layout. For Page name, enter Logon page and

click Save.

2 Kentico Switch to Site Manager  Site:| My Community Site =] User: Global Administrater v5.0.3628 Sign out

#g%  CMS Desk Content | Mydesk  Tool

[ Copy i ue 4 E] = )3

Administration

New Delete [=bMove & pown Edit Preview Live site List Search
Content management | View mode || Other
n:/'i") My Community Site My Community Site
(-G Files

Spell check

[ search E Save E‘ Save and create another

Page name: Logon page
(") Use page template ) Inheritfrom parent page @ Create a blank page

Layout name:

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells
ﬂ
Three columns Three columns (CSS) Top row, three columns,
bottom row

12
Simple

Simple layout with one web part zone.

Gopy this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

(2]

Simple

Two columns

(]
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

Switch to Site Manager  Site:| My Community Site User: Global
=32 Kentico x by Sie[=]
1% CMS Desk Content My desk Tools Administration
= c U - i
) [ Do dw (4  [d P
New Delete |=k Move & Down | Edit Preview Live site List | Search |

Content management View mode | Other |

l:‘l'!h;'] My Community Site Page  Design Form Properties

‘1‘@ Files General
,_] Logon page E Save
‘[ ] search i
Template
Metadata Template
Categories Ad-hoc: Logon page " Select |
Menu -
Workflow -'5_‘: Save 38 new eniolte..
Versions € Inherit template
Related docs
Lried g [ﬁ Edit template properties ]
Security
Attachments Inherit content
@ Use page template settings
@ Da notinherit any content
H (©) Selectinherited levels

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
layout with the following code:

<l-- Container -->
<di v cl ass="| ogonReg" >
<I-- Left zone -->

<div class="zoneLeft" style="width: 50% float: left;">
<div style="wi dth: 270px; margin: 30px Opx 10px 90px;">
<ccl: OvBWbPart Zone | D="zonelLeft" runat="server" />
</ di v>
</ di v>

<l-- Right zone -->
<div class="zoneRight" style="width: 50% float: left;">
<div style="w dth: 280px; margin: 30px auto;">
<ccl: CvB\WebPart Zone | D="zoneRi ght" runat="server" />
</ di v>
</ di v>
</ di v>

Click Save.
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-

& | Page Templates -- Webpage Dialog

:j Page template properties

Templates b Ad-hoc: Logon page

General Layout Web parts Header Documents

e s2e () checkouttofie

8d71-30949944798d.ascx to edit the hyout externally.

) Use shared layout

Grid 2x2 cells

@ Use custom layout

<!-- Container -->
<div class="logonBeg”>
<!-- Left zone -->

Check out the layout to file C:\inetpub\wwwroot)50screenshots\CMSAdhocTemplateLayouts\edc61a27-c677-477a-

<div class="zoneleft"™ style="width: 50%; float: left;">
<div style="width: 270px; margin: 30px Opx lO0px 90px;">
<ccl:CMSWebPartZone ID="zcneleft™ runat="server"” />
</dive
</div>
<!-— Right zZcne —-->
<div class="zoneRight™ style="width: 50%; float: left;">
<div style="width: 280px; margin: 30px auto;">
<ccl:CMSWebPartZone ID="zoneRight™ runat="server™ />

<fdive
</dive
</divy|

http://localhost/kenticocms/CMSModules/PortalEngine/Ul/Page @ Local intranet | Protected Mode: Off

5. Switch to the Design tab. You should see two web part zones on the page - zonelLeft and
zoneRight - just as you defined by the layout code above. The left web part zone will host the logon
form, the registration form will be placed in the right one. Click the Add web part (%) icon of the
zoneleft web part zone and choose the Membership -> Logon form web part. Set the following

properties of the web part, the rest can be left at their default values:

Default target URL: ~/Home.aspx

Web part container title: Sign in

Content after: </div>

Click OK.

Web part container: Community Site - Blue Box Light

Content before: <div style="min-height: 160px;height:auto">

6. User registration will be achieved using the Custom registration form web part. This web part has no
default appearance - the way it will look like is defined by an alternative form of the cms.user system
table. We will use the pre-defined Registration form alternative form. However, you can customize the
alternative form according to your needs, as described here, or even create your own form a similar way.

First, click the Add web part (%) icon of the zoneRight web part zone and choose the Membership -
> Custom registration form web part. Set the following properties of the web part, all other properties

can be left at their default values:
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Alternative form: cms.user.RegistrationForm

Redirect to URL: ~/Members/{%CMSContext.CurrentUser.UserName%]}.aspx

Registration error message: There was an error during registration. Please see details below.
E-mail confirmation page: ~/Special-pages/Registration-approval.aspx

Web part container: Community Site - Blue Box Light

Web part container title: Join the community

Click OK.

7. If you switch to the Live site mode, you should see the following appearance of the page.

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Logon page | . | || searcn

Sign in Join the community

User name: User name:

Password: First name:

[ElRemember me Last name:

Log on Email:

Password:
Forgotten password

Confirm password:

Gender: O Male ) Female

Vo il
e:& Kentico
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8. Switch back to the Edit mode and go to the Properties -> URLSs tab. Enter the following details:

e Document alias: Logon
e Document URL path: /Join

Site: My Community

Click Save.
Switch to Site Manager
232 Kentico
#g% CMS Desk Content My desk Tools Administration
) [x Dloer W [q] ~r
New Delete = Mave & Down | Edit Preview Live site List | Search |
Content management | View mode | Other
C‘F_,J My Community Site Page Design Form Froperties
'1“"3” A General |
‘-] Logon page E Save
D= URLs
‘|| Search
Template
Metadata The changes were saved.
Categories Path
Menu Document alias: Logon
Workflaw Document URL path: |fJgin
Versions Use custom URL path
Related docs
Lirdecl e Extended properties
X URL extensions:
Security |:|
At Use custom URL extensions
Track campaign:

9. We don't want the Logon page to be displayed in the menu. Go to the Properties -> Menu tab and
disable the Show in navigation check-box. Click Save.

Switch to Site Manager Site:| My C
232 Kentico x
‘l‘ CMS Desk Content My desk Tools Administration
S [ Blcer  du (4 [d P
New Delete |= Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other |
‘Zl'{‘_;'l My Community Site Page Design Form Properties
'1‘ L')' Eiles General
|/ Logon page E Save
Lo URLs
|| Search
Template
Metadata Basic properties
Categories Menu caption:
Menu Show in navigation'@
Workflow Show in sitemap:
‘ersions

ommunity SiteEl User: Global
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10. Finally, we will save the page as a page template for further re-usability. Go to the Properties ->
Template tab and click the Save as new template link. Enter the following details:

Template display name: My Community Site - Logon Page
Template code name: MyCommunitySite.LogonPage
Template category: My Community Site templates

Template description: some text describing the page template

Click OK.
Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.3688
232 Kentico ¥ ty Stelx]
#av  CMS Desk Content | Mydesk Tooks  Administration
= =) [ u . @
Bl m B #w | 3 [ @ B2 | P |
New Delete =¢Move & pown ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
12 My Community Site Page  Design  Form | Propertiss
9 @ Elles General
| |/Logon page E Save
HE URLs
i | Search
Template
Metadata Template
Categories My Community Site - Logon Page Select
Menu r N
& | Page template - Save as new -- Webpage Dialog ﬂ
Workflow
Versions @ Inheril emplate /5 Save as new page template
Related docs .
i 4=/ Clone template as ad-hoc
fme = Template display name: My Community Site - Logon page
. , "
eazby E Edittempl3te properties Template code name:  MyCommunitySite LogonPage
Attachments
Template category: My Community Site templates El
Inherit content This is the Logon page of My =
@ Use page template settings Community Site.
E| > Do notinherit any content Template description:
) Selectinherited levels
http://localk €& Local intranet | Protected Mode: Off
\
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3.6 Creating the Home page

In this chapter, you will see how to create the Home page. This is the initial landing page - the page that
the site visitors will see at first when they enter the URL of your site into the browser. It is important to
set the alias path of this page in Site Manager -> Settings -> Web site -> Default alias path, as

described here.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico

“1% CMS Desk Content My desk
[ Copy i up
New |Delete = Move & Down

Content management

d-t;_;:l My Community Site
()-S5 Files
I_| Logon page
i.[] search

Tools Administration

4 [d [ =

Edit Preview Live site List

View mode

My Community Site

;' New document

Please select new document type:

[ Page (menu item)

‘¥ Blog

i Folder

#] Link an existing document

Switch

A

Search
Other
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2. Choose to Create a blank page using the Simple layout. For Page name, enter Home and click

Save.
212 Kentico
CMS Deskc Content | Mydesk
D Copy T up
New Delete bMove & Down

Content management

l:/'ﬁg'l My Community Site
(-G Files
|| Logan page
|| Search

Switch to Site Manager  Site:| My Community Site =] User: Global Administrater v5.0.3628

Administration
A & @ = | A
Edit Preview Live site List Search
View mode |l other
My Community Site

E‘- Save and create another

Page name: Home

(") Use page template ) Inheritfrom parent page @ Create a blank page

Layout name:

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells
Three columns Three columns (CSS) Top row, three columns,
bottom row

12
Simple

Simple layout with one web part zone.

0py this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

Simple

Two columns

Sign out

(2]

(]
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

Switch to Site Manager  Site:| My Community Site[=] User: Global

22 Kentico

1% CMS Desk Content My desk Tools Administration
Beow v | [ [Q @ 2 | L
New Delete = Move & Down Edit Preview  Live site List Search
Content management | View mode || other
l:‘l'i;] My Community Site Page  Design  Form | Properties
‘1‘@ Files General
- ]Home E Save
I_] Logon page i+
._] Search Template
Metadata Template
Categories Ad-hoc: Home " Select |
Menu -
Wt -ii: Save as new template...
Versions Q Inherit template
Related docs
Lried g [ ﬁ Edit template pro erties]
Security
Attachments Inheri: content
@ Use page template settings
@ Da notinherit any content
ﬂ (©) Selectinherited levels

4. In the pop-up Page template properties window, switch to the Layout tab and replace the original
layout with the following code:

<di v cl ass="subcontent D v">
<di v cl ass="zoneCent er HonePage" >
<di v class="centerLeft">
<ccl: CVBWebPar t Zone | D="zoneCenterLeft" runat="server" />
</ di v>
<div class="centerRi ght">
<ccl: CvBWebPar t Zone | D="zoneCenterRi ght" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>

<di v cl ass="cent er Hone" >
<div class="left">
<ccl: CvBWebPart Zone | D="zoneCent er BottonmLeft" runat="server" />
</ di v>
<div class="right">
<ccl: CvBWebPar t Zone | D="zoneCent er Bott onRi ght" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>

</ di v>
<di v cl ass="zoneRi ght">
<ccl: CvBWebPar t Zone | D="zoneRi ght" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>
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Click Save.
r& Page Templates -- Webpage Dialeg ﬁ‘
:.;/ Page template properties @

Templates » Ad-hoc: Home

General Layout Web parts Header Documents

E Save El Check out to file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\fdch91eb-ee8d-4486-
acac-156414878297.ascx to edit the ayout externaly.

) Use shared layout

Grid 2x¢2 cells

@ Use custom layout

<div class="subcontentDiv">
<div class="zoneCenterHomePage">
<div class="centerlefit">
<ccl:CMSWebPartZone ID="zoneCenterLeft" runat="server" />

»

< /dive
<div class="centerRight™>
<ccl:CMSWebPartZone ID="zoneCenterRight™ runat="server" />
< fdive
<div class="clear">snbsp;</div>

m

<div class="centerHome">
<div claga="left">
<ccl:CMSWebPartZone ID="zoneCenterBottomleft™ runat="server"™ />
</div>r
<div clasa="right">
<ccl:CMSWebPartZone ID="zoneCenterBottomRight™ runat="server" />
</divr
<div class="clear">snbap;</div>

</dive

http//localhost/kenticocms/CMSModules/PortalEngine/UlL/Pag Q.. Local intranet | Protected Made: Off

5. Switch to the Design tab. You should see an empty page with five web part zones. Let's start with
zoneRight, where the right side column with various info boxes will be placed. Click the Add web part (
1) icon of the zoneRight web part zone and choose the Membership -> Logon miniform web part.
Set the following properties of the web part, leave the rest of them as they are:

Display to roles: _notauthenticated

Logon failure text: Error logging in.

Web part container: Community Site - Red Box
Web part container title: Sign in

Click OK. The next web part to add is the handy Shortcuts web part, displaying shortcuts to various
actions and sections depending on the current context. Click the Add web part (4¥) icon again, choose
the Community -> Shortcuts web part and click OK. In the web part properties window, set the
following properties:

e Display Join/Leave the group link: disabled
e Display Friendship links: disabled

e Display Add to contact list link: disabled

e Display Add to ignore list link: disabled

e Display manage group link: disabled

e Display Sign in link: disabled
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e My messages path: /Members/{%UserName|(encode)true%}/Messages
My friends path: /Members/{%UserName|(encode)true%}/ Friends

My invitations path: /Members/{%UserName|(encode)true%}/Invitations
e Sign out path: /Home

Web part container: Community Site - Red Box

Web part container title: Shortcuts

Click OK. Let's go on with the scrolling news. This will be the Scrolling text web part set up so that it
displays news from the News section. The News section will be created later on in this guide. Click the
Add web part (4F) icon again, choose the Listings and viewers -> Scrolling text web part and click
OK. In the web part properties window, set the following properties:

e Path: /News/%

e Document types: CMS.News

e ORDER BY expression: NewsReleaseDate DESC
e Select top Ndocuments: 5

e Transformation: CMS.News.Preview

e Cache dependencies: nodes|{%currentsite.sitename|(tolower)%}/cms.news|all
e Width (px): 150

e Height (px): 150

e Script stop time (milliseconds):4000

e Web part container: Community Site - Blue Box
e Web part container title: Latest News

Leave the rest of the properties at their default values and click OK.

So now we have a web part displaying the latest five news items. Let's have a similar info box displaying
the latest groups. Again, the Groups section is not created yet, but we will get to it later in this guide.
Click the Add web part (%) icon again, choose the Community -> Groups viewer web part and click
OK. In the web part properties window, set the following properties:

e Disable view state: enabled

e Transformation name: Community. Transformations.GroupsPreviewList

e Show filter: disabled

e ORDER BY condition: GroupCreatedWhen DESC

e No record found text: There are currently no groups.

e Web part container: Community Site - Gray Box

e Web part container title: Latest Groups

e Content after: <div class="clear"></div> <div><a href="~/Groups.aspx">View all</a></div>

Leave the rest of the properties at their default values and click OK.

One more info box to go. This time, it will be displaying three latest registered site users. Click the Add
web part (4F) icon again, choose the Membership -> Users viewer web part and click OK. In the web
part properties window, set the following properties:

e Disable view state: enabled

e Transformation name: Community. Transformations.MembersPreviewList

e No record found text: There are currently no members.

Show filter: disabled

ORDER BY condition: UserCreated DESC

Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatarlD,UserCreated,
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UserName, AvatarGuid

Use default cache dependencies: enabled

Web part container: Community Site - Gray Box

Web part container title: Latest Members

Content after: <div class="clear"></div><div><a href="~/Members.aspx">View all</a></div>

Leave the rest of the properties at their default values and click OK.

That's us finished with the info boxes in this web part zone. However, we will place the sample poll
created in this chapter to the bottom of the web part zone. Click the Add web part () icon for the last
time, choose the Polls -> Poll web part and click OK. In the web part properties window, set the
following properties:

¢ Poll name: Continents
e Web part container: Community Site - Blue Box
e Web part container title: Poll

Click OK. That's us finished with the zoneRight web part zone. Now we can move on and populate the
other web part zones.

6. We will place the community_home_img.jpg image, which we uploaded earlier in this chapter, to
the zoneCenterRight web part zone. Click the Add web part (%) icon, choose the Text -> Editable
image web part and click OK. In the web part properties window, set the following properties:

e Alternate text: Community photo

Click OK.

Switch to the Page tab and click the Select link of the Editable image web part.

Community

Starter site

Home | || searcn

Shortcuts

My profie
Edit my profile
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Select the file from the content tree and click the Select link. Click Save to sawve the content of the
page.

|| Insert - Webpage Dialog [

@ Selectimage

Attachments | Content | Medialibraries  Web

=
l_\ﬂ New folder (l New file E List Tiles @ Thumbnails @
Site: | My Community Site E General
URL:  |/kenticocms/Files/community_home_img.aspx 1)
=% J My Community Site = =
o \
=5 Files Wwidth: |374 r3 g
¢-{3 button_joinnow Height 205

*. [ button_signin
i-[=] community_header_img
|kl community_home_img
-] Home
|| Logon page
-] Search

P—

| Select  Cance

http://localhost/kenticocms/CMSFormControls/Selectors/InserfimageOrMedia/Default.aspxioutput=url&amp:content=img&amp;documentid=415&am € Local intranet | Protected Mode: Off

7. The zoneCenterLeft web part zone will host the welcome text and links for sing-in and registration.
Click the Add web part (4) icon, choose the Text -> Editable text web part and click OK. You can
left all web part's properties at the default values and click OK.

8. Switch to the Page tab. Using the WYSIWYG editor, try to achieve the same result that you can see
in the screenshot below. You can find detailed description of the WYSIWYG editor's capabilities in
Kentico CMS Deweloper's Guide -> Content management -> WYSIWYG editor. However, you can see
the controls that you will use highlighted in the screenshot.
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You will need to write the heading and change its Format to Heading 1. Then you will need to add a
table with one row and two columns. Set the Border size property of the table to 0. You will insert the
images into the table. Then you will select each of the images and add a hyperlink to the Logon page
to it. Then you will have to select both of the images in the table and choose the center alignment.
Finally, you will have to type the remaining text and set its Format to Normal.

Page Design Form Properties E
E Save Spell check
£ 5 Souce | [ |@fo c[M%|E I8 I 1% ciEE|EE{El==={ga ¢
FE=R-os2:iag/olxs

‘ Style o - | Format | Heading 1 - [Font - | Size = E T-' %'E m

The changes were saved.

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is admini: with blank p:

Current user: Global Administrator {administrator) | Edit my profile | Inbox | Sign out

Community

Starter site

Home . | | | Search

e oo

fi -
| Welcome to our community Sl
: My profile
! | ‘ Edit my profile
| o 0 oW
; —SRERTIT—. N ST W) My messages
! A My friends
! This community site is a virtual point for those who like traveling, |= My invitations

|| adventrure, discovering new places, meeting new people and al
|| the things related to it. If you are interested in this sort of
things, don't hesitate and join now!

Create a new group
Create a new blog
Sign out

e —————————————— - Latest News
No data found

9. Two web part zones are remaining. In the zoneCenterBottomLeft, we will place a repeater displaying
extracts from the latest blog posts. The Blogs section from that the extracts will be displayed will be
created later in this guide. Click the Add web part (%) icon, choose the Listings and viewers ->
Repeater web part and click OK. Set the following properties of the web part, leave the rest of them at
their default values:

¢ Disable view state: enabled

e Path: /Blogs/%

e Document types: CMS.BlogPost

¢ ORDER BY expression: BlogPostDate DESC

e Select top N documents: 6

e Transformation: Community. Transformations.HomeBlogPostsCenter

e Cache dependencies: nodes|{%CurrentSite. SiteName|(tolower)%}|cms.blogpost|all
e No record found text: There are currently no posts.

e Web part container: Community Site - Blue Box Light

e Web part container title: Latest blog posts

Click OK.

10. Last but not least, we will place a similar repeater to the zoneCenterBottomRight web part zone.
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This repeater will be displaying latest forum posts. The Forums section will be created later in this
guide. Click the Add web part () icon, choose the Forums -> Forum posts viewer web part and
click OK. Set the following properties of the web part, leave the rest of them at their default values:

e Disable view state: enabled

e Top N: 6

e Order by: PostTime DESC

e Web part container: Community Site - Blue Box Light
e Web part container title: Latest forum posts

Click OK.

11. You hawe just finished creating the Home page. Most of the web parts are not displaying any
content because the related sections of the web are not created yet. Howewer, as you will be creating
these sections further in this guide, you will see the related content appear on the home page. In the
Design tab, the page should look as in the following screenshot.
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|V /Home - page template: ad-hoc

P

= zoneCenterleft I*

= zoneCenterRight

* zoneRight I*

|

v editabletext {3

e to our
community

[This community site is a virtual meeting point for those who like
traveling, adventure, discovering new places, meeting new people and
all the things related to it. If you are interested in this sort of things,
don't hesitate and join now!

= zoneCenterBottomLeft I*

¥ EditableImage e

= zoneCenterBottomRight

* logonminiform i:eo}
v Shortcuts {23

Shortcuts

My profile
Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog

Sign out

¥ repeater {:e}

¥ ForumPostsViewer {

= ScrolingText {_Ec}

Latest News

Mo data found

-~

¥ GroupsViewer ,ﬂeﬁ
Latest Groups

There are currently no groups.

View all

¥ UsersViewer §

Latest Members

There are currently no
members.

Wiew all
‘
Pol

Which continent are you
planning to visit during
your next trip?

_ Africa

! America

_' Asia

_ Australia

_' Europe
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12. The last step is to save the page as a page template for further reusability. Switch to the Properties
-> Template tab and click the Save as new template link. Enter the following details:

Template display name: My Community Site - Home page
Template code name: MyCommunitySite. HomePage
Template category: My Community Site templates

Template description: some text describing the page template

Click OK.
Switch to Site Manager  Site: My Community Site User: Global Administrator v5.0.
22 Kentico v ty Site [+
‘.‘ CMS Desk Content My desk Tools Administration
=) o U =3 —
B G O= v |3 @ @ 5], ]
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
Iﬂ'!‘b‘_."i My Community Site Page Design  Form | Properties
@ G Files General
[ 1Home E Save
= URLs
i L] Logon page
|| search Template
Metadats Template
Categories Ad-hoc: Home Select
Menu 1 5 h
P - S -- Web Dial
Save 34 e terpiaie & Page P ave as new ‘ebpage [halog u
Workflow : grrm—— —
: H —
3 - Save as new e template
Versions € Inherit template {"4 pag P
Related docs
Edittemplate properties
Linked docs E Template display name: My Community Site - Home page
Security || Template code name:  MyCommunitySite HomePage
Attachments Inherit content || Template category: My Community Site templates E
@ Use page template setting —
- This is the Home page of My -
) Do notinherit any content Community Site
EI ) Selectinherited levels Template description
http://localk € Local intranet | Protected Mode: Off
\
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3.7

Creating a starter page template

Many pages on the site will have the same layout and contain the same web parts. To prevent repeating
the same dewvelopment tasks again and again, it is a good practice to create a starter page template.
This template will contain the required layout with two web part zones and three web parts - Editable
text for heading in zonelLeft web part zone and the Logon mini form and Shortcuts web parts in
zoneRight web part zone.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

Switch !
232 Kentico S
#1% CMS Desk Content My desk Toolz Administration
(=) > C U
)& B #w I3 [ @ 2 | P
New ) Delete |= Move & Down Edit Preview Live site List Search
Content management | iew mode | COther
(I My Community Site Wy Community Site
.2 Files \
= New document
i[] Home |
i-[] Logon page
‘[ ] search Please select new document type:

|1 Page (menu item)

‘¥] Blog

& Folder

£] Link an existing document
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2. Choose to Create a blank page using the Simple layout. For Page name, enter starter page

template and click Save.

232 Kentico

CMS Desk Content | Mydesk

Administration

Hecopy W 7 @ & = ye

New Delete [=bMove & pown Edit Preview Live site List Search
Content management | View mode || Other
l:/'ﬁg'l My Community Site My Community Site
S
()5 Files
B Home E‘ Save and create another
|| Logon page
-] Search Page name: starter page template

() Use pagetemplate ) Inheritfrom parent page @ Create a blank page

Layout name:

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells
ﬂ
Three columns Three columns (CSS) Top row, three columns,
bottom row

12
Simple

Simple layout with one web part zone.

Copy this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

Switch to Site Manager  Site:| My Community Site =] User: Global Administrater v5.0.3628

Simple

Two columns

Sign out

(2]

(]
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3. Switch to the Properties -> Template tab and click the Edit template properties link.

22 Kentico

1% CMS Desk Content My desk Tools Administration
—. — = i — -
B [ Ber ®w | 32 [q @ H || L
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
l:‘l'!‘l_‘;] My Community Site Page  Design  Form | Properties
'1“;3" Files General
] Home E Save
Do URLs
/] Logon page
a Search Template
g a starter page template Metadata Template
Categories Ad-hoc: starter page template
Menu .
=]
= plate...
Wolne = Save as new template
Versions @ Inherit template
Related docs
Edit template properties
Linked docs [ E ]
Security
Attachments Inherit content
@ Use page template settings
) Do notinherit any content
H ©) Selectinherited levels

Switch to Site Manager

Site: | My Community Site[=] User: Global

Select

4. In the pop-up window, switch to the Layout tab and replace the original layout with the following code:

<di v cl ass="subcont ent D v">
<di v cl ass="zoneCent er Hone" >
<ccl: CvBWbPart Zone | D="zoneCenter" runat="server" />
</ di v>
<di v cl ass="zoneRi ght">
<ccl: CvBWebPar t Zone | D="zoneRi ght" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>

© 2010 Kentico Software



Part 2 185

Click Save.

' ™
& | Page Templates -- Webpage Dialog ﬁ
=

=

Page template properties @
Templates ¥ Ad-hoc: starter page template

General Layout Web parts Header Documents

E}l Check outto file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\57331e54-4040-410b-
842f-d96b7aefScec.ascx to edit the layout externally.

@ Use shared layout

Grid 22 cells

@ Use custom layout

<div class="subcontentDiv"> -
<div class="zoneCenterHome">
<ccl:CMSWebPartZone ID="zoneCenter” runat="server"” />
</div>
<div class="zoneRight">
<ccl:CMSWebPartZone ID="zoneRight™ runat="server™ />
</div>
<div class="clear">snbap;</div>
</div>

http//localhost/kenticoems/CMSModules/PertalEngine/UL/Pag Q. Lecal intranet | Protected Mode: Off

" 4

5. Switch to the Design tab. You can see a page layout with two web part zones - zoneCenter and
zoneRight. This layout is common to many of pages that we will create on the site. In the zoneCenter
web part zone, all of the pages will contain a heading, provided by the Editable text web part. We will
add the web part now. Click the Add web part (%) icon, choose the Text -> Editable text web part
and click OK. In the web part properties window, set the following properties:

e Editable region type: Text box
e Content before: <hl class="header">
e Content after: </h1>

Click OK.

6. In the zone zoneRight web part zone, two web parts will be common to all the pages. The first of
them will be the Logon mini form. Click the Add web part () icon of the zoneRight web part zone
and choose the Membership -> Logon mini form web part. Set the following properties of the web
part, leave the rest of them as they are:

Display to roles: _notauthenticated

Logon failure text: Error logging in.

Web part container: Community Site - Red Box
Web part container title: Sign in
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Click OK.

7. The next web part common on all the pages is the handy Shortcuts web part, displaying shortcuts to
various actions and sections depending on the current context. Click the Add web part () icon again,
choose the Community -> Shortcuts web part and click OK. In the web part properties window, set the
following properties. Leave the rest of the properties at the default values:

e Display Join/Leave the group link: disabled
e Display Friendship links: disabled

e Display Add to contact list link: disabled

e Display Add to ignore list link: disabled

e Display manage group link: disabled

e Display Sign in link: disabled

e My messages path: /Members/{%UserName|(encode)true%}/Messages
e My friends path: /Members/{%UserName|(encode)true%}/ Friends

e My invitations path: /Members/{%UserName|(encode)true%}/ Invitations
e Sign out path: /Home

e Web part container: Community Site - Red Box

e Web part container title: Shortcuts

Click OK.

When you are finished, the page in Design tab should look as in the following screenshot.

|' [starter page | - page late: _StarterT I f|

v zoneCenter o

= zoneRight o
v editabletext {3 =
+ logonminifarm Qg‘:}
-
Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out
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8. We will save the page template so that it can be reused later. Switch to the Properties -> Template

tab and click the Save as new template link. Enter the following details into the pop-up dialog:

Click OK. Click Save.

Template display name: _StarterTemplate
Template code name: _StarterTemplate
Template category: My Community Site templates
Template description: enter some text describing the page template

-‘:’- Kel'lti.co Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.36
1% CMS Desk Content | Mydesk  Tools  Administration
= = U =3 r—
B [m Boer fw | 3 [g 2 L |
New Delete = Move & pown | Edit  Preview Live site  List ‘ Search |
Content management | View mode | other |
=) My Community Site page  Design  Form | Properties
B @ G General
-] Home E Save
= URLs
-] Logon page
a Search Template
a starter page template Metadata Template
Categories Ad-hoc: starter page template Select
Menu ’ N
& | Page template - Save as new -- Webpage Dialog ﬂ
Workflow
Versions @ et ool /=g Save as new page template
Related docs
E Editternplate properties
Linked docs Template display name: |_StarterTemplate
Security Template code name:  |_StarterTemplate
Attachments |
- Inherit content Template category: My Community Site templates |z|

@ Use page template settings
) Do natinherit any content
(@) Selectinherited levels

Template description:

This is the starter page template
It will be

of My Community Site.
used as the starting point for

development of many pages on the

site.

ok | Cancel |

-

http://localk € Local intranet | Protected Mode: Off
A

9. As the page template is now saved, we do not need the page created in this chapter anymore. Delete
the page from the content tree. The page template will remain saved and can be used in the future.

@ Copy

= Move

New | Delete

T up |
4} Down |

ontent management |

dbg! My Community Site
o
‘[ Home

‘.|| Logon page

a Search

Files

a starter page template
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3.8
3.8.1

Creating the Blogs section

Creating the Blogs page

In this part of the guide, we will create the Blogs section. This section will allow users to read blog posts
from any number of blogs. Users will also be able to create a new blog directly on the site, as well as
add new blog posts. Most of this functionality is is achieved using the User contributions module web
part. For more information about the module, please refer to Kentico CMS Dewveloper's Guide -> Module
User contributions. Detailed information about the Blogs module can be found in Kentico CMS

Deeloper's Guide -> Module Blogs.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

Switch
232 Kentico e
’l\ CMS Desk Content My desk Tools Administration
=] = C U
1) & Bew ®w | 3 [q =2 | P
New JDelete = Move & pown Edit Preview Live site List Search
Content management | View mode | Other
=& /My Community Site My Community Site
-2 Files Y
iy New document
| Home =
I_| Logon page
‘..[[] Search Please select new document type:

| ] Page (menu item)

‘T Blog

i Folder

& Link an existing document
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2. We will use the starter page template created in this chapter as the starting point for this page.
Choose the My Community Site templates -> _StarterTemplate. For Page name, enter Blogs and

click Save.

Switch to Site Manager Site: My Community Site User: Global Administrator v5.0.3688
.3!:_ Kentico y y Site[]
1

CMS Desk Content | Mydesk  Tools  Administration

[ Copy T up w [ZJ = /O

New Delste = Move & Down Edit  Preview Livesite  List Search
Content management View mode Other
=] é_/)My Community Site My Community Site
(28 Files

.[2 Home E‘ Save and create another Spell check

-] Logon page

|| search Page name: Blogs
@ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates Template name:

) Articles

: j Blank pages for widgets
H Blogs

Community Site

Corporate Site ASPX

E-commerce
Events _StarterTemplate My Community Site -
Home page
FAQs
Forums
H General

Home pages
5 Images
Job openings
Knowledge base
Master templates
Membership and security
Message boards
My Community Site templates
News

My Community Site -
Search page

Newsletter

Offices

Press releases

Products

Templates with editable regig

La) wiki _StarterTemplate

Q
Q
Q@
QY
Q
=]
Q
=1
Q
Q@
]
=]
=]
Q
=1
Q
Q@
QY
Q
=]
Q
=1

ly C ity Site -

Logon Page

Sign out

ity Site -

Master Page

This is the starter page template of My Community Site. It will be used as the starting point for development

e < of many pages on the site.

(-]
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3. Go to the Properties -> Template tab and click the Save as new template link. Enter the following

details in the pop-up dialog:

Template code name: MyCommunitySite.Blogs

Click OK. Click Save.

=32 Kentico
'l\ CMS Desk Content My desk Tools Administration

Template display name: My Community Site - Blogs

Template category: My Community Site templates
Template description: some text describing the page template

Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.36!

:‘x' D Copy i up | j @ % | })

New Delete |=bMove & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
= ;“_,3 My Community Site Page Design Form Properties
~|l[Blogs General
(-G Files
= URLs
| Home
. a Logon page Template
1 a Search Metadata The changes were saved.
Categories Template
Menu StarterTemplate Select
Workflow ' N
X & | Page template - Save as new -- Webpage Dialog ﬂ
Versions
Related does @ Inherit template -'.-::'E Save as new page template
Linked docs .
@/ Clone template as ad-hoc
Securif &f " "
& Template display name: My Community Site - Blogs
Attachments i
E Edit templale properties Template code name:  |MyCommunitySite Blogs
Template category My Community Site templates [=]
Inherit content This is the starter page template =
@ Use page template settings of My Community Site. It will be
_ . ) used as the starting point for
) Do notinheritany content Template description

() Selectinherited levels

development of many pages on the
aice.

[ ok [ cancel |

http://localk € Local intranet | Protected Mode: Off

4. On the same tab, click the Edit template properties link. In the pop-up Page template properties
window, switch to the Layout tab and replace the original layout with the following code:

<di v cl ass="subcont ent D v">
<di v cl ass="zoneCent er Bl og" >
<ccl: QvBWbPart Zone | D="zoneCent er"
</ di v>
<di v cl ass="zoneRi ght">
<ccl: CVBWebPart Zone | D="zoneRi ght" r
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>

runat ="server" />

unat ="server" />
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Click Save.

' A’
& | Page Templates - Webpage Dialog ﬁ

=/ Page template properties (2]
Templates » My Community Site - Blogs

General Sites Layout Web parts Header Documents

|E Save @J Check out to file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSTemplateLayouts\ MyCommunitySite\Blogs.ascx
to edit the kyout externally.

) Use shared layout

Grid 242 cells

@ Use custom layout

<div class="subcontentDiv"> -
<div class="zonelCenterHome">
<ccl:CMSWebPartZone ID="zoneCenter" runat="server" />
</dive
<div class="zoneRight">
<ccl:CMSWebPartZone ID="zoneRight™ runat="server" />
</fdive
<div class="clear">rsnbsp;</div>
< fdive

http://lecalhost/kenticocms/CMSModules/PortalEngine/UL/Pag €L Local intranet | Protected Mode: Off

" =

5. Switch to the Design tab. You should see two web part zones - zonelLeft and zoneRight - just as
you defined by the layout above. Let's add web parts to the zoneRight web part zone first.

Below the Shortcuts menu, the Tag cloud web part will be displayed. After clicking a tag in the web
part, users will be redirected to the /Blogs/Blog-posts page, where a list of blog posts tagged with the
clicked tag will be displayed. Click the Add web part (3F) icon again, choose the Tagging &
categories -> Tag cloud web part and click OK. In the web part properties window, set the following
properties:

Show for document types: CMS.Blog;CMS.Menultem
e Tag group name: Blogs

e Document list URL: /Blogs/Blog-posts

Web part container: Community Site - Orange Box
Web part container title: Tag cloud

Click OK.

Below the Tag cloud, we will place an info-box displaying links to 3 latest blogs on the site. This will be
achieved using the Repeater web part. Click the Add web part (4) icon again, choose the Listings
and viewers -> Repeater web part and click OK. In the web part properties window, set the following
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properties:

e Web part control ID: LatestBlogs

e Disable view state: enabled

e Show for document types: CMS.Menultem

e Path: ./%

e Document types: CMS.Blog

e Select top Ndocuments: 3

e Transformation: Community.Transformations.BlogsListRight

e Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blog|all

e Web part container: Community Site - Gray Box

e Web part container title: Recent blogs

e Content after: <a href="~/Blogs/Blog-list.aspx" title="All blogs" class="viewAllBlogs">View all
blogs</a>

Click OK.

Next on is another similar info box. This one will be displaying latest blog comments. Click the Add
web part (3) icon again, choose the Blogs -> Blogs comments viewer web part and click OK. In the
web part properties window, set the following properties:

e Transformation name: Community. Transformations.BlogComments

e Selected columns: CommentPostDocumentlD,CommentDate,CommentUserName, CommentText
Hide if no record found: disabled

e No record found text: There are currently no comments.

Web part container: Community Site - Gray Box

Web part container title: Latest blog comments

Click OK.

The last web part in the right column will be the Posts archive web part. This web part will be displaying
links to the latest blog months. The web part will not be displayed on this page, but only when a blog,
blog month or blog post is displayed. Click the Add web part () icon again, choose the Blogs ->
Post archive web part and click OK. In the web part properties window, set the following properties:

e Show for document types: cms.blog;cms.blogmonth;cms.blogpost
Hide if no record found: disabled

¢ No record found text: No data in archive.

e Web part container: Community Site - Gray Box

e Web part container title: Post archive

Click OK.
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The zonelLeft web part zone is finished. You can see the desired appearance in the screenshot below.
Notice that some of the web parts are not displaying any content yet. This is because there is no
content to be displayed yet, but when the content is added, all the web parts should work fine. You will
see later on in this guide.

= zoneRight o

¥ |ogonminiform @
¥ Shortouts @ |

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

T TagCloud @
v LatestBlogs @

|' BlogsCommentsiewer @
Latest blog comments

There are currently no
comments.

+ PostéArchive @ ‘

We will move to the zoneCenter web part zone now. First, let's enter the heading text. Switch to the
Page tab and enter Recent blog posts into the text box representing the web part. Click Save.

_____________________

The heading that we've just added will be displayed only on the title page. When a content of a blog is
displayed, the heading will be replaced by breadcrumbs of the same size. These breadcrumbs will be
clickable and will indicate the current position in the blogs hierarchy. Click the Add web part (4F) icon
again, choose the Navigation -> Breadcrumbs web part and click OK. In the web part properties
window, set the following properties:

e Show for document types: CMS.BlogMonth;CMS.BlogPost;CMS.Blog
e Starting path: /Blogs

e Document types: CMS.Blog;CMS.BlogMonth;CMS.Menultem

e Content before: <div class="blogsTopBreadcrumbs">

e Content after: </div>

Click OK.
Now we have the heading ready, so let's get to the three web parts enabling users to edit blog

properties, create blog posts and edit blog posts directly on the live site. As mentioned abowe, this
functionality will be achieved using the User contributions module web parts.
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The first one will be used for blogs editing. Click the Add web part (3) icon again, choose the User
contributions -> Edit contribution web part and click OK. In the web part properties window, set the
following properties:

Web part control ID: EditBlog

Show for document types: CMS.Blog
Alternative form name: CMS.Blog.EditBlog
Edit button label: Edit blog

Allow delete: disabled

Content before: <div class="EditPanel">
Content after: </div>

Click OK.

The second of the User contributions web parts will be used to enable users edit blog posts. Click the
Add web part (4) icon again, choose the User contributions -> Edit contribution web part and click
OK. In the web part properties window, set the following properties:

Web part control ID: EditBlogPost

Show for document types: CMS.BlogPost
Alternative form name: CMS.BlogPost.EditBlogPost
Content before: <div class="EditPanel">

Content after: </div>

Click OK.

The last of the three User contributions web parts will enable adding of new blog posts. Click the Add
web part (4F) icon again, choose the User contributions -> Contributions list web part and click OK.
In the web part properties window, set the following properties:

e Web part control ID: NewBlogPost

e Show for document types: CMS.Blog

e Path for new documents: "." (do not include the parentheses, these are only indicating that you
should enter the dot only)

Allowed new document types: CMS.BlogPost
Alternative form name: CMS.BlogPost.EditBlogPost
Display list of documents: disabled

New item button label: New blog post

List button label: My blog posts

Allow delete: disabled

Content before: <div class="EditPanel">

Content after: </div>

Click OK.

Now we will add two repeaters with similar settings. The first repeater will be displayed only on Blog
month documents and will display a list of all blog posts in the month, paged by 5 posts. Click the Add
web part (3F) icon again, choose the Listings and viewers -> Repeater web part and click OK. In the
web part properties window, set the following properties:

e Web part control ID: rptMonthPosts
e Show for document types: cms.blogmonth
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Path: ./%

Document types: CMS.BlogPost

Transformation: Community.Transformations.BlogsAllBlogsPosts

Selected item transformation: Community. Transformations.BlogPostDetail
Enable paging: enabled

Page size: 5

Cache dependencies: nodes[{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

The second repeater will display a list of 5 latest blog posts on the Blogs title page (the page that you
are creating now) and on a particular blog's title page. The repeater will also be used for displaying
particular blog posts. Click the Add web part () icon again, choose the Listings and viewers ->
Repeater web part and click OK. In the web part properties window, set the following properties:

Web part control ID: rptLatestPostsAllBlogs

Disable view state: enabled

Show for document types: CMS.Blog;CMS.BlogPost;CMS.Menultem

Path: ./%

Document types: cms.blogpost

Order by expression: BlogPostDate DESC

Select top N documents: 5

Transformation: Community.Transformations.BlogsAllBlogsPosts

Selected item transformation: Community. Transformations.BlogPostDetail
Cache dependencies: nodes[{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

Three web parts remaining. The next one will be the Content rating web part. It will be displayed only
for blog posts and will enable users to rate the content of the blog posts. Click the Add web part ()
icon again, choose the Content rating -> Content rating web part and click OK. In the web part
properties window, set the following properties:

e Show for document types: CMS.BlogPost
e Content before: <div class="blogContentRating">
e Content after: </div><br />

Click OK.

The Social bookmarking web part will be placed below the Content rating web part and will enable
users to bookmark blog posts via a large number of social bookmarking senices. Click the Add web
part () icon again, choose the Community services -> Social bookmarking web part and click OK.
In the web part properties window, set the following properties:

e Show for document types: CMS.BlogPost

e Bookmarking services: enable the check-boxes for all social bookmarking senices that you want to
be available

e Content after: <br /><br />

Click OK.

The last web part on the page will also be displayed only for blog posts. It is the Comments view web
part, enabling users to post blog comments and displaying the comments. Click the Add web part ()
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icon again, choose the Blogs -> Comment view web part and click OK. In the web part properties

window, set the following properties:

e Show for document types: CMS.BlogPost
e Check permissions: disabled
e Comment separator: <div class="PostCommentSeparatorLine">&nbsp;</div>

e Show edit button: enabled

e Enable user pictures: enabled

e User picture width: 66
e User picture height: 66

e Content before: <div class="blogComments">

e Content after: </div>

Click OK.

In the screenshot below, you can see the desired appearance of the page in Design tab. As mentioned
abowe, no content is displayed as there is no content (no blogs, no posts, ...) on the site yet. Howeer,

as the site gets populated with content, all web parts should be fully functional.

|V /Blogs - page template: My Community Site - Blogs

B

v EditBlogPost {13
* MewBlogPost @Z‘!

¥ rptMonthPosts @,!

&

¥ ContentRating {53

¥ SocdalBookmarking @,!

4
b=
=3
[
il
t
T
]
[
£
=)
a8
]

¥ Commentview ’,:e_:‘,!

= zoneCenter

= ¥ zoneRight *
v editabletext ”

editabletext {5 pOStS  logonminiform ig‘,!

i {v Shorteuts
¥ breadcrumbs {53 Sl |:Ill'|]:u|:5“g‘z‘g
~ Edittlog 31:31‘3 My profile

Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

+ TagCloud @,!
+ LatestBlogs ’{é‘}

|V BlogsCommentsViewer ’;y}|
Latest blog comments

There are currently no
comments.

¥ PostArchive ";Z! ‘
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3.8.2

Creating the Create page

The Create page is where users are redirected when they want to create a new blog. The page is
accessible via the Shortcuts menu, after clicking the Create a new blog link. In the following example,
you will learn how to create the page. We will use the My Community Site - Blogs page template
created in the previous chapter so that we don't have to waste time by adding the same web parts
again.

1. Go to CMS Desk, select the Blogs page in the content tree and click the New icon. Choose the
Page (menu item) document type.

Switch
232 Kentico S
#1% CMS Desk Content My desk Tools Administration
Ci U e
) L Bl W 4 & [ = e
New | Delete |= Move & pown | Edit Preview Live site List || Search |
Content management | View mode Other
= ) My Community Site » Blogs

‘[ ||Blogs oy

: i New document

.;‘,--'\5,,“‘ Files L

[ Home

‘.[] Logon page Please select new document type:
‘[ ] search

|| Page (menu item)

2. Choose the My Community Site templates -> My Community Site - Blogs page template. For
Page name, enter Create and click Save.

Switch to Sits Manager  Site:| My Community Site =] User: Global Administrator 450 3688 sign out
232 Kentico v & ste[~]
#1%  CMS Desk Content | Mydesk  Tools  Administration
[leosy e A4 e = »F (2]
New Delete bMove & Down | | Edt  Preview Livesite List | Search | '
Content management | View mode Other

=

=] {-_;l My Community Site » Blogs

||/Blogs =
&G Files -1 Save and create another = Spell check
|| Home
|1 Logon page Page name: Create
-] Search
@ Use page template () Inheritfrom parent page (") Create a blank page
(53 All page templates Template name:
i) Articles
.':'Q' Blank pages for widgets
&) Blogs

::‘}' Community Site
&5 Corporate Site ASPX
-3 E-commerce
&) Events
- FAQs
ﬂ &) Forums
| ) General
_":‘}‘ Home pages
;‘j‘ Images
i3 Job openings
::'Q' Knowledge base
3y Master templates
&) Membership and security
&) Message boards
i) [My Community Site templates
&) News
& Newsletter
&) Offices
& Press releases
i) Products

_StarterTemplate My Community Site -

Home page

My Community Site -

My Community Site -
Blogs Logon Page

My Community Site -
Master Page

My Community Site -
Search page

.':'Q' Templates with editable regio
&) wiki

< i ] »

My Community Site - Blogs
This is the Blogs page of My Community Site.
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3. Now we hawe the Create page created. It uses the My Community Site - Blogs page template. If we
started making modifications to the page now, the page template would also get modified, so that the
Blogs page would be modified too. To prevent this, we will have to save the page as a new page template
before the actual modification. Switch to the Properties -> Template tab and click the Save as new

template link. Enter the following details in the pop-up dialog:

Template display name: My Community Site - Blog creation
Template code name: MyCommunitySite.BlogCreation
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

i,
- -
'l\ CMS Desk Content My desk Tools Administration

:‘x' E} Copy i up | j @ E | })

Kentlco Switch to Site Manager  Site: My Community Site EI User: Global Administrator v5.0.36!

New Delete |=»Move & Down | Edit Preview Live site List | Search |
Content management | View mode | other |
=] ;“_,'3 My Community Site Page  Design  Form | Properties
=-E Blogs General
- || Create E Save
L URLS
[=)-<J Files
] 3 Home Template
-] Logon page Metadata Template
-] search Categories Iy Community Site - Blogs ﬁ
Menu 1 d B B
‘Save 35 EW tempiate & | Page template - Save as new -- Webpage Dialog ﬂ
Workflow
Versions ¥ el Gk /4 Save as new page template
Related docs .
. 4/ Clone template as ad-hoc
Sl ~ Template display name: |My Community Site - Blog creation
e E Edittemplate properies Template code name: | MyCommunitySite.BlogCreation
AutacuE Template category: My Community Site templates E|
Inherit content This is tl'_\e hl?g creation page of =«
H @ Use page template settings My Community Site.

) Do natinheritany content Template description
) Selectinherited levels

[ ok | cancel |

http:/{localk € Local intranet | Protected Mode: Off
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4. Now switch to the Design tab. Because the page template already contains some web parts that we
will need on the page, we can focus on deleting the not-needed ones first. You can delete a web part by
opening the web part's context menu (down-pointing arrow on the left) and selecting the Remove
command.

@ Configure
o

4 Down ...

i= Move to zone ..,
&% Duplicate web part

I€ Remove

From the zoneRight web part zone, delete the Logon miniform, Post archive and Blog comments
viewer web parts.

5. We will add two more web parts to this web part zone. The first one will be a repeater displaying the
current user's blogs. Click the Add web part (%) icon of the zoneRight web part zone and choose the
Listings and viewers -> Repeater web part. Set the following properties of the web part, leave the rest
of them as they are:

Web part control ID: repeaterYourBlogs

Path: /Blogs/%

Document types: CMS.Blog

ORDER BY expression: DocumentCreatedWhen DESC
WHERE condition: NodeOwner={%CurrentUser.UserID%}'
Transformation: Community. Transformations.BlogsListRight
No record found text: You have currently no blogs.

Web part container: Community Site - Orange Box

Web part container title: Your blogs

Click OK.

The second web part that we will add to the zoneRight web part zone is the Users viewer. We will set it
up so that it displays the four most active bloggers on the site. Click the Add web part (%) icon and
choose the Membership -> Users viewer web part. Set the following properties of the web part, leave
the rest of them as they are:

Web part control ID: TopBloggers

Transformation name: Community. Transformations.MembersPreviewList
Hide if no record found: disabled

No record found text: There are currently no bloggers.

Show filter: disabled

ORDER BY condition: UserBlogPosts DESC

Select top N members: 4

Use default cache dependencies: enabled

Web part container: Community Site - Blue Box

Web part container title: Top bloggers

Click OK.
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Now that you have the web parts in place and configured, let's just reorder them by dragging and
dropping. In the result, they should be ordered as in the screenshot below:

¥ zoneRight a9k

w shortcuts {8 !

Shortcuts

My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sian out

Top bloggers

Sort by: User name Activity
Admin
l Gender: N/A
Age: 0

6. In the zoneCenter web part zone, we will need only the Editable text web part at the top, hence you
canremove all the other web parts in this web part zone. Switch to the Page tab and enter Create
new blog into the web part's text box. Click Save.

_____________________

7. Switch back to the Design tab. You should see the heading displayed in the appropriate font size.
The rest of the zoneCenter web part zone will host only another Editable text web part displaying
some info text and the New blog web part. Click the Add web part () icon and choose the Text ->
Editable text web part. You can leave all properties of the web part at their default values and click OK.
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Switch to the Page tab and enter some info text into the web part's text area. You can use the following
sample text:

You can create your new blog by entering the required details into the fields
bel ow. You will be able to change the entered data later. After submtting these
details, you will be able to edit your blog's properties or start bl ogging

i mredi atel y.

Click Save.

E ¥ou can create your new blog by entering the required details into the fields below. You will be able to change the entered data later. After
| submitting these details, you will be able to edit your blog's properties or start blogging immediately.

m

8. Switch back to the Design tab. Let's finish the page by adding its main part - the New blog web part.
Click the Add web part (4) icon and choose the Blogs -> New blog web part. Set the following
property of the web part, leave the rest at their default values:

e Blog parent path: /Blogs

Click OK. You hawe just finished creating the blogs creation page. In Design tab, it should look as in the
following screenshot.
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|V /Blogs/Create - page template: My C ity Site - Blog

B

Blog name:

EBlog description:

3.8.3 Creating the Blog list page

w zoneCenter e +‘
¥ zonel

v editabletext (i3 blog i ¥ Shorteuts {63 '—L

Shortcuts
blog by entering the required details into the fields below. You will be able to change the entered data later. After submitting M_\"__ profile

" O able to edit your blog's properties or start blogging immediately. Edit my profile
i *‘”3 Vi fnds
My invitations

Create a new group
Create a new blog
Sign out

Top bloggers

Sort by: User name Activity

Admin

Gender: NfA
Age: 0

The Blog list page displays a list of all blogs on the site. This functionality will be achieved using the
Repeater web part. The page is accessible from the Recent blogs repeater on the Blogs title page, by

clicking the View all blogs link.

1. Go to CMS Desk -> Edit mode, select the Blogs page from the content tree and click New.

212 Kentico

#1% CMS Desk Content My desk  Tools Administration

[ Copy T up . @ [f]

New |Delete |=»Move & Down Edit Preview Live site List
Content management iew mode
BR4F] My Community Site » Blogs

Blogs >

=4 New document
<] Create

._| \___. Files

: "._| Home Please select new document type:

] Logon page
.| ] search

|| Page (menu item)

Switch ©

)3
Search
Other
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2. We will use the page template from the previous chapter so that we can save time by eliminating
adding some identically configured web parts. Choose the My Community Site templates -> My
Community Site - Blog creation page template. For Page name, enter Blog list and click Save.

Switch to Site Manager
212 Kentico
1% CMSs Desk Content | Mydesk  Took  Administration
) Dewr 4w | 3 [q =N
New Delete = Move & pown Edit  Preview Livesite  List Search
Content management | View mode || other
=] n_;_;l My Community Site » Blogs
(=11l |Blogs
..[3) Create E‘ Save and create another Spell check
(-5 Files
|| Home Page name: Biog list
--|_| Logon page
[ search @ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates Template name:
&) Articles
;-:i Blank pages for widgets
. Blogs

: ;ﬂ Community Site

] ;ﬂ Corporate Site ASPX

i) E-commerce

& Events _StarterTemplate
-3y FAQs

E j Forums

) General

: ;ﬂ Home pages

iy Images

;‘J Job openings

) Knowledge base

T“l Master templates My Community Site -
©J Membership and security Logen Page
i.:4) Message boards

: ;ﬂ My Community Site templates

L) News

;‘J Newsletter

L) Offices

;‘] Press releases

: j Products

i.:4) Templates with editable regio

My Community Site -
Blog creation

My Community Site -
Master Page

La) wiki My Community Site - Blog creation

Site:| My Community Site[+| User: Global Administrator v5.0.2688

=

My C ity Site -

C

ity Site -

Blogs

My Community Site -
Search page

This is the blog creation page of My Community Site.

My

Home page

Sign out
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3. Switch to the Properties -> Template tab. We will save the page as a new page template so that
the modifications made to this page will not be reflected on the Blog creation page. Click the Sawe as
new template link and enter the following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Blog list
Template code name: MyCommunitySite.BlogList
Template category: My Community Site templates
Template description: some text describing the page template

Site: My Community Site EI

Select

User: Global Administrator v5.0.36

| Page template - Save as new -- Webpage Dialog

;1__.[ Save as new page template

Template display name. My Community Site -

Template code name:

232 Kentico
#1% CMS Desk Content | Mydesk  Tools  Administration
E = C u B )
S [ B R 4  [d pl
New Delete |= Move & Down | Edit Preview Live site List ‘ Search |
Content management | View mode || other
(=& ) My Community Site Page  Desgn  Form | Properties
c-a ?_!;:IS - General
og lis
™ URLs
|| Create
54 Files Template
1] Home Metadata Templte
[l Logon page Categories Iy Community Site - Blog creation
J Search Menu
Workflow ve as new templat
Versions ﬁ Inherit template
Related docs .
Lred :TJ Clone template as ad-hoc
Security ["f Edittemolate properties
Attachments

Inherit content
@ Use page template settings
) Donotinherit any content

(@) Selectinherited levels

Template category:

Community Site.

Template description:

MyCommunitySite BlogList
My Community Site templates

This i= the Blog list page of My -

Blog list

]

http://locall €& Local intranet | Protected Mode: Off
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4. Switch to the Design tab. Let's start with zoneRight web part zone. Remowe the
repeaterYourBlogPosts and LatestBlogs web parts. These web parts wouldn't make sense in this
context, so you can leave them out.

Click the Add web part (4) icon and choose the Membership -> Logon mini form web part. Set the
following properties of the web part, leave the rest of them as they are:

e Display to roles: _notauthenticated

e Logon failure text: Error logging in.

e Web part container: Community Site - Red box
e Web part container title: Sign in

Click OK.

Drag and drop the web part to the top of the web part zone, above the Shortcuts box. The web part zone
is ready now and should look as in the screenshot below.

¥ zoneRight 9k
w logonminiform @

|
Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

\
w TopBloggers @

Top bloggers

Sort by: User name Activity

Admin
I Gender: MN/A
Age: 0

5. Modifying the zoneCenter web part zone will also be a task of a few clicks. Firstly, remowve the
DescriptionText and NewBlog web parts so that the only web part remaining is the Editable text for
the heading.

Now we will add the main part of the page - the repeater for displaying blogs. Click the Add web part (
) icon and choose the Listings and viewers -> Repeater web part. Set the following properties of the
web part, leave the rest of them at the default values:

Web part control ID: rptListOfBlogs

Show for document types: CMS.Menultem

Path: /Blogs/%

Document types: CMS.Blog

Transformation: Community.Transformations.BlogPostDetail

Selected item transformation: Community. Transformations.BlogPostDetail
Paging: enabled

© 2010 Kentico Software



206

Kentico CMS 5.0 Community Site Guide

e Page size: 5
e Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blog|all

Click OK.

6. Finally, switch to the Page tab and enter Blogs list into the text field of the heading Editable text
web part. Click Save.

Blog list

l
'
'
e e e e

In the screenshot below, you can see the desired appearance of the page in Design tab. The page is not
displaying anything yet, because there are no blogs on the site. If you create one, it will be displayed
here.

|V /Blogs/Blog list - page template: My Community Site - Blog list y|

* zoneCenter * = zoneRight +
y P
v editabletext (&3 = logonminiform {23
] ¥ Shortcuts 1
¥ rptlistOfElogs ’,g‘,! Sl l::n'l]:uts'&z‘g

My profile
Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

v TagCloud {3 ‘

= TopBloggers ’é}
Top bloggers

Sort by: User name Activity
Admin
l Gender: NfA
Age: 0
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3.8.4 Creating the Blog posts page

The last page in the Blogs section is the Blog posts page. When a user clicks a tag in the Tag cloud
web part, she is redirected to this page. On the page, all blog posts will be displayed by the Repeater
web part based on a querystring parameter.

1. Go to CMS Desk, select the Blogs page from the content tree and click New. Choose the Page
(menu item) document type.

232 Kentico S
#1% CMS Desk Content My desk Toolz Administration
| [x Do dw 4 @ @©@ =2 @ AL
New |Delete [= Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
(=) My Community Site » Blogs
5[ /Blogs -
o-ae . New document
o] Blog list L
¢ Create
(x-S Files Please select new document type:
‘—] Home [ Page (menu item)
:~|.] Logon page
1] Search =) Article
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2. We will use the page template of the Blog list page created in the previous chapter. The page
template is almost identical, only the settings of the main repeater will be modified. Choose the My

Community Site template -> My Community Site - Blog list page template. For Page name, enter
Blog posts and click Save.

:!,. Kentico Switch to Site Manager  Site: |My Community Site[+] User: Global Administrator v5.0.3688 Sign out
% CMS Desk

Content My desk Tools Administration

) 5 Oes e |3 @ @ B | AL o
New Delete = Move & Down Edit  Preview Livesite  List Search

Content management View mode || other

=
=] n_;_;l My Community Site » Blogs
(=11l |Blogs
e 3 ave Save and create another Spell check
+-| ] Blog list
B ._I Create
(2.5 Files Page name: Blog posts
--|_] Home
[ Logon page @ Use page template () Inheritfrom parentpage () Create a blank page
-] Search _ R
=& All page templates Template name:
&) Articles

©y Blank pages for widgets

_StarterTemplate My Community Site - C

My ity Site - My C ity Site -
Blog creation Blog list Blogs
N
My Community Site - My Community Site - My C: ity Site - My C ity Site -
Home page Logon Page Master Page Search page

&) Templates with editable regio
La) wiki My Community Site - Blog list
This is the Blog list page of My Community Site.

3. View the new page in Page tab. Enter Blog posts into the heading Editable text web part's text box
and click Save.

Blog posts

l
|
'
3
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4. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details into the pop-up dialog:

Template display name: My Community Site - Blog posts
Template code name: MyCommunitySite.BlogPosts
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

212 Kentico
s

CMS Desk Content My desk Tools Administration
=) c U — -y
B & Bo  fuw [ O B | P
New Delete | =¢Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other |
|:Iv.‘_’J My Community Site Page  Design  Form  Properties
U L] Blogs General
=
o URLs
| |Blog posts
| -[J] Create Template
(415 Files Metadata Template
; a Home Categories My Community Site - Blog list Select
[ Logon page Menu s T—— : ==
] a Search warnl [ .;“;: SaVE a3 neiw tempiate. | ] & Page template - Save as new -- Webpage Dialog
o \Q{ Inherit template ,\.gﬁ Save as new page template
Related docs .
. &3/ Clone template as ad-hoc
Linked docs = Template display name: |My Community Site - Blog posts
Secriy [H Edittemplate properies Template code name:  MyCommunitySite BlogPosts
Attachments
" Template category: Wy Community Site templates [+
Inherit content This= i? the _Blog post page of My -
@ Use page template settings Community Site.
H = Do notinherit any content Template description:

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

5. Switch to the Design tab. There is the rptListOfBlogs web part already on the page in the
zoneCenter web part zone. It is configured for the purposes of the Blog list page, so we will have to
modify its properties. Click the Configure (‘&) icon of the web part and set the following properties:

Web part control ID: rptBlogPosts

Show for document types: CMS.Blog;CMS.BlogPost;CMS.Menultem
Document types: cms.blogpost

ORDER BY expression: BlogPostDate DESC

WHERE condition:

({?tagid|(toint)?} = 0 AND '{?tagnane?}'=""') OR (DocunentlD IN (SELECT Docunent|D
FROM CVB_Docurnent Tag WHERE Tagl D = {?tagid| (toint)?})) OR (Docunent|ID IN ( SELECT
Docunent | D FROM CVB_Docunent Tag WHERE Tagl D I N ( SELECT Tagl D FROM CVM5S_Tag WHERE
TagName = '{?tagnane?}' AND TagG oupl D = {?groupid|(toint)?})))

® Transformation: Community.Transformations.BlogsAllBlogsPosts
e Selected item transformation: clear the value as it wouldn't make sense in this context
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e Cache dependencies: nodes|{%CurrentSite.SiteName|(tolower)%}|cms.blogpost|all

Click OK.

The page is now finished. In Design tab, it should look as in the following screenshot:

|V /Blogs/Blog posts - page template: My Community Site - Blog posts y|
T zoneCenter I*

= zoneRight I*

v editabletext { =
"‘} = |ogonminiform {_\Qy}

_ v Shortcuts {23
* rptBlogPosts i_go} Shortcuts

My profile
Edit my profie

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

* TagCloud {_':eo} ‘
+ TopBloggers {e}

Top bloggers
Sort by: User name Activity

Search
Admin

Gender: NfA
Age: 0
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3.9 Creating the News page

The News page will contain a repeater displaying news. News items can be created by users with
access to CMS Desk, typically content editors or site administrators. They are useful for announcing
important information to all site users and visitors.

Creating the News page will be very simple. We will re-use the starter page template created in this
chapter and add some web parts, mainly the Repeater for displaying news items.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

-‘:’- Kentico Switch

'l‘ CMS Deslk Content My desk Tools Administration

[ copy T up 2 E E )3

Mew |Delete |=bMove 4 Down Edit Preview Live site List Search
Content management iew mode Other
cl-\:-'_F'J My Community Site My Community Site

5[] Blogs N
‘—' o New document

| Blog list
|_| Blog posts

: [ Create Please select new document type:
ey :jles |1 Page (menu item)
[ Home
i[] Logon page ) 8lo
"] Search
i Folder
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2. Choose the My Community Site templates -> _StarterTemplate page template. For Page name,
enter News and click Save.

< Kentico
CMS Desk Content | My desk
[ Copy T up
New Delste =sMove 4 Down

Content management

(Z-6[My Community Site

(=)-] Blogs

i-[] Blog list

fm __, Blog posts
|-] Create
(-5 Files

-] Home

-] Logon page
|| Search

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out

Tools Administration

@ & =2 kL

Edit Preview Live site List Search
View mode Other
My Community Site

E‘ Save and create another

Page name: MNews
@ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates
5 Articles
4 Blank pages for widgets

Template name:

_StarterTemplate

2]

i

My Community Site - My C ity Site - My C ity Site -
Blog creation Blog posts
My Community Site - My Community Site - My C: ity Site - My C ity Site -
Blogs Home page Logon Page Master Page
_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

e b

3. View the page in Page tab and enter News into the heading Editable text web part's text box. Click

Save.
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4. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details into the pop-up dialog:

e Template display name: My Community Site - News
e Template code name: MyCommunitySite.News

e Template category: My Community Site templates

e Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager

232 Kentico
#1% CMS Desk Content | Mydesk Tools  Administration
- G u — B
& S R [l A
New Delete =k Move & Down ‘ Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
(=4 ) My Community Site Page  Desgn  Form | Properties
© | B.Iugs General
(-G Files
= URLs
i |1 Home
L] Logan page femplate
i [[News Metadata Template
L] search Categories _StarterTemplate Select
Menu i 5 ~
RS e e & | Page template - Save as new -- Webpage Dialog ﬂ
Workflow 7 —
Versions Q Inherit template /3l Save as new page template
Related docs —
a3/ Clone template as ad-hoc
Linked docs =/ Template display name: My Community Site - News
e [ Edittemplate properties Template code name:  |MyCommunitySite News
Attachments Template category My Community Site templates [=]
Inherit content This i§ the _News page of My =
@ Use page template settings Community Site.
H @ Do notinherit any content Template description
() Selectinherited levels
http://localk € Local intranet | Protected Mode: Off

Site: My Community Site E| User: Global Administrator 5.0

5. Switch to the Design tab. Firstly, we will add a tag cloud that will display tags from the News tag

group. After clicking a tag, users will be redirected to this page again, where the repeater in the

zoneCenter web part zone will display all news items tagged with the clicked tag.Click the Add web
part (%) icon of the zoneRight web part zone and choose the Tagging & Categories -> Tag cloud

web part. Set the following properties of the web part, leave the rest of them at their default values:

Click OK.

Tag group name: News
Document list URL: /News
Web part container: Community Site - Orange Box
Web part container title: Tag cloud

6. Now we will add the Content subscription web part to enable users subscribe to receiving
notifications about new news items. Click the Add web part (4F) icon of the zoneRight web part zone

and choose the Notifications -> Content subscription web part. Set the following properties of the web
part, leave the rest of them at their default values:
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Display to roles: _authenticated

Path: /News/%

Document types: CMS.News

Create event enabled: enabled

Create event display name: Community news notification
Create event template name: News notification

Web part container: Community Site - Blue Box

Web part container title: News subscription

Click OK. The zoneRight web part zone is finished and in Design tab, it should look as in the
screenshot below.

¥ zoneRight 9k
[ e ———
Shortcuts
My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

|' ContentSubscription @|
News subscription

E-mail:
administrator@localhost.lo

7. Now to the zoneCenter web part zone. The main web part will be a repeater displaying the news
items. Click the Add web part (4) icon, choose the Listings and viewers -> Repeater web part and
click OK. In the web part properties window, set the following properties:

Web part control ID: NewsRepeater

Path: /News/%

Document types: CMS.News

ORDER BY expression: NewsReleaseDate DESC
WHERE condition:

({?tagid|(toint)?} = 0) OR (Docunent|D IN ( SELECT Docunent| D FROM CV5_Docunent Tag
WHERE Tagl D = {?tagid| (toint)?} ))

Transformation: Community. Transformations.NewsPreview

Selected item transformation: Community.Transformations.NewsDetail
Show new button: enabled

New button text: Add news<br />

Show Edit and Delete buttons: enabled

Content before: <div class="newsRepeater">

Content after: </div>
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Click OK.

8. Now let's add the Breadcrumbs web part. This web part will be displayed only when a news item is
displayed, not in the list of news items. When the News item is displayed, the breadcrumbs will make
the heading of the page in format News > Title of the news item. Click the Add web part () icon of
the zoneCenter web part zone and choose the Navigation -> Breadcrumbs web part. Set the
following properties of the web part, leave the rest of them at their default values:

e Show for document types: CMS.News

e Breadcrumb separator: <span class="TitleBreadCrumbSeparator">&nbsp;</span>
e Encode name: disabled

e Web part container: Breadcrumbs box

e Content before: <div class="blogsTopBreadcrumbs">

e Content after: </div>

Click OK and drag-and-drop the web part between the NewsTitle and the NewsRepeater web part.
9. Finally, we will add the possibility to sign up for RSS natifications about new news items. Click the
Add web part (4F) icon of the zoneCenter web part zone and choose the Text -> Static text web part.

Set the following properties of the web part, leave the rest of them at their default values:

e Web part control ID: RSSImage
e Text:

<br /><a href ="~/ CMSPages/ NewsRss. aspx" styl e="border:0; padding-left: 10px;
paddi ng-right: 10px;"><ing src="~/ App_Thenes/ Defaul t/| mages/rss. gi f" border="0"
al t="RSS" /></a>
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Click OK. The News page is now ready. You can try out its functionality by adding some news items
under the News page via CMS Desk. The page should display the news items correctly. In Design tab,
the page should look as in the screenshot below.

|V /News - page template: My Community Site - News ﬂ|

* zoneCenter * Right +

¥ zonel
- ~
v editabletext {4} ¥ logonminiform {23
_ ¥ Shortcuts {23 :

¥ breadcrumbs @ Shortcuts

* MNewsRepeater @} My profile
Edit my profie

=

T RS55image g:} My messages

- My friends
My invitations.

Create a new group
Create a new blog
Sign out

* TagCloud @ ‘
¥ ContentSubscription @}

News subscription
E-mail:
administrator@localhost.lo

3.10 Creating the Media page

The Media page will display content of the site's global media library created in this chapter. As you will
see, the page is very easy to create as all the required functionality will be achieved using the Media
gallery web part.

Further information can be found in the Module Media libraries chapter of Kentico CMS Developer's
Guide.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

-‘:’- Kentico Switch

'l‘ CMS Deslk Content My desk Tools Administration

[ copy ¥ up 2 E E )_J

New | Delete [ Move & Down Edit Preview Live site List Search
Content management View mode Other
.;l-\j-'_’-l My Community Site My Community Site
5|l Blogs 2y
- New document
[+]- = Files
[ Home
‘.[] Logon page Please select new document type:
i News [] Page (menu item)
“ | Search
W) Blog
i) Folder
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2. Enter Media into the Page name field. Select the My Community Site templates ->

_StarterTemplate page template and click Save.

Kentico Switch to Site Manager  Site:| My Community Site [+
CMS Desk Content | Mydesk  Took  Administration
3 c U
] & Bowr T [al =i P
New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management | View mode || other
=] n_;_;l My Community Site My Community Site
(x-l] Blogs
)G Files E‘ Save and create another
-] Home
|| Logon page Page name: Media
-] News
[ search @ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:
&) Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Events

FAQs

Forums

General

Home pages

Images

Job openings
Knowledge base
Master templates

_StarterTemplate My Community Site -
Blog creation

My Community Site - My Community Site -
Membership and security Blogs Home page

Message boards

My Community Site templates
News

Newsletter

Offices

Press releases

Products

Templates with editable regig

o) wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.

ly C ity Site -

User: Global Administrator v5.0.3688

My C ity Site -

Blog list

Blog posts

My C: ity Site -
Logon Page

My C ity Site -
Master Page

Sign out

2]

m
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3. Now we will save the page as a new page template so that the changes made to the page would not
be reflected to the _StarterTemplate. Select the Media page from the content tree, switch to the
Properties -> Template tab and the Save as new template link. Enter the following details into the

pop-up dialog:

Template display name: My Community Site - Media

e Template code name: MyCommunitySite.Media

Switch to Site Manager

Select

Site: My Community Site E User: Global Administrator v5.0.

& Page template - Save as new -- Webpage Dialog

;;.ﬁ Save as new page template

Template code name

e Template category: My Community Site templates
e Template description: enter some text describing the page template
Click OK.
232 Kentico
‘.‘ CMS Desk Content My desk Tools Administration
2 [ Boer  #u (4 [d pe
New Delete |= Move & pown | Edit Preview Live site List | Search
Content management | View mode | Other
E‘"Y“‘_.,'J My Community Site Page Design Form Properties
[#)-.] Blogs
G |
©.[]] Home URLs
| Logon page Template
; J Media Metadata Template
P[] News Categories _StarterTemplate
“.[]] search Meral .
v Save as newtemplate..;
Versions Q Inherit template
Related docs —
# Llone template a5 ad-hoc
e f__.Tj Clone template as ad-hoc
Security E Edit template properties
Attachments

Inherit content
@ Use page template seftings
() Do notinherit any content

() Selectinherited levels

Template category:

Template description:

Template display name: My Community Site - Media
MyCommunitySite. Media
My Cammunity Site templates [~]

This is the Media page of My -
Community Site.

http://localk € Local intranet | Protected Mode: Off

4. The only web part that we need to add is the Media gallery web part. Obviously, it will be placed in
the zoneCenter web part zone. Click the Add web part (4) icon of the zoneCenter web part zone
and choose the Media library -> Media gallery web part. Set the following properties of the web part,

leave the rest of them as they are:

Use secure links: disabled
Page size: 8
Group size: 8

Click OK.

Media library: My Community Site Media
Show subfolders content: enabled

No record found text: There are no files in the library.

5. The last step is to change the header text. Switch to the Page tab and enter Media gallery into the
Editable text web part's text field. Click Save.
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Media gallery

l
|
'
e e e ]

6. And that's the Media page finished. If you switch to the live site now, you should see the page
displaying content of the previously created sample media library.

Blogs Home Media News | || searcn
Media gallery
Shortcuts
(=) MyCommunitySiteMedia  S0rt by: Name Date Size My profie
"\S' Documents Edit my profile
50 Music My messages
R n
= s My friends
s Pictures -, My invitations
) Video o = J‘] LEs Create a new group
% %‘ = MP3 Create a new blog
BLL Sign out
IMO0260: IMO01775 Windows-XP-Startu.. Sample-document
Size: 31 kB Size: kB Si kB Size kB
£ 3 Uploaded: 2/22/2010 Up 2/22/2010
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3.11 Creating the Forums section

3.11.1 Creating the Forums page

The forums page will host the site's discussion forums. All the forum content will be displayed by this
single page using the Forum group web part. In order for the page to display some content, there has
to be some forum group defined via the administration interface.

Before you start creating the page, it is therefore recommended to create one forum group. In this
chapter, you can see how a sample forum group can be created.

If you needed some more information about the Kentico CMS Forums module, you can find it in Kentico
CMS Developer's Guide -> Module Forums.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)
document type.

Switch
22 Kentico
'.‘ CMS Deslk Content My desk Toals Administration
> c u
Al B T I3 [ @ FH | AP
New |Delete = Move 4 Down Edit Preview Live site List Search
Content management | View mode | COther
=4 J[My Community Site My Community Site
3-[.] Blogs .
= 4.‘—'_‘ . New document
[+]- = Files =
._I Home
._I Logon page Please select new document type:
e — [] Page (menu item)
] News
“..[] search ) 8lo
) Folder
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2. In the following dialog, choose to Create a blank page using the Simple layout. Enter Forums into

the Page name field and click Save.

22 Kentico
#1N CMS Desk

Content My desk Tools Administration

Switch to Site Manager

=] Co u )
EE ooy Hue A d P
New Delete = Move & Down | Edit Preview Live site  List | Search \
Content management | View mode Il other |
ni/'!'t") My Community Site My Community Site
2] Blogs
5 Files [ S2teano create anotner Spell check
J Home
[ Logon page Page name: Forums
-1 Media
:1 News () Use page template () Inheritfrom parent page @ Create a blank page
J Search —
Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells

Grid 3x2 cells (CSS)

Three columns

Three columns (CSS)

Top row, three columns,
bottom row

Top row, two columns,
bottom row

12
Simple

Simple layout with one web partzone.

Copy this layout to my page template

3. Switch to the Properties -> Template tab and click the Edit template properties link.

=32 Kentico
#g%  CMS Desk

Switch to Site Manager

Content My desk Tools Administration
SRS INE LA X [d] A
New Delete = Move 4 Down Edit Preview Live site List | Search |
Content management | View mode | other |
C-"{“_;'J My Community Site Page Design Form Properties
ja],“‘ Eillzgss e E Save
URLs -
Template
Metadata Template
Categories Ad-hoc: Forums
Menu
vaies -:!I: Save as new template..
Versians € Inherit te mplate
Related docs
Lrled E Edit template properties
Security
Attachments Inherit content

@ Use page template settings
) Do notinherit any content
() Selectinherited levels

Site: | My Community Site[+]| User: Global Administrater v5.0.26288

Simple

Two columns

Sign out

2]

i

Site: My Community Site [ |
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4. In the pop-up window, switch to the Layout tab and replace the layout code with the following code:

<l-- Container -->
<di v class="foruntearch">

<ccl: CvBWbPart Zone | D="zonelLeft" runat="server" />
</ di v>

Click Save.

& | Page Templates - Webpage Dialog ﬁ

-/ Page template properties @
Templates » Ad-hoc: Forums

General Layout Web parts Header Documents

E Save El Check out to file

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplatelLayouts\960a99e2-aecd-43cd-
8205-e60c34baddd0.ascx to edit the layout externally.
) Use shared layout

Grid 2x2 cells

@ Use custom layout
<!-- Container --> -
<div clasa="forumSearch">
<ccl:CMSWebPartZone ID="zoneleft™ runat="server" />
</divy

http://localhost/kenticocms/CMSModules/PartalEngine/Ul/Pag €& Local intranet | Protected Mode: Off

5. Switch to the Design tab. You can see only one web part zone on the page, so let's start adding web
parts to it. First, we need a heading. Click the Add web part () icon of the zoneLeft web part zone
and choose the Text -> Editable text web part. Set the following properties of the web part, leave the
rest of them as they are:

e Web part control ID: editabletextHeader
Editable region title: Header

Editable region type: Text box
Content before: <hl class="header">
Content after: </h1>
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Click OK.

6. Switch to the Page tab and enter Forums into the Editable text web part's text box. Click Save.

7. Switch back to the Design tab. Because some forums might be accessible only to authenticated
users, we will add the Logon miniform web part below the heading. It will be displayed only to
unauthenticated anonymous site \isitors. Click the Add web part (4) icon of the zoneLeft web part
zone and choose the Membership -> Logon miniform web part. Set the following properties of the
web part, leave the rest of them as they are:

e Display to roles: _notauthenticated

e Logon failure text: Error logging in.

e Username text: username

e Content before: <div class="ForumLogonBox">
e Content after: </div>

Click OK.

8. Below the logon mini form, the Forum search box web part will reside. It will enable users to search
in the forum contents. Click the Add web part (%) icon of the zoneLeft web part zone and choose the
Forums -> Forum search box web part. Set the following properties of the web part, leave the rest of

them as they are:

e Advanced search path: /Forums/Forum-search
e Context search: enabled

e Content before:

<di v cl ass="For unSear chBox" >

<tr><td style="vertical -align:top; paddi ng-top: 3px; "><b>Sear ch foruns: &bsp; </ b></
td>
<td style="text-align: right">

* Content after:

</td></tr></tabl e></di v><div cl ass="cl ear"></div>

Click OK.

9. Below the Forum search box, we will place the Forum group web part. In order for it to display any
content, you should have created some sample forum group as mentioned in the beginning of this
chapter. Click the Add web part () icon of the zoneLeft web part zone and choose the Forums ->
Forum group web part. Set the following properties of the web part, leave the rest of them at the default
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values:

e Group name: choose your previously created forum group

e Enable favorites: enabled

e Thread view mode: Flat - oldest to newest

e Allow private messaging: enabled

e Allow friendship request: enabled

e Access denied page URL: ~/Special-pages/Access-denied.aspx
e Use friendly URLs: enabled

e Friendly Base URL: ~/Forums

e Content after: <div style="height: 15px;"></div>

Click OK.

10. Below the Forum group, we will place the Forum search results. The web part will be displaying
results of forum search performed by the Forum search box web part above. Click the Add web part (
2F) icon of the zoneLeft web part zone and choose the Forums -> Forum search results web part.

You can leawe all properties of the web part at the default values.

11. The last web part on the page is the On-line users web part. We will set it up so that it displays the
number of users who are currently browsing the forums section. Click the Add web part (4) icon of the
zoneleft web part zone and choose the Membership -> On-line users web part. Set the following

properties of the web part:

e Transformation name: Community. Transformations.MembersOnline

Path: /Forums
Use default cache dependencies: enabled
Content before: <br />

Click OK.

12. The page is now finished. In Design tab, it should look as in the following screenshot.

| = [Forums - page template: Community Site - Forums

2

¥ zoneleft

¥ editsbletextHeader @

= logonminiform @
==

Advanced search

¥ ForumGroup @ Threads

Last post

Sample Forum Group

Thig iz a sample forum group.

Sample Forum 2

\aE’]E\ This is the second sample forum, 0
Lock
Sample Forum 1
\aE)E\ This is the first sample forum. 0
Lock

=
¥ Onlinelsers )

(1/1/0001 12:00:00 AM)

(1/1/0001 12:00:00 AM)
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13. Finally, we will save the page as a new page template so that it can be reused in the future (we will
use it when creating the Forum search page). Switch to the Properties -> Template tab and click the
Save as new template link. In the pop-up dialog, enter the following details:

Template display name: My Community Site - Forums

e Template code name: MyCommunitySite.Forums

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager Site: My Community S\teEI User: Global Administrator v5.0.

212 Kentico

‘.‘ CMS Desk Content My desk Tools Administration
Ci u E 2 |
8 G Jewr Tw 4 [ A
New Delete |=»Move & Down | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
=] \;_;J My Community Site Page Design  Form | Properties
‘ﬂ 2] Blogs General
S
o URLs
i[][Forums
g :I Home Template
:~] Logon page Metadata Template
L[] Media Categories Ad-hoc: Forums W
[ News Menu ( )
:l Search - | Sive a5 new lemplate " || €. Page template - Save as new -- Webpage Dialog ﬁ
Versions @ ‘heriemplate (=g Save as new page template
Related docs )
1 E Edit template properties
Linked docs Template display name: My Community Site - Forums
Security Template code name:  MyCommunitySite. Forums
Attach ts i
E In_herrt content i Template category: My Community Site templates E
@ Use page template settings
) D notinherit any content This is the Forums page of My i
- Community Site.
r () Selectinherited levels
Template description
http://localk € Local intranet | Protected Mode: Off
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3.11.2 Creating the Forum search page

The Forum search page is accessible from the Forums page, after clicking the Advanced search link
of the Forum search box web part. The page contains the Forum search - advanced dialog web part
which enables searching the forums with extended search criteria.

1. Go to CMS Desk, select the Forums page from the content tree and click New. Choose the Page
(menu item) document type.

Switch
232 Kentico
#4% CMS Desk Content My desk Tools Administration
g Glcosy  Fue 4 [& [ EH pe
New | Delete | Move & pown | Edit Preview Live site List | Search |
Content management | ‘iew mode | Other
(=) My Community Site » Forums
3-[.] Blogs -9
= :‘—l ) New document
B Files —
-] [Forums
|_] Home Please select new document type:
‘—] Logc_m S [ Page (menu item)
i) Media
'—] flevrs = Article
] Search —
‘¥] Blog
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2. We will use the page template created in the previous chapter as the starting point. Choose the My
Community Site templates -> My Community Site - Forums page template. Enter Forum search into

the Page name field and click Save.

22 Kentico
#1% CMS Desk Content | Mydesk  Tools  Administration

)y Oem ¥ | 3 (g =
New Delete = Move & Down Edit  Preview Livesite  List

Content management View mode

» Forums

d'éq’) My Community Site

-] Blogs
-G Files [ S22 and create anotner
|| Forums
L] Home Page name: Forum search
| Logon page
-] Media @ Use page template
| News -
j Search =4} All page templates

Articles

Q

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX

E-commerce
Events
FAQs
Forums

General
Home pages
Images

Q@
Q
Q
=]
@
=]
Q@
Q
Q
Q
=
i) Job openings
@
Q
Q@
Q
@
Q
@
=]
&

Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates
News

Newsletter
Offices

Press releases
Products

Templates with editable regig

i £y wiki

) Inheritfrom parent page

Switch to Site Manager

P

Search
Other

Spell check

() Create a blank page

Template name:

_StarterTemplate My Community Site -

Blog creation

My Community Site -
Blogs

My Community Site -
Forums

My Community Site - Forums
This is the Forums page of My Community Site.

Site:| My Community Site[+| User: Global Administrator v5.0.3688

My C ity Site - My C ity Site -
Blog list Blog posts

My C ity Site - My C ity Site -
Home page Logon Page

Sign out

m
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3. Switch to the Properties -> Template tab and click the Save as new template link. In the pop-up
dialog, enter the following details:

Click OK. Click Save.

232 Kentico
#§% CMS Desk Content | Mydesk  Tools
S Copy It up
.-
New Delete = Move

& Down Edit

Content management

= {-_/J My Community Site
@ [l Blogs
[+ Files
5[] Forums
: -_||[Forum search
|| Home
i..[]] Logon page
] Media
o] News
i []] search

Page Design

General
URLs
Template
Metadata
Categories
Menu
Workflow
Versions
Related docs
Linked docs
Security
Attachments

[y

View mode

Form

Switch to Site Manager

4 &4 @ 2 | AL

Preview Live site List Search
Other
Properties
Template

My Community Site - Forums

Template display name: My Community Site - Forum search
Template code name: MyCommunitySite.ForumSearch

Template category: My Community Site templates
Template description: some text describing the page template

Site: My Community Site E User: Global Administrator v5.0.

Select

-ﬁl Inherit template

4/ Clone template as ad-hog

[H Edittemolate properties

Inherit content

@ Use page template settings
) Do notinherit any content
() Selectinherited levels

| | & Page template - Save as new -- Webpage Dialog

/- Save as new page template

Template display name: My Community Site - Forum search
Template code name:  |MyCommunitySite. ForumSearch
My Community Site templates [~]

This is the Forum search page of -
My Community Site.

Template category:

Template description:

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Design tab. Firstly, delete all web parts so that only the editabletextHeader and
ForumSearchResults web parts remain.

| = [Forums/Forum search - page template: My Community Site - Forum search

B

- zoneleft

v editabletextHeader @
¥ ForumSearchResults @}
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5. Click the Add web part () icon of the zoneLeft web part zone and choose the Forums -> Forum
search - advanced dialog web part. You can leawve all properties of the web part at the default values.
Drag and drop the web part between the other two web parts on the page.

6. Switch to the Page tab and enter Forums advanced search into the Editable text web part's text box.
Click Save.

7. The page is finished. If you view it in Design tab, it should look as in the following screenshot.

| - [Forums/Forum search - page template: My Community Site - Forum search y|

v zoneleft +

v editabletextHeader @

| ¥ ExtendedForumSearchDialog @} | @

Written by:

Community forums -
Announcements
Community FAQ
General discussion
Members discussion

Back-packer forums
Announcements
FAQs -

Search within: Subject and text |Z|

m

Search in forums:

Sortresultsby: | Post time |z| @ ascending ) Descending

¥ ForumSearchResults @}
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3.12 Creating the Groups section

3.12.1 Creating the Groups page

The Groups page is the title page of the Groups section. Users will see two Groups viewer web parts.
The first one of them will be displaying the groups where the user is a members. The second one will be
displaying all groups sorted from the newest to the oldest, paged by 9 groups.

If you right-click a group in one of the Groups viewers, you will be offered some actions by a context
menu. This functionality is provided in the transformation and here, you can find a description of how
exactly it is achieved.

In case you needed detailed information about Kentico CMS Groups module, please refer to the Module
Groups chapter of Kentico CMS Developer's Guide.

1. Select the root of the content tree and click New. Choose the Page (menu item) document type.

Switch
=32 Kentico S
'l‘ C€MS Desk Content My desk Tools Administration
= C U
Q) g Ber % 4 [Q @ B | P
New | Delete |= Move & Down Edit Preview Live site List Search
Content management | Wiew mode | Other
=& My Community Site My Community Site
5-[] Blogs -
T ;l i New document
[ERY Files —
-] Forums
._] Home Please select new document type:
‘—] Loggn S [ [) Page (menu item) ]
1] Media
I_] News ] Blo
| Search
i) Folder
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Groups and click Save.

Kentico
CMS Desk Content | My desk
3 [Elcopy i up
| x
New Delete = Move & Down
Content management
d'éq) My Community Site

-] Blogs
(-5 Files
(+]-|.] Forums
-] Home
| Logon page
-] Media
] News
-] Search

Switch to Site Manager

Tools Administration
Edit Preview Live site List Search
View mode Other
My Community Site

Spell check

F- Save and create another

Page name: Groups

@ Usepagetemplate () Inheritfrom parentpage () Create a blank page

(=5} All page templates Template name:
L) Articles

Blank pages for widgets

Blogs

Community Site

Corporate Site ASPX

E-commerce

Events

FAQs

Forums

General

Home pages

Images

Job openings

Knowledge base

Master templates

Membership and security

Message boards

My Community Site templates

News

Newsletter

Offices

Press releases

Products

Templates with editable regig

_StarterTemplate My Community Site -

Blog creation

My Community Site -

My Community Site -
Blogs Forum search

_StarterTemplate

Site:| My Community Site[+| User: Global Administrator v5.0.3688

C ity Site - My C ity Site -
Blog list Blog posts

My C ity Site - My C ity Site -
Forums Home page

Sign out

m

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

212 Kentico

#1%  CMS Desk Content My desk
=) [Hcopy T up
= =4 :
New Delete |= Move & Down |

Content management

Toals

[

Edit

Switch to Site Manager

Administration
Cd] L
Preview Live site List ‘ Search
View mode | Other

= f-_j My Community Site
(@ ] Blogs
,1/ 5 Files
(@[] Forums
_1/Groups
.+l Home
i..[] Logen page
i 1] Media
i.[ News
‘.1 Search

=

Page Design Form Properties

General
URLs
Template
Metadata
Categories
Menu
Workflow
Versions
Related docs
Linked docs
Security
Attachments

Template
_StarterTemplate

Template display name: My Community Site - Groups
Template code name: MyCommunitySite.Groups
Template category: My Community Site templates
Template description: some text describing the page template

Site: My Community S\teEI User: Global Administrator v5.0.

7

Save as new fempiate ]

E Inherit template
./ Clone template as ad-h
/& Clone template as ad-hoc

[H Edittemplste properties

Inherit content

@ Use page template settings
) Do notinherit any content
() Selectinherited levels

& | Page template - Save as new -- Webpage Dialog ﬂ

Template code name:

Template category:

Template description:

L;ﬁ Save as new page template

Template display name: |My Community Site - Groups

MyCommunitySite. Groups
Wy Community Site templates |Z|

This is the Groups page of My -
Community Site.

hitp://localk @ Local intranet | Protected Mode: Off

4. Switch to the Design tab. First, we will add another Editable text web part to zoneCenter. This web
part will be displaying a text informing users that they can get context menus with available group-
related actions by right clicking a group. Click the Add web part (%) icon of the zoneCenter web part
zone and choose the Text -> Editable text web part. You do not need to set any properties of the web
part, just leave all of them at the default values.
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5. Switch to the Page tab. Enter Groups into the first Editable text web part's text field. Into the second
one, enter: Right click the group to get available actions. Click Save.

Blogs Forums Groups Home Media News | | | Search

Shortcuts

Y 4 My profile
| Right click the group to get available actions. ol H Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

m

6. Switch back to the Design tab. We will add the first Groups viewer for displaying the current user's
groups. Click the Add web part () icon of the zoneCenter web part zone and choose the
Community -> Groups viewer web part. Set the following properties of the web part, leave the rest at
the default values.

e Web part control ID: YourGroups

e Display to roles: _authenticated

e Transformation name: Community. Transformations.GroupsList

e Show filter: disabled

e ORDER BY condition: GroupDisplayName

e WHERE condition: GroupID IN (Select MemberGrouplD FROM Community _GroupMember WHERE
MemberUserID = {%currentuser.userid%} AND MemberStatus = 0)

e Selected columns: GroupCreatedWhen,GrouplD,GroupName, GroupDisplayName,GroupDescription,
GroupAvatarlD, AvatarGuid

e Hide if no record found: disabled

e No record found text: You are not currently in any group.

e Web part container: Community Site - Red Box Light
e Web part container title: Your groups
e Content after: <div class="clear">&nbsp;</div>

Click OK.

7. The second Groups viewer will be displaying all groups ordered from the newest to the oldest, paged
by 9 groups. Click the Add web part () icon of the zoneCenter web part zone and choose the
Community -> Groups viewer web part. Set the following properties of the web part, leave the rest at
the default values.

e Web part control ID: RecentlyAddedGroups

e Display to roles: _authenticated

e Transformation name: Community.Transformations.GroupsList

e ORDER BY condition: GroupCreatedWhen DESC

e Selected columns: GroupCreatedWhen,GrouplD,GroupName, GroupDisplayName,GroupDescription,
GroupAvatarlD,AvatarGuid

e Hide if no record found: disabled

e No record found text: There are no recently added groups at this moment.

e Page size: 9
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e Paging mode: PostBack

Web part container: Community Site - Blue Box Light
Web part container title: Recently added groups
Content after: <div class="clear">&nbsp;</div>

8. The page is now finished. In Design tab, it should look as in the following screenshot.

| T /Groups - page template: My Community Site - Groups y|
= zoneCenter
— * = zoneRight +
v editabletext {5 =
= |ogonminiform g:}
|
v editabletextl &b to get available actions. Shortcuts
Your groups Edit my profie
My messanes
'You are not currently in any group. My friends
My invitations
Create a new group
¥ RecentlyAddedGroups @ Create a new blog
Recently a groups Sign out
Sort by: Group name Created
[There are no recently added groups at this moment.

3.12.2 Creating the Create page

On this page, users will be provided with the possibility to create new groups. This is achieved using the
Group registration web part. There will also be the Groups viewer web part in zoneRight, which will
be displaying the latest 5 groups. The page is accessible from the Shortcuts menu, by clicking the
Create a new group link.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico S
#§% CMS Desk Content My desk Tools Administration
| & Ber #w [ @ H | L
New | Delete | = Move & Down Edit Preview Live site List Search
Content management iew mode Cther
= ) My Community Site » Groups
7-[] Blogs Y
= ;'H . New document
[+]- = Files
¢|,_| Forums
..[]/Groups Please select new document type:
e Home [ Page (menu item)
|2 Logon page
._I Media = Article
] News
‘[ search ] Blog
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the

Page name field, enter Create and click Save.

Kentico Switch to Site Manager ~ Site: |My Community Site[+] User: Global Administrator v5.0.3688 Sign out
CMS Desk Content | Mydesk  Tooks  Administration
2) Copy i up
B2 m @ 5|4, o
New Delete = Move & pown Edit  Preview Livesite  List Search
Content management | View mode || other
(26 My Community Site » Groups
(+]-.] Blogs
)G Files E‘ Save and create anather
[#-1] Forums
|| Groups Page name: Create
.| Home
[ Logon page @ Use page template () Inheritfrom parent page (") Create a blank page
-] Media _ R
I News =&y All page templates Template name:
y i) Articles
|| Search - |-
&3 Blank pages for widgets
-3 Blogs

.ﬂ' Community Site
J-4) Corporate Site ASPX

i3} E-commerce
) Events _StarterTemplate My Community Site -
S FAQ Blog creation

- - s

1 d‘ Forums
ﬂ i) General
T ) Home pages
iﬂ‘ Images
.j‘ Job openings
) knowledge base
“ Master templates My Community Site - My Community Site -
;j‘ Membership and security Blogs Forum search
-i3) Message boards
.ﬂ' My Community Site templates
iﬂ‘ News
.j‘ Newsletter
&) offices
i) Press releases
ij‘ Products
i) Templates with editable regia
& wiki _StarterTemplate

My Community Site -
Blog list

My Community Site -
Forums

My Community Site -
Blog posts

m

My Community Site -
Groups

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

Click OK. Click Save.

232 Kentico
#4% CMS Desk Content | Mydesk  Tools

Template display name: My Community Site - Groups create
Template code name: MyCommunitySite.GroupsCreate

Template category: My Community Site templates
Template description: some text describing the page template

Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

= [« u sl 1
5 [ Do @w (4 [d y)
New Delete | = Move & Down ‘ Edit Preview Live site List Search ‘
Content management | View mode | Other
=14} My Community Site Page  Design  Form | Properties
‘%‘ :(—1 B.Iogs General
= URLs
[+)-.] Forums
8 J Groups Template
..[[] [Create Metadata Template
i ] Home Categaries _StarterTemplate Select
[ Logon page i )
; ‘:] Ve Mo - || & Page template - Save as new -- Webpage Dialog ﬂ
x_] &= Workflow i =
L] News =
8 Vo ETT— 4 Save as new page template
] Search inherfiiemplate
Related docs -
a5/ Clone template as ad-hoc
Linked docs = Template display name: My Community Site - Groups create
Security E Edittemplate properties Template code name:  |MyCommunitySite. GroupsCreate
Attachments

Inherit content

@ Use page template settings
= Do notinherit any content
() Selectinherited levels

Template category. My Community Site templates [~]

This is group creation page of My =+
Community Site.l

Template description

http://localk €L Local intranet | Protected Mode: Off

4. Switch to the Design tab. Firstly, delete the Logon mini form in zoneRight. We will not need it on
this page as the page is accessible only to authenticated users (the Shortcuts menu doesn't display the

link to unauthenticated users).

5. Now that the Logon mini form is deleted, we will add the Groups viewer below the Shortcuts menu.
Click the Add web part (4) icon of the zoneRight web part zone and choose the Community ->
Groups viewer web part. Set the following properties of the web part, the rest of them can be left at the

default values:

e Transformation name: Community. Transformations.GroupsPreviewList

e Show filter: disabled

e ORDER BY condition: GroupCreatedWhen DESC

e Select Top N groups: 5

e Hide if no record found: disabled

e No record found text: There are currently no groups.

e Web part container: Community Site - Blue Box
e Web part container title: Recent groups
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Click OK.

6. Let's move on to zoneCenter. First, we will add another Editable text web part for displaying
additional info text. Click the Add web part () icon of the zoneCenter web part zone and choose the
Text -> Editable text web part. You do not need to set any properties of the web part, just leave all of
them at the default values.

7. Below the second Editable text web part, we will add the main web part of this page - the Group
registration web part. Click the Add web part (4) icon of the zoneCenter web part zone and choose
the Community -> Group registration web part. Set the following properties of the web part, leave the
rest of them at the default values.

e Template source alias path: /Groups/Template

e Template target alias path: /Group-pages

e Text after successful registration: Group has been succesfully registered. <a href="{0}">Click here
to view group profile</a>

Click OK.

8. Switch to the Page tab. Enter Create new group into the first Editable text web part's text field. Into
the second Editable text web part's HTML area, enter the following text:

By entering the details into the form below, you can create your new user group. Make sure you give the
group a name and description according to the group's field of interest. It is a good way of attracting site
users with the same interest to join your group.

Click Save.

E By entering the details into the form below, you can create your new user group. Make sure you give the group a name and description according
| to the group's field of interest. Itis a good way of attracting site users with the same interest to join your group.

m
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9. The page is now finished. In Design tab, it should look as in the following screenshot.

| - /Groups/Create - page template: My Community Site - Groups create

B

Description:

@ Any site member can join

Approve members: (2 Only approved members can join
8] Only approved members can join except for invited members
@ anybody can view the content

Contentaccess: () Site members can view the content

(@] Only group members can view the content

w zoneCenter
= * = zoneRight +‘
v editabletext { =
me‘%“ group * Shortcuts 5‘%,";
Shortcuts
+ editabletext1 ’{é“! nto the form below, you can create your new user group, Make sure you give the group a name and description according to the M_LD__ rofile
Qroup s end o Terest. Itis a good way of attracting site users with the same interest to join your group. Edit my profie
* GroupRegistration @3 My messanes
My friends
) My invitations

Create a new group
Create a new blog
Sign out

T GroupsViewer @,!

Recent groups

There are currently no groups.

3.12.3 Creating the Management page

On the Management page, group administrators will be able to manage the profile and settings of their
groups. This functionality is provided by the Group profile web part. The page is accessible by clicking
the Manage the group link in the Shortcuts menu. This link is displayed only to group administrators

when viewing the group's profile.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico

#1% CMS Desk Content My desk Toolz Administration

d B £

Preview Live site List

[ Copy ¥ up ¥

& Down Edit

b 4 ]
New | Delete | = Move

Content management View mode

[E& ) My Community Site » Groups

7Ll Blogs -

= New document

B Files

&[] Forums

-] /Groups Please select new document type:

P S Create | ] Page (menu item)

2] Home

._l Logc.m page = Article

o] Media

._l News '] Blog

“..[] search B Cell phone

Switch

A

Search
Other
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2. Choose to Create a blank page using the Simple layout. Into the Page name field, enter

Management and click Save.

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688

Kentico
CMS Desk Content | Mydesk  Tools  Administration
2) Col U
3 = [Acopy  Wue [a [@] = ﬁ
New Delete [=»Move & pown Edit  Preview Livesite  List Search
Content management View mode || other
=] {-_;J My Community Site » Groups

-] Blogs
-5 Files
(&) Forums
(=) ||Groups
B0 _] Create
| ] Home
-] Logon page
] Media
-] News
-] Search

i 1 Save and create anather

Page name: Management
(7 Use page template () Inheritfrom parent page @ Create a blank page

Layout name:

Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells
|
Three columns Three columns (CSS) Top row, three columns,

bottom row

12
Simple

Simple layout with one web part zone.

Copy this layout to my page template

Grid 3x2 cells (CSS)

Top row, two columns,
bottom row

Simple

Two columns

239

Sign out

i
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Groups management
Template code name: MyCommunitySite.GroupsManagement
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager  Site: | My Community Site User: Global Administrator v5.0.
232 Kentico x Communty site =] “
#4% CMS Desk Content  Mydesk  Tools  Administration
S c u —
O [ Oew Tw @ @ B2
New Delete |= Move & pown | Edit Preview Live site List ‘ Search ‘
Content management | View mode | Other
=14} My Community Site Page  Design  Form | Properties
‘%‘ :FIH Blogs General
(1) Files E Save
: URLs
[+)-] Forums
d u_l Groups Template
L[] Create Metadata Template
i “..| ||Management Categories Ad-hoc: Management Select
: Home " = ( )
H & e = fericizis ] | @) Page template - Save as new -- Webpage Dialog M
i [] Logon page ol Sy Fave 3z new lemplte . =
] Media cm =
: Vo @ imherttermpiate ,‘.4 Save as new page template
Lo News o T
: Bs h Related docs
E== E Edittemplate properties ) .
Linked docs Template display name: My Community Site - Groups management
Security Template code name:  MyCommunitySite. GroupshManagement
Attachments Inherit content Template category WMy Community Site templates E

@ Use page template settings]

This is the Groups management -
) Donotinherit any content

page of My Community Site.
() Selectinherited levels

Template description

()

http://localk €L Local intranet | Protected Mode: Off

4. On the same tab, click the Edit template properties link. In the pop-up window, switch to the Layout
tab and replace the original layout with the following code:

<di v cl ass="subcontent D v">
<di v cl ass="foruntearch">
<ccl: OvsWbPart Zone | D="zoneCenter" runat="server" />
</ di v>
<di v cl ass="cl ear">&nbsp; </ di v>
</ di v>
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Click Save.

£ | Page Templates -- Webpage Dialog l&l

| Page template properties @
Templates » My Community Site - Groups management

General Sites Layout Web parts Header Documents

ff_jl Check outto file

Check out the layout to file
C:\inetpub\wwwroot\50screenshots\ CMSTemplateLayouts\| MyCc itySite\GroupsI
layout externally.

t.ascx to edit the

) Use shared layout

Grid 2x2 cells

@ Use custom layout

subcontentDiv™> -
forumSearch™>

<ccl:CMSWebPartZone ID="zoneCenter" runat="server" />

</div>

<div class="clear">»snbap;</div>
</divs]

http://localhost/kenticocms/CM5SModules/PortalEngine/Ul/Pag & Local intranet | Protected Mode: Off

5. Switch to the Properties -> URLs tab and enter /Groups/{GroupName}/Management into the
Document URL path field.

Switch to Site Manager  Site: | My Community Site
232 Kentico : v siel]
#4% CMS Desk Content Mydesk  Tools Administration
A 3 C U
o [x Boew % | 3 [Q @ BH | L
New Delete = Move & Down Edit Preview Live site List Search
Content management | View mode | Other
|:'l'{t‘_;'l My Community Site Page Design Form | Properties
‘1“—] B.Iogs General
()-G) Files
T = URLs
[#-|| Forums
|£l .J Groups Template
[ Create Metadata Path
._] Management Categories Document alias: Management
I_] Home Menu Document URL path: /Groups/{GroupName}/Management
L] Logon page Workflow Use custom URL path
.| Media
'J. - Versions
'—] ews Related i Extended properties
|| Search URL extensions:
Linked docs
X [[luse custom URL extensions
Security .
Track campaign:
Attachments
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6. Switch to the Design tab. First, we will add the Group security access web part. This web part
checks if the user has the appropriate permissions for this group and redirects her to the Access page,
which we will create later in this chapter, in case that the permissions are insufficient. Click the Add
web part () icon of the zoneCenter web part zone and choose the Community -> Group security
access web part. You do not need to set any properties of the web part, just leave all of them at the
default values. Click OK.

7. Below the Group securtity access, we will add the Static text web part, which will show the path to
the currently managed group in a form of breadcrumbs. Click the Add web part (<) icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties of
the web part, leave the rest of them at the default values.

e Web part control ID: Breadcrumbs
e Text:

<di v cl ass="G oupBreadcrunbs" >

<a href="~/ G oups. aspx" cl ass="CVsBr eadCr unbsLi nk">G oups</a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ {%

Communi t yCont ext . Cur r ent G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Curr ent G oup. G oupDi spl ayNane| (encode) t rue% </ a> <span

cl ass="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span

cl ass="CVBBr eadCrunbsCurrent |t eni' > { %CVBCont ext . Cur r ent Docunent . Docunent Nane|
(encode)true% </span>

</ di v>

Click OK.

8. Finally, we will add the Group profile web part. Click the Add web part (3F) icon of the zoneCenter
web part zone and choose the Community -> Group profile web part. Set the following properties of
the web part, leave the rest of them at the default values.

e Group name: (current group)

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.

|V /Groups{Management - page template: My C ity Site - Gi t £|

¥ Breadcrumbs @ ent
v GroupProfie @ manage this group.
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3.12.4 Creating the Access page

Many of the pages in the Groups section contain the Group security access web part. This web part
checks if the user is permitted to see the content of the page. When a user tries to access such a page
with insufficient permissions, she is redirected to the Access page. Here, a message is displayed telling
that access is not permitted. This message is displayed by the Group security message web part.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

-‘2'- Kenti.co Switch
#4% CMS Desk Content My desk Tools Administration
S ) & Beer  #w (4 [qd ~r
New | Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | Wiew mode | Other
= ) My Community Site » Groups
- Blogs -
T :‘—l ) New document
B Files =l
-] Forums
2| |/Groups Please select new document type:
[ create

[[] Page (menu item)

: ] Management

'—] LI =1 Article
| Logon page —

I_] Media ] Blog

I_] News 5 Cell phone
i..[] search P Event
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the

Page name field, enter Access and click Save.

Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out
CMS Desk Content | Mydesk  Took  Administration
3 [ copy T up
x L [q =R o
New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management View mode Other
=
=] !_;_/) My Community Site » Groups
(x-l] Blogs
o ’\fj Files E‘ Save and create another
(#-l.] Forums
(=) | |Groups Page name: Access
._I Create
| Management @ Use page template () Inheritfrom parentpage () Create a blank page
-] Home _ R
@ Logon page o :MI page templates Template name:
y ) Articles
-] Media -
3 Blank pages for widgets
-] News
y Blogs
|| Search
Community Site
Corporate Site ASPX
E-commerce
Events _StarterTemplate My Cummunity Site - ly C v Site - My C ity Site -
Blog creation Blog list Blog posts
FAQs =
Forums
H General
Home pages
Images
Job openings
Knowledge base L
Master templates . . . . . . . "
My Community Site - My Community Site - My C y Site - My C y Site -
Membership and security Blogs Forum search Forums Groups
Message boards
My Community Site templates
News
Newsletter
Offices
Press releases i
Products z
Templates with editable regig =
o) wiki _StarterTemplate
This is the starter page template of My Community Site. It will be used as the starting point for development
ry = < of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Access
Template code name: MyCommunitySite.Access
Template category: My Community Site templates
Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager

Select

Site: My Community Site EI User: Global Administrator v5.0

£ Page temp

232 Kentico
#1% CMS Desk Content My desk Tools Administration
E = [« U e @
S [y Boey  Rw A [ F
New Delete |=kMove & Down ‘ Edit Preview Live site List | Search
Content management | View mode | Other
I:-l'!‘b‘_."l My Community Site Page Design Form | Properties
w E B.Iogs General
(-] Forums =
8 :1 Groups Template
|1/ Access Metadata Template
-[] Create Categories _StarterTemplate
[ Management Menu -
[ Home o Save as newtemplate !
-[]] Logon page - =
- Eersions d i
. [l Media Q Inherit template
: 3 T Related docs —
;o News : 43/ Clone template as ad-hoc
i..[] search Linked docs =)
Security E Edit template properties
Attachments

Inherit content

@ Use page template settings
= Do notinheritany content
) Selectinherited levels

- Save as new -- Webpage Dialog

Template code name:

Template category:

Template description:

,;.jﬁ Save as new page template

Template display name: |My Community Site - Access

MyCommunitySite_Access
Wy Community Site templates

This is the Access page of My
Community Site.

http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Access into the Document URL

path field and click Save.

232 Kentico
'l‘ CMS Deslk Content My desk  Tools

Administration

Switch to Site Manager

Flcopy  Tup 4 pe

New Delete | Move & pown | Edit Preview Live site List | Search |
Content management | View mode | Other
C-"{“_;'J My Community Site Page Design Form Properties
'1"—] B_|0gs General |
(x)-75) Files E Save
= URLs =
[#-|| Forums
|:l|:] Groups Template
P |:] Access Metadata Path
] create Categories Document alias: Access
i ] Management Menu Document URL path: /Groups/{GroupMame}/Access
I_] Home Workflow Use custom URL path
~-|| Logon page
: 5 ¥ gd Leu Versions
edia )
N Related docs Extended properties
|_] SE s URL extensions:
‘.| 1 search inl ocs
'—] g [[JuUse custom URL extensions
Security .
Track campaign:
Attachments

Site: My Community Site [=]

5. Switch to the Design tab. First, remowe the Editable text web part from zoneCenter. We will add
the Static text web part instead of it. The Static text web part will be set up so that it displays the path
to the page in a form of breadcrumbs. Click the Add web part (#) icon of the zoneCenter web part
zone and choose the Text -> Static text web part. Set the following properties of the web part, leave the

rest of them at the default values.

e Web part control ID: Breadcrumbs
e Text:

<di v cl ass="G oupBreadcrunbs" >

</ di v>

<a href="~/ G oups. aspx" cl ass="CVsBr eadCr unbsLi nk">G oups</a> <span
cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ {%
Communi t yCont ext . Cur r ent G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Current G oup. G oupDi spl ayNane| (encode)true% </ a> <span

cl ass="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span

cl ass="CVBBr eadCrunbsCurrent I teni' > Access deni ed </ span>

Click OK.
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6. The main part of this page is the Group security message web part. The web part will display the
warning message about insufficient permissions. Click the Add web part () icon of the zoneCenter
web part zone and choose the Text -> Static text web part. You do not need to set any properties of
the web part, leave all of them at the default values.

7. The page is finished. In Design tab, it should look as in the following screenshot.

|V JGroups [ Access - page template: My Community Site - Access p|

w zoneCenter *

= zoneRight o
w Breadcrumbs {3 =
lmien"?d ¥ logonminiform {23

|V GroupSecurityMessage @}| {' Shortouts @I
Shortcuts

My profile
Edit my profie

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

3.12.5 Creating groups starter template

In this example, we will create another starter template. In the Groups section, there will be pages
displaying content of particular groups - group's profile, pages (articles), media libraries, group members
and group forums. All of the pages will contain the same three web parts, so we will create a starter
template with these web parts to facilitate development of these pages.

The page template will be based on the _StarterTemplate page template created in this chapter.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

=32 Kentico —
’.‘ €MS Desk Content My desk Tools Administration
1) [g Beer ®w | 3 [ @ B | AP
New | Delete |=» Move & Down Edit Preview Live site List Search
Content management | Wiew mode | Other
[E& ) My Community Site » Groups
5[] Blogs Y
-y ;'L' . New document
[+]- = Files —
¢|,_| Forums
21|/ Groups Please select new document type:
el Access [ Page (menu item)
sl Create
: :_----,_| Management = Article
-] Home ]
I_| Logon page W) Blog
] Media 3 Cell phone
-—| News I Event
| Search

{5 Event (booking system)
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter _GroupsTemplate and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Delste =sMove 4 Down

Content management

=] !_;_/) My Community Site
(x-l] Blogs
(-5 Files
(#-l.] Forums
(=]-|] (Groups
._I Access
|| Create
.| Management
Home
Logon page
Media
News
Search

W D i

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out

Tools Administration

Q@ & 5 kL 2]

Edit Preview Live site List Search

View mode Other
=

» Groups

E‘ Save and create another

Page name: _GroupsTemplate

@ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:

&) Articles "
Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Events

FAQs

Forums

General

Home pages

Images

Job openings
Knowledge base L
Master templates

_StarterTemplate My Community Site - My C ity Site - My C ity Site -
Access Blog creation Blog list

m

My Community Site - My Community Site - My G ity Site - My C ity Site -
Membership and security Blog posts Blogs Forum search Forums
Message boards

My Community Site templates

News

Newsletter

Offices

Press releases i
Products

Templates with editable regig =

o) wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.

2
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: _GroupsTemplate

Template code name: _GroupsTemplate

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

-\='- Kenti.co Switch to Site Manager  Site: My Community Sitelzl User: Global Administrator v5.0
#§% CMS Desk

Content My desk Tools Administration

_X [ copy i up E @ /C)

N;N De\éte = Move & Down ‘ Edit Preview Live site List Search ‘
Content management | View mode | Other
(€} My Community Site Page  Design  Form | Propertes
‘ﬂ ] Blogs General
(-3 Files E ave
= URLs
[#-| Forums
8 3 Groups Template
i -[J|_GroupsTemplate Metadata Template
,j Access Categories _StarterTemplate Select
-[] Create Menu , y
B b 3 & | Page template - Save as new -- Webpage Dialog ﬁ
;b || Management Woki Save as newtemplate
i[] Home = = s t lat
[l Logon page Versions Q Inherittemplate ‘\"4 BRER M RROE ST e
g ;] Med Related docs .
;i Media ; 43/ Clone template as ad-hoc
L] News Linked docs e Template display name: _GroupsTemplate
*|] search S [H Edittemplate properties Template code name: | _GroupsTemplate
Attachments Template category Wy Community Site templates |Z|
Inhert content This is the template fnrrﬁnma -
@ Use page template seftings pages of the Groups section.
H (=) Do notinherit any content Template description

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Design tab. First, we will add the Group links menu into zoneRight web part zone.
The menu will contain links interconnecting particular pages of the currently displayed group like its
forums, media, etc. The menu will be created using the Static text web part. Click the Add web part (
2k) icon of the zoneRight web part zone and choose the Text -> Static text web part. Set the following
properties of the web part, leave the rest of them at the default values.

e Web part control ID: Links
e Text:

<a href ="~/ G oups/ { %Comuni t yCont ext . Curr ent G oup. G oupNane?% . aspx" >Honme</ a><br />
<a href ="~/ G oup- pages/ { “Comuni t yCont ext . Curr ent G oup. G oupNane% / Pages.

aspx" >Pages</ a><br />

<a href ="~/ G oups/ { %Communi t yCont ext . Cur r ent G oup. G oupNane% / Medi a- | i st .
aspx">Medi a</ a><br />

<a href ="~/ G oups/{ % omruni t yCont ext . Curr ent G oup. G oupNane% / Menber s.

aspx" >Menber s</ a><br />

<a href ="~/ G oups/ { %Comuni t yCont ext . Curr ent G oup. G oupNane% / For uns.

aspx" >For uns</ a><br />

* Web part container: Community Site - Blue Box
e Web part container title: Group links

Click OK.

5. In zoneCenter, you first need to remove the Editable text web part that is already in the template.
Now that zoneCenter is clear, we can add Group security access web part to the top of the web part
zone. Click the Add web part (#) icon of the zoneCenter web part zone and choose the Community
-> Group security access web part. You do not need to set any properties of the web part. Just use the
default values and click OK.
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6. The page is now finished. In Design tab, it should look as in the following screenshot.

| - jGroups/_GroupsTemplate - page template: _GroupsTemplate

B

¥ zoneCenter

ok

| GroupsSecurityAccess (33|

= zoneRight

e

=

= |ogonminiform tgz,!

Shortcuts
My profile

Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog

7. Finally, delete the _GroupsTemplate page from the content tree. The page template will remain

saved and available.

2Y2 Kentico

4% CMS Desk Content
3 | [ copy i up
x -

New [Delete] = Move & Down

Content management

';"‘;_,'-' My Community Site

-] Blogs

_|’E:\J' Files

-] Forums

_| | Groups

i I,_, _GroupsTemplate I
-] Access
L[] create

“..[ 1 Management
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3.12.6 Creating the Profile page

The Profile page displays a profile of a group besed on the {GroupName} wildcard part of the URL, which
gets translated into a query string parameter and is then taken as the current group. More information
about wildcard URLs can be found in this chapter of Kentico CMS Developer's Guide.

The profile is displayed using the Group public profile based on the Community.Group.DisplayProfile
alternative form. You can learn how to modify the alternative form here.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

-‘:’- KQI'I thO Switch
4% CMSDesk Content My desk  Tools Administration

) [ By wuw o @ @ = | .

New | Delete |=»Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
[E& ) My Community Site + Groups
3] Blogs Y
T :‘—l i New document
[ERY Files =]
-] Forums
21| /Groups Please select new document type:
‘—] Access [) Page (menu item)
o] Create
: I_] Management = Article
] Home —
I_] Logon page W] Blog
[ Media 3 Cell phone
-l News ™ Event
‘] Search

% Event (booking system)
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Profile and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Delste =Move 4 Down
Content management
=] !_;_/) My Community Site

(x-l] Blogs

(-5 Files

(#-l.] Forums

(=]-|] (Groups
._I Access

|| Create

.| Management

Home

Logon page

Media

News

Search

W D i

Tools

Edit

» Groups

Page

@ Use page template

= Al
=]

Switch to Site Manager

Administration

@ & =2 kL

Preview Live site List Search

Other

View mode

E‘ Save and create another

name: Profile
() Inherit from parent page

page templates

Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Events

FAQs

Forums

General

Home pages

Images

Job openings
Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates
News

Template name:

_GroupsTemplate

My Community Site -
Blog list

Newsletter

Offices

Press releases

Products

Templates with editable regig

_GroupsTemplate

() Create a blank page

_StarterT: I}

Site:| My Community Site[+| User: Global Administrator v5.0.2688

My Community Site -
Blog posts

ity Site -

My C ity Site - My C
Access Blog creation
My C: ity Site - My C

Blogs

This is the template for some pages of the Groups section.

e b

ity Site -
Forum search

Sign out

m
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Groups profile
Template code name: MyCommunitySite.GroupsProfile

Template category: My Community Site templates
Template description: some text describing the page template

Select

Site: My Community S\teEI User: Global Administrator v5.0.

232 Kentico
#1%  CMS Desk Content | Mydesk  Tools Administration
S Co u B @
] g Bem Ww &4 @ 2 A~
New Delete |= Move & Down | Edit Preview Live site List ‘ Search
Content management | View mode | Other
(26} My Community Site Page  Design  Form | Properties
‘%‘ ] Blogs General
£ URLs
[#-] Forums
1) Groups Template
FE Metadata Template
Categories _GroupsTemplate
Menu !
i ; ve as new template,
il Logon page Versions # Inherit template
: ;_I Med Related docs —
: edia . 4=/ Clone template as ad-hoc
: [ News Linked docs =
] search Security E Edit template properties
Attachments

Inherit content
@ Use page template settings
) Do notinherit any content

(@) Selectinherited levels

£ | Page template - Save as new -- Webpage Dialog

;__.[ Save as new page template

Template code name

Template display name: My Community Site - Groups profile

Template category.

MyCommunitySite. GroupsProfile

My Community Site templates

This is the Groups profile page

of My Community Site.

=]

Template description

http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName} into the Document URL path
field and click Save.

Switch to Site Manager  Site: | My Community Site
232 Kentico v ty Ste =]
’.‘ CMS Desk Content My desk Tools Administration
Ci u e &
5 [ Boer R (4 [d F
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
C.l'{“_;'l My Community Site Page Design Form Properties
'1"_',_?]_‘ Bllogs General |
g Fles
T = URLs
[#--|| Forums

|:||_] Groups Template
i L[] Access Metadata Path
-[] Create Categories Document alias: Profile

I_] Management Menu Document URL path: |/Groups/{Grouplame}
|_] Profile Workflow Use custom URL path
Home .
N Ersions
- ;og;n $ELE Related oot Extended properties
edia e
URL extensions:
‘[l News Linked docs
E = X [[luse custom URL extensions
|_] Search Security .
Track campaign:
Attachments

5. Switch to the Design tab. We will start with zoneRight web part zone. Below the Group links info
box, we will add two more info boxes. The first one of them will be displaying the current group's
administrators. Click the Add web part () icon of the zoneRight web part zone and choose the
Community -> Group members viewer web part. Set the following properties of the web part, leave
the rest of them at the default values.

Web part control ID: GroupMembersAdministrators

Transformation name: Community. Transformations.MembersPreviewList

No record found text: There are currently no administrators.

Show filter: disabled

WHERE condition: MemberUserID IN (SELECT UserID FROM CMS_UserRole WHERE RolelD IN
(SELECT RolelD FROM CMS_Role WHERE RoleGroupID = {%Community Context.CurrentGroup.
GrouplD%}' AND RolelsGroupAdministrator = 1))

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatarlD, UserCreated,
UserName, AvatarGuid

e Web part container: Community Site - Red Box
e Web part container title: Group administrators

Click OK.

6. Below the group administrators, we will add the same Group members viewer web part, but this
one will be displaying the latest 5 approved members of the group. Click the Add web part () icon of
the zoneRight web part zone and choose the Community -> Group members viewer web part. Set
the following properties of the web part, leave the rest of them at the default values.

Transformation name: Community. Transformations.MembersPreviewList

No record found text: There are currently no members.
Show filter: disabled
ORDER BY condition: MemberApprovedWhen DESC
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Select Top N members: 5
Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatarlD,UserCreated,
UserName, AvatarGUID

Web part container: Community Site - Red Box
Web part container title: Group administrators

Click OK.

7. The zoneRight web part zone is finshed, so let's move to zoneCenter. To the top of the web part
zone, we will add a breadcrumbs heading using the Breadcrumbs web part. Click the Add web part (
4k) icon of the zoneCenter web part zone and choose the Navigation -> Breadcrumbs web part. Set
the following properties of the web part, leave the rest of them at the default values.

e Breadcrumb separator: <span class="TitleBreadCrumbSeparator'>&nbsp;</span>

e Content before: <div class="GroupBreadcrumbs">
e Content after: </div>

Click OK.

8. Below the breadcrumbs, we want the group's public profile to be displayed. This can be achieved
using the Group public profile web part, which displays the group's public profile based on the
specified alternative form. By default, the Community.Group.DisplayProfile alternative form is used. Click
the Add web part () icon of the zoneCenter web part zone and choose the Community -> Group
public profile web part. You do not need to set any properties of the web part. Just use the default
values and click OK.

9. Below the Group public profile, we will add a message board where group administrators will be able
to leave announcements. Click the Add web part (#) icon of the zoneCenter web part zone and
choose the Community -> Group message board web part. Set the following properties of the web
part, leave the rest of them at the default values.

e Message transformation: Community.Transformations.MessageBoardComments

e No messages text: There are no announcements at this time

e Display name: Group {%CommunityContext.CurrentGroup.GroupDisplayName|(encode)true%} board
e Access: Only group admin

e Enable subscriptions: enabled

e Board base URL: ~/Groups/{%Community Context.CurrentGroup.GroupName%?}.aspx

e Web part container: Community Site - Blue Box Light

e Web part container title: Group announcements

Click OK.

10. Now we will add a Group forum posts viewer. This web part will be set so that it will display the 5
latest posts in the group's forums. Click the Add web part (4) icon of the zoneCenter web part zone
and choose the Community -> Group forum posts viewer web part. Set the following properties of the
web part, leave the rest of them at the default values.

e Transformation name: Community. Transformations.ForumGroupPostsList

e Top N: 5

e Order by: PostTime DESC

e Selected columns: PostIDPath,PostForumID,PostText,PostTime,PostSubject
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Hide if no record found: disalbed
No record found text: There are currently no posts.

Web part container: Community Site - Blue Box Light
Web part container title: Latest in forums

Click OK.

11. The last web part on the page will be a Repeater displaying articles in the Group pages section.
Click the Add web part (4) icon of the zoneCenter web part zone and choose the Listings and
viewers -> Repeater web part. Set the following properties of the web part, leave the rest of them at the
default values.

e Web part control ID: MostRecentPages

e Path: /Group-pages/{%Community Context.CurrentGroup.GroupName%?}/Pages/%
e Document types: CMS.SimpleArticle

e ORDER BY expression: DocumentCreatedWhen DESC

e Transformation: CMS.SimpleArticle.SimplePreview

e Selected item transformation: CMS.SimpleArticle.Default
e Hide if no record found: disabled

e No record found text: There are currently no pages.

e Web part container: Community Site - Blue Box Light

e Web part container title: Most recent pages

e Content before: <div class="GeneralList">

e Content after: </div>

Click OK.
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12. The page is now finished. In Design tab, it should look as in the following screenshot.
|V JGroups [ Profile - page template: My Community Site - Groups profile y|
- zcieCenber _ * > zoneRight *
| LG = ﬁﬂ = |ogonminiform @,!
.
[ commison 3} shortes
My profile
|V GroupForumPostsViewer ’{éj,!| H&'ﬁﬁ
Latest in forums My invitations
[There are currently no posts. Create s new droup
Create a new blog
Sign out
Most recent pages
Group finks
[There are currently no pages.
Home
Pages
Media
Members
Forums
|
|V GroupMembersAdministrators @
|V GroupMembersViewer 1 @,!| ‘
3.12.7 Creating the Members page

On the Members page, users of the current group will be displayed. This will be achieved using the

Group members viewer web patrt.

If you right-click a user, you will be offered some actions by a context menu. This functionality is
provided in the transformation and here, you can find a description of how exactly it is achieved.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

232 Kentico
#§n  CMS Desk

Content My desk Toolz
Co u
D pv e A
Mew | Delete |= Move & Down Edit

Content management

-;l-\:-'_"l My Community Site v Groups

&[] Blogs
ﬂﬂ' Files
1|I_| Forums
;|_, Groups

Administration

d @ =

Preview Live site List
View mode

| New document

Please select new document type:

= Access |1 Page (menu item)
|| Create
=l Management = Artide
|| Profile -
— E
._I Home 'i] Blog
+-] Logon page 3 cell phone
& Media ¥ Event
|5 News 1 Event (booki o)
._| Search ¢ Event (booking system

@ a0

Switch

)3
Search
Other
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Members and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Delste =Move 4 Down
Content management
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(x-l] Blogs
(-5 Files
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Search

) D )

Tools

Edit

» Groups
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Administration

@ & =2 kL

Preview Live site List Search

Other

View mode

E‘ Save and create another

Page name: MVembers

@ Use page template

= Al
=]

() Inherit from parent page
page templates Template name:
Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
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Events

FAQs
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General
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Home pages

Images
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Master templates
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My Community Site templates

My Community Site -
Blog list
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Press releases

Products

Templates with editable regig

_GroupsTemplate

() Create a blank page
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This is the template for some pages of the Groups section.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Group members
Template code name: MyCommunitySite.GroupsMembers

Template category: My Community Site templates
Template description: some text describing the page template

Select

Site: My Community S\teEI User: Global Administrator v5.0.

232 Kentico
#1%  CMS Desk Content | Mydesk  Tools Administration
S Co u B @
5 _[& Bow Tuw [dl =2 | A
New Delete |= Move & Down | Edit Preview Live site List ‘ Search
Content management | View mode | Other
5] \;_;J My Community Site Page  Design  Form | Properties
‘%‘ ] Blogs General
e =
B URL:
[#-] Forums 3
1) Groups Template
i [ Access Metadata Template
I Categories _GroupsTemplate
| Management Menu §
|[Members Workflow Sasasnewlemele.
-] Profile 2
B Home Versions # Inherit template
g Related docs .
;] Legon page . 4+ Clone template as ad-hoc
: ] Media Linked docs =
] News Security E Edit template properties
‘.| ] search Attachments

Inherit content

@ Use page template settings
) Do notinherit any content
() Selectinherited levels

£ | Page template - Save as new -- Webpage Dialog

;;.ﬁ Save as new page template

Template code name:

Template category:

Template description:

Template display name: |My Community Site - Group members
MyCommunitySite. GroupsMembers
My Community Site templates E|

This is the Group members page of =+
My Community Site.

hitp://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLSs tab. Enter /Groups/{GroupName}/Members into the Document
URL path field and click Save.

Switch to Site Manager  Site:| My Community Site
22 Kentico v ty Site ]
"‘ CMS Desk Content My desk Tools Administration
] [x Doer T [4 [d A
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
C-"{“_;'] My Community Site Page Design Form Properties
'i‘_',_?l B_logs General |
[+)- Files E Save
- URLs =
[+~ Forums
|:l|_] Groups Template
i L[] Access Metadata Path
3 Categories Document alias: Members
Menu Document URL path: |/Groups/{GroupMame}/Members
Warkflow Use custom URL path
Versions
Related it Extended properties

2 Logon page
Y Media Linked docs

URL extensions:

- X [[luse custom URL extensions
News Security

‘.|| Search Attachments

Track campaign:

5. Switch to the Design tab. We can leave zoneRight as it is and go straight to zoneCenter. First, we
will add a breadcrumbs heading using the Static text web part. Click the Add web part (%) icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties of
the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
e Text:

<di v cl ass="G oupBreadcrunbs" >

<a href="~/ G oups. aspx" cl ass="CVsBr eadCr unbsLi nk">G oups</a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { %

Communi t yCont ext . Cur r ent G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Curr ent G oup. G oupDi spl ayNane| (encode) t rue% </ a> <span

cl ass="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span

cl ass="CVBBr eadCrunbsCurrent |t eni' > { %CVBCont ext . Cur r ent Docunent . Docunent Nane|
(encode)true% </span>

</ di v>

Click OK.

6. Below the heading, it will be useful to add some info text. We will use the Editable text web part for
this purpose. Click the Add web part () icon of the zoneCenter web part zone and choose the Text -
> Editable text web part. You do not need to set any properties of the web part, just leave all of them at
the default values.

Click OK.

7. Switch to the Page tab and enter the following text into the Editable text web part's text area.
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Bel | ow you can find |ist of group nenbers.

actions.

Click Save.

Right click the user to get available

8. Switch back to Design tab. Now we will add the Group members viewer web part, which displays
members of the current group. Click the Add web part () icon of the zoneCenter web part zone and
choose the Community -> Group members viewer web part. Set the following properties of the web

part, leave the default values for the rest of them.

e Transformation name: Community. Transformations.MembersList

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatarlD,

UserActivityPoints,UserName, AvatarGuid
e Page size: 9
e Paging mode: PostBack
e Group size: 9

e Web part container: Community Site - Blue Box Light

e Web part container title: All members

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.

| = /Groups/Members - page template: My Community Site - Group members

B

¥ zoneCenter =T == >
¥ zonel
= | iGroupSecurityAccess s
| ...... @‘H + logonminiform @
- ar| n
- editabletext @ of group members, Right dick the user to get available actions. Shortcuts
My profile
|V GroupMembersViewer @}| Edit my profile
My messages
My friends

My invitations
Create a new group
Create a new blog
Sign out

Group links
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Groups can have any number of media libraries. Because of this fact, we will create the Media list page.
On this page, a list of all media libraries of the current group will be displayed by the Group media
libraries viewer web part. After clicking a media library, users will be redirected to the Media page,
created in this chapter, where the content of the library will be displayed.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

Switch
=32 Kentico S
#1% CMS Desk Content My desk Toolz Administration
> Copy i up —=
5)5.2 O @ @ 3|,
MNew |Delete = Move & Down Edit Preview Live site List Search
Content management | iew mode | other |
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()5 Files
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L[] Create
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I_] Members
L[] Profile

| New document

Please select new document type:

[ ] Page (menu item)

=) Article

] Blog

2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Media list and click Save.
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. Master templates
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This is the template for some pages of the Groups section.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template category: My Community Site templates

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Media list
Template code name: MyCommunitySite.MediaList

Template description: some text describing the page template

Select

Site: My Community Site EI User: Global Administrator v5.0

232 Kentico
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E‘"Y“‘_.,'J My Community Site Page Design Form Properties
v a B.Iogs General
: URL:
[#)-] Forums :
d ;_] Groups Template
[0 Access Metadata Template
-[] Create Categories _GroupsTemplate
-] Management Mered
!_.1 Media list workfiow
-] Members - ==
ersions i’ i
Inherit te mplate
; [ Profile q Inherit template
I m Related docs .
x—] Home ; 43/ Clone template as ad-hoc
i..[]] Logon page Linked docs =)
i [ Media Security E Edit template properties
E ews Attachments
An ch
] search

Inherit content
@ Use page template seftings
(=) Do notinherit any content

() Selectinherited levels

| Page template - Save as new -- Webpage Dialog

Template code name:

Template category:

Template description:

;j[ Save as new page template

Template display name: My Community Site - Media list
MyCommunitySite MediaList
My Community Site templates |E|

This is the Media list page of My =~
Community Site.

http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLSs tab. Enter /Groups/{GroupName}/Media-list into the Document
URL path field and click Save.

-\2'- Kel'lthO Switch to Site Manager Site: My Community Site El
7% CMS Desk

Content My desk Tools Administration

S g Dow ®w | [J [q = | L
New Delete |= Move & pown | Edit Preview Live site List | Search |

Content management | View mode | other |

I:-I'\t_;'l My Community Site Page Design Form Properties

(-] Blogs
g General |
(- Files 7 E Save
-] Forums s
‘:‘a Groups Template
i [ Access Metadata Path
a Create Categories Document alias: Media-list
-] Management Menu Document URL path: |/Groups/{GroupName}/Media-list
-] [Media list Workflow Use custom URL path
Versions
Related docs Extended properties
Je= e URL extensions:
| ] Logon page s
g g 9 . pag g [l Use custom URL extensions
|_] Media Security .
o Track campaign:
,_] MNews Attachments
i..[] Search

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Static text web part.
Click the Add web part (4) icon of the zoneCenter web part zone and choose the Text -> Static text
web part. Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
e Text:

<di v cl ass="G oupBreadcrunbs" >

<a href="~/ G oups. aspx" cl ass="CVsBr eadCr unbsLi nk">G oups</a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ {%

Communi t yCont ext . Cur r ent G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Current G oup. G oupDi spl ayNane| (encode)true% </ a> <span

cl ass="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span

cl ass="CQVBBr eadCrunbsCurrent | teni' > Medi a </ span>

</ di v>

6. Now we will add some info text using the Editable text web part. Click the Add web part () icon of
the zoneCenter web part zone and choose the Text -> Editable text web part. You do not need to set
any properties of the web part, just leave all of them at the default values.

Click OK.

7. Switch to the Page tab and enter the following text into the Editable text web part's text area.

Bel | ow you can find |list of group nedia l|ibraries.

Click Save.
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8. Switch back to Design tab. We will add the Group media libraries viewer web part. Click the Add
web part (4F) icon of the zoneCenter web part zone and choose the Community -> Group media
libraries viewer web part. Set the following properties of the web part, leave the default values for the

rest of them.

e Hide if no record found: disabled

e No record found text: There are currently no media libraries.

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot.

| - [Groups/Media list - page template: My Community Site - Media list

B

T zoneCenter * ¥ zoneRight *
= {ian ityAccess o =
| s e = 2‘9—"‘4 = logonminiform ’te‘z,!
¥ Shor
- editabletext {:ez,! of group media libraries. Shortcuts
My profile
|' GroupMediaLibrariesViewer {‘Zy}| . ) Edit my profie
My Community Site... T
This is the global media library of M... :_v_r,:i\i:sons

Create a new group
Create a new blog
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3.12.9 Creating the Media page

When a user clicks a media library in a list on the Media list page, created in the previous chapter, she
is redirected to this page where the Media gallery web part displays the content of the selected library.
The name of the library is passed in the {GroupName}/{LibraryName} wildcard part of the URL of this
page. Then it gets translated into a query string parameter and displayed by the Media gallery web part
as the current group.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico e
#1% CMS Desk Content My desk Tools Administration
EL N L 4 [ [e EH e
New | Delete [= Move & pown | Edit Preview Live site List | Search |
Content management | WView mode | Other
5 ) My Community Site » Groups
3-[2] Blogs -
-y 4.‘—]_‘ . New document
= Files =]
-] Forums

dl_] Groups Please select new document type:

j (e [ Page (menu item)
| Create

I_] Management

- = Article
| Media list —
I_] Members '] Blog
L[] Profile B Cell phone
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Media and click Save.

SR

Kentico
CMS Desk Content | My desk
) 3 Bl copy i up
x
New Delete |= Move & pown
Content management
« ) My Community Site

-] Blogs
(-5 Files
-] Forums
(=)-1] (Groups
[0 Access
: ,_| Create
[ 1] Management
g ,_| Media list
[ Members
,_'i Praofile
-] Home
| Logon page
-] Media
] News
-] Search

Tools

A
Edit

» Groups

Switch to Site Manager

Administration

Cd] 8 A
Preview Live site List Search
View mode

Other

E‘- Save and create another

Page name: Media

@ Use page template

54 All page templates

=1

() Inheritfrom parentpage () Create a blank page
Template name:

Articles

Blank pages for widgets

Blogs

Community Site

Corporate Site ASPX

E-commerce

Site:| My Community Site[+| User: Global Administrator v5.0.3688

Sign out

2]

_ GroupsTemplate _ StarterTi

Events

FAQs

Forums

General

Home pages

Images

Job openings

Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates
News

Newsletter

Offices

Press releases

Products

Templates with editable regig

My Community Site -
Blog list

My Community Site -
Blog posts

12

_GroupsTemplate

My Ci ity Site -

Access

My C ity Site -
Blog creation

m

My C: ity Site -

Blogs

This is the template for some pages of the Groups section.

My C ity Site -
Forum search
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Group media
Template code name: MyCommunitySite.GroupMedia
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

-\='- Kentl.co Switch to Site Manager  Site: | My Community Site[+] User: Global Administrator v5.0.
#1% CMS Desk Content | My desk

Tools Administration

J‘ Hcopy Hup F. O /O

New Delete [=bMove & Down | Edit Preview Live site List Search ‘
Content management | View mode | Other
C‘\‘_,J My Community Site Page  Design  Form | Properties
';-/ ‘—I B.Iogs General
-G Files E ave
- URLs
-] Forums
d u:l Groups Template
g F Metadata Template
Categories _GroupsTemplate Select
M e R e T & | Page template - Save as new -- Webpage Dialog ﬂ
= Workflow FRNERS NI

|1 Media list 2 =

[ Members Versions @ hen empiate .‘4 Save as new page template

l] Profil Related docs .
. B n &/ Clone template as ad-hoc
¢ Home Lok=CLES =~ Template display name: My Community Site - Group media
- Ul Logon page Security [ Edittemplate properties Template code name:  MyCommunitySite. GroupMedia
g j Media Attachments Template category: My Community Site templates [=]
News
E=" S h Inherit content This is the group Media page of -

=l My Community Site
H @ Use page template settings "
) Do netinherit any content Template description
) Selectinherited levels
http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Library-{LibraryName} into the
Document URL path field and click Save.

Switch to Site Manager  Site: | My Community Site
232 Kentico v ty Ste =]
’.‘ CMS Desk Content My desk Tools Administration
0 g Boer  #w [q] A
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
C-l'{“_;'l My Community Site Page Design Form Properties
'1‘_',_?]‘ B.Iogs General |
T = URLs
[#--|| Forums
|:l|:] Groups Template
FE Metadata Path
Categories Document alias: Media
Menu Document URL path: /Groups/{GroupMame)/Library-{LibraryMame}
Workflow Use custom URL path
Versions
Related docs Extended properties

URL extensions:

Linked docs
2. Seanty [l use custom URL extensions
ECury
- og?n page Track campaign:
<] Media Attachments

1:] News

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Static text web part.
Click the Add web part (4) icon of the zoneCenter web part zone and choose the Text -> Static text
web part. Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
e Text:

<di v cl ass="G oupBreadcrunbs" >

<a href="~/ G oups. aspx" cl ass="CVsBr eadCr unbsLi nk">G oups</a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { %

Communi t yCont ext . Cur r ent G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Curr ent G oup. G oupDi spl ayNane| (encode) t rue% </ a> <span

cl ass="Ti t| eBr eadCr unbSepar at or " >&nbsp; </ span> <span

cl ass="CVBBr eadCrunbsCurrent |t eni' > { %CVBCont ext . Cur r ent Docunent . Docunent Nane|
(encode)true% </span>

</ di v>

Click OK.

6. Below the breadcrumbs, we will add another Static text web part. This one will provide a link back to
the list of the group's media libraries. Click the Add web part (%) icon of the zoneCenter web part
zone and choose the Text -> Static text web part. Set the following properties of the web part, leave the
rest at the default values.

e Web part control ID: BackLink
e Text:
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<a style="margin: 20px Opx Opx 98px;" class="Medi aBack" href="~/ G oups/{%
Communi t yCont ext . Cur r ent G oup. G oupNanme% / Medi a- Li st. aspx">Back to |ibraries</a>

Click OK.

7. The last web part in zoneCenter will be the Media gallery web part. This web part displays content of
the particular libraries based on the library name passed in query string. Click the Add web part ()
icon of the zoneCenter web part zone and choose the Media library -> Media gallery web part. Set
the following properties of the web part, leave the rest at the default values.

e Show subfolders content: enabled

e Hide folder tree: enabled

e Content before: <div style="padding: 10px Opx Opx 100px">
e Content after: <div class="clear"></div></div>

Click OK.

8. The page is now finished. In Design tab, it should look as in the following screenshot.

|' /Groups/Media - page template: My Community Site - Group media ﬂ|
* zoneCenter + -
|v I GroupSecurityAccess z@‘ﬂ ¥ _2oneRight 28
= logonminiform @}
St
h 4 or if n
<t Back to libraries My profile
Edit my profie
= MediaGallery @} My messages

My invitations
Create a new group
Create a new blog
Sign out
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3.12.10 Creating the Forums page

The forums page will provide the group forums functionality using the Group forum list web part. It will
display the content of the group forums based on the {GroupName} wildcard part of the URL.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico
1% CMS Desk

— )
| ] [ Copy

New | Delete |=b Move

Content management

Tools Administration

4 L [ H

Edit Preview Live site List

View mode

Switch

A

| Search |
Other

:In_il My Community Site

&2l Blogs

(-5 Files

|1||_] Forums
.j,_] Groups

¢ i.[] Access
I_] Create
I_] Management
] Media
-] Media list
-] Members
L[] Profile

v Groups

| New document

Please select new document type:

|1 Page (menu item)

') Blog
8 Cell phone
P Event
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Forums and click Save.

Kentico
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[ Copy

= Move

I

New Delate

Content
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My desk

Content management
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« ) My Community Site
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[ ] Management
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o[ Media list
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[ Profile
| Home
--|] Logen page
.| Media
-] News
|| Search

Switch to Site Manager

Tools Administration
i @ @ 32 | L
Edit Preview Live site List Search
View mode Other
» Groups

E‘ Save and create another

Page name: Forums

@ Use page template () Inheritfrom parent page () Create a blank page

=<3 All page templates Template name:
Loh) Articles

&3 Blank pages for widgets
&) Blogs

L. Community Site

® &) Corporate Site ASPX

&) E-commerce

Site: | My Community Site[+]| User: Global Administrater v5.0.26288

]
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My Community Site - My Community Site -
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ity Site -

My C ity Site - My C
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My C ity Site - My C
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;‘3}' My Community Site templates
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‘&) Templates with editable regic _GroupsTemplate
i) wiki This is the template for some pages of the Groups section.
o . v
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Forum search

Sign out
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Group forums
Template code name: MyCommunitySite.GroupForums

Template category: My Community Site templates
Template description: some text describing the page template

Select

Site: My Community Site EI User: Global Administrator v5.0

232 Kentico
"‘ CMS Desk Content My desk Tools Administration
S Co U ~ ry
O G Boe Ww 2 [4 = 0]
New Delete = Move & Down ‘ Edit Preview Live site List | Search
Content management | View mode | Other
(26} My Community Site Page  Desgn  Form | Properties
‘;‘ _‘Fl Blogs General
[+)-.] Forums 2
-1 Groups Template
i [ Access Metadata Template
|| Create Categories _GroupsTemplate
,_] Forums Mt -
!_.1 Management Workfiow Save as new template, ;
-] Media 5 s
— ersions
[ Media list q Inherit template
;_-] Memb Related docs .
i Members ; 43/ Clone template as ad-hoc
-] Profile Linked docs =
i1 Home Security E Edit template propedies
:.[] Logon page Attachments
] Media
[0 News Inherit content
H [l Search H @ Use page template seftings

(Do notinherit any content

() Selectinherited levels

& Page template - Save as new -- Webpage Dialog

L;ﬁ Save as new page template

Template code name:

Template category:

Template description:

Template display name: |My Community Site - Group forums
MyCommunitySite.GroupForums
Wy Community Site templates E

This is the Group forums page of -
My Community Site.

http://localk € Local intranet | Protected Mede: Off
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4. Switch to the Properties -> URLs tab. Enter /Groups/{GroupName}/Forums into the Document URL
path field and click Save.

Switch to Site Manager  Site: My Community Site
232 Kentico v ty Site =]
"" CMS Desk Content My desk Tools Administration
— — z i — —
EE! E] opy T up | 2 @ = | }3 |
New Delete |= Move & Down | Edit Preview Live site List Search |
Content management | View mode | other |
I:-I'{t_;'l My Community Site Page Design Form Properties
'ﬂ’_‘,_?l B.Iogs General |
9 Fles
T = URLs
[#--|| Forums
H Template

-] Groups
i i-[B Access Metadata Path

a Create Categaries Document alias: Forums

| ]|Forums Menu Document URL path: |/Groups/{GroupMame)/Forums

Q FERIEIELE Warkflow Use custom URL path
|| Media

|1 Media list

Versions

@ Members Related docs Eréind):d properties
extensions:
o e[ Profile Linked docs
J— X [l use custom URL extensions
IJ Home Security S
§ = Track campaign:
|_] Logon page Attachments

5. Switch to the Design tab. We will leave zoneRight web part zone as it is and start modifying
zoneCenter right off. First, we will add a breadcrumbs heading using the Static text web part. Click
the Add web part () icon of the zoneCenter web part zone and choose the Text -> Static text web
part. Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: Breadcrumbs
* Text:

<di v cl ass="G oupBr eadcr unbs" >

<a href="~/ G oups. aspx" cl ass="CVBBr eadCr unbsLi nk" >G oups</ a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { %

Communi t yCont ext . Current G oup. G oupNanme?% . aspx" cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Current G oup. G oupDi spl ayNane| (encode)true% </ a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&bsp; </ span> <span

cl ass="CVSBr eadCr unbsCurrent | t emt > { %CVSCont ext . Cur r ent Docunrent . Docurrent Nane|
(encode) true% </ span>

</ di v>

Click OK.

6. Below the breadcrumbs, we will add the Forum search box web part that will enable users to search
the forum content. Click the Add web part (%) icon of the zoneCenter web part zone and choose the
Forums -> Forum search box web part. Set the following properties of the web part, leave the rest at
the default values.

e Content before:

<di v cl ass="For unBear chBox" ><t abl e cel | spaci ng="0"
cel | paddi ng="0"><t r ><t d><b>Sear ch foruns: &bsp; </ b></t d><t d>
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® Content after:

</td></tr></tabl e></di v><div class="cl ear"></div>

Click OK.

7. The forum functionality itself is provided by the Group forum list web part. This is the only web part
that is needed for the whole forums structure, all forum content will be displayed from this page by this
web part. Click the Add web part () icon of the zoneCenter web part zone and choose the
Community -> Group forum list web part. Set the following properties of the web part, leave the rest at
the default values.

e Groups separator: <br />
e Base URL: ~/{%CommunityContext.CurrentGroup.GroupName%}/Forums.aspx
e Unsubscription URL: ~/Special-Pages/Forum-Unsubscribe.aspx

Click OK.

8. In step 6, we added the Forum search box web part to the page. Now we need to add another web
part to the page where the search results will be displayed. This can be achieved by the Group forum
search results web part. Click the Add web part (4) icon of the zoneCenter web part zone and
choose the Community -> Group forum search results web part. You do not need to set any
properties of the web part, just leave all of them at the default values.

Click OK.

9. The last web part in this web part zone will be the On-line users web part. It will be set up so that it
displays the number of users currently accessing the group's forum section. Click the Add web part (4
) icon of the zoneCenter web part zone and choose the Membership -> On-line users web part. Set
the following properties of the web part, leave the rest at the default values.

Transformation name: Community. Transformations.MembersOnline
Path: /Groups/{GroupName}/Forums

Use default cache dependencies: enabled

Content before: <br />

Click OK.
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10. The page is now finished. In Design tab, it should look as in the following screenshot.

| - [Groups/Forums - page template: Community Site - Group forums

B

T zoneCenter *
— = zoneRight +
i GroupSecurityAccess =
| @| = |ogonminiform @
[~ ereadaunis S r——r |
¥ ForumSearch @} Ehorauls
= T My profile
Edit my profie
¥ GroupForumList @ My messages
My friends
|V GroupForumSearchResults ’@,!| My invitations
- Create a new group
= OnlineUsers {g} "
b users ondine. Create a new blog

3.12.11 Preparing the Group pages section

3.12.11.1 Creating the Template page

This page is a special one. It will be used as a template for the group pages section, which is created for
each group under a specified page of the content tree, which we will create in this chapter. The group
pages section enables members of a group to create and edit articles related to the group and displayed

within the group's section.

On this page, there will be a Repeater displaying a list of articles of the particular group. This page will
also be used as a master page for the Pages page, which will be displaying the particular articles
placed under it. The Pages page will be created in the following chapter.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

212 Kentico
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Content management
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df_;‘ Files
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Edit Preview Live site List

View mode

¥ Groups

| New document

Please select new document type:
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] Blog

8 Cell phone
P Event

}& Event (booking system)

Switch

A

Search
Other
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Template and click Save.

22 Kentico

#1% CMS Desk

Switch to Site Manager

Content My desk Tools Administration
) Co U
i Dow T o =R
New Delete = Move & pown Edit Preview Live site List Search
Content management View mode Other
| My Community Site » Groups

®=
(3}
®=
S}

Site:| My Community Site[+| User: Global Administrator v5.0.3688

Sign out

ity Site -

m

ity Site -

’\E‘V E:IZQSS F‘ Save and create another
|| Forums
.| Groups Page name: Template
[0 Access
._.i Create @ Use pagetemplate () Inheritfrom parentpage () Create a blank page
: :: ;Zr:.;':;sement 54 All page templates Template name:
] Media Articles
._.i Media list Blank pages for widgets
-] Members Blogs
._.i Profile Community Site
.[2 Home Corporate Site ASPX
[ Logon page E-commerce Crou } _
. Events _ psTemplate _ StarterTi My Ci y Site My C Y
-] Media Access Blog creation
] News FAQs
-] Search H Forums
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Home pages
Images
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Knowledge base
Master templates . . . . . "
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Templates with editable regio _GroupsTemplate

This is the template for some pages of the Groups section.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Group pages template
Template code name: MyCommunitySite.GroupPagesTemplate
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

-\='- Kentl.co Switch to Site Manager Site: My Community S\teEI User: Global Administrator v5.0.
#§% CMS Desk

Content Mydesk  Toals Administration

£l Hcopy ®uw a P
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F URLs
.| Forums
8 :I Groups Template
: [l Access Metadata Template
1| Create Categories _GroupsTemplate W

Forums Menu
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l;] Media -
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£ Page template - Save as new -- Webpage Dialog ﬁ

';Iﬁ Save as new page template

l] Memb Related docs —
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[ Profile Linked docs = Template display name: My Community Site - Group pages template
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Logon page -
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http://localk € Local intranet | Protected Mode: Off
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4. Still on the Properties tab, click the Edit template properties link. In the pop-up window, scroll
down and check the Show as master template option. Also change the inheritance so that the page
template inherits from Level 0 and Level 2. Click Save in the pop-up window to save the changes and

close it.

& | Page Templates - Webpage Dialog

i

-/ Page template properties
Templates » My Community Site - Group pages template

General Sites Layout Web parts Header Documents

Template display name: My Community Site - Group pages t
Template code name: MyCommunitySite. GroupPagesTem
Category: My Community Site templates

This the Group pages tenpl
My Community Site.

Template description:

Thumbnail: Upload:

Template type: @ Portal page () ASPX page

[Show as master template: I
Inherit content:

() Inherit all
Do notinherit any content

@ Selectinherited levels

----- LevelD
|:| Levell
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ate of -
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m
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Local intranet | Protected Mode: Off

5. Switch to the Design tab. First, we will add a breadcrumbs heading using the Breadcrumbs web
part. Click the Add web part (4) icon of the zoneCenter web part zone and choose the Navigation ->
Breadcrumbs web part. Set the following properties of the web part, leave the rest at the default values.

e Starting path: /{0}/{1}/

e Breadcrumb separator: <span class="TitleBreadCrumbSeparator'>&nbsp;</span>

e Content before:

<di v styl e="paddi ng-1eft: 10px" cl ass="G oupBreadcrunbs">

<a href="~/ G oups. aspx" cl ass="CVsBr eadCr unbsLi nk">G oups</a> <span

cl ass="Ti t| eBreadCr unbSepar at or " >&nbsp; </ span> <a href ="~/ G oups/ { %

Communi t yCont ext . Cur r ent G oup. G oupNanme% . aspx” cl ass="CVSBr eadCr unbsLi nk" >{ %
Communi t yCont ext . Current G oup. G oupDi spl ayNane| (encode)true% </ a> <span

cl ass="Ti t | eBr eadCr unbSepar at or " >&nbsp; </ span>

* Content after: </div>
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Click OK.

6. Now we will add a repeater displaying a list of pages of the current group. Click the Add web part (4
) icon of the zoneCenter web part zone and choose the Listings and viewers -> Repeater web part.

Set the following properties of the web part, leave the rest at the default values.

e Web part control ID: repeaterPages

e Hide on subpages: enabled

e Path: ./Pages/%

e Document types: CMS.SimpleArticle

e Transformation: CMS.SimpleArticle.SimplePreview

e Hide if no record found: disabled

e No record found text: There are currently no pages.

e Web part container: Community Site - Blue Box Light
e Web part container title: Most recent pages

e Content before: <div class="GenerallList">

e Content after: </div>

Click OK.

7. Finally, we will add the Page placeholder in which the page with the particular article will be

displayed. Click the Add web part (4) icon of the zoneCenter web part zone and choose the General
-> Page placeholder web part. Leave all the properties of the web part at the default values and click

OK.

8. The page is now finished. In Design tab, it should look as in the following screenshot.

B

| - /Groups/Template - page template: My Community Site - Group pages template
= zoneCenter *
= zoneRight
| - GroupSeq.nntyﬁccEss @| > +
...... = |ogonminiform ’,ﬁ}
¥ breadcrumbs @} Shortouts @
T Shor i ]
My profile
Most recent pages Edit my profile
[There are currently no pages. My messages
My friends
= My invitations
¥ [|pageplaceholder sté‘.:} Create a new group

Create a new blog
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3.12.11.2 Creating the Pages page

This page also senes as the template for the group pages section. It will be copied along with the
Template page to the specified path on each group's creation to form the group's group pages section.

On the page, there will be a Repeater for displaying the articles. We will also need the User
contributions module web parts providing on-site adding and editing of articles. For more details about
the User contributions concept, please refer to the Module User contributions chapter of Kentico CMS

Developer's Guide.

1. Select the Groups page in the content tree and click New. Choose the Page (menu item)

document type.

Switch
232 Kentico
#4™ CMS Desk Content My desk  Tools Administration
g [cov T 4  [&d [ = ~r
New |Delete |2 Move & Down | Edit Preview Live site List | Search |
Content management | View mode Other
l:‘!l_,l My Community Site + Groups » Template
3] Blogs >
= 4.‘—]_‘ . New document
[+]- = Files —
|1||_] Forums

-] Groups Please select new document type:

: I_] Template
[ Home

|1 Page (menu item)

') Blog

8 Cell phone

P Event

& Event (booking system)
@Fa0
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2. Select the My Community Site templates -> _GroupsTemplate created in this chapter. Into the
Page name field, enter Pages and click Save.

:!1. Kentico Switch to Site Manager  Site:| My Community Site =] User: Global Administrator v5.0.3688 Sign out
#1% CMS Desk Content | Mydesk  Tools  Administration
) S0 e | @ @ =] L | o
New Delete = Move & Down Edit Preview Live site List Search
Content management | View mode ||__other —]
l:/'!'," My Community Site » Groups + Template
Z"\E‘,\j i:l:gss E‘ Save and create another
-] Forums
(=)-] Groups Page name: Pages
[0 Access
._.i Create () Use page template () Inheritfrom parentpage (@ Create a blank page
|] Forums R
J Management Ll e
o[ Media -
g I_| Media list
g I_| Praofile
.|| Template
~—‘: Home Grid 2x2 cells Grid 2x2 cells (CSS) Grid 3x2 cells Grid 3x2 cells (CSS) Simple
| Logon page
] Media 3
-] News H
|| Search

Three columns Three columns (CSS) Top row, three columns, Top row, two columns, Two columns
bottom row bottom row
[— — —— [——| [— i
12
Simple

Simple layout with one web part zone

Copy this layoutto my page template

© 2010 Kentico Software



284

Kentico CMS 5.0 Community Site Guide

3. Switch to the Properties tab and click the Edit template properties link. In the pop-up window,
scroll down and select the inheritance so that the page template inherits from Level 0 and Level 2.
Click Save.

& | Page Templates -- Webpage Dialog ﬁ

3 Page template properties @

Templates » Ad-hoc: Pages

General Layout Web parts Header Documents

Template display name:  |Ad-hoc: Pages
Template code name: 296cf491-8286-4732-b8d2-c20467b89b46
Category: Ad-hoc [~] -

Template description: Generic default template -

Template type: @ Portal page ) ASPX page

ik}

Show as master template: O
Inherit content: () Inherit all

© Do notinherit any content

@ Selectinherited levels

----- Leveld
D Levell i
Level2
|:| Leveld
[ Leveld
] Levels =
http:/flocalhost/kenticocms/CMSModules/PortalEngine/Ul/Page € Local intranet | Protected Mode: Off

4. Switch to the Layout tab and replace the original layout code with the following code:

<di v cl ass="subcontentD v">
<di v cl ass="cont ent G oupPages" >
<ccl: CvBWebPart Zone | D="zonelLi st" runat="server" />
</ di v>
</ di v>
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Click Save.

& | Page Templates -- Webpage Dialog ﬁ
Lo
=

Page template properties @
Templates » Ad-hoc: Pages

General Layout Web parts Header Documents

E Save f?l Check outto file T

»

Check out the layout to file C:\inetpub\wwwroot\50screenshots\CMSAdhocTemplateLayouts\e96cf491-8286-47a2-
b8d2-c20467b89b46.ascx to edit the kyout externally.

() Use shared layout

Grid 242 cells

@ Use custom layout

<div class="subcontentDiv">
<div class="contentGroupPages">

m

<ccl:CMSWebFartZone ID="zonelist" runat="server"” />
</divy
</div>

http://localhost/kenticecms/CMSModules/PortalEngine/Ul/Page €& Local intranet | Protected Mode: Off
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5. Back on the Properties -> Template tab, click the Save as new template link. Enter the following
details in the pop-up window:

Click OK.

232 Kentico
#§% CMS Desk

D Copy

= Move

X

New Delete

Content

My desk Tools

I up
& Down ‘ Edit

Content management

[l r
Preview Live site List |

View mode

Switch to Site Manager

Search

| Other

Template display name: My Community Site - Group template - Pages
Template code name: MyCommunitySite.GroupTemplatePages

Template category: My Community Site templates
Template description: some text describing the page template

= f-_j My Community Site
(@[] Blogs
,1/ ) Files
(@[] Forums
=[] Groups
i [ Access
-[J] Create
,:] Forums
[ Management
[ Media
-] Media list
| Members
i -] Profile
i .;|,_] Template
[1lPages
i..[] Home
i~ ] Logon page
i.[0] Media
J News
[l search

Page Design

General
URLs
Template
Metadata
Categories
Menu
Workflow
Versions
Related docs
Linked docs
Security
Attachments

Farm Properties

Template
Ad-hoc: Pages

Select

Site: My Community Site EI User: Global Administrator v5.0

7

Saye as new template

@ Inherit template

E Edit template properties

Inherit content

@ Use page template settings
= Do natinheritany content
) Selectinherited levels

| Page template - Save as new -- Webpage Dialog

J Save as new page template

Template code name:

Template category.

) Community Site.
Template description

Template display name: |My Community Site - Group template - Pages
MyCommunitySite. GroupTemplatePages
My Community Site templates E|

This is the Pages page of the -
group pages template of My

http://localk € Local intranet | Protected Mode: Off

6. Switch to the Design tab. First, we will need the Group security access web part to ensure that only
users with appropriate permissions can access the group pages. Click the Add web part () icon of
the zoneList web part zone and choose the Community -> Group security access web part. You do
not need to set any properties of the web part, just leave the default values for all of them.

7. Click the Add web part (%) icon of the zoneList web part zone and choose the Community ->
Group contribution list web part. Set the following properties of the web part, leave the rest of them at

the default values.

e Hide on subpages: enabled

e Path: ./%

e Path for new documents: ./%

e Allowed new document types: CMS.SimpleArticle
e Alternative form name: PublicSimpleArticle

e Display list of documents: disabled
e New item button label: New page

e List button label: Pages

e Select only published: disabled
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e Allow editing by users: Authenticated
Click OK.

8. Click the Add web part () icon of the zoneList web part zone and choose the Community ->
Group edit contribution web part. Set the following properties of the web part, leave the rest of them at
the default values.

e Show for document types: CMS.SimpleArticle
e Alternative form name: PublicSimpleArticle
Allow editing by users: Authenticated
Content before: <div class="Contributions">
Content after: </div>

Click OK.

9. Finally, we will add a Repeater for displaying the articles. Click the Add web part (%) icon of the
zonelList web part zone and choose the Listings and viewers -> Repeater web part. Set the following
properties of the web part, leave the rest of them at the default values.

e Web part control ID: ArticleRepeater

e Path: ./%

e Document types: CMS.SimpleArticle

e Transformation: CMS.SimpleArticle.SimplePreview

e Selected item transformation: CMS.SimpleArticle. Default
e Navigation buttons: None

e Hide if no record found: disabled

e No record found text: There are currently no pages.
e Content before: <br /><div class="GeneralList">

e Content after: </div><br />

Click OK.

10. The page is finished. In Design tab, it should look as in the following screenshot.

Blogs Forums Groups Home Media News Search
Groups »
| - [Groups/Template/Pages - page template: My Community Site - Group template - Pages j| Shortcuts
- My profile
T zonelist 4k Edit my profile
| v || GroupsecurityAccess @| My messanes
- My friends
| ¥ GroupContributionList Qﬂ My invitations

Create a new group

v GroupEditContribution
| = tgl,!| Create a new blog

¥ ArticdeRepeater @} s Sign out
Group links
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3.12.11.3 Creating the Group pages title page

The Group pages page will not be displayed in the site navigation. It will also not contain any content.
The only purpose of this page it for the group pages sections of particular groups to be placed under it. It
is important to set the alias path of this page in the Template target alias path property of the Group
registration web part, which was added to this page.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Page (menu item)

document type.

Switch

232 Kentico
'l‘ CMS Desk Content My desk Tools Administration
C U e
) g Boer W 4 & [ = 2
New | Delete = Move 4 Down | Edit Preview Live site List | Search
Content management | iew mode Other
(=& /My Community Site My Community Site
5-[] Blogs Y
'1' :‘—l ) New document
[+ Files —
|1||_] Forums
1] Groups Please select new document type:
‘—] Home [ Page (menu item)
:~|.] Logon page
I_] Media €] Blo
|_] News -
“..[] search & Folder

2. Choose to Create a blank page using the Simple layout. For Page name, enter Group pages and

click Save.

R 7 i Switch to Site Manager  Site: | My Community Site [

=e= Kentico

#4%  CMS Desk Content | Mydesk Tooks  Administration

3 3 [ U -
2 & Bl 4 [ B & P

New Delete = Move & pown | Edit Preview Live site List | search |

Content management | View mode other |

-6 /My Community Site

My Community Site

Spell check

) Inheritfrom parentpage @ Create a blank page

]

(J-.| Blogs
&) G Files E‘ Save and create another
-] Forums
(-] Groups Page name: Group pages
|| Home
-] Logon page () Use page template
] Media
[ News Layout name:
|| Search

Grid 2x2 cells

Three columns

Grid 2x2 cells (CSS)

Grid 3x2 cells (CSS)

e

Grid 3x2 cells

Il

Three columns (CSS) Top row, three columns,

bottom row bottom row

[—— ]
12

|

Simple

Simple layout with one web part zone.

Copy this layout to my page template

Top row, two columns,

User: Global Administrator v5.0 3688 Sign out

(2]

=

Simple

Two columns

(]
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3. Switch to the Properties -> Menu tab and disable the Show in navigation option. Click Save.

Switch to Site Manager  Site: My Community

232 Kentico

#2% CMS Desk Content My desk  Tools Administration

> | C u D
=) B Eiceey  #u (4 [d F
New Delete |= Move & Down | Edit Preview Live site List | Search |

Content management | View mode | Other |
l:l!l_’l My Community Site Page  Design  Form | Properties

‘ﬂr‘c—l B_logs General

[+]-°5)] Files E Save

T = URLs

[+-|_] Forums

~[1/Group pages e

|1I|_] Groups Metadata Basic properties

|_] Home Categories Menu caption:

._] Logon page Menu Show in navigation|

n_] Media Waorkflow Show in sitemap:

S ] News 2

§ = ‘ersions

‘] 5earch

4. That's the page finished, now you've got to enter its alias path in the site settings and the group pages
of particular groups may be stored under it.
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3.13 Creating the Members section

3.13.1 Creating the Members page

This page will be the title page of the Members section. We will base it on the _StarterTemplate page
template created in this chapter. Besides the web parts from this page template, the page will contain
two Users viewer web parts in the zoneCenter web part zone. The first one will be displaying the 6
most active users of the site. The second one will be displaying all site users, with the pager enabled
and 9 records by page. In zoneRight, there will also be the On-line users web part showing who is
currently on-line.

If you right-click a user in of of the Users viewer, you will be offered some actions by a context menu.
This functionality is provided in the transformation and here, you can find a description of how exactly it
is achieved.

1. Select the root of the content tree and click New. Choose the Page (menu item) document type.

Switch
3£ Kentico =
'l‘ CMS Deslk Content My desk Toals Administration

| C U

2} & Boer %*w | [ [ @ B | AP

New | Delete | = Move 4 Down Edit Preview Live site List Search
Content management | iew mode | Other
=& /My Community Site My Community Site

5[] Blogs -

T ;l i New document

= Files —

-] Forums

i.[] Group pages Please select new document type:

‘1“—] Cros [[] Page (menu item)

+-] Home

I_] Loggn page €] Blo

o] Media -

._] News ) Folder

i..[]] search
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Members and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Deleste =bMove & Down

Content management

=] !_;_/) My Community Site
(x-l] Blogs
(-5 Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
Logon page
Media
News
Search

Tools Administration

@ & =2 kL

Switch to Site Manager

Edit Preview Live site List Search

View mode

My Community Site

Page name: MVembers
@ Use page template

54 All page templates

) Articles

Blogs

Events
FAQs
Forums

Images

News

Offices

Other

E‘ Save and create another

Community Site
Corporate Site ASPX
E-commerce

General
Home pages

Job openings

Knowledge base

Master templates

Membership and security Blog list
Message boards

My Community Site templates

Newsletter
Press releases

Products
Templates with editable regig

i

Template name:

Blank pages for widgets

_GroupsTemplate

My Community Site -

2
_StarterTemplate

() Inheritfrom parentpage () Create a blank page

Site: | My Community Site [+

User: Global Administrator v5.0.3688

_StarterT:

My Community Site -
Blog posts

My C ity Site - My C ity Site -
Access Blog creation

My C ity Site - My C ity Site -
Blogs Forum search

Sign out

m

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

e Template display name: My Community Site - Members

e Template code name: MyCommunitySite.Members

e Template category: My Community Site templates

e Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager Site: My Community Site EI User: Global Administrator v5.0

212 Kentico

#1% CMS Desk Content My desk Tools Administration
C Ui B 3}
O [y Ocm #w 2 O = | L
New Delete | =¢Move & Down ‘ Edit Preview Live site List | Search ‘
Content management | View mode | Other
':."‘"._.,'J My Community Site Page Design Form | Properties
‘ﬂ ] Blogs General
H ﬁ e
H URLs
[#)-] Forums
3 Template
i1 Group pages
(2-[2] Groups Metadata Template
| Home Categories _StarterTemplate Select
i..[] Logon page Menu [ i ==
[ Media o =) B aE e tempiate £ | Page template - Save as new -- Webpage Dialog
~_||Members e =
- Versions @ lonerttemplete 4 Save as new page template
L] News
g Bs h Related docs .
eard s :}u‘ Clone template as ad-hoc
Linl ocs E Template display name: |My Community Site - Members
Security E Edit template properties Template code name:  MyCommunitySite Members
Attachments Template category: Wy Community Site templates [+

This is the Members page of My -
Community Site.

Inherit content
@ Use page template seftings
H () Do notinherit any content Template description:

) Selectinherited levels

http://localk € Local intranet | Protected Mode: Off

4. Switch to the Design tab. Click the Add web part (4) icon of the zoneRight web part zone and
choose the Membership -> On-line users web part. Set the following properties of the web part, leave
the default values for the rest of them:

Transformation name: Community. Transformations.MembersOnline
Select top N: 20
Additional info text: {2} member(s) on-line:<br />

Web part container: Community Site - Orange Box
Web part container title: On-line members
Content after: <div><br /><a href="~/Members/Online.aspx">View all on-line members</a></div>

Click OK.

5. In the zoneCenter web part zone, we will want an info text displayed above the Users viewers. Click
the Add web part (4) icon of the zoneCenter web part zone and choose the Text -> Editable text
web part. Set the following properties of the web part, leave the default values for the rest of them:
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e Web part control ID: editabletextContent
Click OK.
6. Switch to the Page tab. Enter the following texts into the Editable text web parts' text fields:

e Heading: Members
e Content: Bellow you can find list of site members. Right click the user to get available actions.

Click Save.

............................................................................................................................

E Bellow you can find list of site members, Right dick the user to get available actions. i .

m

7. Now we will add the first Users viewer which will display the 6 most active users. Switch back to the
Design tab. Click the Add web part () icon of the zoneCenter web part zone and choose the
Membership -> Users viewer web part. Set the following properties of the web part, leave the default
values for the rest of them:

e Transformation name: Community. Transformations.MembersList

e Show filter: disabled

e ORDER BY condition: UserActivityPoints DESC

e Select Top N members: 6

e Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth, UserAvatariD,
UserActivityPoints,UserName,AvatarGuid

e Web part container: Community Site - Red Box Light
e Web part container title: Top members
e Content after: <div class="clear">&nbsp;</div>

Click OK.

8. The second repeater will display all site members paged by 9. Click the Add web part (%) icon of
the zoneCenter web part zone and choose the Membership -> Users viewer web part. Set the
following properties of the web part, leave the default values for the rest of them:

e Web part control ID: AllUsers

e Transformation name: Community. Transformations.MembersList

e Hide if no record found: disabled

e No record found text: No users found

Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatariD,
UserActivityPoints,UserName, AvatarGuid
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e Page size: 9

e Paging mode: PostBack

e Group size: 9

e Use default cache dependencies: enabled

e Web part container: Community Site - Blue Box Light
e Web part container title: All members

e Content after: <div class="clear">&nbsp;</div>

Click OK.

9. The page is now finished. In Design tab, it should look as in the following screenshot. Obviously,
because there are no users on the site yet, only the Administrator is displayed by the viewers. However,
you may try creating a few users via the administration interface or registering on-site. You will see the

new users listed on this page.

B

| T /Members - page template: My Community Site - Members
= zoneCenter
— * = zoneRight +
v editabletext {2 =
= |ogonminiform g:}
- ! ) ¥ Shorteuts {28
w» editabletextContent @ embers. Right dick the user to get available actions. I;
ortcuts
Top members Edit my profie
My messages
Admin My friends
My invitations
g;gl::leNr;ANfA Create a new group
Create a new blog
Sign out
v Allusers @ = Onlinelsers @}
Allmembers On-Tine members
Th t
Sort by: User name Activity -Iinje are currently no users on

Admin
Gender: NfA
Age: NfA

View all onine members
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3.13.2 Creating the Online page

In the previous example, we have put the On-line users web part to the right column. There is a link
added by the Content after property of the web part, leading to this page. On this page, there will be
another On-line users web part, which will display all users that are currently on-line.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico e
#4% CMS Desk Content My desk Tools Administration
: > C u —3 O
Bl B Q opy T up [ @ @] =
New | Delete = Move & Down | Edit Preview Live site List | Search |
Content management Wiew mode | COther
clp_’l My Community Site » Members
3-[.] Blogs -
= 4.‘—]_‘ . New document
[+]- = Files =]
|1||_] Forums
.. ] Group pages Please select new document type:
'1“—] oS | Page (menu item)
++||] Home
‘—] Logc_m BUE = Article
] Media —
“[[Members '] Blog
[ News B Cell phone
‘] Search ¥ Event
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Online and click Save.

Kentico
CMS Desk

[ Copy

= Move

Content
i up
& Down

Content management

*

New Delete

d'iq) My Community Site
-] Blogs
(-5 Files
[+]-1] Forums
-] Group pages
(+]-1] Groups
-] Home
.| Logon page
-] Media
| Members
-] News
| Search

My desk

Tools Administration
Edit Preview Live site List
View mode
¥ Members

E‘ Save and create another

Page name: Online
@ Use page template

= ;ﬁ All page templates
& Articles
- _"_‘}‘ Blank pages for widgets
&y Blogs
&) Community Site
&y Corporate Site ASPX
-5 E-commerce
&) Events
-5 FAQs
&) Forums
- General
.ﬂ' Home pages
:ﬂ‘ Images
:_'Q‘ Job openings
&y Knowledge base
.j‘ Master templates
) Membership and security
_"_‘}‘ Message boards
ij‘ My Community Site templates
&) News
& Newsletter
i) Offices
&) Press releases
i) Products
&) Templates with editable regio
- wiki

) Inheritfrom parent page

Switch to Site Manager

)

Search
Other

Spell check

() Create a blank page

Template name:

_GroupsTemplate _StarterTemplate

My Community Site -

My Community Site -
Blog list Blog posts

2
_StarterTemplate

Site: | My Community Site =] User: Global Administrator v5.0.3688

Sign out

)

Search

My Community Site -
Access

My Community Site -
Blogs

My Community Site -
Blog creation

m

My Community Site -
Forum search

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Members Online
Template code name: MyCommunitySite.MembersOnline
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

Switch to Site Manager  Site:| My Community Site User: Global Administrator v5.0
232 Kentico v o site ] v
"‘ CMS Desk Content My desk Tools Administration
= c U —] 1
o g Pew W [l A
New Delete | = Move & Down ‘ Edit Preview Live site List Search ‘
Content management | View mode | Other
(=14} My Community Site Page  Design  Form | Properties
‘ﬂ _‘Fl Bloos General
()] Forums =
|1 Group pages Template
[E3] :] Groups Metadata Template
J Home Categories StarterTemplate Select
8 - P!
_| Logon page o ( i
: s:] gon pag Menu = R e £ Page template - Save as new -- Webpage Dialog ﬁ
{8l Media Workfiow gl PR R NGBl —
5] Members i 'l Save as new e template
B - Versions Q Inherit template "'4 pag P
H || Online
: :1 N Related docs -
il News . 43/ Clone template as ad-hoc — -
i ] search Linked docs =/ Template display name: |My Community Site - Members Online
Security E Edit template properties Template code name:  |MyCommunitySite.MembersOnline
Attachments Template category: Wy Community Site templates [+
Inherit content This 1? t,he_Onllne page of My =
_ " Community Site.
@ Use page template settings
H ) Do notinheritany content Template description:

() Selectinherited levels

hitp://localk €& Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Members on-line to the heading Editable text web part's text field.
Click Save.

Members on-line

h
'
'
b e

© 2010 Kentico Software



298 Kentico CMS 5.0 Community Site Guide

5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and

choose the Membership -> On-line users web part. Leave all properties of the web part at their default
values and click OK.

6. The page is now ready. In Design tab, it should look as in the following screenshot.

| = /Members/Online - page template: My Community Site - Members Online y|

* zoneCenter *

= ¥ zoneRight *
+ editabletext § - =
Lmrrrwm—_r—g“grh'“ne = |ogonminiform 5@!}

_ ) v Shorteuts (&
| Onincldsers ,&} b users on-ine.

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out
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3.13.3 Creating the Profile page

On the Profile page, public profiles of users will be displayed based on the wildcard part of the URL. We
will set the page's URL to /Members/{UserName}. This means that if you type <sitename>/Members/
David.aspx into the browser, David will be recognized as the wildcard part of the URL and David's profile
will be displayed by this page.

The profile is displayed using the User public profile web part and is based on the cms.user.
EditProfileCommunity alternative form. You can find more information on how to modify the alternative

form in this chapter.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.

-‘='. Kenti.co Switch
#§% CMS Desk Content My desk  Tools Administration
2 C u E D

S )G B e 4 [d 2

New |Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | WView mode | other |
=4 ) My Community Site ¥ Members

-] Blogs Y

iy :‘—l 9 New document

- Files —

=[] Forums

|_] Group pages Please select new document type:

‘1"—] Groups | ] Page (menu item)

+~|.] Home

|_] Logon page = Article

bl Media -

=-[1[Members ] Blog

: i) online B cell phone

I_] News [ Event

| Search

¢ Event (booking system)
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Profile and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Delste =sMove 4 Down

Content management

=] !_;_/) My Community Site

(x-l] Blogs

(-5 Files

3} Forums
Group pages
Groups
Home
Logon page
Media
Members

®

o D ) ) ) ) ) i

._'j Online
News
Search

i

Tools Administration

Q@ & 5 kL 2]

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out

Edit Preview Live site List Search
Other

View mode

b Members

E‘ Save and create another

Page name: Profile
@ Use page template

54 All page templates

) Articles

Blogs

Events
FAQs
Forums
General

Images

News

Offices

Product:

Blank pages for widgets
Community Site

Corporate Site ASPX
E-commerce

Home pages

Job openings
Master templates
Membership and security Blog list Blog posts Blogs Forum search
Message boards

My Community Site templates

Newsletter

Press releases

S

Templates with editable regig

i

() Inheritfrom parentpage () Create a blank page

Template name:

_GroupsTemplate __StarterT: My C ity Site - My C ity Site -
Access Blog creation
Knowledge base L
My Community Site - My Community Site - My C: ity Site - My C ity Site -

2

_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Members Profile
Template code name: MyCommunitySite.MembersProfile

Template category: My Community Site templates
Template description: some text describing the page template

Select

Site: My Community Site E| User: Global Administrator 5.0

232 Kentico
#1% CMS Desk Content | Mydesk Tools  Administration
—, = i = —
2 & B  fuw 2 [ p
New Delete =k Move & Down ‘ Edit Preview Live site List ‘ Search
Content management | View mode | Other
C‘\‘_,] My Community Site Page  Design  Form | Properties
';/ '—I B.Iugs General
(-G Files
- URLs
[#)-|] Forums
‘[] Group pages Template
& ._l Groups Metadata Template
L] Home Categories _StarterTemplate
:|] Logon page Menu
: L1 Media v ,..,!g.gm.w.ig,m,g.lglem
5)-L.] Members 2
— Versions
= Inherittemplate
[ online Q Inherit template
Related docs —
@5 Clone template as ad-hoc
Linked docs =
| search Security E Edit template properties
Attachments

Inherit content

@ Use page template settings
) Do notinherit any content
() Selectinherited levels

£ | Page

- Save as new -- Webpage Dialog

;__.[ Save as new page template

Template code name:

Template category.

Template description

Template display name: My Community Site - Members Profile
MyCommunitySite MembersProfile
My Community Site templates |Z|

This is the Members Profile page -
of My Community Site.

http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLs tab and enter /Members/{UserName} into the Document alias

field. Click Save.
:l"- Kenti.co Switch to Site Manager  Site: My Community
'l‘ CMS Desk Content My desk Tools Administration
Ci u N )
S [ Boer ®w [d] e
New Delete |= Move & Down Edit Preview Live site List | Search |
Content management | View mode | other |
C"l‘_,] My Community Site Page  Design  Form | Properties
'ﬂ'—] B.Iogs General |
(#)-5) Files E Save
L URLs
[3]-|| Forums
I_] Group pages Template
-] Groups Metadata Path
I_] Home Categories Document alias: Members/{UserMame}
I_] Logon page Menu Document URL path:
[ Media okl Use custom URL path
=} | Members
= '_] ._] onli Versions
nline )
s — Related docs Extended properties
. ._] JLLE . URL extensions:
] News - LI
: ‘—] h Security [[luse custom URL extensions
SCure
‘—] BEalT Track campaign:
Attachments

5. Switch to the Design tab. In the zoneRight web part zone, we will want three info boxes - for
displaying the user's friends, blogs and groups. Let's start with the first one. Click the Add web part (dF

)

icon of the zoneRight web part zone and choose the Community -> Friends -> Friends viewer web

part. Set the following properties of the web part, leave the default values for the rest of them:

Transformation name: Community. Transformations.MembersPreviewList

No record found text: Currently doesn't have any friends.

Friend status: Approved

Selected columns: UserlD,UserNickName,UserGender,UserDateOfBirth,UserAvatarlD,UserCreated,
UserName, AvatarGuid

Web part container: Community Site - Gray Box

Web part container title: My friends

Click OK.

6. The second info box will be displaying links to the user's blogs. Click the Add web part (#) icon of
the zoneRight web part zone and choose the Listings and viewers -> Repeater web part. Set the
following properties of the web part, leave the default values for the rest of them:

Web part control ID: repeaterBlogs

Path: /Blogs/%

Document types: CMS.Blog

ORDER BY expression: DocumentCreatedWhen DESC

WHERE condition: NodeOwner = {%SiteContext.CurrentUser.UserlD%}'
Transformation: Community. Transformations.BlogsListRight

Hide if no record found: disabled

No record found text: Currently doesn't have any blogs.

Web part container: Community Site - Orange Box

Web part container title: My Blogs
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Click OK.

7. The third info box will be displaying the groups where the user is a member. Click the Add web part (
1) icon of the zoneRight web part zone and choose the Community -> Groups viewer web part. Set
the following properties of the web part, leave the default values for the rest of them:

e Transformation name: Community. Transformations.GroupsPreviewList

e Show filter: disabled

e ORDER BY condition: GroupDisplayName ASC

e WHERE condition: GroupID IN (Select MemberGrouplD FROM Community _GroupMember WHERE
MemberUserID = {%SiteContext.CurrentUser.UserID%}' AND MemberStatus = 0)

e Hide if no record found: disabled

e No record found text: Currently is not member of any group.

e Use default cache dependencies: enabled

e Web part container: Communty Site - Gray Box

e Web part container title: My groups

Click OK.

8. In the zoneCenter web part zone, the main web part is the User public profile. Click the Add web
part () icon of the zoneCenter web part zone and choose the Membership -> User public profile
web part. Set the following properties of the web part, leave the default values for the rest of them:

e Apply visibility settings: enabled
e Use visibility settings from: cms.user.EditProfileCommunity

Click OK.

9. Below the user's profile, there will be two message boards. The first one will be used only by the
owner of the profile. This will be where the user can post announcements for the other users. Click the
Add web part (3F) icon of the zoneCenter web part zone and choose the Message boards ->
Message board web part. Set the following properties of the web part, leave the default values for the
rest of them:

e Web part control ID: MessageBoardAnnouncements

e No messages text: There are currently no announcements.

e Display name: Anouncements of {%SiteContext.CurrentUser.FullName|(encode)true%}

e Message board owner: User message board

e Access: Only Owner

e Enable subscriptions: enabled

e Board base URL: ~/Members/{%SiteContext.CurrentUser.UserName|(encode)true%}.aspx
e Web part container: Community Site - Blue Box Light

e Web part container title: My announcements

Click OK.

10. Below the first message board, there will be another one. This one will be a public board, which
means that anybody can post messages on it. This is where users can leave comments on the user.
Click the Add web part () icon of the zoneCenter web part zone and choose the Message boards -
> Message board web part. Set the following properties of the web part, leave the default values for the
rest of them:

e Web part control ID: MessageBoardComments
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e No messages text: There are currently no comments.

e Display name: Comments on {%SiteContext.CurrentUser.FullName|(encode)true%}

e Message board owner: User message board

e Access: Only authenticated users

e Enable subscriptions: enabled

e Board base URL: ~/Members/{%SiteContext.CurrentUser.UserName|(encode)true%}.aspx
e Web part container: Community Site - Red Box Light

e Web part container title: Comments on me

Click OK.

11. The page is now ready. In Design tab, it should look as in the following screenshot.

|V /Members/Profile - page template: My Community Site - Members Profile y|
T zoneCenter * - Right +
zone
- [
v editabletext {3 ¥ logonminiform {23
= UserPublicProfile ’{Ey} d. Shortouts ’t:!‘,".g
{V or
|V MessageBoardAnnouncements ’{éj,!| Shortcuts
My announcements My profile
Edit my profie
[There are no messages.
My messanes
My friends
My invitations

Create a new group
Create a new blog

Sign out
¥ MessageBoardComments ’{éj,!|
Comments on me = FriendsVi ’t;,".!
[There are no messages. My friends
Currently doesn't have any
friends.

-~

¥ repeaterBlogs ,33
My Blogs

Currently doesn't have any
blogs.

¥ GroupsViewer @,!
My groups

Currently is not member of any
aroup.
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3.13.4 Creating the Members management starter template

Next on in the Members section, we will create a series of five pages that will be used by the users for
their accounts management. All the pages will have three web parts common in the zoneRight web part
zone. These will be info boxes displaying the user's blogs, groups and forum favorites. We will create a
starter page template to facilitate the creation of these pages.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico e
#1% CMS Desk Content My desk Toolz Administration
[=) 2 C U
)z B v | F [ @ H | L
MNew [Delete = Move & Down Edit Preview Live site List Search
Content management | View mode | COther
=4 ) My Community Site » Members
7] Blogs N
'ﬂ _‘;J. ) g New document
[+]- = Files —
|1|,_| Forums
._I Group pages Please select new document type:
'ﬂ‘—l TR [[1 Page (menu item)
-] Home
] Logon page =) Article
i-[] Media =T
-1 /Members ) Blog
¢ [ online 3 Cell phone
L[] Profile P Event
i [d] News )
: '_I I[& Event (booking system)
| Search
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter members management template and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Delste =sMove 4 Down

[SE4?

(€3}
®=
)

®

W i

e ) ) ) ) ) )

Content management

1 My Community Site
-1 Blogs

& Files

Forums
Group pages
Groups
Home

Logon page
Media
Members

._'j Online

|| Profile
News
Search

Tools Administration

Q@ & 5 kL 2]

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out

Edit Preview Live site List Search
Other

View mode

» Members

E‘ Save and create another

Page name: members management template

@ Use page template

54 All page templates

) Articles

Blogs

Events
FAQs
Forums
General

Images

News

Offices

Blank pages for widgets

Community Site
Corporate Site ASPX
E-commerce

Home pages
Job openings

Master templates
Membership and security Blog list Blog posts Blogs Forum search
Message boards

My Community Site templates

Newsletter
Press releases

Products
Templates with editable regig

i

() Inheritfrom parentpage () Create a blank page

Template name:

_GroupsTemplate __StarterT: My C ity Site - My C ity Site -
Access Blog creation
Knowledge base L
My Community Site - My Community Site - My C: ity Site - My C ity Site -

2

_StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

22 Kentico

g% CMS Desk Content

My desk

Template display name: _MembersManagement
Template code name: MembersManagement
Template category: My Community Site templates
Template description: some text describing the page template

Switch to Site Manager

Tools Administration

(=) :2“ [ copy I up

New Delete |= Move

Content management

& Down |
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Edit Preview Live site List

View mode | Other

(2 My Community Site
(-] Blogs
[+)-5 Files
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a Group pages
-[] Groups
i..[]] Home
] Logon page
] Media
5-] Members

Online
“|] Profile

a members management templa’

a News
.| search

Page Design
General
URLs
Template
Metadata
Categories
Menu
Workfiow
Versions
Related docs
Linked docs
Security
Attachments

Form Properties

|

Template
_StarterTemplate

Site: My Community Site E| User: Global Administrator v5.0.31

ﬂ Inherit template

«+/ Clone template as ad-hac
&

[H Evittemplate properties

Inherit content
@ Use page template settings
() Do notinherit any content

) Selectinherited levels

-
| Page template - Save as new -- Webpage Dialog

Template code name:

Template category:

Template description:

,\] Save as new page template

Template display name: |_MembersManagement
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My Community Site templates

This is the starter template for
the Members management section of

My Community Site.

[ o [ cancel |

=]

http://localk € Local intranet | Protected Mode: Off

© 2010 Kentico Software



308 Kentico CMS 5.0 Community Site Guide

4. Switch to the Design tab. We will place the three info boxes into the zoneRight web part zone. The
first info box will be displaying links to the user's blogs. Click the Add web part (#) icon of the
zoneRight web part zone and choose the Listings and viewers -> Repeater web part. Set the
following properties of the web part, leave the default values for the rest of them:

Web part control ID: BlogsRepeater

Path: /Blogs/%

Document types: CMS.Blog

ORDER BY expression: DocumentCreatedWhen DESC
WHERE condition: NodeOwner = {%CurrentUser.UserlD%}
Transformation: Community. Transformations.BlogsListRight
Hide if no record found: disabled

No record found text: You currently do not have any blogs.
Web part container: Community Site - Orange Box

Web part container title: My Blogs

Click OK.

5. The second info box will be displaying the groups where the user is a member. Click the Add web
part () icon of the zoneRight web part zone and choose the Community -> Groups viewer web
part. Set the following properties of the web part, leave the default values for the rest of them:

Transformation name: Community. Transformations.GroupsPreviewList

Show filter: disabled

ORDER BY condition: GroupDisplayName ASC

WHERE condition: GroupID IN (Select MemberGrouplD FROM Community_GroupMember WHERE
MemberUserID = {%currentuser.userid%} AND MemberStatus = 0)

Hide if no record found: disabled

No record found text: Currently is not member of any group.

Web part container: Communty Site - Gray Box

Web part container title: My groups

Click OK.
6. The last info box will be displaying the user's forum faworites. Click the Add web part (<) icon of the
zoneRight web part zone and choose the Forums -> Forum favorites web part. Set the following

properties of the web part, leave the default values for the rest of them:

e Web part container: Community Site - Gray Box
e Web part container title: Forum favorites

Click OK.
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7. That's the page template finished. In Design tab, it should look as in the following screenshot.

i

- page template: _MembersManagement

B

w zoneCenter

o

v editabletext {2

= zoneRight I*

o

= |ogonminiform ,_\:y}
Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

+ BlogsRepeater i:eo}

My Blogs
You currently do not have any
blogs.

|
My groups

Currently is not member of any
group.

‘

Forum favorites

Mo favorites found

10. Finally, you can delete the page created in this example. We will not need it anymore as the page
template is already saved and can be reused.
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3.13.5 Creating the Management page

The Management page can be used by site members to manage the details in their public profiles. This
functionality is achieved using the My account web part, based on the cms.user.
EditProfileCommunity alternative form.

1. Select the Members page in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico

#1% CMS Desk Content My desk Toolz Administration

E EL A L (4 [qd =

New |Delete [= Move & Down Edit Preview Live site List

Content management | View mode
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¢ ..l online 3 Cell phone
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: '_I I[& Event (booking system)
|zl Search
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A

Search
Other
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Management and click Save.

Kentico
€M Desk Content
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E‘ Save and create another
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@ Use page template () Inheritfrom parentpage () Create a blank page

54 All page templates Template name:
&) Articles

Blank pages for widgets
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Images
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This is the starter template for the Members management section of My Community Site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

Template display name: My Community Site - Members management
Template code name: MyCommunitySite.MembersManagement

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

232 Kentico
#1%  CMS Desk

witch to Site Manager

Site: My Community Site E| User: Global Administrator v5.0.31
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Inherit content
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4. Switch to the Properties -> URLSs tab. Into the Document URL path field, enter /Members/
{UserName}/Management and click Save.

Switch to Site Manager  Site: | My Communi
232 Kentico Y Y
#2% CMS Desk Content My desk Tools Administration
Ci u gl r
2 [ Do R [d] e
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
C"E‘_,J My Community Site Page Design Form Properties
‘ﬂ..lc_l B.Iogs General |
[+-= Files E Save
= URLs =
(-] Forums
-] Group pages Templats
[3-L] Groups Metadata Path
|_] Home Cateqories Document alias: Management
Logon page Menu Document URL path: |/iembers/{UserName}/Management

|_] Media Workflow Use custom URL path
(2|1 Members

= Versions
--L_||Management

Related docs Extended properties

URL extensions:
Linked docs

Security

[[use custom URL extensions

Track campaign:
Attachments

5. Switch to the Design tab. We will only need to place the My account web part to the zoneCenter
web part zone and set it up properly. Click the Add web part (4F) icon of the zoneCenter web part
zone and choose the Membership -> My account web part. Set the following properties of the web
part, leave the default values for the rest of them:

e Form name: cms.user.EditProfileCommunity
e Allow user to edit field visibility: enabled

e Display my address: disabled

e Display my orders: disabled

e Display my credit: disabled

e Display my subscriptions: disabled

e Display my messages: disabled

e Display my friends: disabled

e Content before: <divclass="myAccMenu">
e Content after: </div>

Click OK.
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6. Switch to the Page tab and enter My profile into the heading Editable text web part's text field. Click
Save.

My profile

h
'
'
e

7. The page is now finished. In Design tab, it should look as in the following screenshot.
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3.13.6 Creating the Invitations page

On the Invitations page, users will see their invitations to groups and will be able to manage them. This
functionality will be provided by the My invitations and My sent invitations web parts. The page is
accessible from the Shortcuts menu, by clicking the My invitations link.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Invitations and click Save.
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() Create a blank page

.

Template name:

My Community Site -
Access

_GroupsTemplate _MembersManagemen _StarterTemplate

My Community Site -

My Community Site -
Blog creation i

Blog list

My Community Site -
Blog posts

My Community Site -
Blogs

_MembersManagement

This is the starter template for the Members management section of My Community Site.

Sign out

@

m
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Invitations
Template code name: My Community Site.Invitations
Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

-‘:’- Kenti.co Switch to Site Manager  Site:| My Community Site[+| User: Global Administrator v5.0.3
1% CMSDesk Content | Mydesk  Tools  Administration
— — - i — —
B B Fce #*w | 3 [F =2 | L |
New Delete |=¢ Move & Down | Edit Preview Live site List | Search
Content management | View mode | other |
=14 ) My Community Site Page  Design  Form | Propertes
‘ﬂ'—l Bloos General
(-G Files E Save
- URLs
(-] Ferums
a Group pages Template
2 a Groups Metadata Template
i..[]] Home Categories IMembersManagement ﬁ
] Logon page M r N
: a Med o | Page template - Save as new -- Webpage Dialog ﬂ
i lal Media Workflow
5-|] Members - =
R _ e 7 \nherit template 4\.4 Save as new page template
. 2] Management g
T a TR Related docs —
= Ao 5 . :;J Clone template as ad-hoc
| Online Limici = Template display name: |My Community Site - Imvitations
[ profile Seaurity E Edit template properties Template code name: My Community Site.Invitations
News
L Al Template categary: My Community Site templates =]
o] Search
Inherit content B This 1z the Invitatlions page of -
@ Use page template settings My Community Site.
H ) Do notinherit any content Template description:

) Selectinherited levels

http://localk @ Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLSs tab. Into the Document URL path field, enter /Members/
{UserName}/Invitations and click Save.

Switch to Site Manager  Site: | My Communi
232 Kentico ’ w
#1% CMS Desk Content My desk  Tools Administration
O [ O wuw 3 P
New Delete |= Move d} Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
l:l!l_’l My Community Site Page  Design  Form | Properties
‘ﬂ'—] B_|0gs General |
lil@ Files E Save
= URLs
(-] Forums
i--|] Group pages Template
|il|_] Groups Metadata Path
._] Home Categories Document alias: Invitations
I_] Logon page Menu Document URL path: /iMembers/{UserMame}/Invitations
I_] Media Workfiow Use custom URL path
=J-.] Members
‘—' ‘—] . -+ o Versions
: C‘l—] e cuac U I Extended properties
i l/Invitations URL extensions:
|_] online Linked docs

i = [ [[luse custom URL extensions
‘-] Profile Security

- Track campaign:
|_] News Attachments

5. Switch to the Page tab. Enter My invitations into the Editable text web part's text field and click Save

_______________________

6. Switch to the Design tab. First, we will add the My invitations web part, which will display the user's
received invitations. Click the Add web part (%) icon of the zoneCenter web part zone and choose
the Community -> My invitations web part. Set the following properties of the web part, leave the
default values for the rest of them:

e Zero rows text: You have currently no invtations.

Hide control for zero rows: disabled

Web part container: Community Site - Blue Box Light
Web part container title: Received invitations

Click OK.
7. The second web part on this page will be displaying the user's sent invitations. Click the Add web
part () icon of the zoneCenter web part zone and choose the Community -> My sent invitations

web part. Set the following properties of the web part, leave the default values for the rest of them:

e Web part container: Community Site - Blue Box Light
e Web part container title: My sent invitations

Click OK.

© 2010 Kentico Software



Part 2 319

8. The page is now finished. In Design tab, it should look as in the following screenshot.

|V /Members/Management/Invitations - page template: My Community Site - Invitations y|
T zoneCenter
= * = zoneRight I*
v editabletext {2 =
S = logonminiform i_\:y}

_ v Shortcuts {23
Shortcts

Received Invitations
My profile

'vou have currently no invitations. Edit my profie

My messages

= My friends
T MySentInvitations ’e‘a.} My invitations
Create a new droup
Create a new blo
Sign out

+ BlogsRepeater i:eo}

My Blogs
You currently do not have any
blogs.

|
My groups

Currently is not member of any
group.

‘

Forum favorites

Mo favorites found
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3.13.7 Creating the Messages page

The Messages page will provide users with the functionality of private messaging. The page is
accessible from the Shortcuts menu, by clicking the My messages link. Its main part is the My
Messages web part. For more information on the Messaging module, please refer to Kentico CMS

Deeloper's Guide -> Module Messaging.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.

o

745 CMS Desk

New

Kentico

X }
Delete | = Mowve

Content management

|;'|-\_;_"J My Community Site
@-[2] Blogs
[3-"5 Files

[&)-|] Forums

I_| Group pages
&)-1.] Groups

|_| Home

I_| Logon page
] Media

|:I._I Members

¢ [=-L]Management

“.[ ] Invitations

-] online
: -] Profile
|_| News

Content

[ Copy T up
@ Down

Tools

L4

Edit

Administration

d @B =

Preview Live site List

View mode

r Members » Management

;' New document

Please select new document type:

|1 Page (menu item)

=) Article

'] Blog

8 Cell phone

¥ Event

% Event (booking system)

@r0

Switch

A

Search
Other
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Messages and click Save.

Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out
CMS Desk Content | Mydesk  Took  Administration
2 Copy T up
2 [d = A o
New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management | View mode || other
=
.j._; J My Community Site » Members » Management
(x-l] Blogs
o ’\fj Files E‘ Save and create another
(#-l.] Forums
|| Group pages Page name: Messages
(+)-.| Groups
[] Home @ Use page template () Inheritfrom parentpage () Create a blank page
-] Logon page _
T Media =& All page templates Template name:
= &) Articles
=11 Members -
e Blank pages for widgets B
=)~ .|IManagement
g . Blogs
g |1 Invitations
- Community Site
-] Online
y Corporate Site ASPX
|| Profile
N E-commerce
i News Events _GroupsT I _Member _StarterTemplate My Community Site -
.| Search Access
FAQs =
Forums
H General
Home pages
Images
Job openings
Knowledge base L
Master templates . . . . . . . "
My Community Site - My Community Site - My C y Site - My C y Site -
Membership and security Blog creation Blog list Blog posts Blogs
Message boards
My Community Site templates
News
Newsletter
Offices
Press releases i
Products B
Templates with editable regig —
o) wiki _MembersManagement
This is the starter template for the Members management section of My Community Site.
« m »
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

232 Kentico
1™ CMS Desk Content | Mydesk  Toos  Administration
B 8w e |3 Q@ @ 3|/,
New Delete |=Move & Down ‘ Edit Preview Live site List | Search
Content management | View mode | Other
=€) My Community Site Page  Desgn  Form | Properties
&[5 Blogs General
() & Files . E Save
[ [ Forums =
-] Group pages Template
@ L] Groups Metadata Template
= a Home Categories MembersManagement
] Logon page Menu .
to a Media Workflaw Save as newtemplate :
= ] Members =
3 Versions
_ Inherit template
- B Management q Inherit template
a Invitati Related docs —
il Invitations ) 4 Clone template as ad-hoc
;_] Messages Linked docs =
-] online Security E Edit template properies
a Profile Attachments
-] News
-] search Inherit content

Template display name: My Community Site - Messages
Template code name: My Community Site.Messages
Template category: My Community Site templates

Template description: some text describing the page template

Select

Site: My Community S\talz| User: Global Administrator v5.0.36

@ Use page template setings
Do notinheritany content
() Selectinherited levels

s
& | Page template - Save as new -- Webpage Dialog

Template code name:

Template category:

Template description

.‘_.; Save as new page template

Template display name: My Community Site - Messages

Iy Community Site_Messages

Wy Community Site templates

This is the Messages page of My

Community Site.

ok [ Cancel |

[=]

http:/flocalr € Local intranet | Protected Mode: OFf
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4. Switch to the Properties -> URLSs tab. Into the Document URL path field, enter /Members/
{UserName}/Messages and click Save.

Switch to Site Manager  Site: | My Communi
232 Kentico v ty
"" CMS Desk Content My desk Tools Administration
= C U ~ O
= = E] opy i up [ E @] =
New Delete |= Move & pown | Edit Preview Live site Llist || search |
Content management | View mode | Other
C‘!‘_,] My Community Site Page Design  Form | Properties
'ﬂ'—] B_|0gs General |
(-5 Files E Save
- URLs =
(-] Forums
i--|] Group pages Template
-] Groups Metadata Path
|_] Home Categories Document alias: Messages
._] Logon page Menu Document URL path: |/Members/{UserName)/Messages
[ Media oty Use custom URL path

d,_] Members

z — Wersions
=) ] Management !
;. [ Invitations Related docs Extended properties
- URL extensions:
|_] Messages Linked docs -
. h X [TTUse custom URL extensions
|| Online Security .

- Track campaign:
.| ] Profile Attachments

5. Switch to the Page tab. Enter My messages into the Editable text web part's text field and click
Save.

My messages

h
'
'
Lo mm e c e m e e
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6. Switch to the Design tab. Here, we will only need to add the My messages web part into the
zoneCenter web part zone. Click the Add web part (%) icon of the zoneCenter web part zone and
choose the Messaging -> My messages web part. You do not need to set any properties of the web
part, leave all of them at the default values.

7. The page is now finished, in Design tab, it should look as in the following screenshot.

|v /Memb fr it/ M -page template: My C ity Site - M ﬁ|
T zoneCenter
= * = zoneRight *
v editabletext {2 =
S * logonminiform ’zg‘,!
_ v Shortcuts {23
Contact list  Ignore list Shortcuts
My profile
Mew message Delete all messages Edit my profie
My messages
0 unread message(s) of 0 total My friends
My invitations
Create a new droup

Create a new blog
Sign out

+ BlogsRepeater ’é}

My Blogs

You currently do not have any
blogs.

|
My groups

Currently is not member of any
group.

¥ ForumFavorites ’é}

Forum favorites

Mo favorites found
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3.13.8 Creating the Friends page

On the Friends page, users will see an oveniew of their friends, provided by the Friends viewer web
part. Users will be able to request new friendships from this page too. There will also be a link to the
Manage friends page which we will create in the following example. Detailed information on the Friends
module can be found in Kentico CMS Deweloper's Guide -> Module Friends.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.

=32 Kentico

#1% CMS Desk Content My desk
;“ @ Copy i up

Nav Derléte b Move & Down |

Content management

Tools

L4

Edit

Administration

[d [ E

Preview Live site List

View mode

Switch

A

| Search |
Other

cl\-_’l My Community Site

-] Blogs

(5.5 Files

|1||_] Forums

I_] Group pages
@] Groups

I_] Home

[ Logon page
] Media

-] Members

-] |Management

] Invitations
I_] Messages
Online
Profile

» Members » Management

=] New document

Please select new document type:

| ] Page (menu item)

=] Article

i) Blog

8 Cell phone

¥ Event

& Event (booking system)

@ o
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Friends and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Delste =sMove 4 Down

Content management

=] !_;_/) My Community Site

(x-l] Blogs
(-5 Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
=11 Members
2 [1[Management

| Invitations
--|_| Messages
] Online
[ Profile
News
Search

)

Switch to Site Manager

Administration

[ B &

Edit Preview Live site List

Tools

P

Search

Other

View mode

» Members » Management

E‘ Save and create another

Page name: Friends

@ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates

&) Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Template name:

_GroupsTi

Events

FAQs

Forums

General

Home pages

Images

Job openings

Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates
News

My Community Site -

My Community Site -
Blog creation i

Blog list

Newsletter
Offices

Press releases
Products

. 3
Templates with editable regig —

_MembersManagement

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

2]

_StarterTemplate

My Community Site -
Access

m

My C: ity Site -

Blog posts

My C ity Site -

Blogs

This is the starter template for the Members management section of My Community Site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Template display name: My Community Site - Friends
Template code name: My Community Site.Friends

Template category: My Community Site templates

Template description: some text describing the page template

Click OK. Click Save.

-\21- Kenti.CO Switch to Site Manager Site: My Community Sitalzl User: Global Administrator v5.0.3
'.‘ CMS Desk Content My desk

Tools Administration

: :’_“ Hcopy Hue I [ E = | /O |

New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode || other |
=] {‘_," My Community Site Page  Design  Form | Properties
@ a Blogs General
‘ﬂ s —
(4[] Forums =
:I Group pages Template
5--3 Groups Metadata Template
[] Home Categories MembersManagement Select
1] Logon page Menu r - 1y
a Media - e R he esiaie | Page template - Save as new -- Webpage Dialog @
3-[] Members — =
B E| Momagement Versas @ bt empigte /= Save as new page template
a 3 d Related docs .
Ll iFnends g =3/ Clone template as ad-hoc
|| Invitations Linked docs = Template display name: |My Community Site - Friends
B || Messages 2 E Edit template properties Template code name: | My Community Site Friends
Onllfn‘e Attachments 1| Template category My Community Site templates El
Profile
:I News Inherit content 1 zhls 1?tth: ) Zr1ands page of My it
H D Search @ Use page template settings Ommunity Site.
@ Do notinherit any content Template description:

) Selectinherited levels

http://localk @ Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLSs tab. Into the Document URL path field, enter /Members/
{UserName}/Friends and click Save.

Switch to Site Manager  Site: | My Community

232 Kentico

#4% CMS Desk Content My desk  Tools Administration
2 C u T D
O [ Do ww ¥ K P
New Delete |=»Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
cl!l_il My Community Site Page  Design  Form | Properties
‘ﬂ‘—] B_mgs General |
(x)-G Files E Save
2= LRLs
(-] Forums
i--|] Group pages Lot
|1||_] Groups Metadata Path
i..[] Home Cateqories Document alias: Friends
._] Logon page Menu Document URL path: /\embers/{UserName}/Friends
-] Media Workfow Use custom URL path

d,_] Members

T Versions
¢ [=-l] Management

.. [ s Related docs Extended properties

URL extensions:

[ Invitations Linked docs
= g [[luse custom URL extensions
-] Messages Security

Track campaign:

] online Attachments

5. Switch to the Page tab. Enter My friends into the Editable text web part's text field and click Save.

.......................

6. Switch to the Design tab. Frist, we will add the Request friendship web part, which will enable users
to request other users' friendship. Click the Add web part (%) icon of the zoneCenter web part zone
and choose the Community -> Friends -> Request friendship web part. Set only the following
property of the web part, leave the rest at the default values.

e Link text: Add a friend
Click OK.

7. Below, we will place the Static text web part with a link to the Manage friends page. Click the Add
web part () icon of the zoneCenter web part zone and choose the Text -> Static text web part. Set
the following properties of the web part, leave the rest at the default values.

e Web part control ID: ManageFriendsLink
e Text: <span class="ManageFriends"><a href="~/Members/{%UserName|(encode)true%}/Friends/
Manage.aspx">Manage my friends</a></span><br /><br /><br />

Click OK.

8. Finally, we will add the Friends viewer web part, which will display the user's friends. Click the Add
web part (#) icon of the zoneCenter web part zone and choose the Community -> Friends ->
Friends viewer web part. Set the following properties of the web part, leave the rest at the default
values.
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e Transformation name: Community. Transformations.MembersList
Hide if no record found: disabled

No record found text: You currently do not have any friends.
Friend status: Approved

Click OK.

9. The page is finished. In Design tab, it should look as in the following screenshot.

| + {Members/Management/Friends - page template: My Community Site - Friends y|

¥ zoneCenter * ¥ zoneRight ‘*

v editabletext () =
Lr,—rrrcrn::r\ﬂ = logonminiform {_.‘a.:!

_ v Shortcuts {23
¥ RequestFriendship i_gu:,! Shortcuts

= ManageFriendsLink {_‘:eo} My profile
Edit my profie
s e any friends. My messages

¥ FriendsViewer ,_\go} My friends

My invitations
Create a new group
Create a new blog
Sign out

+ BlogsRepeater i:eo}

My Blogs
You currently do not have any
blogs.

|
My groups

Currently is not member of any
group.

* ForumFavorites {_:go} ‘
Forum favorites

Mo favorites found
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3.13.9 Creating the Manage friends page

The Manage friends page, as its name should indicate, will provide users with the friendship
management functionality. It is accessible from the Friends page created in the previous chapter. The
friendship management functionality will be provided by the My friends web part.

1. Select the Management page in the content tree and click New. Choose the Page (menu item)
document type.

212 Kentico Switch

#1% CMS Desk Content My desk  Tools Administration

2l G Boer . 4 [d =8 2

New | Delete [ Move & Down Edit Preview Live site List Search
Content management | View mode | Other
|;l\- - My Community Site » Members » Management
3-[.] Blogs -,
'—' _‘;'_‘ ) New document
[+]- 2 Files —
|1|,_| Forums
‘. Group pages Please select new document type:
'1“—| Groups [[] Page (menu item)
|5 Home
I_| Logc.m page = Artidle
o] Media )
5[] Members %) Blog
¢ 3-[1/Management 3 Cell phone
i i [ Friends ¥ Event

[ tnvitations i
j Messages {5 Event (booking system)

I_| Online @ Ea0
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2. Select the My Community Site templates -> _MembersManagement created in this chapter. Into
the Page name field, enter Manage friends and click Save.

Kentico
CMS Desk Content | My desk
;‘ [ Copy T up
New Deleste =bMove & Down

Content management

=] !_;_/) My Community Site
(x-l] Blogs
(-5 Files
3} Forums
Group pages
Groups
Home
Logon page
Media
Members
._'j Management
|| Friends
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] Messages
|| Online
,_'i Praofile
-] News
-] Search

®

e T D ) ) )

Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688

Tools Administration

@ & =2 kL

Edit Preview Live site List Search

View mode || other

» Members » Management

E‘ Save and create another

Page name: Manage fiiends

@ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates Template name:
&) Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Events

FAQs

Forums

General

Home pages
Images

Job openings
Knowledge base
Master templates

_Member _StarterTemplate My Community Site -
Access
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My Community Site - My Community Site - My G ity Site - My C ity Site -
Membership and security Blog creation Blog list Blog posts Blogs
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Offices
Press releases
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Templates with editable regig
o) wiki _MembersManagement

23

This is the starter template for the Members management section of My Community Site.

Sign out

m
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

22 Kentico

Switch to Site Manager

Template display name: My Community Site - Manage friends
Template code name: My Community Site.ManageFriends

Template category: My Community Site templates
Template description: some text describing the page template

Site: My Community Site E| User: Global Administrator v5.0.31
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‘ﬂ @ les -
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[] Home Categories MembersManagement Select
] Logon page Menu r - N
a Media N e A T e s #  Page template - Save as new -- Webpage Dialog @
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= Momagement Veri @ Dhertiempiote /=gl Save as new page template
3 I3 d Related docs -
= nends n a3/ Clone template as ad-hoc
Invitations Linked docs e Template display name: |My Community Site - Manage friends
y Yy g
g Manage friends Seaai E Edit template properties Template code name: My Community Site ManageFriends
g] ‘Messages Attachments Template category My Community Site templates [=]
nline
. D Profile Inherit content This is the 1:Ianag§ friends page -
a News @ Use page template settings of My Community Site.
: a Search H ) Do notinherit any content Template description

() Selectinherited levels

http://localk € Local intranet | Protected Mode: Off
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4. Switch to the Properties -> URLSs tab. Into the Document URL path field, enter /Members/
{UserName}/Friends/Manage and click Save.

Switch to Site Manager  Site: | My Communi
232 Kentico v v
"" CMS Desk Content My desk Tools Administration
| = C U ~ =
SRS E LA [d] 2
New Delete |= Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other |
cl!lq] My Community Site Page  Design  Form | Properties
'ﬂ'—] B_|0gs General |
(-5 Files E Save
T = URLs =
(-] Forums
i--|] Group pages Template
-] Groups Metadata Path
i Home Categories Document alias: Manage-friends
._] Logon page Menu Document URL path: |/\Members/{UserName)/Friends/Manage
[ Media oty Use custom URL path

-] Members

-] Management
| ] Friends
] Invitations Linked docs
; I_] Manage friends Security
[0 Messages Attachments

Wersions

Related docs Extended properties
URL extensions:

[TTUse custom URL extensions
Track campaign:

5. Switch to the Page tab. Enter Manage my friends into the Editable text web part's text field and click
Save.

Manage my friends

h
'
'
e e e e

6. The zoneCenter web part zone will host two web parts. The first one of them will be the Static text
web part with a link leading back to the Friends page. Click the Add web part () icon of the
zoneCenter web part zone and choose the Text -> Static text web part. Set the following properties of
the web part, leave the rest at the default values.

e Web part control ID: BackToFriends
e Text: <span class="ManageFriends"><a href="~/Members/{%UserName|(encode)true%}/Friends.
aspx">&lt; Back to friends</a></span><br /><br /><br />

Click OK.

7. Now we will add the My friends web part used for friends management. Click the Add web part (9)
icon of the zoneCenter web part zone and choose the Community -> Friends -> My friends web part.
You do not need to set any properties of the web part. Just leave all of them at the default values and
click OK.
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8. The page is finished. In Design tab, it should look as in the following screenshot.

| - /Members/Management/Manage friends - page template: My Community Site - Manage friends

B

w zoneCenter

o

v editabletext {2 friends

pending requests  Rejected friends

Add a friend

My current friends

Mo approved friendships were found.

= zoneRight I*

= |ogonminiform {_‘:eo}
v Shortcuts {23

Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

+ BlogsRepeater i:eo}

My Blogs
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blogs.

|
My groups
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group.

‘

Forum favorites

Mo favorites found

© 2010 Kentico Software



Part 2 335

3.14 Creating the Special pages
3.14.1 Creating the Special pages folder

The special pages section consists of pages that do not display any content. Instead, these pages
contain special web parts for performing actions like user registration approval, unsubscription from
various notifications, acceptation for group invitation, etc.

In the following example, we will create a folder in which the special pages will be stored.

1. Go to CMS Desk, select the root of the content tree and click New. Choose the Folder document

type.
‘.' K l Switch
== Kentico
'l\ CMS Desk Content My desk Tools Administration
] C u ~ &)
=| B Ej opy T up [ @ @ @
New | Delete = Maove 4 Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
=4 /My Community Site My Community Site
-] Blogs -4
'1' _‘;l ) g New document
[+]- 2 Files —
(&[] Forums
‘.[] Group pages Please select new document type:
'1“—] Cross [ ] Page (menu item)
-] Home
I_] Logc_m page ¥ Blog
S| Media
" i Folder
5 £ wembers
|_] News
“.[] search £] Link an existing document

2. Enter Special pages into the Document name filed and click Save.

Switch to Site Manager

212 Kentico

#1% CMS Desk Content My desk Toolz Administration
™ b = U .
S E S L . 2 Q@ @ =2 | AR
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | iew mode | Other
= /My Community Site My Community Site
-] Blogs
d@ Filas E Save E‘ Save and create another Spell check
-] Forums
‘.| ] Group pages
: ‘—] PLEL Document name: |Special pages
)| Groups
[ Home
I_] Logon page
[ Media

1] Members
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3. The folder has been created and the special pages can now be placed under it.

2)¢ Kentico

‘.‘ CMS Desk Content My desk
3 3 Copy T up
BN
New Delete =k Move & Down |

Content management

clv_’l My Community Site
(-] Blogs

¢|’£j‘ Files
|1||_] Forums

I_] Group pages
(#-L] Groups

I_] Home

I_] Logon page
[ Media

(1-] Members
I_] News

i[0 search

“..75) Special pages

3.14.2 Creating the Access denied page

The first special page will be the Access denied page. This is where users with insufficient permissions
will be redirected after accessing some secured page. The page will contain only an Editable text web
part which will display the access denied message.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

Switch
=32 Kentico ]
#4% CMS Desk Content My desk Tools Administration
2 2 i u — Y
| (g Doer e 2 O =2 | AP
New | Delete | = Move & Down | Edit Preview Live site List | Search |
Content management | Wiew mode | COther

.;'l-{-_';: My Community Site } Special pages

5[] Blogs ™
j‘ fl_zl," o New document

- =l
|1||_] Forums

|_] Group pages Please select new document type:
‘ﬂj EmuDs [ Page (menu item)

ome

I_] Logon page e

] Media e

= st

-] Members ) Eolder

|_] News

‘.| ] search &1 Link an existing document
: %] Link an existing document

*.75]Special pages
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Access denied and click Save.

Kentico
CMS Desk

%

New Delste

[ Copy

= Move

Content
T up
& Down

My desk

Content management

=] !_;_/) My Community Site

(x-l] Blogs
(-5 Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
-] News
|| Search

.15 Special pages

Administration

[ B &

Preview Live site List

Tools

Edit
View mode

» Special pages

E‘ Save and create another

Switch to Site Manager

P

Search

Other

Page name: Access denied
@ Use page template

54 All page templates

&) Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Events

FAQs

Forums

General

Home pages

Images

Job openings
Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates
News

Newsletter

Offices

Press releases

Products

Templates with editable regig

() Inherit from parent page

() Create a blank page

Template name:

_GroupsTi

My Community Site -
Blog creation

My Community Site -
Blog list

2 3
_StarterTemplate

Site:| My Community Site[+| User: Global Administrator v5.0.2688

_StarterTemplate

My Community Site -
Access

My C: ity Site -

Blog posts

ity Site -
Blogs

My C

Sign out

m

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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Click OK. Click Save.

22 Kentico

Template display name: My Community Site - Access Denied
Template code name: MyCommunitySite.AccessDenied
Template category: My Community Site templates

Template description: some text describing the page template

Switch to Site Manager

Select

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Site: My Community Sitelzl User: Global Administrator v5.0.3

-
& | Page template - Save as new -- Webpage Dialog

1% CMSDesk Content | Mydesk  Tools  Administration
= = - i — —
E By dw || [7  [q] 2 | P
New Delete = Move & Down | Edit Preview Live site List | Search |
Content management | View mode | Other
=14 ) My Community Site Page  Design  Form | Propertes

‘ﬂ'—l Bloos General

(-5 Files E Save

t URLs

(-] Ferums

a Group pages Template

2 a Groups Metadata Template

i..[]] Home Categories StarterTemplate

-] Logon page Menu

9 Media Workflow

(3-[-] Members 2 .

g Versions

Innerttemplate
— Q Inherit template
s h Related docs .
; EETRe 4=/ Clone template as ad-hoc
=] "ij Special pages Linked docs =f
i..[)[Access denied Security E Edit template properties Template code name
Attachments

Template category:
Inherit content

@ Use page template settings
) Do notinherit any content Template description:

(@) Selectinherited levels

;j Save as new page template

Template display name: My Community Site - Access Denied

MyCommunitySite AccessDenied

My Community Site templates

This is the Access denied page of

My Community Site.

[=]

-

http://localk €L Local intranet | Protected Mode: Off
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4. Switch to the Design tab. We will only need to add the Editable text web part into the zoneCenter
web part zone, below the Editable text web part for heading. Click the Add web part () icon of the
zoneCenter web part zone and choose the Text -> Editable text web part. You do not need to set any
properties of the web part, just leave all of them at the default values.

In Design tab, the page should now look as in the following screenshot.

|V /5pecial pages/Access denied - page template: My Community Site - Access Denied y|

= zoneCenter * = zoneRight *

v editabletext {3 v logonminiform {3

v editabletextl {3 { Shortcuts {53
- O
Shortcuts

My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out
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5. Switch to the Page tab. You can see two editable text regions on the page now - one for heading and

one for the warning text. Enter the following texts into the text areas:

e Heading: Access denied
e Warning text: You're not allowed to access the required page. Please contact the administrator if

you think you should be allowed to access it.

Click Save.
‘I' Kenti.co Switch to Site Manager Site: My Community SitaE User: Global Adminis
-
#§%  CMS Desk | Content | My desk Tools Administration
—. — = . = —
5 5 B w3 Q@ B = | AL |
| Mew Delete = Move & Down || Edit  Preview Live site  List || Search |
| Content management | View mode | other |
=) My Community Site | Page | Desgn  Form  Froperties
@D Blogs
(55 Files Spell check
-] Forums ; = - : : : = pry
.-[J] Group pages s |G BB HEISE [# LB 2iB £ U s x &S ==
@DGruups MO =0 & Si03 0wl ¥
[ Home |E St ~ | Format | Nomal - | Font T i &
_ e changes were saved.
: %;ogdcn page The ch d
IJD Me I: Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is with blank p:
+ embers
D News
D Search Currentuser: Global Administrator (administra

=)-%5) Special pages

“..[][Access denied

Community

Starter site

| You're not allowed to access the required page. Please contact the administrator if you think you should be allowed to access it.|

n
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The page is complete. If you view it in Live site mode, you should see the page as in the following
screenshot. Please note that the Logon mini form is displayed only to unauthenticated users.

Community

Starter site

- N

Current user: Global Administrator (administrator) | Edit my profile | Inbox | Sign out

Blogs  Forums  Groups Home  Media  Members  HNews

| | | Search

Access denied

Shortcuts

‘fou're not allowed to access the required page. Please contact the administrator if you think you should be allowed to access it My profie

3.14.3 Creating the Blog unsubscribe page

Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

The Blog unsubscribe page will be used to handle blog post unsubscription requests. Users are able to
subscribe to receiving notifications about new blog comments on a particular blog post. Notification e-
mails contain an unsubscription link leading to this page with the subscription GUID in the query string
parameter. By clicking this link, users can unsubscribe from receiving the notifications. The
unsubscription request is handled by the Blog post unsubscription web part on this page.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings -> Blogs
-> Blog unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)

document type.

22 Kentico
1% CMS Desk

Tools Administration

Switch

=21 5 [Ecoy
= X -
| New | Delete | = Move

Content management

[
Edit Preview Live site List

View mode

2 |
| | Search |
| | Other |

I;"l-\!’»;:i My Community Site
-] Blogs
@TES]‘ Files
@D Forums
D Group pages
-] Groups
D Home
D Logon page
[ Media
&[] Members
D News
i-[] search
=)&) Special pages
i..[] Access denied

» Special pages

:] New document

Please select new document type:

|| Page (menu item)

=k

i) Folder

£ Link an existing document
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Blog unsubscribe and click Save.

22 Kentico

#1% CMS Desk Content
[ Copy T up
New Delste = Move & Down

Content management

=] !_;_/) My Community Site

(x-l] Blogs
(-5 Files
(#-l.] Forums
|| Group pages
(+)-.| Groups
| Home
-] Logon page
| Media
-] Members
-] News
|| Search
(=) %5 Special pages

|| Access denied

My desk

Switch to Site Manager

Administration

@ & =2 kL

Preview Live site List Search

Tools

Edit

Other

View mode

» Special pages

E‘ Save and create another

Page name: Blog unsubscribe

@ Use page template () Inheritfrom parentpage () Create a blank page
54 All page templates

Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Template name:

_Member

Events —GroupsT

FAQs
Forums

General

Home pages

Images

Job openings

Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates

My Community Site -
Blog creation

My Community Site -
Access Denied

News
Newsletter
Offices

Press releases
Products s
Templates with editable regig

_StarterTemplate

Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out

2]

_StarterTemplate

c

My Community Site -
Access

m

ity Site -
Blog list

My C ity Sit
Blog posts

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

232 Kentico
#1%  CMS Desk

Switch to Site Manager

Content Tools Administration
— = = — —
= el Cd] B2 A
New Delete |=¢ Move Edit Preview Live site List | Search
Content management View mode | Other

d-{-__'l My Community Site

Template display name: My Community Site - Blog unsubscribe
Template code name: MyCommunitySite.BlogUnsubscribe

Template category: My Community Site templates
Template description: some text describing the page template

Site: My Community Sitelzl User: Global Administrator v5.0.3

Select

Page Design Form Properties

-2 Blogs
B General
(-G Files E Save
u a Forums e
Ik
] Group pages Tempiate
(i) Groups Metadata Template
i..[]] Home Categories _StarterTemplate
‘| Logon page Menu
g Media Workflow
[&]-] Members 2 1

= Versions g Inherit template

Related docs .

|_| Search 4+ Clone template as ad-hoc
B ﬂ Special pages Linked docs =f

[ Access denied Security E Edit template properties

- |/Blog unsubscribe Attachments

Inherit content
@ Use page template setings
) Do notinherit any content

(@) Selectinherited levels

-
£ | Page template - Save as new -- Webpage Dialog

,\_.iﬂ Save as new page template

Template display name: My Community Site - Blog unsubscribe
Template code name: | MyCommunitySite. BlogUnsubscribe
Template category: Wy Community Site templates [+]

This is the Blog unsubscribe page =
of My Community Site.

Template description

http://localk €& Local intranet | Protected Mode: Off

4. Switch to the Page tab and enter Blog unsubscribe into the Editable text web part's text box. Click

Save.

Blog unsubscribe

h
'
'
e
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5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Blogs -> Blog post unsubscription web part. Set the following properties of the web part,
leave the default values for the rest of them:

e Confirmation text: You have been successfully unsubscribed.
e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

|V /Special pages/Blog unsubscribe - page template: My C ity Site - Blog bscrik f|
w zoneCenter
= s = zoneRight o
= editsbletext -
Lrwg—wrmw‘gﬂcnbe + logonminiform @}
|
|V BlogPostUnsubscription @,!| S or[cuts‘@
My profile
Edit my profile

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out

3.14.4 Creating the Board unsubscribe page

This page will be used to handle message board unsubscription requests. There are several message
boards throughout the whole site. Users can subscribe to receiving e-mail notifications about new
messages on a particular board. The notification e-mails contain an unsubscription link leading to this
page. When a user clicks it, she is redirected to this page with the subscription GUID in query string
parameter. On the page, the Message board unsubscription web part will handle the request and
perform unsubscription.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings ->
Message boards -> Board unsubscription URL, as described in this chapter.
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1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

-‘:’. Ken ti.CO Switch
1% CMSDesk Content My desk

2 X [ copy T up . @ @ )3

Tools Administration

New |Delete |2 Move 4 pown | Edit Preview Live site List | Search |
Content management | WView mode | Other
.;'l-{-_';: My Community Site v Special pages
3-[.] Blogs -
= 4.‘—]_‘ . New document
[+]- = Files —
-] Forums
‘.[] Group pages Please select new document type:
@2 Groups

|| Page (menu item)

‘[ Home

I_] Logaon page e
-] Media

- =

[#)-|.] Members i) Eolder

[ News

“[] search %) Link an existing document
=-S5/ Special pages

“[] Access denied

‘..[] Blog unsubscribe

2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Board unsubscribe and click Save.

-‘!,- Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3638 Sign out
#1%  CMS Desk Content | Mydesk  Tools  Administration
) ) [ U .
D 0w e |3 q @ B[ L N
New Delete = Move & pown | Edit Preview Live site Lst || search |
Content management | View mode || other
(-6 My Community Site » Special pages
(-] Blogs
-G Files E‘ Save and create another
(©-L] Forums
|1 Group pages Page name: Board unsubscribe
(©-.] Groups
@ Usepagetemplate Inheritfrom parentpage Create a blank page
[ Home - E F
-] Logon page - —
T Media =& All page templates Template name:

L.y Articles

.| Members -
: &) Blank pages for widgets

-] News i
[ search : :ﬂ Blogs
(-1-%5)Special pages (&) Community Site
. []] Access denied ] Corporate Site ASPX

H :‘] E-commerce
-] Blog unsubscribe 5 Events _GroupsT

) FAQs
: ;'} Forums
H i) General
:'} Home pages
L. Images
i ) Job openings
E ::i Knowledge base
i) Master templates

_Member _StarterTemplate My Community Site -

= My Community Site - My Community Site - My C ity Site - My C ity Site -
: d Membership and security Access Denied Blog creation Blog list Blog posts
i) Message boards

:'} My Community Site templates

L) News

Newsletter

“y Offices

i) Press releases

‘&) Products

: T“i . 123

.1y Templates with editable regig

Ly wiki _StarterTemplate

This is the starter page template of My Community Site. It will be used as the starting point for development
of many pages on the site.

3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

m
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following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Board unsubscribe
Template code name: MyCommunitySite.BoardUnsubscribe

Template category: My Community Site templates
Template description: some text describing the page template

s Kel'lti.CO Switch to Site Manager  Site: | My Community Site EI User: Global Administrator v5.0.3
-
1% CMS Desk Content | Mydesk Took  Administration
B c u = —
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Content management | View mode | other |
=14 ) My Community Site Page  Design  Form | Properties
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(-3 Files
L — URL:
(#-.] Ferums =
‘[ Group pages Template
D Groups Metadata Template
i..[]] Home Categories _StarterTemplate ﬁ
— e = %8 Page template - 5 Webpage Dial =)
e 'age tlemplate - save as new -- ebpage Lhalog
: g Media o Saye a5 new fempiat
i-|| Members =
@ Yo @ imherttemoiat /=g, Save as new page template
News f |nhentiempiate
5 h Related docs —
; earg e :;J Clone template as ad-hoc
(575 Special pages g = = Template display name: |My Community Site - Board unsubscribe
g Access denied S E Edit template properties Template code name: | MyCommunitySite BoardUnsubscribe
i1 Blog unsubscribe Attachments

i..[[/Board unsubscribe

Inherit content
@ Use page template settings
() Do notinherit any content

() Selectinherited levels

Template category:

Template description:

My Community Site templates

This iz the Board unsubscribe -
page of My Community Site.

http://localk € Local intranet | Protected Mode: Off
\

4. Switch to the Page tab and enter Blog unsubscribe into the Editable text web part's text box. Click

Save.

Blog unsubscribe

h
'
'
e e e
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5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Message board -> Message board unsubscription web part. Set the following properties
of the web part, leave the default values for the rest of them:

e Confirmation text: You have been successfully unsubscribed.
e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

| = /Special pages/Board unsubscribe - page template: My Community Site - Board unsubscribe y|
¥ zoneCenter
= * w zoneRight *
v editabletext - =
angvrmqgﬂcrl be = logonminiform ’tgz‘!
~ -
| + MessageBoardUnsubscription ‘t&"‘!| S| OI'tCUtSt&“g
My profile
Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out
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3.14.5 Creating the Forum unsubscribe page

The last of the unsubscription pages is the Forum unsubscribe page. In the Forums section, users have
the possibility to subscribe to receiving notification e-mails about new posts in a particular forum thread.
The notification e-mails contain unsubscription links leading to this page. The GUID of the subscription is
contained in the querystring parameter. The main part of this page is the Forum unsubscription web
part. When a user clicks the unsubscription link, she is redirected to this page where the web part
handles the unsubscription request.

In order to for the page to be functional, you need to set its URL in Site Manager -> Settings ->
Forums -> Forum unsubscription URL, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

232 Kentico —
‘.‘ €MS Desk Content My desk Tools Administration
O ) Beer R 4 & [ = 2
New |Delete = Mowve &4 pown | Edit Preview Live site List | Search |
Content management | iew mode | Other
.;'l-i_';: My Community Site » Special pages
7] Blogs Y
'ﬂ _‘;l ) d New document
= Files —
[+ Forums
..[ ] Group pages Please select new document type:
‘1"—] EELE [[] Page (menu item)
|| Home
I_] Loggn page i File
S ] Media
: = &
&l Members &y Folder
[ News
“[] search % Link an existing document

-5/ Special pages

] Access denied
I_] Blog unsubscribe
‘.|| Board unsubscribe
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Forum unsubscribe and click Save.

Kentico Switch to Site Manager  Site:| My Community Site[+] User: Global Administrator v5.0.3688 Sign out
CMS Desk Content | My desk

Tools Administration

) 5% D copy T up [d = /O o
New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management | View mode || other | —
=] !_;_/) My Community Site » Special pages
j_\g E:Ic;gss E‘ Save and create another
(#-l.] Forums
|| Group pages Page name: Forum unsubscribe
[x-] Groups
[} Home @ Use page template () Inheritfrom parentpage () Create a blank page

-] Logon page
| Media
-] Members

54 All page templates Template name:
&) Articles

Blank pages for widgets B
Blogs

Community Site

Corporate Site ASPX

E-commerce

Events _GroupsT:
FAQs

Forums

General

Home pages

Images

Job openings

Knowledge base

Master templates

-] News
|| Search
(=) %5 Special pages
|| Access denied
:--|] Blog unsubscribe
,_'i Board unsubscribe

_StarterTemplate My Community Site -
Access

m

My Community Site - My Community Site - My C: ity Site - My C ity Site -
Membership and security Access Denied Blog creation Blog list Blog posts
Message boards

My Community Site templates

News
Newsletter
Offices
Press releases i
Products s
Templates with editable regig —
o) wiki _StarterTemplate
This is the starter page template of My Community Site. It will be used as the starting point for development
ry = < of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.

Switch to Site Manager

Template display name: My Community Site - Forum unsubscribe
Template code name: MyCommunitySite.ForumUnsubscribe

Template category: My Community Site templates
Template description: some text describing the page template

Select

Site: My Community Site E| User: Global Administrator v5.0.31

=32 Kentico
1% CMSDesk Content | Mydesk  Took  Administration
[= = c U e 3
E Dowr & o 2 O B | A
New Delete |= Move & Down | Edit Preview Live site List ‘ Search
Content management | View mode | Other
(2§ My Community Site Page  Desgn  Form | Properties
(@[] Blogs
‘ﬂ S Files General
Ty URL:
(+]-L] Forums £
i) Group pages Template
5--3 Groups Metadata Template
Categories _StarterTemplate
Menu + .
Workfiow Save as newlemplate i
I Versions q Inherit template
q Related docs -
i~ search i &+ Clone template as ad-hoc
(-J-J special pages R =
a Access denied Seaurity E Edit template properies
a Blog unsubscribe Attachments

[ Board unsubscribe
“...| )|[Forum unsubscribe

Inherit content
@ Use page template settings
(©» Do notinherit any content

() Selectinherited levels

-
& | Page template - Save as new -- Webpage Dialog

Template code name:

Template category:

Template description

,\_.; Save as new page template

Template display name: |My Community Site - Forum unsubscribe

MyCommunitySite. ForumUnsubscribe
My Community Site templates

This is the Forum unsubscribe
page of My Community Site.

http://localk €& Local intranet | Protected Mode: Off
\

4. Switch to the Page tab and enter Forum unsubscribe into the Editable text web part's text box. Click

Save.

Forum unsubscribe

h
'
'
e e e
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5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Forums -> Forum unsubscription web part. Set the following properties of the web part,
leave the default values for the rest of them:

e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the unsubscription requests.

| - [Special pages/Forum unsubscribe - page template: My Community Site - Forum unsubscribe y|

¥ zoneCenter * = zoneRight *

v editabletext i - =
e ‘g‘?‘g Scrlbe * |ogonminiform "g}}
¥ shortcuts £
il

My profile
Edit my profie

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

3.14.6 Creating the Friend management page

One of the community features in Kentico CMS is the Friends module. It provides users the possibility of
creating social relations - friendships. This special page will contain the Friendship management web
part, which handles the friendship approval or rejection requests.

In order to for the page to be functional, you need to set its alias path in Site Manager -> Settings ->
Community -> Friend management path, as described in this chapter.
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1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)

document type.
=32 Kentico
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[ copy
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;' New document

Please select new document type:
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%] Link an existing document
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Friend management and click Save.
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New Delete |=Move & Down Edit  Preview Livesite  List Search
Content management | View mode || other | —
=] !_;_/) My Community Site » Special pages
j_\g E:Ic;gss E‘ Save and create another
(#-l.] Forums
|| Group pages Page name: Friend management
[x-] Groups
[} Home @ Use page template () Inheritfrom parentpage () Create a blank page

-] Logon page
| Media
-] Members

54 All page templates Template name:
&) Articles

-3 News Blank pages for widgets B
|| Search Blogs
£)-GiSpeaal pages Community Site
1] Access denied Corporate Site ASPX
P @ E-commerce
i Blog unsubscribe Events _GroupsT I _StarterTemplate My Community Site -
|| Board unsubscribe Access
“.[1] Forum unsubscribe FAQs 3
Forums
H General
Home pages
Images
Job openings
Knowledge base L
Master templates . . . . . . . "
My Community Site - My Community Site - My C y Site - My C y Site -
Membership and security Access Denied Blog creation Blog list Blog posts

Message boards
My Community Site templates

News
Newsletter
Offices
Press releases i
Products s
Templates with editable regig —
o) wiki _StarterTemplate
This is the starter page template of My Community Site. It will be used as the starting point for development
ry = < of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

Click OK. Click Save.

Template display name: My Community Site - Friend management
Template code name: MyCommunitySite.FriendManagement

Template category: My Community Site templates
Template description: some text describing the page template
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)

Page Design
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Metadata
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Menu
Workflow
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Security
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Form Properties
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Template
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T
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J one lempldie 35 a 0C

E Edittemplate properties

Inherit content
@ Use page template settings

@ Do notinheritany content
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Site: My Community Site E User: Global Administrator v5.0.
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-
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Template code name
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4. Switch to the Page tab and enter Friend management into the Editable text web part's text box.
Click Save.

_______________________

5. Switch to the Design tab. Click the Add web part (<) icon of the zoneCenter web part zone and
choose the Community -> Friends -> Friendship management web part. Set the following properties
of the web part, leave the default values for the rest of them:

My friends page path: /Members/{%CurrentUser.UserName|(encode)true%}/Friends
Send notification message: enabled

Send notification e-mail: enabled

Content after: <br /><br />

Click OK. The page is now finished and ready to handle the friendship management requests.

| = [Special pages/Friend management - page template: My Community Site - Friend management y|
T zoneCenter *

= zoneRight +

v editabletext {3 gement ¥ logonminiform £
-

|V FriendshipManagement @5| Shortcuts

My profile
Edit my profie

My messages
My friends
My invitations

Create a new group
Create a new blog
Sign out
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3.14.7 Creating the Invitation acceptation page

This special page is related to Kentico CMS Groups module. Members of a group can send e-mail
invitations to join the group. In the e-mail, there is a link leading to this page with the invitation GUID in
query string parameter. When a user clicks the link, she will be redirected to this page where the Group
invitation web part handles the invitation and makes the user a member of the group.

In order to for the page to be functional, you need to set its alias path in Site Manager -> Settings ->

Community -> Invitation acceptation path, as described in this chapter.

1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)
document type.

212 Kentico

#4% CMS Desk Content My desk Tools Administration
> C u
)& B e |3 @ @ B
New | Delete = Move & Down Edit Preview Live site List

Content management
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Special pages
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=] New document

Please select new document type:

| ] Page (menu item)

=L

i) Folder

£] Link an existing document
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Invitation acceptation and click Save.

Kentico
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Content
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& Down

My desk

Content management

=] !_;_/) My Community Site
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(-5 Files
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Preview Live site List

Tools

Edit
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» Special pages

E‘ Save and create another

Switch to Site Manager

P

Search

Other

Page name: Invitation acceptation
@ Use page template

54 All page templates

&) Articles

Blank pages for widgets
Blogs

Community Site
Corporate Site ASPX
E-commerce

Events

FAQs

Forums

General

Home pages

Images

Job openings
Knowledge base

Master templates
Membership and security
Message boards

My Community Site templates
News

Newsletter

Offices

Press releases

Products

Templates with editable regig

() Inherit from parent page

() Create a blank page

Template name:
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My Community Site -
Access Denied

My Community Site -
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2 3
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Site:| My Community Site[+| User: Global Administrator v5.0.2688

Sign out
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My Community Site -

Access
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Blog list Blog posts

This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the
following details in the pop-up dialog:

Click OK. Click Save.
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4. Switch to the Page tab and enter Invitation acceptation into the Editable text web part's text box.

Click Save.

Invitation acceptation

h
'
'
e
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5. Switch to the Design tab. Click the Add web part () icon of the zoneCenter web part zone and
choose the Community -> Group invitation web part. Set the following properties of the web part,
leave the default values for the rest of them:

e Content before: <h3>
e Content after: </h3><br /><br />

Click OK. The page is now finished and ready to handle the invitations.

|V /Special pages/Invitation acceptation - page template: My G ity Site - Invitati i f‘|
- Centel
zoneCenter * ¥ zoneRight *

v editabletext & . =

¥ Shorteuts
==

My profile

Edit my profile

My messages

My friends

My invitations
Create a new group
Create a new blog
Sign out

3.14.8 Creating the Registration approval page

After registration to the page, users don't become members immediately. Instead, an e-mail is sent to
them with the registration approval link. The link is leading to this page and contains the registration
GUID in query string parameter. When the user clicks this link, the Registration e-mail confirmation
web part on this page handles the registration approval request and the user becomes a member.

In order to for the page to be functional, you need to set its URL into E-mail confirmation page
property of the Custom registration form web part, as described in this chapter.
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1. Select the Special pages folder in the content tree and click New. Choose the Page (menu item)

document type.
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2. Select the My Community Site templates -> _StarterTemplate created in this chapter. Into the
Page name field, enter Registration approval and click Save.
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This is the starter page template of My Community Site. It will be used as the starting point for development

of many pages on the site.
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3. Switch to the Properties -> Template tab and click the Save as new template link. Enter the

following details in the pop-up dialog:

Click OK. Click Save.
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4. Switch to the Page tab and enter Registration approval into the Editable text web part's text box.
Click Save.

_______________________

5. Switch to the Design tab. Click the Add web part (<) icon of the zoneCenter web part zone and
choose the Membership -> Registration e-mail confirmation web part. Set the following properties of
the web part, leave the default values for the rest of them:

From address: no-reply@mycommunitysite.com

Administrator e-mail: admin@mycommunitysite.com

Notify administrator: enabled

Successful approval text: Your user account is now active. You can sign in using your user name
and password. <a href="~/Logon.aspx" title="Logon page">Click here to continue</a>
Unsuccessful approval text: Your registration wasn't approved.

e User deleted text: The user account has been already deleted.

e Content after: <br /><br />

Click OK. The page is now finished and ready to handle the registration approval requests.

|V /Special pages/Registration approval - page template: My Community Site - Registration approval y|
- Centel
zoneCenter * ¥ zoneRight +
v editabletext { =
e ‘%“} approva| * logonminiform ’,ﬁ}
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My friends
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Create a new group
Create a new blog
Sign out
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3.15 Ordering pages in the content tree

Once all the pages are created, it is a good idea to give them a logical organization in the content tree.
Use the Up and Down buttons to move pages to achieve the same page order as in the screenshot
below.
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3.16 Making the settings

To get the site working, you also have to make several settings in the Site manager -> Settings
section.

1. First, select the name of your site from the Site drop-down list in the top left corner of the page.

Switch to CMS Desk  User: Global Administrator v5.0.3688 Sign out
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2. In Site Manager -> Settings -> Web site, make the following settings. Remember that you need to
uncheck the Inherit from global settings check-box in order to be able to enter values into the fields.

e Default alias path: /Home

e Default culture of the content: English - United States
e Page title prefix: My Community Site

e Exclude documents from search: /Special-Pages/%
Click Save.

3. In Site Manager -> Settings -> Security, make the following settings:

e Check page permissions: No page
e Website logon page URL: ~/Logon.aspx

Click Save.

4. In Site Manager -> Settings -> Blogs, set the following value:

e Blog unsubscription URL: ~/Special-Pages/Blog-Unsubscription.aspx
Click Save.

5. In Site Manager -> Settings -> Community, enter the following values:
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Group security access denied path: /Groups/{GroupName}/Access
Group management path: /Groups/{GroupName}/Management
Group profile path: /Groups/{GroupName}

Member management path: /Members/{UserName}/Management
Member profile path: /Members/{UserName}

Invitation acceptation path: /Special-Pages/Invitation-Acceptation
Friend management path: /Special-Pages/Friend-Management

Click Save.
6. In Site Manager -> Settings -> Forums, enter the following values:

e Forum unsubscription URL: ~/Special-Pages/Forum-Unsubscribe.aspx
e Forum base URL: ~/Forums.aspx

Click Save.

7. In Site Manager -> Settings -> Message boards, adjust the following property:

e Board unsubscription URL: ~/Special-Pages/Board-Unsubscribe.aspx
Click Save.

8. The settings are done. The whole web site should now be fully functional.
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