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11

Personal Site Guide

Overview

Kentico CMS Personal Site allows you to easily run your own personal web site. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:

e Content editing
e Blogs

e Forums

e Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.

© 2009 Kentico Software
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2.1

Getting Started

Editing content

In this chapter, you will learn how to change the About text on your web site.

1) Go to CMS Desk -> Content -> Personal Site -> About me.

CMS Desk

Content | My Desk | Tools | Administration
D D @ B ﬁ G Edit Preview Live site
New Delete, Copy Move Up Down @ @ * @

=4 Personal Site

] ?Hv Blog
About Me H Save

Page | Design | Form | Product | Propertes

pell check

g Forums

#-%) Phota Gallery Source | (& 2 |1&:
] Special pages @ B Q@e=a2le
[CR Images = Shyls - | Format

E List

| ¢4

- | Fort

- | Size

Switch to Site Manager

Bl #:B I U 2e|x <

Site: | Perscnal Site % | User: Global Administrator ~ Sign Out

T R

Sign in to CMS Desk. Sign in to CMS Site Manaqger. The default account is administrator with blank password.

it can you find on my web
There isn't much stuff

so far, still working on it.
it you might be interested

Awith my friand P1 this
\summer. Hope to upload more
iphotos in near future.

Documents | Search

Current user: Global Administrator| My details | Sign out

"Tlusion is the first of all pleasures.” - Oscar Wilde.

About Me Forums Photo Gallery
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2) Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This the new About me text. Then click Save at the top-left.

Page | Design | Form || Product | Propertes

Spell check
£ [=] Source | (& BR®B &G o M EIB 7 U~ ciZE|==]Es= &
DO =0% 53O
AE Style = | Format |Mommal (DIV) ~ | Font - | Size z T-' %v E @l | @
Jon # so far, stil working on it. | LT o

What you might be interested
fin is my blog from a trip
Jground Europe that we took 1 |

|with my friend PJ this ~
lsummer. Hope to upload more |\ . T
Ephotos in near future. i i x

e LS

My latest blog posts iThis is the new About me text.

6/1/2008 | Destination Madrid

Spain welcomed us with the
entirely Spanish-only
environment. You would think
that they would bother to have
Some signs our announcements
in English at the international

i by, P1 knows

we were able to
find our way out of airport and
take the right bus to our hostel.

’l? Powered by
% KENTICO
CMS

|>

53]
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3) Now switch to the Preview viewing mode. You can see that the About me text has been updated.

| My details | Sign In

"Tusion is the first of all pleasures.” - Oscar W

My Blog About Me Photo Gallery

‘What can you find on my web About Me
site? There isn't much stuff on it o
so far, stil working on it. What you

might be interested in is my blog

from a trip around Europe that we

‘took with my friend PJ this

summer. Hope to upload more

photos in near future.

This is the new About me text.

My latest blog posts

6/1/2008 | Destination Madrid

Spain welcomed us with the
entirely Spanish-only
emvironment, “au would think
that they would bother to have
S0MMe Sighns aur annauncements
in English at the international
airport. Fortunately, PJ knows
little Spanish so we were able to
find our way out of arport and
take the right bus to our hostel,
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2.2 Adding a blog post
In this chapter, you will learn how to add a new post to your blog.

1) Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action
toolbar.

CMS Desk Switch to Site Manager  Site: | Personal Site v | User: Global Administrator  Sign Qut

Content | My Desk | Tools | Administration

D a Iﬁl B ﬁ @ @E(m @Preview‘ @Livesne Eust @)

New | Delete| Gopy | Move | Up | Down

=] Personal Site
N)_ Page | Design | Form | Product | Properties Q
2] j My Blog
About Me ) sae  [EE) soel check
g Farums
[#-[=1 Photo Gallery £ Elsowce | [4 £ | & [ B @iB 7 U o= 22 2 £

Special pages
Images

HeO-—aasB8lo
= Sl ~| Fomat ~| Font - Size - Ty~ - & | @

sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

"Tlusion is the first of all pleasures.” - Oscar Wilde.

My Blog About Me Photo Gallery

Saying goodbye Europe

[ Recent posts

» saying goodbye Europe
» Wir sind Berliners
¥ Disapointment in Prague
» Sweetness of loneliness Paris, our final destination. Because there’s no upcoming hitchhiking
» Sacher torte and Austrian . trip, the tension between PJ and me is all gone. I have a friend here,
capital L so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.
£} Syndication
Today, PJ went to do some shopping and we've promised each
» RSS other go out have dinner tonight.

Documents | Search

2) Choose Blog post as a hew document type.

CMS Desk

Content | My Desk | Tools | Administration

D D @ @ ﬁ @ @Eclit Preview

Mew | Delete, Copy  Move Down
24 personal Site Ny Blog
=3 My Blog
: About Me
D New document
Forums

(- [5] Photo Gallery
1| Special pages
635 Images

Please select new document type:

ZZ:I Blog maonth

"] Blog post

@ Link an existing document
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3) Next, enter information for your new blog post.

e Post title: My new blog post

e Post Summary: Summary of the blog post.
e Post text: The entire text of the blog post.

Then click Save at the top.

My Blog » MyBlog » June 2008

Hj Save and create another

5| Spell check

£ & Sowee | [& BR®E & o o AULIEFIB 7 U % =S| E= &
BeD=0&S5i03l0
‘ Style - | Format | Momal - Font ~ | Size - Ty~ - G ‘ E‘
Posttitle: ‘My new blog post

=
Fost date: 6/27/2008 12:05:25 @RM

Summary of the blog post

Post Summary:

The entire text of the blog post.

Fosttext:

© 2009 Kentico Software
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Your new blog post has been added to My Blog.

| My detais | Sign In

"Tiusion is the first of all pleasures

About Me Photo Gallery

[] Recent posts |
| e
U

* My new blog post

¥ Saying goodbye Europe
* Wir sind Berliners

} Disapointment in Prague Summary of the blog post
+ Sweetness of loneliness

,.J Syndication Posted: 8/1/2008 10:43:55 AM by Global Administrator | with 0 comments

» RSS
&

| | Saving goodhye Eurape

[*%) Post archive
+ August 2008(1)
+ July 2008(3)

» June 2008(7) Paris, our final destination. Because there’s no upcoming hitchhiking

trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in

"The World is 3 book, and those - Europe.

who do not travel read only a

page.” Saint Augustine Today, P went to do some shopping and we've promised each

other go out have dinner tonight.

Visit my gallery
Posted: 7/5/2008 1:56:04PM by Global Administrator | with 3 comments

| Wir sind Berliners
o
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Adding a photo gallery

In this chapter, you will learn how to add the new photo gallery and upload some photos.

2) Choose Image gallery as a new document type.

Photo Gallery

D New document

Please select new document type:

) Article

™ Blog

q Cell phone

{¥ Event

@ Event (booking svstem)
@ Fa0

& File

Falder

Image gallery

i Job opening
&9 Knowledge base article
& Laptop

Page (menu item]

& eo2
& Press release

[ Product
=) simple article

@ Link an existing document

1) Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document
action toolbar.

© 2009 Kentico Software



Getting Started 13

3) Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then
click Save at the top.

0

pell check

H Save bj Save and create another

Name: Mew gallery

Description:

Teaser image: Upload: [C:\Documents and Setting[ Browse... |
Publish from: | | Naw

Publish to: | | Naw

[ create a new product

4) Now, go to Properties -> Template and click Select to choose template to use. Choose Personal
Site\Personal Site - Photo Gallery. Click Save at the top.

Page Design Form Product Properties

General
b 2

Template
Metadata
Menu Template: |F'ersona| Site - Photo Gallery H Select.
Workflow ;{‘P Save as new template...
e @ Inhertternpiate
Related docs .
e Clone as ad-hoc template
Linked docs
. [T] Edittemplate properties

Inherit content:
® Use page template settings

) Do natinherit any content
O Select inherited levels

© 2009 Kentico Software
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5) Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.

D New document

Please select new document type:

k= File

Pags (menu item)

@ Link an existing document

6) Click Browse .. and choose a picture to upload. Then enter The description of the first picture. into
the File description text box and click Save at the
top.

H Zave hj Zave and create another i'a Zpell check

Uploadfile: ChDocuments and Settings'zdenekH\My Documents'fotky_pers

The description of the first picture.

File description:

© 2009 Kentico Software



Getting Started 15

Congratulations, you've just learned how to create a new gallery and add some pictures into it.

| My detais | Sign In

"Tusion is the first of all pleasures.” - Oscar Wide

My Blog About Me Photo Gallery

About my photos List of galleries

Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload
more picturas in near future.

I'm far from being 3 professional

photographer. Therefore, if you're European Tri

looking for mesmerzing pictures, T P P

advise you to search somewhere N ,
ale. = Sat of pictures, we've taken on our hitchhiking trip around

Europe with my friend P1. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to nd of coyote howling at the Moon.
Mothing compares to view of blossoming saguaro.

Nothing compares to Arizona.

New gallery

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import.

2.4  Adding forum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1) Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.

CMS Desk Content | My Desk | Tools | Administration
5)-Tools
. [E] BizForms &3 Forum groups
.- i Booking system
.. ¥y Content staging 83 Add forum group
il E-commerce
..[fy File import
: 3 FI < Impo Actions Group name
....83 Forums
{5 Newsletter € & B wyFoums
.. Polls
- Reporting _ »
G Web Analytics @ Posts waiting for my approval

© 2009 Kentico Software



16

Kentico CMS Personal Site Guide 4.0

2) In the Forum group properties, click Add forum @ Add forum |

3) Add the following information for the new forum:

e Forum display name: New forum

e Forum code name: newForum

e Description: The description of the new forum.

Then click OK.

Forums || General | View

& New forum

Forums » Mew forum

Forum display name: Mew forum

Faorum code name: newForum
The description of the new
forum.

Description:

Forum base URL:
Inherit from forum group
Forum unsubscription URL:

Inherit from forum group

Forum s open
Forumis moderated O
Require e-mail addresses: O
Display e-mail addresses: O
Enable WYSIWYG editor: O

Use security code (CAPTCHA): [

© 2009 Kentico Software
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4) The forum has been added as you can see in the following screenshot.

Forums

Forum

| My details | Sign In

"Tlusion is the

Forums Photo Gallery

Threads Posts Last post

My Forums

Goodbye party

New forum
The description of the new forum.

Where to go in Europe

i
(5/28/2008 25T:25 PI)

administrator
(7/7/2008 1:57:32 PM)

Kate
(5i22/2008 8:16:15 PM)

17
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3 Adjusting Design

3.1  Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will
learn which stylesheets are available and how you can choose the CSS stylesheet you want to use on
your web site.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site
next to the Personal Site.

CMS Site Manager

0 Sites

@ nNew site wizard W Import site or obiects .ﬁ Export objects

Sites Administration Settings Development Licenses Support

Actions Site name Status
S i ?_1’ @ [b ':u Corporate Site Stopped
< i ?_1’ @ [?.'«‘-' ":u E-commerce site Stopped

? @ [?«‘* ';E,. Fersonal Site Running

© 2009 Kentico Software



20

Kentico CMS Personal Site Guide 4.0

In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.

CMS Site Manager

Sites | Administration Settings Development

o Site Properties

Sites » PersonalSite

General | Domain aliases || Cultures

Site display name: |F'ersnna| Site |
Site code name: |Persnna|8ite |
Site domain name: ||cu:a|hc|st |
Default content culture: cpgjizh - United States

Default visitor culture: | (Automatic) V|
Site CSS stylesheet  |EEEICELC |
Editor C8S stylesheet | Personal Site v|
Site description: Sample personal web site

Licenses

Support

© 2009 Kentico Software
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The following CSS stylesheets are available in the sample Personal Site:

Personal Site

[ Recent posts

» Saying goodbye Europe

» Wir sind Berliners

» Disapointment in Prague
» Sweetness of loneliness

» Sacher torte and Austrian
capital

E) Syndication

»RSS

[*% Post archive
» August 2008(0)

» July 2008(3)
» June 2008(7)

"The World is a book, and those
who do not travel read only a
page.” Saint Augustine

Visit my gallery

Personal Site - Blue

| My details | Sign In

n is the fir

My Blog About He Photo Gallery

J Saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhi
trip, the tension between PJ and me is all gone. T have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2008 1:55:04PM by Global Administrator | with 3 comments

J Wir sind Berliners

Berlin, after a long time the ity we both wanted to see. And as we're

most done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. We don't have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Posted: 7/3/2008 1:54:27 FM by Global Administrator | with 1 comments

| My details | SignIn

Personal starter site

"Tlusion is the first of all pleasures.” - Oscar Wilde.

T Recent posts

» Saying goodbye Europe

» Wir sind Berliners

» Disapointment in Prague
» Sweetness of loneliness

, Sacher torte and Austrian

EY syndication
» RSS.

[ Post archive

» August 2008(0)
» July 2008(3)
¥ June 2008(7)

"The World is 2 book, 2nd those
who do not travel read only a
page.” Saint Augustine

it my gallery

J Saying goodbye Eurape

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between P and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2008 1:56:04PM by Global Ad rator | with 3 comments

J Wir sind Berliners.

Berlin, after a long time the city we both wanted to see. And as we're
almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. We don't have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Posted: 7/3/2008 1:54:27 PM by Global Administrator | with 1 comments

21
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Personal Site - Green

| My details | Sign In

e

< MyBlog « AboutMe ¥ Forums i Photo Gallery

[ Recent posts J
Saying goodbye Europe

} Saying goodbye Europe o "

¥ Wir sind Berliners

» Disapointment in Prague

¥ Sweetness of loneliness
Sacher torte and Austrian

Capital

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

E) syndication
Today, PJ went to do some shopping and we've promised each

»RSS other go out have dinner tonight.

[ Post archive Posted: 7/5/2008 1:36:04 PM by Global Administrator | with 3 comments
» August 2008(0)

» July 2008(3)

¥ June 2008(7)
J Wir sind Berliners

"The Warld is 2 book, and those
who do not travel read only 2

page.” Saint Augustine Berlin, after a long time the city we both wanted to see. And as we're

almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. We don’t have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Visit my gallery

Posted: 7/3/2008 1:54:27PM by Global Admi

vator | with 1 comments

Personal Site - Red

| My details | SignIn

Personal starter site

"Tlusion is the first of al pleasure: Oscar Wide.

W MyBlog

) Recent posts J
Saying goodbye Europe
» Saying goodbye Europe e ”
» Wir sind Berliners
¥ Disapointment in Prague
» sweetness of loneliness Paris, our final destination. Because there's no upcoming hitchhiking
Sacher torte and Austrian trip, the tension between PJ and me is all gone. I have a friend here,
Capital so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

E) Syndication
&) sy Today, P went to do some shopping and we've promised each
» RSS. other go out have dinner tonight.

[ Post archive Posted: 7/5/2008 1:56:04PM by Global Administrator | with 3 comments
» August 2008(0)

» July 2008(3)

» June 2008(7)

J Wir sind Berliners

"The World is 2 book, 2nd those
who do not travel read only a

page.” Sant Augustne Berlin, after a long time the city we both wanted to see. And as we're

almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. We don't have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Visit my gallery

Posted: 7/3/2008 1:5%:27 PM by Global Administrator | with 1 comments
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3.2  Editing CSS stylesheets

In this chapter, you will learn how to change the design of your web site by modifying the CSS
stylesheets.

Changing the header picture

1) Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site
and choose Main styles/Master page section in the text box on the left side.

CMS Site Manager

Switch to CMS Desk  User: Global Administrator  Sign Out
Sites | Administration | Settinge | Development | Licenses | Support Switch to CMS Desk  User: Global Administrator  Sig

(=) Development

4055 stylesheats j CS8 stylesheet properties

@ Countries 38 stileshests » Personal Sits

@ Cultures

g Document types General | Sites

o) E-mail templates

.. Form controls s 4 checkouttofie

i.[Z) Inline controls

B _sMudules Check outthe stylesheetto file clinetpubh icoCMSICMSC \Persor ite.css to editthe stylesheet externally.

[T Page layouts

@ Page templates Stylesheet display 3 s
:.=3 Relationship names name: ersonal Sits
i) System tables

2 UI cultures

Veb part containers
L Farums
B Global
* [3@) web templates wi :

g Workflows

Stylesheetcode name:  |PersonalSite

in styles/Mascer pages=/ | ||Blogs

Boxes

Logon page

Main styles
Left menu

| Masterpage |
Membership top zone
Search box
Top menu

My profile

Photogallery

Search page

Styleshest text

r1(../Bpp Themes/PerscnalSite/Images/bg head.ipg)

2) In the .zoneTop style, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

-zoneTop
{ _

height: 239px;

width: 795px;

background-color: #fff;

padding: Opx Opx 7px;

margin: Opx Opx Opx;

background: #Ffff url(../App_Themes/PersonalSiteGreen/Images/bg_head. jpg)
no-repeat top left;

Then click Save at the top-left.

© 2009 Kentico Software
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3) Now click Sign out at the top-right. You can see that the header image has been changed.

I 5o |

[ Recent posts

» Saying goodbye Europe

¥ Wir sind Berliners

} Disapointment in Prague
} Sweetness of loneliness

» Sacher torte and Austrian
«capital

£ Syndication
* RSS

[ Post archive

» August 2008(0)
+ July 2008(3)
+ June 2008(7)

"The World is a book, and those
who do not travel read only 3
page.” Szint Augustine

Visit my gallery

Changing the top menu

1) Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master

| My detais | Sign In

My Blog About Me Photo Gallery

:J Saying goodbye Europe

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between PJ and me is all gone. T have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2008 1:55:04PM by Global Administrator | with 3 comments

Wir sind Berlit

Berlin, after a long time the city we both wanted to see. And as we're
almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
cach other again. We don't have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Posted: 7/3/2008 1:54:27 PM by Global Administrator | with 1 comments

page section in the text box on the left side.

© 2009 Kentico Software
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2) Scroll down to see .zoneTopMenu style.

if i 5 d Adminis Sign Out
CMS Site Manager ctes o | Setings | D Geenses | Support | Bay Switch to CMS Desk  User: Global Administrator  Sign Oul
(= DS S loDme 5 CS8S stylesheet properties
i 4 55 stylesheets prop
i@ Countries CSS stilesheets » Persanal Site
4@ Cultures
i@ Document types General | Sitss
i (2) E-mail templates
i Form controls H Save ’J Check out o file
* [ Inline controls
SMndules Check outthe stylesheet to file ciiinetpubh T OCMSICMSC rsor css to editthe stylesheet externally.
[[JPage layouts
H & Page templates Stylesheetdisplay |F 'S ‘
i@ Relationship names name ersonal Site
[E) System tables Stylesheet code name |Persnna\Sne ‘
L UI cultures
8] Web part containers S #||Blogs
Web part: font-sizer 32pw; Forums
B¢ Web parts margin-top:Opx; Global
i..[@) Web templates 3 Boxes
g Workflows Logon page
| [ pee
: Left menu
‘
‘ R R _ Membership top zone
1 #£If url(../App_Themes/PersonalSite/Images/bg_topmenu.gd Search box
Top menu
Styleshesttext ) gﬁ;i’ﬂ’;@ﬁew
Search page
.DesignMode .zoneTopMenu
neignht: 120px;
1
.zoneBottom
L
< b4

3) Change the background color to #B0C4DE and erase the URL part so that the entire section reads
as follows:

-zoneTopMenu
{
height: 43px;
width: 795px;
background: #BOC4DE;
padding: Opx;
margin: Opx;

This will change the background of the navigation at the top to dark blue.
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4) Now, switch to the Top menu section and find .CMSListMenuLl a:hover style. This style modifies
the appearance of menu item when mouse is over it.

CMS Site Manager

Swj S Des : Adminis Sign Out
Sites | Administration | Settings | Development | Licenses | Support | Buy Switch to WS Desk  User: Glabal Administratar AT
2 Development N

. CSS stylesheet properties

i 4 55 stylesheets ‘5 ty prop

i@ Countries CSS stilesheets » Persanal Site

4@ Cultures

i@ Document types General | Sites .

i (2) E-mail templates

.. Form controls H Save 9 Check outto file

* [ Inline controls

srr'\odules Check outthe stylesheet to file ciiinetpubh T oCMSICMSC \Persor css to editthe stylesheet externally.

[[JPage layouts

H & Page templates Stylesheetdisplay P 'S

i@ Relationship names name ersonal Site

- [l system tables Stylesheet code name:  |PersonalSite

@ UI cultures
Web part containers #||Blogs
& Web parts .CM5ListMenulink, istMenuLinkdighlighted E\Tf;;m‘s

g Global

i..[@) Web templates Boxes

g Workflows Logon page

Main styles
Left menu

Master page
Membership top zone
Search box

My profile

Photogallery

Search page

Styleshesttext

LI, .leftMenu .CM5ListMenuHighlightedLI

5) Change color to #fff and replace the url part with #87CEFA. The entire style should read as follows:

-CMSListMenuLl a:hover, .CMSListMenuLinkHighlighted, .CMSListMenuLllast a:hover,

-CMSListMenuHighlightedLllast a, .CMSListMenuHighlightedLl a

{
color: #fff;
background: #87CEFA;
text-decoration: none;

This will change the background of the menu item to light blue and its font color to white when mouse
hovers above it.

© 2009 Kentico Software



Adjusting Design

You've just learnt how modify CSS stylesheets to change design of your web site.

I oo

[ Recent posts

» Saying goodbye Europe

» Wir sind Berliners

» Disapointment in Prague
» Sweetness of loneliness

» Sacher torte and Austrian
capital

E) syndication
¥ RSS

[*%) Post archive
¥ August 2008(0)

» July 2008(3)
» June 2008(7)

"The World is 3 book, and those
who do not travel read only a
page.” Szint Augustine

Visit my gallery

| My detais | Sign In

J Saying goodbye Europe

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

Posted: 7/5/2008 1:56:04 PM by Global Administrator | with 3 comments

Wir sind Berliners
J

Berlin, after a long time the city we both wanted to see. And as we're
almost done with our trip, we're getting much more relaxed in
comparison with just week ago. We are almost able to joke with
each other again. We don’t have much money left, though, so we're
mostly hanging around, considering every Euro, spent for the gallery
ticket.

Posted: 7/3/2008 1:54:27 PM by Global Administrator | with 1 comments
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4 Adding web parts

4.1  Adding text

In this chapter, you will learn how to add the new editable text region into your web site.

1) Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web part in
zoneRight.

- - N pers = . i Sign Out
CMS Desk Content |ty Desk || Tools | Admnistraton Switch to Site Manager  Site __PEr onal Site v | User: Global Administrator  Sigl

D a @ B ﬁ g @ Edit Preview @ Live site E List

New Delete, Copy Move Up Down

@

n:l-_aiersunal S Page Design | Form Product Properties [¥] Display web part content g)
@-[3 My Blog
About Me

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. ~
Forums

Photo Gallery
Special pages

[ERC R

Current user: Global Administrator | My details | Sign out
“ Images

Photo Gallery

~ [About Me - page template: Personal Site - About Me

¥ zoneleft ] * zoneRight

¥ LeftText op| ¥ TitleRegion &7
About Me

What can you find on my web
site? There isn't much stuff on it

so far, stil working on it. What ¥ MainRegion &7

Hi there,

Documents | Search
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2) Select Text/EditableText web part.

2 Portal engine - Web part selection -- Webpage Dialog
* Select web part

N
|1|L:] Listings and viewers —|| Editable text

&I Media

-J Membership B s AN e
|1|L:] Massaging x: E w‘-'-r;w Ll =

&) Navigation : i

(5 COINews e ey s o et ok s
& Newsletters

|:|L:] Palls

(-{J Reporting

- Text

-k Editable image

- pag‘?d text The Editable text web part displays an editable region that enabled
- Static HTML content editors to edit page content.

. i Static text
(- User contributions
&) Web services

e

I Ok H Cancel

hittp: fflocalhostkenticoCMS6/CMSDesk/PartalEngine SelectvwebPart, aspix ‘:g Local intranet

3) In the Web part properties dialog, enter the following information for the new web part.

e Editable region title: AboutWebPageTitle
e Content before: <h1>
e Content after: </h1>

Then click Ok.
4) Click Add web part again and select the same Text/EditableText web part.

5) In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click Ok.

6) Now you have the new web parts ready and you can enter some new text. Switch to the Page tab
and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.

© 2009 Kentico Software



Adding web parts 31

7) Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.

@ Edit @ Preview @ Live site E List

Page Design Form Product Properties

2]

pell check

to see me. The trip to Prague is e e e
one smooth ride. Butthe city .
center is jammed with people ! AboutWebPageTitle

again. Why all tourists share the [About my web page
nead nfwiziting =ame nlares At f

. AboutWebPageText
EThis is a shor text about my web page.

e®= Powered by
J :‘\ﬁf:ﬂco

|>

4]
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That is how you add a new editable region into your web site.

E—

‘What can you find on my web About Me
site? There isn't much stuff on it e
so far, still working on it. What you

might be interested in is my blog

from a trip around Europe that we

‘took with my friend PJ this About my web page
summer. Hope to upload more = This is 2 short text sbout my web page.
photos in near future.

This is the new About me text.

My latest blog posts

6/4/2008 | Along the coast of
Dragon to Montpellier

France, eventually. For a whils,
it seemed like we wouldn't be
able to make it. We spent more
than three hours waiting for a
ride at the Spanish — French
border in Pyrenees, The scenery
was cool, thaugh. Finally, an old
man in the rusty Seat took us
on board, &5 if unaware of his
vehicle condition, he drove like
nuts so that we sat in sience
with terror in our eyes, He
couldn’t speak English anyway.
However he took us all the way

+A Mentraliar

| My detais | Sign In
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4.2  Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

33

1) First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll.

CMS Desk

Content | My Desk || Teols | Administration

[z)-Tools
-..[E] BizForms € Polis
f..-}ﬂBGGking system
5....% Content staging @ newpol
_7,!' E-commerce
j; File import
E.l Forums
‘;j Mewsletter
Q Palls
.[g Reporting
:...j. Web Analytics

2) Enter the following information for the new poll.

e Display name: My poll
e Code name: MyPoll
¢ Question: How do you like my pictures?

Then click Ok.
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3) Now we need to defined some questions for your new poll. In the poll properties, switch to Answers

tab and click New answer 5! Mew amswer  Into the Text text box, enter | love them!. Make sure that
the Enabled check box is checked and click Ok.

General | Answers | Security | Sites | View
ﬂ New answer
Answers » Mew answer

ﬁ Mew answer

Text: | love them!

Enahled:

4) Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.
Then click Ok.

5) Click New answer again and enter Waste of time! into the text box provided. Click Ok.
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6) Now we are ready to add your new poll to web site. Go to CMS Desk -> Content -> Personal Site -
> Photo Gallery and switch to the Design tab. Click Add web part in zoneLeft.

Tools || Administration

CMS Desk Content | vy Desk
D a2+ @ [ eait
New Delete, Copy Move Up Down

(=@ Personal Site

] ? My Blog

g About Me

== Forums

(+-[¥ Phota Gallery

@ Special pages

- Images
Documents | Search

Preview @ Live site E List

Page | Design | Form | Product || Properties

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. o)

Switch te Site Manager Site:| Personal Site ¥ | User: Global Administrator  Sign Out

@

Display web part content g)

Current user: Global Administrator | My details | Sign out

~ [Photo Gallery - page tempb;eg’emonal Site - List of galleries

¥ zoneleft (d} * zoneRight

@

¥ LeftText op|

About my photos

¥ HeaderText &7
List of galleries

Alright, let’s be clear on this.

I'm far from being a professi I

PPV |

7) In the Select web part dialog, select Polls\Poll web part.

v DescriptionText g—;zrgnd picturas I took in past few months. I'm planning to upload

=

& Portal engine - Web part selection -- Webpage Dialog

ﬁ Select web part
L
-{ZJ Events
(4] Forums
|:I'L:] Full-text search
-] General
|:I~LJ Google services
¢|~Lj Listings and viewers
&¢I Media
(i) Membership
¢|~Lj Messaging
(&) Navigation
&) News
¢|~Lj Newsletters
- Polls
@-{ZJ Reporting
@) Text
.11{3 User contributions

-~
—| Poll

Do you like our product?

s ez, | da.

' o, | dan't.

[ I don'tknow your praduct.

The Poll web part allows you to insert your own Poll an the page.

| £

[ OK ] ’ Cancel

Ihttp:,l’,l’localhost,l’KenticoCMS6,!’CMSDeskJ'PortaIEngine,l’SeIectWebPart.aspx

‘-ﬁ Local intranet
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8) In the Web part properties dialog, make sure My poll is selected as Poll name and click Ok.

Congratulations, you've just learned how to add a new poll to your web site.

I soarcn

About my photos
Alright, let’s be clear on this.
I'm far from being 2 professional
photographer. Therefore, if youre
Inoking for mesmerizing pictures, I
advise you to search somewhere
else.
How do you like my pictures?
O1love them!
O Mot bad.

Waste of time!

My Blog

List of galleries

| My detais | Sign In

In these galleries, you can find pictures I took in past few months. I'm planning to upload

mare pictures in near future.

European Trip

Set of pictures, e taken on our hitchhiking trip around
Europe with my friend PJ. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
Nothing compares of blossoming saguaro.

Nothing compares f na.
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Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

e Kentico CMS Tutorial
e Kentico CMS Developer's Guide
e Kentico DevNet at http://www.kentico.com/DevNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.

com/Support.aspx.
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