New Hotfix 5.5.20 (build no. 3926) Released

   —   
The new hotfix package was released and it is available for download. You can find the hotfix packages for appropriate .Net version in the Bugtracker (the orange box on the right). Instructions are included, please read carefully.
Bugs fixed in hotfix 5.5.20 (build no. 3926):
· Asynchronous postbacks caused by third party components threw an exception in special cases.
· Blogs - MetaWeblogAPI didn't work correctly when obtaining recent blog posts.
· Blogs - an unwanted info message was displayed in special cases.
· Form controls - empty fields using the document selector form control weren't saved correctly.
· Web parts - Document attachments web parts didn't cache data correctly.
· Web parts - the Check permissions property wasn't processed correctly in special cases.
· BizForms - Date time picker was missing an icon on the live site.
· Media library - trailing spaces weren't correctly removed from the names of new folders.
· Media library - the edit button wasn't disabled immediately after import for unsupported image formats.
· Media library - mass actions didn't work correctly in special cases.
· Alternative forms - modifications of alternative forms after new fields were added to a base form affected form definition in special cases.

Bugs fixed in hotfix 5.5.19 (build no. 3922):
· User contributions didn't work properly with form controls based on uni-selector (e.g. country selector).
· Publishing or archiving of selected documents in the listing mode didn't work correctly in special cases.
· Ecommerce - required tax id and organization id wasn't validated correctly for anonymous customers.
· Media library - incorrect permissions handling for group administrator in special cases.
· Dynamically loaded controls based on uni-selector couldn't open selection dialog in special cases.
· Documents in recycle bin weren't restored correctly in special cases.
· Media selector returned resolved URLs for selected media files.
· ShowSortDirection option of UniGrid control didn't work correctly.
· Message boards' "No message text" property was not used correctly for user message boards.
· Viewer and navigation controls didn't cache data properly if the "Check permissions" property was enabled.

Bugs fixed in hotfix 5.5.18 (build no. 3912):
· Inserting links with encoded characters through the WYSIWYG editor resulted in the links being inserted with the characters decoded.
· Text displayed on handler404.aspx or PageNotFound.aspx pages was always in the default culture.
· Widgets - The content of User widget zones wasn't correctly displayed in special cases.
· Staging - Staging tasks weren't logged for document attachment updates in special cases.
· Workflow - Publishing in list view mode didn't work correctly for child documents.
· The Publish from/to fields were always disabled for the Root document.
· GetUrl transformation method didn't reflect site settings for extensions.

Bugs fixed in hotfix 5.5.17 (build no. 3905):
· Creating new folders in WYSIWYG editor dialogs wasn't working properly if the selected site was different from the current site.
· Web analytics - log processing caused an error if site information wasn't present in the .log file.
· Page templates - Page template selector didn´t correctly show all templates during the creation of a new document.
· Recycle bin - Now uses a more efficient query for loading data.
· Editable region - When inserting flash objects into the HTML editor, the code was rewritten after the page was saved, causing some parameters to disappear.

Bugs fixed in hotfix 5.5.16 (build no. 3901):
· Smart search - Where condition for attachment searching wasn't created correctly in special cases.
· Web parts - Attachment web parts weren't resolving path macros correctly.
· Import - Document related permissions weren't imported correctly with the document onto an existing site.
· BizForms - Private fields that allowed an empty value didn't save the content of the Default value.
· Document selector didn't correctly handle selection from a different site than the current one.
· Staging - Publish document staging tasks didn't contain version history information in special cases.
· Document urls weren't created correctly from document names in special cases.

Bugs fixed in hotfix 5.5.15 (build no. 3894):
· The loading of settings after manually clearing the cache wasn't effective.
· Reporting - Print functionality didn't reflect report parameter value changes.
· Document stylesheets weren't inherited correctly from parent documents in special cases.
· The "Archived" flag sometimes persisted in the document tree even if it wasn't current.
· Staging - Publish document staging task didn't contain the version history data in special cases, which resulted in the document not being synchronized properly on the target.
· Page placeholder web part didn't resolve path macro expressions in the Document to display property.

Bugs fixed in hotfix 5.5.14 (build no. 3887):
· Output filter didn't process conditional comments properly.
· Domain alias redirecting didn't work correctly if the URL contained the application path.
· OpenID logon didn't work properly on ASPX templates.
· Pages generating XML content could throw an exception in special cases.
· EventLog - A deadlock could occur when deleting older logs on heavy traffic web sites.
· Mobile device redirection - Always redirect property added to allow extended configuration.
· Bad format of the "No messages" text in message boards.
· A page with a wildcard URL couldn't be found if the URL contained an underscore.

Bugs fixed in hotfix 5.5.13 (build no. 3880):
· New CMS.File documents didn't correctly handle files with file names that were too long during creation.
· Widget selector didn't display all available widgets for the global administrator.
· Registration web parts didn't display content correctly.
· Export - Some of the child objects were exported even if the parent object wasn't selected in the export settings.
· Import - The license wasn't checked correctly during the import process.
· Scrolling text web part didn't work correctly if two web parts with the same ID were on one site.
· Country selector didn't return an empty value when no country was selected.
· URLs in forum macros without query parameter values weren't resolved correctly.
· Context macros didn't allow recursion in some cases.
· Page manager could cause an exception.
· Output cache wasn't flushed when document attachments were modified.
· Performing a mass action in List view mode of the Media library caused an error when a folder was selected.
· Group members data source web part had an incorrect path to its physical file.
· Documents - A deadlock occurred during document version history removal.
· Event log - A deadlock occurred when deleting old Event log entries.

Bugs fixed in hotfix 5.5.12 (build no. 3873):
· It was possible to transfer documents between sites even if their document types were not assigned to the target site.
· Template subject was omitted when cloning newsletter templates.
· Newsletter unsubscription link was not resolved properly when it was placed right behind a metafile image.
· Group widgets were not saved correctly if a document was under workflow.
· Single object export - Object binary files were exported without their extensions, which could cause import problems.
· RSS transformations - Default transformations were using encoding, which caused issues with diacritics.
· Groups datasource web part contained an invalid path to its ASCX file.
· Import/Export - Newsletter subscribers were not exported properly.
· Staging - Document staging tasks list did not show document links correctly in the titles of some task types
· Permissions - When selecting a Custom table permission type, an error was shown if there were no custom tables assigned to the selected site.
· Group forum post viewer web part did not display any data.
· Cache wasn't flushed for documents when permissions changed.
· The RemoveUserFromRole method could throw an exception if it was used in custom code.
· Import - Workflow scopes were not imported during new site creation from a web template.
· Some CMS controls did not work properly in Visual studio design mode.
· Staging - Sorting a sub-section of a document did not log staging tasks.

Bugs fixed in hotfix 5.5.11 (build no. 3866):
· Media file thumbnail was not refreshed when uploading a file under a folder path containing an apostrophe.
· Universal selector - Selection dialog did not show items correctly in special cases.
· Navigation controls did not display items in the correct order in special cases.
· Newsletters - A large number of subscribers caused their export to fail.
· Polls - Users were unable to create polls with the same code name in different community groups.
· Blog comments RSS web part - The Check permissions property was removed because it was useless.
· RSS feeds - RSS feeds were not cached properly in special cases.
· WYSIWYG editor - Attachment file icons were not displayed correcty in thumbnails and tiles view modes.
· Media libraries did not work effectively if web farm support was enabled.
· Scrolling news web part started scrolling right after a page was loaded.
· Image selection and Media selection form controls did not handle automatic resizing settings correctly.
· Paging in controls did not work correctly if partial caching was enabled.
· Smart search - German, Portugese, French and Swedish stop words lists contained duplicate words, which caused an exception.
· New site wizard - New sites were created with an incorrect content culture in special cases.
· Caching in the custom table datagrid and Custom table datalist did not work properly.
· Newsletters - Unsubscribing while mailout was in progress sometimes interrupted the mailout or caused it to report an incorrect sent e-mails count.
· Abuse report API - The GetAbuseReports method recursively called itself causing an infinite loop.
· Import - Web farm synchronization tasks for media files were not created during the import process.

Bugs fixed in hotfix 5.5.10 (build no. 3859):
· Permission matrix drop-down list was not refreshed when the selected site changed.
· E-commerce checkout process - Country and state were not reloaded when the selected address changed.
· Security - An exception could occur when breaking document permission inheritance in special cases.
· Settings - Event log size setting was not reflected properly.
· Listing of users in Administration has been optimized.
· Friends data source web part had a wrong filename set.
· WYSIWYG editor - URLs generated for CMS.File documents did not reflect document URL extension settings.
· An error message was sometimes displayed when uploading attachments on machines using IIS 6.
· WYSIWYG editor - UI personalization was used even though it had been disabled in Site Manager settings.
· Form Engine - Macros used as default values of properties were not resolved in some places.
· Recycle bin - Document permissions weren't checked properly in Recycle bin.
· Friends - After approving or rejecting a friend using a link from an e-mail, the user name was missing in the confirmation e-mail.
· Workflow - User could not submit a document for approval from the edit step on the Workflow tab in specific cases.
· Workflow - Users could not check in a document which had been checked out before when check out/check in was turned off in settings.

Bugs fixed in hotfix 5.5.9 (build no. 3849):
· URL Rewriting - Url path prefix wasn't processed in special cases.
· Security - It was possible to change the order of nodes without appropriate permissions.
· Security - User wasn't able to create new documents using the context menu in specific cases.
· Security - Editable content - user was able to delete editable content of a node without appropriate permissions.
· Document type icons weren't renamed appropriately when a user changed document type name.
· Attachments - The Attachment datasource web part didn't cache its data correctly.
· Media library - The See library content permission was not correctly checked for group media libraries.
· Localization didn't work correctly for tree menus in administration UI.
· Newsletters - Deleting a user or a role didn't result in deleting related newsletter subscribers.
· Newsletters - Sending dynamic newsletters may have caused big load.
· Newsletters - Sending newsletters with attachments to role subscriber caused an exception.
· Page placeholder didn't display content correctly on an inherited page if default page template was specified.

Bugs fixed in hotfix 5.5.8 (build no. 3842):
· Settings - Event log size setting key allowed entering negative values.
· Ecommerce - Shopping cart item custom data wasn't transferred to the Order item custom fields.
· Web methods didn't work correctly in special cases.
· Security - The list of documents which use a page template was displayed incorrectly due to a wrong security check.
· Security - Document type permissions weren't checked correctly in multisite environment in special cases.
· Newsletters - Custom newsletter stylesheet wasn't applied when editing an issue.

Bugs fixed in hotfix 5.5.7 (build no. 3834):
· Smart search - Polish stop words list contained duplicate words which caused an exception.
· Staging - Creation of group media libraries was not synchronized correctly.
· Ecommerce - When a site was deleted, the products assigned to the documents of that site were also deleted even if they were assigned to documents on another existing site.
· Message boards - Role code names were displayed instead of their display names in the list of roles on security tab in message board management.
· Widgets - Resetting to default did not work correctly in user widget zones.
· Child documents of a linked document did not keep their current order after creation.
· Output filter did not handle conditional comments properly.
· WYSIWYG editor - Inserting e-mail link did not work correctly if the e-mail body contained empty lines.

Bugs fixed in hotfix 5.5.6 (build no. 3828):
· The Group polls web part did not work correctly in AJAX Update panel.
· URL path conversion did not correctly remove diacritics which could cause some multilingual URLs not to work in IE6.
· Configuration settings were not initialized correctly for the Document attachments field in special cases.
· MetaWeblogAPI trimmed the blog post summary in the middle of a word.
· The configured page not found page did not receive the set query string.
· Site folders were not deleted with the site in special cases.
· The OpenIDUserRequiredData web part did not display the 'Display message' property correctly.
· Membership - Authentication of a user with a name that contained special characters failed in mixed mode authentication.
· The Mobile redirection web part now creates a cookie indicating if the redirection was already done.
· Output cache was available longer than the Publish to field allowed.
· Output cache was not flushed when the document changed.
· Subscriber created for an e-commerce customer did not have the 'Subscriber full name' field set.
· Data web parts could throw an exception if the selected columns were defined explicitly.
· Shopping cart step images did not have tooltips assigned.
· Product selector displayed product options along with the list of products.

Bugs fixed in hotfix 5.5.5 (build no. 3821):
· Google site map did not work correctly if the application was initialized through the Google site map page.
· Creating of a new document culture version could throw the 'Invalid length parameter passed to the RIGHT function.' exception in special cases.
· Web analytics displayed wrong browser version numbers on IIS7 and .NET 4.0.
· US Section 508 validation changes.
· The File system selector could throw an exception with some special forms of relative path.
· The Import wizard could throw an exception when having insufficient permissions on the import folder.
· The UniSelector did not resolve localization macros in drop-down lists.
· The WYSIWYG editor toolbar disappeared after partial postback in CMSDesk -> Content -> Form.
· Wrong document permissions could be set to child documents while breaking or restoring parent permissions inheritance.
· Documents after "Click here for more ..." were not displayed correctly in the content tree if there was more such items on the path.
· The Attachments data source web part did not cache its data properly.
· Media library - The MediaLibraryTree control accessed an incorrect disk location.

Bugs fixed in hotfix 5.5.4 (build no. 3817):
· MetaWeblogAPI - Image paths were incorrect when the system was installed in the root of IIS.
· Media library - An exception was thrown when CMYK images were resized on Windows 7.
· Media library - Multiple file import did not work when page size drop-down list and paging was used in the file listing.
·  Reporting - Graph/Table/Value items were not loaded correctly in special cases in the editing window.
· Version manager did not perform proper checks for empty datasets and therefore was causing exceptions.
· Web part categories with the same display name could cause an exception on the web part editing page.
· Widget categories with the same display name could cause an exception on the widget editing page.
· Scheduled tasks for e-mail and newsletter sending could start more threads at one time.
· Forums - On-site management actions did not work for .NET 4.0.
· Linked document creation did not flush the cache properly.
· Optimized deleting of archived e-mails prevents "Out of memory" exceptions.

Bugs fixed in hotfix 5.5.3 (build no. 3810):
· Portal engine - The "Display to roles" web part zone property did not work properly for global administrators.
· Reporting - Graphs did not work if the application ran under medium trust.
· Documents - A document under a workflow marked as a product was not published correctly in special cases.
· Portal engine - Widget header controls were hidden in editing mode when the widget itself was hidden (e.g. while having the "Hide if no record found" property on).
· User control selector - The entered file's extension was not checked.
· General - An exception was thrown when a user browsed the live site with an unusual device.
· The "Restore all" function in Recycle bin restored only documents on the first page of the list.

Bugs fixed in hotfix 5.5.2 (build no. 3803):
· Content staging - When a user selected to synchronize all tasks on the Documents tab, the tasks were sychronized in an incorrect order.
· The "Always use URL without trailing slash" setting could cause an infinite redirect loop on the website root page.
· Site cultures list showed only the first 11 pages.
· Export wizard - items were not preselected correctly in specific cases.
· Media library files selection did not work properly if the copy/move dialog was closed without executing an action.
· Content staging - A document created under a workflow was published immediately after synchronization to the target server.
· Content staging - Archived documents were not synchronized correctly in some special cases.
· Field editor - Users could not add a new system attribute of LongText data type (e.g. the DocumentTags attribute) to a document type.
· Cursor position was lost after postback when editing a text area.
· Attachment URLs were not handled correctly if a custom file friendly URL extension was used.
· In-place localization macros used parameters of the previously evaluated macro.
· TrueValue and FalseValue macro parameters did not work properly if used after an evaluation parameter.

Bugs fixed in hotfix 5.5.1 (build no. 3793):
· Search – The 'Did you mean' web part could throw an exception in special cases.
· Page template categories with the same display name could cause an exception on the template editing page.
· Friends - Ignore list was not respected when sending friendship request notification messages.
· File system selector - Selected file path was invalid if the web site was installed into the root.
· Content Staging - There was an occasional problem with the DataReader during document staging tasks logging.
· UI Cultures - If user selected '(default)' option in the 'Preferred user interface culture' setting, an exception was thrown after she logged in the system again.
· New Site Wizard - There was a problem with loading web site templates if the Previous button was hit.
· Selectors in the permissions administration section did not reflect site selection when loading the list of modules/document types.
· Page template inheritance didn't work properly for values defined on the Master page tab.

Should you need any help with this hotfix or experience any other issues with it, please feel free to contact us at support@kentico.com. Version 5.5 contains all bug fixes from 5.0 version.
Share this article on   LinkedIn Google+

Juraj Ondrus

Hi, I am the Technical support leader at Kentico. I'm here to help you use Kentico and get as much as possible out of it.

Comments