How to initialize the Azure storage emulator on a local SQL server

   —   
This article describes how to initialize the Azure storage emulator on a local SQL server using the built-in DSInit Command-Line Tool.
When trying to run an Azure application on the Azure emulator (CTRL + F5 in the Visual Studio), you may encounter the following (or similar) error message:
 
…
Unable to start Development Storage. Failed to start Development Storage: the SQL Server instance XXX could not be found.  Please configure the SQL Server instance for Development Storage using the ‘DSInit’ utility in the Windows Azure SDK.
…
 
The background of this problem is that the Azure emulator needs a local SQL instance to create a development storage database on. This is not a Kentico CMS database yet - it is the Azure development storage database with the following structure:



If no local SQL server is available or one is present but not well mapped, the emulator fails with a message above. To fix this and set a local SQL server instance manually, the following steps must be taken (in Windows 7):
 
1. Click Start, point to All Programs, and then click Windows Azure SDK.
 
2. Right-click on Windows Azure SDK Command Prompt and then click Run as administrator.
 
3. In the Windows Azure SDK Command Prompt window, type the following command:
 
DSInit /sqlInstance:<SQLServerInstance>
 
where <SQLServerInstance> is the name of the SQL Server instance.
 
You can also use the following command, which uses the default instance:
DSInit /sqlInstance:.
 
Or, you can use the following command, which reinitializes the database:
DSInit /forceCreate
 
When all steps are successfully completed, you should see a dialog like this:



Please note:
  • You must have administrative privileges to run the DSInit Command-Line Tool.
  • Running the “DSInit /forceCreate” command results in all of the existing data in the local Blob and Queue service being lost.
  • You can use the DSInit Command-Line Tool at any time to configure the Windows Azure storage emulator to point to a different instance.
 
-rm-


See also: DSInit Command-Line Tool
Kentico CMS 7 Windows Azure Deployment Guide

Applies to: Kentico CMS 6 and 7
Share this article on   LinkedIn