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Kentico CMS 5.5 Personal Site Guide

1.1

Personal Site Guide

Overview

Kentico CMS Personal Site allows you to easily run your own personal website. It comes with several
design templates and you can easily change the graphics.

The Personal Site is built with Kentico CMS and it comes with following features out-of-the box:
e Content editing

e Blogs

e Forums

e Photo Galleries

You can also use other Kentico CMS modules (such as newsletter, polls or forms) as you need.

To learn about other features and capabilities of Kentico CMS, please refer to other Kentico
documentation, such as Kentico CMS Tutorial (http://www.kentico.com/devnet/documentation.aspx).

You can contact our technical support at http://www.kentico.com/Support.aspx.
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2.1

Getting Started

Editing content

In this chapter, you will learn how to change the About text on your website.

1. Go to CMS Desk -> Content -> Personal Site -> About me.

232 Kentico

“1%  CMS Desk Content | My desk
} Copy T up

New Delete = Move & pown

Content management

(=4} Personal Site
(2] My Blog
|| About Me
|| Forums
[+ ] Photo Gallery
(1.5 Special pages
#-%5) Images

Tools

(A

Edit

Page

[ s

L|E Style

§ = 5ource | [& §

Switch to Site Manager  Site: | Personal Site[] User: Global Administrator v5.0 3688

Administration

4 @ B | P

Preview Live site List Search
View mode Other
Design  Form  Properties
= Spell check
| & (68 25 |E i 1 U % < =] &
mEO -0 &SiE 3 olwl B
- | Famat ~ | Font | Giza Ty dy [&

Sign out

L ©

@

S T S DS, SN L0 LS SILE FIANAYEE. § 1S Ui Suil SUooui 1S G0

About Me Photo Gallery

f Vhat can you find on my web . |
|site? There isn't much stuffon |
it so far, still working on ft.

What you might be interested

in is my blog from a trip

iin near future.
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2. Make sure you are on the Page tab and click into the Main text text box. Erase the text from the
text box and enter This is the new About me text. Then click Save at the top-left.

Page Design Form Properties

Spell check

£ El souee | [& £ |Gt @4 EH fiB 7 U a|x <} =E=i@ 0 F
e =-0Q &SR 0lw 8
[ Stle - | Format - | Font - | Size - Ty~ M- [,
. Left column text .

What can you find on my web & |
Jsite? There isn't much stuff on |
|it so far, still working on it.

J(What you might be interested |
in is rry blog from a trip |
'faround Europe that we took d

[with my friend PJ this summer.
[Hope to upload more photos
fin near future.

: 5 K:;g'/

My latest blog posts This is the new About me text.

6/15/2008 | Friendly Slovenia

After a while, we're getting
farther away from the coast.
From Trieste, the old ldy gave
us a ride. She realzed soon that
she liked us so much that we
had to meet her famity. And you
can't say NO to an old lady who
gives you a ride. Meeting her ) s
famity was great. We werent T TTTTTTTIITIIITITImI I
apparently the first hitchhikers

invited into this family in its

history. Therefore, everybody
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3. Now switch to the Preview viewing mode. You can see that the About me text has been updated.

What can you find on my web
site? There isn't much stuff on it
so far, stil working on it. What you
might be interested in is my blog
from a trip around Europe that we
took with my friend P this
summer. Hope to upload more
photos in near future.

My latest blog posts

6/4/2008 | Along the coast of
Dragon to Montpellier

France, eventually. For a while,
it seemed like we wouldnt be
able to make it. We spent more
than three hours waiting for a
ride at the Spanish — French

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator | My details | Sign out

My Blog About Me Photo Gallery

About Me

—

This is the new About me text.
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2.2 Adding a blog post

In this chapter, you will learn how to add a new post to your blog.

1. Go to CMS Desk -> Content -> Personal Site -> My Blog and click New in the document action

toolbar.
_\!,_ Kentico Switch to Site Manager ~ Site:|Personal Site[+| User: Global Administrator v5.0.2633
#1%  CMS Desk Content  Mydesk  Tools  Administration
1 e u
% Bcow  duw (4 & [@ E »
New Delete |=bMove & Down Edit  Preview Livesite  List Search
Content management View mode Gther
(=4 ) Personal Site Page | Design  Form  Properties
-] [My Blog -
-.[] About Me E Save ET‘-E Spell check
|| Forums : z A B
(-] Photo Gallery Souree | [& |&i |[#h LB FiB 1 U o 2 &
(-G Special pages al kgl M1 [ == = AR

(1) &) Images £ Syle - Fomat

~ | Font ~ | Size < Ty dm-: )[R

Sign out

©F ©

Tags

airport  Austria bus cuisine

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator | My details | Sign out

About Me Photo Gallery

Saying goodbye Europe

Czech Republic France Germany

hitchhiking hostel
Ttaly luggage sacher torte
slovenia Spain  subway
tourism  traffic  train

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. T have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in

Europe.

2. Choose Blog post as a hew document type.

=32 Kentico

“1% CMS Desk Content My desk
3 5l Copy i up
® -

New Delete |=kMove & Down

Content management

.;|-{£_"_1 Personal Site
-E]/My Blog
_, About Me
-] Forums
[©-] Photo Gallery
_,fj_,' Special pages
_|fjj Images

Tools Administration

4 [d [ EH

Edit Preview Live site List

)3
Search

View mode Other

r My Blog

| New document

Please select new document type:

[E) Blog month
" Blog post

%] Link an existing document
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3. Next, enter information for your new blog post.

e Post title: My new blog post

e Post Summary: Summary of the blog post.

e Post text: The entire text of the blog post.
Then click Save at the top.

+ My Blog

F- Save and create another Spell check

[Esouce Al 4 BB BE S (MG EFIB 7 Uw|x <

MO =0 &S SiEH B 0w B

4 Style ~ | Format ~ | Fant ~| Size - Tﬂ' %‘
Post title: My new blog post
Post date: 2M16/2010 10:02:43 @Nﬂ

Summary of the blog post.

Post summary:

»

m

The entire text of the blog post.

Post text:

»

m
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Your new blog post has been added to My Blog.

Sign in ko CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password.

Current user: Global Administrator| My details | Sign out

Photo Gallery

My new blog post
airport  Austria bus cuisine ~
Czech Republic France Germany

hitChhikillg hostel Summary of the blog post.
Italy luggage sacher torte

Slovenia 5Spain  subway
tourism  traffic  train Posted: 2/16/2010 10:02:43 AM by Global Administrator | with 0 comments

Tags

a Recent posts Saying goodbye Europe

U
» Saying goodbye Europe
» Wir sind Berliners
¥ Disappointment in Prague Paris, our final destination. Because there's no upcoming hitchhiking
¥ Sweetness of loneliness trip, the tension between PJ and me is all gone. I have a friend here,
b Garhar barke and fuckrian IS < the lact ninht we cnand in hic nlara drinkina wina and scinn hic
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Adding a photo gallery
In this chapter, you will learn how to add the new photo gallery and upload some photos.

1. Go to CMS Desk -> Content -> Personal Site -> Photo Gallery and click New in the document
action toolbar.

2. Choose Image gallery as a new document type.

| New document

Please select new document type:

|| Page (menu item)

= Article

] Blog

5 Cell phone

[ Event

I& Event (booking system)
g FAQ

=k

& Falder

& 1ob opening

&» Knowledge base article

& Laptop

@ Office

& oA

(3 Press release
59 Product

Simple article

%] Link an existing document
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3. Enter New gallery into the Name text box and click Browse ... . Choose some Teaser image. Then

click Save at the top.

+ Photo Gallery

E Save F Save and create another == Spell check
£ [ Soues | [, § | & B E IR 1 U ose|x i S = &
MO =09 & S0l8 ol
A Style - | Format - | Font - | Size < Ti' %' [,
Name: MNew gallery
Description:
Actions Update Name Size
Teaserimage: .
7R & [ testimage png 6 kB
Publish from: @Now
Publish to: B now

4. Now, go to Properties -> Template and click Select to choose template to use.
Site\Personal Site - Photo Gallery. Click Save at the top.

Page Design Form

General

Properties

E Save
URLs

Template

Metadata Template

Categaries Personal Site - Photo Gallery
Menu —

Workflow -'4_?: Save 3s new template..
Versions ﬂ Inherit template

Related docs —

i :}J Clone template as ad-hoc
Security [ f Edittemplate properties
Attachments

Inherit content

@ Use page template settings
© Do notinherit any content
() Selectinherited levels

Select

Choose Personal
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5. Your new gallery is ready. All you have to do is to add some pictures into your new created gallery.
Make sure New gallery is selected in the content tree and click New in the document action toolbar.
Choose File as the new document type.

;' New document

Please select new document type:

[ ] Page (menu item)

il

#] Link an existing document

6. Click the Upload file (\#) icon and choose a picture to upload.

» Photo Gallery » Mew gallery

E Save E‘ Save and create anather

Z| Spell check

Upload file: 4 Upload file

File description:

Then enter The description of the first picture. into the File description text box and click Save at the
top.

» Photo Gallery » Mew gallery

E Save E‘ Save and create another

(]

pell check

Actions Update Name Size
Lipload file: -
7R %) [=] Penquins.ipg 760 kB
The description of the first picture -

File description:
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Congratulations, you've just learned how to create a new gallery and add some pictures into it.

Current user: Global Administrator| My detsils | Sign out

is the first of all pleasures.” - Qscar

My Blog About Me Forums Photo Gallery
About my photos List of galleries
Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload

, . ) more pictures in near future.
I'm far from being a professional

photographer. Therefore, if you're

looking for mesmerizing pictures, I European Trip
advise you to search somewhere
else. Set of pictures, we've taken on our hitchhiking trip around

Europe with my friend PJ. Additional pictures are to come.

Sweet Home Arizona

Nothing compares to smell of desert after moonson rain.
Nothing compares to sound of coyote howling at the Moon.
MNothing compares to view of blossoming saguaro.

MNothing compares to Arizona.

New gallery

302 A
-,:: Kentico

Please note that you can take advantage of the File Import module to upload more images and files.
The File Import module can be found at CMS Desk -> Tools -> File import.

© 2010 Kentico Software
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2.4 Adding aforum

In this chapter you will learn how to create a new forum, create new thread and post a message.

1. Go to CMS Desk -> Tools -> Forums and click Edit next to the My Forums group.

212 Kentico

#g% CMS Desk Content My desk | Tools Administration

=) Tools

|@ Abuse report
BizForms

Blogs

n} Booking system
Ba Content staging Actions Group name
-fiill Custom tables & & MyForums

- T E-commerce
I File import

.- 8d[Forums

- Groups

198 Media libraries
...[] Message boards
‘:}] Newsletters

&l Forum groups

&4 New forum aroup

“..faf) Web analytics

2. In the Forum group properties, click Add forum

3# Add forum

Switch to Site Manager

© 2010 Kentico Software
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3. Add the following information for the new forum:

e Forum display name: New forum
e Forum code name: newForum
e Description: The description of the new forum.

Then click OK.

&a Forum group properties

Forum groups *» My Forums
Forums General Wiew

Forums » Mew forum

Forum display name:

Forum code name:

Description:

Forum base URL:

Forum unsubscription URL:
Require e-mail addresses:
Display e-mail addresses:
Enable WYSIWYG editor:

Use security code (CAPTCHA):
Forum is open:

Forum is locked:

Forum is moderated:

New forum
newForum

The description of the new forum. -

Inherit from forum group
Inherit from forum group

[Z Einnerit from forum group

[T [l inherit from forum group

[Z Einnerit from forum group

[T [l inherit from forum group

O

]

17
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4. The forum has been added as you can see in the following screenshot.

Current user: Global Administrator| My details | Sign out

is the first of all pleasures.

Forums

My Blog

Forums

Photo Gallery

Welcome to my forums. You ca use these forums to discuss different topics. If you want to add new post or reply to a post you have to be

signed in. You can use the sign in link in the top right corner.

Search forums:
Forum Threads Posts Last post
My Forums
Hew forum
T2, The description of the new forum. 0 0 (1/1/0001 12:00:00 AM)
;/
Lock
Goodbye party )
Goodbye pa ) . Abi
Lock (512812008 3:57:25 PM)
— Where to go in Europe
=) 1 5 Kate
g (5/22/2008 8:16:15 PM)

Lock

© 2010 Kentico Software
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3.1

Adjusting Design

Changing the theme

The sample Personal Site comes with several predefined CSS stylesheets. In this chapter, you will learn
which stylesheets are available and how you can choose the CSS stylesheet you want to use on your
website.

To choose the CSS stylesheet for your website, go to CMS Site Manager -> Sites and click Edit site
next to the Personal Site.

232 Kentico
#4%  CMS Site Manager Sites | Administration

6_} Sites

E:IJ Mew site wizard [E. Import site or objects [3 Export objects

Settings

Actions Site name -

@X W@ B M@ &3 Personal site

In the Site Properties, choose your CSS stylesheet from the Site CSS stylesheet drop-down list.

&) Site properties

Sites » Personal Site

General Domain aliases Cultures

Site display name: Personal Site

Site code name: PersonalSite

Site domain name: localhost

Default content culture: | English - United States

Default visitor culture: | (Automatic) |Z|

Site CSS stylesheet

EditorCsS stylesheet Personaisite |+ | ETSEN

Site description: Sample personal web site -
| OK |

© 2010 Kentico Software
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The following CSS stylesheets are available in the sample Personal Site:

Personal Site

Current user: Global Administrator | My details | Sign out

st of all p

My Blog About Me Forums Photo Gallery
Tags 8
My new blog post

airport  Austria bus cuisine e

Czech Republic France Germany

hitchhiking hostel Summary of the blog post.

Italy luggage sacher torte

Slovenia Spain  subway

tourism  traffic  train Posted: 2/15/2010 10:02:43 AM by Global Administrator | with 0 comments
D Recent posts Saying goodbye Europe

—
} Saying goodbye Europe

» Wir sind Berliners

¥ Disappointment in Prague Paris, our final destination. Because there's no upcoming hitchhiking
+ Sweetness of loneliness trip, the tension between PJ and me is all gone. I have a friend here,
» Sacher torte and Austrian so the last night we spend in his place, drinking wine and using his

capital computer to look at pictures we've taken during our month in
Europe.
Today, P] went to do some shopping and we've promised each
£ syndication other go out have dinner tonight.

© 2010 Kentico Software
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Personal Site - Blue

| Iy details

Personal starter site

Tags

} airport P Austria » bus » cuisine
} Czech Republic * France

} Germany b I'IitCI'II'IikiI'Ig

» hostel » italy » luggage » sacher
torte P Slovenia * Spain * subway
F tourism P traffic } train

i Recent posts

} Saying goodbye Europe

» Wir sind Betliners

¢ Disappointment in Prague
¥ Sweetness of loneliness

¥ Sacher torte and Austrian
capital

Syndication

My Blog | About Me | Forums | Photo Gallery

a 5saying goodbye Europe

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
50 the last night we spend in his place, drinking wine and using his
computer to look at pictures we’ve taken during our month in
Europe.

Today, P] went to do some shopping and we've promised each
other go out have dinner tonight.

Posted; 7/5/2008 1:56:04 PM by Abigail Woodwarth | with 3 comments

a Wir sind Berliners

2 Berlin, after a long time the city we both wanted to see. And as we're
“ A - almost done with our trip, we're getting much more relaxed in

© 2010 Kentico Software
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Personal Site - Green

| My details

&

l:l ¢ My Blog w2 About Me wr Forums wr Photo Gallery

Tags

Saying goodbye Europe
F airport ¥ Austria » bus * cuisine
¥ Czech Republic ¥ France

F Germany D l'litCh hiking

+ hostel » Italy ¥ luggage F sacher
torte P Slovenia * Spain b subway
F tourism * traffic # train

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between P1 and me is all gone. I have a friend here,
s0 the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, P] went to do some shopping and we've promised each
other go out have dinner tonight.

B Recent posts Posted: 7/5/2002 1:56:04 PM by Abigail Woodwarth | with 3 comments
F Saying goodbye Europe

+ Wir sind Berliners

+ Disappointment in Prague

+ Sweetness of loneliness

+ Sacher torte and Austrian

capital a Wir sind Berliners

E’ Svndicati Berlin, after a long time the city we both wanted to see. And as we're
yndication & ﬁ ™ almost done with our trip, we're getting much more relaxed in
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Personal Site - Red

| My details

Personal starter site

"liusion is the first of al pleasures." - Oscar Wilde,

About Me Forums Photo Gallery

Tags .

| Saying goodbye Europe
¥ airport * Austria * bus * cuisine =
¥ Czech Republic * France

»cermany * hitchhiking

rhostel » Italy * luggage F sacher
torte ¥ Slovenia * Spain b subway
F tourism F traffic ¥ train

Paris, our final destination. Because there’s no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

Today, PJ went to do some shopping and we've promised each
other go out have dinner tonight.

£ Recent posts Posted: 7/5{2008 1:56:04 PM by Abigail Woodwarth | with 3 comments
* Saying goodbye Europe

» ¥Wir sind Berliners

k Disappointment in Prague

» Sweetness of loneliness

» sacher torte and Austrian =

capital k_,| Wir sind Berliners

- . . Berlin, after a long time the city we both wanted to see. And as we're
2 Syndication & & - almost done with our trip, we're getting much more relaxed in
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3.2 Editing CSS stylesheets

In this chapter, you will learn how to change the design of your website by modifying the CSS
stylesheets.

Changing the header picture

1. Go to CMS Site Manager -> Development -> CSS stylesheets, click Edit next to Personal Site
and choose Main styles -> Master page section in the text box on the left side.

:!;- Kentico Switch to CMS Desk ~ User: Global Administrator v5.0.3688 Sign out
#§%  CMS Site Manager Sites Administration Settings Development Licenses Support
(=) Development ()’ CS$ stylesheet properties
L Categories
4 Countries CSS shleshests » Personal Site
‘.qf CSS stylesheets —
: @ Cultures eners =
-£} custom tables Save fE?l Check out
. [l Document types =
-[3) E-mail templates
: 9 Check outthe styleshestto file ¢ MSC r ite.css to edit the externally.
<% Form controls
+[E] Inline controls
B Modules The changes were saved.

i-Ji.] Notifications
:.[H page layouts
Page templates

Stylesheet display name: Personal Site
Stylesheet code name:  PersonalSite

B 5 » | Abuse report
=8 Relationship names .zoneTopMenu Blogs P
(il system tables 1 Buttons
:..&J Tag groups height: 43px; Content rating
: @Tlme TS width: 795px;_ . =1 Forums
8 - background: #£ff url(../App Themes/PersonalSite/Images/bg_topmenu.gi Attachments
UI cultures H padding: Opx; Global
Web part containers margin: Opx: Boxes
:..g# Web parts ¥ hngnn p‘ags
: ain styles
:-[@] web templates . ' Lg‘t menu
i .DesignMode .zoneTopMenu
; [2] widgets : Master page
L.l Workflows Stylesheet text height: 120px; Membership top zone
i . heigh 20p=, Search box
Top menu
Modal popup
.zoneBottom My profile
¢ - Photogallery
height: 57px; Search page
width: 795px; Tags

padding-top: 15px;
text-align: center;
background: #e2e2e2 url(../App Themes/PersonalSite/Images/bg_footte:

] i r

2. Inthe .zoneTop style, change the url of the background image to ../App_Themes/
PersonalSiteGreen/Images/bg_head.jpg so that the entire style reads as follows:

.zoneTop

hei ght: 239px;

wi dt h: 795px;

background-col or: #fff;

paddi ng: Opx Opx 7pX;

mar gi n: Opx Opx Opx;

background: #fff url(../App_Thenes/ Personal SiteG een/| mges/bg_head. | pg)
no-repeat top left;

Then click Save at the top-left.

Y

H

© 2010 Kentico Software



Kentico CMS 5.5 Personal Site Guide

3. Now click Sign out at the top-right. You can see that the header image has been changed.

| My details

[ ] ' Search | My Blog About Me Forums Photo Gallery

J My new blog post
] Recent posts

» My new blog post

» Saying ik Europe Summary of the blog post.
+ Wir sind Berliners

} Disappointment in Prague

} Sweetness of loneliness Posted: 2f16/2010 10:02:43 AM by Global Administrator | with 0 comments

£J syndication

F RSS J Saying goodbye Europe

Paris, our final destination. Because there's no upcoming hitchhiking
trip, the tension between PJ and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to look at pictures we've taken during our month in
Europe.

("7 Post archive

¥ February 2010(1)
» July 2008(3)
¥ June 2008(7)

Today, P went to do some shopping and we've promised each
other go out have dinner tonight.
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Changing the top menu

1. Go to CMS Site Manager -> Development -> CSS stylesheets and choose Main styles/Master

page section in the text box on the left side.

2. Scroll down to see .zoneTopMenu style.

=32 Kentico
#3% CMS Site Manager

=)~ Development
- Categories
0 Countries
Q‘ C5S stylesheets
@ cultures
[l custom tables
l:,]‘ Document types
- Q E-mail templates
- ~3_’} Form controls
-[E] Inline contrals
Modules
[ Notifications
-[B Page layouts
Page templates
=8 relationship names
ﬂ System tables
% Tag groups
@A Time zones
3 Ul cultures
Web part containers
- ¢# Web parts
-[@] Web templates
widgets
) Workflows

3. Change the background color to #BOC4DE and erase the URL part so that the entire section reads

as follows:

Sites Adrniniistration

Settings

Development Licenses

(j CSS stylesheet properties

B85 stylesheets » Personal Site

General

[ 22

Check outthe stylesheetto file

Sites.

ﬂf_ij Check out

Stylesheet display name: Personal Site

Stylesheet code name:

/*#Nain styles/Master pageff®/

PersonalSite

mainbiv

{

width: 796px;
margin: 35px suto;
padding: Opx 7px Opx

Suppark

HenticoCMS_0225'CMSC!

Switch to CMS Desk

ite.css 10 edit the styl

27

User: Global Administrator v5.0. 2656

Tpx:

background-color: #££f;

Stylesheet text:

.zoneTopMenu

hei ght :
wi dt h:

background: #BOCADE;

43px;
795pXx;

paddi ng: Opx;

mar gi n:

0px;

i

height: 239px;
width: 795px;

background-color: #££f;
background: HEff url(../ipp Thewes/PersonalSite/Images/by head.jpg)

.zoneTopHenbership

{

width: 795px:
height: 15px:
padding: 3px 0 3px 0;

I

This will change the background of the navigation at the top to dark blue.

t externally.

»

Abuse report
Blogs
Buttons
Caontent rating
Forums
Altachments
Global
Boves
Logon page
Main styles

Sign

Search hox

Tap menu
Modal popup
My profile
Photogallery
Search page
Tags
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4. Now, switch to the Top menu section and find .CMSListMenuLl a:hover style. This style modifies
the appearance of menu item when mouse is ower it.

(f CSS stylesheet properties

CS58 stylesheets » Personal Site

General Sites
E Save fE?' Check out
Check out the stylesheetto file ¢! ootiManuals\CMSCS S Sty \Personal Site.css to edit the stylesheet externally.

Stylesheet display name: |Personal Site

Stylesheet code name:  |PersonalSite

.CM5ListMenull a:hover, .CHSListMenuLinkHighlighted, .CMSListMenuLIlast a:hc .| Abusereport

i Blogs
color: #000; Buttons
background: url(../App Themes/PersconalSite/Images/bg_topmenu hover.c | |Contentrating
text—-decoration: none: Forums
= Attachments
Global
.UnigridActionButton Boxes
{ Logon page
margin-right: S5px: Main styles
' ) o ! Left menu

Master page

Stylesheet text: .RTL .UnigridActionButton g:;sﬁ?&lp top zone
¢
margin-right: auto; Modal popup
margin-left: 5px: My profile
Photogallery
Search page
/*3#Main styles/Left menu*/ Tags
JleftMenu .CMS5ListMenulLI, .leftMenu .CHMS5ListMenuHighlightedLI
i

background: none;
line-height: 18px:

4 T

5. Change color to #fff and replace the url part with #87CEFA. The entire style should read as follows:

. CMSLi st MenuLl a: hover, .CMSLi st MenuLi nkHi ghli ghted, .CMSListMenulLllast a:hover,
. CMSLi st MenuHi ghl i ght edLI | ast a, .CMSLi st MenuHi ghli ghtedLl a

{
color: #fff;
background: #87CEFA;
t ext-decorati on: none;
}

This will change the background of the menu item to light blue and its font color to white when mouse
hovers abowe it.
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[] Recent posts

* My new blog post

¥ Saying goodbye Europe

» Wir sind Berliners

» Disappointment in Prague
+ Sweetness of loneliness

£ Syndication
k RSS

(79 Post archive

» February 2010{1)
¥ July 2008(3)
¥ June 2008(7)

You've just learnt how modify CSS stylesheets to change design of your website.

| My details

es." - Oscar

My new blog post
J
Summary of the blog post.

Posted: 2/16/2010 10:02:43 AM by Global Administrator | with 0 comments

J Saying goodbye Europe

Paris, our final destination. B there's no up ing

trip, the tension between P1 and me is all gone. I have a friend here,
so the last night we spend in his place, drinking wine and using his
computer to lock at pictures we've taken during our month in
Europe.

Today, P] went to do some shopping and we've p ised each
other go out have dinner tonight.

29

© 2010 Kentico Software




Adding web Earts



Adding web parts

4.1

31

Adding web parts

Adding text

In this chapter, you will learn how to add the new editable text region into your website.

1. Go to CMS Desk -> Content -> About Me and switch to the Design tab. Click Add web partin

zoneRight.

Switch to Site Manager ~ Site:| Personal Site[+] User: Global Administrator v5.0.3688 Sign out
232 Kentico
#4%  CMS Desk Content | Mydesk  Tools  Administration
C u ] 1
0 G Ber #e | 3 o[g o
New Delete |=bMove & Down || Edit  Preview Livesite List | Search |
Content management | View mode || other |
——=L =
n:'/-{-_;) Personal Site Page | Design | Form  Properties Display web part content @
'] My Blog - . P ;
T Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. -
[ ]/About Me E
_] Forums

(#-[] Photo Gallery
(1)%3J Special pages
(-5 Images

Current user: Global Administrator| My detsils | Sign out

Bl plcasiiESE= Oscar Wilde.

= [About Me - page template: Personal Site - About Me
¥ zoneleft + + zoneRight

> LeftText @ ~ TitleRegion @

|About Me

What can vou find on mv weh
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2. Select Text/EditableText web part.

M
#| Select web part -- Webpage Dialog ﬁ

B selectweb part

Q Recently used web parts Web part name:
=-%5) All web parts
-.i5) Abuse report
-5 Articles =
..75) Attachments if
) BizForms dal
-.i5) Blogs
-5 Booking system
] '{_L-j‘ Community
) Community services
%) Content rating
-.i5) Custom tables
-.i5) Data sources
-.74) E-commerce
) Events
-.i5) Forums
-5 Full-text search
.35 General
) Google services
) Listings and viewers
i) Media
-5 Media library
) Membership
i) Message board
-.i5) Messaging
-5 Navigation
-.15) News
) Newsletters
) Notifications
-5 Polls
-5 Reporting
) Silverlight
'i(j‘ Tagaging & categories
-5 [Text

-8 User contributions .
= Editable text
-] Web services

) widgets The Editable text web part displays an editable region that enabled content editors to edit page content.

|:|l
I
Hi
il

Editable image Editable text Paged text Static HTML Static text

http://localhost/Manuals/CMS5Modules/PortalEngine/Ul/Webparts/WebPartSelector.aspx € Local intranet | Protected Mode: Off

3. In the Web part properties dialog, enter the following information for the new web part.
e Editable region title: AboutWebPageTitle
e Content before: <hl>
e Content after: </h1>

Then click OK.

4. Click Add web part again and select the same Text/EditableText web part.

5. In the Web part properties dialog, enter AboutWebPageText into the Editable region title textbox.
Then click OK.

6. Now you have the new web parts ready and you can enter some new text. Switch to the Page tab
and click into the AboutWebPageTitle editable region. Enter About my web page. Click Save at the
top.
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7. Click into the AboutWebPage editable region and enter This is a short text about my web page.
Click Save again.

E Save Spell check

Elsowce|[Qf BBRBEIGiv | GIE FIB I U % 1 2|8
imME@O=0 S SiE 8 olw 8
|F Style ~ | Format ~ | Font v | Size ~E Ty Iy &,

gives you a ride. Meeting her

family was great. We weren't
apparently the first hitchhikers | 1
invited into this family in is N
history. Therefore, everybody

knew what to do. We had a s o m s oo oooooooooo .
great lunch and only because | AboutWebPageTitle ]
our busy schedule we had to |About my web page -

rafiicad tn cnand 2 ninht thara

EAhmll:WehPageTﬂ(t |
ETth i5 @ short text about my web page al
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That is how you add a new editable region into your website.

Current user: Global Administrator| My details | Sign out

I oo e

What can you find on my web About Me
site? There isn't much stuff on it y o
so far, stil working on it. What you

might be interested in is my blog

from a trip around Europe that we -
took with my friend PJ this

summer. Hope to upload more - -. About my web page

photos in near future. i A This is a short text about my web page

This is the new About me text.

My latest blog posts

6/11/2008 | Traffic in Trieste

They say Trieste is one charming
city. We barely had a time to
notice it, though, because we
were really busy taking care of
not being run over by the
insane Italian drivers.
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4.2 Adding a poll

In this chapter, you will learn how to create a new poll and add it to your web page.

1. First of all we need to create a new poll. Go to CMS Desk -> Tools -> Polls and click New poll.

22 Kentico

#4% CMS Desk Content My desk Tools Administration
(=) Tools & rolis
H =
‘@ Abuse report
BizForms &3 New pol
-1l Blogs

Pﬂl Booking system
9@ Content staging
-fiill Custom tables
- PR E-commerce

- [[q File import

&4 Forums

& Groups

Il Media libraries
Message boards
- [E Newsletters

- @ Palls

[S_l Reporting

“..fal) Web analytics

Mo data found.

2. Enter the following information for the new poll.

e Display name: My poll
e Code name: MyPoll
e Question: How do you like my pictures?

Then click OK.

3. Now we need to defined some questions for your new poll. In the poll properties, switch to Answers

tab and click New answer EH-' Mew answer |ntg the Text text box, enter | love them! and click OK.

@ Poll properties
Palls » My pall

General Answers Security Sites View
Answers » MNew answer
(7
o MNew answer

Text: || love them!

[ OK
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4. Click New answer again and enter Not bad. as Text. The Enabled check box should be checked.

Then click OK.

5. Click New answer again and enter Waste of time! into the text box provided. Click OK.

6. Now we are ready to add your new poll to website. Go to CMS Desk -> Content -> Personal Site ->
Photo Gallery and switch to the Design tab. Click Add web part in zoneLeft.

22 Kentico
L

Switch to Site Manager ~ Site: | Personal Site[w] User: Global Administrator v5.0.3688 Sign out

» .
| Search ‘ @

=

CMS Desk Content  Mydesk  Tools  Administration
c u = i
= Boowy  Hw 4  [d
New Delete |= Move & pown ‘ Edit Preview Live site List
Content management | View mods Il other |
=€) Personal Site Page | Design | Form  Properties

(15 My Blog

-] About Me

ES I_] Forums
(&)-|1/Photo Gallery
|ﬂ 5] Special pages
-5 Images

Display web part content @

Sign in to CMS Desk. Sign in to CMS Site Manager. The default account is administrator with blank password. -

Current user: Global Administrator| My details | Sign out

= [Photo Gallery - page template: Personal Site - List of galleries

¥ zoneleft (+

* zoneRight

v LeftText {8

About my photos

¥ HeaderText @

List of galleries
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7. In the Select web part dialog, select Polls\Poll web part.

#| Select web part -- Webpage Dialog

B selectweb part

ﬂ Recently used web parts
=-%5) All web parts
Abuse report
Articles
Attachments
BizForms
Blogs
Booking system
Community
Community services
Content rating
Custom tables
Data sources
E-commerce

Web part name:

Poll

Events

Forums

Full-text search
General

Google services
Listings and viewers
Media

Media library
Membership
Message board
Messaging
Navigation

News
Newsletters
Notifications

Polls

Reporting
Silverlight
Tagaging & categories
Text

User contributions
Web services
Widgets

Poll

The Poll web part allows you to insert your own Poll on the page.

GLLLBELEELLLLBLELEBLLLLBLLEBELELLLLD

ok | Cancel |

http://localhost/Manuals/CMS5Modules/PortalEngine/Ul/Webparts/WebPartSelector.aspx

€ Local intranet | Protected Mode: Off
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8. In the Web part properties dialog, make sure My poll is selected as Poll name and click OK.

Congratulations, you've just learned how to add a new poll to your website.

Current user: Global Administrator| My details | Sign out

About my photos List of galleries

Alright, let’s be clear on this. In these galleries, you can find pictures I took in past few months. I'm planning to upload
more pictures in near future.
I'm far from being a professional

photographer. Therefore, if you're
looking for mesmerizing pictures, European Trip
advise you to search somewhere :
else.

Set of pictures, we've taken on our hitchhiking trip around

How d ik — Europe with my friend P1. Additional pictures are to come.
ow do you like my pictures?

1 love them!
© Mot bad.
© Waste of time!

Sweet Home Arizona

MNothing compares to smell of desert after moonson rain.
Mothing compares to sound of coyote howling at the Moon.
MNothing compares to view of blossoming saguaro.

MNothing compares to Arizona.

New gallery
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Further reading

This guide has provided you only with a short introduction to some of the aspects of the Kentico CMS.
For more detailed information about Kentico CMS please consult the following resources:

e Kentico CMS Tutorial
e Kentico CMS Developer's Guide

e Kentico DevNet at http://www.kentico.com/DeviNet.aspx

Should you need any further assistance, please do not hesitate to contact us at http://www.kentico.

com/Support.aspx.

© 2010 Kentico Software
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